回路図とPCBの間においてのデザイン変更の管理

概略

この記事では、Constraint Managerの使用から、プロジェクトオプションの設定、ECOの生成、クロスプローブとクロスセレクトによる変更の確認や対象箇所への移動まで、Altium Designerで設計制約を管理し、回路図とPCBを同期する方法を順に解説します。制約を定義する場所、設定の保存と転送の仕組み、回路図からPCBへ設計を反映する際に比較・更新する内容を制御する方法を説明します。設計変更のたびに設計データの整合性を保ち、より明確で確実なワークフローを実現したい方は、ぜひ読み進めてください。このガイドで、手順を一つずつ確認できます。

- プロジェクトでConstraint ManagerとPCB Rule and Constraints Editorのどちらを使用しているかを確認する方法と、関連設定にアクセスする場所を学びます。
- プロジェクトオプション、比較設定、ECOの生成が、回路図からPCBに反映される変更内容にどのように影響するかを理解します。
- クロスプローブとクロスセレクトを使って、各エディターで対応するオブジェクトを確認し、設計更新時の作業効率を高める方法を紹介します。
AIでさらに深掘り:

Constraint Managerを使用した設計要件の定義

設計制約は、PCB設計で従うべき一連の指示を構成します。クリアランス、配線幅、トポロジーなど、設計のあらゆる側面を網羅します。PCB設計で使用する設計制約の表示、作成、管理には、Constraint Managerを使用します。Constraint Managerは、設計制約を定義するための統一された表形式のスプレッドシートに似た編集インターフェースを提供し、回路図とPCBの両方からアクセスできます。この強力かつ効率的なアプローチにより、組織内で役割の異なるエンジニア間の連携が促進され、より幅広い関係者が共同で設計に必要な制約を定義できるようになります。

Do I have the Constraint Manager?

Altium Designerでは、設計制約を定義するために、Constraint ManagerとPCB Rule and Constraints Editorダイアログという2つの異なるアプローチが用意されています。

PCB設計プロジェクトでConstraint Managerを使用できるのは、プロジェクト作成時にプロジェクトの作成ダイアログでConstraint Managementオプションが有効になっていた場合のみです。次の点に注意してください。

  • PCBプロジェクトでConstraint Managerが有効になっていた場合、PCBエディターではPCB Rule and Constraints Editorダイアログをnot使用できません。

  • PCBプロジェクトでConstraint Managerがnot有効になっていなかった場合、設計制約の定義には従来のアプローチ(設計ディレクティブとPCB Rule and Constraints Editorダイアログの使用)のみを使用できます。

現在のPCBプロジェクトで設計制約の定義にどちらのアプローチが使用されているかを簡単に確認するには、プロジェクトの回路図またはPCBドキュメントを開いた状態で、回路図エディターまたはPCBエディターのメインメニューにDesign » Constraint Managerコマンドがあるかどうかを確認します。このコマンドがある場合、そのプロジェクトではConstraint Managerが使用されています。ない場合は、PCB Rule and Constraints Editorダイアログ(PCBエディターのDesign » Rules)が使用されています。

Constraint Managerには、回路図エディターまたはPCBエディターのメインメニューからDesign » Constraint Managerコマンドを選択してアクセスできます。Constraint Managerには、さまざまな種類の制約を定義するための複数のビューがあります。Constraint Managerの上部にあるボタンを使用して、次のビューを切り替えます。

  • Clearances – ネットクラス間の電気的クリアランスを定義できるクリアランスマトリックス。

  • Physical – ネット、差動ペア、xNet、およびそれらのクラスの一覧。導体の幅や差動ペアの間隔など、設計の物理的制約を定義できます。

  • Electrical – ネット、xNet、xSignal、およびそれらのクラスの一覧。トポロジーやインピーダンスなど、設計の電気的制約を定義できます。

PCBエディターからConstraint Managerにアクセスすると、追加のAll Rulesビューを使用できます。これは設計制約をルール中心に表示するビューで、PCB設計内のすべてのルールが一覧表示され、クエリに基づいてカスタムルールを作成できます。

変更を設計に反映するには、Constraint Managerで保存を実行する必要があります。これを行うには、Constraint ManagerのメインメニューからFile » Save(回路図からConstraint Managerにアクセスした場合)またはFile » Save to PCB(PCBからConstraint Managerにアクセスした場合)コマンドを使用するか、Ctrl+Sショートカットを使用します。

回路図側からアクセスしたConstraint Managerで定義した制約は、以下で説明する通常のECO(Engineering Change Order:設計変更指示)プロセス中にPCB設計へ転送されます。

詳細については、Constraint Managerを使用した設計要件の定義ページを参照してください。

PCBへの転送に向けたプロジェクトの設定

Project Optionsダイアログには、回路図設計とPCBレイアウト間で転送するデータを制御するさまざまな設定があります。このダイアログにアクセスするには、Projectsパネルでプロジェクトの項目を右クリックし、コンテキストメニューからProject Optionsコマンドを選択します。

設計を転送する際に同期する内容を設定するには、ダイアログの次のタブを使用します。

Javascript ID: Dlg_ProjectOptions

Class Generation – コンポーネントクラスとネットクラスの生成を設定および制御できます。たとえば、特定の回路図シートに配置されたコンポーネントをコンポーネントクラスにまとめたり、バスにまとめられたネットをネットクラスにまとめたりできます。また、このタブでは、配置された設計ディレクティブから派生するユーザー定義クラスの生成も設定できます。詳細については、回路図とPCBでのクラスの操作を参照してください。

Comparator – ドキュメントの比較時に検出する差異と無視する差異の種類、つまり比較対象となる回路図とPCBのデータを具体的に定義できます。比較の種類ごとにMode列を使用して、Find DifferencesやIgnore Differencesなどの比較モードを選択します。

ECO Generation – データ転送時に、どの設計変更(比較機能で検出された差異に基づく変更)に対して設計変更指示(ECO)を生成できるかを定義できます。変更の種類ごとにMode列を使用して、Generate Change OrdersやIgnore Differencesなどの生成モードを選択します。

詳細については、プロジェクトオプションへのアクセス、定義、管理ページを参照してください。

PCBへの設計情報の転送

設計の同期は、回路図エディターとPCBエディターの間で直接実行されます。PCBドキュメントをプロジェクトに追加し、ハードドライブに保存したら、回路図エディターのメインメニューからDesign » Update PCB Document <PCBDocumentName>コマンドを選択して、Engineering Change Orderダイアログを開きます。このダイアログには、現在のプロジェクトオプションに従ってPCBを回路図と一致させるために必要な変更(Engineering Change Order – ECO)の一覧が表示されます。

  • 必要に応じて、ダイアログ内の変更項目を有効または無効にできます。

  • Validate Changesボタンをクリックすると、ECOに含めるよう有効にした変更に対して検証チェックが実行されます。検証結果は、ダイアログのStatus 領域にあるCheck 列に表示されます。

    検証段階で失敗した変更項目がある場合、ダイアログの対応するMessage列に、その理由を示す情報(例:Footprint Not Found)が表示されます。ダイアログを閉じて、特定の変更が失敗する原因を調査し、必要に応じて設計を変更できます。
  • 実行する変更内容を確認し、問題がなければ、 Execute Changes ボタンをクリックしてECOを実行し、その中に含まれる有効な変更を適用します。実行結果は、ダイアログの Status 領域にある Done 列に表示されます。

 Execute Changes ボタンをクリックすると、変更がPCBドキュメントに適用され、Engineering Change Orderダイアログを閉じることができます。新規作成したPCBでは、回路図の設計に従って、コンポーネントのフットプリントが基板の外側に配置され、フットプリントのパッド間に接続線が表示されます。

設計を初めてPCBに転送した後も、回路図側で加えた変更は同じ手順でPCBに転送できます。

詳細については、 回路図とPCBの同期の維持 のページを参照してください。

クロスプローブ

クロスプローブは、現在のエディターでオブジェクトをクリックして、他のエディターでそのオブジェクトを見つける機能です。例えば、回路図エディターの Tools » Cross Probe コマンドを実行した後、回路図上のコンポーネントをクリックすると、PCB上の同じコンポーネントを表示できます。このコマンドは、コンポーネント、バス、ネット、ピン/パッド間のクロスプローブに対応しています。

デフォルトでは、操作元のエディターに留まります。 上の動画のように設計スペースを分割して2つのドキュメントを表示している場合など、操作元と対象の両方のドキュメントが表示されているときに、この動作を利用します。詳細については、ドキュメントウィンドウの管理を参照してください。

ドキュメントが1つだけ表示されている場合は、 Ctrl を押しながらオブジェクトをクリックすると、対象ドキュメント内の対応するオブジェクトにクロスプローブし、そのドキュメントをアクティブにできます。

クロス選択

クロス選択機能は、PCBドキュメントと回路図ドキュメントの間で、対応するオブジェクトを選択するために使用します。つまり、PCBドキュメントでオブジェクトを選択すると、元の回路図ドキュメントでも同じオブジェクトが選択されます。逆の場合も同様です。

クロス選択機能を有効にするには、回路図エディターまたはPCBエディターのメインメニューから Tools » Cross Select Mode コマンドを選択します。 このコマンドで機能のオン/オフを切り替えることができ、メニュー内のコマンドアイコンに現在の状態が表示されます。

この機能は、回路図で複数のコンポーネントを選択してPCBドキュメント上に新しいコンポーネントクラスをすばやく作成したり、回路図で選択した順序に従って複数のPCBコンポーネントを順次再配置したりする場合に特に便利です。
詳細については、 クロスプローブとクロス選択 のページを参照してください。
AI-LocalizedAI で翻訳
問題が見つかった場合、文字/画像を選択し、Ctrl + Enter キーを押してフィードバックをお送りください。
Contents
機能の提供状況

ご利用可能な機能は、お使いのAltiumソリューション(Altium Develop、Altium Agile Teams、Altium Agile Enterprise、または有効な契約期間中のAltium Designer)によって異なります。

実際にお使いのソフトウェアに文書化されている機能が表示されない場合は、詳細についてAltium Sales までお問い合わせください。

従来のドキュメント

Altium Designer のドキュメントは、バージョンごとに掲載されなくなりました。Altium Designer の旧バージョンのドキュメントは、Other Installers ページの Legacy Documentation の項目をご覧ください。

Contents