Releasing to a Workspace
W skrócie
- Określ, które zestawy danych źródłowych, produkcyjnych, montażowych, wariantowych i niestandardowych uwzględnić oraz jak przypisać wymagane zadania generowania plików wyjściowych.
- Poznaj opcje miejsca docelowego wydania, schematy nazewnictwa elementów obszaru roboczego oraz ustawienia rewizji docelowych.
- Prześledź etapy wydawania i dowiedz się, jak zautomatyzowane polecenia wydawania wpływają na przegląd, raportowanie i publikowanie w systemie PLM.
W widoku Release w Online Mode proces wydawania przebiega etapowo, a pozycje po lewej stronie widoku pozwalają szybko sprawdzić, na którym etapie aktualnie się znajdujesz:
-
Configure Server Release – na tym etapie procesu wydawania określasz typy danych, które chcesz wygenerować: dane źródłowe (generowane zawsze), dane produkcyjne oraz dane montażowe (dla projektu bazowego i każdego wykrytego wariantu).
-
Validate Project – ten kolejny etap procesu wydawania jest uruchamiany automatycznie po wykryciu co najmniej jednego raportu typu Validation w przypisanych plikach OutJob. Uruchamiane są wszystkie generatory wyników walidacji zdefiniowane w pliku Output Job przypisanym do wydawanego elementu danych.
-
Generate Data – ten kolejny etap procesu wydawania jest uruchamiany automatycznie. Uruchamiane są na nim wszystkie pozostałe generatory wyników zdefiniowane w plikach OutJob przypisanych do uwzględnionych elementów danych, aby wygenerować dane przeznaczone do wydania do odpowiednich elementów docelowych w przestrzeni roboczej.
-
Review Data – po pomyślnym przejściu wszystkich kontroli walidacyjnych i wygenerowaniu danych wyjściowych ten etap procesu wydawania umożliwia przejrzenie wygenerowanych danych.
-
Upload Data – po potwierdzeniu wydania na poprzednim etapie następuje automatyczne przejście do tego etapu. Przedstawia on postęp przesyłania danych do rewizji odpowiednich elementów danych w docelowej przestrzeni roboczej.
-
Execution Report – jest to końcowy etap procesu, zawierający podsumowanie wydania. Dostępne łącza nawigacyjne umożliwiają szybkie przejście do wygenerowanych rewizji elementów w panelu Explorer. Jeśli Project Releaser otwarto w ramach procesu wydawania i publikowania w systemie PLM, zostanie wyświetlony przycisk
. Kliknij go, aby kontynuować przepływ pracy tego procesu i opublikować dane w systemie PLM.
-
Publish to PLM – ten etap jest dostępny tylko podczas wydawania w ramach odpowiedniego aktywowanego procesu (obejmującego wydawanie, a następnie publikowanie w systemie PLM). Przejście do niego następuje automatycznie po kliknięciu przycisku
na poprzednim etapie (lub bezpośrednio, jeśli użyto polecenia Prepare & Release & Publish to PLM z menu powiązanego z przyciskiem Zostanie wyświetlone okno dialogowe Login Credentials. Wprowadź Username i Password dla swojej instancji PLM oraz wybierz szablon PLM, którego chcesz użyć (wyświetlany w postaci <PLMInstance>:<PublishingTemplate>).
Etap online 1 – konfiguracja wydania na serwer
Na tym etapie procesu wydawania określasz typy danych, które chcesz wygenerować. Wydawać można następujące elementy danych:
- Source Data – migawka projektu źródłowego.
- Fabrication Data – dane wymagane przez producenta PCB do wykonania nieobsadzonej płytki.
- Assembly Data for the Base Design (no variations) – dane wymagane przez zakład montażowy do pełnego obsadzenia nieobsadzonej płytki zgodnie z zestawieniem materiałowym, dla projektu bazowego bez wariantów.
-
Assembly Data for Design
Variant n– dane wymagane przez zakład montażowy do obsadzenia nieobsadzonej płytki zgodnie z zestawieniem materiałowym, dlaVariant nprojektu bazowego.
Liczba zestawów danych montażowych będzie odpowiadać projektowi bazowemu (bez wariantów) oraz wszystkim wykrytym wariantom zdefiniowanym dla tego projektu.

Etap 1 procesu wydawania projektu – konfigurowanie zawartości wydania (danych do wygenerowania).
Element Source Data jest zawsze uwzględniany w wydaniu. Pozostałe elementy danych można uwzględnić opcjonalnie.
Przypisywanie plików Output Job
Aby elementy Fabrication Data i Assembly Data zostały uwzględnione w wydaniu, należy przypisać do nich co najmniej jeden plik Output Job. Jeśli masz pliki Output Job, których nazwy zaczynają się od ciągów „fab” i „ass”, zostaną one automatycznie przypisane odpowiednio do sekcji Fabrication Data i Assembly Data przy pierwszym otwarciu widoku Release. W przeciwnym razie konieczne będzie ręczne przypisanie odpowiednich plików OutJob w każdym przypadku. Można to zrobić na karcie Release Options w oknie dialogowym Project Release Options (aby je otworzyć, kliknij przycisk
w lewym dolnym rogu widoku).

Przypisz pliki OutJob do odpowiednich zestawów danych zgodnie z potrzebami.
Zmiana miejsca docelowego wydania
Karta Release Options w oknie dialogowym Project Release Options umożliwia również zmianę miejsca docelowego wydania — przełączanie między zarządzanym (Online) a niezarządzanym (Offline) trybem pracy. Dostępne są trzy opcje:
-
Unmanaged - Folder(Offline): wybierz tę opcję, aby wydać wygenerowane dane do folderu lokalnego. Ścieżkę folderu głównego określa się na karcie Output Path okna dialogowego. Domyślnie jest ona ustawiona na[OutputPath](z użyciem ścieżki zdefiniowanej w polu Output Path na karcie Options w oknie dialogowym Project Options). -
Unmanaged - Zip(Offline): wybierz tę opcję, aby wydać wygenerowane dane do folderu lokalnego. Dane zostaną spakowane do pojedynczego pliku ZIP. Ścieżkę i nazwę pliku ZIP określa się na karcie Output Path okna dialogowego. Domyślnie jest ona ustawiona na[OutputPath][ProjectName].zip(z użyciem ścieżki zdefiniowanej w polu Output Path na karcie Options w oknie dialogowym Project Options). -
Managed - <WorkspaceName>(Online): wybierz tę opcję, aby wydać dane do przestrzeni roboczej (zWorkspaceName), z którą masz obecnie aktywne połączenie.

Zmień miejsce docelowe publikacji — do którego mają zostać wysłane wygenerowane dane — w opcjach publikacji projektu.
Ustawianie schematów nazewnictwa elementów w przestrzeni roboczej
Podczas pierwszej publikacji projektu w docelowej przestrzeni roboczej możesz określić sposób nazywania docelowych elementów danych w tej przestrzeni (do których rewizji trafiają wygenerowane dane). Służy do tego karta Item Naming w oknie dialogowym Project Release Options, dostępnym po naciśnięciu przycisku
w lewym dolnym rogu widoku (lub po kliknięciu łącza Target Revision dla zestawu danych przeznaczonego do publikacji i wybraniu z menu kontekstowego polecenia Edit). Na tej karcie możesz:
- Określić nazwę projektu. Domyślnie pole to jest wypełniane bieżącą nazwą projektu.
-
Określić domyślne schematy nazewnictwa różnych elementów danych, które mogą zostać wygenerowane podczas publikacji. Kliknij pole w kolumnie Item ID, a następnie przycisk
po prawej stronie pola, aby otworzyć okno dialogowe Choose Item (odmianę panelu Explorer), które umożliwia wskazanie istniejącego elementu w aktualnie podłączonej przestrzeni roboczej.
Aby zmienić dowolny schemat nazewnictwa, kliknij przycisk Settings, aby otworzyć okno dialogowe Naming Template Settings.

Ustaw nazwę projektu i określ nazewnictwo generowanych elementów danych w docelowej przestrzeni roboczej. Tutaj pola są edytowalne, ponieważ projekt nie został jeszcze opublikowany.
W szablonie nazewnictwa obsługiwane są następujące formaty makr:
-
Parameter-based — obsługuje parametry ujęte w nawiasy kwadratowe (np.
[ProjectName],[VariantName],[ProjectParameter]). -
Numeric-based — obsługuje kwantyfikatory liczbowe ujęte w nawiasy klamrowe (np.
{0000},{9000}).
Sterowanie rewizją docelową
W widoku głównym kliknij łącze obok wpisu Target Revision, aby otworzyć menu poleceń przedstawione na poniższym obrazie:

Dostęp do opcji określania rewizji docelowej zestawu danych, który ma zostać wygenerowany podczas publikacji — najedź kursorem na obraz, aby je zobaczyć.
Dostępne polecenia zależą od tego, czy element został już po raz pierwszy opublikowany. Poniżej znajduje się lista wszystkich możliwych poleceń:
-
Auto <RevisionID> — ta opcja pozwala systemowi zarządzać rewizjami, dzięki czemu nie musisz tworzyć zaplanowanych rewizji tam, gdzie jeszcze nie istnieją.
RevisionIDwskazuje następną rewizję elementu na tym samym poziomie przypisanego schematu nazewnictwa rewizji (np. jeśli bieżąca rewizja toA.1, polecenie to wskaże jako docelową rewizjęA.2). -
Next <RevisionID> — ta opcja jest dostępna dopiero po pierwszej publikacji elementu. Użyj jej, aby szybko zwiększyć numer rewizji docelowej na kolejnym poziomie przypisanego schematu nazewnictwa rewizji.
RevisionIDwskazuje następną rewizję (np. jeśli bieżąca rewizja toA.1, polecenie to zmieni rewizję docelową naB.1). -
Custom — użyj tej opcji, aby wskazać konkretną rewizję elementu docelowego przez zdefiniowanie niestandardowego identyfikatora rewizji w oknie dialogowym Custom Revision ID. W zależności od używanego schematu nazewnictwa rewizji okno dialogowe może zawierać do trzech pól identyfikatorów poziomów. Pamiętaj, że identyfikator pierwszej zaplanowanej rewizji elementu można zmienić w dowolnym momencie po utworzeniu elementu i przed opublikowaniem danych w tej pierwszej rewizji (czyli gdy nadal znajduje się ona w stanie
Planned). - Browse — użyj tej opcji, aby wskazać istniejącą rewizję elementu docelowego, w której mają zostać opublikowane dane. W tym celu zostanie wyświetlone okno dialogowe Choose Target Item (odmiana panelu Explorer).
- Edit — użyj tej opcji, aby przejść do karty Item Naming okna dialogowego Project Release Options, na której możesz zmienić nazwę tworzonego elementu docelowego (i jego pierwszej rewizji).
- Navigate — użyj tej opcji, aby szybko przejść do elementu w panelu Explorer (jeśli został już opublikowany, a kolejna rewizja istnieje w stanie zaplanowanym).
Wpis u góry menu odzwierciedla aktualnie wybraną lub zdefiniowaną rewizję docelową.
Dostęp do szczegółów generowania danych
Kliknij element sterujący Details — po prawej stronie nagłówka zestawu danych — aby wyświetlić szczegóły dotyczące tego, co dokładnie zostanie wygenerowane przez ten zestaw danych. Zwiń ten rozszerzony widok, klikając element sterujący Hide Details. Z wyjątkiem zestawu Source Data generowane dane będą pochodzić z co najmniej jednego przypisanego pliku Output Job. Możesz szybko otworzyć źródłowy plik OutJob, klikając element sterujący Configure.

Otwórz widok szczegółowy zestawu danych, aby zobaczyć, jakie dane zostaną wygenerowane — najedź kursorem na obraz, aby je zobaczyć.
Dodatkowe ustawienia
Dodatkowe ustawienia dotyczące publikacji projektu można zdefiniować na stronie Data Management – Servers okna dialogowego Preferences:
-
Folder używany do tymczasowego przechowywania wygenerowanych plików przed przesłaniem ich do aktualnie podłączonej przestrzeni roboczej może znajdować się w lokalizacji ustawianej automatycznie (
\Users\<ProfileName>\AppData\Local\Temp\Releasesw przypadku domyślnej instalacji) lub w wybranej lokalizacji wskazanej ręcznie. - Włącz opcję Delete contents after exiting release mode, aby po zakończeniu procesu publikacji folder tymczasowy został opróżniony.
- Nazwę każdego wygenerowanego pliku wyjściowego można opcjonalnie poprzedzić identyfikatorem elementu i identyfikatorem rewizji (np.
[FAB-Kame_FMU-A.1] Validation.PDF). W tym celu włącz opcję Prepend revision HRID to file names.
Po skonfigurowaniu zgodnie z wymaganiami elementów danych, które mają zostać utworzone w ramach wydania, kliknij przycisk
w prawym dolnym rogu widoku, aby kontynuować.
W ramach przygotowania wykonywanych jest kilka kontroli poprzedzających wydanie, w tym:
- Sprawdzenie, czy projekt i wszystkie pliki zostały zapisane.
- Sprawdzenie, czy projekt i wszystkie odpowiednie pliki zostały zatwierdzone w systemie kontroli wersji (VCS), jeśli ma to zastosowanie.
- Sprawdzenie, czy każdemu włączonemu elementowi danych nadano nazwę.
- Sprawdzenie, czy użytkownik ma uprawnienia do utworzenia elementu docelowego (i jego rewizji).
- Utworzenie wymaganych elementów docelowych (i planowanych rewizji) w przestrzeni roboczej, jeśli jeszcze nie istnieją, oraz zapewnienie użycia kolejnej rewizji w przypadku elementów, które już istnieją.
Jeśli zostaną wykryte jakiekolwiek problemy, zostaną zaproponowane sposoby ich rozwiązania (takie jak zapisanie lokalnie zmodyfikowanych plików i zatwierdzenie ich w VCS).
Na tym etapie generowany jest element Source Data — migawka plików źródłowych projektu jest wydawana do docelowej rewizji elementu.
Etap online 2 — Walidacja projektu
Po pomyślnym zakończeniu etapu 1 ten kolejny etap procesu wydawania jest uruchamiany automatycznie, gdy w przypisanych plikach OutJob zostanie wykryty co najmniej jeden raport typu Validation. Uruchamiane są wszystkie generatory wyników walidacji zdefiniowane w pliku Output Job przypisanym do wydawanego elementu danych. Obejmuje to uruchomienie dowolnej z następujących kontroli:
- Differences Report — użycie komparatora do ustalenia, czy dokumenty źródłowe i dokumenty projektu PCB są prawidłowo zsynchronizowane.
- Electrical Rules Check — sprawdzenie poprawności elektrycznej i rysunkowej opracowanego projektu źródłowego.
- Design Rules Check — sprawdzenie poprawności dokumentu PCB pod kątem określonych ograniczeń projektowych na poziomie płytki.
-
BOM Checks — sprawdzenie potencjalnych naruszeń związanych z elementami projektu lub wybranymi częściami w źródłowym dokumencie BOM (
*.BomDoc), jeśli jest dostępny. - Footprint Comparison Report — porównanie footprintów na płytce z ich biblioteką źródłową w celu upewnienia się, że są aktualne i zgodne.
- Component State Checking — sprawdzenie, czy występują komponenty znajdujące się w stanach objętych ograniczeniami. W ramach konfiguracji określasz działanie podejmowane dla każdego aktualnie zdefiniowanego stanu w każdej aktualnie zdefiniowanej definicji cyklu życia w docelowej przestrzeni roboczej: brak działania, ostrzeżenie lub wygenerowanie błędu. Ta ostatnia opcja uniemożliwi wydanie projektu. Ponadto uruchomienie kontroli spowoduje wygenerowanie przydatnego raportu HTML, który pozwala szybko sprawdzić, które komponenty projektu znajdują się w niedozwolonych stanach.
- Environment Configuration Compliance Check — sprawdzenie, czy używane są wyłącznie elementy danych dozwolone przez konfigurację środowiska dostępną dla przypisanej Ci roli (jeśli ma to zastosowanie). Ta kontrola może również zapewnić, że wszystkie elementy projektu pochodzą z przestrzeni roboczej.
Jeśli walidacja zakończy się pomyślnie, pojawi się ikona
z tekstem Passed. W przeciwnym razie zostanie wyświetlona ikona
z tekstem Failed.
Etap online 3 — Generowanie danych
Po pomyślnym zakończeniu etapu 2 ten kolejny etap procesu wydawania jest uruchamiany automatycznie. Na tym etapie uruchamiane są wszystkie pozostałe generatory danych wyjściowych — zdefiniowane w plikach OutJob przypisanych do uwzględnionych elementów danych — w celu wygenerowania danych, które zostaną wydane do odpowiednich elementów docelowych w przestrzeni roboczej.
Podobnie jak na pozostałych etapach, lecz wyraźniej na tym etapie ze względu na dłuższy czas jego trwania, postęp generowania jest przedstawiany za pomocą ikon:
— jeszcze nie uruchomiono / nie wygenerowano.
— trwa wykonywanie / generowanie.
— wygenerowano pomyślnie.
— generowanie nie powiodło się.
Etap online 4 — Przegląd danych
Po pomyślnym przejściu wszystkich kontroli walidacyjnych i wygenerowaniu danych wyjściowych ten etap procesu wydawania umożliwia przegląd wygenerowanych danych.

Przejrzyj wygenerowane dane i sprawdź, czy wszystko jest zgodne z oczekiwaniami, zanim zatwierdzisz wydanie i prześlesz dane do przestrzeni roboczej.
Domyślnie strona przedstawia wygenerowane dane w widoku uproszczonym (kompaktowym). Aby przełączyć się na bardziej szczegółowy widok, kliknij element sterujący Details powiązany z interesującą Cię sekcją.

Kliknij element sterujący Details, aby przełączyć widok wygenerowanych danych dla powiązanej sekcji z uproszczonego na szczegółowy. Aby powrócić do poprzedniego widoku, kliknij element sterujący Hide Details.
Stany generowania danych wyjściowych w widoku szczegółowym
Poniższa tabela zawiera możliwe stany danych wyjściowych podczas ich generowania i przeglądania w widoku szczegółowym:
Stan |
Opis |
|---|---|
|
Dane wyjściowe nie zostały jeszcze wygenerowane / nie istnieją. |
|
Dane wyjściowe zostały wygenerowane, ale od tego czasu w projekcie wprowadzono zmiany, przez co dane te nie są już aktualne. |
|
Trwa generowanie danych wyjściowych. |
|
Dane wyjściowe są wynikiem walidacji i został wygenerowany raport bez błędów. W przypadku raportu ERC nie ma żadnych błędów lub ich poziom mieści się w określonym dla tego raportu maksymalnym dopuszczalnym poziomie błędów. |
|
Dane wyjściowe (z wyjątkiem wyników walidacji) zostały pomyślnie wygenerowane. |
|
Nie udało się pomyślnie wygenerować danych wyjściowych. W przypadku wyników walidacji oznacza to, że w dokumentach źródłowych projektu występują błędy powodujące niepowodzenie określonych kontroli. W przypadku standardowych danych wyjściowych nie udało się ich pomyślnie wygenerować. Być może podczas walidacji poprzedzającej generowanie wystąpiły błędy krytyczne lub konfiguracja powiązanego generatora danych wyjściowych w pliku Output Job jest nieprawidłowa. |
W widoku kompaktowym wygenerowanych danych kliknij łącze View, aby otworzyć powiązany plik danych lub zestaw plików w odpowiednim edytorze w Altium Designer (np. w edytorze CAM w przypadku plików Gerber lub skompresowanych/nieskompresowanych plików ODB++) albo w odpowiedniej aplikacji zewnętrznej (np. Microsoft Excel w przypadku zestawienia materiałowego). W widoku szczegółowym kliknij dwukrotnie wpis, aby wyświetlić tylko ten plik.
Typowym testem gotowości do wydania, stosowanym przez wielu projektantów, jest porównanie plików Gerber wygenerowanych dla bieżącego wydania z plikami Gerber z poprzedniego wydania. Kliknij łącze Compare Gerber obok danych wyjściowych Gerber i wybierz poprzednie wydanie z menu rozwijanego, aby porównać przygotowane dane Gerber z danymi z wybranego wydania. W domyślnej przeglądarce otworzy się firmowy obszar roboczy i zostaną wyświetlone wyniki.

Dostęp do funkcji porównywania plików Gerber z poziomu Project Releaser, przed opublikowaniem danych w obszarze roboczym.
► Dowiedz się więcej o funkcji Gerber Comparison (obszar roboczy Altium 365, obszar roboczy Enterprise Server).
Jeśli po przejrzeniu danych okaże się, że konieczne są modyfikacje, kliknij przycisk
w prawym dolnym rogu widoku. Pojawi się okno dialogowe z prośbą o potwierdzenie i ostrzeżeniem, że wszystkie wygenerowane dane zostaną utracone — kliknięcie OK spowoduje anulowanie wydania i powrót do etapu 1 procesu.
Jeśli wszystkie wygenerowane dane są poprawne, kontynuuj wydawanie, klikając przycisk
(również w prawym dolnym rogu widoku). Pojawi się okno dialogowe Confirm Release z podsumowaniem konfiguracji projektu, które zostaną opublikowane w obszarze roboczym. Możesz tutaj również dodać Name (domyślny wpis to [ProjectName]), Description oraz wszelkie istotne uwagi do wydania.

Potwierdzenie zakresu wydania, obejmujące wygenerowane rewizje elementów, oraz możliwość zmiany nazwy/opisu i dodania uwag do wydania.
Etap 5 w trybie online — przesyłanie danych
Po potwierdzeniu wydania w poprzednim etapie następuje automatyczne przejście do tego etapu. Prezentuje on postęp przesyłania danych do rewizji odpowiednich elementów danych w obszarze roboczym.

Ten etap pokazuje postęp przesyłania wygenerowanych danych do powiązanych rewizji elementów w obszarze roboczym.
Etap 6 w trybie online — raport z wykonania
To ostatni etap procesu, zawierający podsumowanie wydania.

Raport końcowy dotyczący wydania.
Użyj łączy nawigacyjnych, aby szybko uzyskać dostęp do powiązanej rewizji elementu zawierającej opublikowane dane (dane produkcyjne, dane montażowe i wszelkie niestandardowe zestawy danych) w panelu Explorer — bramie do Twojego obszaru roboczego.

Wyświetlanie opublikowanych danych projektu bezpośrednio w obszarze roboczym za pomocą panelu Explorer.
Wyświetlanie opublikowanego projektu
W przypadku projektu w obszarze roboczym po zakończeniu wydawania dostępna jest dodatkowa funkcja. Kliknięcie łącza Project Page, ostatniego z łączy nawigacyjnych u góry strony Execution Report, otworzy panel Explorer, prezentujący projekt w Project View — funkcja ta jest dostępna wyłącznie dla projektów w obszarze roboczym.

Możesz dokładniej przeglądać projekt w obszarze roboczym w panelu Explorer dzięki Project View.
Obszar Releases (w lewym dolnym rogu widoku) zawiera zestawienie wydań powiązanych z projektem, obejmujące podsumowanie każdego wydania i wchodzących w jego skład pakietów. Kliknij przycisk
w tym obszarze, aby otworzyć okno dialogowe zbiorczej zmiany stanu, za pomocą którego można jednocześnie zmienić stan cyklu życia wielu elementów powiązanych z tym samym wydaniem w ramach jednego procesu wsadowego.
Dodatkowy dostęp do informacji o wydaniach projektu jest dostępny w przeglądarce internetowej docelowego obszaru roboczego, otwieranej przyciskiem
w panelu Explorer. W przeglądarce internetowej obszaru roboczego wszystkie wydania powiązane z projektem są dostępne w widoku Releases — lub w widoku Manufacture w przypadku obszaru roboczego udostępnianego przez serwer lokalny. Strona zawiera listę wszystkich wydań projektu, z najnowszym wpisem na górze. Poszczególne wydania można otworzyć w Manufacturing Portal obszaru roboczego za pomocą przycisku otwierania Widok Manufacturing Portal zawiera bardziej szczegółowe informacje o wybranym wydaniu, w tym pliki pakietów wchodzących w jego skład, pełny zestaw dokumentów projektowych oraz dane producentów i dostawców komponentów. Pamiętaj, że funkcja Send to Manufacturer jest dostępna wyłącznie w obszarze roboczym Altium 365. ► Więcej informacji znajdziesz na stronie Widok wydań w obszarze roboczym Altium 365.
To wszystko — po opublikowaniu projektu możesz po prostu zamknąć widok Release (przyciskiem
w prawym dolnym rogu widoku). A gdy w przyszłości zajdzie potrzeba ponownego wydania tego samego projektu, Project Releaser umożliwi szybkie i łatwe wykonanie tej czynności, automatycznie zwiększając numery docelowych rewizji elementów.
Publikowanie w instancji PLM
Related pages: Integracja z PLM (Altium 365 Workspace, Enterprise Server Workspace), Publikowanie w PLM
Możesz opublikować projekt w instancji PLM w ramach uruchamiania Project Releaser w Altium Designer. Operacja publikowania wykorzystuje szablon publikowania — zdefiniowany w konfiguracji integracji danej instancji PLM — do sterowania sposobem przekazywania danych do PLM. Funkcja ta jest dostępna za pośrednictwem odpowiednio skonfigurowanego procesu. W ramach instalacji dostarczana jest przykładowa definicja procesu — Project Releaser with Publish — której przepływ pracy umożliwia publikowanie w zintegrowanej instancji PLM jako dodatkowy etap działania narzędzia Project Releaser. Diagram przepływu pracy przedstawiono poniżej.

Diagram przepływu pracy domyślnej przykładowej definicji procesu Project Releaser with Publish
Po aktywacji proces publikowania w instancji PLM w ramach Project Releaser jest dostępny w Altium Designer z podmenu Project » Project Releaser aktywnego projektu lub z podmenu kontekstowego Project Releaser, dostępnego po kliknięciu prawym przyciskiem myszy pozycji projektu w panelu Projects.

Dostęp do procesu publikowania w instancji PLM w ramach Project Releaser
Pojawi się Project Releaser z dodatkowym etapem — 7. Publish to PLM. Ponadto w menu przycisku
dostępne jest polecenie Prepare & Release & Publish to PLM, pozwalające uruchomić Project Releaser bez zatrzymywania w celu przeglądu wygenerowanych danych i raportu z wykonania.

Dodatkowe polecenie umożliwiające uruchomienie Project Releaser bez zatrzymywania w celu przeglądu wygenerowanych danych i raportu z wykonania
Jeśli uruchomisz Project Releaser za pomocą standardowego polecenia Prepare, po przejrzeniu i wydaniu danych na etapie Execution Report pojawi się przycisk
. Kliknij go, aby kontynuować przepływ pracy procesu i opublikować dane w PLM. Pojawi się okno dialogowe Login Credentials. Wprowadź Username i Password dla swojej instancji PLM, a następnie wybierz szablon PLM, którego chcesz użyć (wyświetlany w postaci <PLMInstance>:<PublishingTemplate>).

Okno dialogowe Login Credentials wyświetlane podczas pierwszego publikowania w instancji PLM.
Kliknij kartę Diagram, aby zobaczyć przepływ pracy procesu.

Karta Diagram okna dialogowego Login Credentials
Kliknij przycisk
, aby kontynuować proces publikowania zgodnie z tym przepływem pracy.

).
