Navegação em um documento

Altium Training

Altium Essentials: Navigating Schematics

This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.

Ao trabalhar com um documento gráfico, como uma folha de esquemático, um documento de PCB ou um documento do Draftsman, você pode aplicar zoom e deslocar a visualização para focar em uma área específica do documento. Os atalhos básicos que podem ser usados para isso são:

  • Ctrl+Mouse Wheel para ampliar e reduzir
  • Right-Click, Hold&Drag para deslocar o documento

O menu principal View inclui vários comandos que podem ser usados para controlar a visualização do documento atual.

Use os comandos do menu principal View para controlar a visualização do documento. Na imagem superior, é mostrado o menu View do editor de esquemáticos. Na imagem inferior, é mostrado o menu View do editor de PCB.

Use os comandos do menu principal View para controlar a visualização do documento. Na imagem superior, é mostrado o menu View do editor de esquemáticos. Na imagem inferior, é mostrado o menu View do editor de PCB.

Esses comandos incluem:

  • Fit Document - exibir toda a área do documento atual.

  • Fit All Objects - exibir todos os objetos de projeto no documento atual.

  • Area - ampliar uma área do documento atual definida pelo usuário.

  • Around Point - redefinir a área de exibição em torno de um ponto especificado no documento atual.

  • Selected Objects - alterar a visualização no espaço de projeto de modo que todos os objetos selecionados fiquem visíveis.

  • Zoom In - aproximar o projeto em relação à posição do cursor no documento atual.

  • Zoom Out - afastar o projeto em relação à posição do cursor no documento atual.

  • Zoom Last - retornar à visualização anterior da tela no documento atual.

Você também pode usar o atalho Z para acessar o menu pop-up com comandos de zoom.

Nos editores de PCB e de footprints de PCB, esse menu permite acessar o comando Select, que abre a caixa de diálogo Zoom Value (0.001x..4x), na qual você pode alterar a ampliação da exibição do documento atual por um valor especificado. Valores maiores que 1 são inseridos para ampliar ainda mais (aumentar a ampliação). Valores menores que 1 são usados para reduzir ainda mais (diminuir a ampliação).

A caixa de diálogo Zoom Value
A caixa de diálogo Zoom Value

Ao visualizar um documento de PCB ou de footprint de PCB em 3D, comandos, atalhos e controles adicionais estão disponíveis para navegar pela visualização com fluidez. Consulte a página Controlando a visualização 3D para saber mais.

Ir para um ponto específico em um documento

Usando os comandos do submenu Edit » Jump dos menus principais do editor de esquemáticos, de símbolos esquemáticos, de PCB ou de footprints de PCB, você pode ir para um ponto específico no documento ativo. O menu pop-up Jump também pode ser acessado pressionando a tecla J no espaço de projeto. Por exemplo, você pode ir para:

  • a coordenada de origem do documento:
    • o ponto de origem de uma folha de esquemático (que corresponde ao canto inferior esquerdo) - Origin;

    • a origem absoluta do documento de PCB - Absolute Origin;

    • a origem relativa do documento de PCB atual - Current Origin;

    • a localização do ponto de referência do componente no documento de footprint de PCB - Reference;

  • qualquer localização no documento atual, com base nas coordenadas XY especificadas pelo usuário - selecione o comando New Location para inserir os valores das coordenadas X e Y no espaço de projeto para a localização à qual deseja mover o cursor, na caixa de diálogo Jump To Location que aparece. No editor de PCB, você também pode usar os campos Delta X e Delta Y para especificar os deslocamentos das coordenadas X e Y para a localização desejada.

    A caixa de diálogo Jump To Location - no editor de esquemáticos (primeira imagem) e no editor de PCB (segunda imagem)
    A caixa de diálogo Jump To Location - no editor de esquemáticos (primeira imagem) e no editor de PCB (segunda imagem)

  • um objeto no documento. Use os seguintes comandos para ir para um objeto de interesse:
    • um componente na folha de esquemático - Jump Component. Após executar o comando, a caixa de diálogo Component Designator será exibida. Insira o designador do componente para o qual deseja ir. Se o designador for válido e o componente existir em um documento esquemático de origem dentro do projeto ativo, o documento esquemático correspondente se tornará o documento ativo, e o componente de destino será ampliado e centralizado (quando possível) no espaço de projeto. O componente encontrado (ou todas as partes de um componente com várias partes) também será listado no painel Messages . Clique duas vezes em uma entrada de mensagem para ir para esse componente (ou uma de suas partes) no espaço de projeto.

      A caixa de diálogo Component Designator
      A caixa de diálogo Component Designator

      Ao buscar um componente com várias partes, insira apenas o designador raiz. Não inclua o sufixo da parte. Por exemplo, para ir para um componente de CI com duas partes, cujas partes são designadas como IC1_CPA e IC1_CPB, insira IC1_CP na caixa de diálogo Component Designator. Para um componente com várias partes, a primeira parte será destacada e a caixa de diálogo Find Text - Jump será aberta. Use essa caixa de diálogo para navegar entre as subpartes do componente.
      Habilite a opção Physical na caixa de diálogo Component Designator para restringir o recurso de navegação apenas aos designadores físicos de componentes - aqueles que aparecem nas visualizações em abas Compiled Document dos documentos esquemáticos de origem. Com essa opção desabilitada, o recurso de navegação considerará apenas os designadores lógicos - aqueles que aparecem nas visualizações em abas Editor dos documentos esquemáticos de origem.
    • um componente específico no documento de PCB - Component. Após executar o comando, a caixa de diálogo Component Designator será exibida. Digite o designador do componente para ir até ele. Se não tiver certeza do designador, digite ? e clique em OK para abrir a caixa de diálogo Components Placed, que lista todos os componentes do projeto. Insira texto no campo Mask para procurar o componente desejado. À medida que você digita, a lista é filtrada para mostrar apenas as strings que correspondem à string da máscara. Você pode usar os curingas ? (qualquer caractere único) e * (quaisquer caracteres) na string. O cursor irá para o ponto de referência do componente selecionado.

      Digite ? na caixa de diálogo Component Designator para acessar a caixa de diálogo Components Placed, que lista todos os componentes da PCB.
      Digite ? na caixa de diálogo Component Designator para acessar a caixa de diálogo Components Placed, que lista todos os componentes da PCB.

    • uma net específica no documento de PCB - Net. Após executar o comando, a caixa de diálogo Net Name será exibida. Digite o nome da net para a qual deseja ir ou digite ? e pressione OK para abrir a caixa de diálogo Nets Loaded, que contém uma lista de todas as nets carregadas para o projeto. Insira texto no campo Mask para procurar a net desejada. À medida que você digita, a lista é filtrada para mostrar apenas as strings que correspondem à string da máscara. Você pode usar os curingas ? (qualquer caractere único) e * (quaisquer caracteres) na string da máscara. Se a net de destino já estiver sendo exibida na janela principal de projeto, o cursor irá para o objeto de projeto mais próximo que pertença a essa net. Se a net estiver fora da área visível, o cursor será posicionado no objeto de projeto mais próximo que pertença a essa net, centralizado no espaço de projeto (quando possível).

      Digite ? na caixa de diálogo Net Name para acessar a caixa de diálogo Nets Loaded, que lista todas as nets da PCB.Digite ? na caixa de diálogo Net Name para acessar a caixa de diálogo Nets Loaded, que lista todas as nets da PCB.

    • um pad específico de um componente no documento PCB - Pad. Após executar o comando, a caixa de diálogo Jump To Pad Number será exibida. Insira o pad necessário do componente desejado no formato ComponentDesignator-PadDesignator (por exemplo, U1-6) e clique em OK. Se o pad de destino já estiver visível no espaço de projeto, o cursor simplesmente saltará para o centro desse pad. Se o pad estiver fora da área visível, o cursor será posicionado no centro do pad, centralizado no espaço de projeto (quando possível).

      A caixa de diálogo Jump To Pad Number
      A caixa de diálogo Jump To Pad Number

    • uma string específica no documento PCB - String. Após executar o comando, a caixa de diálogo Jump To String será exibida. Digite a string para a qual deseja saltar ou digite ? e clique em OK para abrir a caixa de diálogo Strings, que contém uma lista de todas as strings encontradas no documento da placa ativo (livres e pertencentes a outros objetos de grupo). Use essa caixa de diálogo para localizar rapidamente a string para a qual deseja saltar. Se a string de destino já estiver visível no espaço de projeto, o cursor simplesmente saltará para o ponto de ancoragem da string — o ponto pelo qual ela é segurada durante uma operação de movimentação ou em torno do qual é rotacionada. Se a string estiver fora da área visível, o cursor será posicionado no ponto de ancoragem da string, centralizado no espaço de projeto (quando possível).

      Digite ? na caixa de diálogo Jump To String para acessar a caixa de diálogo Strings, que lista todas as nets da PCB.
      Digite ? na caixa de diálogo Jump To String para acessar a caixa de diálogo Strings, que lista todas as nets da PCB.

      O sistema realizará três buscas: primeiro, por uma string que corresponda à string especificada em maiúsculas e minúsculas, caracteres e comprimento; depois, por uma string com os mesmos caracteres, mas que possa conter caracteres adicionais; e, por fim, por uma string com os mesmos caracteres, sem diferenciar maiúsculas de minúsculas.

    • saltar para todos os marcadores de erro no documento de projeto atual e percorrê-los - Error Marker. Após executar o comando, o cursor saltará para o primeiro marcador de erro da verificação de regras de projeto (DRC), centralizado na janela principal de projeto. O uso repetido do comando fará o cursor saltar para um segundo marcador de erro, e assim por diante. Esse comando saltará para um marcador de erro, independentemente de a violação ter sido dispensada ou não.

      Examine as violações associadas ao objeto sob o cursor clicando com o botão direito do mouse e escolhendo o comando correspondente no submenu Violations .

  • saltar para todos os objetos de projeto selecionados no documento atual e percorrê-los - Selection. Após executar o comando, o cursor saltará para o primeiro objeto selecionado, que será ampliado e centralizado na janela principal de projeto. O uso repetido do comando fará o cursor saltar para um segundo objeto selecionado, e assim por diante, percorrendo todos os objetos selecionados no documento atual. O comando percorre os objetos selecionados na ordem em que foram originalmente adicionados à seleção.

  • uma posição no documento esquemático ou PCB atual, cujas coordenadas tenham sido armazenadas anteriormente no marcador de localização indicado - selecione o comando Location Marks » n para saltar para a posição que foi armazenada no marcador de localização indicado usando o comando Set Location Marks » n.

    Em um documento esquemático, uma localização armazenada só está disponível enquanto o documento permanece aberto (ativo ou não). Se o documento for fechado e aberto novamente, o marcador de localização estará vazio. Em um documento PCB, os marcadores de localização são salvos com o projeto, de modo que as posições definidas pelo usuário neles contidas continuem acessíveis entre sessões de projeto.
AI-LocalizedLocalizado por IA
Caso encontre um problema, selecione o texto/imagem e primaCtrl + Enterpara nos enviar o seu feedback.
Nav
Contents
Disponibilidade de Recursos

Os recursos disponíveis para você dependem de qual solução Altium você possui – Altium Develop, Altium Agile Teams, Altium Agile Enterprise ou Altium Designer (com assinatura ativa).

Se você não vir um recurso documentado no software que está usando no momento, entre em contato com a equipe de vendas da Altium para saber mais.

Documentação Legada

A documentação do Altium Designer já não é versionada. Se precisar de aceder à documentação de versões anteriores do Altium Designer, visite a secção Documentação Legada da página de Outros Instaladores.