Compartilhando um projeto

Como a essência da colaboração é o trabalho conjunto de várias pessoas para alcançar um resultado comum, um fator essencial para colaborar é a capacidade de fornecer e gerenciar o acesso a esse elemento comum — neste caso, um projeto e seus dados associados. O Workspace oferece essa capacidade por meio do compartilhamento controlado por permissões de um projeto — em seu estado atual de trabalho em andamento (WIP) — ou como um instantâneo fixo do projeto naquele momento.

Observe que um projeto recém-criado, ou disponibilizado no Workspace, é compartilhado por padrão com:

  • O proprietário do projeto, que geralmente é o projetista que o criou (ou o disponibilizou no Workspace): com permissões de acesso total (leitura/gravação).

  • A função Administrators: com permissões de acesso total (leitura/gravação).

Os seguintes níveis de compartilhamento estão disponíveis no Altium Designer:

  • Sharing of a live design – o próprio projeto em andamento (WIP), que pode ser compartilhado:
    • Com outros membros da sua equipe do Workspace — para edição e/ou visualização. Um membro da equipe convidado pode visualizar o projeto pelo Altium Designer ou pelo Workspace da equipe. A edição é realizada somente pelo Altium Designer. O membro da equipe convidado deve estar registrado no AltiumLive e ter uma assinatura ativa da licença do Altium Designer.
    • Com pessoas de fora da sua equipe do Workspace — para visualização ou edição, por convite enviado por e-mail. Esse recurso está disponível somente quando você está conectado a um Workspace do Altium 365. Esse tipo de compartilhamento permite que as partes interessadas convidadas visualizem/editem (conforme aplicável) um projeto em andamento, atualizado em tempo real, sem obter acesso a todo o seu Workspace ou aos seus dados de projeto. A pessoa convidada deve estar registrada no AltiumLive e pode acessar o projeto compartilhado pelo seu Espaço pessoal do Altium 365 (ou pelo Workspace da sua organização, se disponível), ou abri-lo no Altium Designer.

    Se receber apenas acesso de visualização, a parte interessada convidada poderá visualizar e comentar o projeto no Altium Designer ou pela interface do seu Workspace do Altium 365. À medida que as pessoas com direitos de edição fazem alterações no projeto e as confirmam, essas alterações podem ser visualizadas em tempo real pelas pessoas externas. Para visualizar o projeto compartilhado pela interface do navegador, de qualquer lugar, basta se registrar no AltiumLive para obter acesso.

    Se a parte interessada convidada receber direitos de edição do projeto, poderá abri-lo e editá-lo no Altium Designer — ideal para prestadores de serviços externos.

    Observe que o compartilhamento de projetos WIP em tempo real com pessoas de fora da sua equipe do Workspace é possível quando você está conectado a um Workspace do Altium 365, mas não ao usar um Workspace do Enterprise Server. No entanto, você pode compartilhar um instantâneo do projeto para visualização e download com alguém de fora da sua equipe do Workspace (veja abaixo).

    O Altium Designer oferece recursos adicionais que complementam a colaboração no projeto por meio do compartilhamento de projetos do Workspace, incluindo Comentários em documentos e Prevenção de conflitos entre colaboradores.

    Quando estiver conectado a um Workspace do Altium 365 que tenha sido atualizado para o novo sistema de herança de permissões (saiba mais), observe que não é impossível reduzir ou remover permissões de um projeto se essas permissões forem herdadas da pasta pai. Ao tentar fazer isso, uma mensagem de erro será exibida (). A opção Inherit permissions from parent do projeto deve ser desativada na interface do Workspace no navegador para desvincular intencionalmente a herança de permissões da pasta pai.

  • Sharing of a design 'snapshot' – um instantâneo estático do projeto em um determinado momento, compartilhado:
    • Por link — disponível para qualquer pessoa por meio de um navegador. O acesso ao projeto compartilhado nesse nível não exige uma assinatura ativa da licença do Altium Designer nem registro no AltiumLive. O destinatário do link compartilhado abre o Visualizador independente do Altium 365 para visualizar o projeto (mas não comentá-lo). A visualização não exige registro no AltiumLive, e o link fica disponível por 48 horas.

    • Com pessoas específicas — disponível para pessoas específicas por convite enviado por e-mail. O acesso ao projeto compartilhado nesse nível exige registro no AltiumLive, mas não exige uma assinatura ativa da licença do Altium Designer. O destinatário acessa o instantâneo do projeto pelo Visualizador Web da interface do Workspace da plataforma Altium 365, a partir do convite por e-mail. A visualização exige registro no AltiumLive, mas o instantâneo fica disponível permanentemente. Também é possível comentar o projeto.

    Observe que um instantâneo do projeto compartilhado dessa forma é essencialmente somente leitura. Ele pode ser baixado ou visualizado em um Workspace do Altium 365, mas, ao contrário de um projeto WIP compartilhado, não pode ser aberto para visualização/edição no Altium Designer.

    Se o destinatário de um projeto (ou instantâneo do projeto) compartilhado com ele pela plataforma Altium 365 não tiver uma conta no AltiumLive, precisará primeiro criar uma — um link é fornecido na página Altium 365 Sign In.

Para projetos do Altium 365, é possível criar e gerenciar instâncias de revisão de projeto. Essas instâncias podem ser consultadas no Altium Designer — saiba mais.  

Acesso aos controles de compartilhamento

Os controles para compartilhar um projeto no Altium Designer estão disponíveis na caixa de diálogo Share — acessada das seguintes maneiras:

  • Para o projeto ativo — clicando no botão no canto superior direito da janela principal do aplicativo ou escolhendo o comando Project » Share nos menus principais.
  • Para o projeto selecionado no painel Projetos — clicando com o botão direito do mouse na entrada do projeto e escolhendo o comando Share no menu de contexto.
  • Ao comentar um documento de projeto, publicando um comentário que mencione um usuário que não tenha acesso ao projeto atual.

Se não houver um projeto ativo — ou seja, nenhum documento de projeto estiver aberto —, o botão atuará sobre o projeto selecionado no painel Projetos.

Acesso à caixa de diálogo Share — a central de comandos para compartilhar um projeto no Altium Designer.
Acesso à caixa de diálogo Share — a central de comandos para compartilhar um projeto no Altium Designer.

Compartilhamento de um projeto em tempo real

Com um projeto registrado (disponibilizado) em um Workspace do Altium 365, você pode compartilhar esse projeto com outras pessoas. Elas podem ser outros membros da equipe do seu Workspace ou pessoas de fora da equipe. Para compartilhar dessa maneira, clique para selecionar a opção , no lado esquerdo da caixa de diálogo Share.

Os administradores da equipe do Workspace sempre podem compartilhar um projeto com outras pessoas para edição ou visualização. Os membros da equipe do Workspace que não são administradores, ou os usuários de fora da equipe do Workspace com quem um projeto foi compartilhado, podem compartilhar um projeto com outras pessoas para edição ou visualização, dependendo do nível de acesso que eles próprios têm. Portanto, se tiverem direitos de edição, poderão compartilhar com outras pessoas para edição ou visualização. Se tiverem apenas direitos de visualização, só poderão compartilhar com outros usuários para visualização e comentários.

Acesso aos controles para compartilhar um projeto em tempo real/em andamento (WIP) com outras pessoas. Observe que a imagem mostra o caso de um projeto já disponível em um Workspace conectado.Acesso aos controles para compartilhar um projeto em tempo real/em andamento (WIP) com outras pessoas. Observe que a imagem mostra o caso de um projeto já disponível em um Workspace conectado.

Use o controle Copy Link para copiar um link direto para o projeto, que pode ser usado por quem já tem acesso a ele para abri-lo no Web Viewer do Workspace.

Compartilhamento com novas pessoas

Com a preparação concluída, um projeto selecionado e um Workspace de destino conectado, você pode prosseguir e especificar com quem o projeto será compartilhado. Para verificar quem já tem acesso ao projeto, clique no controle Shared with. A área será expandida para mostrar com quem o projeto está compartilhado e se essas pessoas têm direitos de edição (Can Edit) ou podem apenas visualizar e comentar no projeto (Can View).

Verifique com quem o projeto está compartilhado no momento clicando no campo Share with. Passe o cursor sobre a imagem para ver o resultado.
Verifique com quem o projeto está compartilhado no momento clicando no campo Share with. Passe o cursor sobre a imagem para ver o resultado.

Você pode compartilhar o projeto com qualquer pessoa: outros usuários do AltiumLive da sua própria organização, usuários do AltiumLive de outras organizações e pessoas que não usam o AltiumLive (que precisarão se cadastrar para obter uma conta no AltiumLive). Observe que, quando conectado a um Workspace do Enterprise Server, você só pode compartilhar o projeto WIP com usuários cadastrados nesse Workspace. Para compartilhar externamente, consulte Compartilhamento de um Snapshot do projeto ou a forma de compartilhamento disponível no seu Espaço Pessoal do Altium 365.

Para adicionar uma entrada, comece a digitar o nome/e-mail/função desejado no campo para selecionar o usuário ou a função correspondente na lista dinâmica, que conterá apenas os usuários filtrados da equipe do seu Workspace ou da sua organização e as funções existentes definidas para o Workspace. É possível selecionar vários usuários e funções. Para remover um usuário ou uma função inseridos, clique no controle associado à entrada.

Para compartilhar com uma pessoa de fora da sua organização, independentemente de ela ter ou não uma conta no AltiumLive, você deve inserir o endereço de e-mail completo dela e pressionar Enter.

Defina as permissões de acesso de compartilhamento para as pessoas/funções adicionadas no menu suspenso associado, selecionando Can View () ou Can Edit (), sendo que a última opção inclui, por padrão, a capacidade de visualização. Inicialmente, a configuração se aplica a todas as entradas (pessoas/funções) incluídas no campo. Use o campo de observação opcional para incluir informações relacionadas ao compartilhamento deste projeto.

Os administradores da equipe do Workspace sempre podem compartilhar um projeto com outras pessoas para edição ou visualização. Os membros da equipe do Workspace que não são administradores podem compartilhar um projeto com outras pessoas para edição ou visualização, dependendo do nível de acesso que eles próprios têm.

Somente os usuários com quem o projeto foi compartilhado e que tenham permissões de Edit podem compartilhá-lo novamente com outras pessoas. Todos os usuários com quem o projeto foi compartilhado e que tenham direitos de Edit podem baixar os arquivos de design do projeto. Permissões adicionais de compartilhamento estão disponíveis para os administradores e para o proprietário do projeto na caixa de diálogo Share. Use o Advanced Settings opções para especificar os direitos de recompartilhamento e download dos usuários com os quais o projeto será compartilhado.

As opções adicionais de compartilhamento e download estão agrupadas da seguinte forma:

  • Member Rights – para membros do Workspace:

    • Editors can share – permitir que membros do Workspace com direitos de Edit no projeto compartilhado o compartilhem novamente com outras pessoas.

    • Viewers can download – permitir que membros do Workspace com direitos de View no projeto compartilhado baixem os arquivos do projeto.

  • Guest and External Share Rights – para usuários convidados externos com os quais os projetos foram compartilhados:

    • Editors can share – permitir que pessoas que não são membros do Workspace e têm direitos de Edit no projeto compartilhado o compartilhem novamente com outras pessoas.

    • Viewers can download – permitir que pessoas que não são membros do Workspace e têm direitos de View no projeto compartilhado baixem os arquivos do projeto.

Para confirmar as alterações nas configurações avançadas, clique no botão  de volta à caixa de diálogo principal Share.

Com os destinatários definidos e os direitos de acesso especificados, clique no botão para prosseguir com o compartilhamento do projeto. A caixa de diálogo exibirá uma mensagem informando que o projeto foi compartilhado com sucesso. A partir daí, você pode clicar no controle Who has access para retornar à lista de usuários que têm acesso ao projeto, clicar no botão  para copiar o link direto para o projeto ou simplesmente fechar a caixa de diálogo clicando em OK.

Compartilhamento com alguém que não faz parte da equipe

Quando conectado a um Workspace do Enterprise Server, um projeto em andamento (WIP) não pode ser compartilhado com pessoas que não sejam usuários registrados desse Workspace (pessoas que não fazem parte da equipe). Para compartilhar externamente a partir de um Workspace do Enterprise Server, consulte Compartilhamento de um snapshot do projeto, ou a abordagem de compartilhamento por upload disponível no seu Espaço Pessoal do Altium 365.

Se você tentar compartilhar um projeto de um Workspace do Altium 365 com alguém de fora da equipe, a caixa de diálogo Confirm será exibida, avisando que o usuário terá acesso aos documentos-fonte do projeto compartilhado, aos comentários inseridos e aos pacotes de liberação. Clique em OK para prosseguir com o compartilhamento do projeto.

Você pode compartilhar um projeto com qualquer pessoa de fora da equipe do Workspace, para edição ou visualização.Você pode compartilhar um projeto com qualquer pessoa de fora da equipe do Workspace, para edição ou visualização.

Compartilhar com um usuário de fora da equipe do Workspace para edição é ideal para prestadores de serviços — quando você deseja que trabalhem ativamente no projeto, mas sem incluí-los na sua equipe.

Compartilhamento de um projeto local

Se você estiver compartilhando um projeto local (que não está sob um VCS externo), o projeto será disponibilizado no Workspace ao qual você estiver conectado no momento do compartilhamento com as pessoas indicadas. O que acontece de fato depende de você estar compartilhando para visualização ou edição:

  • Ao compartilhar apenas para visualização (e estando conectado a um Workspace do Altium 365) — o projeto é disponibilizado por meio do Simple Sync. Nesse modo, o projeto só pode ser editado por uma única pessoa (o proprietário do projeto). A vantagem do Simple Sync aparece quando você não quer que outras pessoas editem seu projeto, mas deseja aproveitar o paradigma de Global Sharing do Altium 365 e compartilhar esse projeto com várias outras pessoas para visualização e comentários. Para obter mais informações sobre essa funcionalidade, consulte Espelhamento de um projeto no Workspace usando o Simple Sync.
  • Ao compartilhar para edição — o projeto precisa ser adicionado ao repositório Git de projetos Versioned Storage do Workspace. Nesse modo, o projeto pode ser compartilhado com várias pessoas para edição, além de permitir o uso do suporte a Compartilhamento Global do Altium 365 para visualização e comentários compartilhados. Uma caixa de diálogo será exibida para informar isso e oferecer a opção Use Altium 365 VCS para fazê-lo. Clique em Learn More para acessar a página de compartilhamento, que ajudará a orientar você no compartilhamento do projeto.

Ao compartilhar um projeto local (que não está sob um VCS) com alguém para edição, será necessário colocar o projeto sob controle de versão, adicionando-o ao repositório Git de projetos Versioned Storage do Workspace.Ao compartilhar um projeto local (que não está sob um VCS) com alguém para edição, será necessário colocar o projeto sob controle de versão, adicionando-o ao repositório Git de projetos Versioned Storage do Workspace.

Se o projeto local já estiver sob controle de versão (em um repositório externo de projetos), ele permanecerá no repositório de projetos do VCS externo e não será adicionado ao repositório de projetos do VCS (Git) integrado ao Workspace. Nesse caso, Simple Sync (espelhamento) se aplica, mas, naturalmente, vários colaboradores podem continuar trabalhando no projeto e editando-o, pois ele está sob um VCS.

No entanto, só é possível aproveitar todas as funcionalidades oferecidas pela plataforma Altium 365 — ou, mais especificamente, por um Workspace do Altium 365 — se o projeto estiver totalmente armazenado no VCS nativo do Workspace (em seu repositório Git Versioned Storage). Você pode migrar seu projeto do sistema VCS externo para o sistema VCS nativo do Workspace usando o recurso de migração de repositórios VCS integrado ao Altium Designer.

► Para obter informações sobre isso, consulte Migração de um VCS externo para o VCS nativo do Workspace.

  • Quando conectado a um Workspace do Enterprise Server, um projeto local a ser compartilhado com outro usuário do Workspace é adicionado automaticamente ao VCS do Workspace. O projeto, agora pertencente ao Workspace, será compartilhado com o usuário especificado do Workspace com direitos de Visualização ou Edição, conforme selecionado na caixa de diálogo Share.
  • Observe que um Workspace do Enterprise Server não pode compartilhar um projeto em andamento (WIP) com alguém de fora da equipe do Workspace — ou seja, que não seja um usuário registrado do Workspace.

Resultado do compartilhamento

O que acontece em seguida depende do tipo de usuário convidado:

  • Um usuário que já faz parte da equipe do seu Workspace será adicionado diretamente à lista de acesso compartilhado do projeto e receberá um e-mail informando que o projeto foi compartilhado com ele. Esse usuário poderá abrir o projeto no Altium Designer ou acessá-lo pela interface do Workspace (na página Projects ).
  • Quando uma função existente do Workspace é adicionada, ela aparece na lista de acesso do projeto, e todos os membros dessa função recebem um e-mail informando que o projeto foi compartilhado com eles. Esses usuários podem abrir o projeto no Altium Designer ou acessá-lo pela interface do Workspace (na página Projects ).
  • Ao usar um Workspace do Altium 365 para compartilhar com alguém de fora da equipe do seu Workspace, essa pessoa será adicionada à lista de compartilhamento e receberá um e-mail informando que o projeto foi compartilhado com ela. Ela poderá abrir o projeto no Altium Designer pela opção Compartilhado comigo ou acessá-lo pela interface do Espaço Pessoal da plataforma Altium 365 (na página Shared with Me ). O e-mail recebido fornece acesso direto ao projeto por meio do Altium 365. Ao clicar no botão do e-mail, a pessoa será direcionada à página Altium 365 Sign In (a menos que já esteja conectada à plataforma ou à sua conta AltiumLive). Após fazer login, ela será direcionada diretamente ao Visualizador Web, com o projeto compartilhado carregado.

    Você não pode compartilhar um projeto em andamento (WIP) com pessoas de fora da equipe (usuários externos) quando estiver conectado a um Workspace do Enterprise Server. No entanto:

Se a pessoa não tiver uma conta AltiumLive, precisará criar uma primeiro — um link está disponível na página Altium 365 Sign In.

Acesso a um projeto compartilhado em tempo real a partir do convite por e-mail recebido pelo usuário que não é membro da equipe do Workspace.
Acesso a um projeto compartilhado em tempo real a partir do convite por e-mail recebido pelo usuário que não é membro da equipe do Workspace.

Modificar os direitos de acesso de pessoas existentes

A qualquer momento, um administrador (ou membro da equipe do Workspace com direitos de edição) pode modificar as permissões de acesso existentes para um projeto. Para acessar a lista de pessoas e funções com as quais um projeto já está compartilhado, clique na entrada à esquerda da caixa de diálogo Share e expanda o campo Shared with à direita.

Acesso à lista de pessoas e funções que atualmente têm acesso compartilhado ao projeto.Acesso à lista de pessoas e funções que atualmente têm acesso compartilhado ao projeto.

Pontos a observar:

  • Em termos de permissões, uma pessoa/função tem acesso completo de edição ao projeto quando a opção Can Edit () está selecionada. Caso contrário, tem acesso somente para visualização ().
  • O Owner e a função Administrators sempre têm acesso completo de edição (Can Edit).
  • Com exceção do Owner e da função Administrators, as permissões de todas as pessoas/funções incluídas podem ser definidas individualmente como Can View ou Can Edit, ou os direitos de acesso podem ser completamente removidos. Além disso, a propriedade do projeto pode ser transferida para outro usuário (veja abaixo). Clique no estado atual da permissão para acessar os controles.

  • Um projeto pode ser compartilhado explicitamente com pessoas e/ou funções específicas ou simplesmente com todos os membros da equipe do Workspace. Neste último caso, defina o acesso necessário para a entrada Workspace Members . Para não compartilhar o projeto com toda a equipe, defina essa entrada como None.

Faça as alterações necessárias nas permissões de acesso. Cada entidade alterada é destacada na lista com um fundo mais escuro.

Exemplo de alterações nas permissões de duas pessoas existentes com as quais um projeto está compartilhado atualmente.Exemplo de alterações nas permissões de duas pessoas existentes com as quais um projeto está compartilhado atualmente.

Para aplicar as alterações, clique no botão . As alterações serão aplicadas, e a confirmação será exibida na caixa de diálogo. Para ver a lista atualizada de acesso compartilhado, clique no link Who has access.

Depois de salvar as alterações nas permissões, você pode visualizar o resultado atualizado diretamente na caixa de diálogo Share.Depois de salvar as alterações nas permissões, você pode visualizar o resultado atualizado diretamente na caixa de diálogo Share.

  • Observe que o compartilhamento de um projeto com outro usuário pode ser revogado a qualquer momento, escolhendo a opção Remove para esse usuário na caixa de diálogo Share.
  • Observe também que, se você estiver alterando as permissões para Can Edit de alguém que não faz parte da equipe do Workspace do Altium 365, será solicitado — por meio da caixa de diálogo Sharing Outside of the Workspace — que confirme se deseja conceder direitos somente de visualização ou direitos de edição.

Transferir a propriedade do projeto

Administradores e proprietários podem transferir a propriedade para outro usuário usando a opção Owner  no menu suspenso do estado atual da permissão. A opção pode ser usada pelo proprietário atual do projeto ou por um administrador do Workspace.

A propriedade só pode ser transferida para outro membro do Workspace. A transferência para um usuário que não pertence ao Workspace não está disponível.

Ao selecionar a opção Owner para um usuário, a caixa de diálogo Transfer Ownership será aberta. Clique em Yes para processar.

As alterações nas permissões do proprietário atual e do novo proprietário serão exibidas na caixa de diálogo. Clique em Save para prosseguir com as alterações.

Com a transferência, os direitos de acesso do proprietário atual são atribuídos da seguinte forma:

  • Os direitos de edição são transferidos se o projeto estiver sob controle de versão.
  • Os direitos de visualização são transferidos se o projeto estiver sob SimpleSync.

O usuário para o qual a propriedade é transferida receberá uma notificação por e-mail.

Acessar um projeto compartilhado em tempo real

O acesso a um projeto compartilhado com um usuário depende de ele ser membro da equipe do Workspace ou não.

Membro da equipe do Workspace

Um membro da equipe do Workspace pode acessar o projeto compartilhado pelo Altium Designer ou pela página Projects da interface do Workspace. Observe que a edição do projeto — caso tenha direitos de edição — só é possível pelo Altium Designer.

No Altium Designer, acesse o projeto usando o comando File » Open Project ou o botão de reticências associado à entrada do Workspace no painel Projects. A caixa de diálogo Open Project será exibida, permitindo escolher qual projeto do Workspace conectado você deseja abrir — quando houver uma conexão com um Workspace, ele aparecerá na região Locations da caixa de diálogo, identificado pelo ícone e com o nome atribuído ao Workspace. Somente os projetos do Workspace que foram compartilhados com você (e que você tem permissão para acessar) serão listados.

Depois de aberto, o projeto aparecerá sob uma entrada do Workspace no painel Projects.

No Altium Designer, escolha qual projeto do Workspace conectado deseja abrir entre os que estão compartilhados com você. No Altium Designer, escolha qual projeto do Workspace conectado deseja abrir entre os que estão compartilhados com você.

Você pode abrir o projeto no caminho padrão de checkout ou usar o menu suspenso para especificar um caminho personalizado. O caminho padrão de checkout é obtido do campo Document Path na página System – Default Locations da caixa de diálogo Preferences.
Ao navegar pelo projeto no painel Explorer do Altium Designer — configurado no modo padrão Project View, em vez de Classic View — clique no botão , no canto superior direito do painel, para abrir o projeto no Altium Designer (adicionando-o ao painel Projects). Use o botão para abrir o projeto para visualização na interface do Workspace conectado no navegador.

Parte interessada convidada que não faz parte da equipe do Workspace

Uma pessoa que não faz parte da equipe do Workspace do Altium 365 e com a qual o projeto foi compartilhado pode acessar esse projeto pelo Altium Designer ou pela interface da plataforma Altium 365 (na página Compartilhado comigo). Para abrir o projeto, selecione o bloco do projeto e clique no nome dele ou escolha a opção Open no menu de reticências do bloco. Como alternativa, clique duas vezes diretamente no bloco. Observe que a edição do projeto — caso a pessoa tenha direitos de edição — só é possível pelo Altium Designer.

Um projeto em andamento (WIP) não pode ser compartilhado fora da equipe (com usuários externos) ao usar um Workspace do Enterprise Server.

No entanto, se você recebeu um projeto compartilhado por um membro de um Workspace do Altium 365, ele estará disponível no Altium Designer no local Shared with Me, conforme descrito abaixo, e também poderá ser visualizado no seu Espaço pessoal.

No Altium Designer, acesse o projeto usando o comando File » Open Project. A caixa de diálogo Abrir projeto será exibida, permitindo escolher qual projeto do Workspace abrir no local Shared With Me.

Depois de aberto, o projeto aparecerá sob a entrada Shared with me, no painel Projetos. O que você pode fazer com o projeto depende dos direitos de acesso concedidos a você. Se você recebeu direitos de edição, poderá editar o projeto normalmente, o que costuma ser o caso de um prestador de serviços externo. Como o projeto é compartilhado a partir de um Workspace, as alterações são sincronizadas em ambas as direções. Se seu acesso estiver restrito à visualização, você ainda poderá comentar no projeto em andamento.

No Altium Designer, escolha qual projeto do Workspace abrir entre aqueles atualmente compartilhados com você como colaborador externo. Observe que é possível acessar esses projetos sem ter acesso ao Workspace.No Altium Designer, escolha qual projeto do Workspace abrir entre aqueles atualmente compartilhados com você como colaborador externo. Observe que é possível acessar esses projetos sem ter acesso ao Workspace.

Você pode abrir o projeto no caminho padrão de checkout ou usar o menu suspenso para especificar um caminho personalizado. O caminho padrão de checkout é obtido do campo Document Path na página Sistema – Locais padrão da caixa de diálogo Preferences.

Compartilhamento de um snapshot do projeto

Criar um snapshot somente leitura de um projeto permite compartilhar esse projeto rapidamente, no estado em que se encontra naquele momento específico do desenvolvimento, para ampliar a colaboração com outras pessoas pela Web. Isso pode ser útil para uma revisão rápida do projeto, para compartilhar um marco específico do desenvolvimento ou até mesmo para estimular discussões contextualizadas. Para compartilhar dessa maneira, clique para selecionar a entrada , no lado esquerdo da caixa de diálogo Share.

Acesso aos controles para compartilhar um snapshot de um projeto.Acesso aos controles para compartilhar um snapshot de um projeto.

Qualquer usuário que esteja visualizando um projeto no Altium Designer pode compartilhar um snapshot desse projeto.

Compartilhamento por link

Por padrão, a caixa de diálogo está definida como Compartilhar por link, o que significa que qualquer pessoa que receber o link poderá visualizar o snapshot do projeto pelo navegador por um período limitado de 48 horas. Não é possível comentar no projeto com esse nível de compartilhamento.

Esse nível de compartilhamento não exige que você esteja conectado à sua conta Altium no Altium Designer.
Observe que os snapshots de projetos compartilhados por link podem ser indexados por mecanismos de busca e ficar disponíveis para seus usuários.

Clique no botão para gerar o link para o snapshot do projeto. Em segundo plano, o próprio projeto é empacotado em um arquivo ZIP usando o Empacotador de projetos do Altium Designer. Quando o link estiver pronto, clique no botão para copiá-lo e compartilhe-o com as pessoas desejadas, conforme necessário.

Geração do link com prazo de validade, que pode ser compartilhado com qualquer pessoa, em qualquer lugar.Geração do link com prazo de validade, que pode ser compartilhado com qualquer pessoa, em qualquer lugar.

Quando o destinatário abrir o link em um navegador, será direcionado a uma instância do Altium 365 Viewer, no site principal altium.com, com o projeto processado e carregado.

Usando o link compartilhado, o destinatário pode explorar o snapshot do projeto no Altium 365 Viewer, carregado no site principal altium.com. Aqui é mostrado um esquemático. Passe o cursor sobre a imagem para ver a PCB.Usando o link compartilhado, o destinatário pode explorar o snapshot do projeto no Altium 365 Viewer, carregado no site principal altium.com. Aqui é mostrado um esquemático. Passe o cursor sobre a imagem para ver a PCB.

Quando o projeto (no arquivo ZIP) é enviado ao Altium 365 Viewer, ele é removido assim que o processamento termina. Por isso, a visualização do projeto é limitada à duração da sessão do navegador e deixa de estar disponível se você fechar a aba do navegador. Como alternativa, use o link novamente a qualquer momento dentro do período permitido de 48 horas.

Compartilhamento com pessoas específicas

Clicar no controle Share with specific people altera o modo de compartilhamento do snapshot do projeto para permitir o compartilhamento com uma ou mais pessoas específicas, por meio de um convite por e-mail. Os destinatários poderão visualizar, compartilhar ou baixar o snapshot do projeto pela interface da plataforma Altium 365, acessada pelo navegador. Esse snapshot fica disponível permanentemente na plataforma, e esse nível de compartilhamento permite comentar no projeto.

Esse nível de compartilhamento exige que você esteja conectado à sua conta Altium no Altium Designer, usando as credenciais da sua conta AltiumLive. Se você não estiver conectado à sua conta Altium, a caixa de diálogo apresentará um link para entrar (acessando a caixa de diálogo Entrar) ou para se cadastrar no AltiumLive, caso ainda não tenha credenciais.

Altere o modo para poder compartilhar um snapshot do projeto com pessoas específicas de forma permanente.Altere o modo para poder compartilhar um snapshot do projeto com pessoas específicas de forma permanente.

Insira o endereço de e-mail completo da pessoa com quem deseja compartilhar o snapshot e pressione Enter. É possível especificar várias pessoas dessa maneira, conforme necessário. Você também pode adicionar uma observação opcional para informar qualquer detalhe relevante sobre o snapshot específico que está sendo compartilhado.

Exemplo de compartilhamento de um snapshot do projeto com uma pessoa específica por e-mail.Exemplo de compartilhamento de um snapshot do projeto com uma pessoa específica por e-mail.

Use as opções Advanced Settings da caixa de diálogo Share para especificar as permissões aplicadas ao snapshot compartilhado do projeto (). Selecione Allow sharing para permitir que a pessoa especificada compartilhe novamente o snapshot do projeto e a opção Allow downloading para permitir o download do snapshot (compactado em ZIP).

Quando estiver pronto, clique no botão . O próprio projeto é empacotado em um arquivo ZIP usando o Empacotador de projetos do Altium Designer e, em seguida, enviado à plataforma Altium 365. Uma confirmação de envio é fornecida quando o processo é concluído.

O snapshot compartilhado é empacotado e enviado à plataforma Altium 365, onde fica disponível permanentemente.O snapshot compartilhado é empacotado e enviado à plataforma Altium 365, onde fica disponível permanentemente.

A pessoa com quem você compartilhou o snapshot do projeto enviado receberá um convite por e-mail para acessá-lo pelo Altium 365. Ao clicar no botão do e-mail, ela será direcionada à página Altium 365 Sign In, a menos que já esteja conectada à plataforma ou à sua conta AltiumLive. Após entrar, ela será direcionada ao Visualizador Web, com o snapshot compartilhado do projeto carregado.

Se a pessoa não tiver uma conta AltiumLive, precisará criar uma primeiro. Um formulário de criação de conta é fornecido quando o link Altium 365 é aberto.

Acesso ao snapshot do projeto a partir do convite por e-mail recebido pelo usuário com quem o snapshot foi compartilhado.Acesso ao snapshot do projeto a partir do convite por e-mail recebido pelo usuário com quem o snapshot foi compartilhado.

Acesso a um snapshot compartilhado do projeto

Além de seguir o link no convite por e-mail, a pessoa com quem um snapshot permanente do projeto foi compartilhado poderá acessá-lo (abrir, compartilhar e visualizar) a qualquer momento pela Shared with Me página da  interface da plataforma Altium 365. Um snapshot do projeto é identificado pelo ícone em seu bloco.

Para abrir no visualizador integrado, selecione o bloco do design e clique no nome do projeto ou escolha a opção Open no menu de reticências do bloco. Como alternativa, clique duas vezes diretamente no bloco. Observe que um snapshot compartilhado de um design não pode ser editado e, portanto, não pode ser acessado pelo Altium Designer por meio do local Shared With Me na caixa de diálogo Abrir projeto — no entanto, ele pode ser baixado se tiver sido compartilhado com essa permissão habilitada.

Acessando um snapshot de design pela página Shared with Me  da interface da plataforma Altium 365. Neste exemplo, um comentário foi inserido no design compartilhado.Acessando um snapshot de design pela página Shared with Me da interface da plataforma Altium 365. Neste exemplo, um comentário foi inserido no design compartilhado.

A pessoa que compartilhou originalmente o snapshot do design — enviando-o permanentemente para a plataforma Altium 365 — também poderá acessá-lo pela página Files do seu Espaço pessoal.

Desativando o compartilhamento

Para desativar completamente o compartilhamento, desmarque a opção Altium Cloud na página Sistema – Atividade de rede da caixa de diálogo Preferences. Se você tentar compartilhar um design pela caixa de diálogo Share — ao vivo ou como snapshot —, uma caixa de diálogo de aviso será exibida, informando que essa opção foi desativada.

Desativar a conectividade com a nuvem Altium impedirá o compartilhamento de projetos de design.
Desativar a conectividade com a nuvem Altium impedirá o compartilhamento de projetos de design.

Suporte a revisões de design

A caixa de diálogo Share permite consultar uma lista das instâncias de revisão de design do projeto.

A funcionalidade de revisão de design permite criar e gerenciar instâncias de revisão estruturadas para seus projetos do Workspace do Altium 365.

Para saber mais, consulte a página Revisões de design.

Quando a entrada é selecionada no lado esquerdo da caixa de diálogo Share, o lado direito lista as revisões de design ativas do projeto (aquelas no estado In Progress) para as quais você foi definido como revisor. Cada instância de revisão de design é apresentada com os seguintes dados:

  • Nome da instância. Clique no link para abrir a instância na interface do Altium 365 no navegador.

  • Descrição.

  • Data e hora do commit/lançamento para o qual a instância de revisão de design foi criada.

  • Iniciador e data e hora de criação da instância.

Se o projeto não tiver instâncias no estado In Progress, o botão  ficará disponível no canto inferior direito da caixa de diálogo. Clique nele para fechar a caixa de diálogo e acessar a página Design Reviews do projeto na interface do Workspace no navegador. A janela Create Design Review será aberta, permitindo definir os revisores, a descrição e qual modelo de lista de verificação será usado.

AI-LocalizedLocalizado por IA
Caso encontre um problema, selecione o texto/imagem e primaCtrl + Enterpara nos enviar o seu feedback.
Nav
Contents
Disponibilidade de Recursos

Os recursos disponíveis para você dependem de qual solução Altium você possui – Altium Develop, Altium Agile Teams, Altium Agile Enterprise ou Altium Designer (com assinatura ativa).

Se você não vir um recurso documentado no software que está usando no momento, entre em contato com a equipe de vendas da Altium para saber mais.

Documentação Legada

A documentação do Altium Designer já não é versionada. Se precisar de aceder à documentação de versões anteriores do Altium Designer, visite a secção Documentação Legada da página de Outros Instaladores.

Contents