Painel Navigator
Altium Essentials: Navigating Schematics
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
Num relance
- Saiba como o painel Navigator permite explorar folhas individuais do esquemático, o projeto completo e a hierarquia do projeto para encontrar rapidamente objetos conectados.
- Veja como navegar nos dois sentidos, do painel para o esquemático e do esquemático de volta para o painel, incluindo as situações em que Alt + clique pode ajudar a localizar itens relacionados na PCB.
- Entenda como o destaque, o zoom, o esmaecimento e a validação afetam o que você vê durante a navegação, para acompanhar melhor as conexões em projetos complexos.
Se o projeto for grande e distribuído por muitas folhas, pode ser difícil acompanhar uma rede e verificar a conectividade do projeto apenas olhando os esquemas. Tentar localizar esses mesmos objetos na PCB representa um desafio ainda maior. Para ajudar nesse processo, utiliza-se o painel Navigator.

Use o painel Navigator para visualizar todo o projeto. Mantenha Alt pressionado ao clicar no painel para também localizar esse item na PCB.
O painel Navigator permite explorar o documento esquemático de origem ativo ou todos os documentos esquemáticos de origem do projeto ativo. O painel utiliza o modelo de conectividade do projeto, criado automaticamente em segundo plano, como base para a navegação. O painel também pode ser usado para navegar até componentes, pads, barramentos e redes na PCB.
Navegação pelo projeto
A navegação pode ser realizada de duas maneiras: clicando no painel Navigator para localizar o objeto no esquema ou clicando no objeto no esquema para localizá-lo no painel Navigator.
A partir do painel Navigator
Para exibir o painel Navigator, use o botão Panels no canto inferior direito do software ou selecione View » Panels » Navigator nos menus.
As informações de componentes e conectividade são carregadas no painel assim que um esquema é aberto. Clique em um ícone na seção Documents para exibi-las. O software cria automaticamente um Modelo de Dados Dinâmico para todo o projeto e mantém esse modelo atualizado à medida que as ações de edição são executadas. Observe que as abas dos documentos não são exibidas (na parte superior da área de edição gráfica) para todas as folhas esquemáticas (elas são abertas em segundo plano); uma aba só aparece quando o usuário realiza uma ação nessa folha.
O Modelo de Dados Dinâmico está disponível para cada um dos editores e também para o painel Navigator. Se, em algum momento, você não tiver certeza de que o conteúdo do painel corresponde ao estado atual do projeto, selecione o comando Validate Project para forçar uma atualização do modelo (no menu Project ou no menu de contexto acessado com o botão direito do mouse no painel Navigator).

Clique em um objeto no painel Navigator para localizar todas as instâncias desse objeto em todo o projeto.
Navegação interativa
Além de navegar pelas listas de objetos apresentadas no painel e clicar para localizar um objeto na área gráfica, você também pode navegar da área gráfica de volta para a lista. Esse recurso é chamado de navegação interativa. Para iniciar esse modo, clique no botão Interactive Navigation na parte superior do painel Navigator. O cursor muda para uma mira, indicando que você está no modo de navegação, no qual permanecerá até clicar com o botão direito do mouse ou pressionar a tecla Esc .
À medida que você navega pelo projeto, a exibição da folha é atualizada de acordo com as opções atuais de destaque, e o painel Navigator é atualizado para mostrar informações relacionadas à seleção atual na janela de edição gráfica.

Ative a navegação interativa (botão na parte superior do painel Navigator) e clique em um objeto na folha para localizá-lo no painel e no restante do projeto.
Atalho de navegação interativa
Além de iniciar a navegação interativa pelo painel Navigator, você pode ativar a navegação a qualquer momento no editor de esquemas: mantenha Alt pressionado ao clicar em um objeto do projeto. Você pode clicar em qualquer objeto, incluindo um fio, rótulo de rede, porta, entrada de folha, símbolo de folha ou componente.
Use o atalho Alt+Clique para navegar pelo projeto.
Como os objetos são destacados durante a navegação
Quando você clica em um objeto no painel Navigator, ele é exibido na área de edição gráfica. A forma como o objeto é apresentado depende das configurações de Sistema - Navegação na caixa de diálogo Preferences. Para acessar as configurações diretamente pelo painel Navigator, clique no botão Navigation Options na parte superior do painel para abrir a caixa de diálogo.
A região Highlight Methods da caixa de diálogo Preferences oferece opções para controlar o resultado visual da filtragem temporária aplicada ao documento durante a navegação, tanto pelo painel quanto no próprio documento. Qualquer combinação dessas opções pode ser habilitada. Por exemplo, você pode querer ampliar e selecionar todos os objetos filtrados na janela do editor de projeto enquanto esmaece os demais objetos para reduzir a poluição visual.
O painel Navigator
O painel Navigator oferece uma visão do modelo de conectividade do projeto. A estrutura do projeto é apresentada nas quatro seções do painel, descritas abaixo.
O painel Navigator apresenta uma visão de todo o projeto centrada na conectividade.
Seção Documentos
Localizada na parte superior do painel, a seção Documents oferece três maneiras diferentes de visualizar o projeto – o individual sheets, o flattened hierarchy (o projeto inteiro) ou a possibilidade de navegar pelo full design hierarchy. Clique uma vez em um ícone nesta primeira seção para carregar os dados no painel; clique duas vezes para também exibir os resultados na área de edição gráfica.
Recursos da seção Documentos
Seção Documentos |
|
| Individual Sheets | Exibe um ícone para cada uma das folhas de esquemático capturadas, identificadas pelo Clique uma vez para exibir os resultados no painel Navigator; clique duas vezes para também exibir os resultados na área de edição gráfica. |
| Flattened Hierarchy (projeto inteiro |
Exibe todos os objetos e a conectividade de todo o projeto. Se houver folhas repetidas (canais) no projeto, um ícone filho será exibido para cada classe de canal, identificado pelo nome do canal (derivado do Clique uma vez para exibir os resultados no painel Navigator; clique duas vezes para também exibir os resultados na área de edição gráfica. |
| Full Design Hierarchy | Exibe um ícone para cada folha lógica do projeto. Se houver folhas repetidas (canais) no projeto, haverá um ícone de folha para cada canal, identificado pelo Clique uma vez para exibir os resultados no painel Navigator; clique duas vezes para também exibir os resultados na área de edição gráfica. Se você clicar duas vezes no ícone de um canal repetido, além de exibir a folha desse canal, a aba do canal específico será selecionada na parte inferior da área de edição do esquemático. |
Seção Componentes
A segunda região do painel contém todos os componentes existentes no documento atualmente selecionado na primeira seção. Ao selecionar uma entrada de instância de componente de nível superior na lista, um filtro será aplicado com base nessa entrada, e seu resultado visual será determinado pelos métodos de realce escolhidos. Se as opções de realce habilitadas incluírem a opção Connective Graph, todos os outros componentes conectados ao componente selecionado ficarão visíveis (o filtro será estendido para incluí-los). Os componentes conectados são realçados visualmente pelas linhas verdes de conexão do grafo.
Como o grafo de conectividade está habilitado, uma linha verde é traçada até cada componente conectado ao componente selecionado no painel.
Recursos da seção Componentes
Seção Componentes |
|
| Information available | Para cada entrada de componente, há subpastas para Parameters e Implementations (modelos). Se a opção Pins estiver habilitada nas opções de realce, uma subpasta Pins também estará disponível |
| When you click | Ao clicar em uma entrada de pino na lista Instance, a entrada correspondente a esse pino será selecionada na seção Net / Bus do painel e todos os pinos da rede à qual ele pertence serão listados na seção inferior do painel. Um filtro também será aplicado com base na entrada de pino escolhida; o resultado visual será determinado pelos métodos de realce habilitados. |
| Connective Graph | Se você tiver habilitado a opção Connective Graph, todos os outros pinos conectados à rede à qual pertence o pino selecionado ficarão visíveis (o filtro será estendido para incluí-los). A rede à qual pertencem os pinos conectados é realçada visualmente por linhas vermelhas de conexão do grafo |
Seção Rede / Barramento
A terceira seção do painel lista cada uma das redes e dos barramentos no documento (ou na hierarquia planificada) que está sendo navegado. Ao clicar em uma entrada, todos os objetos associados à rede/ao barramento — Pinos, Rótulos de Rede, Portas, Entradas de Folha e Conectores entre Folhas — serão exibidos na janela do editor de projeto de acordo com os métodos de destaque habilitados.
Recursos da seção Rede / Barramento
Seção Rede / Barramento |
|
| Information available | Os diversos tipos de objetos associados à rede/ao barramento selecionado são listados em subpastas, dependendo das opções de destaque atualmente habilitadas e da presença desse tipo de objeto na rede/no barramento atualmente selecionado. Para cada rede/barramento, pode ser incluída uma subpasta adicional que lista todas as linhas gráficas usadas para conectar os pinos/portas/rótulos de rede/entradas de folha/conectores entre folhas associados. Clique em uma entrada de linha para filtrar apenas esse objeto de linha e aplicar as configurações de controle visual. |
| When you click | Todos os objetos de rede cuja exibição no painel foi habilitada (com exceção das linhas gráficas) serão exibidos na seção inferior do painel Da mesma forma, clicar em qualquer um deles aplicará a filtragem de acordo com os métodos de destaque habilitados. |
Seção Redes do Barramento - Pinos da Rede
O conteúdo da quarta seção do painel depende de dois fatores: o objeto pelo qual você está navegando e os objetos que você configurou para exibição. Se você clicar em um bus na seção Rede / Barramento, as redes desse barramento serão listadas nesta seção do painel. Se você clicar em uma net na seção Rede / Barramento, os pinos dessa rede serão listados. Os identificadores de rede vinculados a essa rede também serão listados, se estiverem habilitados para exibição.
Seção Sinal
O painel Navigator permite visualizar o projeto com foco nos sinais, em vez da abordagem centrada nos objetos com a qual normalmente apresenta o projeto. Se um documento esquemático estiver selecionado na seção Documents do painel, habilitar a opção Show Signals na parte superior do painel alternará a terceira seção do painel para o modo Signal.
Clique em uma entrada de sinal para aplicar um filtro, e os nós desse sinal (pinos/portas/rótulos de rede/entradas de folha/conectores entre folhas) serão exibidos na janela do editor de projeto, de acordo com os métodos de destaque habilitados. Para cada sinal na lista, serão listados os pinos de nó, as entradas de folha ou os conectores entre folhas associados a esse sinal. Essas entradas serão exibidas independentemente de a opção de exibição correspondente a esse tipo de objeto estar habilitada ou não.
Recursos da seção Sinal
Seção Sinal |
|
| Signal | Nome do sinal (nome do barramento ou da rede). |
| Width | Número de redes individuais neste sinal. |
| Click on a top-level signal entry | Clique em uma entrada de sinal de nível superior para preencher a seção inferior do painel com todos os nós de sinal associados a esse sinal. Eles podem incluir Pinos, Rótulos de Rede, Portas, Entradas de Folha e Conectores entre Folhas. As entradas só serão exibidas se a opção correspondente para exibir esse tipo de objeto estiver habilitada. |
| Click on a sub-entry | Clique em uma subentrada na lista principal de Sinais para preencher a seção inferior do painel com todos os objetos de rede associados à rede à qual esse sinal pertence. |
| SignalName Driven By Pin X | Exibido quando um pino de nó associado a um sinal é um pino de saída ou de E/S. X representa o designador do componente-pino que está acionando o sinal. |
| Driving Node Pin X | Exibido quando um pino de nó associado a um sinal é um pino de entrada. X representa o designador do componente-pino que está sendo acionado pelo sinal. |
| Driven By Node Sheet Entry SignalName | Exibido quando o tipo elétrico de um nó de entrada de folha é saída ou E/S; a entrada está acionando o sinal. |
| Driving Node Sheet Entry X | Exibido quando o tipo elétrico da entrada de folha é Entrada; nesse caso, a entrada está sendo acionada pelo sinal. |
Navegação pela PCB
Além de navegar até os objetos no esquemático ao clicar no painel Navigator, você também pode navegar até esses objetos na PCB ao mesmo tempo. Se você mantiver a tecla Alt pressionada ao clicar em um objeto no painel Navigator, os objetos de destino serão destacados tanto no esquemático quanto na PCB.
Como a navegação sempre ocorre no esquemático, para navegar até os objetos na PCB você precisa exibir o esquemático e a PCB ao mesmo tempo. Você pode fazer isso exibindo a PCB em uma janela separada ou compartilhando a área gráfica usando o recurso Split Vertical ou Split Horizonal (a disposição vertical é mostrada abaixo). Os comandos para cada uma dessas opções estão disponíveis no menu de contexto ao clicar com o botão direito em uma aba de documento.
Mantenha a tecla Alt pressionada enquanto navega pelo projeto para também localizar esses objetos na PCB.
O Altium Designer inclui diversos recursos para trabalhar entre o esquemático e a PCB, incluindo:
| Cross probe | Sondagem cruzada — Clique com o botão direito para iniciar e, em seguida, clique em um objeto (componente, pino, rede) em um editor para ir até esse objeto no outro editor. Há dois modos: continuous (permanecer no editor de origem) ou jump-to (tornar o editor/documento de destino o documento ativo). Mantenha Ctrl pressionado durante a sondagem cruzada para ativar o modo jump-to. A sondagem cruzada é compatível com: os editores de esquemático, PCB e BOM; o Gerenciador de Restrições; e os painéis Project, Navigator e Messages. |
| Cross select | Clique para selecionar um componente em um editor e selecioná-lo também no outro editor. Compatível com os editores de esquemático e PCB, habilitado no menu View. |
Saiba mais sobre Sondagem Cruzada e Seleção Cruzada
Menu de Contexto do Painel Navigator
O menu de contexto do painel Navigator, acessado com o botão direito, inclui os seguintes comandos:
)
)
).


).
).
).

).
