SI Analyzer от Keysight

Краткий обзор

В этой статье представлен модуль SI Analyzer by Keysight для Altium Designer и описано, как с его помощью выполнять проверку целостности сигналов после трассировки платы по ключевым параметрам высокоскоростных устройств: импедансу, задержке, вносимым потерям и обратным потерям. Вы узнаете, как открыть и запустить расширение, добавлять цепи и управлять ими, назначать или создавать спецификации, задавать ограничения и подготавливать проект к анализу. Также рассмотрены важные требования: установка расширения, наличие подписки для запуска новых сеансов анализа и особенности обновления документа при изменении данных печатной платы. Хотите разобраться, как настроить анализ целостности сигналов и управлять им непосредственно в среде проектирования? Читайте дальше — это руководство поможет вам уверенно начать работу.

- Узнайте, какие задачи решает расширение SI Analyzer by Keysight в Altium Designer и какие виды проверок целостности сигналов оно поддерживает.
- Ознакомьтесь с установкой расширения, открытием документа SI Analyzer, добавлением цепей или классов цепей и назначением встроенных или пользовательских спецификаций.
- Изучите базовый порядок подготовки ограничений и данных для анализа, чтобы перейти к проверке целостности сигналов в вашем проекте.
Узнайте больше с ИИ:

Все больше современных электронных устройств используют высокоскоростные печатные платы, а по мере развития технологий скорости передачи сигналов растут (17 ГГц в DDR6, 400 Гбит/с в QSFP++ и т. д.). Обеспечение целостности сигналов (SI) — важнейший этап проектирования высокоскоростных устройств. Несоблюдение требований разработчика интерфейса с высокой вероятностью приведет к проблемам на последующих этапах проектирования, при производстве и эксплуатации.

Для анализа целостности сигналов непосредственно в среде Altium Designer доступно решение SI Analyzer by Keysight. SI Analyzer by Keysight, реализованный в виде программного расширения, интегрируется непосредственно с Altium Designer и позволяет выполнять ряд проверок целостности сигналов после трассировки, охватывающих наиболее важные параметры высокоскоростных устройств:

  • Импеданс

  • Задержка

  • Вносимые потери (IL)

  • Обратные потери (RL)

SI Analyzer by Keysight находится на этапе открытого бета-тестирования.

Если вы предпочитаете учиться по видео, посмотрите плейлист обучающих видеороликов по Signal Analyzer by Keysight в Altium Academy.

Доступ к функциям SI Analyzer by Keysight

Для доступа к функциям SI Analyzer by Keysight в Altium Designer необходимо установить программное расширение SI Analyzer by Keysight . Это расширение можно установить или удалить вручную.

Подробнее об управлении расширениями см. на Extending Your Installation странице (Altium Designer Develop, Altium Designer Agile, Altium Designer).

При нажатии кнопки загрузки и установки расширения открывается End-User License Agreement (). Нажимая Accept, вы принимаете условия лицензионного соглашения (EULA), после чего установка продолжится. Нажатие Close означает, что вы не принимаете условия лицензионного соглашения, и процесс установки будет остановлен.

После установки программного расширения SI Analyzer by Keysight становятся доступны следующие возможности:

  • Создание нового или открытие существующего документа SI Analyzer by Keysight.

  • Добавление и настройка цепей для анализа целостности сигналов.

  • Просмотр имеющихся результатов анализа целостности сигналов.

  • Создание отчета об анализе целостности сигналов.

Однако для выполнения нового анализа целостности сигналов необходима действующая подписка на SI Analyzer by Keysight. В противном случае при попытке запустить анализ откроется диалоговое окно Analyze Your Nets, в котором можно запросить бесплатную пробную версию ().

Запуск SI Analyzer by Keysight

Чтобы начать анализ целостности сигналов, откройте документ печатной платы проекта и выберите Tools » SI Analyzer by Keysight в главном меню.

Откроется документ SI Analyzer by Keysight (<ProjectName> [SIK]), который будет добавлен в раздел Source Documents проекта (на панели Projects). Изначально документ не сохранен. Чтобы сохранить его в нужном месте, используйте команду File » Save As из главного меню.

  • После сохранения документа SI Analyzer by Keysight выполнение команды Tools » SI Analyzer by Keysight из главного меню редактора печатных плат создаст еще один документ SI Analyzer by Keysight, который можно использовать для настройки другого анализа целостности сигналов. Чтобы продолжить работу с ранее созданным документом SI Analyzer by Keysight, откройте его двойным щелчком по соответствующей записи на панели Projects.

  • Если после создания документа SI Analyzer by Keysight проект печатной платы был изменен, документ становится неактуальным, а в его правом верхнем углу отображается предупреждение PCB data is outdated. В этом случае управление цепями в документе и запуск анализа недоступны. Чтобы обновить документ SI Analyzer by Keysight в соответствии с данными печатной платы, нажмите элемент управления Refresh рядом с предупреждением.

Подготовка к анализу

Добавление цепей для анализа

После запуска SI Analyzer by Keysight данные печатной платы импортируются в расчетный модуль в формате ODB++. На этом этапе можно задать список анализируемых цепей и назначить им спецификации. Для этого нажмите кнопку Manage Nets в верхней части документа SI Analyzer by Keysight или используйте команду Edit » Manage Nets из главного меню (если в документе нет цепей, в его центре также доступна кнопка Manage Nets). Откроется диалоговое окно Manage Nets со списком классов цепей, дифференциальных пар и xSignals печатной платы.

Классы дифференциальных пар и xSignals проекта печатной платы автоматически добавляются в документ при его создании.
Если класс не содержит объектов, он будет недоступен для выбора в диалоговом окне Manage Nets.

Установите флажки для всех нужных классов (или используйте флажок в заголовке таблицы, чтобы выбрать все классы). При необходимости щелкните ячейку в столбце Specifications, чтобы открыть всплывающее окно и выбрать одну или несколько спецификаций, определяющих ограничения для выбранного класса (при необходимости их можно изменить позже — подробнее). Можно выбрать встроенные или пользовательские спецификации (на вкладке Specifications всплывающего окна) либо вручную задать необходимые значения ограничений для класса (на вкладке Custom Constraints всплывающего окна).  

Нельзя применить спецификации, задающие ограничения одного и того же типа. Например, невозможно применить две спецификации, если обе задают ограничения Impedance ().

Подробнее об управлении встроенными и пользовательскими спецификациями см. в разделе Управление спецификациями.

Также можно развернуть список All Nets в нижней части диалогового окна, чтобы выбрать отдельные цепи проекта и назначить им одну или несколько спецификаций.

После нажатия OK в диалоговом окне выбранные классы появятся в документе SI Analyzer by Keysight. Если цепь была выбрана в области All Nets диалогового окна Manage Nets, она появится в классе All Nets. Разверните запись класса, чтобы просмотреть входящие в него цепи или xSignals.

  • Элемент управления справа от цепи в области All Nets или от класса отображает названия спецификаций, назначенных этому классу или цепи (если же ограничения заданы вручную, элемент управления будет называться Constraints Set и отображать заданные типы ограничений). Если спецификация не назначена, элемент управления будет называться Assign Specification. Нажмите этот элемент управления, чтобы при необходимости изменить назначенную спецификацию, аналогично тому, как это делается в диалоговом окне Manage Nets, как описано выше.

  • Отдельная цепь или xSignal обозначается в документе значком . Если цепь входит в состав дифференциальной пары, она будет добавлена в документ SI Analyzer by Keysight как дифференциальная пара вместе со второй цепью пары, а ее запись будет отмечена значком .

Разверните запись цепи, xSignal или дифференциальной пары, чтобы увидеть составляющие ее объекты (контактные площадки, дорожки, дуги и переходные отверстия) в области Transmission Line. Наведите курсор на плитку объекта и нажмите значок , чтобы перейти к этому объекту на печатной плате с помощью перекрестного выбора.

Чтобы удалить из документа класс или отдельно добавленную цепь, нажмите кнопку  справа от соответствующей записи.

Управление спецификациями

Диалоговое окно Manage Specifications, открываемое нажатием кнопки Manage Specifications в верхней части документа SI Analyzer by Keysight, позволяет управлять как встроенными, так и пользовательскими спецификациями. Затем спецификации можно назначать классам или цепям, чтобы быстро задавать для них ограничения, как описано в предыдущем разделе.

  • В левой части диалогового окна представлен список заданных спецификаций. Для каждой спецификации отображаются ее название и один или несколько типов ограничений, которые она задает.

    Для поиска нужных спецификаций используйте поле Search над списком спецификаций. По мере ввода поискового запроса список будет фильтроваться: в нем останутся только спецификации с соответствующими названиями.
  • Выберите спецификацию в списке, чтобы отобразить сведения о ней (название, тип спецификации — Built-In или User-Defined — и ограничения) в правой части диалогового окна.
  • Чтобы создать новую спецификацию, нажмите кнопку Add New в левом нижнем углу списка спецификаций. В правой части диалогового окна появятся элементы управления для задания спецификации:
    • Задайте название нового ограничения в поле Specification Name.

    • Установите флажки для типов ограничений, которые должна задавать эта спецификация: Impedance, Delay, Insertion Losses (IL) и/или Return Losses (RL).

    • Задайте значения для включенных типов ограничений. Для ограничений типов Impedance и Delay используйте соответствующие текстовые поля. Для ограничений типов Insertion Losses (IL) и Return Losses (RL) можно добавлять, изменять и удалять границы, формируя области запрещенных и допустимых значений потерь в нужном диапазоне частот.

    • Задав все необходимые параметры спецификации, нажмите кнопку Save вверху правой части диалогового окна, чтобы создать ее, или нажмите Cancel, чтобы выйти без создания.

      Обратите внимание: невозможно создать новую спецификацию с уже используемым названием или с недопустимыми значениями включенных ограничений.
  • Новую спецификацию также можно создать путем дублирования существующей — пользовательской или встроенной. Выберите в списке спецификацию для дублирования, затем нажмите кнопку Duplicate в левом нижнем углу списка спецификаций. Будет создана новая спецификация с первоначальным названием <OriginalSpecificationName>(Copy) и теми же ограничениями, что и у исходной; она будет готова к редактированию в правой части диалогового окна. Внесите необходимые изменения и нажмите кнопку Save вверху, чтобы создать спецификацию, или нажмите Cancel, чтобы выйти без создания.
  • Чтобы изменить пользовательскую спецификацию, выберите ее в списке и нажмите кнопку  в правой части диалогового окна. Внесите необходимые изменения и нажмите кнопку Save вверху, чтобы сохранить изменения, или нажмите Cancel, чтобы выйти без применения изменений.
  • Чтобы удалить спецификацию (пользовательскую или встроенную), выберите ее в списке и нажмите кнопку  в правой части диалогового окна.
  • Удаленные встроенные спецификации можно восстановить, щелкнув правой кнопкой мыши в списке спецификаций и выбрав команду Restore Built-In Spec. Эта команда не влияет на пользовательские спецификации.

Задание ограничений

Каждая цепь будет проанализирована на соответствие заданным ограничениям. Если для родительского класса выбрана спецификация, ограничения определяются этой спецификацией.

Чтобы просмотреть текущие ограничения цепи, xSignal или дифференциальной пары, разверните соответствующую запись и выберите вкладку Constraints.

Нажмите значение ограничения, чтобы изменить его в появившемся всплывающем окне.

Обратите внимание: если значение ограничения изменено вручную, в соответствующей записи появится предупреждение Custom constraints are used.

Запуск анализа

После завершения настройки можно запустить анализ для всех добавленных цепей, отдельного класса или отдельной цепи. Нажмите кнопку Analyze All в правом верхнем углу документа SI Analyzer by Keysight, чтобы проанализировать все цепи, или кнопку Analyze в записи определенного класса или цепи, чтобы проанализировать только этот класс или эту цепь.

Просмотр результатов

После завершения анализа его результаты отображаются в документе SI Analyzer by Keysight. В правом верхнем углу документа появится сообщение Analyzed. Если все проанализированные цепи соответствуют ограничениям, рядом с сообщением отобразится текст All Passed. В противном случае отобразится текст Failed с количеством цепей, не соответствующих ограничениям.

Если все цепи класса успешно прошли анализ, в записи этого класса отобразится текст Success. В противном случае отобразится текст Failed.

Разверните запись класса, чтобы увидеть рассчитанные значения (импеданс, задержку, вносимые потери и обратные потери) для каждой проанализированной цепи этого класса. Значения, соответствующие ограничениям, отображаются зеленым цветом, а не соответствующие — красным.

Разверните запись цепи, чтобы увидеть рассчитанные для нее значения на вкладке Results. Кроме того, плитки объектов цепи, не соответствующих ограничениям, выделяются красной рамкой в области Transmission Line, а значение, не прошедшее проверку, отображается красным цветом.

  • Если после анализа конструкция печатной платы была изменена, данные анализа становятся неактуальными. После обновления самого документа SI Analyzer by Keysight с учетом новых данных печатной платы (нажатием Refresh рядом с предупреждением PCB data is outdated в правом верхнем углу документа) появится предупреждение Analysis data is outdated, please re-analyze. Нажмите кнопку Analyze All, чтобы обновить данные анализа с учетом изменений в проекте.
  • Обратите внимание: заданные значения спецификаций или ограничений можно изменить после выполнения анализа. В этом случае рассчитанные значения будут сравниваться с новыми ограничениями, а статус соответствия будет обновлен соответствующим образом.

Чтобы просмотреть результаты анализа для класса или цепи/xSignal/дифференциальной пары на печатной плате, нажмите соответствующую кнопку Show on PCB.

Панель SI Analyzer by Keysight

В редакторе печатных плат управление процессом анализа и его результатами осуществляется с помощью панели SI Analyzer by Keysight. Обратите внимание: панель добавляется в список доступных панелей (открываемый кнопкой Panels) после выполнения анализа целостности сигналов и нажатия кнопки Show on PCB.

Моделируемый сигнал

  • Simulated Signal – позволяет выбрать класс или цепь/xSignal/дифференциальную пару для отображения в виде тепловой карты в рабочей области.
  • Only nets with violations – если этот параметр включен, в раскрывающемся списке доступны только объекты, у которых в данный момент есть нарушения. Отключите этот параметр, чтобы отобразить все проанализированные объекты.
  • Show Heatmap – если этот параметр включен, в рабочей области отображается тепловая карта для объекта, выбранного в раскрывающемся списке Simulated Signal.

Под этими элементами управления расположены две вкладки панели: General и Heatmap. Параметры на этих вкладках применяются к объекту, выбранному в раскрывающемся списке Simulated Signal.

Тепловая карта

Вкладка Heatmap на панели SI Analyzer by Keysight позволяет выбрать данные для отображения в виде тепловой карты — импеданс или задержку, а также настроить цветовое представление импеданса/задержки. Обратите внимание: эти настройки тепловой карты доступны только при включенном параметре Show Heatmap.

Для переключения между двумя режимами используйте кнопки Impedance и Delay. Вся цепь окрашивается в соответствии со значением импеданса/задержки в каждой ее точке следующим образом:

  • Для импеданса: чем ближе импеданс к целевому значению Z0, тем зеленее цвет, а чем дальше от целевого значения Z0 — тем краснее. Рассчитанные значения ниже минимума и выше максимума отображаются красным цветом. 
  • Для задержки: чем больше задержка, тем теплее (краснее) цвет, а чем меньше — тем холоднее. Рассчитанные значения ниже минимума отображаются синим цветом, а значения выше максимума — красным.

Цветовая шкала показывает соответствие значений цветам. Минимальное и максимальное значения можно настроить, перетаскивая ползунки или вводя новые значения в расположенные ниже поля. Шкала также отображается в виде цветной полосы в рабочей области под печатной платой.

Включите параметр Color focus on results, чтобы выделить объект, выбранный в раскрывающемся списке Simulated Signal, и скрыть остальные объекты печатной платы с помощью фильтра.

Пример тепловой карты для расчета импеданса.
Пример тепловой карты для расчета импеданса.

Пример тепловой карты для расчета задержки.
Пример тепловой карты для расчета задержки.

Обнаружение нарушений

Если при анализе обнаружены нарушения ограничений для объекта, выбранного в раскрывающемся списке Simulated Signal, они отображаются в области Violations на вкладке General панели SI Analyzer by Keysight.

  • С помощью кнопок в верхней части области выберите типы нарушений, которые должны отображаться в списке.
  • Используйте кнопку Analyze в нижней части области для повторного запуска анализа целостности сигналов. Это позволяет быстро проверить, соответствует ли объект ограничению после внесения изменений в редакторе печатных плат, не возвращаясь к документу SI Analyzer by Keysight.

Измерительные зонды

Область Probes панели SI Analyzer by Keysight используется для размещения измерительных зондов непосредственно на печатной плате. Зонды позволяют измерять импеданс или задержку; тип измерения определяется текущим режимом тепловой карты платы.

Зонды могут быть одиночными — для измерения абсолютного значения в точке установки, или разностными — для измерения разницы значений между двумя точками. Оба типа зондов размещаются нажатием кнопки Add в области Probes панели. Чтобы разместить одиночный зонд, щелкните в нужном месте, затем нажмите правую кнопку мыши (или клавишу Esc). Чтобы разместить разностный зонд, первым щелчком задайте первую точку измерения, а вторым — вторую. После размещения зонда результаты измерений отобразятся на панели.

Пример одиночного зонда
Пример одиночного зонда

Пример разностного зонда
Пример разностного зонда

Щелкните запись зонда на панели, чтобы показать его точку или точки измерения на печатной плате. Чтобы удалить зонд, выберите его запись на панели и нажмите кнопку  в нижней части области.

Нажмите кнопку Add to Report, чтобы создать снимок печатной платы в выбранной точке измерения. Изображение появится в области Image Captures панели и будет отмечено значком Probe. Наведите указатель на снимок, чтобы просмотреть сведения о зонде.

Снимки экрана

Функция создания снимков экрана на панели SI Analyzer by Keysight позволяет получить снимок нужного участка проекта, который затем можно включить в отчет.

Чтобы сделать снимок определенного участка платы, сначала настройте вид платы в рабочей области так, чтобы были видны все элементы, которые должны попасть на снимок. Затем нажмите кнопку Add в области Image Captures панели, чтобы сделать снимок экрана. Вы можете продолжить изменять вид платы и добавлять новые изображения.

Чтобы удалить изображение, наведите на него указатель, чтобы появилась кнопка , затем нажмите ее.

Снимки экрана хранятся в документе SI Analyzer by Keysight. Чтобы сохранить изображения, сохраните документ.

Отчет о результатах

Чтобы сформировать полный отчет по анализу, нажмите кнопку Full Report в верхней части документа SI Analyzer by Keysight. Полный отчет содержит раздел для каждого класса (а также раздел All Nets для цепей, добавленных по отдельности и не входящих в классы цепей).

В полном отчете нажмите имя класса цепей (или имя цепи в списке All Nets), чтобы просмотреть подробный отчет, включающий:

  • Имя класса цепей или цепи.
  • Назначенные спецификации.
  • Сводку проверок ограничений. Нажмите запись о непройденной проверке, чтобы просмотреть рекомендации по устранению соответствующих проблем.
  • Стек слоев платы.
  • Проверки ограничений для каждой цепи. Разверните запись цепи, чтобы просмотреть проверки ограничений для каждого объекта этой цепи.
  • График вносимых потерь.
  • График возвратных потерь.

При просмотре подробного отчета нажмите кнопку Show on PCB, чтобы открыть плату и панель SI Analyzer by Keysight для изучения класса или цепи.

Работа с графиками

Графики вносимых и возвратных потерь показывают соответствующие кривые для каждой цепи в рассматриваемом классе. Красная область на графике обозначает запрещенную зону, заданную ограничениями.

  • Используйте раскрывающийся список в правом верхнем углу графика вносимых или возвратных потерь, чтобы выбрать отображаемые цепи. Можно отобразить все цепи, цепи, не прошедшие проверки, или отдельные цепи.

  • Нажмите имя кривой справа от графика, чтобы выделить ее, приглушив остальные кривые. Нажмите имя кривой еще раз, чтобы снять выделение.

  • Прокручивайте колесо мыши, чтобы изменять масштаб относительно положения указателя на графике. Если указатель находится на оси графика, прокрутка колеса изменяет масштаб относительно положения указателя только на этой оси (масштаб другой оси не изменяется).

  • Для измерения данных можно использовать измерительные курсоры. Доступны два курсора, которые можно добавить к одной или разным кривым на графике. Нажмите правой кнопкой мыши имя кривой справа от графика и используйте команды Cursor A и Cursor B в контекстном меню, чтобы включить или отключить курсоры. Чтобы переместить курсор, нажмите его вкладку и перетащите ее. Данные измерений для включенного курсора отображаются в нижней части графика.

    Пример курсоров A и B, добавленных к одной кривой.
    Пример курсоров A и B, добавленных к одной кривой.

Экспорт отчета

Нажмите кнопку Save Report, чтобы сохранить отчет в формате HTML. В открывшемся диалоговом окне Report Settings укажите, какие цепи (если окно открыто из полного отчета) и какие данные следует включить в отчет.

После нажатия кнопки Generate Report отчет сохраняется во вложенной папке проекта с именем \SiAnalyzerByKeysight_Output\HTMLReport\<ProjectName>.sik_<CurrentDate>_<CurrentTime>. Все изображения отчета сохраняются во вложенной папке \Images.

AI-LocalizedЛокализовано с помощью ИИ
Если вы обнаружили проблему, выделите текст/изображение и нажмитеCtrl + Enter, чтобы отправить нам свой отзыв.
Меню
Contents
Доступность функций

Доступные вам функции зависят от того, какое решение Altium вы используете: Altium Develop, Altium Agile Teams, Altium Agile Enterprise или Altium Designer (при активной подписке).

Если вы не видите описанную функцию в используемом вами программном обеспечении, свяжитесь с отделом продаж Altium, чтобы узнать больше.

Устаревшая документация

Документация Altium Designer больше не разделена по версиям ПО. Если вам необходим доступ к документации по старым версиям Altium Designer, посетите раздел Устаревшая документация на странице Прочие установщики.

Contents