Altium Designer Documentation

Создание посадочного места

Последнее изменение: Pavel Demidov; 25.10.2020

Содержание

Полное содержание

Altium Designer содержит большой набор готовых к использованию компонентов, как на серверах, так и в ряде интегрированных и отдельных библиотек, доступных через сообщество AltiumLive. Тем не менее, в какой-то момент может возникнуть необходимость создания собственного компонента. Создание посадочных мест компонентов осуществляется в редакторе библиотек посадочных мест (PCB Library) с помощью того же набора объектов, которые доступны в редакторе плат. Помимо посадочных мест, в качестве компонентов также можно сохранять логотипы компании, технологические и прочие объекты, необходимые в процессе конструирования платы.

Физический компонент, который монтируется на плату, представлен схемным символом в процессе ввода схемы и посадочным местом при конструировании платы. Компоненты Altium Designer могут быть:

  • Созданы в локальных библиотеках и размещены из них, либо
  • Размещены непосредственно из сервера управляемых данных – глобально доступной системы хранения компонентов, которая содержит тысячи компонентов с символами, посадочными местами, параметрами компонентов и ссылками на поставщиков.
Для получения более подробной информации перейдите на страницу Концепция моделей, компонентов и библиотек.

Создание посадочного места вручную

2D- и 3D-вид посадочного места компонента (джойстик). На 3D-виде отображена импортированная STEP-модель компонента. Обратите внимание, что контактные площадки и шелкография компонента отображаются под STEP-моделью.

Типовой алгоритм создания посадочного места компонента вручную:

  1. Посадочное место создается около начала координат рабочей области в центре редактора PCBLIB. Используйте последовательность клавиш J, R для перехода непосредственно к началу координат. Если вы забыли переместить начало координат до того, как начали создавать посадочное место, вы можете задать отсчетную контактную площадку посадочного места с помощью команд подменю Edit » Set Reference.
  2. Разместите контактные площадки (Place » Pad) в соответствии с требованиями к компоненту. После запуска команды на размещение контактной площадки, перед размещением первой из них нажмите клавишу Tab, чтобы открыть панель Properties для задания всех свойств контактной площадки, в том числе ее обозначение (Designator), размеры и форму (Size and Shape), слой (Layer) и, для сквозных контактных площадок, размер отверстия (Hole Size). Значение Designator автоматически увеличивается при последующих размещениях контактных площадок. Для контактных площадок, монтируемых на поверхность, задайте свойству Layer значение Top Layer. Для сквозных контактных площадок задайте свойству Layer значение Multi-Layer.

    Задавать номера контактных площадок следует аккуратно, поскольку именно это свойство используется в Altium Designer при отображении номеров выводов схемного символа.
  3. Чтобы обеспечить точность размещения контактных площадок, задайте сетку специально для этой задачи. Используйте сочетание клавиш Ctrl+G, чтобы открыть диалоговое окно Cartesian Grid Editor и клавишу Q для переключения единиц измерения сетки.
  4. Для точного размещения контактной площадки при ее перемещении с помощью мыши используйте клавиши со стрелками для перемещения курсора по узлам текущей сетки привязки. Кроме того, вы можете зажать клавишу Shift для перемещения сразу через 10 узлов сетки привязки. Текущие координаты отображаются в строке состояния, а также в информационном окне Heads Up display. Информационное окно Heads Up display содержит в себе как координаты, так и приращение от точки последнего щелчка ЛКМ до текущего положения курсора. Используйте сочетание клавиш Shift+H для включения и отключения информационного окна Heads Up display. Либо дважды щелкните ЛКМ по размещенной контактной площадке и введите нужные координаты в панели Properties.
  5. Чтобы проверить расстояние между двумя точками рабочей области, используйте команду Reports » Measure Distance (сочетание клавиш Ctrl+M). Следуйте подсказкам в строке состояния.
  6. Относящиеся к контактной площадке свойства, такие как паяльная маска и паяльная паста, рассчитываются автоматически на основе размеров контактной площадки и применяемых правил проектирования. Хотя эти настройки можно задать вручную, изменить их после этого может быть сложнее на последующем этапе конструирования платы. Как правило, это делается, только если не возможно задать правила проектирования контактным площадкам. Обратите внимание, что эти правила определяются в редакторе плат на этапе конструирования платы.
  7. Используйте трассы, дуги и прочие примитивы для определения контура компонента на слое шелкографии.
  8. Разместите трассы и прочие примитивы на механическом слое для определения дополнительной информации, например, области размещения. Механические слои являются слоями общего назначения. Вам необходимо распределить назначения этих слоев и затем использовать их согласно этим назначениям в посадочных местах.
  9. Разместите объекты 3D Body для определения трехмерной модели компонента, которая соответствует посадочному месту. Для построения модели можно разместить множество объектов 3D Body, либо вы можете импортировать в объект 3D Body трехмерную модель компонента в формате STEP.
  10. Строки позиционного обозначения и комментария будут автоматически добавлены на слой шелкографии посадочного места при его размещении в редакторе плат. Дополнительные строки можно добавить, разместив специальные строки .Designator и .Comment на механическом слое.

    При размещении строк Designator и Comment необходимо определить пару слоев в редакторе плат. Это обеспечит привязку строк к той стороне платы, на которой размещен компонент, и они будут перемещены на другую сторону платы при перемещении на нее компонента. Для получения более подробной информации перейдите в раздел Управление требованиями, относящимся к специальным слоям ниже.
  11. Переименуйте посадочное место, дважды щелкнув по его имени в списке Footprints в панели PCB Library, чтобы открыть диалоговое окно PCB Library Footprint. Введите нужное имя; имя может содержать до 255 символов.
Для размещения стандартизированных контактных площадок и переходных отверстий в посадочных местах вы можете использовать библиотеку шаблонов контактных площадок/переходных отверстий (*.PvLiB).

Создание посадочного места с помощью мастера IPC Compliant Footprint Wizard

Мастер IPC Compliant Footprint Wizard создает посадочные места компонентов, совместимые со стандартами IPC. Вместо работы непосредственно с размерами посадочного места, мастер использует информацию самого компонента, затем рассчитывает подходящие контактные площадки и прочие свойства посадочного места в соответствии с алгоритмами IPC.


Один из поддерживаемых в IPC Compliant Footprint Wizard корпусов – DPAK.

  • Выберите команду Tools » IPC Compliant Footprint Wizard в документе библиотеки посадочных мест (*.PcbLib), чтобы запустить IPC Compliant Footprint Wizard.
  • Мастер может создавать посадочные места следующих типов: BGA, BQFP, CAPAE, CFP, CHIP Array, DFN, CHIP, CQFP, DPAK, LCC, LGA, MELF, MOLDED, PLCC, PQFN, PQFP, PSON, QFN, QFN-2ROW, SODFL, SOIC, SOJ, SON, SOP/TSOP, SOT143/343, SOT223, SOT23, SOT89, SOTFL и WIRE WOUND.
  • Мастер IPC Compliant Footprint Wizard использует размерную информацию о самом компоненте в соответствии со стандартами IPC.

Некоторые из возможностей IPC Compliant Footprint Wizard:

  • Можно ввести и сразу отобразить габаритные размеры корпуса, информацию о выводах, расстояние между пятками выводов, кромки припоя и допуски.
  • Можно ввести механические размеры, такие как информацию об области размещения, сборке и 3D-модели компонента.
  • Вы можете вернуться на любой этап мастера, чтобы проверить данные и внести изменения. Предварительный просмотр посадочного места отображается на каждом этапе мастера.
  • Вы можете нажать клавишу завершения на любом этапе мастера для формирования посадочного места, который отображается в данный момент.
Если вы нажмете кнопку Finish до завершения ввода всей информации, будет создано посадочное место с настройками по умолчанию для выбранного типа компонентов.

Создание посадочного места с помощью средства IPC Footprint Batch Generator

Средство IPC Footprint Batch Generator можно использовать для формирования множества посадочных мест для различных уровней плотности монтажа. Средство зачитывает размерные данные компонентов из таблицы Excel и файла CSV, затем применяет расчеты IPC для создания IPC-совместимых посадочных мест. Поддержка средства IPC Footprints Batch Generator включает в себя:

  • Файлы пустых шаблонов корпусов включены в папку \Templates установки Altium Designer.
  • Входные файлы корпусов содержат в себе информацию для одного или множества посадочных мест одного типа корпуса, которые могут быть в формате файла Excel или CSV.


Средство IPC Footprints Batch Generator может создать все посадочные места в открытой библиотеки посадочных мест или сформировать отдельные библиотеки на основе входных файлов или названий посадочных мест.

Создание компонента с помощью мастера Footprint Wizard

Редактор библиотек посадочных мест включает в себя мастер Footprint Wizard. Этот мастер позволяет выбрать тип корпуса и ввести соответствующую информацию, после чего будет создано посадочное место. Обратите внимание, что в мастере Footprint Wizard вы задаете размеры для контактных площадок и шелкографии.

Для запуска мастера Footprint Wizard щелкните ПКМ в области Footprints панели PCB Library и выберите Footprint Wizard либо выберите команду Tools » Footprint Wizard из главного меню.

Добавление 3D-модели компонента

В посадочное место может быть добавлено 3D-представление компонента. В Altium Designer могут использоваться следующие форматы 3D-моделей:

  • Объекты 3D Body Altium Designer – разместите их для создания требуемой формы компонента.
  • Модели STEP – *.Stp и *.Step.
  • Детали SolidWorks – *.SldPrt.
  • Модели Parasolid – *.x_t и *.x_b.

Форму компонента можно задать, разместив объект 3D Body и/или импортировав 3D-модель.

  • Назначьте механический слой для объектов 3D Body, затем в процессе размещения убедитесь, что этот слой выбран в панели Properties.

    Панель Properties можно использовать для задания ссылки на 3D-модель, которая хранится на сервере.
  • Как правило, построение формы компонента из объектов 3D Body проще осуществлять в 2D-режиме отображения. Доступные формы объектов 3D Body включают в себя вытянутую модель, цилиндр и сферу.
  • Для переключения редактора библиотек посадочных мест между 2D- и 3D-режимами отображения используйте клавиши 2 и 3.
  • 3D-модели компонентов можно загрузить с веб-сайтов производителей компонентов или сайтов обмена ресурсами, таких как www.3dContentCentral.com.
  • 3D-модели проще размещать в 3D-режиме отображения. Для размещения общей 3D-модели сначала разместите объект 3D Body и, когда открыта панель Properties, задайте Generic в качестве типа модели 3D Model Type и выберите опцию Embed Model в области Source. Нажмите кнопку Choose, чтобы найти и выбрать файл 3D-модели.
  • При зажатии ЛКМ на 3D-модели для ее перемещения курсор будет прикреплен к ближайшей вершине, принадлежащей встроенной 3D-модели объекта 3D Body, или точке привязки, заданной в 3D-модели. Точки привязки можно определить в разделе Snap Points панели Properties или с помощью команды Tools » 3D Body Placement » Add Snap Points From Vertices. Команда является интерактивной – подсказки отображаются в строке состояния. Обратите внимание, что есть два режима команды. По умолчанию точка привязки добавляется в вершину, выбранную пользователем. Для переключения во второй режим следует нажать клавишу Пробел после запуска команды. В этом режиме необходимо выбрать щелчками ЛКМ две точки. Система вычислит и разместит точку привязки в средней точке между выбранными точками.
  • Используйте стандартные сочетания клавиш Windows для приближения и панорамирования в 3D-режиме отображения редактора библиотек посадочных мест. В 2D-режиме зажмите ПКМ для панорамирования документа. Для поворота вида зажмите клавишу Shift, затем зажмите ПКМ, либо используйте 3D-мышь, такую как Space Navigator™.
  • Панель List полезно использовать для редактирования свойств объекта 3D Body, таких как размеры, угол поворота и цвет. Эта панель позволяет легко редактировать значения и сразу видеть результат, что идеально подходит для решения таких задач, как поворот 3D-модели.
  • Поддержка 3D-моделей не ограничена только компонентами. Их также можно использовать для импорта другой механической информации, такой как крепежные или корпусные детали. Если модель не встроена, а добавлена ссылка на нее, то при изменении 3D-модели будет открыто диалоговое окно с предложением загрузить модель повторно.


Одно и то же посадочное место: слева – физический компонент, созданный из набора объектов 3D Body; справа – импортированная модель STEP.

Обратите внимание, что для режима 3D-отображения Altium Designer необходима графическая карта с поддержкой Microsoft DirectX 9 (или выше) и Shader Model 3 (или выше).

Создание посадочных мест с контактными площадками нестандартной формы

Для некоторых посадочных мест необходимы контактные площадки нестандартной формы. Для этого можно использовать любые объекты, доступные в редакторе библиотек посадочных мест, но при этом важно помнить об одном важном моменте.


Создание контактных площадок нестандартной формы путем размещения множества объектов.

Altium Designer автоматически добавляет паяльную маску и паяльную пасту на основе форм контактных площадок. Значения отступов по умолчанию определяются правилами проектирования, но их также можно задать на странице PCB Editor - Defaults диалогового окна Preferences. Эти настройки можно переопределить в панели Properties при размещении или после размещения.

Для получения более подробной информации об использовании правил проектирования для определения значений отступов по умолчанию перейдите в справочник по правилам проектирования категории Mask Rules.

Создание контактных площадок нестандартной формы

Главная страница: Работа с контактными площадками нестандартной формы

Если для создания нестандартной формы использовались только объекты Pad, то соответствующая форма паяльной маски/пасты будет сформирована автоматически как расширение формы контактной площадки. Но если нестандартная форма была создана с помощью других объектов, таких как линии (трассы), заполнения, регионы, контактные площадки или дуги, то паяльную маску/пасты необходимо настроить вручную.

У объектов всех типов есть свойство паяльной маски, а у заполнений и регионов есть также свойство расширения паяльной пасты. Если эти объекты были размещены на верхнем слое для создания формы контактной площадки, то можно включить свойство паяльной маски этих объектов, чтобы она подчинялась применяемым правилам проектирования или использовала расширение, заданное вручную. Если для создания формы контактной площадки использовались заполнения и регионы, то для этих объектов также можно включить свойство паяльной пасты.

Если маска/паста была некорректно сформирована как расширение (или сжатие) набора объектов, используемых для создания контактных площадок нестандартной формы, то можно задать расширения паяльной маски/пасты вручную путем размещения линий (трасс), заполнений, регионов и дуг непосредственно на соответствующие слои паяльной маски и паяльной пасты. Пример пользовательского посадочного места кнопки показан ниже.

Внутри контактной площадки нестандартной формы необходимо использовать объект Pad, чтобы система понимала, куда подключать цепь.

Отображение паяльной маски/пасты

Чтобы убедиться в том, что паяльная маска и/или паста корректно задана в редакторе библиотек посадочных мест, откройте панель View Configuration panel и включите отображение () для этих слоев.

На изображении в разделе Посадочные места со множеством контактных площадок, подключенных к одному выводу показано посадочное место с фиолетовой (цвет слоя Top Solder Mask) границей, которая появляется вокруг краев контактных площадок. Так отображается граница паяльной маски, выступающей из-под контактной площадки на величину расширения.

Для быстрого переключения между слоями используйте режим одного слоя (Shift+S) в сочетании с Ctrl + Shift + Вращение колеса мыши.

Управление посадочными местами с объектами трассировки

При передаче проекта, посадочные места, указанные в компонентах, извлекаются из доступных библиотеки и размещаются на плате. Затем каждой контактной площадке в посадочном месте задается цепь в соответствии с именем цепи, подключенной к соответствующему выводу на схеме. Все объекты, касающиеся контактной площадки, подключаются к той же цепи, что и у контактной площадки.

Редактор плат включает в себя полнофункциональное средство управления цепями. Для его запуска выберите команду Design » Netlist » Configure Physical Nets из главного меню, чтобы открыть диалоговое окно Configure Physical Nets. Щелкните ЛКМ по кнопке Menu, чтобы открыть меню настроек. Щелкните ЛКМ по выпадающему меню заголовка New Net Name, чтобы выбрать цепь для неназначенных примитивов.

Посадочные места со множеством контактных площадок, подключенных к одному выводу

В посадочном месте транзистора SOT223, показанном ниже, множество контактных площадок подключено к одному логическому выводу компонента на схеме – выводу 2. Для создания этого соединения, двум контактным площадкам задано одно и то же обозначение '2'. При использовании в редакторе схем команды Design » Update PCB для передачи проектной информации в плату будет отображена линия соединения, идущая к обеим контактным площадкам.


Посадочное место SOT223 с двумя контактными площадками с обозначением 2.

Управление специальными требованиями паяльной маски

Посадочное место, показанное ниже, является набором контактов для кнопочного переключателя, выполненного непосредственно на внешнем проводящем слое платы.


Посадочное место печатной кнопки, выполненное путем размещения контактных площадок, линий и дуг.

На печатной плате размещена резиновая накладка переключателя с кнопкой, которая при нажатии кнопки соединяется с обоими наборами выступов в посадочном месте для создания электрического соединения. Для этого оба набора выступов не должны быть закрыты паяльной маской.

Круглое вскрытие паяльной маски было создано путем размещения дуги, ширина которой равна или больше радиуса дуги, в результате чего позади обоих наборов выступов появляется сплошной фиолетовый круг. Каждый набор выступов определен дугой, горизонтальными линиями и контактной площадкой (выделены на изображении, чтобы она были видимыми). Контактные площадки необходимы для определения точек подключения. Размещенные вручную на верхнем слое объекты паяльной маски будут автоматически перенесены на нижнюю сторону слоя паяльной маски при перемещении компонента на нижнюю сторону платы.

Поддержка параметров

Параметры, применяемые к объектам в Altium Designer, позволяют эффективно добавлять дополнительную информацию в конструкцию платы. Применяемые в качестве свойств родительских объектов, параметры могут быть применены на различных уровнях, в том числе к проектам, документам, шаблонам и отдельным объектам в проектом документе.

Перейдите на страницу объекта Parameter для получения более подробной информации.

Параметры, которые становятся доступными в редакторе плат, можно использовать для фильтрации запросов, правил проектирования, скриптов и вариантов, и их можно использовать в библиотеках посадочных мест для вызова пользовательских строк в размещенных посадочных местах.

Передача параметров через Engineering Change Order

Возможности использования параметров в плате основаны на функциональности, включенной в механизм ECO и документ платы, что позволяет передавать определенные пользователем параметры в плату. Это односторонняя передача, и полученные параметры доступны в плате только для чтения.

Передача параметров осуществляется путем создания запроса на инженерные изменения (Engineering Change Order, ECO) из схемы в плату с помощью команды Design » Update PCB Document.

После выполнения ECO (с помощью кнопки Execute Changes) все новые параметры компонентов, заданные пользователем в схеме, будут переданы в соответствующие посадочные места в плате.

Обнаружение и передача параметров в плату определяется настройками проекта (Project » Project Options). В диалоговом окне Project Options задайте настройки обнаружения и изменения различий в разделе Differences Associated with Parameters на вкладке Comparator и в разделе Modifications Associated with Parameters на вкладке ECO Generation.

Чтобы увидеть переданные параметры в редакторе платы, дважды щелкните ЛКМ по компоненту, чтобы открыть панель Properties, и выберите вкладку Parameters. На вкладке будет приведен список пользовательских параметров, которые были присвоены выбранному компоненту. Параметры выбранного посадочного места компонента также доступны в панели Components.

Ссылки на справочную информацию

Редактор плат автоматически получает предопределенные параметры ComponentLink из схемы. Эти параметры определяются в качестве пар параметров (описание и URL-ссылка), которые, как правило, являются ссылками на определенные файлы или Интернет-ресурсы, такие как веб-сайт производителя или даташит компонента.

Для получения информации по параметрам ссылок на справочную информацию перейдите на страницы по команде Document Reference Link редактора схем и команде Component Link редактора плат.

Как в редакторе схем, так и в редакторе плат, доступ к ссылками осуществляется из контекстного меню компонента (в подменю References). Эти специальные параметры добавляются в панель Properties, и после передачи в редактор плат они появляются как параметры посадочного места компонента.

Параметры в исходных посадочных местах

Параметры, переданные в редактор плат, могут использоваться для предоставления дополнительной информации (по работе платы или для ее изготовления) через посадочные места компонентов. При добавлении строк специальных параметров в посадочные места в исходных библиотеках, пользовательские строки будут преобразованы на целевом механическом слое или слое шелкографии.

Специальные строки, представляющие пользовательские параметры, могут быть добавлены в исходное посадочное место компонента с помощью кнопки и выпадающего меню специальных строк () в панели Properties.

В показанном ниже посадочном месте была добавлена специальная строка .Designator на второй механический слой.


Специальная строка, представляющая пользовательский параметр, может быть добавлена в посадочное место компонента.

При применении этого пользовательского параметра к компоненту на схеме и передаче параметров в плату преобразованные строки посадочных мест появятся как на виде платы, так и в сформированных выходных файлах. В этом примере строка специального параметра содержит в себе пользовательский идентификатор компонента для помощи в монтаже.

Использование пользовательских параметров в посадочных местах компонентов в качестве специальных строк может служить и другим целям, таким как обозначение функции переключателей и соединителей, где соответствующая строка параметра может быть размещена на слое шелкографии в посадочных местах этих компонентов.

Чтобы видеть преобразованные значения специальных строк на плате, включите опцию Special Strings в области Additional Options на вкладке View Options в панели View Configuration. Специальные строки всегда преобразуются в формируемых выходных файлах.

В редакторе схем, если нужно, включите опцию Display Names of Special Strings that have No Value Defined на странице Schematic – Graphical Editing диалогового окна Preferences.

Параметрические запросы

Строки параметров в редакторе плат также доступны через язык запросов Altium Designer, и они, соответственно, доступны для фильтрации объектов, в том числе через функцию поиска подобных объектов.

Чтобы выполнить выделение подобных объектов, щелкните ПКМ по компоненту и выберите Find Similar Objects из контекстного меню, чтобы открыть диалоговое окно Find Similar Objects.

Диалоговое окно Find Similar Objects включает в себя область Parameters, где могут быть заданы нужные опции фильтра.

Панель PCB Filter может применить ключевые слова запросов, относящиеся к параметрам, в качестве критериев фильтрации, и ее можно использовать для создания правил проектирования, основанных на параметрах в плате.

Для работы с параметрами посадочных мест доступно несколько ключевых слов запросов, в том числе ключевые слова специальных функций для преобразования значений строк в числа (например StrToNumber). Преобразования значений строк учитывают единицы измерения (V, mA, mV, kOhm и т.д.) и позволяют определить результаты запроса путем обработки числовых значений строк значений параметров.

Поддерживаемые типы единиц измерения, которые могут быть указаны в запросах:

  • % – процент
  • A – ток
  • C – температура
  • dB – децибелы
  • F – емкость
  • G – проводимость
  • H – индуктивность
  • Hz – частота
  • Kg – масса
  • m – длина
  • Ohm – сопротивление
  • Q – заряд
  • s – время
  • V – напряжение
  • W – мощность
  • Z – импеданс


Для работы с параметрами посадочных мест компонентов доступно несколько ключевых слов запросов параметров.

В примере, показанном в диалоговом окне Query Helper выше, происходит обработка параметра Voltage Rating всех компонентов (с помощью преобразования строки в число – StrToNumber(Unit Value, Unit Type)) для определения того, больше ли это значение 50V. При применении этого запроса в панели PCB Filter, на плате отображается один высоковольтный компонент C1, значение номинального напряжения которого составляет 3kV.

Также поддерживается экспоненциальная запись. Например, запрос на фильтрацию конденсаторов номиналом больше 1nF можно записать так:

StrToNumber(ParameterValue('CapacitanceValue'), F) > 1e-9

Либо функцию числового преобразования можно использовать для возвращенного значения параметра и и для сравнительного значения:

StrToNumber(ParameterValue('CapacitanceValue'), F) > StrToNumber('1nF', F)

Правила и скрипты

Запросы параметров также можно использовать в скриптах и правилах проектирования Altium Designer. Правила проектирования можно использовать для проверок конструкции платы, таких как обнаружение параметров посадочных мест для анализа размещения или назначения слоев компонентов. Обратите внимание, что функции, приведенные в диалоговом окне Query Helper выше, доступны в языке скриптов.

На изображении ниже показан запрос номинального напряжения конденсаторов (см. запрос фильтра выше), примененный в правиле для размещения компонентов, которое при запуске будет проверять значения зазоров для компонентов, определенных как высоковольтные устройства (>50V).


Правила проектирования, заданные по определенным параметрам посадочных мест, которые были получены из схемы, можно использовать для обнаружения определенных условий на плате.

Аналогичным образом, пользовательские параметры в плате можно использовать для проверки совместимости слоев компонентов, например, если компонент не поддерживает пайку волной и, соответственно, размещение на нижнем слое. Для этого в правиле Permitted Layers Rule может быть использован запрос на соответствие объектов, который обрабатывает пользовательский параметр ‘WaveSoldering’.

Далее это правило будет проверять (в пакетном режиме) значения этого параметра и формировать нарушение, если компонент не может быть размещен на нижнем слое.

Варианты

Параметры, переданные в плату, которые включены в варианты проекта (см. Варианты проекта), обрабатываются при выборе варианта.

На практике, параметры компонентов с вариантами в документе платы будет динамически обнаруживаться строкой запроса или, например, будут отображаться на слое платы через специальную строку.

Строки Designator и Comment

Строки Designator и Comment по умолчанию

При размещении посадочного места на плате ему задается позиционное обозначение (Designator) и комментарий (Comment) на основе информации, извлеченной из схемы проекта. Местозаполнители для строк Designator и Comment не нужно задавать вручную, поскольку они добавляются автоматически при размещении посадочного места на плате. Положение этих строк определяется опцией Autoposition строк Designator и Comment в панели Properties. Положение и размер по умолчанию этих строк задается в свойствах соответствующих примитивов на странице PCB Editor - Defaults диалогового окна Preferences.

Дополнительные строки Designator и Comment

Могут возникнуть ситуации, когда необходимы дополнительные копии строк Designator и Comment. Например, сборочному цеху может потребоваться подробный сборочный чертеж с позиционным обозначением, показанным внутри каждого компонента, в то время как внутренние требования предприятия предусматривают размещение позиционного обозначения прямо над компонентом на слое шелкографии изготовленной платы. Дополнительное позиционное обозначение можно добавить, включив специальную строку .Designator в посадочное место. Для указания положения строки комментария на альтернативных слоях или в альтернативным расположениях также доступна специальная строка .Comment.

Для обеспечения требований сборочного цеха, строку .Designator можно разместить на механическом слое в редакторе библиотек посадочных мест, после чего в качестве инструкций для сборки сформировать распечатки, которые включают в себя этот слой.

Управление требованиями, относящимся к специальным слоям

Есть ряд специальных требований, которые могут быть у посадочного места компонента, такие как необходимость в точке клейки или определение удаляемой паяльной маски. Многие из этих специальных требований будут связаны с той стороной платы, на которой смонтирован компонент, и они должны переноситься на другую сторону платы при перемещении туда компонента.

Вместо того, чтобы добавлять большое количество специальных слоев, которые будут редко использоваться, редактор плат поддерживает это через так называемые пары слоев. Пара слоев – это два механических слоя, которые были определены как пара. При перемещении платы с одной стороны платы на другую, все объекты в паре механических слоев будут перемещены на противоположный механический слой в этой паре.

Пару слоев необходимо определить перед тем, как компонент будет перемещен на другую сторону. Если пара была определена после перемещения компонента на нижнюю сторону, содержимое механического слоя будет перевернуто, но останется на изначальном слое. Если вы забыли создать пару слоев перед перемещением на другой слой, вы можете изменить посадочное место в библиотеке, чтобы обновить экземпляр компонента, размещенный на плате.

Названия механических слоев можно редактировать непосредственно в панели View Configurations, выбрав Edit Layer из контекстного меню слоя.

Распространенным подходом к управлению использованием механических слоев является назначение определенного номера слоя каждому механическому слою, выполняющему определенную функцию. Этот подход требует ото всех проектировщиков использования одной и той же схемы назначения и нумерации слоев. Это может привести к трудностям при использовании компонентов, полученных из других источников, которые не следует этой схеме назначения и нумерации. Если используется другая схема, то необходимо переместить объекты с текущего механического слоя на нужный механический слой, которому назначена соответствующая функция.

Эта проблема решена реализацией свойства Layer Type. При размещении компонента из библиотеки в редактор плат, копировании из одной библиотеки в другую или создании с помощью IPC Footprint Wizard, происходит автоматическое сопоставление по существующим типам слоев, независимо от номеров механических слоев, заданных слоям этих типов. Объекты размещаются на нужных слоях в соответствии с типами этих слоев. Если система не может произвести сопоставление по типу слоя, будет произведено сопоставление по номеру слоя.

Как для отдельных механических слоев, так и для пар слоев компонентов, вы можете выбрать тип слоя из предопределенного списка типов. Вы можете открыть диалоговые окна, показанные ниже, щелкнув ПКМ по отдельному слою и выбрав команду Edit Layer или Add Component Layer из меню.

  Выберите тип слоя из предопределенного списка. На первом изображении показаны отдельные механические слои; на втором изображении показаны пары слоев компонентов; на третьем изображении показан новый слой компонента.

Для получения более подробной информации о типах механических слоев, относящихся к компонентам, перейдите на страницу Работа с механическими слоями.

Определение высоты посадочного места

На самом простом уровне 3D-представления, посадочному месту можно добавить информацию о высоте. Для этого дважды щелкните ЛКМ по посадочному месту в списке Footprints в панели PCB Library, чтобы открыть диалоговое окно PCB Library Footprint. Введите нужную высоту компонента в поле Height.

На этапе конструирования платы можно определить правила проектирования для высоты (выберите Design » Rules в редакторе плат), которые, как правило, проверяют максимальную высоту компонентов в классе компонентов или внутри комнаты (Room).

Более хорошим подходом к определению высоты компонента является добавление объектов 3D Body и/или модели STEP в посадочное место. Более подробно об этом сказано в других разделах.

Добавление посадочного места из других источников

Посадочные места можно скопировать из других библиотек, после чего переименовать их и изменить в целевой библиотеке в соответствии с требованиями. Есть ряд способов использования этой функции.

  • Выберите размещенные посадочные места в документе платы, затем скопируйте (Edit » Copy) и вставьте их в открытую библиотеку посадочных мест с помощью команды Edit » Paste Component.
  • Выберите команду Edit » Copy Component, когда посадочное место, которое необходимо скопировать, является активным в редакторе библиотек посадочных мест, переключитесь на целевую библиотеку посадочных мест и выберите команду Edit » Paste Component.
  • Выберите одно или множество посадочных мест в списке панели с помощью стандартных сочетаний клавиш Shift+ЛКМ или Ctrl+ЛКМ, щелкните ПКМ и выберите команду Copy. Переключитесь на целевую библиотеку, щелкните ПКМ в списке названий посадочных мест и выберите команду Paste.

Валидация посадочных мест компонентов

Существует ряд отчетов, которые можно запустить для проверки того, что посадочные места были созданы корректно, а также для определения того, какие компоненты находятся в текущей библиотеке посадочных мест.

Отчет Component Rule Check (Reports » Component Rule Check) полезен для валидации всех компонентов в текущей библиотеке посадочных мест на предмет дубликатов примитивов, потерянных обозначений контактных площадок, неподключенных проводящих объектов и неподходящих ссылок на компоненты.

Валидация библиотек посадочных мест в интегрированной библиотеке

Добавление библиотек посадочных мест в пакет интегрированной библиотеки обеспечивает дополнительный уровень валидации, поскольку в этом случае компилятор может проверить модели схемы и платы вместе. Для этого, конечно, необходимо, чтобы библиотека схемных символов соответствовала библиотеке посадочных мест, но в этом случае доступен ряд дополнительных настроек на вкладке Error Reporting диалогового окна Project Options.

Обновление посадочного места

Доступно два способа обновления посадочного места: передача изменений из редактора библиотек посадочных мест в редактор плат либо принятие изменений в редактор плат. Для передачи изменений из библиотеки необходимо выделить здесь посадочные места и обновить все открытые документы плат, в которых находятся эти посадочные места. Этот метод наилучшим образом подходит, когда нужна полная замена. Второй вариант позволяет просмотреть все различия между существующим посадочным местом и посадочным местом в библиотеке перед проведением обновления. Вы также можете выбрать, какие объекты необходимо обновить из библиотеки. Этот метод наилучшим образом подходит, когда необходимо точно понять различия между посадочным местом на плате и посадочным местом в библиотеке.

Передача изменений из редактора библиотек посадочных мест

В редакторе PCBLIB используйте команду Tools » Update PCB with Current Footprint или Tools » Update PCB With All Footprints. В панели PCB Library щелкните ПКМ в области Components и выберите команду Update PCB with [Component] или Update PCB with All. При запуске любой из этих команд будет открыто диалоговое окно Component(s) Update Options, в котором вы можете выбрать, какие примитивы/атрибуты должны быть обновлены.

Выбранные обновления будут применены к соответствующим посадочным местам во всех открытых документах плат.

Принятие изменений в редактор плат

В редакторе плат выберите команду Tools » Update From PCB Libraries, после чего будет открыто диалоговое окно Update From PCB Libraries - Options. Нажмите OK, чтобы открыть диалоговое окно Update From PCB Libraries.

Выпуск завершенных посадочных мест на сервер

2D/3D-модели посадочных мест можно отредактировать и выпустить в качестве начальной ревизии нового созданного объекта Footprint Item с помощью поддержки сервером прямого редактирования через панель Explorer или с помощью редактора Component Editor в режиме Single Component Editor. Через прямое редактирование вы можете изменить поддерживаемый тип объекта с помощью временного редактора, в который загружается самая новая информация непосредственно с сервера. По завершении редактирования объект будет выпущен (или выпущен повторно) в следующую запланированную ревизию родительского объекта, и временный редактор будет закрыт.

Для получения более подробной информации об управляемых посадочных местах перейдите на страницу Управляемые модели посадочных мест.
Обнаружили проблему в этом документе? Выделите область и нажмите Ctrl+Enter, чтобы оповестить нас.

Связаться с нами

Связаться с нашими Представительствами напрямую

Вы сообщаете о проблеме, связанной со следующим выделенным текстом
и/или изображением в активном документе:
Бесплатная пробная версия Altium Concord Pro

Заполните форму ниже, чтобы получить бесплатную пробную версию Altium Concord Pro