Working with PCB Libraries in Altium Designer

Created: June 20, 2022 | Updated: June 20, 2022

Parent page: Working with File-based Component Libraries

This document outlines the creation of PCB footprints (including adding 3D body objects) using the PCB footprint editor.

The following topics are covered:

  • Creating PCB component footprints manually and using the Footprint Wizard.
  • Handling other special footprint requirements, including irregular pad shapes.
  • Including three-dimensional component detail (3D bodies).
  • Checking the component footprints using PCB footprint editor reports.

This information assumes you have a working knowledge of the PCB editor environment and are familiar with placing and editing components. 

Creating PCB Component Footprints

Footprints are always built on the top side, regardless of which final side of the board they are placed. Layer-specific attributes, such as surface mount pads and solder mask definitions, are automatically transferred to appropriate bottom-side layers when you flip the footprint to the other side of the board during component placement.

This section covers the following topics:

  • Creating a new PCB library.
  • Using the Footprint Wizard to create a footprint for a schematic component.
  • Manually creating a footprint.
  • Other special footprint requirements, including irregular pad shapes.
  • Including three-dimensional component body detail (3D bodies).

Footprints can be copied from the PCB editor into a PCB library, copied between PCB libraries, or created from scratch using the Footprint Wizard or drawing tools. If you have a PCB design with all the footprints already placed, you could use the Design » Make PCB Library command in the PCB editor to generate a PCB library that includes only those footprints. Altium Designer also includes comprehensive libraries (*.PcbLib) of predefined through-hole and SMD component footprints for use in designing PCBs. 

The footprints that are created manually in this section are only to illustrate the procedures required; they are not dimensionally accurate. Always check the specifications of a new footprint against the manufacturer's datasheet.

Creating a New PCB Library

To create a new PCB library:

  1. Select the File » New » Library command from the main menus and selecting the PCB Library option from the File region of the New Library dialog. After clicking Create, a new PCB library document named PcbLib1.PcbLib is created and an empty component sheet called PCBComponent_1 displays.
  2. Rename the new PCB library document to PCB Footprints.PcbLib, for example, by selecting File » Save As. The new library PCB Footprints.PcbLib displays in the Projects panel.
  3. Open the PCB Library panel.
  4. Click once in the PCB footprint editor design space and press Page Up or Page Down as needed until you can see the grid.

You are now ready to add, remove, or edit the footprint components in the new PCB library using the PCB footprint editor commands.

The default is to display the grids using dots. If you prefer, grids can be displayed using lines. This is configured in the Grid Editor dialog, accessed by clicking the Properties button in the Properties panel as shown in the image below. Alternatively, press the Ctrl+G shortcut to open the dialog.

In the image, the fine grid is displayed as dots, and the coarse grid is displayed as lines.

Using the Footprint Wizard

The PCB footprint editor includes a Footprint Wizard that will build a component footprint using information you supply. We will use the Wizard to create a footprint for a DIP14.

Perform the following steps to create the new component footprint DIP14 using the Footprint Wizard:

  1. Select Tools » Footprint Wizard from the main menus. The Footprint Wizard opens. Click Next to progress through the pages of the Wizard.

  1. Select Dual in-line Packages (DIP) and Imperial (mil) on the Component patterns page.

  1. Select each dimension and type in the new dimensions as shown below: 60mil for the round pads and 32mil for the hole dimension.

  1.  Select and type the new pad to pad distances as shown below: 300mil (horizontal) and 100mil (vertical).

  1. Leave the outline width page at the default setting as shown below.

  1. Set the number of pads to 14 on the following page as shown below.

  1. On the next page, ensure the name is displayed as DIP14 as shown below.

  1. Click Finish on the last page of the Wizard. The filename of the new footprint (DIP14) will appear in the Footprints list in the PCB Library panel and the new footprint will display in the design window, as shown in the following images. 

  1. Click File » Save from the main menus to save the library with its new footprint component.

Using the IPC® Compliant Footprint Wizard

You also can create component footprints using the IPC Compliant Footprint Wizard. Rather than requiring you to enter the properties of the pads and tracks that are used to define the footprint, the IPC® Compliant Footprint Wizard takes the actual component dimensions as its inputs. Based on the formulae developed for the IPC-7351 standard, the Wizard generates the footprint using standard Altium Designer objects, such as pads and tracks. The Wizard is launched from the PCB footprint editor by clicking Tools » IPC Compliant Footprint Wizard. Click Next to progress through the pages of the Wizard, setting the options as desired on each page.

 

The IPC Compliant Footprint Wizard builds the footprint based on the component dimensions.

Manually Creating a Footprint

Footprints are created and modified in the PCB footprint editor using the same set of tools and design objects available in the PCB editor. Anything can be saved as a PCB footprint, including corner markers, photo tool targets, and mechanical definitions. Once a footprint has been placed onto a PCB, you can set the Type property, defining it as Graphical or Mechanical if required. 

To create the component footprint, we will place pads to form the component pin connections then place tracks and arcs for the outline. Design objects can be placed on any layer, however, the outline is normally created on the Top Overlay (silkscreen) layer and the pads on the multi-layer (for thru-hole component pins) or the top signal layer (for a surface mount component pins). When you place the footprint on a PCB, all objects that make up the footprint will be assigned to their defined layers.
To manually create a footprint suitable for the NPN transistor:

  1. Before creating the footprint, check that the units and grids are suitable. Click in the design space then choose Tools » Document Options from the main menus to open the Properties panel in Library Options mode. In the Other region, ensure that Units is set to mils. In the Snap Options region, enable Grids and All Layers. In the Grid Manager region, double-click on a listed item to open the Cartesian Grid Editor dialog. In the Steps region, set Step X and Step Y to 10mil using the associated drop-downs. The "link" icon must be set to  in order to access both Step X and Step Y settings.
You need to set the grid to suit the spacing required by the pads in the footprint you are creating.
To change the snap grid while you are working, press Ctrl+G
  1. To create an empty component footprint design space, click Tools » New Blank Footprint (shortcut T, W) from the main menus.
  1. To rename the default blank footprint, double-click on its name in the PCB Library panel to open the PCB Library Footprint dialog. Enter the same name as the one used earlier in the tutorial (BCY-W3).
It is recommended that you build the footprint around the design space 0, 0 reference point indicated by the origin marker. Use the shortcut J, R to jump the cursor to the origin at any stage while you are working. The reference point is the place at which you will be 'holding' the component when you place it. Typically, the reference point is either the center of pad 1 or the geometric center of the component. The reference point can be set to either of these at any time using the Edit » Set Reference sub-menu options.

Placing Pads on a New Footprint

The Properties panel in Pad mode includes a viewer in the Pad Stack region that allows you to inspect the pad shapes on the defined layers (select the desired layer from the Layer drop-down in the Properties region of the panel). You can define normal round, rectangular, octagonal, rounded rectangle (oval), or Hole Size in pads and toggle their Plated property and all the work needed to support thermal reliefs generation, clearances calculation, output to Gerber, ODB++, and NC Drill, for example, will be automatically handled. The NC Drill Output (NC Drill Excellon format 2) will generate up to six different NC files for three different hole kinds and whether or not they are plated or non-plated.

One of the most important procedures in creating a new component footprint is placing the pads that will be used to solder the component to the PCB. These must be placed in exactly the right positions to correspond to the pins on the physical device.

To place the pads:

  1. Select Place » Pad (shortcut P, P) or click  on the Active Bar or on the PCB Lib Placement toolbar. A pad will appear floating on the cursor. Before placing the first pad, press the Tab key to open the Properties panel in Pad mode to define the pad properties.
  2. Edit the various regions of the panel as shown in the following image. This creates a stretched round pad.

  1. Using the coordinates displayed in the Status bar, position the first pad at X:0, Y:-50 then click or press Enter to place.
  1. After placing the first pad, another will appear on the cursor. Position the cursor at X:0, Y:0 then click to place the second pad. The pad designator is automatically incremented.
  2. Position the cursor at X:0, Y:50, then click to place the third pad.
  3. Right-click or press Esc to exit pad placement mode. The three pads should resemble the following image.

  1. Save the footprint by selecting File » Save (shortcut Ctrl+S).
For a surface mount pad, in the Properties panel in Pad mode, using the Layer drop-down in the Properties region, set the layer to Top Layer. For a thru-hole pad that has different size requirements for each layer, use the Pad Stack settings in the panel.

Pad Designators

Pads can be labeled with a designator (usually representing the component pin number) of up to 20 alphanumeric characters. The designator can be left blank if desired. If the designator begins or ends with a number, the number will auto-increment when placing a series of pads sequentially. To achieve alpha increments, e.g,. 1A, 1B, or numeric increments other than 1, use the Setup Paste Array dialog (click the Paste Array button in the Paste Special dialog (Edit » Paste Special)).

Paste Array Feature

By setting the designator of the pad prior to copying it to the clipboard, you can use the Setup Paste Array dialog to automatically apply a designation sequence during pad placement. By using the Text Increment field in the Setup Paste Array dialog, the following pad designator sequences can be placed:

  • Numeric (1, 3, 5)
  • Alphabetic (A, B, C)
  • Combination of alpha-numeric (A1 A2, 1A 1B, A1 B1, or 1A 2A, etc.)

To increment numerically, set the Text Increment field to the amount by which you want to increment. To increment alphabetically, set the Text Increment field to the letter in the alphabet that represents the number of letters you want to skip. For example, if the initial pad has a designator of 1A, set the field to A, (first letter of the alphabet) to increment designators by 1. If you set the field to C (third letter of the alphabet), the designators will become 1A, 1D (three letters after A), 1G, etc.

Drawing the Outline on the Component Overlay

The outline that appears on the PCB silkscreen is defined on the Top Overlay layer. If the component is flipped to the bottom of the board during placement, the overlay is automatically transferred to the Bottom Overlay layer.

  1. Click on the Top Overlay layer tab at the bottom of the main editing window before placing overlay objects such as arcs or lines (tracks).
  2. To place the arc, select Place » Arc (Center) from the main menus, or select the  from the Active Bar or PCB Lib Placement toolbar. Position the cursor at X:0, Y:0 then click to define the arc center and edit the placed arc through the settings in the Properties panel in Arc mode (the panel opens automatically when in placement mode).
If you know the arc radius and start and end angles, it is easier to complete the arc placement without trying to interactively define these settings.
  1. Click to approximately define the arc radius, then click to define the arc start angle. Click again to define the arc end angle. Right-click to exit arc placement mode. The placed arc is shown in the following image.

 

  1. Set the arc properties in the Properties panel as follows: Width = 6mil, Radius = 105mil, Start Angle = 55, End Angle = 305.
  1. To place the line, click Place » Line (shortcut P, L), or click the  button on the Active Bar or on the PCB Lib Placement toolbar. Position the cursor near the end of the arc and press Page Up to zoom in. Click to start the line segment.
  2. Press Tab to open the Properties panel in Line Placement mode. Set the Line Width to 6mil and Current Layer to Top Overlay.
  3. Move the mouse until it is over the other end of the arc, then click again to define the end of the line. During line placement, you can cycle through the different line corner modes by pressing the Shift+Spacebar key combination.
  4. To exit line placement mode, right-click or press Esc. The completed arc is shown in the following image.

Creating Footprints with an Irregular Pad Shape

There will be situations when you need to create a footprint with pads that have an irregular shape. This can be done using any of the design objects available in the PCB footprint editor, but there is an important factor that you must keep in mind. The software automatically creates solder and paste masks based on the shape of pad objects. If you use pad objects to build an irregular shape, the matching irregular mask shape will be generated correctly. If you build the irregular shape from other objects, such as lines (tracks), fills, regions, or arcs, you also will need to define any required solder or paste masks by placing suitably enlarged or contracted objects on the solder mask and paste mask layers.

You can learn more about custom pad shapes here

Managing Components that Include Routing Primitives in their Footprint

When you transfer a design, the footprint specified in each component is extracted from the available libraries and placed on the board. Then each pad in the footprint has its net property set to the name of the net connected to that component pin in the schematic. If the footprint includes copper primitives touching the pads, these primitives will not be assigned the net name automatically and will create a design rule violation. In this case, you will need to perform an update process to assign the net name. The PCB editor includes a comprehensive net management tool that is launched by selecting Design » Netlist » Configure Physical Nets from the main menus. In the Configure Physical Nets dialog, click in the New Net Name region to select the net to assigned to the unassigned primitives.

Footprints with Multiple Pads Connected to the Same Pin

The footprint shown in the image below has multiple pads that are connected to the same logical schematic component pin. For this component, both of the two mounting hole pads have the same designator of '3'. When the Design » Update PCB command is used in the schematic editor to transfer design information to the PCB, the resulting synchronization will show the connection lines going to both pads in the PCB Editor, i.e. they are on the same net. Both of these can be routed.

TO-3 footprint showing two pads with a designator of 3 on the same net.

Handling Special Solder Mask Requirements

The footprint shown in the following image is the contact set for a push button switch, which is implemented directly in the copper on the surface layer of the PCB.

Printed push button footprint, designed by placing pads, lines and arcs.

A rubber switchpad overlay is placed on top of the PCB with a small captive carbon button that contacts both sets of fingers in the footprint when the button is pressed, creating the electrical connectivity. For this to happen, both sets of fingers must not be covered by the solder mask. The circular solder mask opening has been achieved by placing an arc whose width is equal to or greater than the arc radius, resulting in the solid circle shown behind the two sets of fingers. Each set of copper fingers has been defined by an arc, horizontal lines, and a pad. The pads are required to define the points of connectivity. Manually placed solder mask definitions are automatically transferred when the component is placed on the bottom of the board.

Other Footprint Attributes

Solder and Paste Masks

Solder and paste masks are created automatically at each pad site on the Solder Mask and Paste Mask layers, respectively. The shape that is created on the mask layer is the pad shape, expanded or contracted by the amount specified by the Solder Mask and Paste Mask design rules set in the PCB editor or as specified in the Properties panel in Pad mode.

Pads with the solder mask displayed.

When you edit a pad, you see the settings for the solder mask and paste mask expansions. While these settings are included to give you localized control of the expansion requirements of a pad, you will not normally need them. Generally, it is easier to control the paste mask and solder mask requirements by defining the appropriate design rules in the PCB editor. Using design rules, one rule is designed to set the expansion for all components on the board, then, if required, you can add other rules that target any specific situations, such as all instances of a specific footprint type used on the board, or a specific pad on a specific component, etc.

Displaying the Masks

To check the solder and/or paste masks have been automatically defined in the PCB footprint editor, click the Top Solder layer tab at the bottom of the main design window and examine the contents.

To make the mask layers visible, open the View Configuration panel and enable the  for each mask layer.

The ring that appears around the edge of each pad in the color of the Top Solder Mask layer represents the edge of the solder mask shape protruding by the expansion amount from under the multi-layer pad because multi-layer is at the top of the layer drawing order; it is drawn on top. The Layer Drawing Order is set on the PCB Editor - Display page of the Preferences dialog).

Setting Mask Expansions by Design Rules

To set the mask expansions in the design rules:

  1. Confirm that the Rule option is selected in the Paste Mask Expansion and/or Solder Mask Expansion regions of the Properties panel in Pad mode.
  2. With a PCB open (you can create a temporary new PCB file if you do not have a PCB open) select Design » Rules from the main menus and examine the Mask category design rules in the PCB Rules and Constraints Editor dialog. These rules will be obeyed when the footprint is placed in the PCB. Note: The rule system is hierarchical; you can define a higher priority rule to selectively override the general rule that applies to the entire board if required.

Manually Specifying Mask Expansions

To override the expansion design rules and specify a mask expansion as a pad attribute:

  1. Select Manual in the Paste Mask Expansion and/or Solder Mask Expansion sections of the Properties panel in Pad mode.

  1. Type the required value(s) then save the footprint.

Designator and Comment Strings

Default Designator and Comment Strings

What you are building in the library is a footprint. When that footprint is placed on a board, it is given a designator and comment and is then referred to as a component. You do not need to manually define placeholders for the designator and comment strings when you build the footprint since these are added automatically when the footprint is placed on a board. The locations of these strings are determined by the designator and comment string Autoposition options in the Properties panel in Parameter mode when the designator or comment string is selected in the design space. You can pre-define the required string position (and size) on the PCB Editor - Defaults page of the Preferences dialog.

Additional Designator and Comment Strings

There may be situations when you would like additional copies of the designator or comment strings. As an example, your assembly house wants a detailed assembly drawing with the designator shown within each component outline, while your company requires the designator to be located just above the component on the component overlay on the final PCB. This requirement for an additional designator can be achieved by including the .Designator special string in the footprint (there is also a .Comment special string). To satisfy your assembly house requirement, you would place the .Designator string on a mechanical layer in the library editor, then generate a printout that included this layer. If you need this feature:

  1. Display the required mechanical layer by ensuring the is enabled for each mechanical layer in the View Configuration panel.

  1. Click on the Mechanical layer tab at the bottom of the main design window to activate this layer. The tab will be highlighted and all new text will be placed on this layer.
  2. Select Place » String (shortcut P, S) from the main menus or click  on the Active Bar.
  3. Press the Tab key to pause placement. Enter ".Designator" in the Text field in the Properties region of the Properties panel (in Text mode). Set Text Height to 40mil and Width to 6mil in the diagram. The bottom left corner of the actual designator will locate where the dot in the .Designator string is located.
  4. Now we can place the text string. Press the spacebar to rotate the text string, position it in the required location then click to place it. Right-click or press Esc to exit string placement mode.
  5. If required, place the .Comment special string using the same procedure.
  6. To test the special strings, place the footprint on a PCB. You can place the footprint by right-clicking on its name in the PCB Library panel then selecting Place

Handling Special Layer-specific Requirements such as Glue Dots

There are a number of special requirements a PCB component can have, such as needing a glue dot or a peel-able solder mask definition. Many of these special requirements will be tied to the side of the board on which the component is mounted, and must flip to the other side of the board when the component is flipped. Rather than including a large number of special purpose layers that may rarely be used, Altium Designer's PCB editor supports this requirement through a feature called layer pairs. A layer pair is two mechanical layers that have been defined as a pair. Whenever you flip a component from one side of the board to the other, any objects on a paired mechanical layer are flipped to the other mechanical layer in that pair. Using this approach, you select a suitable mechanical layer to include the glue dot (or other special requirement) and define its shape using the available objects. When you place that footprint onto a board, you must set up the layer pairing. This instructs the software which layer it must transfer objects to when this component is flipped to the other side of the board. You cannot define layer pairs in the PCB footprint editor; this is done in the PCB Editor.

Including Three-Dimensional Component Detail

Given the density and complexity of today's electronic products, today's PCB designer must consider more than the horizontal component clearance requirements. You must also consider height restrictions and component-under-component placement options. There is also the need to transfer the final PCB to a mechanical CAD tool where a virtual product assembly can verify the complete packaging of the product being developed. Altium Designer includes a number of features, including realistic 3D visualization for these different situations.

Adding Height to a PCB Footprint

At the simplest level, you can add a height attribute to your footprint. To do this, double-click on the footprint in the Footprints list in the PCB Library panel to open the PCB Library Footprint dialog. Enter the desired height for the component in the Height field.

Height design rules can be defined during board design (click Design » Rules in the PCB editor), typically testing for maximum component height in a class of components or within a room definition.

Adding a 3D Body to a Footprint

For more realistic component rendering in 3D view mode, you can add 3D body objects to the footprint. 3D bodies can be added to a footprint on enabled mechanical layers only. An extruded (simple) 3D body is a 2D polygon-type object that has surface color and a height attribute to pull or extrude the shape when rendered in 3D. 3D bodies can also be created as spheres or cylinders. One or more 3D bodies can be combined to define the physical size and shape of a component in all directions and are used by the Component Clearance design rule. Using high accuracy 3D models improves component clearance checking accuracy and generally improves the visual appeal and realism of the finished PCB assembly. Altium Designer supports directly importing 3D STEP models (*.step or *.stp files), Parasolid Models (*.x_t and *.x_b), and SolidWorks parts (*.SldPrt) into PCB footprints to render the 3D model. This functionality extends to having models either embedded or linked to Altium Designer PCB documents, however, linked models are not available in the PCB footprint editor.


3D bodies will flip to the other side of the board when the component is flipped. However, if you want the 3D body data (which is stored on a mechanical layer) to also be flipped onto another mechanical layer, you will need to define a layer pair in the PCB document as discussed in the section Handling Special Layer-Specific Requirements Such as Glue Dots.

Manually Placing 3D Bodies

3D bodies can be placed manually in the PCB footprint editor by clicking Place » 3D Body from the main menus or by selecting  from the Active Bar. They also can be added automatically to footprints in the PCB footprint editor (and to placed footprints in the PCB editor) using the Component Body Manager dialog (Tools » Manage 3D Bodies for Current Component).

You can place 3D bodies in either 2D or 3D modes.

We will now add a 3D body to footprint DIP14, which was created previously in this document. To manually place a 3D body in the PCB footprint editor:

  1. In the PCB Library panel, double-click the DIP14 entry to open the PCB Library Footprint dialog. The height of the component is important since we need to make the 3D body representative of the actual height.

  1. Click Place » 3D Body from the main menus or select  from the Active Bar. After launching the command, the Properties panel opens in 3D Body mode. Click Tab to pause placement and set the 3D Body properties.
  2. Select Extruded in the 3D Model Type region.
  3. Use the controls in the Properties region to give the 3D body object an identifying name (Identifier), set the Board Side (which side of the board the 3D body should project vertically) to Top. Note: You can enter a negative standoff height for components that protrude through the PCB, such as pins. Standoff heights are not checked by the Design Rules Checker.
  4. Define the Overall Height as 200mil and Standoff Height (distance from the board to the underside of the 3D body) to 0mil; enable the Override Color checkbox, then set the color box to a suitable color.
  1. Click the  or Esc to re-enter placement mode. The cursor will change to a crosshair in 2D, or a blue-cone cursor in 3D.
  2. Position the cursor then click to anchor the starting point for the body; continue to anchor a series of vertex points that define the polygonal shape of the body.
  3. After placing the final vertex point, right-click or press Esc to complete placement of the body. There is no need to "close" the polygon as the software will automatically complete the shape by connecting the start point to the final point placed.
  4. While defining the shape, use Shift+Spacebar to cycle through various corner modes. Modes available are any angle, 45°, 45° with arc, 90°, and 90° with arc. Arcs can be increased or decreased in radius using Shift+. (period) or Shift+, (comma), respectively. Use the Spacebar to toggle the direction of the corner.
When an extruded 3D body object is selected, editing handles are displayed at each vertex. When the cursor changes to arrows over a handle, click and drag to move the vertex. When this cursor appears over the middle of an edge, click&drag to add a vertex to that edge and move it.
  1. Use the Backspace key while in placement mode to remove the last placed vertex point. Repeatedly use Backspace to 'unwind' the outline for the polygon back to the initial starting point. You can design and add more 3D bodies for further component detail. Continue placing further 3D bodies or click Cancel or press Esc to exit placement mode. 

DIP-14 3D representation

  1. To view the 3D body in 3D at any time, press 3 to enter 3D viewing mode. If you cannot see the 3D body, press L to open the View Configuration panel. Ensure the 3D option is set to On in the General Settings region on the View Options tab.

Interactively Creating 3D Bodies

Interactively creating 3D body objects from a footprint is very similar to the manual method. The basic difference is to use Altium Designer to detect closed shapes that can be used to "extrude" into 3D bodies from the existing objects that comprise the footprint details. This is accomplished through the Component Body Manager dialog.


Only closed polygons will create 3D body objects.

The Component Body Manager dialog is used to define a 3D body for the transistor package TO-39. Using this approach is easier than attempting to define the shape manually because of the curved shape and orientation tab of the package body. To use the dialog:

  1. Make the DIP14 footprint the active footprint in the PCB Library panel.
  2. Select Tools » Manage 3D Bodies for Current Component to open the Component Body Manager dialog.


  1. To create a shape that follows the outline defined on the component overlay, click to select Polygonal shape created from primitives on TopOverlay. Click the entry in the Body State column to add the component, set the Registration Layer to the mechanical layer on which the body object should be placed (Mechanical 1 in this case), set the Overall Height to a suitable value, then click the entry in Body 3D Color to open the Choose Color dialog and select a suitable color.
Scroll through the list to select any closed polygons that you want to use to define the component model.
  1. Close the Component Body Manager dialog. The 3D body shape will appear on the component. Save the library.
  2. To edit a 3D body, right-click on it in the PCB editor then select Component Actions » Manage 3D Bodies from the context menu to open the Component Body Manager dialog. You also can use the PCBLIB List panel (shown in the following image) to display 3D bodies and edit them directly.

Importing a STEP Model as a 3D Body

Many component vendors supply detailed 3D models for use in popular mechanical CAD packages. Altium Designer can import 3D STEP models (.step or .stp), SolidWorks parts (*.SldPrt), and Parasolid Models (*.x_t and *.x_b) directly into a component footprint. This saves time in creating the model yourself and also may provide a more sophisticated model.

Linked Models

Linked models are not supported in the PCB footprint editor. Embedded models are supported.

Importing Models

To import a model, perform the following steps:

  1. Click Place » 3D Body (shortcut P, B) from the main menus or click  on the Active Bar to open the Properties panel in 3D Body mode.
  1. In the 3D Model Type region, select Generic.
  2. In the Source region, select Embed Model. Click Choose to search for and select the desired .step or .stp file. 
  3. The 3D body appears floating on the cursor.
  4. Click in the design space to place the 3D body object with the selected model loaded into it.

Positioning and Orienting Models

When a model has been imported, the placeholder 3D body re-sizes to house the model. The model may not be oriented correctly in relation to the axes of the PCB document due to the origin used in the originating application. There are several methods for graphically positioning models, using reference points (known as snap points) placed on the model to manipulate it and using faces or surfaces on the model in relation to the board. 

Adding Footprints from Other Sources

You can copy existing footprints into your PCB library. The copied footprint can then be renamed and modified to match the specifications required. The following are different ways to copy existing footprints to your PCB library:

  • Select placed footprint(s) in a PCB document then copy (Edit » Copy) and paste them into an open PCB library using Edit » Paste Component.
  • Select Edit » Copy Component when the footprint to be copied is active in the PCB footprint editor. Change to the open PCB destination library, then select Edit » Paste Component.
  • Select one or more footprints in the PCB Library panel using standard Shift+Click or Ctrl+Click, right-click then choose Copy. Switch to the target library then right-click in the list of footprint names and choose Paste.

Compiling Component Footprints

As in the schematic symbol editor, there are a series of reports that you can run to check that the footprints have been created correctly and identify which components are in the current PCB library. To compile all components in the current PCB library, run the Component Rule Check report. The Component Rule Check tests for duplicate primitives, missing pad designators, floating copper, and inappropriate component reference. To run the Component Rule Check:

  1. Save your library file before running any of these reports.
  2. Select Reports » Component Rule Check (shortcut R, R) to open the Component Rule Check dialog.

  1. Check all the boxes available then click OK. A report titled PCB<libraryfilename>.ERR is generated and opens in the Text Editor. Any errors will be noted.
  2. Close the report to return to the PCB footprint editor.

PCB Library Panel

The PCB Library panel enables you to browse footprints stored in the active PCB library document and edit their properties. When a PCB Library document is active, the panel becomes populated with information pertaining to the constituent footprints of that library. The panel also offers the ability to pass on any changes made to them directly to the PCB design document.

The PCB Library panel
The PCB Library panel

Library Browsing

The panel has three main sections, each offering a different scope or view of the footprints in the active PCB Library:

  • Footprints - a list of footprints in the active library. The number of pads and primitive objects used to define the footprint is listed for each entry.
  • Footprint Primitives - the primitive objects and their main properties that make up the currently selected footprint.
  • Other - a simplified, overall view of the currently selected footprint with the main editor view indicated by an overlay graphic.

As a footprint is selected in the panel, its constituent primitives populate the Footprint Primitives section and the footprint is displayed in the main editor workspace. Selecting a primitive object in the panel causes the corresponding object to be highlighted in the editor workspace. In this way, the PCB Library panel offers a fast and easy way to browse, view and access PCB library footprints.

Double-clicking on a Footprint entry opens the PCB Library Footprint dialog, and double-clicking on a Footprint Primitives entry will access its corresponding Properties panel - see more options in the Right-Click Menus section below.

Filtering Content

The contents of the list can be filtered, enabling you to quickly find a particular footprint within the library. This is especially useful if the library contains a large number of items. Filtering can be applied using the following methods:

Indirect Filtering

This method uses the Mask field at the top of the panel to filter the contents of the list. Masking is applied based on the entry in the field. Only those footprints in the list targeted by the scope of the entry will remain displayed.

Note that the Mask field is not case sensitive. To list all footprints again, clear (delete) the entry in the Mask field.

Use the * wild card operator for more elaborate filtering. For example, typing m* will display only footprints whose names begin with m, or as in the image below, typing *16 will display only footprints that contains 16 in the name.

Direct Filtering

This method is available for all list regions in the panel and allows you to quickly jump to an entry by directly typing within the area of the list. Masking is not applied, leaving the full content of the list visible at all times.

To use the feature to quickly find a footprint, click inside the Footprints section of the panel then type the first letter of the footprint to which you want to jumps. For example, if you wanted to quickly jump to footprint entries starting with the letter S, you would press "S" on the keyboard. The first footprint in the list starting with S will be made active, and the letter will be highlighted to indicate that filtering of the list is based upon it.

If there are multiple footprints starting with the same letter and especially if the library is particularly large, type additional letters to target the specific entry you require, for example, "SO" as shown below.

To clear the current filtering allowing you to enter a different starting letter, press Esc. Use the Backspace key to clear the previously entered filter characters in sequence.

Combination Filtering

In some situations, it may be helpful to use Indirect and Direct filtering together. If, for example, you recall that the footprint you want to locate has a sub-type number of 4 and a prefix of PO, this information can be used as Indirect (Mask) and Direct entries.

Footprints Controls

  • Place - click to place the selected footprint.
  • Add - click to add a new footprint to the list. The default name will be PCBCOMPONENT_1.
  • Delete - click to delete the selected footprint. A dialog will open asking for confirmation before the delete occurs.
  • Edit - click to open the PCB Library Footprint dialog to edit the selected footprint.

Browsing Footprint Primitives

The Footprint Primitives section lists all primitive objects that constitute the footprint currently selected in the Footprints list. For each primitive entry, the following information is displayed:

  • Type - the type of primitive object (e.g., pad, track, arc, etc.).
  • Name - the specified value for the objects' designator (where one exists).
  • X-Size - the X dimension of the object (e.g., the width of an arc, track or fill, the X-Size value of a pad).
  • Y-Size - the Y dimension of the object (e.g., the height of a fill, the Y-Size value of a pad). This field will be empty for a track or arc.
  • Layer - the layer upon which the object resides.

As individual object primitives are selected in the panel, the matching object (track, arc, pad, etc.,) is graphically highlighted in the editor workspace.

Controlling the Display of Browsed Entries in the Workspace

Selecting an entry in either panel list region applies a filter, essentially using the entry as its scope. The visual result of the applied filtering on the document in the design editor window is determined by a series of highlighting controls located at the top of the panel.

  • Mask / Dim / Normal - provides the options for visibly contrasting filtered and unfiltered objects within the design editor window. The effectiveness of masking and dimming is determined by the Highlighting Options set in the PCB Editor - Display page of the Preferences dialog.
    • When Mask is selected, filtered objects will appear visible in the design editor window, with all other objects being made monochrome. When this option is applied, unfiltered objects will be unavailable for selection or editing.
    • When Dim is selected, filtered objects will appear visible in the design editor window, with all other objects retaining their colors but shaded. 
  • Select - when enabled (default), the filtered objects will be selected in the workspace.
  • Zoom - when enabled (default), the filtered objects will be zoomed and centered (where possible) in the design workspace.
  • Clear Existing - when enabled (default), an existing filter will be cleared before applying a new one. Disabling this option allows you to extend an existing filter, essentially refining the filter further by applying a new filter in addition to the existing one.

Any combination of these options can be enabled. For example, you might want to have all filtered objects zoomed, centered and selected in the design workspace as well as applying masking to take away the clutter of other design objects. Use the Clear button to clear the currently-applied filter. All objects in the design workspace will become fully visible and available for selection/editing. If you want to re-apply the filter, click the Apply button.

Using the Panel's Mini-viewer

The bottom section provides a mini-viewer for the document, with an image of the active footprint central to its window. The area currently displayed in the design editor window is denoted by white hash marks as highlighted in the following image.

Click the Magnify button at the top of the panel to provide a floating magnifying glass and zoom cursor in the design editor window. As you move these around in the workspace, the mini-viewer in the panel will contain the magnified image of the active footprint centered on the cursor. This allows you to browse the document at full size in the design editor window, while looking at zoomed detail in the mini-viewer window.

Use the Page Up and Page Down keys to increase or decrease the magnification. Right-click, click or press Esc to exit magnify mode.

Right-click Menus

Footprints

  • New Blank Footprint - select to add a new footprint to the list. The footprint is given the default name PCBCOMPONENT_1 and a blank sheet is opened in the design editor window, ready for you to start placing the primitive objects that will define it.
  • Footprint Wizard - click to open the Footprint Wizard. The pages of the Wizard will guide you through the steps to creating a new component footprint. 
  • Cut - place a copy of the selected footprint(s) onto the PCB Library Editor's internal clipboard then permanently delete the footprint(s) from the library. A confirmation dialog will appear asking for verification to proceed with the deletion.
  • Copy - place a copy of the selected footprint(s) onto the PCB Library Editor's internal clipboard.
  • Copy Name - copy the name of the focused footprint to the PCB Library Editor's internal clipboard.
  • Paste - paste a footprint from the PCB Library Editor's internal clipboard into the active library document. The entry for this command will change to reflect how many valid footprints are on the clipboard. 
  • Delete - permanently delete the selected footprint(s) from the library document. A confirmation dialog will appear asking for verification of whether or not to proceed with the deletion.
  • Select All - quickly select all footprint entries in the list.
  • Footprint Properties - click to access the PCB Library Footprint dialog in which you can view/modify the Name, Height, Description, and Type for the focused footprint. The PCB Library Footprint dialog will also open when a footprint entry is double-clicked in the panel.
  • Place - place the focused footprint onto the PCB design document. When clicked, the last PCB to have been active (regardless of the project to which it belongs) will be made the active document in the design workspace.
  • Update PCB With <FocusedFootprint> - pass on changes made to the focused footprint within the library document to all open PCB design documents where that footprint has been placed. All instances of the footprint will be updated.
  • Update PCB With All - pass on all changes made to footprints within the library document to all open PCB design documents where these footprints have been placed. All placed instances of a changed footprint will be updated.
  • Report - generate a report for the active footprint. After launching the command, the report will be generated (LibraryName.CMP) in the same folder as the source PCB library document and will automatically be opened as the active document in the design editor window. The report lists information including footprint dimensions, a breakdown of the primitive objects that constitute the footprint, and the layers on which they reside.
  • Delete All Grids And Guides In Library - click to delete grids and guides for this library.

Footprint Primitives

  • Show Pads - enable to display pad entries.
  • Show Vias - enable to display via entries.
  • Show Tracks - enable to display track entries.
  • Show Arcs - enable to display arc entries.
  • Show Regions - enable to display region entries.
  • Show Component Bodies - enable to display component body entries.
  • Show Fills - enable to display fill entries.
  • Show Strings All - enable to display string entries.
The above listed commands will depend on the types of objects in the selected document. Other Show commands may also be available.
  • Select All - quickly select all footprint primitive entries in the list.
  • Report - generate a primitive information report for the focused footprint in the Footprints section of the panel. After launching the command, the Report Preview dialog will open containing the primitive information currently displayed in the Footprint Primitives region of the panel. Use the dialog to view, print and export the report in various file formats.
  • Properties - access the corresponding Properties panel for the focused primitive in which you can view and modify properties as required. The primitive's corresponding Properties panel also will open when a primitive entry is double-clicked in the panel.

Notes

  • Standard Ctrl+Click and Shift+Click functionality is supported for selection of multiple entries in a list.
  • The active footprint is that whose graphics are currently displayed in the design editor window. A footprint can be active without necessarily being selected and/or focused in the Footprints list.
  • Ctrl+Click over a selected entry in a list to deselect it. If the entry is the only one selected for that section, performing this action will clear the filter.
  • The keyboard shortcuts Up Arrow, Home, End, and Down Arrow can be used to display the previous, first, last, and next footprint, respectively.
  • In regions of the panel where multiple columns of data exist, the data may be sorted by any column by clicking on the header for that column. Clicking once will sort in ascending order; click again to sort by descending order.
  • You can change the order in which columns of data are displayed. To move a column, click on its header and drag it horizontally to the required position. A valid position is indicated by the appearance of two positional arrows.
  • The filtering applied when browsing design objects is permanent. If the Mask or Dim highlight method has been selected, all objects not falling under the scope of the filter will become faded (depending on settings) in the workspace and are not available for selection or editing. Clicking inside the design editor window will not clear the filter. A permanent filter must be cleared by clicking on the Clear button from within the panel.
  • The footprint that you paste into the active library document can originate from either a PCB design document or another PCB library document.
  • If multiple footprints have been copied to the clipboard from the main design in the PCB Editor, only the last footprint of the group to have been selected will be pasted into the library document.
  • If the same footprint is pasted into the library more than once or if more than one new footprint is added to the library without renaming, the copies are distinguished by the suffix - DUPLICATE, - DUPLICATE1, - DUPLICATE2, etc.
  • A PCB design document must be open before a library footprint can be placed using the Place command.
  • A PCB design document must be open in order to pass on changes made to footprints in the library document.
  • When a new PCB library document is created the panel will, by default, contain a single, blank footprint - PCBCOMPONENT_1.
  • Library footprints can be edited only in the source PCB library (*.PcbLib). You cannot edit the footprints in an integrated library (*.IntLib). You would have to de-compile the integrated library first then edit the required footprint(s) in the source PCB library document(s). The source can then be recompiled to produce the updated integrated library.
Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Contact Us

Contact our corporate or local offices directly.

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
You are reporting an issue with the following selected text
and/or image within the active document: