Создание шаблонов документов жгутов
Краткий обзор
- Изучите пошаговый процесс создания шаблонов схем соединений, компоновочных и производственных чертежей жгутов как в рабочем пространстве, так и локально.
- Узнайте, как настроить внешний вид шаблона, параметры и специальные строки, чтобы в документах автоматически отображалась нужная информация.
- Разберитесь, как сохранять, переносить, загружать, редактировать и применять шаблоны, избегая распространённых ошибок настройки, которые могут повлиять на их работу.
При применении к монтажной схеме или компоновочному чертежу документ шаблона жгута определяет размер листа, графические элементы (например, основную надпись) и список параметров уровня документа. Вы можете создать собственный набор шаблонов, чтобы обеспечить единообразное оформление документов проекта жгута, создаваемых вами или всей командой.
Создание шаблона монтажной схемы или компоновочного чертежа в Workspace
-
Откройте вкладку Templates на странице Data Management – Templates диалогового окна Preferences.
-
Выберите команду Harness Wiring или Harness Layout в меню кнопки
или в контекстном меню таблицы шаблонов.
-
После выбора команды нажмите OK в открывшемся диалоговом окне Close Preferences, чтобы закрыть диалоговое окно Preferences и открыть временный редактор шаблона. Планируемая ревизия нового шаблона будет автоматически создана в папке Workspace типа Harness Wiring Templates / Harness Layout Templates.
-
Настройте параметры рабочей области на вкладке General панели Properties, когда в рабочей области не выбран ни один объект.
-
В области General панели выберите единицы измерения и настройте параметры сетки.
-
В области Page Options панели выберите Standard или Custom в области Formatting and Size и настройте доступные параметры по необходимости — задайте размер и ориентацию листа, включите или отключите использование стандартной основной надписи, задайте поля и зоны.
-
-
Задайте набор параметров на вкладке Parameters панели Properties в режиме Documents Options. Эти параметры станут параметрами уровня документа монтажной схемы / компоновочного чертежа, к которому будет применен шаблон. Используйте элементы управления в нижней части панели для добавления и удаления пользовательских параметров.
-
С помощью графических объектов задайте внешний вид шаблона. Например, если вы решили не использовать стандартную основную надпись, создайте собственную с помощью этих объектов.
Вы также можете использовать текстовые строки для задания статического текста шаблона, то есть текста, который не будет изменяться в документе (например, текста
Drawn By).
Пример пользовательской основной надписи, созданной с помощью линий и текстовых объектов. -
Используйте текстовые объекты в качестве специальных строк, чтобы задать заполнители для проектной или системной информации, которые будут заменены значениями параметров при применении шаблона к документу. Задайте свойство Text выбранной текстовой строки в формате
=<ParameterName>. При применении к документу эта текстовая строка будет отображать значение одноименного параметра. Это может быть параметр уровня листа (предопределенный или пользовательский) либо параметр уровня проекта.Например, текстовая строка с текстом
=DrawnByбудет отображать значение параметраDrawn By(в котором, например, указано ваше имя), когда шаблон будет применен к документу.
Пример пользовательской основной надписи с добавленными специальными строками. При применении шаблона к документу эти специальные строки будут заменены фактическими значениями параметров. -
Сохраните шаблон в подключенном Workspace, выбрав команду File » Save to Server в главном меню. Откроется диалоговое окно Edit Revision, в котором можно задать Name и Description создаваемого в Workspace элемента шаблона и при необходимости добавить примечания к выпуску.
Теперь шаблон можно применить к документу монтажной схемы / компоновочного чертежа. Когда документ активен, откройте панель Properties в режиме Documents Options (он активен, когда в рабочей области не выбран ни один объект), затем в области Page Options вкладки General выберите режим Template для Formatting and Size и воспользуйтесь раскрывающимся списком Template для выбора одного из доступных шаблонов.

Шаблон монтажной схемы применен к документу монтажной схемы. Обратите внимание: специальные строки-заполнители заменены значениями параметров.
Сохранение существующего локального шаблона монтажной схемы или компоновочного чертежа в Workspace
-
Вы можете создать новый шаблон монтажной схемы или компоновочного чертежа в Workspace с помощью команды Load from File из меню кнопки
или контекстного меню Add таблицы шаблонов на вкладке Templates на странице Data Management – Templates диалогового окна Preferences. В открывшемся диалоговом окне Open (стандартном диалоговом окне Windows для открытия файлов) выберите вариант Harness Wiring Diagram Template File (*.WirDot) и Harness Layout Diagram Template File (*.LdrDot) в раскрывающемся списке справа от поля File name, затем найдите и откройте нужный файл. Он будет загружен в начальную ревизию нового шаблона Workspace, автоматически созданного в папке Workspace типа Harness Wiring Templates / Harness Layout Templates.
-
Если нужный шаблон монтажной схемы или компоновочного чертежа, который необходимо сохранить в Workspace, находится в Local Template folder (указано внизу страницы Data Management – Templates диалогового окна Preferences) и отображается в строке Local таблицы шаблонов, его можно перенести в новый элемент Harness Wiring Template Item / Harness Layout Template Item, щелкнув по нему правой кнопкой мыши и выбрав команду Migrate to Server. Нажмите кнопку OK в диалоговом окне Template migration, чтобы начать перенос. Как указано в этом окне, исходный файл шаблона будет добавлен в ZIP-архив в локальной папке шаблонов (и поэтому больше не будет отображаться в списке шаблонов Local).
-
Если необходимо обновить шаблон монтажной схемы или компоновочного чертежа в Workspace и у вас есть обновленный файл шаблона, его можно загрузить в шаблон Workspace. На вкладке Templates страницы Data Management – Templates диалогового окна Preferences щелкните правой кнопкой мыши по записи шаблона и выберите в контекстном меню команду Upload. В открывшемся диалоговом окне Open (стандартном окне открытия файлов Windows) найдите и откройте нужный файл — он будет загружен в следующую ревизию шаблона Workspace.
Редактирование шаблона монтажной схемы или компоновочного чертежа в Workspace
На любом этапе можно вернуться к шаблону монтажной схемы или компоновочного чертежа в Workspace и отредактировать его. На вкладке Templates страницы Data Management – Templates диалогового окна Preferences щелкните правой кнопкой мыши по записи шаблона и выберите в контекстном меню команду Edit. Откроется временный редактор с шаблоном из выбранной ревизии, доступным для редактирования. Внесите необходимые изменения, затем сохраните документ в следующую ревизию шаблона.
Создание локального шаблона монтажной схемы или компоновочного чертежа
Также можно создать локальный шаблон монтажной схемы или компоновочного чертежа. Для этого:
-
Когда активен проект жгута, создайте новый документ монтажной схемы или компоновочного чертежа, выбрав в главном меню команду File » New » Harness Wiring Diagram или File » New » Harness Layout Drawing соответственно.
-
Используйте этот документ, чтобы настроить шаблон в соответствии с вашими требованиями, как описано выше.
-
Выберите в главном меню команду File » Save As. В появившемся диалоговом окне Save As перейдите в локальную папку шаблонов вашей установки Altium Designer (указана в поле Local Templates folder внизу страницы Data Management – Templates диалогового окна Preferences;
C:\Users\Public\Documents\Altium\AD<Solution/Version>для установки по умолчанию), введите нужное имя шаблона и выберите Harness Wiring template (*.WirDot) или Harness Layout template (*.LdrDot) в раскрывающемся списке Save as type.
Создание шаблона производственного чертежа
Шаблон производственного чертежа определяет содержимое документа производственного чертежа и, при необходимости, параметры его оформления.
Чтобы создать новый шаблон документа производственного чертежа:
-
Когда активен проект жгута, создайте новый документ производственного чертежа, выбрав в главном меню команду File » New » Draftsman Document.
-
Определите содержимое шаблона. Шаблон поддерживает многостраничные документы, данные основных атрибутов документа (таблицы и списки, типы чертежей и т. д.), настройки страниц и элементы, не зависящие от содержимого проекта жгута. Для оформления нового или существующего чертежного документа можно использовать шаблон листа, который также сохраняется в составе шаблона документа производственного чертежа.

Пример шаблона документа производственного чертежаМногостраничный документ производственного чертежа обычно может содержать вид монтажной схемы, вид компоновочного чертежа и таблицу спецификации (BOM). При сохранении в качестве шаблона документа данные текущего проекта жгута сохраняются, формируя «каркас» содержимого чертежа.
-
Выберите в главном меню команду File » Save Copy As или File » Save As. В появившемся диалоговом окне Save перейдите в локальную папку шаблонов вашей установки Altium Designer (определена в поле Local Templates folder внизу страницы Data Management – Templates диалогового окна Preferences;
C:\Users\Public\Documents\Altium\AD<Solution/Version>для установки по умолчанию), введите нужное имя шаблона и выберите Altium Draftsman Harness Document Templates (*.HarDot) в раскрывающемся списке Save as type.
После нажатия Save содержимое и атрибуты существующего чертежного документа, за исключением связанных с данными, извлеченными из проекта жгута, будут сохранены в виде шаблона документа производственного чертежа. Если у исходного чертежного документа задано определенное оформление страниц (например, с помощью шаблона листа), эти графические элементы и атрибуты будут сохранены вместе с новым шаблоном документа производственного чертежа.
При последующем использовании этого шаблона для нового документа производственного чертежа данные проекта загружаются в каркас вместо данных шаблона, воссоздавая формат документа и тип его содержимого.



