Создание производственного чертежа

Краткий обзор

В этой статье подробно описано, как создать производственный чертёж жгута в Altium Designer с помощью редактора Draftsman: от добавления документа в проект и его настройки до размещения доступных только для чтения видов схемы соединений и компоновочного чертежа, добавления выносных элементов и видов компонентов, а также использования аннотаций, размеров и таблиц для подготовки производственной документации. Вы также узнаете, как перенести изменения со схемы соединений и компоновочного чертежа на производственный чертёж и как управлять свойствами, единицами измерения, параметрами и навигацией по листам документа. Хотите разобраться, как данные проекта жгута превращаются в упорядоченную производственную документацию? Читайте дальше — статья поможет вам понять весь рабочий процесс.

- Узнайте, как создать и настроить документ производственного чертежа жгута в Draftsman, включая выбор шаблонов, настройку документа и единиц измерения, а также импорт параметров проекта.
- Ознакомьтесь с типами видов, аннотаций, размеров и дополнительных инструментов черчения, которые позволяют наглядно представить информацию о проекте жгута.
- Узнайте, какие таблицы доступны для производственной документации, включая спецификации (BOM), перечни проводов и таблицы соединений, а также откуда берутся и как представляются их данные.
Узнайте больше с ИИ:

После завершения схемы соединений и компоновочного чертежа копии их содержимого, доступные только для чтения, можно разместить в документе производственного чертежа (*.HarDwf) и при необходимости добавить пояснения. Производственный чертеж жгута создается в редакторе Draftsman.

Общие сведения о Draftsman см. на странице Оптимизация подготовки документации по проектированию плат с помощью Draftsman.

Добавьте производственный чертеж в проект жгута из панели Projects: щелкните правой кнопкой мыши запись проекта и выберите Add New to Project » Draftsman Document в контекстном меню (или воспользуйтесь командой File » New » Draftsman Document в главном меню). В открывшемся диалоговом окне New Document выберите подходящий шаблон производственного чертежа и убедитесь, что выбраны правильные Project и компоновочный чертеж жгута Document.

Диалоговое окно New Document
Диалоговое окно New Document

Подробнее о создании шаблонов производственных чертежей см. на странице Создание документов-шаблонов жгутов.

Настройка документа производственного чертежа

Параметры документа производственного чертежа можно настроить на панели Properties, когда в рабочей области документа не выбран ни один объект. Подробнее см. на странице Настройка документа Draftsman.

Вкладки панели Properties, когда в документе производственного чертежа жгута не выбран ни один объект
Вкладки панели Properties, когда в документе производственного чертежа жгута не выбран ни один объект

  • После создания документа производственного чертежа любые изменения, внесенные в схему соединений или компоновочный чертеж, можно импортировать в производственный чертеж с помощью команды Tools » Import Changes From <LayoutDrawing.LdrDoc> в главном меню или контекстном меню рабочей области. Обратите внимание: несмотря на описание команды меню, при ее выполнении импортируются изменения из both the wiring diagram and the layout drawing.

  • Свойства объектов производственного чертежа по умолчанию можно настроить на странице Draftsman — Параметры по умолчанию диалогового окна Preferences. Эти свойства будут применяться при размещении последующих объектов.

  • Панель Bookmarks предоставляет удобные средства навигации и управления многостраничным производственным чертежом. На панели отображается раскрываемое дерево полной структуры документа, включающее все листы документа и основные объекты видов на этих листах.

  • С помощью параметров Units и Dual_Units на панели Properties, когда в рабочей области не выбран ни один объект, можно выбрать единицы измерения по умолчанию для размерных значений и значений длины, отображаемых в таблицах. При необходимости единицы измерения, заданные на уровне документа, можно переопределить в свойствах отдельных объектов. Поддерживаемые единицы измерения: Millimeters, Mils, Inches, Сантиметры, Метры и Feet.

  • Параметры документа компоновочного чертежа импортируются в связанный документ производственного чертежа жгута. Эти параметры перечислены на вкладке Parameters панели Properties для документа (отображение параметров компоновки в списке можно включать и отключать с помощью флажка рядом со значком  на панели) и могут использоваться в специальных строках. Вычисляемые значения параметров, такие как =ItemRevision и =ItemRevisionLevel1, также включаются в выходные документы, создаваемые при выпуске, и интерпретируются в них.

Работа с видами

В документе производственного чертежа можно размещать доступные только для чтения виды схемы соединений жгута и компоновочного чертежа жгута, входящих в этот проект.

Вид схемы соединений

Вид схемы соединений (Place » Wiring Diagram View) — это автоматически формируемое графическое представление схемы соединений активного проекта жгута.

Пример вида схемы соединений
Пример вида схемы соединений

Свойства размещенного вида схемы соединений можно настроить на панели Properties, когда вид выбран в рабочей области.

Панель Properties при выбранном виде схемы соединений
Панель Properties при выбранном виде схемы соединений

  • Если проект жгута содержит несколько документов схем соединений (подробнее), можно выбрать документ схемы соединений, на основе которого будет формироваться и обновляться размещенный вид. Выбрав вид схемы соединений, используйте раскрывающийся список Document в области Properties панели Properties, чтобы выбрать документ схемы соединений для этого вида ().

  • Когда параметр Auto Size включен, размер вида схемы соединений автоматически подстраивается так, чтобы убрать пустое пространство по краям.

  • Выберите Justification , щелкнув стрелку, соответствующую нужному выравниванию, или круг для выравнивания по центру. Выбранное значение Justification определяет точку, относительно которой изменяется положение вида при обновлении его размера.

Вид компоновочного чертежа

Вид компоновочного чертежа (Place » Layout Drawing View) — это автоматически формируемое графическое представление компоновочного чертежа активного проекта жгута.

Пример вида компоновочного чертежа
Пример вида компоновочного чертежа

Свойства размещенного вида компоновочного чертежа можно настроить на панели Properties, когда вид выбран в рабочей области.

Панель Properties при выбранном виде компоновочного чертежа
Панель Properties при выбранном виде компоновочного чертежа

  • Когда параметр Auto Size включен, размер вида компоновочного чертежа автоматически подстраивается так, чтобы убрать пустое пространство по краям.

  • Выберите Justification , щелкнув стрелку, соответствующую нужному выравниванию, или круг для выравнивания по центру. Выбранное значение Justification определяет точку, относительно которой изменяется положение вида при обновлении его размера.

Дополнительные виды

Для дополнения производственного чертежа можно использовать дополнительные виды: выносной элемент жгута и вид компонента.

Выносной элемент жгута позволяет представить заданную область существующего чертежа в виде отдельно размещаемого увеличенного изображения. Для выносного элемента жгута доступны круглая и прямоугольная области. Чтобы разместить нужный вид, выберите соответствующий вариант (Circle area detail view или Rectangle area detail view) в главном меню Place » Additional Views » Harness Detail View.

Javascript ID: Harness_MD_HarnessDetailView_AD24

Пример выносного элемента жгута с круглой областью на виде схемы соединений

Пример выносного элемента жгута с прямоугольной областью на виде схемы соединений

Вид компонента (Place » Additional Views » Component View) — это чертежный вид отдельного компонента из текущего проекта жгута.

Пример вида компонента
Пример вида компонента

Добавление пояснений и нанесение размеров на чертеж

Для добавления важной информации на производственный чертеж предусмотрен ряд дополнительных инструментов аннотирования, нанесения размеров и черчения. К ним относятся автоматизированные системы примечаний и выделения, а также инструменты для указания длин, размеров и углов контуров объектов или расстояний между выбранными объектами.

Пример аннотированного вида компоновочного чертежа
Пример аннотированного вида компоновочного чертежа

  • Выноска, связанная с разъемом или точкой подключения и настроенная на отображение позиции спецификации, показывает номера позиций спецификации для самого разъема или точки подключения и связанных с ними деталей. Выноска, добавленная к физическому представлению компонента на виде компоновочного чертежа, также показывает номера позиций спецификации для всех контактных гнезд, назначенных этому компоненту.

  • При размещении линейного размера между точками подключения на виде компоновочного чертежа поле Value  (длина размера) автоматически заполняется соответствующей длиной пучка жгута.

Дополнительную информацию см. на следующих страницах:

Работа с таблицами

В документе производственного чертежа можно разместить спецификацию (BOM), таблицу проводов, таблицу соединений и таблицу общего назначения. Табличные данные формируются непосредственно из документов проекта и позволяют просто и наглядно передать важную информацию для изготовления жгута.

  • В свойствах спецификации, таблицы проводов и таблиц соединений можно задать Length Units и Value Precision длины (переопределив настройки уровня документа). Выбранные параметры будут применяться к значениям длины, отображаемым в соответствующей таблице.

  • Для компонентов электрической схемы жгута в столбце Length таблицы спецификации указывается суммарная длина проводов или кабелей одной позиции спецификации, а не их отдельные длины.

  • Покрытия проводов, кабелей и жгутов — это объекты, учитываемые по длине; ее значение отображается в поле Length . Значение поля Quantity  для этих объектов — As Required.

  • При копировании любого табличного объекта из документа производственного чертежа его содержимое можно вставить в электронную таблицу Microsoft Excel.

Подробнее о работе со спецификацией и таблицами.

Таблица проводов

Таблица проводов (Place » Wiring List) — это автоматически формируемый табличный объект, в котором отображаются начальная и конечная точки, а также значения параметров каждого провода жгута.

Пример таблицы проводов
Пример таблицы проводов

Свойства размещенной таблицы проводов (например, внешний вид и состав данных) можно настроить на панели Properties, выбрав таблицу проводов в рабочей области.

Вкладки панели Properties при выбранной таблице проводов 
Вкладки панели Properties при выбранной таблице проводов

  • В таблице проводов отображаются позиционные обозначения объектов экрана с подключением, если к такому объекту подключен провод.

  • Если параметр Include Cut провода имеет значение No, этот провод не будет отображаться в таблице проводов.

  • Параметры проводов (и их значения), заданные на электрической схеме, отражаются в таблице проводов. Для каждого параметра провода в таблицу добавляется отдельный столбец. По умолчанию эти дополнительные столбцы скрыты. Чтобы отобразить их в рабочей области (и при необходимости скрыть столбцы по умолчанию), выберите таблицу проводов и воспользуйтесь элементами управления видимостью на вкладке Columns панели Properties.

  • Многоцветные провода поддерживаются в таблицах проводов ():

    • Ячейки столбца Color разделяются для отображения второго и третьего цветов, назначенных проводу.

    • Столбец ColorName содержит названия основного, второго и третьего цветов.

    • Можно включить отображение дополнительных столбцов для второго и третьего цветов, а также цвета окантовки.

  • Для проводов в составе кабеля в столбце Length таблицы проводов отображается индивидуальная длина каждого провода.

  • Для проходного разъема (разъема с наибольшим числом контактных гнезд) в таблице проводов автоматически применяется группировка, обеспечивающая правильное объединение всех его контактных гнезд в столбце From.

  • Используйте кнопки  и , чтобы переместить видимый столбец, запись которого выбрана на вкладке Columns, на одну позицию влево или вправо в таблице проводов.

  • Щелкните ячейку в столбце Order, чтобы переключить порядок сортировки данных столбца таблицы (без сортировки, по возрастанию или по убыванию). Сортировку можно применить к нескольким столбцам с учетом приоритета, удерживая Ctrl и щелкая ячейки в столбце Order.

  • Разъем с наибольшим количеством проводов (и все его контактные гнезда) автоматически группируется в столбце From  ().

Разделение таблицы проводов

Таблица проводов сложного жгута может содержать большое количество записей, из-за чего ее трудно разместить в документе чертежа в виде единой таблицы. Вместо изменения масштаба шрифта и таблицы, создания нескольких пользовательских таблиц или использования внешнего документа можно «разделить» таблицу проводов, чтобы она отображалась на нескольких «страницах».

На панели Properties  размещенной таблицы проводов включите параметр Limit Page Height в области Pages , чтобы ограничить высоту таблицы заданным значением (Max Page Height) и, соответственно, количество отображаемых в ней строк.

Javascript ID: Harness_MD_WiringList_LimitPageHeight_AD25_3

Редактор определяет, что таблица проводов показана не полностью, о чем свидетельствует значение Page на панели (например, Page 1 from 2), а соответствующее раскрывающееся меню позволяет выбрать отображаемую страницу. Чтобы добавить следующие страницы таблицы проводов, разместите еще одну таблицу проводов и укажите следующую Page в области Pages панели Properties .

Поскольку каждая страница таблицы проводов создается путем добавления еще одной таблицы проводов с последующей настройкой, отдельные страницы можно размещать на любом листе документа производственного чертежа.

Обратите внимание, что свойство Max Page Height задает высоту страницы first таблицы проводов. При выборе второй страницы (страница 2) свойство Max Page Height определяет высоту первой исключенной страницы (страница 1). Таким образом, на странице 2 отображаются оставшиеся записи таблицы проводов. Для начала задайте Max Page Height свойство одинаково для каждой страницы.

Таблица соединений

Таблица соединений (Place » Connection Table) — это автоматически формируемый табличный объект, в котором показаны провода, подключенные к каждой точке соединения (контакту разъема, сростку и т. д.) в жгуте.

Пример таблицы соединений (для всех компонентов)
Пример таблицы соединений (для всех компонентов)

Свойства размещенной таблицы соединений (например, внешний вид и содержимое) можно настроить на панели Properties, выбрав таблицу соединений в рабочей области.

Вкладки панели Properties при выбранной таблице соединений 
Вкладки панели Properties при выбранной таблице соединений

  • С помощью параметра Component можно отобразить в таблице данные всех компонентов проекта либо данные отдельного компонента или сростка.

  • Если параметр Include Cut провода имеет значение No, этот провод не будет отображаться в таблице соединений.

  • Параметры проводов (и их значения), заданные на схеме соединений, отображаются в таблице соединений. Для каждого параметра провода в таблицу соединений добавляется отдельный столбец. По умолчанию эти дополнительные столбцы скрыты. Чтобы отобразить их в рабочей области (и при необходимости скрыть стандартные столбцы), выберите таблицу соединений и используйте элементы управления видимостью на вкладке Columns панели Properties.

  • Многоцветные провода поддерживаются в таблицах соединений ():

    • Ячейки столбца Color разделяются на области для отображения второго и третьего цветов, назначенных проводу.

    • Столбец ColorName содержит названия основного, второго и третьего цветов.

    • Можно включить отображение дополнительных столбцов для второго и третьего цветов, а также цвета окантовки.

  • Для проводов в составе кабеля столбец Length таблицы соединений отображает индивидуальную длину каждого провода.

  • Используйте кнопки  и , чтобы переместить видимый столбец, выбранный на вкладке Columns, на одну позицию влево или вправо в таблице соединений.

  • Нажимайте ячейку в столбце Order, чтобы переключаться между вариантами сортировки данных столбца таблицы (без сортировки, по возрастанию и по убыванию). Сортировку можно применить к нескольким столбцам с учетом приоритета: для этого, удерживая Ctrl, нажимайте ячейки в столбце Order.

  • Используйте раскрывающийся список Display на панели Properties, чтобы настроить данные, отображаемые в таблице:

    • Wires Only – отображать только контакты, к которым подключены провода.

    • Wires & Parts – отображать контакты с подключенными проводами, а также контакты с установленными в гнезда деталями, например заглушками для герметичных разъемов при отсутствии провода.

    • All Cavities – отображать все контакты всех компонентов независимо от подключенных проводов и установленных в гнезда деталей (например, если компонент имеет 10 контактов, в таблице будут показаны все 10 контактов).

    • No Connect – отображать только объекты «Нет соединения».

Разбиение таблицы соединений

Таблица соединений сложного проекта жгута может содержать большое количество записей, из-за чего ее трудно разместить в чертежном документе в виде единой таблицы. Вместо масштабирования шрифта и таблицы, создания нескольких пользовательских таблиц или использования внешнего документа можно «разбить» таблицу соединений в документе Harness Draftsman (*.HarDwf), чтобы она отображалась на нескольких «страницах». Чтобы воспользоваться этой возможностью, на панели Properties  для размещенной таблицы соединений включите параметр Limit Page Height в области Pages . Это ограничит высоту таблицы соединений заданным значением (Max Page Height) и, соответственно, количество отображаемых в ней строк.

 

Редактор определяет, что таблица соединений отображается не целиком, о чем свидетельствует поле Page на панели (например, 1 from 2), а соответствующее раскрывающееся меню позволяет выбрать отображаемую страницу. Чтобы добавить следующие страницы таблицы соединений, разместите еще одну таблицу соединений (Place » Connection Table) и укажите следующую Page в области Pages панели Properties .

AI-LocalizedЛокализовано с помощью ИИ
Если вы обнаружили проблему, выделите текст/изображение и нажмитеCtrl + Enter, чтобы отправить нам свой отзыв.
Меню
Contents
Доступность функций

Доступные вам функции зависят от того, какое решение Altium вы используете: Altium Develop, Altium Agile Teams, Altium Agile Enterprise или Altium Designer (при активной подписке).

Если вы не видите описанную функцию в используемом вами программном обеспечении, свяжитесь с отделом продаж Altium, чтобы узнать больше.

Устаревшая документация

Документация Altium Designer больше не разделена по версиям ПО. Если вам необходим доступ к документации по старым версиям Altium Designer, посетите раздел Устаревшая документация на странице Прочие установщики.

Contents