使用变量管理对话框

在 Variant Management对话框中创建和配置。要打开对话框,请从 Variants从 Project菜单(快捷键 C, V) 或右键单击面板中的项目名称,然后选择 Projects然后选择 Variants。

右键单击原理图编辑器中已放置的元件,然后选择 Part Actions » Variants。在这种情况下,对话框中将显示当前在原理图编辑器中选择的部件。

对话框 Variant Management对话框可用。 UI.ModernVariantsManager选项在高级设置对话框中禁用时,该对话框才可用。启用该 UI.ModernVariantsManager选项时,变量管理器将用于创建和配置设计变量。

该对话框有两个主要区域:

  • 上部 Components for project区域,其中列出了基本设计中的所有组件,如果适用,还列出了应用变量的列。

  • 下部 Component Parameters区域,该区域详细列出了当前在上部区域所选组件的所有参数,如果适用,还列出了所应用变量的列。

变量在 Variant Management对话框中创建和配置。
变量在 Variant Management对话框中创建和配置。

双击 Variant Management对话框中的元件上双击,以跳转到原理图上的该元件,或从右键单击上下文菜单中选择 Cross Probe从右键单击上下文菜单中选择

创建新变量

Add Variant button 在 Variant Management对话框中的 按钮,创建基本设计的新变量。对话框将打开。 Edit Project Variant对话框将打开。

至少要在 Description字段中输入变量的名称,默认情况下该字段的内容为 Variant of .

如果需要从设计中生成制造变量,请启用 Allow variation of fabrication outputs选项。 Edit Project Variant对话框中启用该选项。如果需要为包含有 "未装配 "部件的变量的设计生成粘贴掩模输出,请启用该选项。 Allow variation for paste mask选项。这些元件的焊盘上将不再包含锡膏掩膜。

您可以选择是否需要在原理图上更改备用零件的符号,或使用以下选项将其基底面添加到 PCB 上。 Edit Project Variant对话框中的以下选项:

  • Do not overwrite schematic symbol- 启用后,在变量中选择了备用零件的元件将使用非变量符号。

    请注意,该选项仅影响原理图工作表上的符号表示。在建立设计连接性模型时会考虑备用零件符号。因此,即使启用了该选项,基本元件和备用元件也需要引脚兼容。有关引脚兼容的更多信息,请参阅 "选择备用零件"部分。

  • Do not overwrite PCB footprint- 启用该选项后,在变量中选择了替代零件的组件将使用非变量基底面。应用于变量的替代零件的基底面不会作为 PCB 更新的一部分转移到 PCB 上(不会生成将基底面添加到 PCB 的 ECO)。

无论是否启用这两个参数,所选替代零件的参数都会如实显示在 ActiveBOM 中。

您还可以为变量定义参数。有关如何定义以及变量级参数如何与 Altium Designer 中的参数层次结构相匹配的详细信息,请参阅 "使用变量参数"。

按要求定义变量后,单击 OK。然后对话框右侧将出现一列额外的 Variant Management对话框的右侧将出现一列,列标题为新变量名。所有单元格都将为空,其中空单元格表示该组件已安装且与基本设计保持一致。现在可以为新变量配置组件了。下图显示了一个创建了两个变量(BGA 和 TSOP)的项目。

区域 1 详细说明了基本设计中的元件,区域 2 详细说明了 BGA 变量中的元件,区域 3 详细说明了 TSOP 变量中的元件。
区域 1 详细说明了基本设计中的元件,区域 2 详细说明了 BGA 变量中的元件,区域 3 详细说明了 TSOP 变量中的元件。

要将某个变量作为活动选项,请单击列标题中的变量名称,或单击该变量的任意单元格。

对话框 Variant Management对话框包含许多界面功能,可帮助显示有用信息。这些功能可通过 right-click上下文菜单进行配置。

Right-click context menu, Variant Management dialog

有用的命令包括

  • Columns:
    • Hierarchy Path列 - 显示组件在设计层次结构中的位置。
    • Original Library Link列 - 详细说明基础组件的来源。
  • Set Selected As- 子菜单,用于选择变化类型(拟合、非拟合、替代)。可以用来代替单击组件单元格中的Ellipsis control used to configure a variation 控件。仅在右键单击变量的组件单元格时可用。
  • Only Show Varied Parameters- 仅在对话框中显示已应用某种形式变量的组件。 Variant Management对话框中显示。
  • Filter- 子菜单可控制在对话框中显示的变化类型(变化参数、不适合、替代)。 Variant Management对话框中显示的变化类型(变化参数、不拟合、替代)。与 Only Show Varied Parameters命令结合使用。

Varied parameters - 与基本设计不同的参数将显示在 bold中显示。 Component Parameters对话框的 Variant Management对话框中显示,便于直观识别。

定义组件变量

一旦创建了变量本身,就可以随时更改每个组件的状态。这可以通过单击变量列中的组件单元格以显示Ellipsis control used to configure a variation 控件,或右键单击单元格并从上下文子菜单中选择所需条目来完成。 Set Selected As子菜单中选择所需的条目。

Ellipsis control used to configure a variation 控件打开 Edit Component Variation对话框。

该 Edit Component Variation对话框,也可从原理图的编译选项卡中访问,方法是右键单击已定义变量的组件,然后选择 Part Actions » Choose Alternate Part。

对话框提供三种选择:

  • Fitted - 基本设计中使用的原始组件也会在该设计的变量中安装/使用。对于新添加的变量,默认情况下所有组件都是拟合的,这些拟合组件的单元格为空。请注意,也可以更改拟合元件的单个参数,只需在对话框的 Component Parameters区域输入新的参数值。
  • Not Fitted- 在基本设计中使用的原始组件在该设计的变量中没有装配/使用。对于未装配组件状态,单元格中将显示文本 Not Fitted而对话框下部的 Component Parameters区域为空白。
  • Alternate Part- 该选项允许选择不同的(替代)部件。对话框将展开,包含浏览和查找所需替代零件的控件。选择部件后,单元格将显示替代部件的源链接。对话框下部 Component Parameters区域将显示替代部件的所有参数。更多信息请参见下一节。

支持标准的 Windows 多选技术。使用这些技术可同时选择和配置多个组件。

选择替代部件

当 Alternate Part选项时, Edit Component Variation对话框展开,显示现有部件的基本参数。使用 按钮在 "替换组件 "对话框(组件面板的模态对话框版本)中浏览并定位所需的备用零件组件。支持 Altium Designer 的所有组件存储模型,如独立库、数据库库以及工作区库组件(如下图所示)。

选择替代部件后,软件会检查所选替代部件与原始基本设计部件之间的引脚兼容性。要实现引脚兼容,替代部件必须与原始部件具有相同数量的引脚,而且这些引脚的位置和电气类型必须相同。两个组件符号中使用的图形基元不需要匹配。如果软件检测到替代组件的引脚不兼容,则在替换之前必须取消对话框。 Confirm对话框。在这种情况下,您需要注意对布线的潜在影响,以及在验证设计时可能会遇到的错误违反 (Project » Validate )。

替代部件变化示例。
替代部件变化示例。

新应用的替代部件可以在设计空间中重新检查--请参阅 "在设计中使用变量"页面了解更多信息。

选择替代零件时,无需更改原理图上的符号,也无需在 PCB 上添加基底面。在 Edit Project Variant对话框中,启用 Do not overwrite schematic symbol 和/或 Do not overwrite PCB footprint选项。启用后者后,作为 PCB 更新的一部分,应用于变量的替代零件的基底面将不会转移到 PCB 上(不会生成将基底面添加到 PCB 上的 ECO)。所选替代元件的参数将如实显示在 ActiveBOM 中。

使用 DbLink 文件时的变量

Altium Designer 支持多种元件存储和处理方式,包括在项目中使用 DBLink 文件。DBLink 文件是原理图上的组件与公司数据库之间的接口。

DBLink 模型并不像从 DBLib 类型库中放置组件时通常所做的那样,只是从每个组件创建一个指向特定数据库记录的引用,而是依靠设计器根据一个或多个组件参数启动查询操作。然后,软件会在数据库中搜索包含匹配值的字段记录,当出现匹配时,该记录中的其他字段值(如零件编号)就会返回 Altium Designer 组件。该 component parameter-to-database field映射在 DBLink 文档中定义,目标数据库也是如此。

►了解更多关于数据库库

在不使用 "变量 "的设计中,可通过 "从数据库更新参数"命令执行查询操作,也可在 BOM 生成过程中通过启用 Include Parameters from Database选项(见下文),以提取 BOM 特定组件数据(如价格)。

对于包含变量的设计,用于查询数据库的参数可在 Variant Management对话框中更改用于查询数据库的参数。由于这些参数值只存在于 Variant Management对话框中,因此 Update Parameters from Database命令不用于检索数据库信息,而是在生成 BOM 时从数据库中提取参数。

显示变型管理对话框数据

变量管理对话框 Variant Management对话框具有帮助控制显示数据量的功能,这在处理大型设计时特别有用。

  • 要删除不感兴趣的列,请右键单击对话框的 upper部分单击右键,然后使用 Columns选项来切换任何列的可见性。
  • 要只显示正在变化的组件,请右键单击对话框的 upper部分右键单击,然后从右键菜单中选择 Only Show Varied Components选项。
  • 当 Only Show Varied Components模式后,再次右键单击并配置选项。 Filter选项。在下图中, Filter已配置为只显示使用替代部件的组件。
  • 要更改所列变量的顺序,请选择并拖动变量列标题到新位置。将其与 Fit to Width复选框来定位和调整相关变量的大小。

对话框 Variant Management对话框,其中隐藏了列,并应用了过滤器以只显示使用替代部件的组件。
对话框 Variant Management对话框,其中隐藏了列,并应用了过滤器以只显示使用替代部件的组件。

重置和更新变量数据

在 Variant Management对话框中设置的设计变量最终会保存在项目文件中。这包括未拟合状态、拟合组件的本地参数变化以及备用零件的参数值。实际的备用零件保存在ProjectName].PrjPcbVariants文件中。对话框 Variant Management对话框包含重置参数和更新组件的命令,有助于确保组件与源组件库同步。

更新变量参数

在 Variant Management对话框中本地修改的参数可通过右键单击变量参数列表中修改的参数(粗体显示),然后从上下文菜单中选择 Reset Selected如下图所示。请注意,可以同时选择多个参数,然后在单个操作中重置,或 Reset All用于重置该组件的所有参数。

修改后的参数可以使用 Reset Selected命令恢复参数值。
修改后的参数可以使用 Reset Selected命令恢复参数值。

更新替代部件参数

如果作为替代零件使用的库组件的参数在库中发生了更改,您可以右键单击该变量的参数列表,然后从菜单中选择 Update Values from Library如下图所示)。请注意,这将更新参数;如果需要更新图形,请使用下面描述的技术。

如果修改了库中的替代零件组件,请使用 Update Values from Library命令刷新项目中使用的副本。
如果修改了库中的替代零件组件,请使用 Update Values from Library命令刷新项目中使用的副本。

在执行 Update Values from Library命令后,在源代码库中通过 Browse Libraries对话框浏览并找到源代码库中的组件,然后单击 "确定 "打开 Update Project Variants From Library对话框。选择/取消选择 Parameters from Library Component和 Variants to Update然后单击 OK完成更新过程。

如果为参数更新选择的组件是工作区组件,则将打开组件面板的基本模式对话框版本,而不是 Browse Libraries对话框。浏览或搜索查找组件,单击 OK打开 Update Project Variants From Library对话框,然后按此处所述选择所需的参数进行更新。

从源代码库中更新一个不同的组件。在此您可以配置更新哪些参数,以及将更新应用于哪个变量。
从源代码库中更新一个不同的组件。在此您可以配置更新哪些参数,以及将更新应用于哪个变量。

对话框左侧列出了所有参数。 Update Project Variants From Library对话框左侧列出了所有参数--如果需要,可以取消选择任何参数,将其排除在更新过程之外。在对话框右侧,可以更改目标项目变量 (Project Variant To Update),这将默认选择激活命令时所选择的变量。 Update Values from Library命令时所选择的变量。

请注意,此参数更新过程会将参数值直接从库带入 Variant Management对话框中,而不会更新存储在 [ProjectName].PrjPcbVariants文件中存储的组件副本。如果随后执行 Reset命令之一重置参数值(从 PrjPcbVariants文件中的值,则可能会将参数值恢复到较早的值,并覆盖当前的任何更改。为确保这种情况不会发生,请使用以下步骤更新文件中的组件。 PrjPcbVariants文件中的组件。

完全更新替代部件

如果替代零件的源组件已在其库中编辑过,则可通过运行 "从库更新 "对话框在设计中对其进行更新。

从原理图编辑器的 Tools菜单启动,该对话框包含一个选项,用于 Include Variants。启用该选项后,元件列表将展开,以包括任何已用作备用零件的元件。选中列表中要更新的部件,然后完成向导,更新源中所需的部件。

要完全更新一个备用零件,包括其图形,请启用 Include Variants复选框,并启用要更新的零件。
要完全更新一个备用零件,包括其图形,请启用 Include Variants复选框,并启用要更新的零件。

如果对基础设计中使用的库组件进行了更改,也会以通常的方式进行更新:

  • 通过原理图编辑器 Tools » Update from Library命令
  • 或原理图库编辑器 Tools » Update Schematics命令进行编辑。

更改多个组件的多个参数

对话框支持多选。 Variant Management对话框支持多选,这意味着可以在对话框的上部(组件)同时选择任意数量的组件,然后在对话框的下部(参数)对任意数量的参数进行更新。对话框还提供过滤器(通过右键单击上下文菜单),以进一步完善选择和显示的数据。

例如,在所有变量中重置所有组件的手动变量参数:

  1. 在对话框的上部(组件),使用 Only Show Varied Components右键菜单选项,结合右键 Filter选项,仅 Show Fitted with Varied Parameters。现在组件列表中将只显示手动更改参数的组件。

  2. 右键单击组件列表,从右键菜单中选择 Select All。当前显示在对话框上部的所有组件都将被选中。

  3. 然后右键单击对话框下部(参数),从右键菜单中选择 Select All。现在所有组件的所有参数都将被选中。注意 Select Column命令,这样就可以对特定变量(列)中的组件执行操作(如重置)。

  4. 再次右键单击参数列表,从上下文菜单中选择 Reset Selected。将光标悬停在下图上,显示步骤 2、3 和 4。

重置所有变量中所有组件的所有手动更改参数。将光标移动到图片上,显示步骤 2、3 和 4。
重置所有变量中所有组件的所有手动更改参数。将光标移动到图片上,显示步骤 2、3 和 4。

如果您一直在尝试使用 "过滤器 "选项并应用了不同的过滤器,可能需要在尝试再次更新之前重置过滤器。为此,请禁用 Only Show Varied Components选项来清除过滤系统,然后根据需要重新应用并清除 Filter选项。

使用变量参数

Altium Designer 支持项目不同级别的参数。例如,文档级参数可添加到原理图编辑器的 Parameters选项卡中的 Properties面板的选项卡中添加到每个原理图工作表中(当未选择任何内容时可用)。项目级参数也可在项目选项对话框的 Parameters选项卡上添加项目级参数 (Project » Options)。

此外,还可以通过编辑项目变量对话框将参数添加到变量中。在 Variant Management对话框中,选择变量列并单击 Edit Variant按钮打开此对话框。要添加新参数,请单击 Add 按钮。在打开的 Parameter Properties对话框输入 Name 并设置新参数的 Value 然后单击 OK。新参数将显示在 Edit Project Variant 对话框中。

项目中不同层级的参数以层次结构存在,这意味着您可以在项目的不同层级创建具有相同 名称的参数,而每个参数都具有不同的值。Altium Designer 使用优先级解决了这种情况,具体方法如下:

  1. 变量(最高优先级)
  2. 示意图文件
  3. 项目

这种安排意味着原理图文档中定义的参数值优先于项目选项中定义的参数值,而变量中定义的参数值优先于原理图文档中定义的参数值。请注意,PCB 或 BOM 中没有原理图级参数--对于这些类型的输出,应使用项目或变量参数。

可通过放置特殊字符串在原理图或 PCB 文档中显示变量参数。进一步了解原理图上的特殊字符串和PCB 上的特殊字符串。

在下面的图片中,一个名为 ProjectTitle的参数已为项目和每个变量定义。动画显示 PCB 上的行为,因为 Variants选择器来显示基本设计,然后再显示每个变量。

A ProjectTitle参数(通过 Project Options 对话框)添加到项目中的参数也被添加到每个设计变量中,但每个变量的值都不同。
A ProjectTitle参数(通过 Project Options 对话框)添加到项目中的参数也被添加到每个设计变量中,但每个变量的值都不同。

一个特殊的字符串 .ProjectTitle字符串,该字符串会自动链接到同名的项目和变量参数。 一个特殊的字符串 .ProjectTitle字符串,该字符串会自动链接到同名的项目和变量参数。

生成变量报告

点击 Variant Report对话框。 Detailed Report按钮进入对话框。 Variant Management对话框可以配置和生成已定义项目变量的 HTML 格式详细报告。

对话框 Variant Report对话框
对话框 Variant Report对话框

变量错误

变量设置存储在项目文件 (*.PrjPcb)中,这些数据将被读取、分析并加载到 Variant Management对话框中。如果在加载数据时发现问题,例如组件代号或组件 UID 之间不匹配,将打开一个 Information对话框来概述问题。

在继续设计流程之前,请先解决代号和 UID 不匹配的问题。
在继续设计流程之前,请先解决代号和 UID 不匹配的问题。

组件 UID 不匹配会自动解决,保存项目时将保留这些更正。必须在原理图级别纠正重复的代号。要解决这些问题,请验证项目 (Project » Validate ) 并检查 Messages面板上的警告/错误详细信息。

AI-LocalizedAI 翻译
如您发现任何问题,请选中相关文本/图片,并按 Ctrl + Enter 键向我们提交反馈。
功能可用性

您可使用的功能取决于您所采用的 Altium 解决方案——Altium Develop、Altium Agile Teams、Altium Agile Enterprise,或 Altium Designer(在有效订阅期内)。

如果您在实际软件中未看到文档中介绍的某项功能, 请联系 Altium Sales 了解更多信息。

旧版文档

Altium Designer 文档不再提供版本区分。如果您需要访问 Altium Designer 旧版本的文档,请前往其他安装程序页面的旧版文档部分。

Content