Defining the Wiring Diagram

Auf einen Blick

Dieser Artikel erläutert, wie Kabelbaum-Verdrahtungspläne in Altium Designer erstellt, konfiguriert und verwendet werden, um die einzelnen Drahtverbindungen innerhalb eines Kabelbaumprojekts zu definieren. Er führt Sie durch das Hinzufügen eines Verdrahtungsplandokuments und das Festlegen wichtiger Dokumentoptionen wie Einheiten, Raster, Seiteneinstellungen und Vorlagen. Außerdem stellt er ergänzende Funktionen wie Validierung, Text- und Zeichenobjekte sowie das Speichern im ASCII-Format vor. Darüber hinaus erfahren Sie, wie Verdrahtungspläne mit Multi-Board-Projekten synchronisiert und Komponenten importiert oder manuell platziert werden können. So erhalten Sie einen praxisnahen Überblick über den grundlegenden Arbeitsablauf, bevor Sie mit der Ausarbeitung Ihres Designs beginnen. Lesen Sie weiter, um die wesentlichen Einrichtungs- und Synchronisierungsschritte kennenzulernen, die Ihnen die Arbeit mit Kabelbaum-Verdrahtungsplänen erleichtern.

- So fügen Sie ein Kabelbaum-Verdrahtungsplandokument hinzu und konfigurieren Einheiten, Raster, Seitenoptionen und Standardeinstellungen.
- So werden durch die Synchronisierung mit einem Multi-Board-Projekt Steckverbinderkomponenten und logische Verbindungen in den Verdrahtungsplan importiert.
- So platzieren und verwalten Sie Komponenten im Verdrahtungsplan – unabhängig davon, ob diese aus einem Multi-Board-Design importiert oder manuell hinzugefügt wurden.
Mit KI tiefer einsteigen:

Die einzelnen Drahtverbindungen innerhalb des Kabelbaums werden im Kabelbaum-Verdrahtungsplan (*.WirDoc) festgelegt. Fügen Sie dieses Dokument über das Panel Projects zum Kabelbaumprojekt hinzu, indem Sie mit der rechten Maustaste auf den Projekteintrag klicken und anschließend Add New to Project » Harness Wiring Diagram im Kontextmenü auswählen (oder verwenden Sie den Befehl File » New » Harness Wiring Diagram aus den Hauptmenüs).

Einrichten eines Kabelbaum-Verdrahtungsplandokuments

Die Optionen eines Kabelbaum-Verdrahtungsplandokuments können im Panel Properties konfiguriert werden, wenn im Designbereich des Dokuments kein Objekt ausgewählt ist. Die wichtigsten Einstellungen sind:

  • Im Bereich General auf der Registerkarte General des Panels – wählen Sie die Maßeinheiten für das Dokument und seine grafischen Elemente aus und legen Sie die Raster fest, um die Platzierung zu erleichtern. Altium Designer bietet drei Rastertypen: ein sichtbares Raster zur Orientierung, ein Fangraster zur Platzierung und einen Fangabstand zur Unterstützung beim Erstellen von Verbindungen.

  • Im Bereich Page Options auf der Registerkarte General des Panels – konfigurieren Sie das Blattformat und den Schriftkopf des Dokuments oder wählen Sie aus den verfügbaren Vorlagen für Kabelbaum-Verdrahtungspläne.

Die Registerkarten General und Parameters des Panels Properties, wenn im Kabelbaum-Verdrahtungsplandokument kein Objekt ausgewählt ist 
Die Registerkarten General und Parameters des Panels Properties, wenn im Kabelbaum-Verdrahtungsplandokument kein Objekt ausgewählt ist

  • Das Einrichten eines Kabelbaum-Verdrahtungsplandokuments ähnelt dem Einrichten eines Schaltplandokuments (*.SchDoc) in einem PCB-Designprojekt. Weitere Informationen finden Sie auf der Seite Einrichten eines Schaltplandokuments.

  • Verwenden Sie die Dropdown-Liste Length Units, um die Längeneinheiten für das Dokument auszuwählen. Die Werte Strip Length und Pull Off Length der Kontaktkammern werden in den ausgewählten Einheiten angezeigt. Unterstützt werden die Einheiten mm, cm, m, in und ft. Die Standard-Längeneinheiten für neu erstellte Verdrahtungsplandokumente können auf der Seite Harness Design – General des Dialogs Preferences festgelegt werden.

  • Weitere Informationen zum Erstellen von Vorlagen für Kabelbaum-Verdrahtungsplandokumente finden Sie auf der Seite Erstellen von Kabelbaum-Vorlagendokumenten.

  • Die Standardeigenschaften von Objekten in Kabelbaum-Verdrahtungsplänen können auf der Seite Harness Design – Defaults des Dialogs Preferences konfiguriert werden. Diese Eigenschaften werden beim Platzieren nachfolgender Objekte angewendet.

  • Beim Erstellen eines Kabelbaum-Verdrahtungsplandokuments können Sie auch Text- und Zeichenobjekte verwenden. Die Arbeit mit diesen Objekten in einem Kabelbaum-Verdrahtungsplandokument ähnelt der Arbeit mit ihnen in einem Schaltplandokument (*.SchDoc) eines PCB-Designprojekts. Weitere Informationen zu diesen Objekten finden Sie unter Arbeiten mit Textobjekten in einem Schaltplan und Arbeiten mit Zeichenobjekten in einem Schaltplan.

    • Beachten Sie, dass in Textrahmen und Notizen auch aktive Links zu Objekten in Kabelbaum-Verdrahtungsplänen (z. B. Drähten und Bauteilen) und Kabelbaum-Layoutzeichnungen (z. B. Bündeln und Verbindungspunkten) unterstützt werden. Klicken Sie auf einen Link im platzierten Textrahmen oder in der Notiz, um per Cross-Probing zum entsprechenden Objekt im zugehörigen Dokument zu navigieren.

  • Zur Prüfung Ihres Kabelbaum-Verdrahtungsplans auf logische, elektrische und zeichnerische Regelverstöße werden verschiedene Prüfungen unterstützt. Weitere Informationen finden Sie auf der Seite Validieren des Kabelbaumdesigns.

  • Ein Kabelbaum-Verdrahtungsplandokument kann im ASCII-Format gespeichert werden, was beim Austausch von Dokumenten vorteilhaft sein kann. Verwenden Sie den Befehl File » Save As und wählen Sie im sich öffnenden Dialog Save As den Eintrag Harness Wiring ascii (*.WirDoc) aus der Dropdown-Liste Save as type aus. Beim Speichern eines ASCII-Verdrahtungsplans mit dem Befehl File » Save wird der Dialog File Format geöffnet, der Sie darauf hinweist, dass das ASCII-Format verwendet wird. Wählen Sie im Dialog  die ASCII-Version aus, um dieses Format weiterhin zu verwenden.

Synchronisieren von Multi-Board- und Kabelbaumprojekten

 
 
 
 
 

Wenn das Kabelbaumprojekt Teil eines Multi-Board-Designprojekts ist, kann der Kabelbaum-Verdrahtungsplan anhand der Daten des Multi-Board-Schaltplandokuments (*.MbsDoc) synchronisiert werden. Wählen Sie dazu den Befehl Design » Import Changes From <Multi-board Project> aus den Hauptmenüs.

Weitere Informationen zum Hinzufügen eines Kabelbaum-Designprojekts zu einem Multi-Board-Projekt finden Sie auf der Seite Kabelbaumdesign.

Wenn das Multi-Board-Schaltplandokument mehr als eine Definition für Kabelbaumverbindungen enthält, wird der Dialog Select Harness Definition geöffnet. Geben Sie die Definition an, die zum aktuellen Kabelbaumprojekt gehört.

Der Dialog Select Harness Definition
Der Dialog Select Harness Definition

Anschließend wird der Dialog Engineering Change Order geöffnet. Er zeigt die im Multi-Board-Schaltplan definierten Kabelbaum-Steckverbinderbauteile und Kabelbaumnetze, die als Grundlage für den Kabelbaum-Verdrahtungsplan dienen.

Verwenden Sie den Dialog Engineering Change Order, um Daten aus dem Multi-Board-Projekt zu importieren. 
Verwenden Sie den Dialog Engineering Change Order, um Daten aus dem Multi-Board-Projekt zu importieren. 

Nach dem Ausführen der Änderungen () werden die Daten aus dem Multi-Board-Schaltplandokument in den Kabelbaum-Verdrahtungsplan importiert. Die Steckverbinderbauteile, die jeweils durch ihr Schaltplansymbol dargestellt werden, erscheinen im Kabelbaum-Verdrahtungsplandokument zunächst an beliebigen Positionen.

Beispiel eines Kabelbaum-Verdrahtungsplans direkt nach dem Import.
Beispiel eines Kabelbaum-Verdrahtungsplans direkt nach dem Import.

Zwischen den Pins werden Netzlinien angezeigt, die die im Multi-Board-Schaltplan definierten logischen Verbindungen darstellen. Beachten Sie, dass zu diesem Zeitpunkt noch keine physischen Drähte im Design vorhanden sind.

Beachten Sie, dass die aus dem Multi-Board-Projekt in das Kabelbaumprojekt importierten Verbindungsdaten auf den Pin-Namen der Steckverbinderbauteile basieren. Stellen Sie daher vor dem Datenimport sicher, dass den Bauteil-Pins in der Quellbibliothek eindeutige und korrekte Namen zugewiesen sind.

Arbeiten mit Komponenten

Neben der Synchronisierung aus dem Multi-Board-Schaltplandokument können Komponenten auch manuell im Kabelbaumverdrahtungsplan platziert werden. Dadurch können Komponenten sowohl in einem eigenständigen Kabelbaumprojekt (das nicht Teil eines Multi-Board-Projekts ist) als auch als zusätzliche Komponenten in einem Kabelbaumverdrahtungsplan platziert werden, der Teil eines Multi-Board-Projekts ist.

Verwenden Sie das Panel Components, um die Symbole der benötigten Komponenten zu platzieren. Die Komponentenplatzierung erfolgt ähnlich wie im Schaltplaneditor – weitere Informationen finden Sie auf der Seite Komponenten suchen und platzieren. Beachten Sie, dass für manuell hinzugefügte Komponenten keine Netzlinien vorhanden sind, da es kein übergeordnetes logisches Design gibt, das diese vorgibt.

  • Komponenten werden aus verfügbaren Bibliotheken platziert und in einem Kabelbaumverdrahtungsplan durch ihre Schaltplansymbolmodelle dargestellt. Weitere Informationen zum Erstellen von Komponenten finden Sie unter Komponenten und Bibliotheken erstellen und pflegen .

  • Mehrteilige Komponenten können ebenfalls in einem Kabelbaumverdrahtungsplan platziert werden. Wenn die Designdaten in die Kabelbaum-Layoutzeichnung importiert werden, werden die Bauteilkennzeichen den Komponenten in der Kabelbaum-Layoutzeichnung korrekt zugewiesen. Wenn mehrere Teile derselben Komponente im Kabelbaumverdrahtungsplan platziert sind, wird nur eine Instanz der Komponente in der Kabelbaum-Layoutzeichnung platziert ().

  • Kabelbaum-Steckverbinder können verwendet werden, um Verbindungen zwischen mehreren verschachtelten Multi-Board-Projekten herzustellen.

  • Beim Einfügen ausgeschnittener oder kopierter Kabelbaumkomponenten in einen Kabelbaumverdrahtungsplan wird für die Bauteilkennzeichen der eingefügten Komponenten die Option Reset Parts Designators On Paste auf der Seite Schematic – Graphical Editing des Dialogfelds Preferences berücksichtigt. Wenn die Option aktiviert ist, wird beim Einfügen von Komponenten der numerische Teil ihrer Bauteilkennzeichen auf ? zurückgesetzt.

Um eine platzierte Komponente (oder eine Komponente, die gerade aus dem Panel Components platziert wird) an die gewünschte Position zu verschieben, halten Sie die linke Maustaste auf der Komponente gedrückt und bewegen Sie die Maus. Verwenden Sie während des Ziehens Spacebar, um die Komponenten um 90 Grad zu drehen, und die Tasten X und Y, um sie horizontal bzw. vertikal zu spiegeln.

Der Kabelbaumverdrahtungsplan nach dem Verschieben der Komponenten
Der Kabelbaumverdrahtungsplan nach dem Verschieben der Komponenten

Die Eigenschaften einer platzierten Komponente können im Panel Properties konfiguriert werden, wenn die Komponente im Designbereich ausgewählt ist. Das Panel Properties für eine Komponente enthält die folgenden Registerkarten:

 
 
 
 
 
  • General – allgemeine Eigenschaften der Komponente, z. B. Bauteilkennzeichen und Kommentar, Position, Parameter usw.

  • Pins – die Liste der Komponentenpins.

  • Cavities – ermöglicht es, der Komponente Kontaktkammern zuzuweisen (mehr erfahren).

  • Associated Parts – ermöglicht es, der Komponente zusätzliche Teile wie Schrumpfschläuche zuzuweisen.

Registerkarten des Panels Properties bei ausgewählter Komponente
Registerkarten des Panels Properties bei ausgewählter Komponente

Kontaktkammern zuweisen

 
 
 
 
 

Einem Kabelbaum-Bauteil können Steckerkammern und deren Typ zugewiesen werden. Wählen Sie ein Bauteil im Designbereich aus, um eine Kammer und deren Typ hinzuzufügen. Wählen Sie auf der Registerkarte Cavities des Panels Properties einen Pin aus und klicken Sie anschließend auf die Schaltfläche . Wählen Sie den gewünschten Typ aus der Dropdown-Liste aus. Folgende Kammertypen werden unterstützt:

  • Crimp – stellt eine elektrische Verbindung her, indem eine Kontakthülse um einen Leiter verpresst wird.

  • Seal – schützt vor Umwelteinflüssen, indem die Leitungseinführung abgedichtet wird.

  • Plug – verschließt eine offene (unbenutzte) Steckerkammer, um die Abdichtung gegen Umwelteinflüsse aufrechtzuerhalten.

  • Other – dient zur Angabe anderer/zusätzlicher Teile oder Materialien, z. B. Lötzinn.

Für den Kammertyp Crimp oder für Zeilen, denen kein Kammertyp hinzugefügt wurde, können Sie die folgenden Werte angeben:

  • Strip Length – die Länge, über die die Isolierung des Leiters abgeschnitten wird.

  • Pull Off Length – die Länge, um die die abgeschnittene Isolierung vom Leiter abgezogen wird. Dies kann verwendet werden, wenn das Leitungsende nicht vollständig abisoliert wird und das abgeschnittene Isolierstück auf der Leitung verbleibt, um eine Beschädigung der Litze zu verhindern.

Die Einheiten, in denen diese Werte bei ausgewähltem Bauteil im Panel Properties angezeigt werden, werden über die Dropdown-Liste Length Units auf der Registerkarte General des Panels Properties festgelegt, wenn im Dokument kein Objekt ausgewählt ist.

Suchen Sie im daraufhin geöffneten Dialog Select Connector das gewünschte Bauteil und wählen Sie es aus. Der jeweilige Typ und die zugehörigen Informationen werden dem Pin auf der Registerkarte hinzugefügt, wie in den folgenden Abbildungen am Beispiel eines Crimpkontakts für Pin 1 gezeigt.

Beachten Sie, dass Pins in der Tabelle auf der Registerkarte Cavities mit ihren Namen (in der Spalte Pins) aufgeführt werden und die Kammerzuweisung auf den Pin-Namen basiert. Stellen Sie daher sicher, dass den Bauteil-Pins eindeutige und korrekte Namen zugewiesen sind.

Für Crimpkontakte, Dichtungen oder Blindstopfen kann einem Pin nur eine Kammer des jeweiligen Typs hinzugefügt werden. Sobald eine Kammer eines bestimmten Typs hinzugefügt wurde, ist der entsprechende Eintrag in der Dropdown-Liste nicht mehr verfügbar (ausgegraut). Einem Pin können beliebig viele Kammern des Typs Other hinzugefügt werden.

Pins mit zugewiesenen Crimpkontakten werden im Designbereich durch das Symbol  gekennzeichnet, wie in der folgenden Abbildung gezeigt.

Der Tabellenbereich der Registerkarte Cavities unterstützt die Mehrfachauswahl sowie das Kopieren, Einfügen und Löschen ausgewählter Einträge.

  • Mehrere Pin-Einträge können mit den Tastenkombinationen Click, Hold&Drag, Ctrl+Click, Shift+Click und Ctrl+A ausgewählt werden.

  • Wenn mehrere Pin-Einträge ausgewählt sind, klicken Sie auf  , um allen ausgewählten Pins eine Kammer hinzuzufügen, oder klicken Sie auf  bzw. drücken Sie Delete, um hinzugefügte Kammern von den ausgewählten Pins zu entfernen. 

  • Um die Kammer eines Pins zu ändern, wählen Sie dessen Eintrag aus und klicken Sie anschließend auf , um den Dialog Select Connector zu öffnen und die neue Kammer auszuwählen.

  • Wählen Sie einen oder mehrere Pin-Einträge aus und verwenden Sie die Tastenkombinationen Ctrl+X/Ctrl+C, um die ausgewählten Einträge auszuschneiden/zu kopieren. Verwenden Sie anschließend die Tastenkombination Ctrl+V, um den ausgeschnittenen/kopierten Inhalt am aktuell ausgewählten Eintrag einzufügen.

Herstellen von Verbindungen im Kabelbaum-Verdrahtungsplan

Physische Leitungen werden im Kabelbaum-Verdrahtungsplandokument platziert, indem Sie den Befehl Place » Harness Wire aus den Hauptmenüs auswählen (Tastenkombination: Shift+W).

Klicken Sie nach Auswahl des Befehls auf einen Pin eines Steckverbinders, um den Startpunkt der Kabelbaumleitung zu platzieren. Wenn sich der Cursor über dem Hotspot eines Pins befindet, erscheint ein rotes Kreuz am Cursor. Positionieren Sie den Cursor und klicken Sie, um nacheinander Stützpunkte zu setzen, die den Verlauf der Kabelbaumleitung bestimmen. Nachdem Sie den letzten Stützpunkt am Hotspot eines anderen Pins platziert haben, klicken Sie mit der rechten Maustaste, um die Platzierung abzuschließen.

Drücken Sie beim Platzieren einer Kabelbaumleitung Shift+Spacebar, um zwischen den Platzierungsmodi zu wechseln. Der Modus legt fest, wie beim Platzieren von Leitungen Ecken erzeugt werden und in welchen Winkeln Leitungen platziert werden können. Drücken Sie im Modus 90 Degree oder 45 Degree (rein orthogonale Modi) die Taste Spacebar, um zwischen den Untermodi für Anfang und Ende zu wechseln. Der aktuelle Modus und Untermodus werden in der Statusleiste angezeigt.

Beim Platzieren einer Kabelbaumleitung werden die Verbindungslinien in Echtzeit nachgeführt und aktualisiert. So sehen Sie unmittelbar, wo die Verdrahtung erfolgen soll, wie im folgenden Video gezeigt. Sobald eine Verbindung hergestellt ist, verschwindet die zugehörige Verbindungslinie aus dem Dokument.

Demonstration der Live-Nachverfolgung

Nach dem Platzieren und Auswählen einer Kabelbaumleitung können deren Stützpunkte gezogen werden, um den Winkel zwischen zwei benachbarten Abschnitten zu ändern (Beispiel anzeigen).

Wählen Sie eine Kabelbaumleitung im Entwurfsbereich aus, um sie im Panel Properties zu ändern. Im Panel können Sie die ausgewählte Kabelbaumleitung umbenennen, ihre Breite und Farbe ändern sowie Parameter hinzufügen, die im Entwurfsbereich ein- oder ausgeblendet werden können.

Das Panel Properties bei ausgewählter Kabelbaumleitung
Das Panel Properties bei ausgewählter Kabelbaumleitung

  • Eine platzierte Kabelbaumleitung kann durch eine Kabelbaum-Verdrahtungskomponente ersetzt werden, die eine einzelne Leitung enthält. Wählen Sie dazu die zu ersetzende Kabelbaumleitung aus und klicken Sie im Panel Properties auf die Schaltfläche  rechts neben dem Feld Design Item ID. Suchen Sie im daraufhin geöffneten Dialog Replace Component die gewünschte Komponente und wählen Sie sie aus. Die platzierte Leitung wird mit den Eigenschaften und Parametern der gewählten Komponente aktualisiert, wobei ihre Geometrie unverändert bleibt. Weitere Informationen finden Sie im Abschnitt Platzieren einer Kabelbaum-Verdrahtungskomponente.

  • Die Primärfarbe einer Leitung wird durch den Parameter Color definiert, der bei einer platzierten Kabelbaumleitung standardmäßig vorhanden ist. Um die Farbe zu ändern, geben Sie ihren Namen (z. B. Red) oder ihren Hexadezimalcode als Parameterwert ein. Geben Sie für den Hexadezimalcode das Zeichen # gefolgt von der Hexadezimalzahl ein, z. B. #9900FF. Alternativ können Sie auf die Farbschaltfläche links neben dem Parameterwert klicken und die sich öffnende Farbauswahl verwenden. Dort lässt sich die Leitungsfarbe über einen RGB- oder HEX-Wert, durch freie Auswahl oder anhand verschiedener Voreinstellungen festlegen.

  • Mehrfarbige Kabelbaumleitungen werden im Kabelbaum-Verdrahtungsplan durch die Auswahl einer Sekundär- und Tertiärfarbe für die Leitung unterstützt. Klicken Sie im Panel Properties auf das Dropdown-Menü   unten im Bereich Parameters und wählen Sie anschließend Secondary und Tertiary , um die gewünschten Farben festzulegen. Der Parameter für die gewählte Farbe wird im Bereich Parameters angezeigt. Über dasselbe Dropdown-Menü können Sie auch die Umrandungsfarbe der Kabelbaumleitung festlegen, indem Sie Border auswählen. Beachten Sie, dass der Parameter Color die Sichtbarkeit des kombinierten Werts der definierten Leitungsparameter Color, Secondary Color und Tertiary Color steuert. Klicken Sie sich durch die folgende Diashow, um Beispiele zu sehen.

    Javascript ID: Harness_WD_Pnl_Properties_Wire_Colors_AD25

    Eine Leitung, für die nur die Primärfarbe definiert ist

    Eine Leitung mit definierter Sekundärfarbe

    Eine Leitung mit definierter Tertiärfarbe

    Eine Leitung mit definierter Umrandungsfarbe

    Eine Leitung, für die alle Farboptionen definiert sind

    Mehrfarbige Leitungen werden von Tabellen in Fertigungszeichnungsdokumenten für Kabelbaumentwürfe (*.HarDwf) unterstützt – mehr erfahren.

  • Wenn der Parameter Include Cut einer Kabelbaumleitung den Wert No hat, wird diese Leitung nicht in einer Verdrahtungsliste oder Verbindungstabelle in der Fertigungszeichnung aufgeführt.

  • Die Parameter Color, Min. Bending Radius, Thickness und Units einer Kabelbaumleitung werden beim Synchronisieren eines Kabelbaum-Entwurfsprojekts mit einem MCAD-Tool über MCAD CoDesigner verwendet. Weitere Informationen finden Sie auf der Seite Synchronisieren eines Kabelbaum-Entwurfsprojekts.

Hinzufügen von Spleißen und Abgriffen

Wenn beim Entwurf eine neue Leitung mit einer bereits platzierten Leitung verbunden werden muss, ist zunächst ein Spleißobjekt (Place » Splice) oder ein Abgriffobjekt (Place » Tap) zu platzieren.

  • Splice – die ursprüngliche Leitung wird durch den Spleiß in zwei separate Leitungen aufgeteilt.

    Javascript ID: Harness_WD_PlacingSplice_AD25

    Eine weitere Leitung muss mit der ausgewählten Leitung (W4) verbunden werden.

    Ein auf der Leitung platzierter Spleiß. Beachten Sie, dass der Spleiß die ursprüngliche Leitung an seiner Position in zwei Leitungen aufteilt.

    Eine weitere Leitung wurde mit dem Spleiß verbunden.

    Wenn zwei Leitungen T-förmig miteinander verbunden werden, wird an der T-Verbindungsstelle automatisch ein Spleiß platziert (Beispiel anzeigen).

  • Tap – die ursprüngliche Leitung bleibt ununterbrochen.

    Javascript ID: Harness_WD_PlacingTap_AD25

    Ein weiterer Draht muss mit dem ausgewählten Draht (W4) verbunden werden.

    Eine auf dem Draht platzierte Abzweigung. Beachten Sie, dass die Abzweigung den ursprünglichen Draht nicht aufteilt.

    Ein weiterer Draht wurde mit der Abzweigung verbunden.

Die Eigenschaften einer platzierten Spleißstelle oder Abzweigung (Position und Darstellung) können im Properties Panel konfiguriert werden, wenn das Objekt im Designbereich ausgewählt ist.

Das Properties-Panel bei ausgewählter Spleißstelle/Abzweigung
Das Properties-Panel bei ausgewählter Spleißstelle/Abzweigung

Im Bereich Associated Parts des Properties-Panels können der ausgewählten Spleißstelle/Abzweigung Bauteile zugewiesen werden. Diese Bauteile werden in der Stückliste des Projekts aufgeführt.

Kabel hinzufügen

Um einen oder mehrere Drähte als Bestandteil eines Kabels zu definieren, können Sie ein Kabelobjekt im Kabelbaum-Verdrahtungsplan platzieren (Place » Harness Cable).

Platzieren Sie ein Kabel, um einen oder mehrere Drähte als Bestandteil eines Kabels zu definieren.
Platzieren Sie ein Kabel, um einen oder mehrere Drähte als Bestandteil eines Kabels zu definieren.

Wenn ein Kabelobjekt ausgewählt ist, werden die von diesem Kabel erfassten Drähte im Designbereich neongrün hervorgehoben ().

Die Eigenschaften eines platzierten Kabelobjekts (Position, Darstellung und Parameter) können im Properties Panel konfiguriert werden, wenn das Objekt im Designbereich ausgewählt ist.

Das Properties-Panel bei ausgewähltem Kabel
Das Properties-Panel bei ausgewähltem Kabel

Verwenden Sie das Steuerelement zum Sperren/Entsperren in den Width/Height Feldern des Panels, um zwischen gesperrten und entsperrten Abmessungen umzuschalten. Wenn das Objekt an seinen Bearbeitungsgriffen gezogen wird, wird das Seitenverhältnis entsprechend der Einstellung beibehalten. Standardmäßig sind die Abmessungen gesperrt, was einem Verhältnis von Höhe zu Breite von 2:1 entspricht.  Im entsperrten Zustand können Sie die Abmessungen nach Bedarf unabhängig voneinander ändern.

  • Wenn ein Kabel an mehreren Stellen im Kabelbaum-Verdrahtungsplan mit Drähten verknüpft ist (d. h., wenn mehrere Kabelobjekte mit demselben Bezeichner über verschiedenen Drähten platziert sind), werden beim Auswählen eines Objekts alle zugehörigen Drähte der Gruppe hervorgehoben. Alle diese Drähte werden im Bereich Cable Objects des Properties-Panels aufgelistet ().

  • Die Parameter Color, Min. Bending Radius, Thickness und Units eines Kabels werden verwendet, wenn ein Kabelbaum-Designprojekt mithilfe von MCAD CoDesigner mit einem MCAD-Tool synchronisiert wird. Weitere Informationen finden Sie auf der Seite Synchronisieren eines Kabelbaum-Designprojekts.

Abschirmung und Verdrillung von Drähten

Eine Abschirmung (mit oder ohne Anschluss, beispielsweise für einen Beidraht) kann einer Gruppe von Drähten zugewiesen werden, indem entweder ein Abschirmungsobjekt (Place » Shield) oder ein Abschirmungsobjekt mit Anschluss (Place » Shield with Connection) platziert wird.

Im unten gezeigten Beispiel sind die Drähte W1, W2 und W3 durch eine Abschirmung ohne Anschluss (SH1) abgeschirmt. Die Drähte W4, W8 und W9 sind durch eine Abschirmung mit Anschluss (SH2) abgeschirmt. Draht W10 wird platziert, um SH2 mit einem Bauteilpin zu verbinden.

Platzieren Sie ein Abschirmungsobjekt oder ein Abschirmungsobjekt mit Anschluss, um Drähte als abgeschirmt zu kennzeichnen.
Platzieren Sie ein Abschirmungsobjekt oder ein Abschirmungsobjekt mit Anschluss, um Drähte als abgeschirmt zu kennzeichnen.

Wenn ein Abschirmungsobjekt oder ein Abschirmungsobjekt mit Anschluss ausgewählt ist, werden die erfassten Drähte im Designbereich neongrün hervorgehoben ().

Die Eigenschaften eines platzierten Abschirmungsobjekts oder Abschirmungsobjekts mit Anschluss (Position und Darstellung) können im Properties Panel konfiguriert werden, wenn das Objekt im Designbereich ausgewählt ist. Im Bereich Shield Objects des Panels werden die vom ausgewählten Objekt erfassten Drähte aufgelistet.

Das Properties-Panel bei ausgewählter Abschirmung
Das Properties-Panel bei ausgewählter Abschirmung

  • Verwenden Sie das Steuerelement zum Sperren/Entsperren in den Width/Height-Feldern des Panels, um zwischen gesperrten und entsperrten Abmessungen umzuschalten. Wenn das Objekt an seinen Bearbeitungsgriffen gezogen wird, wird das Seitenverhältnis entsprechend der Einstellung beibehalten. Standardmäßig sind die Abmessungen gesperrt, was einem Verhältnis von Höhe zu Breite von 2:1 entspricht.  Im entsperrten Zustand können Sie die Abmessungen nach Bedarf unabhängig voneinander ändern.

  • Wenn eine Abschirmung an mehreren Stellen im Kabelbaum-Verdrahtungsplan mit Drähten verknüpft ist (d. h., wenn mehrere Abschirmungsobjekte mit demselben Bezeichner über verschiedenen Drähten platziert sind), werden beim Auswählen eines Objekts alle zugehörigen Drähte der Gruppe hervorgehoben. Alle diese Drähte werden im Bereich Shield Objects des Properties-Panels aufgelistet ().

Drähte können durch Platzieren eines Verdrillungsobjekts (Place » Twist) als miteinander verdrillt gekennzeichnet werden. Ein Verdrillungsobjekt kann über zwei oder mehr Drähten platziert werden.

Im folgenden Beispiel sind die Drähte W1 und W2 durch das Verdrillungsobjekt Tw1 als miteinander verdrillt gekennzeichnet.

Platzieren Sie ein Verdrillungsobjekt, um Drähte als miteinander verdrillt zu kennzeichnen.
Platzieren Sie ein Verdrillungsobjekt, um Drähte als miteinander verdrillt zu kennzeichnen.

Wenn ein Verdrillungsobjekt ausgewählt ist, werden die erfassten Drähte im Designbereich neongrün hervorgehoben ().

Die Eigenschaften eines platzierten Verdrillungsobjekts (Position und Darstellung) können im Properties Panel konfiguriert werden, wenn das Objekt im Designbereich ausgewählt ist. Im Bereich Twist Objects des Panels werden die vom ausgewählten Verdrillungsobjekt erfassten Drähte aufgelistet.

Das Properties-Panel bei ausgewähltem Verdrillungsobjekt
Das Properties-Panel bei ausgewähltem Verdrillungsobjekt

  • Verwenden Sie das Steuerelement zum Sperren/Entsperren in den Width/Height-Feldern des Panels, um zwischen gesperrten und entsperrten Abmessungen umzuschalten. Wenn das Objekt an seinen Bearbeitungsgriffen gezogen wird, wird das Seitenverhältnis entsprechend der Einstellung beibehalten. Standardmäßig sind die Abmessungen gesperrt, was einem Verhältnis von Höhe zu Breite von 1:1 entspricht.  Im entsperrten Zustand können Sie die Abmessungen nach Bedarf unabhängig voneinander ändern.

  • Wenn ein Verdrillungsobjekt an mehreren Stellen im Kabelbaum-Verdrahtungsplan mit Drähten verknüpft ist (d. h., wenn mehrere Verdrillungsobjekte mit demselben Bezeichner über verschiedenen Drähten platziert sind), werden beim Auswählen eines Objekts alle zugehörigen Drähte der Gruppe hervorgehoben. Alle diese Drähte werden im Bereich Twist Objects des Properties-Panels aufgelistet ().

  • Die Parameter Verdrillungen pro Längeneinheit und Thickness eines Verdrillungsobjekts werden verwendet, wenn ein Kabelbaum-Designprojekt mithilfe von MCAD CoDesigner mit einem MCAD-Tool synchronisiert wird. Weitere Informationen finden Sie auf der Seite Synchronisieren eines Kabelbaum-Designprojekts.

Nicht verbundene Drähte

Nicht verbundene Drahtenden werden durch ein ausgefülltes Quadrat gekennzeichnet.

Ein als nicht verbunden gekennzeichneter Draht
Ein als nicht verbunden gekennzeichneter Draht

Ein Drahtende sollte nicht unverbunden bleiben. Wenn das Design ein nicht verbundenes Drahtende erfordert, sollte am Ende ein „No Connect“-Objekt platziert werden (Place » No Connect).

Platzieren Sie ein „No Connect“-Objekt am Ende eines Drahts, der unverbunden bleiben soll.
Platzieren Sie ein „No Connect“-Objekt am Ende eines Drahts, der unverbunden bleiben soll.

Die Eigenschaften eines platzierten „No Connect“-Objekts (Position und Darstellung) können im Properties Panel konfiguriert werden, wenn das Objekt im Designbereich ausgewählt ist.

Das Properties-Panel bei ausgewähltem „No Connect“-Objekt
Das Properties-Panel bei ausgewähltem „No Connect“-Objekt

Arbeiten mit mehreren Blättern

Ein vollständiger Kabelbaum-Verdrahtungsplan kann sich über mehrere Blätter erstrecken (in einer „flachen“ Entwurfsstruktur, in der alle Blätter auf derselben Ebene liegen), die jeweils durch ein eigenes *.WirDoc Dokument repräsentiert werden. Die elektrische Verbindung zwischen beliebigen Blättern wird direkt über Leitungsunterbrechungsobjekte (Place » Wire Break) mit derselben Leitungsbezeichnung hergestellt.

Nachdem Sie den Befehl zum Platzieren einer Leitungsunterbrechung ausgewählt haben, positionieren Sie das Objekt so, dass sein elektrischer Anschlusspunkt (das am Cursor befindliche Ende) die Leitung berührt, mit der Sie es verbinden möchten. Klicken Sie dann oder drücken Sie Enter, um das Objekt zu platzieren. Eine platzierte Leitungsunterbrechung übernimmt die Eigenschaften (Bezeichnung und Farbe) der Leitung, mit der sie verbunden ist.

Wählen Sie eine Leitungsunterbrechung im Designbereich aus, um sie im Panel Properties zu ändern. Im Panel können Sie die Bezeichnung der angeschlossenen Leitung sowie den Stil der Leitungsunterbrechung festlegen: Richtung (Left oder Right) und Farbe.

Synchronisierung von Leitungen

Kabelbaumleitungen, die über eine Leitungsunterbrechung verbunden sind, werden auch dann erkannt, wenn sie unterschiedliche Design Item IDs haben. Darüber hinaus werden alle Leitungssegmente mit derselben Bezeichnung, die über dieselbe Leitungsunterbrechung verbunden sind, miteinander verglichen (hinsichtlich Teilenummer, Kommentar, Farbe und sämtlicher Parameter). Werden Unterschiede festgestellt, wird der Verstoß Mismatched parameters in connected wire segments gemeldet. Außerdem erscheint im Panel Properties der Leitung und der Leitungsunterbrechung eine Warnung, die auf einen Konflikt zwischen den Parametern hinweist. Klicken Sie in der Warnung auf Synchronize , um den Dialog Conflict Wire Parameters zu öffnen. Dort können Sie auswählen, welche Parameter für das Leitungssegment verwendet werden sollen.

Eigenschaften und Parameter der Leitung vor der Synchronisierung

Im Panel Properties erscheint eine Warnung, die auf einen Konflikt zwischen Parametern hinweist. Wenn Sie in der Warnung auf Synchronize klicken, öffnet sich der Dialog Confirm Wire Parameters. Wählen Sie die gewünschte Option aus und klicken Sie anschließend auf OK, um die Synchronisierung durchzuführen.

Der Verstoß Mismatched parameters in connected wire segments im Dialog Project Options

Nach der Synchronisierung sind die Eigenschaften der Leitungssegmente abgeglichen. 

 
  • Beachten Sie, dass beim Ändern der Farbe und Bezeichnung einer Leitungsunterbrechung auch die Farbe und Bezeichnung der angeschlossenen Leitung entsprechend geändert werden. Umgekehrt werden beim Ändern der Farbe und Bezeichnung einer Leitung auch die Farbe und Bezeichnung der angeschlossenen Leitungsunterbrechung entsprechend geändert.

  • Sie können die Eigenschaften einer Leitungsunterbrechung auch während der Platzierung ändern, indem Sie nach Auswahl des Platzierungsbefehls Tab drücken. Beachten Sie: Wenn vor dem Platzieren eine Bezeichnung für die Leitungsunterbrechung festgelegt wurde, übernimmt die angeschlossene Leitung die Bezeichnung und Farbe der Leitungsunterbrechung.

  • Wenn für eine Leitung, an die eine Leitungsunterbrechung angeschlossen ist, eine Umrandungsfarbe festgelegt wurde, wird auch diese Leitungsunterbrechung mit einer Umrandung in dieser Farbe angezeigt. Außerdem wird die Bezeichnung der Leitungsunterbrechung in der Umrandungsfarbe der angeschlossenen Leitung dargestellt.

  • Leitungsunterbrechungen haben keine eigenen Schrifteigenschaften. Sie verwenden die Eigenschaften Document Font des Kabelbaum-Verdrahtungsplandokuments, auf dem sie platziert sind.

  • Leitungsunterbrechungen können auch verwendet werden, um Verbindungen innerhalb desselben Blatts eines Kabelbaum-Verdrahtungsplans herzustellen – beispielsweise können Sie anstelle einer Leitung zwischen zwei Steckverbinderkontakten an jedem dieser Kontakte eine kurze Kabelbaumleitung mit einer Leitungsunterbrechung platzieren ().

Platzieren einer Kabelbaum-Verdrahtungskomponente

Wenn Sie mit Ihrem Workspace verbunden sind, können Sie dort nach Bedarf Komponenten mit vordefinierter Struktur und vordefinierten Eigenschaften erstellen. Diese Komponenten können Sie anschließend in Ihren Kabelbaumentwürfen wiederverwenden, indem Sie sie direkt in Kabelbaum-Verdrahtungsplandokumenten platzieren.

Weitere Informationen finden Sie auf der Seite Erstellen einer Kabelbaum-Verdrahtungskomponente.

Auf diese Komponenten (denen jeweils ein definiertes Kabelbaum-Verdrahtungsmodell zugewiesen ist) greifen Sie über das Panel Components zu. Wenn das gewünschte Kabelbaum-Verdrahtungsplandokument im Designbereich aktiv ist, platzieren Sie eine Komponente, indem Sie im Panel mit der rechten Maustaste auf deren Eintrag klicken und im Kontextmenü den Befehl Place <ComponentName> auswählen. Das Verhalten beim Platzieren einer Komponente hängt davon ab, ob die Komponente ein einzelnes Leitungsobjekt oder eine Kabelstruktur enthält (mehrere Leitungen und/oder zusätzliche Objekte wie Kabel, Schirme usw.).

  • Single wire – Beim Platzieren einer Komponente, die ein einzelnes Leitungsobjekt enthält, wechseln Sie in den Modus zum Platzieren von Kabelbaumleitungen. Die zu platzierende Leitung übernimmt die bei der Komponentenerstellung definierten Eigenschaften. Weitere Informationen zum Platzieren von Kabelbaumleitungen finden Sie im obigen Abschnitt Herstellen von Verbindungen im Kabelbaum-Verdrahtungsplan.

  • Cable structure – Wenn Sie den Platzierungsbefehl für eine Komponente auswählen, die eine Kabelstruktur enthält, wird diese Kabelstruktur genau so am Cursor angezeigt, wie sie bei der Komponentenerstellung definiert wurde. Klicken Sie auf die gewünschte Stelle im Kabelbaum-Verdrahtungsplandokument, um die Komponente zu platzieren. Anschließend können Sie die Objekte der Komponente einzeln bearbeiten, beispielsweise um die zum Kabel gehörenden Leitungen an die Kontakte von Kabelbaum-Steckverbindern anzuschließen.

Aktualisieren des Verdrahtungsplans aus Bibliotheken

Die folgenden Objekte können aus ihrer ursprünglichen Workspace-Bibliothek aktualisiert werden:

  • Kabelbaumkomponenten

  • Kontaktkammern von Kabelbaumkomponenten

  • Den Kabelbaumkomponenten zugeordnete Teile

  • Leitungen

Wenn ein Objekt ausgewählt ist, finden Sie Informationen zur verknüpften Workspace-Komponente im Panel Properties (z. B. auf der Registerkarte Associated Parts für die einer Kabelbaumkomponente zugeordneten Teile).

Wenn eine neuere Revision der Workspace-Komponente verfügbar ist, wird dies im Eintrag für den Revisionsstatus durch den Text Out of date angezeigt. Für ein einzelnes Objekt können Sie die Verknüpfung auf die neueste Revision der Workspace-Komponente aktualisieren, indem Sie auf die Schaltfläche  klicken.

Beispiel für die Kennzeichnung einer veralteten Revision einer Kabelbaumkomponente​
Beispiel für die Kennzeichnung einer veralteten Revision einer Kabelbaumkomponente

Die Funktion Update from Libraries (Tools » Update from Libraries) kann ebenfalls verwendet werden, um veraltete Komponenten zu aktualisieren, die mit den oben aufgeführten Objekten verknüpft sind. Beachten Sie: Damit ein Objekt bei der Aktualisierung mit der Funktion Update from Libraries berücksichtigt wird, muss die dem Objekt zugewiesene Komponente eine Verknüpfung zu einem Schaltplansymbol enthalten.

Annotieren von Objekten im Kabelbaum-Verdrahtungsplan

Verwenden Sie die Befehle im Menü Tools » Annotation, um die folgenden Objekte im Kabelbaum-Verdrahtungsplandokument zu annotieren:

  • Kabelbaumkomponenten

  • Leitungen

  • Spleiße und Abgriffe

  • Kabel

  • Schirme und Schirme mit Anschluss

  • Verdrillungen

  • „Nicht verbunden“-Objekte

Das Annotieren von Objekten in einem Kabelbaum-Verdrahtungsplandokument ähnelt dem Annotieren von Komponenten in einem Schaltplandokument (*.SchDoc) eines PCB-Designprojekts. Über die folgenden Links erfahren Sie mehr über die für ein Kabelbaum-Verdrahtungsplandokument verfügbaren Annotationsbefehle:

AI-LocalizedKI-lokalisiert
Wenn Sie ein Problem feststellen, wählen Sie den Text/das Bild aus und drücken SieCtrl + Enter, um uns Ihr Feedback zu senden.
Contents
Funktionsverfügbarkeit

Die Ihnen zur Verfügung stehenden Funktionen hängen davon ab, über welche Altium-Lösung Sie verfügen – Altium Develop, Altium Agile Teams, Altium Agile Enterprise oder Altium Designer (mit aktivem Laufzeitvertrag).

Wenn Sie eine dokumentierte Funktion in Ihrer tatsächlich verwendeten Software nicht sehen, wenden Sie sich an den Altium-Vertrieb, um mehr zu erfahren.

Legacy-Dokumentation

Die Dokumentation von Altium Designer wird nicht mehr versioniert. Wenn Sie auf Dokumentation für ältere Versionen von Altium Designer zugreifen müssen, besuchen Sie den Abschnitt Legacy-Dokumentation auf der Seite Andere Installer.

Contents