Bauteile in einem Design kennzeichnen
Altium Essentials: Schematic Updating
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
Auf einen Blick
- Erfahren Sie, welchem Zweck die Design-Annotation dient und warum eindeutige Bauteilreferenzkennzeichen in Schaltplänen, im PCB-Layout und in Ausgaben wie der Stückliste wichtig sind.
- Lernen Sie die Unterschiede zwischen der Annotation auf Schaltplanebene, auf PCB-Ebene und auf Baugruppenebene kennen – einschließlich der Designtypen, für die sich das jeweilige Verfahren am besten eignet.
- Erhalten Sie einen ersten Einblick in den Dialog „Annotate“ und die wichtigsten Einstellungen zur Steuerung des Annotationsumfangs, der Verarbeitungsreihenfolge, der Zuordnungsoptionen und der vorgeschlagenen Änderungen.
Die Design-Annotation ist ein systematischer und methodischer Prozess, der sicherstellt, dass jedes Bauteil im Design anhand eines eindeutigen Bezeichners individuell identifiziert werden kann. Altium Designer kann die Identität von Bauteilen zwar mithilfe global eindeutiger IDs (GUIDs) verwalten, doch die meisten Entwickler verwenden traditionell den Bauteilbezeichner als primäre Referenz für das Bauteil – sowohl im Schaltplan (logische Ebene) als auch auf der Leiterplatte (physische Ebene) sowie in Ausgaben wie der Stückliste (BOM).
Es gibt drei Ansätze zur Annotation eines Designs. Die Wahl des Annotationswerkzeugs hängt von verschiedenen Faktoren ab, darunter die Art des Designs, persönliche Vorlieben sowie Unternehmensrichtlinien und -verfahren.
Schematic Level Annotation
Die Annotation auf Schaltplanebene verwendet eine rein logische Sicht auf das Design, um die Bauteilbezeichner festzulegen. Sie eignet sich besonders für einfache Designs, die keine Device Sheets verwenden. Da sie jedoch ermöglicht, die Verarbeitungsreihenfolge festzulegen und vorhandene Gehäuse mehrteiliger Bauteile zu vervollständigen, ist sie auch eine Voraussetzung für die Annotation auf Board-Ebene.
Zusammengefasst verwenden Sie die Annotation auf Schaltplanebene, um:
- Teilkomponenten mehrteiliger Bauteile zu Gehäusen zusammenzufassen.
- Bauteile anhand ihrer Position im Schaltplandesign zu annotieren.
- Mehrkanal-Designs mit dem in den Projektoptionen festgelegten Standard-Benennungsschema zu annotieren.
- Ein Design für weitere Annotationsschritte vorzubereiten.
PCB Annotation
Die PCB-Annotation verwendet die physische Position der Bauteile auf der Leiterplatte, um ihre Bezeichner festzulegen. Dadurch lassen sich Positionsinformationen effektiv im Bauteilbezeichner abbilden, was bei der Fehlersuche auf einer bestückten Leiterplatte sehr hilfreich sein kann. Kurz gesagt: Verwenden Sie die PCB-Annotation, um Bauteile anhand ihrer Position auf der Leiterplatte im PCB-Design zu annotieren.
Board Level Annotation
Die Annotation auf Board-Ebene stellt eine Zuordnung zwischen den im Schaltplandesign (logische Ebene) verwendeten Bezeichnern und ihren tatsächlichen Entsprechungen im PCB-Design (physische Ebene) her. Sie kann zwar in jedem Design verwendet werden, ist aber besonders hilfreich bei Mehrkanal-Designs oder Designs mit Device Sheets, deren Bezeichner nicht direkt auf dem Device Sheet bearbeitet werden können. Auf diese Weise kann das gesamte Design neu annotiert werden, ohne die ursprünglichen Device Sheets tatsächlich zu ändern. Die Annotation auf Board-Ebene löst Annotationskonflikte, die durch doppelte Bezeichner innerhalb eines Projekts entstehen können, und speichert ihre Änderungen in einer *.Annotation-Textdatei. Sie bietet zusätzliche Schlüsselwörter zur Anpassung von Benennungsschemata und ermöglicht, diese auf alle oder nur auf eine ausgewählte Gruppe von Teilkomponenten anzuwenden.
Zusammengefasst verwenden Sie die Annotation auf Board-Ebene, um:
- Die kompilierten Bauteile in Device Sheets zu annotieren.
- Alle Bauteile über mehrere Kanäle hinweg eindeutig zu benennen – mithilfe von Benennungsschemata, die positionsbasierte Annotation, globale Indizierung und weitere konfigurierbare Optionen umfassen.
- Bauteile manuell zu benennen.
Schaltplanannotation
Die Schaltplanannotation wird im Dialogfeld Annotate konfiguriert. Das Dialogfeld bietet Steuerelemente, um allen oder ausgewählten Teilkomponenten auf ausgewählten Blättern eines Projekts systematisch Bezeichner zuzuweisen. Dabei wird sichergestellt, dass die Bezeichner eindeutig sind und entsprechend ihrer Position angeordnet werden. Die Annotationsoptionen lassen sich so konfigurieren, dass Teilkomponenten mehrteiliger Bauteile zu Gehäusen zusammengefasst, Index- und Suffixoptionen festgelegt, Schaltplanbezeichner einschließlich doppelter Bezeichner zurückgesetzt und Änderungen von der Leiterplatte rückannotiert werden.
Das Dialogfeld Annotate wird durch Ausführen des Befehls „Schaltpläne annotieren“ (Tools » Annotation » Annotate Schematics) geöffnet.

Das Dialogfeld Annotate wird über den Befehl Annotate Schematics geöffnet.
Das Dialogfeld ist in zwei Hauptbereiche unterteilt:
- Schematic Annotation Configuration – In diesem Bereich werden das Annotationsschema und der Umfang der Annotation konfiguriert.
- Proposed Change List – In diesem Bereich werden die vorgeschlagenen Änderungen aufgelistet, die nach ihrer Annahme mithilfe eines Engineering Change Order (ECO) ausgeführt werden.
Optionen und Steuerelemente des Dialogfelds „Annotieren“
Konfiguration der Schaltplanannotation
Verarbeitungsreihenfolge
In diesem Bereich legen Sie die gewünschte Methode der positionsbasierten Annotation fest. Wenn Sie eine Methode aus der Dropdown-Liste auswählen, wird die zugehörige grafische Darstellung dynamisch aktualisiert und veranschaulicht, wie die Bauteile annotiert werden. Wählen Sie eine der folgenden Methoden für die positionsbasierte Annotation:
- Up Then Across
- Down Then Across
- Across Then Up
- Across Then Down
Positionsreferenz
In diesem Bereich legen Sie die Referenz für die Bauteilpositionen bei der Ermittlung der Annotationsreihenfolge fest. Wählen Sie eine der folgenden Optionen:
- Designator – Der Bezeichner des Bauteils wird bei der Ermittlung der Verarbeitungsreihenfolge als Referenz für dessen Position verwendet.
- Part – Der Mittelpunkt des Bauteils wird bei der Ermittlung der Verarbeitungsreihenfolge als Referenz für dessen Position verwendet.
Teilkomponenten ersetzen
Wählen Sie in der Dropdown-Liste aus, ob Teilkomponenten im Rahmen des Annotationsprozesses ersetzt werden sollen.
Abgleichoptionen
Bei mehrteiligen Bauteilen ist es häufig wünschenswert, möglichst viele Teilkomponenten in einer möglichst geringen Anzahl physischer Bauteile unterzubringen, da dies die gesamten Stücklistenkosten des Designs minimiert. Mit den Steuerelementen in diesem Bereich legen Sie fest, wie Bauteile abgeglichen und zusammengefasst werden und welche Kriterien für gültige Gruppierungen gelten.
-
Complete Existing Packages – Mit diesem Steuerelement legen Sie fest, ob und wie noch nicht annotierte Teilkomponenten in vorhandene Gehäuse aufgenommen werden. Wählen Sie in der Dropdown-Liste eine der folgenden Optionen aus:
- None – Vorhandene Gehäuse werden nicht vervollständigt; alle neuen Teilkomponenten werden neuen Gehäusen zugeordnet.
- Per Sheet – Vorhandene Gehäuse werden nur um neue Teilkomponenten aus demselben Schaltplanblatt ergänzt.
- Whole Project – Vorhandene Gehäuse werden um neue Teilkomponenten aus beliebigen Schaltplanblättern des Projekts ergänzt.
- Component Parameter – Diese Liste enthält alle Parameter, die in den Bauteilen des aktuellen Designs vorkommen. Aktivieren Sie das Kontrollkästchen eines Parameters, um ihn beim Abgleich von Teilkomponenten für die Zuordnung zu Gehäusen zu verwenden. Wenn mehrteilige Bauteile dieselben aktivierten Parameter mit übereinstimmenden Werten aufweisen, werden sie gemeinsam einem Gehäuse zugeordnet (sofern die Option Complete Existing Packages nicht auf Nonegesetzt ist). Alle verbleibenden Bauteile, die die aktivierten Parameter nicht aufweisen, werden ebenfalls zusammengefasst.
- Strictly - aktivieren Sie diese Option für einen Component Parameter in der Liste, um festzulegen, dass alle Komponenten must diesen Parameter aufweisen müssen, um zu einem Gehäuse zusammengefasst zu werden. Komponenten ohne diesen Parameter werden als einzelne Komponenten annotiert und keinem Gehäuse zugeordnet.
Kontextmenü
- Parameter » Enable Selected Parameters - aktiviert das Kontrollkästchen „Include“ für alle aktuell in der Liste ausgewählten Parameter.
- Parameter » Enable All Parameters - aktiviert das Kontrollkästchen „Include“ für alle Parameter in der Liste.
- Parameter » Disable Selected Parameters - deaktiviert das Kontrollkästchen „Include“ für alle aktuell in der Liste ausgewählten Parameter.
- Parameter » Disable All Parameters - deaktiviert das Kontrollkästchen „Include“ für alle Parameter in der Liste.
- Match Strictly » Enable Strict Matching On Selected Parameters - aktiviert die Option Strictly für alle aktuell in der Liste ausgewählten Parameter.
- Match Strictly » Enable Strict Matching On All Parameters - aktiviert die Option Strictly für alle Parameter in der Liste.
- Match Strictly » Disable Strict Matching On Selected Parameters - deaktiviert die Option Strictly für alle aktuell in der Liste ausgewählten Parameter.
- Match Strictly » Disable Strict Matching On All Parameters - deaktiviert die Option Strictly für alle Parameter in der Liste.
- Selection » Select All - wählt alle Parametereinträge in der Liste aus.
- Selection » Deselect All - hebt die Auswahl aller Parametereinträge in der Liste auf.
- Selection » Invert Selection - wählt alle derzeit nicht ausgewählten Parameter in der Liste aus und hebt die Auswahl der aktuell ausgewählten Parameter auf.
Zu annotierende Schaltplanblätter
Dieser Bereich des Dialogs listet alle Quellschaltplanblätter im Designprojekt auf. Mit den Steuerelementen in diesem Bereich legen Sie fest, welche Blätter in den Annotationsprozess einbezogen werden und wie die Annotationsänderungen berechnet werden. Für jedes Blatt werden die folgenden Angaben angezeigt:
- Include/Exclude checkbox - aktivieren Sie dieses Kontrollkästchen, um das Schaltplanblatt in den Annotationsprozess einzubeziehen.
- Schematic Sheet - dieses Feld zeigt den Namen des Schaltplanblatts an.
-
Annotation Scope - legen Sie in diesem Feld fest, welche Komponenten auf dem Blatt annotiert werden sollen. Wählen Sie in der Dropdown-Liste einen der folgenden Geltungsbereiche:
- All - alle Teile auf dem Schaltplanblatt werden annotiert.
- Ignore Selected Parts - alle Teile mit Ausnahme der aktuell im Design ausgewählten Teile werden annotiert.
- Only Selected Parts - nur die aktuell im Design ausgewählten Teile werden annotiert.
- Order - legen Sie in diesem Feld fest, an welcher Stelle dieses Blatt in der gesamten Annotationsreihenfolge der Blätter stehen soll. Geben Sie die gewünschte Ordnungsnummer direkt in das Feld ein oder verwenden Sie die Pfeile, die beim Klicken in das Feld erscheinen, um den gewünschten Wert einzustellen.
- Designator Index Control - mit den Steuerelementen in dieser Spalte können Sie die Verwendung eines Startindex aktivieren (durch Aktivieren des zugehörigen Kontrollkästchens) und einen Wert für den Index festlegen. Die Nummerierung der Bezeichner beginnt bei diesem Indexwert.
- Add Suffix - legen Sie in diesem Feld ein Suffix fest, das an jeden annotierten Bezeichner angehängt werden soll. Unterstützt werden alphabetische (A, B, C...), numerische (1, 2, 3...) und nicht alphanumerische (_ * . %...) Suffixe sowie Kombinationen daraus.
Additional Controls
- All On - klicken Sie hier, um alle Schaltplanblätter in den Annotationsprozess einzubeziehen.
- All Off - klicken Sie hier, um alle Schaltplanblätter vom Annotationsprozess auszuschließen.
-
Right-Click Menu - im Kontextmenü dieses Bereichs stehen die folgenden Befehle zur Verfügung:
-
Order Alphabetically - sortiert die Liste der Schaltpläne alphabetisch. Dies wirkt sich auf den zugehörigen Eintrag Order für jedes Blatt aus.
-
Order By Project Order - sortiert die Liste der Schaltpläne entsprechend ihrer Reihenfolge im Projekt (wie im Panel Projects angezeigt). Dies wirkt sich auf den zugehörigen Eintrag Order für jedes Blatt aus.
-
All On - bezieht alle Schaltplanblätter in den Annotationsprozess ein.
-
All Off - schließt alle Schaltplanblätter vom Annotationsprozess aus.
-
Liste der vorgeschlagenen Änderungen
-
Main List - dieser Bereich des Dialogs listet alle Bezeichner der Teile auf, die sich auf den zur Annotation ausgewählten Blättern befinden. Für jeden Eintrag werden die Werte von Current und Proposed Designator sowie Sub (Teil) der Komponente und die Quelle Location of Part angezeigt. Die Vorhängeschlosssymbole kennzeichnen gesperrte Spalten, um Änderungen an Bezeichnern und Teilkomponenten zu verhindern.
Wenn Sie das Kontrollkästchen neben einem Bezeichner in der Spalte Current („Bezeichner gesperrt“) aktivieren, wird dieser Bezeichner gegen jegliche Änderungen gesperrt. Ebenso verhindert das Aktivieren des Kontrollkästchens neben dem Feld Sub eines Bezeichners („Teilkomponente gesperrt“), dass diese bestimmte Teilkomponente der übergeordneten mehrteiligen Komponente aktualisiert wird.
Im Kontextmenü dieses Bereichs stehen die folgenden Befehle zur Verfügung:
- Designator » Lock Selected Designators - aktiviert das Kontrollkästchen „Bezeichner gesperrt“ für alle aktuell in der Liste ausgewählten Bezeichner.
- Designator » Lock All Designators - aktiviert das Kontrollkästchen „Bezeichner gesperrt“ für alle Bezeichner.
- Designator » Unlock Selected Designators - deaktiviert das Kontrollkästchen „Bezeichner gesperrt“ für alle aktuell in der Liste ausgewählten Bezeichner.
- Designator » Unlock All Designators - deaktiviert das Kontrollkästchen „Bezeichner gesperrt“ für alle Bezeichner.
- Part ID » Lock Selected Part ID - aktiviert das Kontrollkästchen „Teilkomponente gesperrt“ für alle aktuell in der Liste ausgewählten Bezeichner.
- Part ID » Lock All Part ID - aktiviert das Kontrollkästchen „Teilkomponente gesperrt“ für alle Bezeichner.
- Part ID » Unlock Selected Part ID - deaktiviert das Kontrollkästchen „Teilkomponente gesperrt“ für alle aktuell in der Liste ausgewählten Bezeichner.
- Part ID » Unlock All Part ID - deaktiviert das Kontrollkästchen „Teilkomponente gesperrt“ für alle Bezeichner.
- Selection » Select All - wählt alle Bezeichnereinträge in der Liste aus.
- Selection » Select All With '?' - wählt alle Einträge aus, deren aktueller Bezeichner ein ? enthält (d. h. zurückgesetzt wurde).
- Selection » Deselect All - hebt die Auswahl aller Bezeichnereinträge in der Liste auf.
- Selection » Invert Selection - wählt alle derzeit nicht ausgewählten Bezeichner in der Liste aus und hebt die Auswahl der aktuell ausgewählten Bezeichner auf.
- Annotation Summary - dieser Bereich bietet eine Zusammenfassung der Annotation hinsichtlich der Anzahl der einbezogenen Blätter und der Abgleichoptionen. Sie wird bei Änderungen in diesen Bereichen dynamisch aktualisiert.
- Update Changes List - Klicken Sie hier, um die Hauptliste der vorgeschlagenen Änderungen mit neu berechneten Änderungen auf Grundlage der links im Dialog definierten Annotationseinstellungen zu aktualisieren. Ein Informationsdialog zeigt an, wie viele Änderungen seit dem vorherigen Zustand und wie viele seit dem ursprünglichen Zustand vorgenommen wurden.
- Reset All - Klicken Sie hier, um alle nicht gesperrten Bezeichner in der Hauptliste auf ihre standardmäßigen Bauteilpräfixe zurückzusetzen, z. B. R?, C?, D?. Die Änderungen werden in die Bezeichnerspalte Proposed übernommen. Über das Dropdown-Menü der Schaltfläche können Sie den Befehl in Reset Duplicates ändern. Wenn zwei oder mehr Bauteile denselben Bezeichner haben, werden alle bis auf eines auf ihre Standardpräfixe zurückgesetzt. Auch hier zeigt ein Informationsdialog an, wie viele Änderungen seit dem vorherigen Zustand und wie viele seit dem ursprünglichen Zustand vorgenommen wurden.
- Back Annotate - Klicken Sie hier, um einen Dialog zum Suchen und Auswählen der Datei für die Rückannotation zu öffnen.
- Accept Changes (Create ECO) - Nachdem Sie alle vorgeschlagenen Änderungen überprüft haben, klicken Sie auf diese Schaltfläche, um den Dialog Engineering Change Order aufzurufen. Dieser führt die vorgeschlagenen Änderungen als Modifikationen in der Änderungskategorie „Bauteil annotieren“ auf. Verwenden Sie diesen Dialog, um den ECO zu validieren und auszuführen und damit den Annotationsprozess auf Schaltplanebene abzuschließen.
Bauteile sperren
Stellen Sie bei inhomogenen mehrteiligen Bauteilen sicher, dass die Schlosssymbole im Panel Properties geschlossen sind, um Änderungen an Teilbauteilen während der Annotation zu verhindern.
Option „Strikt“
Wenn das Kontrollkästchen Strictly für einen Component Parameter aktiviert ist, müssen alle Bauteile anhand dieses Parameters einem Gehäuse zugeordnet werden. Bauteile ohne diesen Parameter werden als einzelne Bauteile annotiert und keinem Gehäuse zugeordnet.
Das folgende Beispiel veranschaulicht, wie diese Optionen zusammenwirken, um ein bestimmtes Ergebnis zu erzielen:
Betrachten Sie ein Design mit acht ODER-Gattern und acht Widerständen (wie in der folgenden Abbildung dargestellt). Die ODER-Gatter enthalten einen Parameter namens QuadOrGate, wobei eine Gruppe von vier ODER-Gattern den Parameterwert Package1 und die andere Gruppe von vier ODER-Gattern den Parameterwert Package2 aufweist. Die Widerstände haben keinen solchen Parameter. Wenn Sie das Kontrollkästchen für QuadOrGate im Steuerelement Component Parameter aktivieren, wird dieser Parameter verwendet, um die Zusammenfassung der Bauteile in Gehäusen zu steuern. In diesem Fall ist das Kontrollkästchen Strictly nicht aktiviert.
Nach dem Aufrufen des Befehls Tools » Annotation » Annotate Schematics werden Teile mit dem Parameter QuadOrGate = Package1 im selben physischen Bauteil zusammengefasst. Teile mit dem Parameter QuadOrGate = Package2 werden separat in einem weiteren Bauteil zusammengefasst. Alle übrigen Bauteile ohne den Parameter QuadOrGate werden zusammengefasst. In diesem Fall werden die Widerstände zusammengefasst, da ihre gemeinsame Eigenschaft darin besteht, dass sie den Parameter QuadOrGate nicht enthalten.

Beispiel für zusammengefasste Bauteile bei deaktivierter Option Strictly .
Wird dasselbe Design bei aktivierter Option Strictly annotiert, werden nur die Bauteile zusammengefasst, die den Parameter QuadOrGate besitzen. In diesem Fall werden die ODER-Gatter zusammengefasst, die Widerstände hingegen nicht. Die Option Strictly ermöglicht somit zwar eine äußerst präzise Steuerung des Zusammenfassungsprozesses, sollte jedoch in den meisten Fällen deaktiviert bleiben.

Beispiel für zusammengefasste Bauteile bei aktivierter Option Strictly .
Zu annotierende Schaltplanblätter
Sie können detailliert festlegen, welche Schaltplanblätter und Bauteile von der Annotation betroffen sind und wie diese Änderungen berechnet werden.

Festlegen des Annotationsumfangs.
- Ein Häkchen im Kontrollkästchen links neben einem aufgeführten Schaltplanblatt zeigt an, dass dieses im Rahmen des Annotationsbefehls verarbeitet wird.
- Der Annotationsumfang wird durch die Dropdown-Liste Annotation Scope bestimmt und kann auf das gesamte Schaltplanblatt erweitert oder auf ausgewählte bzw. nicht ausgewählte Bauteile beschränkt werden. Bei Verwendung der Optionen Ignore Selected Parts oder Only Selected Parts müssen die Bauteile vor dem Ausführen des Annotationsbefehls im Design ausgewählt worden sein.
- Legen Sie über das Feld Order die Reihenfolge fest, in der die Schaltplanblätter annotiert werden sollen. Geben Sie einen Wert direkt in das Feld ein oder verwenden Sie die Pfeile, die nach dem Klicken in das Feld erscheinen, um den gewünschten Wert einzustellen.
- Wenn die Option Designator Index Control aktiviert ist, beginnt die Nummerierung der Bezeichner mit dem Wert Start Index. Start Index hat keine Auswirkung, wenn die Option Designator Index Control nicht aktiviert ist.
- Am Ende jedes Bezeichners kann ein zusätzlicher Suffix angefügt werden, indem Sie eine Zeichenfolge bzw. einen Wert in der zugehörigen Spalte Suffix angeben. Vermeiden Sie einstellige Suffixe wie „A“ oder „1“, da diese leicht mit Teilbauteilen und/oder anderen Bezeichnerwerten verwechselt werden können.
Liste der vorgeschlagenen Änderungen
Klicken Sie auf die Schaltfläche Update Changes List, um Proposed Change List zu aktualisieren, sodass alle Bezeichneränderungen vor ihrer Anwendung überprüft werden können. Die Änderungen wirken sich nur auf Bezeichner aus, die noch nicht festgelegt wurden (z. B. R?, C? usw.). Wenn Sie also alle Bezeichner im Design aktualisieren möchten, sollten Sie diese zunächst durch Klicken auf die Schaltfläche Reset All zurücksetzen.

Zurücksetzen der Bezeichner vor dem Anwenden der Annotationseinstellungen.
Proposed Change List führt alle Bezeichner der Teile auf, die sich auf den zur Annotation ausgewählten Blättern befinden. Für jeden Eintrag werden die Bezeichnerwerte Current und Proposed sowie Sub (Teil) des Bauteils und die Quelle Location of Part angezeigt.
Durch Aktivieren des Kontrollkästchens für einen Designator wird dieser Bezeichner gegen jegliche Änderungen gesperrt. Ebenso verhindert das Aktivieren des Kontrollkästchens Sub , dass das betreffende mehrteilige Bauteil aktualisiert wird. Diese Option kann als Alternative zum Setzen des Symbols Lock im Panel Properties verwendet werden.
Nachdem Sie die Liste der vorgeschlagenen Änderungen überprüft haben, klicken Sie auf die Schaltfläche Accept Changes (Create ECO), um den Dialog Engineering Change Order zu öffnen. Sobald der ECO ausgeführt wurde, werden die Annotationsänderungen auf das Design angewendet.
Weitere Befehle zur Schaltplanannotation
Das Menü Werkzeuge » Annotation enthält mehrere gezielte Befehle zur Schaltplanannotation. Der erste Eintrag in dieser Gruppe, Annotate Schematic, wurde bereits erläutert.

Verschiedene verfügbare Annotationsbefehle
Schaltplanbezeichner zurücksetzen
Wenn große Teile von Inhalten aus verschiedenen Quellen ausgeschnitten und in ein neues Design eingefügt wurden, müssen möglicherweise alle Bezeichner zurückgesetzt werden. Da dieser Befehl die Einstellungen aus dem Dialog Annotate verwendet, wird er auf die Elemente angewendet, die zuvor in diesem Dialog festgelegt wurden. Wenn beispielsweise zuvor alle Schematic Sheets To Annotate aktiviert wurden, wird der Befehl Reset Schematic Designators auf das gesamte Projekt angewendet, unabhängig davon, ob die Schaltplanblätter gerade im Editor geöffnet sind oder nicht. Wenn zuvor nur einige Schematic Sheets To Annotate aktiviert wurden, wirkt sich der Befehl Reset Schematic Designators nur auf diese Blätter aus.
Nach dem Aufrufen des Befehls erscheint ein Bestätigungsdialog, der die Anzahl der zu aktualisierenden Bezeichner zusammenfasst und fragt, ob Sie mit den Änderungen fortfahren möchten. Nach einem Klick auf Yes werden alle Bauteilbezeichner auf sämtlichen zur Annotation freigegebenen Schaltplanblättern des aktiven Projekts zurückgesetzt und in folgender Form angezeigt: R?, C?, D?, U? usw.
Gesperrte Bezeichner werden weder zurückgesetzt noch anderweitig geändert.
Doppelte Schaltplanbezeichner zurücksetzen
Beim Duplizieren von Teilen eines Designs behalten die neu kopierten Bauteile dieselben Bezeichnerwerte wie die Bauteile, von denen sie kopiert wurden. Mit dem Befehl Reset Duplicate Schematic Designators lassen sich doppelte Bezeichner schnell auf „?“ zurücksetzen. Da dieser Befehl die Einstellungen aus dem Dialog Annotate verwendet, wird er auf die Elemente angewendet, die zuvor in diesem Dialog festgelegt wurden. Wenn beispielsweise zuvor alle Schematic Sheets To Annotate aktiviert wurden, wird der Befehl Reset Duplicate Schematic Designators auf das gesamte Projekt angewendet, unabhängig davon, ob die Schaltplanblätter gerade im Editor geöffnet sind oder nicht. Wenn zuvor nur einige Schematic Sheets to Annotate aktiviert wurden, wirkt sich der Befehl Reset Schematic Designators nur auf diese Blätter aus.
Nach dem Aufrufen des Befehls erscheint ein Bestätigungsdialog, der die Anzahl der zu aktualisierenden Bezeichner zusammenfasst und fragt, ob Sie mit den Änderungen fortfahren möchten. Nach einem Klick auf Yes werden alle doppelten Bauteilbezeichner, die auf sämtlichen zur Annotation freigegebenen Schaltplanblättern des aktiven Projekts gefunden wurden, zurückgesetzt und in folgender Form angezeigt: R?, C?, D?, U? usw.
Gesperrte Bezeichner werden weder zurückgesetzt noch anderweitig geändert.
Schaltpläne ohne Dialog annotieren
Der Befehl Annotate Schematics Quietly durchsucht alle zur Annotation freigegebenen Quellschaltplandokumente des aktiven Projekts und weist jedem Bauteil, das derzeit keinen Bezeichner hat, einen eindeutigen Bezeichner zu. Die Annotation erfolgt ohne Dialog – so können alle bisherigen Einstellungen des Dialogs Annotate angewendet werden, ohne den Dialog erneut öffnen zu müssen. Dies ist besonders nützlich, wenn sich das Design in einer schnellen Entwicklungsphase befindet und der Entwickler vor dem Kompilieren des Designs rasch eine Annotation durchführen möchte.
Annotation aller Schaltpläne erzwingen
Dieser Befehl durchsucht alle zur Annotation freigegebenen Quellschaltplandokumente des aktiven Projekts und annotiert alle darin enthaltenen Bauteile erneut gemäß dem Annotationsschema, das derzeit im Dialog Annotate definiert ist.
Das Ausführen des Befehls Force Annotate All Schematics entspricht dem Ausführen des Befehls Reset Schematic Designators mit unmittelbar anschließendem Ausführen des Befehls Annotate Schematics Quietly. Daher verwendet der Befehl Force Annotate All Schematics die zuvor im Dialog Annotate festgelegten Einstellungen, um zu bestimmen, welche Bauteile und Blätter aktualisiert werden können.
Nach dem Aufrufen dieses Befehls erscheint eine Bestätigungsabfrage, die angibt, wie viele Bezeichner bei einer Bestätigung aktualisiert werden. Nach einem Klick auf Yes werden alle Bauteilbezeichner auf sämtlichen zur Annotation freigegebenen Schaltplanblättern des aktiven Projekts bei Bedarf erneut annotiert, damit sie dem aktuellen positionsbasierten Annotationsschema entsprechen, das im Bereich Schematic Annotation Configuration des Dialogs Annotate definiert ist.
Schaltpläne rückannotieren
Vor der Einführung von Design Compiler und Synchronizer in Altium Designer wurden Annotationsänderungen üblicherweise über eine Netzlistendatei (*.net) vom Schaltplan an die Leiterplatte übertragen. Annotationsänderungen, die in umgekehrter Richtung – von der Leiterplatte zum Schaltplan – übertragen werden mussten, wurden über eine Rückannotation verarbeitet. Dieser Vorgang verwendet eine Was-Is-Datei (*.WAS) oder eine Engineering-Change-Order-Datei (*.ECO), um die Änderungen an den Schaltplanbezeichnern vorzugeben.
Nach dem Aufrufen des Befehls erscheint der Dialog Choose WAS-IS File for Back-Annotation from PCB. Navigieren Sie zur benötigten .was Datei (oder .eco) und wählen Sie sie aus. Nach einem Klick auf Open erscheint ein Informationsdialog, der auflistet, wie viele Änderungen an Bezeichnern seit dem vorherigen Zustand und wie viele seit dem ursprünglichen Zustand vorgenommen wurden. Zu diesem Zeitpunkt sind die Änderungen noch nicht tatsächlich umgesetzt. Klicken Sie auf OK , um den Dialog Annotate zu öffnen. Dort können Sie die vorgeschlagenen Änderungen an den aktuellen Bezeichnern prüfen, bevor Sie entscheiden, ob Sie einen ECO erstellen möchten, um sie umzusetzen.
Schaltplanblätter nummerieren
Der Befehl Number Schematic Sheets ändert nicht die Bauteilbezeichner, sondern die Bezeichner (Nummern) der Schaltplanblätter. Er ist daher konzeptionell mit dem allgemeinen Konzept der Designannotation verwandt.
Mit der Blatt- und Dokumentnummerierung können Sie die Blattbezeichnungen steuern und als Parameter in den jeweiligen Schaltplandokumenten speichern. Mithilfe der Sonderzeichenfolgen-Funktion von Altium Designer (=SheetNumber, =DocumentNumber, =SheetTotal) lassen sich diese Werte dann als Textobjekte auf dem Blatt anzeigen, beispielsweise in der Fußzeile.

Nummerierung von Schaltplanblättern.
Die Nummerierung der Blätter erfolgt wie folgt:
Automatische Blattnummerierung (Projektoption)
Aktivieren Sie diese Option, um die automatische Blattnummerierung durchzuführen. Die Werte werden im Panel Projects angezeigt. Sie können die automatische Blattnummerierung auch aktivieren, indem Sie die Option Automatic Sheet Numbering auf der Registerkarte Optionen des Dialogs Project Options auswählen.
Automatische Blattnummer
Klicken Sie auf die Dropdown-Schaltfläche Auto Sheet Number, um auf die Optionen zur Blattnummerierung zuzugreifen.
Die Optionen für Select Numbering Scheme sind:
- Display Order – Die Blätter werden in der Reihenfolge nummeriert, in der sie angezeigt werden.
- Sheets Hierarchical Structure - Depth First - Die Blätter werden von der obersten Ebene ausgehend entlang der einzelnen Zweige nummeriert. Zuerst wird die oberste Ebene nummeriert, anschließend der erste Zweig unterhalb der obersten Ebene vollständig, dann der zweite Zweig und so weiter.
- Sheets Hierarchical Structure - Breadth First - Die Blätter werden entsprechend ihrer Ebene in der Hierarchie nummeriert. Zuerst wird die oberste Ebene nummeriert, anschließend alle Blätter der zweiten Ebene und so weiter.
Mit den Select Numbering Method Optionen können fortlaufende Increasing oder Decreasing Werte ausgewählt werden.
Automatische Dokumentnummerierung
Klicken Sie auf die Dropdown-Liste Auto Document Number , um auf die Optionen zur Dokumentnummerierung zuzugreifen. Diese entsprechen im Wesentlichen den Auto Sheet Number Optionen, ergänzt um die Werte Prefix und Postfix .
Die Parameters Optionen sind:
-
Prefix - Wählen Sie ein Präfix, das Ihrer Dokumentnummer vorangestellt wird. Unterstützt werden alphabetische (
A,B,Cusw.), numerische (1,2,3usw.) und nicht numerische (_,*,.,%usw.) Präfixe sowie beliebige Kombinationen daraus. - Start - Wählen Sie einen numerischen Startwert für die Nummerierung.
-
Postfix - Wählen Sie ein Suffix, das an die Dokumentnummer angehängt wird. Unterstützt werden alphabetische (
A,B,Cusw.), numerische (1,2,3usw.) und nicht numerische (_,*,.,%usw.) Suffixe sowie beliebige Kombinationen daraus. - Step - Wählen Sie einen Wert, um den jede Dokumentnummer erhöht wird. Wenn beispielsweise der Start Index auf 1 und der Step Wert auf 100 gesetzt ist, lautet die erste Dokumentnummer 1, die nächste 101 (Startwert + Schrittweite), die darauffolgende 201 und so weiter.
Blattanzahl aktualisieren
Klicken Sie auf die Schaltfläche Update Sheet Count, um die Anzahl der Blätter im aktuellen Projekt zu ermitteln und das Ergebnis in die Spalte SheetTotal einzutragen. Die Blattanzahl entspricht der Gesamtzahl der Blätter im Projekt, unabhängig vom Nummerierungsschema, das in einem der vorherigen Bedienelemente ausgewählt wurde.
Nach oben/unten verschieben
Mit den Schaltflächen Move Up oder Move Down verschieben Sie ein ausgewähltes Schaltplandokument in der Liste nach oben oder unten. Dies ist relevant, wenn Sie das Nummerierungsschema Display Order verwenden, um Blatt- oder Dokumentnummern festzulegen.
Benutzerdefinierte Nummerierung/Benennung
Wenn ein Unternehmen ein bestimmtes Nummerierungs- oder Benennungssystem verwendet, das sich weder mit dem Befehl Auto Sheet Number noch mit dem Befehl Auto Document Number automatisieren lässt, können benutzerdefinierte Blattnamen und -nummern direkt in die Felder SheetNumber oder DocumentNumber eingetragen werden.
Schaltplanblattnummerierung und Device Sheets
Für schreibgeschützte Device Sheets (Standardzustand) können keine Blatt- oder Dokumentnummern konfiguriert werden. Sie werden im Dialog Blattnummerierung für Projekt schraffiert dargestellt, um anzuzeigen, dass sie nicht aktualisiert werden können. Werden Device Sheets als bearbeitbar festgelegt, entfällt die Schraffur und die Blatt- und Dokumentnummerierung kann wie gewohnt konfiguriert werden.
Anzeige der Bauteilbezeichner auf der Leiterplatte steuern
Erweiterte Bauteilbezeichner in einem Mehrkanaldesign können im PCB-Editor umständlich zu platzieren sein. Sie können entweder Benennungsoptionen wählen, die einen kurzen Namen ergeben, oder stattdessen den ursprünglichen logischen Bauteilbezeichner anzeigen lassen. Beispielsweise würde C30_CIN1 als C30 angezeigt. In diesem Fall wäre eine zusätzliche Kennzeichnung auf der Leiterplatte erforderlich, um die einzelnen Kanäle voneinander zu unterscheiden, etwa ein Rahmen um jeden Kanal im Bestückungsdruck.
Über die Dropdown-Liste Designator Display im Bereich Other des Panels Properties im Modus Board können Sie zwischen der Anzeige logischer und physischer Bauteilbezeichner auf der Leiterplatte wählen. Wenn Sie in einem Mehrkanaldesign die logischen Bauteilbezeichner anzeigen lassen, erscheinen diese auf der Leiterplatte und in allen erzeugten Ausgaben, beispielsweise Ausdrucken und Gerber-Dateien. Beim Erstellen einer Stückliste werden jedoch immer die eindeutigen physischen Bauteilbezeichner verwendet.
Designsynchronisierung – Abschluss des Annotierungsprozesses
Die direkte Designsynchronisierung ist die bevorzugte Methode, um die Bauteilbezeichner in Schaltplan und PCB konsistent zu halten, sofern Sie Zugriff auf den Schaltplan- und den PCB-Editor haben. Bei der Designsynchronisierung werden die Bauteile und Verbindungen des Schaltplans direkt mit denen der Leiterplatte verglichen und die Unterschiede aufgelistet. Die zum Beheben dieser Unterschiede erforderlichen Änderungen werden als ECO (Engineering Change Order) zusammengestellt. Eine ECO-Datei beschreibt die Unterschiede zwischen dem aktuellen und dem gewünschten Designzustand und kann ausgeführt werden, um das Zieldokument zu aktualisieren und das Design zu synchronisieren.
Vorwärts- und Rückwärtssynchronisierung
Die Begriffe Vorwärtssynchronisierung und Rückwärtssynchronisierung beschreiben die Richtung, in der Änderungen an der Annotierung und am Design während der Datensynchronisierung übertragen werden. Ausgehend von einem Designablauf, der beim Schaltplan beginnt und von diesem gesteuert wird, bezeichnet die Vorwärtssynchronisierung die Übertragung von Änderungen aus dem Schaltplan-Editor auf die Leiterplatte. Die Rückwärtssynchronisierung bezeichnet die Übertragung von Änderungen an der Leiterplatte zurück in den Schaltplan-Editor.
Vorwärtssynchronisierung
Es gibt verschiedene Gründe, Daten vom Schaltplan auf die Leiterplatte zu übertragen:
- Im Schaltplan-Editor wurde ein neues Bauteil hinzugefügt, das im Leiterplattenlayout benötigt wird.
- Sie haben Ihren Schaltplan zum ersten Mal oder seit der letzten Designsynchronisierung annotiert.
- In einem Mehrkanaldesign haben Sie Project Options geändert, um das Benennungsschema für die physischen Bauteilbezeichner auf der Leiterplatte anzupassen.
- Sie haben zum ersten Mal oder seit der letzten Designsynchronisierung eine Annotierung auf Leiterplattenebene durchgeführt.
Schaltplandesign vorwärts mit dem PCB-Design synchronisieren
Wählen Sie eine der folgenden Methoden, um Ihr Schaltplandesign vorwärts mit Ihrem PCB-Design zu synchronisieren:
- Wählen Sie Update PCB Document im Menü Design des Schaltplan-Editors. Falls Unterschiede zum Ziel-PCB-Dokument bestehen, wird der Dialog Engineering Change Order mit einer Liste der Änderungen geöffnet, die erforderlich sind, um die Leiterplatte mit dem Schaltplandesign zu synchronisieren. Klicken Sie auf Execute Changes, um Ihr Design zu synchronisieren.
- Wählen Sie Import Changes im Menü Design des PCB-Editors. Dadurch werden Änderungen aus den Schaltplandokumenten in das PCB-Dokument importiert.
Rückwärtssynchronisierung
Eine Rückwärtssynchronisierung wird durchgeführt, wenn Sie Ihr PCB-Design annotiert oder geändert haben und das Schaltplandesign entsprechend aktualisieren möchten.
PCB-Design rückwärts mit dem Schaltplandesign synchronisieren
Wählen Sie eine der folgenden Methoden, um Ihr PCB-Design rückwärts mit Ihrem Schaltplandesign zu synchronisieren:
-
Wählen Sie im PCB-Editor Update Schematics im Menü Design . Standardmäßig ist die Option Push Component Designator Changes to Annotation File (if any) auf der Registerkarte ECO-Erzeugung des Dialogs Project Options aktiviert. Dadurch werden Änderungen aus dem PCB-Editor nur in die Annotierungsdatei und bei der Kompilierung schließlich in die kompilierten Dokumente übertragen. Deaktivieren Sie diese Option, um Änderungen ausschließlich in das Quellschaltplandokument zu übertragen (Ansicht Editor ).
- Wählen Sie im Schaltplaneditor Tools » Annotation » Annotate Schematics und klicken Sie dann im Dialog Annotation auf die Schaltfläche Back Annotate. Wählen Sie die WAS-IS-Datei aus, die beim erneuten Annotieren der Bauteilbezeichner in der PCB-Umgebung erzeugt wurde.
- Wählen Sie im Schaltplaneditor Tools » Annotation » Board Level Annotate und klicken Sie dann im Dialog Annotation auf Leiterplattenebene auf die Schaltfläche Back Annotate. Wählen Sie die WAS-IS-Datei aus, die beim erneuten Annotieren der Bauteilbezeichner in der PCB-Umgebung erzeugt wurde.
- Wählen Sie im Schaltplaneditor Tools » Annotation » Back Annotate Schematics. Wählen Sie die WAS-IS-Datei aus, die beim erneuten Annotieren der Bauteilbezeichner in der PCB-Umgebung erzeugt wurde.
Herkömmliche Methoden der Designsynchronisierung
Altium Designer unterstützt den herkömmlichen Ansatz der Designsynchronisierung über Zwischendateien (Netzlisten und WAS/IS-Dateien). Die Vorwärtssynchronisierung von Annotationsdaten kann mithilfe einer Netzlistendatei erfolgen, die Rückwärtssynchronisierung mithilfe einer WAS/IS-Datei. Diese führt auf, wie jeder Bauteilbezeichner WAS und wie er jetzt IS. Die bevorzugte Methode zur Synchronisierung Ihres Designs ist die direkte Designsynchronisierung.
Bauteilverknüpfung über eindeutige IDs
Wenn Sie Ihr Design neu annotiert haben, stimmen die Bauteilbezeichner im Schaltplan oder die kompilierten Bauteilbezeichner nicht mehr mit den Bauteilbezeichnern auf der Leiterplatte überein. Daher ist eine Synchronisierung erforderlich, um den Entwurf erfolgreich abzuschließen. Statt den Bauteilbezeichner selbst als Schlüsselfeld zu verwenden, das ein Schaltplansymbol mit seinem entsprechenden PCB-Footprint verknüpft, kann Altium Designer die Designsynchronisierung über das System eindeutiger Kennungen (Unique IDentifier, UID) aufrechterhalten. Die UID ist ein vom System erzeugter Wert, der das Quellbauteil eindeutig identifiziert und jedes Schaltplanbauteil dem entsprechenden PCB-Bauteil zuordnet.
Wenn ein Bauteil auf einem Schaltplanblatt platziert wird, erhält es automatisch eine UID. Wenn Bauteilinformationen zum ersten Mal aus den Quellschaltplandokumenten auf eine leere Leiterplatte übertragen werden, wird die UID jedes Schaltplanbauteils dem entsprechenden PCB-Bauteil zugewiesen.
Durch Refactoring können Sie Device Sheets in Schaltplanblätter umwandeln und umgekehrt, wobei die eindeutige ID des Blatts und seiner Bauteile erhalten bleibt. Darüber hinaus können Sie Teilschaltungen durch Refactoring auf andere Schaltplanblätter im aktuellen Projekt verschieben, wobei die eindeutige ID der Teilschaltung erhalten bleibt. Der Befehl Refactor befindet sich im Menü Edit .
Die Synchronisierungsfunktion von Altium Designer, die durch Aufrufen des Befehls Design » Update gestartet wird, verwendet diese UIDs, um jedes Schaltplanbauteil seinem PCB-Gegenstück zuzuordnen. Designaktualisierungen und -änderungen können anschließend mithilfe von Engineering Change Orders (ECOs) umgesetzt werden. Eine ECO listet alle erforderlichen Anpassungen an einem oder mehreren Designdokumenten auf, um die angeforderte Synchronisierung durchzuführen. ECOs werden in verschiedenen Situationen zur Durchführung von Designaktualisierungen verwendet, beispielsweise:
- Übertragen von Designaktualisierungen vom Schaltplan auf die Leiterplatte.
- Aktualisieren der Annotation von Schaltplanbauteilbezeichnern und kompilierten Bauteilbezeichnern.
- Aktualisieren von Parametern mithilfe von Parameter Manager (Tools » Parameter Manager).
- Aktualisieren von Parameterinformationen anhand von Informationen aus Quellbibliotheken oder einer Unternehmensdatenbank. Bei jedem Vergleich von Schaltplan und Leiterplatte (beispielsweise wenn Sie Design » Update auswählen) ordnet Altium Designer zunächst die Bauteile mit derselben UID einander zu. Werden Bauteile erkannt, deren UIDs nicht übereinstimmen, erhalten Sie einen Hinweis, und die Anwendung bietet an, eine Zuordnung anhand der Bauteilbezeichner zu versuchen. Solange Sie dem Schaltplan- und dem PCB-Bauteil keine übereinstimmende UID zugewiesen haben, wird diese Meldung weiterhin angezeigt. Eindeutige IDs und ihre Zuordnungen werden im Dialog Bauteilverknüpfungen bearbeiten verwaltet (Project » Component Links).
Beachten Sie, dass sich der Dialog nur öffnen lässt, wenn ein PCB-Dokument aktiv ist, da UID-Änderungen immer auf die Leiterplatte und nicht auf den Schaltplan angewendet werden. Sie können den Dialog in jeder Phase des Entwurfs verwenden, um die Verknüpfungen zwischen den Bauteilen anzuzeigen und zu prüfen, ob die Bauteile dokumentübergreifend korrekt zugeordnet sind. Außerdem können Sie Bauteilen, die derzeit nicht zugeordnet sind, übereinstimmende UIDs zuweisen.
