Defining the Wiring Diagram

Die einzelnen verdrahteten Verbindungen innerhalb des Kabelbaums werden im Verdrahtungsdiagramm des Kabelbaums (*.WirDoc) festgelegt. Fügen Sie dieses Dokument dem Kabelbaumprojekt über das Projects-Panel hinzu, indem Sie mit der rechten Maustaste auf den Projekteintrag klicken und dann im Kontextmenü Add New to Project » Harness Wiring Diagram auswählen (oder den Befehl File » New » Harness Wiring Diagram aus den Hauptmenüs verwenden).

Einrichten eines Verdrahtungsdiagramm-Dokuments für Kabelbäume

Optionen eines Verdrahtungsdiagramm-Dokuments für Kabelbäume können im Properties Panel konfiguriert werden, wenn im Designbereich des Dokuments kein Objekt ausgewählt ist. Die wichtigsten Einstellungen sind:

  • Im Bereich General der Registerkarte General des Panels – wählen Sie die Maßeinheiten aus, die für das Dokument und seine grafischen Elemente gelten, und legen Sie die Raster fest, um die Platzierung zu erleichtern. Altium Designer bietet drei Rastertypen: sichtbares Raster zur Navigation, Fangraster für die Platzierung und Fangabstand zur Unterstützung beim Erstellen von Verbindungen.

  • Im Bereich Page Options der Registerkarte General des Panels – konfigurieren Sie Blattgröße und Schriftfeld des Dokuments oder wählen Sie aus verfügbaren Vorlagen für Verdrahtungsdiagramme von Kabelbäumen aus.

Die Registerkarten General und Parameters des Properties-Panels, wenn im Verdrahtungsdiagramm-Dokument für Kabelbäume kein Objekt ausgewählt ist 
Die Registerkarten General und Parameters des Properties-Panels, wenn im Verdrahtungsdiagramm-Dokument für Kabelbäume kein Objekt ausgewählt ist

  • Das Einrichten eines Verdrahtungsdiagramm-Dokuments für Kabelbäume ähnelt dem Einrichten eines Schaltplandokuments (*.SchDoc) eines PCB-Designprojekts. Weitere Informationen finden Sie auf der Seite Setting Up a Schematic Document.

  • Verwenden Sie die Dropdown-Liste Length Units, um Längeneinheiten für das Dokument auszuwählen. Die Werte Strip Length und Pull Off Length von Socket Cavities werden in den ausgewählten Einheiten angezeigt. Unterstützt werden mm, cm, m, in und ft. Die Standard-Längeneinheiten neu erstellter Verdrahtungsdiagramm-Dokumente können auf der Seite Harness Design – General des Dialogs Preferences festgelegt werden.

  • Weitere Informationen zum Erstellen von Vorlagen für Verdrahtungsdokumente von Kabelbäumen finden Sie auf der Seite Creating Harness Template Documents.

  • Standardeigenschaften von Objekten in Verdrahtungsdiagrammen für Kabelbäume können auf der Seite Harness Design – Defaults  des Dialogs Preferences konfiguriert werden. Diese Eigenschaften werden beim Platzieren nachfolgender Objekte angewendet.

  • Beim Erstellen eines Verdrahtungsdiagramm-Dokuments für Kabelbäume können Sie auch Text- und Zeichenobjekte verwenden. Die Arbeit mit diesen Objekten in einem Verdrahtungsdiagramm-Dokument für Kabelbäume ähnelt der Arbeit mit ihnen in einem Schaltplandokument (*.SchDoc) eines PCB-Designprojekts. Weitere Informationen zu diesen Objekten finden Sie unter Working with Text Objects on a Schematic und Working with Drawing Objects on a Schematic.

    • Beachten Sie, dass aktive Links zu Objekten des Verdrahtungsdiagramms für Kabelbäume (z. B. Drähte und Komponenten) sowie zu Objekten der Kabelbaum-Layoutzeichnung (z. B. Bündel und Verbindungspunkte) auch in Textrahmen und Notizen unterstützt werden. Klicken Sie in einem platzierten Textrahmen oder einer Notiz auf einen Link, um per Cross-Probing zu diesem Objekt im zugehörigen Dokument zu springen.

  • Zum Prüfen Ihres Verdrahtungsdiagramms für Kabelbäume auf logische, elektrische und zeichnerische Verstöße werden verschiedene Verletzungsprüfungen unterstützt. Weitere Informationen finden Sie auf der Seite Validating the Harness Design.

  • Ein Verdrahtungsdiagramm-Dokument für Kabelbäume kann im ASCII-Format gespeichert werden, was beim Teilen von Vorteil sein kann. Verwenden Sie dazu den Befehl File » Save As und wählen Sie im sich öffnenden Dialog Save As in der Dropdown-Liste Save as type die Option Harness Wiring ascii (*.WirDoc) aus. Wenn Sie ein ASCII-Verdrahtungsdiagramm mit dem Befehl File » Save speichern, wird der Dialog File Format geöffnet, der Sie darauf hinweist, dass das ASCII-Format verwendet wird. Wählen Sie im Dialog die ASCII-Version aus, um dieses Format weiterhin zu verwenden.

Synchronisieren von Multi-Board- und Kabelbaumprojekten

 
 
 
 
 

Wenn das Kabelbaumprojekt Teil eines Multi-Board-Designprojekts ist, kann das Verdrahtungsdiagramm für Kabelbäume aus den Daten des Multi-Board-Schaltplandokuments (*.MbsDoc) synchronisiert werden. Wählen Sie dazu den Befehl Design » Import Changes From <Multi-board Project> aus den Hauptmenüs.

Weitere Informationen zum Hinzufügen eines Kabelbaum-Designprojekts zu einem Multi-Board-Projekt finden Sie auf der Seite Harness Design.

Wenn das Multi-Board-Schaltplandokument mehr als eine Definition einer Kabelbaumverbindung enthält, wird der Dialog Select Harness Definition geöffnet. Geben Sie die Definition an, die sich auf das aktuelle Kabelbaumprojekt bezieht.

Der Dialog Select Harness Definition
Der Dialog Select Harness Definition

Der Dialog Engineering Change Order wird dann geöffnet und zeigt die im Multi-Board-Schaltplan definierten Kabelbaum-Steckverbinderkomponenten und Kabelbaum-Netze an, die die Grundlage für das Verdrahtungsdiagramm für Kabelbäume bilden.

Verwenden Sie den Dialog Engineering Change Order, um Daten aus dem Multi-Board-Projekt zu importieren. 
Verwenden Sie den Dialog Engineering Change Order, um Daten aus dem Multi-Board-Projekt zu importieren. 

Nach dem Ausführen der Änderungen () werden die Daten aus dem Multi-Board-Schaltplandokument in das Verdrahtungsdiagramm für Kabelbäume importiert. Die Steckverbinderkomponenten, jeweils dargestellt durch ihr Schaltplansymbol, erscheinen im Verdrahtungsdiagramm-Dokument für Kabelbäume zunächst an beliebigen Positionen.

Ein Beispiel für ein Verdrahtungsdiagramm für Kabelbäume direkt nach dem Import.
Ein Beispiel für ein Verdrahtungsdiagramm für Kabelbäume direkt nach dem Import.

Zwischen den Pins werden Netzlinien angezeigt, um die im Multi-Board-Schaltplan definierten logischen Verbindungen darzustellen. Beachten Sie, dass sich zu diesem Zeitpunkt noch keine physischen Drähte im Design befinden.

Beachten Sie, dass die aus dem Multi-Board-Projekt in das Kabelbaumprojekt importierten Konnektivitätsdaten auf den Pinnamen der Steckverbinderkomponenten basieren. Stellen Sie daher vor dem Datenimport sicher, dass den Komponenten-Pins in der Quellbibliothek eindeutige und korrekte Namen zugewiesen sind.

Arbeiten mit Komponenten

Neben dem Synchronisieren aus dem Multi-Board-Schaltplandokument können Komponenten auch manuell im Verdrahtungsdiagramm für Kabelbäume platziert werden. Dadurch können Komponenten in einem eigenständigen Kabelbaumprojekt (das nicht Teil eines Multi-Board-Projekts ist) platziert werden, aber auch zusätzliche Komponenten in einem Verdrahtungsdiagramm für Kabelbäume, das Teil eines Multi-Board-Projekts ist.

Verwenden Sie das Components-Panel, um die Symbole der erforderlichen Komponenten zu platzieren. Der Komponentenplatzierungsprozess ähnelt dem im Schaltplan-Editor – weitere Informationen finden Sie auf der Seite Searching for & Placing Components. Beachten Sie, dass es für manuell hinzugefügte Komponenten keine Netzlinien gibt, da kein übergeordnetes logisches Design vorhanden ist, das sie steuert.

  • Komponenten werden aus verfügbaren Bibliotheken platziert und in einem Verdrahtungsdiagramm für Kabelbäume durch ihre Schaltplansymbolmodelle dargestellt. Weitere Informationen zur Komponentenerstellung finden Sie unter Building & Maintaining Your Components and Libraries.

  • Mehrteilige Komponenten können ebenfalls in einem Verdrahtungsdiagramm für Kabelbäume platziert werden. Wenn die Designdaten in die Kabelbaum-Layoutzeichnung importiert werden, werden Bezeichner den Komponenten in der Kabelbaum-Layoutzeichnung korrekt zugewiesen. Wenn mehrere Teile derselben Komponente im Verdrahtungsdiagramm für Kabelbäume platziert werden, wird in der Kabelbaum-Layoutzeichnung nur eine Instanz der Komponente platziert ().

  • Kabelbaum-Steckverbinder können verwendet werden, um Verbindungen zwischen mehreren Multi-Board-Projekten herzustellen, die in einer verschachtelten Konfiguration vorliegen.

  • Beim Einfügen ausgeschnittener/kopierter Kabelbaumkomponenten in ein Verdrahtungsdiagramm für Kabelbäume berücksichtigen die Bezeichner eingefügter Komponenten die Option Reset Parts Designators On Paste von der Seite Schematic – Graphical Editing des Dialogs Preferences. Wenn Komponenten eingefügt werden, wird der numerische Teil ihrer Bezeichner auf ? zurückgesetzt, wenn die Option aktiviert ist.

Um eine platzierte Komponente (oder eine Komponente, die aus dem Components-Panel platziert wird) an die gewünschte Position zu verschieben, klicken und halten Sie die linke Maustaste darauf und bewegen Sie die Maus. Während des Ziehens verwenden Sie Spacebar, um die Komponenten um 90 Grad zu drehen, sowie die Tasten X und Y, um sie horizontal bzw. vertikal zu spiegeln.

Das Verdrahtungsdiagramm für Kabelbäume nach dem Verschieben der Komponenten
Das Verdrahtungsdiagramm für Kabelbäume nach dem Verschieben der Komponenten

Eigenschaften einer platzierten Komponente können im Properties-Panel konfiguriert werden, wenn die Komponente im Designbereich ausgewählt ist. Das Properties-Panel für eine Komponente enthält die folgenden Registerkarten:

 
 
 
 
 
  • General – allgemeine Eigenschaften der Komponente, wie Bezeichner und Kommentar, Position, Parameter usw.

  • Pins – die Liste der Komponenten-Pins.

  • Cavities – ermöglicht die Zuweisung von Socket Cavities zur Komponente (weitere Informationen).

  • Associated Parts – ermöglicht die Zuweisung zusätzlicher Teile, z. B. Schrumpfschlauch, zur Komponente.

Registerkarten des Properties-Panels, wenn eine Komponente ausgewählt ist
Registerkarten des Properties-Panels, wenn eine Komponente ausgewählt ist

Zuweisen von Socket Cavities

 
 
 
 
 

Socket Cavities und ihr Typ können einer Kabelbaumkomponente zugewiesen werden. Wählen Sie eine Komponente im Designbereich aus, um eine Kavität und einen Typ hinzuzufügen. Wählen Sie einen Pin auf der Registerkarte Cavities des Properties -Panels aus und klicken Sie dann auf die Schaltfläche . Wählen Sie den gewünschten Typ aus der Dropdown-Liste aus. Die folgenden Kavitätstypen werden unterstützt:

  • Crimp – wird verwendet, um eine elektrische Verbindung herzustellen, indem ein Kontaktfass um einen Leiter gepresst wird.

  • Seal – wird verwendet, um Umweltschutz zu bieten, indem die Draht-Eintrittsstelle abgedichtet wird.

  • Plug – wird verwendet, um eine offene (ungenutzte) Steckverbinderkavität zu füllen, damit die Integrität der Umgebungsabdichtung erhalten bleibt.

  • Other – wird verwendet, um andere/zusätzliche Teile oder Materialien anzugeben, z. B. Lötzinn.

Für den Kavitätstyp Crimp oder Zeilen, denen kein Kavitätstyp hinzugefügt wurde, können Sie die folgenden Werte angeben:

  • Strip Length – die Länge, bei der die Isolierung vom Leiter abgeschnitten wird.

  • Pull Off Length – die Länge, bei der die abgeschnittene Isolierung vom Leiter abgezogen wird. Dies kann in Fällen verwendet werden, in denen das Drahtende nicht vollständig abisoliert ist und das entfernte Isolierungsstück auf dem Draht verbleibt, um eine Beschädigung der Litze zu verhindern.

Die Einheiten, in denen diese Werte im Properties-Panel angezeigt werden, wenn eine Komponente ausgewählt ist, werden über die Dropdown-Liste Length Units auf der Registerkarte General des Properties-Panels festgelegt, wenn im Dokument kein Objekt ausgewählt ist.

Im sich öffnenden Dialog Select Connector suchen Sie die gewünschte Komponente und wählen sie aus. Der spezifische Typ und die zugehörigen Informationen werden dem Pin auf der Registerkarte hinzugefügt, wie in den folgenden Abbildungen für das Hinzufügen eines Crimps zu Pin 1 gezeigt.

Beachten Sie, dass Pins in der Tabelle der Registerkarte Cavities anhand ihrer Namen dargestellt werden (Spalte Pins) und die Kavitätszuweisung auf Pinnamen basiert. Stellen Sie daher sicher, dass den Komponenten-Pins eindeutige und korrekte Namen zugewiesen sind.

Für einen Crimp, eine Dichtung oder einen Blindstopfen kann einem Pin nur eine Kavität eines bestimmten Typs hinzugefügt werden. Sobald eine Kavität eines bestimmten Typs hinzugefügt wurde, ist der Eintrag in der Dropdown-Liste nicht mehr verfügbar (ausgegraut). Es kann beliebig viele Kavitäten des Typs Other zu einem Pin hinzugefügt werden.

Pins mit zugewiesenen Crimps werden im Designbereich durch das Symbol  gekennzeichnet, wie in der folgenden Abbildung gezeigt.

Der Rasterbereich der Registerkarte Cavities unterstützt Mehrfachauswahl sowie Kopieren/Einfügen/Löschen für ausgewählte Einträge.

  • Mehrere Pin-Einträge können mit den Tastenkombinationen Click, Hold&DragCtrl+ClickShift+Click und Ctrl+A ausgewählt werden.

  • Wenn mehrere Pin-Einträge ausgewählt sind, klicken Sie auf  , um allen ausgewählten Pins eine Kavität hinzuzufügen, oder klicken Sie auf  oder drücken Sie Delete, um hinzugefügte Kavitäten von ausgewählten Pins zu entfernen. 

  • Um die Kavität eines Pins zu ändern, wählen Sie dessen Eintrag aus und klicken dann auf , um den Dialog Select Connector zum Auswählen der neuen Kavität zu öffnen.

  • Wählen Sie einen oder mehrere Pin-Einträge aus und verwenden Sie die Tastenkombinationen Ctrl+X/Ctrl+C, um die ausgewählten Einträge auszuschneiden/zu kopieren. Verwenden Sie dann die Tastenkombination Ctrl+V, um den ausgeschnittenen/kopierten Inhalt beim aktuell ausgewählten Eintrag einzufügen.

Erstellen von Konnektivität im Harness-Verdrahtungsdiagramm

Physische Drähte werden im Dokument des Harness-Verdrahtungsdiagramms platziert, indem der Befehl Place » Harness Wire aus den Hauptmenüs ausgewählt wird (Tastenkombination: Shift+W).

Nach Auswahl des Befehls klicken Sie auf einen Pin eines Connectors (ein rotes Kreuz erscheint am Cursor, wenn er sich über dem Hotspot eines Pins befindet), um den Startpunkt des Harness-Drahts zu platzieren. Positionieren Sie den Cursor und klicken Sie, um eine Reihe von Eckpunkten zu verankern, die die Form des Harness-Drahts definieren. Nachdem Sie den letzten Eckpunkt am Hotspot eines anderen Pins platziert haben, klicken Sie mit der rechten Maustaste, um die Platzierung abzuschließen.

Drücken Sie beim Platzieren eines Harness-Drahts Shift+Spacebar, um durch die Platzierungsmodi zu wechseln. Der Modus legt fest, wie Ecken beim Platzieren von Drähten erzeugt werden und in welchen Winkeln Drähte platziert werden können. Im Modus 90 Degree oder 45 Degree (echte orthogonale Modi) drücken Sie Spacebar, um zwischen den Untermodi Start und Ende zu wechseln. Der aktuelle Modus und Untermodus werden in der Statusleiste angezeigt.

Beim Platzieren eines Harness-Drahts verfolgen/aktualisieren sich die Netzlinien „live“ und zeigen Ihnen in Echtzeit, wo zu verdrahten ist, wie im folgenden Video gezeigt. Sobald eine Verbindung abgeschlossen ist, verschwindet ihre Netzlinie aus dem Dokument.

Demonstration der Live-Trace-Funktion

Wenn ein Harness-Draht platziert und ausgewählt ist, können seine Eckpunkte gezogen werden, um den Winkel zwischen zwei benachbarten Segmenten zu ändern (Beispiel anzeigen).

Wählen Sie einen Harness-Draht im Designbereich aus, um ihn im Fenster Properties zu ändern. Im Fenster können Sie den ausgewählten Harness-Draht umbenennen, seine Breite und Farbe ändern und Parameter hinzufügen, die im Designbereich angezeigt oder ausgeblendet werden können.

Das Fenster Properties bei ausgewähltem Harness-Draht
Das Fenster Properties bei ausgewähltem Harness-Draht

  • Ein platzierter Harness-Draht kann durch eine Harness-Wiring-Komponente ersetzt werden, die einen einzelnen Draht enthält. Wählen Sie dazu den zu ersetzenden Harness-Draht aus und klicken Sie auf die Schaltfläche  rechts neben dem Feld Design Item ID im Fenster Properties. Suchen Sie im sich öffnenden Dialog Replace Component die gewünschte Komponente und wählen Sie sie aus. Der platzierte Draht wird mit den Eigenschaften und Parametern der gewählten Komponente aktualisiert, wobei seine Geometrie unverändert bleibt. Weitere Informationen finden Sie im Abschnitt Placing a Harness Wiring Component.

  • Die primäre Farbe eines Drahts wird durch den Parameter Color definiert, der standardmäßig in einem platzierten Harness-Draht dargestellt wird. Um die Farbe zu bearbeiten, geben Sie ihren Namen ein (z. B. Red) oder ihren Hexadezimalcode (durch Eingabe des Zeichens # gefolgt von der Hexadezimalzahl, z. B. #9900FF) als Parameterwert. Alternativ klicken Sie auf die Farbschaltfläche links neben dem Parameterwert und verwenden den sich öffnenden Farbwähler, in dem die Drahtfarbe per RGB- oder HEX-Wert, per freier Auswahl oder aus einer Reihe von Voreinstellungen festgelegt werden kann.

  • Mehrfarbige Harness-Drähte werden im Harness-Verdrahtungsdiagramm unterstützt, indem die Sekundär- und Tertiärfarben eines Drahts ausgewählt werden. Klicken Sie im Fenster Properties unten im Bereich Parameters auf das Dropdown   und wählen Sie dann Secondary und Tertiary , um die gewünschten Farben festzulegen; der Parameter für die gewählte Farbe erscheint im Bereich Parameters . Sie können die Randfarbe für den Harness-Draht auch über dasselbe Dropdown festlegen, indem Sie Border auswählen. Beachten Sie, dass der Parameter Color die Sichtbarkeit des kombinierten Werts der definierten Drahtparameter Color, Secondary Color und Tertiary Color steuert. Klicken Sie sich durch die folgende Slideshow, um Beispiele zu sehen.

    Javascript ID: Harness_WD_Pnl_Properties_Wire_Colors_AD25

    Ein Draht, bei dem nur die Primärfarbe definiert ist

    Ein Draht mit definierter Sekundärfarbe

    Ein Draht mit definierter Tertiärfarbe

    Ein Draht mit definierter Randfarbe

    Ein Draht mit definierten allen Farboptionen

    Mehrfarbige Drähte werden durch Tabellen in Fertigungszeichnungsdokumenten für Harness-Designs unterstützt (*.HarDwf) – mehr erfahren.

  • Wenn ein Harness-Draht für seinen Parameter Include Cut den Wert No aufweist, wird dieser Draht in einer Verdrahtungsliste und Verbindungstabelle in der Fertigungszeichnung nicht dargestellt.

  • Die Parameter Color, Min. Bending Radius, Thickness und Units eines Harness-Drahts werden bei der Synchronisierung eines Harness-Design-Projekts mit einem MCAD-Tool über MCAD CoDesigner verwendet. Weitere Informationen finden Sie auf der Seite Synchronizing a Harness Design Project.

Hinzufügen von Spleißen und Abgriffen

In Designsituationen, in denen ein neuer Draht mit einem bereits platzierten Draht verbunden werden muss, muss zuerst ein Spleiß- (Place » Splice) oder Abgriffobjekt (Place » Tap) platziert werden.

  • Splice – der ursprüngliche Draht wird durch den Spleiß in zwei separate Drähte aufgeteilt.

    Javascript ID: Harness_WD_PlacingSplice_AD25

    Ein weiterer Draht muss mit dem ausgewählten Draht (W4) verbunden werden.

    Ein auf dem Draht platzierter Spleiß. Beachten Sie, dass der Spleiß den ursprünglichen Draht an der Stelle des Spleißes in zwei Teile teilt.

    Ein weiterer Draht wurde mit dem Spleiß verbunden.

    Wenn zwei Drähte T-förmig verbunden werden, wird an der Stelle der T-Verbindung automatisch ein Spleiß platziert (Beispiel anzeigen).

  • Tap – der ursprüngliche Draht bleibt ununterbrochen.

    Javascript ID: Harness_WD_PlacingTap_AD25

    Ein weiterer Draht muss mit dem ausgewählten Draht (W4) verbunden werden.

    Ein auf dem Draht platzierter Abgriff. Beachten Sie, dass der Abgriff den ursprünglichen Draht nicht aufteilt.

    Ein weiterer Draht wurde mit dem Abgriff verbunden.

Eigenschaften eines platzierten Spleiß- oder Abgriffobjekts (seine Position und visuelle Darstellung) können im Fenster Properties konfiguriert werden, wenn das Objekt im Designbereich ausgewählt ist.

Das Properties-Fenster bei ausgewähltem Spleiß/Abgriff
Das Properties-Fenster bei ausgewähltem Spleiß/Abgriff

Der Bereich Associated Parts des Fensters Properties ermöglicht die Zuweisung von Komponenten zum ausgewählten Spleiß/Abgriff; diese Komponente wird in der BOM des Projekts berücksichtigt.

Hinzufügen von Kabeln

Um einen oder mehrere Drähte als zu einem Kabel hinzugefügt zu definieren, können Sie ein Kabelobjekt im Harness-Verdrahtungsdiagramm platzieren (Place » Harness Cable).

Platzieren Sie ein Kabel, um einen oder mehrere Drähte als zu einem Kabel hinzugefügt zu definieren.
Platzieren Sie ein Kabel, um einen oder mehrere Drähte als zu einem Kabel hinzugefügt zu definieren.

Wenn ein Kabelobjekt ausgewählt ist, werden die von diesem Kabel abgedeckten Drähte im Designbereich in Neongrün hervorgehoben ().

Eigenschaften eines platzierten Kabelobjekts (seine Position, visuelle Darstellung und Parameter) können im Fenster Properties konfiguriert werden, wenn das Objekt im Designbereich ausgewählt ist.

 
 
 
 
 

Das Properties-Fenster bei ausgewähltem Kabel
Das Properties-Fenster bei ausgewähltem Kabel

Ein Kabel hat während der Platzierung oder grafischen Bearbeitung ein festes Seitenverhältnis von 2:1, wobei die endgültige Platzierungsgröße durch den aktuellen Fangrasterwert des Dokuments bestimmt wird.

  • Wenn ein Kabel an mehreren Stellen im Harness-Verdrahtungsdiagramm mit Drähten verknüpft ist (d. h. wenn mehrere Kabelobjekte mit demselben Bezeichner über verschiedene Drähte hinweg platziert sind), werden beim Auswählen eines Objekts alle zugehörigen Drähte in der Gruppe hervorgehoben, und alle diese Drähte werden im Bereich Cable Objects des Fensters Properties aufgelistet ().

  • Die Parameter Color, Min. Bending Radius, Thickness und Units eines Kabels werden bei der Synchronisierung eines Harness-Design-Projekts mit einem MCAD-Tool über MCAD CoDesigner verwendet. Weitere Informationen finden Sie auf der Seite Synchronizing a Harness Design Project.

Abschirmung und Verdrillung von Drähten

Eine Abschirmung (mit oder ohne Verbindung, z. B. eine Drain-Draht-Verbindung) kann an einer Gruppe von Drähten angebracht werden, indem entweder ein Abschirmungsobjekt (Place » Shield) oder ein Abschirmungsobjekt mit Verbindung (Place » Shield with Connection) platziert wird.

Im unten gezeigten Beispiel werden die Drähte W1, W2 und W3 durch eine Abschirmung ohne Verbindung (SH1) abgeschirmt, und die Drähte W4, W8 und W9 werden durch eine Abschirmung mit Verbindung (SH2) abgeschirmt. Draht W10 wird platziert, um SH2 mit einem Komponenten-Pin zu verbinden.

Platzieren Sie ein Abschirmungsobjekt oder ein Abschirmungsobjekt mit Verbindung, um Drähte als abgeschirmt zu kennzeichnen.
Platzieren Sie ein Abschirmungsobjekt oder ein Abschirmungsobjekt mit Verbindung, um Drähte als abgeschirmt zu kennzeichnen.

Wenn ein Abschirmungsobjekt oder ein Abschirmungsobjekt mit Verbindung ausgewählt ist, werden die abgedeckten Drähte im Designbereich in Neongrün hervorgehoben ().

Eigenschaften eines platzierten Abschirmungsobjekts oder Abschirmungsobjekts mit Verbindung (Position und visuelle Darstellung) können im Fenster Properties konfiguriert werden, wenn das Objekt im Designbereich ausgewählt ist. Der Bereich Shield Objects des Fensters listet die vom ausgewählten Objekt abgedeckten Drähte auf.

 
 
 
 
 

Das Properties-Fenster bei ausgewählter Abschirmung
Das Properties-Fenster bei ausgewählter Abschirmung

  • Eine Abschirmung hat während der Platzierung oder grafischen Bearbeitung ein festes Seitenverhältnis von 2:1, wobei die endgültige Platzierungsgröße durch den aktuellen Fangrasterwert des Dokuments bestimmt wird. 

  • Wenn eine Abschirmung an mehreren Stellen im Harness-Verdrahtungsdiagramm mit Drähten verknüpft ist (d. h. wenn mehrere Abschirmungsobjekte mit demselben Bezeichner über verschiedene Drähte hinweg platziert sind), werden beim Auswählen eines Objekts alle zugehörigen Drähte in der Gruppe hervorgehoben, und alle diese Drähte werden im Bereich Shield Objects des Fensters Properties aufgelistet ().

Drähte können als miteinander verdrillt gekennzeichnet werden, indem eine Verdrillung (Place » Twist) platziert wird. Eine Verdrillung kann über zwei oder mehr Drähte hinweg platziert werden.

Im folgenden Beispiel werden die Drähte W1 und W2 durch die Verdrillung Tw1 als miteinander verdrillt gekennzeichnet.

Platzieren Sie ein Verdrillungsobjekt, um Drähte als miteinander verdrillt zu kennzeichnen.
Platzieren Sie ein Verdrillungsobjekt, um Drähte als miteinander verdrillt zu kennzeichnen.

Wenn eine Verdrillung ausgewählt ist, werden die abgedeckten Drähte im Designbereich in Neongrün hervorgehoben ().

Die Eigenschaften einer platzierten Verdrillung (ihre Position und visuelle Darstellung) können im Fenster Properties konfiguriert werden, wenn das Objekt im Designbereich ausgewählt ist. Der Bereich Twist Objects des Fensters listet die von der ausgewählten Verdrillung abgedeckten Drähte auf.

 
 
 
 
 

Das Properties-Fenster bei ausgewählter Verdrillung
Das Properties-Fenster bei ausgewählter Verdrillung

  • Eine Verdrillung hat während der Platzierung oder grafischen Bearbeitung ein festes Seitenverhältnis von 1:1, wobei die endgültige Platzierungsgröße durch den aktuellen Fangrasterwert des Dokuments bestimmt wird. 

  • Wenn eine Verdrillung an mehreren Stellen im Harness-Verdrahtungsdiagramm mit Drähten verknüpft ist (d. h. wenn mehrere Verdrillungsobjekte mit demselben Bezeichner über verschiedene Drähte hinweg platziert sind), werden beim Auswählen eines Objekts alle zugehörigen Drähte in der Gruppe hervorgehoben, und alle diese Drähte werden im Bereich Twist Objects des Fensters Properties aufgelistet ().

  • Der Parameter Twists per Unit Length und die Parameter Thickness einer Verdrillung werden bei der Synchronisierung eines Harness-Design-Projekts mit einem MCAD-Tool über MCAD CoDesigner verwendet. Weitere Informationen finden Sie auf der Seite Synchronizing a Harness Design Project.

Nicht verbundene Drähte

Nicht verbundene Drahtenden werden mit einem ausgefüllten Quadrat angezeigt.

Ein angezeigtes nicht verbundenes Drahtende
Ein angezeigtes nicht verbundenes Drahtende

Ein Drahtende sollte nicht unverbunden bleiben. Wenn das Design ein unverbundenes Drahtende erfordert, sollte am Ende ein „No Connect“-Objekt platziert werden (Place » No Connect).

Platzieren Sie ein „No Connect“-Objekt am Ende eines Drahts, der unverbunden bleiben soll.
Platzieren Sie ein „No Connect“-Objekt am Ende eines Drahts, der unverbunden bleiben soll.

Eigenschaften eines platzierten „No Connect“-Objekts (seine Position und visuelle Darstellung) können im Fenster Properties konfiguriert werden, wenn das Objekt im Designbereich ausgewählt ist.

Das Properties-Fenster bei ausgewähltem „No Connect“-Objekt
Das Properties-Fenster bei ausgewähltem „No Connect“-Objekt

Arbeiten mit mehreren Blättern

Ein vollständiger Schaltplan für den Kabelbaum kann über mehrere Blätter hinweg definiert werden (in einer „flachen“ Entwurfsweise, bei der alle Blätter auf derselben Ebene existieren), wobei jedes durch ein eigenes *.WirDoc Dokument dargestellt wird. Die Konnektivität wird mithilfe von Wire-Break-Objekten (Place » Wire Break) mit derselben Wire-Bezeichnung direkt von jedem Blatt zu jedem anderen Blatt erstellt.

Nachdem Sie den Platzierungsbefehl für den Wire Break ausgewählt haben, positionieren Sie das Objekt so, dass sein elektrischer Hotspot (das vom Cursor gehaltene Ende) den Draht berührt, mit dem Sie eine Verbindung herstellen möchten, und klicken Sie dann oder drücken Sie Enter, um die Platzierung auszuführen. Ein platzierter Wire Break übernimmt die Eigenschaften (Bezeichnung und Farbe) des Drahts, mit dem er verbunden ist.

Wählen Sie im Arbeitsbereich einen Wire Break aus, um ihn im Properties Bedienfeld zu ändern. Im Bedienfeld können Sie die Bezeichnung des Drahts festlegen, mit dem er verbunden ist, sowie seinen Stil: Richtung (Left oder Right) und Farbe.

Synchronisierung von Drähten

Mit einem Wire Break verbundene Kabelbaumdrähte werden auch dann erkannt, wenn sie unterschiedliche Design Item IDs haben. Darüber hinaus werden alle Drahtsegmente mit derselben Bezeichnung, die durch denselben Wire Break verbunden sind, miteinander verglichen (hinsichtlich Teilenummer, Kommentar, Farbe und aller Parameter). Werden Unterschiede gefunden, wird die Verletzung Mismatched parameters in connected wire segments gemeldet. Außerdem erscheint im Properties Bedienfeld des Drahts und des Wire Breaks eine Warnung, die darauf hinweist, dass ein Konflikt zwischen den Parametern erkannt wurde. Klicken Sie innerhalb der Warnung auf Synchronize , um den Dialog Conflict Wire Parameters zu öffnen, in dem Sie auswählen können, welche Parameter für das Drahtsegment verwendet werden sollen.

Eigenschaften und Parameter des Drahts vor der Synchronisierung

Im Properties Bedienfeld erscheint eine Warnung, die darauf hinweist, dass ein Konflikt zwischen Parametern besteht. Nach dem Klicken auf Synchronize in der Warnung wird der Dialog Confirm Wire Parameters geöffnet. Wählen Sie die gewünschte Option und klicken Sie dann auf OK, um die Synchronisierung durchzuführen.

Die Verletzung Mismatched parameters in connected wire segments im Dialog Project Options

Nach der Synchronisierung wurden die Eigenschaften der Drahtsegmente synchronisiert. 

 
  • Beachten Sie, dass beim Ändern der Farbe und Bezeichnung eines Wire Breaks die Farbe und Bezeichnung des Drahts, mit dem der Wire Break verbunden ist, entsprechend geändert werden, und umgekehrt: Wenn Sie die Farbe und Bezeichnung eines Drahts ändern, werden die Farbe und Bezeichnung des mit dem Draht verbundenen Wire Breaks entsprechend geändert.

  • Sie können die Eigenschaften eines zu platzierenden Wire Breaks auch ändern, indem Sie nach dem Auswählen des Platzierungsbefehls Tab drücken. Beachten Sie, dass der Draht, mit dem der Wire Break verbunden wird, die Bezeichnung und Farbe des Wire Breaks übernimmt, wenn vor der Platzierung eine Bezeichnung für den Wire Break definiert wird.

  • Wenn für einen Draht, mit dem ein Wire Break verbunden ist, eine Rahmenfarbe definiert ist, wird dieser Wire Break ebenfalls mit einem Rahmen in dieser Farbe angezeigt. Auch die Bezeichnung des Wire Breaks wird in der Rahmenfarbe des verbundenen Drahts angezeigt.

  • Wire Breaks haben keine unabhängigen Schriftarteigenschaften; sie verwenden die Eigenschaften Document Font des Kabelbaum-Schaltplandokuments, auf dem sie platziert sind.

  • Wire Breaks können auch verwendet werden, um Konnektivität innerhalb desselben Kabelbaum-Schaltplanblatts zu erstellen – zum Beispiel können Sie statt einen Draht von einem Steckverbinder-Pin zu einem anderen zu platzieren, an jedem dieser Pins einen kurzen Kabelbaumdraht und einen Wire Break platzieren ().

Platzieren einer Kabelbaum-Schaltplankomponente

Wenn Sie mit Ihrem Workspace verbunden sind, können Sie Komponenten mit vordefinierter Struktur und Eigenschaften erstellen, wie sie im verbundenen Workspace erforderlich sind, und diese Komponenten dann in Ihren Kabelbaumdesigns wiederverwenden, indem Sie sie direkt in Kabelbaum-Schaltplandokumenten platzieren.

Weitere Informationen finden Sie auf der Seite Erstellen einer Kabelbaum-Schaltplankomponente.

Auf diese Komponenten (jeweils mit einem zugewiesenen Kabelbaum-Schaltplanmodell) wird über das Components panel zugegriffen. Wenn das gewünschte Kabelbaum-Schaltplandokument das aktive Dokument im Arbeitsbereich ist, platzieren Sie eine Komponente, indem Sie im Bedienfeld mit der rechten Maustaste auf ihren Eintrag klicken und im Kontextmenü den Befehl Place <ComponentName> auswählen. Das Verhalten beim Platzieren einer Komponente unterscheidet sich je nachdem, ob die Komponente ein einzelnes Drahtobjekt oder eine Kabelstruktur (mehrere Drähte und/oder zusätzliche Objekte: Kabel, Schirme usw.) enthält.

  • Single wire – wenn Sie eine Komponente platzieren, die ein einzelnes Drahtobjekt enthält, wechseln Sie in den Platzierungsmodus für Kabelbaumdrähte. Der platzierte Draht übernimmt die beim Erstellen der Komponente definierten Eigenschaften. Weitere Informationen zum Platzieren von Kabelbaumdrähten finden Sie oben im Abschnitt Creating Connectivity in the Harness Wiring Diagram.

  • Cable structure – wenn Sie den Platzierungsbefehl für eine Komponente auswählen, die eine Kabelstruktur enthält, erscheint diese Kabelstruktur genauso am Cursor angehängt, wie sie bei der Erstellung der Komponente definiert wurde. Klicken Sie an die gewünschte Stelle im Kabelbaum-Schaltplandokument, um die Komponente zu platzieren. Anschließend können Sie die Objekte der Komponente einzeln bearbeiten, zum Beispiel um Drähte, aus denen das Kabel besteht, an die Pins von Kabelbaum-Steckverbindern anzuschließen.

Aktualisieren des Verdrahtungsplans aus Bibliotheken

Die folgenden Objekte können aus ihrer Workspace-Quellbibliothek aktualisiert werden:

  • Kabelbaumkomponenten

  • Kavitäten von Kabelbaumkomponenten

  • Mit Kabelbaumkomponenten verknüpfte Teile

  • Drähte

Wenn ein Objekt ausgewählt ist, finden Sie Informationen über die verknüpfte Workspace-Komponente im Properties Bedienfeld (z. B. auf der Registerkarte Associated Parts für die mit einer Kabelbaumkomponente verknüpften Teile).

Wenn eine neuere Revision der Workspace-Komponente verfügbar ist, wird dies im Eintrag für den Revisionsstatus mit dem Text Out of date angezeigt. Auf Ebene des einzelnen Objekts kann die Verknüpfung zur neuesten Revision der Workspace-Komponente durch Klicken auf die Schaltfläche  aktualisiert werden.

Ein Beispiel für die Kennzeichnung einer veralteten Revision einer Kabelbaumkomponente
Ein Beispiel für die Kennzeichnung einer veralteten Revision einer Kabelbaumkomponente

Die Funktion Update from Libraries (Tools » Update from Libraries) kann ebenfalls verwendet werden, um veraltete Komponenten zu aktualisieren, die mit den oben aufgeführten Objekten verknüpft sind. Beachten Sie, dass eine einem Objekt zugewiesene Komponente eine Verknüpfung zu einem Schaltplansymbol enthalten muss, damit das Objekt mithilfe der Funktion Update from Libraries in die Aktualisierung einbezogen werden kann.

Annotieren von Objekten im Kabelbaum-Schaltplan

Verwenden Sie die Befehle im Menü Tools » Annotation, um die folgenden Objekte im Kabelbaum-Schaltplandokument zu annotieren:

  • Kabelbaumkomponenten

  • Drähte

  • Spleiße und Abzweige

  • Kabel

  • Schirme und Schirme mit Verbindung

  • Verseilungen

  • „No connect“-Objekte

Das Annotieren von Objekten in einem Kabelbaum-Schaltplandokument ist ähnlich wie das Annotieren von Komponenten in einem Schaltplandokument (*.SchDoc) eines PCB-Designprojekts. Über die folgenden Links erfahren Sie mehr über die für ein Kabelbaum-Schaltplandokument verfügbaren Annotierungsbefehle:

AI-LocalizedKI-lokalisiert
Wenn Sie ein Problem feststellen, wählen Sie den Text/das Bild aus und drücken SieCtrl + Enter, um uns Ihr Feedback zu senden.
Funktionsverfügbarkeit

Die Ihnen zur Verfügung stehenden Funktionen hängen davon ab, über welche Altium-Lösung Sie verfügen – Altium Develop, Altium Agile Teams, Altium Agile Enterprise oder Altium Designer (mit aktivem Laufzeitvertrag).

Wenn Sie eine dokumentierte Funktion in Ihrer tatsächlich verwendeten Software nicht sehen, wenden Sie sich an den Altium-Vertrieb, um mehr zu erfahren.

Legacy-Dokumentation

Die Dokumentation von Altium Designer wird nicht mehr versioniert. Wenn Sie auf Dokumentation für ältere Versionen von Altium Designer zugreifen müssen, besuchen Sie den Abschnitt Legacy-Dokumentation auf der Seite Andere Installer.

Inhalt