Unterstützung für die Panelisierung
Auf einen Blick
- Erfahren Sie, wie Nutzengröße, Abstände und die Option „Berechnen“ bestimmen, wie viele Leiterplatten auf einen Nutzen passen.
- Lernen Sie die Abstandsmethoden „Versatz“ und „Zwischenraum“ kennen und prüfen Sie Ihre Anordnung in der Vorschau, bevor Sie sie anwenden.
- Entdecken Sie, wie Step & Repeat die Duplizierung von Daten reduziert und wie Sie Anordnungen nach der Nutzenerstellung aktualisieren.
Traditionell haben Entwicklungsingenieure CAM-Werkzeuge ausschließlich zur Überprüfung eingesetzt und ihre Gerber- und Bohrdatenausgaben visuell kontrolliert, bevor sie diese Dateien an den Leiterplattenhersteller weitergaben. Erfahrene Entwickler wissen, wie wichtig die nach Abschluss des Designs erforderlichen Arbeiten sind, damit sie zuverlässig funktionsfähige Leiterplatten erhalten. Dazu gehört eine präzise und offene Kommunikation mit Fertigung und Bestückung.
Der CAM-Editor von Altium Designer bietet Entwicklern alles, was sie für diese Kommunikation benötigen: nicht nur zuverlässige Prüfwerkzeuge, sondern auch den vollständigen CAM-Werkzeugsatz, der Leiterplattenherstellern und Bestückungsdienstleistern zur Verfügung steht. Dazu gehören Werkzeuge zur Nutzenerstellung und zur Definition von Fräskanten.
Viele Leiterplattenentwickler werden sich fragen, warum diese Werkzeuge enthalten sind. Unsere Antwort lautet: Es ist für uns schwer festzulegen, wo Ihre Aufgabe als Entwickler endet. Einige von Ihnen werden ihre Designs lediglich überprüfen und die optimale Ausnutzung der Leiterplattenfläche dem Hersteller überlassen wollen, solange sie das erhalten, was sie bestellt haben. Andere möchten vielleicht stärker eingebunden sein. Beispielsweise möchten Sie möglicherweise Nutzen erstellen, die nicht nur den Anforderungen des Leiterplattenherstellers, sondern auch denen des Bestückungsdienstleisters optimal entsprechen.
Nutzenerstellung
Ein Nutzen wird in einem automatisierten Prozess erstellt. Dabei legen Sie die Größe des Nutzens fest und bestimmen, wie die einzelnen Kopien der Leiterplattendaten auf der Nutzenfläche angeordnet werden. Sie können außerdem festlegen, wie die Daten gespeichert werden. Wir empfehlen dringend, einen der verfügbaren Offset-Codes zu verwenden, da diese Ihre Dateien klein und übersichtlich halten. Die Bild- und Bohrinformationen werden dann nur einmal im Nutzen definiert, gefolgt von einer Reihe von Wiederholungsanweisungen.
Positionierungswerkzeuge
Die Nutzenerstellung folgt dem allgemeinen Bearbeitungsablauf des CAM-Editors. Rufen Sie zunächst den Befehl Tools » Panelize PCB auf und wählen Sie anschließend die Objekte aus, die Sie in den Nutzen aufnehmen möchten (oder verwenden Sie die Tastenkombinationen E, S, L, um alles auszuwählen). Führen Sie den Befehl dann durch einen Rechtsklick oder mit der Tastenkombination Shift+9 aus. Dadurch wird das Dialogfeld Panelization geöffnet.
Das zunächst angezeigte Dialogfeld Panelization enthält Informationen, die anhand der Abmessungen der Leiterplatte berechnet werden, für die Sie einen Nutzen erstellen. Diese Abmessungen werden durch die ausgewählten Objekte definiert. Oben im Dialogfeld werden die horizontalen und vertikalen Abmessungen der ausgewählten Objekte in den Feldern Image Size angezeigt. Darunter sehen Sie die Werte für Panel Size, Spacing und Parts Count.
Alle diese Felder werden dynamisch aktualisiert. Wenn die Option Calculate aktiviert ist, wird Ihnen die maximale Anzahl von Spalten und Zeilen angezeigt, die bei den von Ihnen eingegebenen Werten für Nutzengröße und Abstände Platz finden. Sie können die Anzahl der Spalten und/oder Zeilen auf Ihrem Nutzen gegebenenfalls erhöhen, indem Sie die Leiterplatten näher zusammenrücken oder einen schmaleren Rand an den Nutzenkanten vorsehen. Auch durch eine Vergrößerung des Nutzens können Sie mehr Leiterplatten unterbringen.
Wenn Sie die Option Calculate deaktivieren, können Sie umgekehrt vorgehen: Sie geben nun die Anzahl der Spalten und Zeilen ein, die auf dem Nutzen Platz finden sollen. Die resultierende Nutzengröße wird entsprechend den Werten angezeigt, die Sie in die Felder Parts Count und Spacing eingegeben haben. Da sich dabei ungerade Werte für die Nutzengröße ergeben, wird diese Methode wahrscheinlich nur zur Ermittlung der minimal erforderlichen Nutzengröße verwendet. Anschließend sollten Sie die Option Calculate wieder aktivieren und eine Nutzengröße eingeben, die von Ihrem Leiterplattenhersteller und Ihrem Bestückungsdienstleister unterstützt wird.
Die Leiterplattenanordnung kann innerhalb des Nutzens zentriert oder in der unteren linken Ecke platziert werden.
Durch Klicken auf die Schaltfläche Show Preview öffnen Sie ein Vorschaufenster innerhalb des Dialogfelds. Dort können Sie sehen, wie die Nutzen auf dem Bogen angeordnet werden. Änderungen an den Nutzenabständen werden im Vorschaufenster aktualisiert, sodass Sie vor dem Fortfahren die gewünschten Abstände einstellen können.
Nachdem Sie alle Optionen wie gewünscht festgelegt haben, wird durch Klicken auf OK die Nutzenerstellung ausgeführt und die Nutzenanordnung im Hauptarbeitsbereich angezeigt. Die Anordnung beginnt mit den ursprünglich ausgewählten Objekten und wird nach oben und nach links erweitert.
Schritte in die richtige Richtung
Wenn Sie acht vollständige Kopien Ihrer Leiterplatte auf einem Nutzen platzieren, ist die resultierende Datei logischerweise mindestens achtmal so groß. Das gilt immer dann, wenn Daten exploded werden, also für jede neue Position vollständig neu in die Beschreibungsdatei geschrieben werden. Die eigentliche Belastung durch eine solche Datei liegt normalerweise nicht in ihrer Größe, sondern darin, dass jeder Neuaufbau der Bildschirmanzeige achtmal so lange dauert.
Der CAM Editor bietet zwei Arten von Offset-Codes, damit Ihre Dateien bei der Nutzenerstellung nicht auf unhandliche Größen anwachsen: herkömmliche Step & Repeat-Befehle und ODB++ Steps.
Step & Repeat
Wenn die Option Use Step & Repeat im Dialogfeld Panelization aktiviert ist, werden die zuvor ausgewählten Daten in die untere linke Ecke des Nutzens verschoben. Alle anderen Nutzenbereiche sehen weitgehend so aus wie in der Nutzenvorschau: als leere Rechtecke, welche die vertikalen und horizontalen Abmessungen der kopierten Daten darstellen. Diese Rechtecke erscheinen auf jeder Lage, die Step & Repeat-Informationen enthält.
Da die in jedem Wiederholungsschritt gespeicherten Daten zum Zeitpunkt der Nutzenerstellung festgelegt werden, sollten Sie Step & Repeat -Codes erst verwenden, wenn Sie absolut sicher sind, dass die ursprünglichen Daten nicht mehr geändert werden. Das ist natürlich der Idealfall, da die Nutzenerstellung normalerweise erst nach Abschluss der Überprüfung erfolgt. Was aber, wenn Sie nach der Nutzenerstellung feststellen, dass noch kleinere Änderungen an der Leiterplatte erforderlich sind?
Es ist möglich, Step & Repeat -Daten zu bearbeiten, allerdings ist dies nicht einfach. Neue Blitze, Linien oder Texte können zu den Daten hinzugefügt werden, die im unteren linken Bereich des Nutzens sichtbar sind. Diese zusätzlichen Objekte können anschließend mit dem Befehl Edit » Step/Repeat » Add Objects zu den übrigen (wiederholten) Bereichen des Nutzens hinzugefügt werden. Nach dem Aufrufen des Befehls wird der Cursor zu einem Quadrat und Sie wechseln in den Modus zum Hinzufügen von Objekten. Führen Sie dazu die folgenden Schritte aus:
- Klicken Sie auf die hinzuzufügenden Objekte, um sie auszuwählen. Wenn Sie neben ein Objekt klicken, können Sie einen Auswahlbereich aufziehen, um mehrere Objekte in die Auswahl aufzunehmen. Die Auswahl wird schrittweise erweitert.
- Sobald alle gewünschten Objekte ausgewählt sind, klicken Sie mit der rechten Maustaste.
- Wählen Sie nun die Step-&-Repeat-Anordnung aus, zu der Sie die ausgewählten Objekte hinzufügen möchten. Positionieren Sie dazu den Cursor über einem beliebigen Objekt, das zur Auswahl der Anordnung im ursprünglichen Rahmen der Anordnung (unten links) gehört, und klicken Sie. Die Größe der Rahmen in der Anordnung wird so angepasst, dass sowohl die hinzugefügten als auch die ursprünglichen Objekte hineinpassen. Nur der ursprüngliche Rahmen der Anordnung (unten links) enthält sichtbare Objekte – alle anderen Rahmen bleiben leer.
- Wählen Sie weitere Objekte aus, die Sie anderen Step-&-Repeat-Anordnungen hinzufügen möchten, oder klicken Sie mit der rechten Maustaste bzw. drücken Sie Esc, um den Modus zu verlassen.
Durch das Hinzufügen von Objekten kann es durchaus vorkommen, dass sich die Rahmen der Anordnung überlappen. Sie können den Abstand (bzw. Zwischenraum) zwischen den Rahmen im Dialogfeld Modify Step_Repeat ändern. Wählen Sie dazu den Befehl Edit » Step/Repeat » Modify in den Hauptmenüs. Nach dem Aufrufen des Befehls wird der Cursor zu einem Quadrat und Sie wechseln in den Modus zum Bearbeiten von Anordnungen. Führen Sie zum Bearbeiten einer Anordnung die folgenden Schritte aus:
-
Wählen Sie die zu bearbeitende Step-&-Repeat-Anordnung aus. Positionieren Sie dazu den Cursor über einem beliebigen Objekt, das zur Auswahl der Anordnung im ursprünglichen Rahmen der Anordnung (unten links) gehört, und klicken Sie. Das Dialogfeld Modify Step_Repeat wird angezeigt. In diesem Dialogfeld können Sie die Anzahl der Zeilen und Spalten der Anordnung sowie deren Abstände ändern. Für die Abstände stehen zwei Methoden zur Verfügung:
- Distance – Mit dieser Methode legen Sie den Abstand zwischen Zeilen und Spalten relativ zur Bildgröße (d. h. zur Auswahl der Objekte) fest. Wenn Sie einen Wert in ein Distance -Feld eingeben, müssen Sie den gewünschten Abstand zum Wert im Feld Image Size addieren und diese Summe als Abstand eingeben. Wenn die Bildgröße beispielsweise 0,5 Zoll beträgt und Sie einen Zwischenraum von 200 mil benötigen, müssen Sie 0.7 in das entsprechende Distance -Feld eingeben.
- Gap – Mit dieser Methode legen Sie den direkten Abstand zwischen Zeilen und Spalten fest, unabhängig von der Bildgröße. Wenn Sie beispielsweise einen Abstand von 200 mil benötigen, müssen Sie 0.2 in das entsprechende Gap -Feld eingeben.
- Nachdem Sie die gewünschten Änderungen an der Anordnung vorgenommen haben, klicken Sie auf OK. Die Step-&-Repeat-Anordnung wird entsprechend den angegebenen Änderungen angepasst.
- Wählen und bearbeiten Sie weitere Step-&-Repeat-Anordnungen, oder klicken Sie mit der rechten Maustaste bzw. drücken Sie Esc, um den Modus zu verlassen.
Das Löschen ist etwas komplexer: Zunächst müssen Sie Objekte mit dem Befehl Edit » Step/Repeat » Remove Objects aus den wiederholten (nicht sichtbaren) Bereichen des Nutzens entfernen, bevor Sie dieselben Objekte mit dem Befehl Edit » Clear aus dem sichtbaren Bereich des Nutzens löschen. Nach dem Aufrufen des Befehls Edit » Step/Repeat » Remove Objects wird der Cursor zu einem Quadrat und Sie wechseln in den Modus zum Entfernen von Objekten. Führen Sie dazu die folgenden Schritte aus:
- Wählen Sie die zu entfernenden Objekte innerhalb des ursprünglichen Rahmens (unten links) der gewünschten Step-&-Repeat-Anordnung aus. Positionieren Sie dazu einfach den Cursor über einem vorhandenen Objekt, das Sie in die Auswahl aufnehmen möchten, und klicken Sie. Alternativ können Sie neben ein Objekt klicken und einen Auswahlbereich aufziehen, um mehrere Objekte in die Auswahl aufzunehmen. Die Auswahl wird schrittweise erweitert.
- Sobald alle gewünschten Objekte ausgewählt sind, klicken Sie mit der rechten Maustaste. Die Objekte werden aus der Anordnung entfernt und die Größe der Rahmen wird an die verbleibenden Objekte angepasst.
- Wählen Sie weitere Objekte aus, die Sie aus anderen Step-&-Repeat-Anordnungen entfernen möchten, oder klicken Sie mit der rechten Maustaste bzw. drücken Sie Esc, um den Modus zu verlassen.
Da dieselbe Gruppe von Objekten für zwei verschiedene Befehle zweimal ausgewählt werden muss, besteht ein hohes Fehlerrisiko. Der CAM-Editor bietet jedoch die Möglichkeit, eine vorherige Auswahl erneut auszuwählen. Erschwerend kommt hinzu, dass die in der Anordnung enthaltenen Step & Repeat-Rahmen leer bleiben und keinerlei Hinweise auf ihren Inhalt liefern, bis die Daten mit dem Befehl Edit » Step/Repeat » Explode in primitive Objekte aufgelöst werden. Nach dem Aufrufen des Befehls wird der Cursor zu einem Quadrat und Sie werden aufgefordert, die aufzulösende Step-&-Repeat-Anordnung auszuwählen. Positionieren Sie dazu den Cursor über einem beliebigen Objekt, das zur Auswahl der Anordnung im ursprünglichen Rahmen der Anordnung (unten links) gehört, und klicken Sie. Alle Rahmen der Anordnung werden mit kopierten Daten aus dem Original gefüllt und die Rahmenbegrenzungen werden entfernt. Lösen Sie weitere Step-&-Repeat-Anordnungen auf, oder klicken Sie mit der rechten Maustaste bzw. drücken Sie Esc, um den Modus zu verlassen.
ODB++-Steps
ODB++ lösen die Probleme, die bei Step & Repeat-Codes auftreten. Jeder von Ihnen erstellte Step wird zu einer neuen Spalte, die den aktuellen Lagenzeilen zugeordnet ist. Je mehr Steps Sie hinzufügen, desto größer wird die Matrix, in der Daten gespeichert werden können. Ein Step kann einmal oder mehrfach in einen anderen Step eingefügt werden. Genau dies geschieht, wenn Sie bei aktivierter Option Create ODB++ Step einen Nutzen erstellen. Bei Verwendung der Option Create ODB++ Step werden zusätzlich zum Standard-Step für den Arbeitsbereich (cam_work) zwei neue Steps erstellt:
- einer für die Daten, die Sie für die Nutzenerstellung ausgewählt haben (campcb)
-
einer für den Nutzen selbst (campanel).
Sie können den Inhalt jedes Steps anzeigen, indem Sie auf dessen Namen auf der Registerkarte Steps des Panels CAM doppelklicken.
Der Step mit den ausgewählten Daten wird automatisch als untergeordneter Step in den Nutzen-Step eingefügt und im folgenden Format angezeigt:
[n]: StepName (Zeilen, Spalten),
wobei [n] die nächste verfügbare Nummer ist, die dem eingefügten Step zugewiesen wird, beginnend bei 1. Rows und Columns werden aus dem Bereich Parts Count des Dialogfelds Panelization übernommen.
Wenn Sie den Inhalt des Nutzenschritts im Designbereich betrachten, wird der eingefügte (Daten-)Schritt als Zeilen × Spalten leere weiße Rechtecke dargestellt. Anders als bei einem Step & Repeat -Array sind die Objektdaten in keinem der Array-Bereiche sichtbar. Für jede Instanz des eingefügten Schritts wird ein weißes Kreuz angezeigt. Es kennzeichnet die Position, an der die Dateninhalte eingefügt werden, wenn Sie das Schritt-Array auflösen.
Bevor Sie Ihre Arbeit abschließen, sollten Sie mit der rechten Maustaste auf den Nutzenschritt klicken und Refresh Inserts wählen. Dadurch wird sichergestellt, dass die eingefügten Schritte auf dem Nutzen den aktuellen Stand der Quelldaten wiedergeben und alle nach der Nutzenerstellung vorgenommenen Änderungen im fertigen Nutzen berücksichtigt werden.
Um das Dialogfeld Steps Table aufzurufen, in dem Sie die ODB++-Schrittinformationen für das aktuelle Dokument anzeigen können, wählen Sie den Befehl Tables » Steps in den Hauptmenüs. Wenn Sie im Dialogfeld Steps Table auf OK klicken, wird die Registerkarte Steps im Panel CAMtastic aktualisiert. Auf dieser Registerkarte können Sie Schritte hinzufügen oder ändern, indem Sie mit der rechten Maustaste klicken und den entsprechenden Befehl aus dem Kontextmenü wählen. Das Dialogfeld Steps Table wird beim Importieren von ODB++-Dateien in den CAMtastic-Editor automatisch angezeigt.
Weitere Strategien zur Nutzenerstellung
Die automatischen Werkzeuge helfen Ihnen dabei, möglichst viele identische Leiterplatten auf Ihrem Nutzen unterzubringen. Doch was ist, wenn Ihre Anforderungen an den Nutzen komplexer sind? Wie fügen Sie dem Nutzen Bohrtestcoupons oder Werkzeuglöcher hinzu? Was, wenn Sie Ihre Daten nach dem Step-and-Turn-Prinzip anordnen möchten, sodass der Nutzen nach dem Wenden identisch aussieht und Sie beide Seiten bestücken können, indem Sie den Nutzen zweimal durch denselben Bestückungsautomaten laufen lassen? Oder wenn Sie die Nutzenfläche optimal ausnutzen möchten, indem Sie unterschiedliche Leiterplatten auf demselben Nutzen anordnen?
Alle diese Anforderungen lassen sich mithilfe von ODB++-Schritten im CAM Editor erfüllen. Ausgangspunkt ist die automatische Nutzenerstellung, denn nur damit lässt sich eine Nutzenkontur erstellen, indem Sie die Option Create ODB++ Step anstelle der Option Use Step & Repeat verwenden.
Schritte einfügen
Die Dialogfelder Enter Value und Add Insert to ODB Step
Sie können neben dem Leiterplatten-Array auf Ihrem Nutzen weitere Schritte einfügen. Ein Leiterplattenhersteller kann beispielsweise einen Bohrtestcoupon auf einem der abbrechbaren Randstreifen platzieren, um die vorgesehenen Bohrungsgrößen visuell mit denen der gefertigten Leiterplatten zu vergleichen. Werkzeuglöcher, mit denen der Nutzen beim Bohren und Fräsen der Nutzenlagen fixiert wird, müssen möglicherweise an anderen Stellen auf dem Nutzen statt innerhalb der Leiterplatteninstanzen platziert werden.
Zunächst müssen Sie einen neuen Schritt erstellen. Verwenden Sie dazu den Befehl Add Step aus dem Kontextmenü der Registerkarte Steps im Panel CAM. Der neue Schritt enthält dieselben Lagen, diese sind jedoch zunächst alle leer. Über dasselbe Kontextmenü können Sie Daten zwischen Schritten kopieren oder verschieben. Alternativ können Sie neue Objekte auf den vorhandenen Lagen platzieren, während der neue Schritt aktiv ist. Diese Objekte sind dann nur in diesem Schritt vorhanden.
Um beispielsweise einen Bohrtestcoupon zu erstellen, können Sie einen neuen Schritt anlegen und anschließend jedes in Ihrem Design verwendete Werkzeug auf der Bohrlage in einer Reihe einmal setzen. Auf der oberen Bestückungsdrucklage können Sie für jede Bohrungsgröße Text oder andere Kennzeichnungen platzieren.
Außerdem sollten Sie eine geschlossene Polylinie um Ihre Daten auf der Lage zeichnen, der Sie in der Lagентabelle den Typ „Border“ zugewiesen haben. Wählen Sie dazu Tables » Layers im Hauptmenü. Daraus wird eine profile für ODB++ erzeugt. Diese Datei ermöglicht es, Schritte ineinander einzufügen, ohne dass deren Begrenzungen durch Schraffurmuster verletzt werden.
Für jeden Coupon oder jedes Objekt, das Sie Ihrem Nutzen hinzufügen möchten, können Sie einen weiteren Schritt erstellen. Bei aktivem Nutzenschritt können Sie jeden davon an einer genau festgelegten Position im übergeordneten Schritt des Nutzens, beispielsweise campanel, einfügen. Verwenden Sie dazu den Befehl Add Insert aus dem Kontextmenü. Falls Sie bei der ursprünglichen Erstellung dieses Nutzens ein Schraffurmuster angewendet haben, sollten Sie es entfernen und anschließend erneut anwenden. Dadurch berücksichtigt das Schraffurmuster die Profilbegrenzung jedes Schritts.
Step-and-Turn

Die Nutzenerstellung nach dem Step-and-Turn-Prinzip vereinfacht die Abläufe beim Bestückungsdienstleister. Normalerweise erfordern Leiterplatten mit Bauteilen auf Ober- und Unterseite zwei Bestückungsautomaten: einen für die Bauteile auf der Oberseite des Nutzens und einen für die Unterseite. Wenn jedoch Ober- und Unterseite des Nutzens nach dem Wenden identisch sind, kann der Nutzen zweimal durch denselben Bestückungsautomaten laufen.
Es ist wichtig, zwischen der Oberseite der Leiterplatte und der Oberseite des Nutzens zu unterscheiden. Bei diesem Verfahren müssen die Leiterplatten auf der rechten Seite des Nutzens denen auf der linken Seite entsprechen, allerdings gewendet. Außerdem muss der Lagenaufbau hinsichtlich der Lagentypen symmetrisch sein. Eine Hälfte der Nutzenoberseite enthält die Abbildungen der Leiterplattenoberseite, die andere Hälfte die gespiegelten Abbildungen der Leiterplattenunterseite.
Um dies im CAM Editor zu erreichen, müssen Sie zunächst alle Leiterplattendaten in einen neuen Schritt kopieren. Mit der Funktion Swap Layers Data, die Sie über Edit » Layers » Swap Layers Data im Hauptmenü aufrufen, können Sie festlegen, wo die Daten der gewendeten Lagen platziert werden. Dadurch enthält Ihre oberste Lage sowohl Abbildungen der oberen als auch der unteren Lage; diese Abbildungen verbleiben jedoch in getrennten Schritten.
Falls Sie noch keinen Nutzen aus dem ursprünglichen Design erstellt haben, können Sie dies jetzt tun. Achten Sie dabei auf eine gerade Anzahl von Spalten oder Zeilen, die im Nutzen zentriert sind. Klicken Sie auf das Pluszeichen neben dem erzeugten Schritt campanel und anschließend mit der rechten Maustaste auf den eingefügten Schritt, um ihn zu ändern. Ändern Sie die Anzahl der Zeilen oder Spalten so, dass die Hälfte der Leiterplatten verschwindet. Fügen Sie nun den neu erstellten Schritt ein und ordnen Sie ihn auf dieselbe Weise als Nutzen an. Verwenden Sie dabei jedoch einen berechneten Basispunkt, der das neue Array an derselben Position platziert wie die zuvor entfernten Schritte. Stellen Sie sicher, dass die Option Mirror für diesen Schritt aktiviert ist.
Das Dialogfeld Modify Insert in ODB Step
Unterschiedliche Leiterplatten auf demselben Nutzen
Das Wenden von Leiterplatten auf einem Nutzen ist tatsächlich nur ein sehr begrenzter Anwendungsfall der Möglichkeiten von ODB-Schritten. Leiterplatten lassen sich wenden, weil dieselbe Lage in jedem ihrer Schritte unterschiedliche Daten enthalten kann. Diese Schritte können anschließend im selben Designbereich nebeneinander platziert werden. Diese grundsätzliche Freiheit wirft die Frage auf: Warum sollte ein Nutzen ausschließlich aus einem Array identischer Leiterplatten bestehen? Die Antwort lautet: Im CAM Editor gibt es keine solche Einschränkung.
Es gibt vielfältige Gründe dafür, unterschiedliche Leiterplatten auf demselben Nutzen anzuordnen. Ein Leiterplattenhersteller möchte die Fläche des Nutzens möglichst vollständig ausnutzen. Je größer die Leiterplatte ist, desto schwieriger wird dies jedoch. Kleine Leiterplatten können freie Flächen füllen und die Fertigungskosten senken, selbst wenn sie aus einer anderen Quelle stammen. Umgekehrt kann ein einzelnes Produkt aus mehreren Leiterplatten bestehen, die ein Entwickler vorzugsweise gemeinsam auf einem einzigen Nutzen fertigen lassen möchte.
Natürlich gibt es bestimmte Einschränkungen. Sie können nur Leiterplatten mit demselben Lagenaufbau aus Signallagen und internen Versorgungslagen zu einem Nutzen zusammenfassen. Außerdem müssen ihre Bohrlagenkombinationen kompatibel sein.
Standardmäßig erstellt der CAM Editor neue Lagen, wenn neue Bilder oder Bohrdateien geladen werden. Dieses Verfahren eignet sich nicht zum gemeinsamen Nutzen unterschiedlicher Leiterplatten, da die Daten verschiedener Leiterplatten auf derselben Lage, aber in unterschiedlichen Schritten vorliegen müssen. Hierfür steht auf der Seite CAM Editor - Import/Export des Dialogs Preferences eine Option zur Verfügung, mit der Sie zusätzliche Gerber-/Bohrdateien in vorhandene Lagen importieren können.
Wenn diese Option aktiviert ist, wird bei jedem Import zusätzlicher Gerber-, Bohr- oder IPC-Datendateien ein Zuordnungsdialog angezeigt, sofern solche Lagen bereits importiert wurden.
Der Dialog Map Layers to Import to Existing Layers
Der Dialog Maps Layers to Import to Existing Layers enthält links die neuen Dateien und rechts die vorhandenen Lagen. Anhand der Dateierweiterungen und der Layer Types Detection Template, die Sie über Tables » Layer Type Detection im Hauptmenü aufrufen, schlägt der CAM-Editor Zuordnungen vor. Diese können Sie jedoch nach Bedarf anpassen. Für Dateien, die Sie keinen vorhandenen Lagen zuordnen möchten, können Sie festlegen, dass eine neue Lage erstellt wird oder dass sie vollständig vom Import ausgeschlossen werden.
Bevor Sie mit dieser Zuordnung fortfahren, müssen Sie einen neuen ODB-Schritt erstellen und als aktuellen Schritt festlegen. Andernfalls würden sämtliche Lagendaten übereinandergelegt, ohne dass sich die Daten der einzelnen Leiterplatten voneinander trennen ließen.
Kupferfüllmuster
Die Dialoge Venting und Edit Pattern - Venting
Sie können den ungenutzten Bereichen Ihres Nutzens ein Kupferfüllmuster hinzufügen, das dazu beitragen kann, das chemische Ätzmittel gleichmäßig über den Nutzen zu verteilen. Die automatische Nutzenerstellung des CAM-Editors füllt den gesamten Bereich zwischen dem Nutzenrand und den Leiterplatteninstanzen mit einem Kupferfüllmuster Ihrer Wahl.
Dieses Muster kann raster-, vektor- oder formbasiert sein oder aus einer Vollfläche bestehen. Sie können aus allgemeinen Formen mit benutzerdefinierten Abmessungen wählen oder einen vorhandenen D-Code als Grundlage für das Kupferfüllmuster auswählen. Dieses Muster wird nur auf die Signal- und Versorgungslagen angewendet (diese werden in der Spalte Layers Table in the Types definiert).
Wenn Sie bei der ursprünglichen Nutzenerstellung ein Kupferfüllmuster erstellt und anschließend ODB++-Schritte wie Testcoupons, Werkzeugbohrungen oder auch gespiegelte bzw. alternative Leiterplatten hinzugefügt haben, sollten Sie das Kupferfüllmuster aktualisieren. Entfernen Sie dazu das Kupferfüllmuster und fügen Sie es anschließend erneut hinzu. Die entsprechenden Befehle werden angezeigt, wenn Sie mit der rechten Maustaste auf den Schritteintrag für den Nutzen (campanel) klicken. Diesen finden Sie auf der Registerkarte Steps des Panels CAM. Denken Sie daran, den Nutzenschritt als aktuellen Schritt festzulegen, damit diese Befehle verfügbar sind.
Um dem aktuellen Leiterplattennutzen ein Kupferfüllmuster hinzuzufügen, wählen Sie im Hauptmenü den Befehl Tools » Venting. Die Verwendung dieses Befehls hängt davon ab, ob Sie die Lage vent_border bei der Nutzenerstellung beibehalten haben.
-
With a vent_border layer present – Nach dem Aufrufen des Befehls wird der Dialog Venting angezeigt. Standardmäßig sind alle Signal- und Versorgungslagen für das Kupferfüllmuster ausgewählt. Um die Auswahl einer Lage aufzuheben, klicken Sie einfach auf deren Eintrag.
Auf der linken Seite des Dialogs wird das aktuell definierte Kupferfüllmuster angezeigt, das angewendet wird. Klicken Sie auf die Schaltfläche Edit Pattern, um den Dialog Edit Pattern - Venting zu öffnen, in dem Sie das gewünschte Kupferfüllmuster festlegen können.
Nachdem Sie das Kupferfüllmuster und die zu füllenden Lagen nach Bedarf festgelegt haben, klicken Sie auf OK , um das Kupferfüllmuster in allen Bereichen außerhalb von vent_border auf den Nutzen anzuwenden.
-
With no vent_border layer present – Ohne eine Lage vent_border ist der Nutzenrand zwar weiterhin vorhanden, die einzelnen Leiterplatten auf dem Nutzen haben jedoch keine Begrenzung, anhand derer sich der Bereich für das Kupferfüllmuster berechnen lässt. Daher müssen Sie jeder Leiterplatte auf dem Nutzen eine Umrandung hinzufügen und damit praktisch Ihre eigene Lage vent_border erstellen. Eine der schnellsten Methoden hierfür besteht darin, eine neue Lage hinzuzufügen und mit dem Polylinienbefehl Begrenzungen um jede Leiterplatte auf dem Nutzen zu zeichnen.
Nach dem Aufrufen des Befehls wird der Cursor zu einem kleinen Quadrat, und Sie werden aufgefordert, die Nutzen- und Leiterplattenumrandungen auszuwählen. Ziehen Sie einfach einen Auswahlrahmen um den gesamten Nutzen. Nun sind alle Leiterplattenumrandungen und der Nutzenrand ausgewählt. Klicken Sie mit der rechten Maustaste – der Dialog Venting wird angezeigt. Legen Sie das Kupferfüllmuster und die zu füllenden Lagen nach Bedarf fest und klicken Sie anschließend auf OK. Das Kupferfüllmuster wird auf den Bereich zwischen dem Nutzenrand und den Leiterplattenumrandungen angewendet.
Film-Assistent
Um ausgewählte Gerber-Lagen des aktuellen Dokuments in einem einzigen Filmrahmen zu einem Nutzen zusammenzufassen und so die Gerber-Lagen auf Film ausgeben zu können, verwenden Sie den Befehl Tools » Film Wizard im Hauptmenü.
Stellen Sie zunächst sicher, dass nur die Gerber-Lagen eingeschaltet sind, die Sie in den Nutzen aufnehmen möchten.
Nach dem Aufrufen des Befehls wird der Dialog Film Wizard angezeigt. In diesem Dialog legen Sie die Größe des Films und die Anordnung der Lagen darauf fest. Sie können eine der vordefinierten Größen-/Anordnungsdefinitionen aus dem Dropdown-Feld Film Description auswählen oder eigene Werte eingeben.
Der Bereich Individual Film Size des Dialogs zeigt anhand der festgelegten Größen- und Anordnungseinstellungen an, wie viel Filmfläche für jedes Bild in der Anordnung verfügbar ist.
Durch Klicken auf die Schaltfläche Neg/Mirror öffnen Sie den Dialog Film Wizard - Select Layers. Wählen Sie in diesem Dialog aus, welche Lagen auf dem Film gespiegelt oder als Negativ dargestellt werden sollen.
Nachdem Sie die Filmoptionen festgelegt haben, klicken Sie im Dialog Film Wizard auf OK , um die Filmlage(n) zu erstellen. In einem Dialog werden Sie gefragt, ob alte Objekte gelöscht werden sollen. Wenn Sie Yes wählen, wird der Filmnutzen erstellt und die ursprünglichen Lagen werden gelöscht. Wenn Sie No wählen, wird der Filmnutzen erstellt und alle ursprünglichen Lagen bleiben erhalten, werden jedoch ausgeschaltet.
Leiterplattenkanten
Wie die Leiterplatten aus dem Nutzen getrennt werden, ist sowohl für Leiterplattenhersteller als auch für Bestückungsdienstleister von Bedeutung. Beispielsweise kann ein Bestückungsdienstleister es vorziehen, den Nutzen bis zum Abschluss der Bestückung intakt zu lassen. Dies setzt voraus, dass der Nutzen stabil genug ist, um während der Bestückung zusammenzuhalten, zugleich aber ausreichend perforiert ist, damit die Leiterplatten anschließend problemlos herausgebrochen werden können.
V-Ritzen
V-Ritzen ist eine geeignete Lösung, bei der zwischen den Leiterplattenabschnitten sowohl auf der Ober- als auch auf der Unterseite des Nutzens eine V-förmige Nut eingebracht wird, sodass ein dünner Verbindungssteg verbleibt. Alle Einzelheiten dieses Verfahrens, etwa der Klingenwinkel und die Stegdicke sowie die Frage, ob unterbrochenes Ritzen angewendet werden soll (Bereiche, in denen die Nut unterbrochen ist, um den Nutzen stabiler zu machen), müssen dem Bediener der Ritzmaschine mitgeteilt werden.
Derzeit müssen Ritzmaschinen programmiert werden. Häufig erfolgt dies anhand von Formularen ohne CAD-Bezug, in denen Sie die Datenpunkte und Linien Ihrer Nutzenkonfiguration angeben. Einige Dienstleister können jedoch Bohrungs- und Linieninformationen aus Gerber-Dateien extrahieren. In diesem Fall können Sie die Ritzlinien in CAM Editor genau nach Ihren Vorstellungen gestalten. In jedem Fall bieten Ritzlinien auf der oberen Bestückungsdrucklage dem Maschinenbediener visuelle Anhaltspunkte, die zusammen mit den extrahierten und den von Ihnen ausdrücklich bereitgestellten Informationen verwendet werden.
NC-Fräsen
Die herkömmliche Bearbeitung von Leiterplattenkanten erfolgt jedoch mit Fräswerkzeugen. Glatte Leiterplattenkanten lassen sich erzeugen, indem ein Fräser an bestimmten Stellen in die Leiterplatte eintaucht, entlang einer vorgegebenen Bahn geführt und anschließend wieder zurückgezogen wird.

Bei der Vorbereitung der Fräsinformationen sind mehrere Aspekte wichtig. Dazu gehören Größe und Form des Werkzeugs sowie die Fräsbahn mit ihren Eintauch- und Rückzugspunkten.
Um diese Anweisungen zu erzeugen und zu überprüfen, muss CAM Editor im NC-Fräsmodus konfiguriert sein. Dieser ist entweder über das Menü View oder das Panel CAM erreichbar. In diesem Modus können Sie anhand ausgewählter Flash-Objekte in Ihrem Design neue Bohrwerkzeuge für Ihre Werkzeugtabelle erstellen, indem Sie im Hauptmenü Tables » NC Tools auswählen. Nach dem Aufrufen des Befehls wird der Dialog Tool Table angezeigt. Standardmäßig enthält die Tabelle eine Werkzeugliste auf Grundlage einer importierten NC-Bohrdatei; andernfalls ist sie leer. Verwenden Sie die Tabelle, um Werkzeugdefinitionen hinzuzufügen oder zu bearbeiten. Es können bis zu 99 Werkzeuge definiert werden, jeweils mit einem eindeutigen D-Code, beginnend bei D9500. Verwenden Sie die Schaltflächen Save und Open , um die aktuelle Werkzeugtabellendefinition zu speichern bzw. eine zuvor gespeicherte Definition zu laden. Werkzeugdaten werden in einer Datei mit den Einstellungen der Fräswerkzeugtabelle (*.mts) gespeichert. Wenn Sie den Mauszeiger über die verschiedenen Spalten der Tabelle bewegen, erscheint ein Tooltip mit weiteren Informationen zum jeweiligen Eintrag.
Anschließend können Sie mit den Befehlen im Menü Rout Fräsbahnen für diese oder andere vorhandene Fräswerkzeuge definieren.
Fräsbahn(en) erstellen
Um Fräsbahnen aus ausgewählten Leiterbahnen im aktuellen Dokument zu erstellen, wählen Sie den Befehl Rout » Create Rout Path(s) aus den Hauptmenüs.
Stellen Sie zunächst sicher, dass Bohrwerkzeuge definiert wurden. Wenn Sie zuvor eine NC-Bohrdatei geladen haben, wurden die Werkzeuge für das Design automatisch geladen und werden im Dialog Tool Table angezeigt (Tables » NC Tools). Wenn derzeit keine Werkzeuge definiert sind, erscheint beim Versuch, den Befehl aufzurufen, ein entsprechender Hinweisdialog. Sie müssen dann Werkzeuge durch Importieren einer Bohrdatei oder durch manuelle Eingabe definieren.
Sobald die benötigten Werkzeuge definiert sind, öffnet sich beim Aufrufen des Befehls der Dialog Select Mill/Drill Tool Dialogfeld. Das Dialogfeld enthält eine Dropdown-Liste aller Bohrwerkzeuge, die derzeit für das Design definiert sind. Wählen Sie das Werkzeug aus, das Sie zum Fräsen verwenden möchten, und klicken Sie auf OK. Der Cursor wird zu einem kleinen Quadrat, und Sie werden aufgefordert, die Objekte auszuwählen, die Sie fräsen möchten. Positionieren Sie den Cursor einfach über einzelnen Objekten und klicken Sie, um sie zur Auswahl hinzuzufügen, oder verwenden Sie eines der zahlreichen verfügbaren Auswahlwerkzeuge. Wenn alle gewünschten Objekte ausgewählt sind, klicken Sie mit der rechten Maustaste.
Die ausgewählten Objekte werden gefräst, und eine Fräslage wird erstellt und der Lagenliste im CAMtastic Panel hinzugefügt. Das Dialogfeld Create Rout Path(s) wird geöffnet. Dort können Sie das zum Fräsen verwendete Werkzeug und dessen Versatz ändern. Sie können auch die Richtung der Fräsbahn(en) umkehren – Eintauchpunkte werden zu Ausfahrpunkten und umgekehrt. Diese Änderungen sind virtuell und werden erst dauerhaft übernommen, wenn Sie auf die Schaltfläche OK klicken.
Fräsbahn(en) ändern
Um ausgewählte Fräsbahnen im aktuellen Dokument zu ändern, wählen Sie den Befehl Rout » Modify Rout Path(s) aus den Hauptmenüs.
Stellen Sie zunächst sicher, dass nur die Fräslage eingeschaltet und im Designbereich sichtbar ist.
Nach dem Aufrufen des Befehls wird der Cursor zu einem kleinen Quadrat, und Sie werden aufgefordert, die zu ändernden Fräsbahnen auszuwählen. Positionieren Sie den Cursor einfach über einzelnen Objekten und klicken Sie, um sie zur Auswahl hinzuzufügen, oder verwenden Sie eines der zahlreichen verfügbaren Auswahlwerkzeuge. Wenn alle gewünschten Objekte ausgewählt sind, klicken Sie mit der rechten Maustaste.
Das Dialogfeld Modify Rout Path(s) wird geöffnet. Dort können Sie das zum Fräsen verwendete Werkzeug und dessen Versatz ändern. Sie können auch die Richtung der Fräsbahn(en) umkehren – Eintauchpunkte werden zu Ausfahrpunkten und umgekehrt. Diese Änderungen sind virtuell und werden erst dauerhaft übernommen, wenn Sie auf die Schaltfläche OK klicken.
Optionen zum Fräsen von Pads
Im Dialogfeld Rout Pads Options können Sie Optionen festlegen, die berücksichtigt werden sollen, wenn eine Fräsbahn auf Pads trifft. Um das Dialogfeld zu öffnen, wählen Sie den Befehl Rout » Rout Pads Options aus den Hauptmenüs. Konfigurieren Sie die verfügbaren Optionen nach Bedarf.
Automatisches Konturfräsen
Fräsbahnen können manuell definiert werden, Sie sollten jedoch nach Möglichkeit die automatischen Werkzeuge verwenden. Das Verbinden der Leiterplattenkontursegmente zu einer einzelnen, geschlossenen Polylinie ist wesentlich weniger aufwendig als das präzise manuelle Platzieren einer Fräsbahn, insbesondere wenn Ihre Leiterplattenkontur Kreisbögen enthält.
Stellen Sie zunächst sicher, dass die Leiterplattenkontur eine einzelne, geschlossene Begrenzung bildet. Möglicherweise müssen Sie dazu den Befehl „Verbinden“ verwenden.
Verwenden Sie den Befehl Auto-Rout PCB Border aus dem Menü Rout, um anhand der Leiterplattenkontur eine Fräsbahn um die gesamte Leiterplatte zu erstellen. Nach dem Aufrufen des Befehls wird der Cursor zu einem kleinen Quadrat, und Sie werden aufgefordert, die Ecke der Kontur auszuwählen, an der die Eintauch- und Ausfahrpunkte der Bahn positioniert werden sollen. Positionieren Sie den Cursor einfach über der Kontur und klicken Sie – ausgewählt wird die Ecke, die der angeklickten Position am nächsten liegt. Falls Sie an dieser Stelle keinen Eckpunkt Ihrer Leiterplattenkontur auswählen können, stellen Sie sicher, dass Ihre Kontur ein geschlossenes Polylinienobjekt ist.
Anschließend werden Sie aufgefordert, die Fräsrichtung auszuwählen. Zur Unterstützung wird ausgehend von der ausgewählten Ecke der Kontur eine Hilfslinie angezeigt. Positionieren Sie den Cursor ungefähr in der Richtung, in die Sie fräsen möchten, und klicken Sie – das Dialogfeld Auto Rout PCB wird geöffnet. Wählen Sie in diesem Dialogfeld das Werkzeug aus, mit dem Sie die Kontur fräsen möchten, und legen Sie außerdem die Verlängerungen für die Eintauch- und Ausfahrpunkte fest.
Nachdem Sie die Fräsoptionen wie gewünscht festgelegt haben, klicken Sie auf OK. Die Fräsbahn wird erstellt und der Fräslage hinzugefügt.
Das Dialogfeld Auto Rout PCB
Der Eckpunkt, den Sie als Anfang Ihrer Fräsbahn auswählen, sollte sich in der unteren linken Ecke Ihres Designs befinden. Andernfalls könnten die Verlängerungslinien, sofern Sie diese verwenden, in Ihre Leiterplatte schneiden. Sie können den Anweisungen in der Statusleiste folgen und auf eine zweite Position auf Ihrer Kontur klicken, um die Richtung der Fräsbahn festzulegen. Wenn Sie zum Abschließen mit der rechten Maustaste klicken, wird das Dialogfeld Auto Rout PCB geöffnet. Dort können Sie das Bohrwerkzeug und die Verlängerungswerte für die Eintauch- und Ausfahrpunkte auswählen.
Wenn für das ausgewählte Werkzeug in der Werkzeugtabelle kein Wert für die Fräserradiuskorrektur definiert ist, kann dieser automatisch für Sie erzeugt werden. Eine neue Lage (*.rte) wird erstellt, die die Fräsbahn für Ihre Leiterplattenkontur enthält.
Sie können anschließend Haltestege entlang der Fräsbahn hinzufügen. Dabei wird das Werkzeug aus dem Nutzen herausgefahren und entlang der Bahn um eine festgelegte Strecke weiterbewegt, bevor es erneut eintaucht. Das Platzieren von Haltestegen ist mit unterbrochenen Ritzsegmenten vergleichbar: Die Leiterplatten bleiben an bestimmten Stellen vollständig mit dem Nutzen verbunden und können später herausgebrochen werden.
Werkzeuge zum manuellen Fräsen
Kreise können als im oder gegen den Uhrzeigersinn verlaufende Objekte erstellt werden, deren Radius Sie festlegen können. Der Eintauchpunkt liegt im Kreismittelpunkt, und das Werkzeug wird zurückgezogen, sobald der Kreis vollständig ausgefräst ist. Bei Schlitzen ist der Ablauf weniger automatisiert: Wenn der Schlitz vollständig ausgefräst werden soll, müssen Sie darauf achten, am Eintauchpunkt zu beginnen und dorthin zurückzukehren, bevor Sie mit einem Rechtsklick den Rückzugspunkt setzen. Textfräsungen funktionieren wie Schlitzfräsungen mit vordefinierten Pfaden für jeden Buchstaben (einschließlich Eintauch- und Rückzugspunkten). Sie geben lediglich den Text und die gewünschte Buchstabenhöhe an.
Fräsanweisungen sind natürlich nicht zwangsläufig erst nach der Nutzenerstellung relevant. Alle innerhalb einer Leiterplatte definierten Fräsobjekte, beispielsweise interne Schlitze, die Sie in die Nutzenerstellung einbeziehen, werden zusammen mit allen anderen Nutzendaten übernommen.
Um Fräspfade manuell im aktuellen Dokument zu platzieren, wählen Sie den Befehl Rout » Manual Rout aus den Hauptmenüs. Der Befehl basiert auf der Platzierung von Polylinien. Polylinien sind hilfreich, wenn Sie eine Linie schließen oder Kreisbögen als Teil der Linie einfügen müssen. Beides ist mit Standardlinien nicht möglich.
Nach dem Aufrufen des Befehls erscheint der Dialog Select Mill/Drill Tool. Wählen Sie aus der Liste der verfügbaren Werkzeuge das Werkzeug aus, das Sie zum Fräsen verwenden möchten. Nachdem Sie auf OK geklickt haben, gelangen Sie in den Polylinien-Platzierungsmodus. Am Cursor erscheint ein gefüllter Kreis, der die ausgewählte Werkzeuggröße darstellt. Die Platzierung erfolgt mit den folgenden Schritten:
- Positionieren Sie den Cursor an der gewünschten Stelle im Arbeitsbereich und klicken Sie, um den Anfang der Polylinie zu verankern.
- Bewegen Sie den Cursor und klicken Sie erneut, um den nächsten Scheitelpunkt der Polylinie zu platzieren.
- Platzieren Sie weitere Scheitelpunkte durch jeweils einen Klick, bis die Polylinie die gewünschte Form hat.
-
Klicken Sie mit der rechten Maustaste, um ein Kontextmenü mit verschiedenen Befehlen zu öffnen, die im Polylinien-Platzierungsmodus angewendet werden können. Folgende Befehle stehen im Menü zur Verfügung:
- End – beendet die Platzierung dieser Polylinie, ohne sie zu schließen.
- Close – schließt die Linie, indem eine Linie vom zuletzt platzierten Punkt zum Startpunkt gezeichnet wird, und beendet die Platzierung dieser Polylinie.
- Change to Line – wechselt in den Platzierungsmodus für gerade Linien.
- Change to Arc – wechselt in den Platzierungsmodus für Kreisbögen.
- Draw Arc Clockwise – zeichnet einen Kreisbogen vom vorherigen Scheitelpunkt aus im Uhrzeigersinn.
- Draw Arc C-Clockwise – zeichnet einen Kreisbogen vom vorherigen Scheitelpunkt aus gegen den Uhrzeigersinn.
- Undo Polyline Changes – löscht die aktuelle Polylinie, verbleibt aber im Polylinien-Platzierungsmodus.
- Snap Change – aktiviert/deaktiviert den Fangmodus während der Polylinienplatzierung.
- Cancel Action – löscht die aktuelle Polylinie und beendet den Polylinien-Platzierungsmodus.
-
Wenn Sie die Polylinie beenden oder schließen oder Änderungen rückgängig machen, bleiben Sie im Platzierungsmodus. Platzieren Sie weitere Polylinienobjekte oder drücken Sie Esc , um den Polylinien-Platzierungsmodus zu verlassen. Alternativ können Sie mit der rechten Maustaste klicken und Cancel Action aus dem Kontextmenü wählen.
Haltesteg zum ausgewählten Fräspfad hinzufügen
Um einen Haltesteg entlang des ausgewählten Fräspfads im aktuellen Dokument hinzuzufügen, wählen Sie den Befehl Rout » Add Tabs aus den Hauptmenüs. Nach dem Aufrufen des Befehls erscheint der Dialog Enter Value. Geben Sie in diesem Dialog die Größe des Haltestegs in den aktuell ausgewählten Arbeitsbereichseinheiten (Zoll oder mm) ein. Nachdem Sie auf OK geklickt haben, kehren Sie zum Hauptentwurfsfenster zurück. Der Cursor nimmt die Form eines kleinen Quadrats an, und Sie werden aufgefordert, eine Position für den Haltesteg auszuwählen. Positionieren Sie den Cursor einfach an der gewünschten Stelle entlang des Fräspfads, an der Sie den Haltesteg einfügen möchten, und klicken Sie.
Der Haltesteg wird eingefügt. Dadurch wird der Fräspfad in zwei Segmente unterteilt, denen jeweils eigene Eintauch- und Rückzugspunkte zugewiesen werden.
Fügen Sie weitere Haltestege entlang von Fräspfaden hinzu oder klicken Sie mit der rechten Maustaste bzw. drücken Sie Esc, um den Vorgang zu beenden.
Linien in einen Kreisbogen umwandeln
Um Linien eines bestimmten Fräspfads im aktuellen Dokument in einen Kreisbogen umzuwandeln, wählen Sie den Befehl Rout » Convert Lines to Arc aus den Hauptmenüs. Nach dem Aufrufen des Befehls gelangen Sie in den Umwandlungsmodus, der die folgenden Schritte umfasst:
- Wählen Sie den Startpunkt für den Kreisbogen aus. Positionieren Sie den Cursor dazu über einem Scheitelpunkt des Fräspfads und klicken Sie, um diesen Punkt zu verankern.
- Wählen Sie den Endpunkt des Bogens aus. Positionieren Sie den Cursor dazu über einem weiteren Eckpunkt des Fräspfads und klicken Sie, um diesen zweiten Punkt zu verankern. Während Sie den Cursor bewegen, wird eine Hilfslinie angezeigt.
- Wählen Sie einen Zwischenpunkt auf dem Bogen aus. Positionieren Sie den Cursor über einem dritten Eckpunkt des Fräspfads und klicken Sie. Die Linien werden durch einen Bogen ersetzt, dessen Größe durch die Länge der Hilfslinie zwischen Start- und Endpunkt sowie den Abstand des gewählten Zwischenpunkts von dieser Linie bestimmt wird.
- Wandeln Sie weitere Linien anderer Fräspfade in Bögen um, oder klicken Sie mit der rechten Maustaste bzw. drücken Sie Esc, um den Vorgang zu beenden.
Linien in einen Kreis umwandeln
Um im aktuellen Dokument einen geschlossenen Fräspfad in einen Fräskreis umzuwandeln, wählen Sie in den Hauptmenüs den Befehl Rout » Convert Lines to Circle. Nach dem Start des Befehls werden Sie aufgefordert, eine geschlossene Kontur auszuwählen. Positionieren Sie den Cursor einfach über einem Teil der Kontur des Fräspfads, den Sie in einen Kreis umwandeln möchten, und klicken Sie. Der geschlossene Fräspfad wird durch einen Kreis ersetzt. Dessen Mittelpunkt entspricht dem Mittelpunkt eines umschließenden Rechtecks, das die geschlossene Kontur vollständig umgeben würde. Der Radius wird durch den horizontalen Abstand von diesem Mittelpunkt zur Kante des umschließenden Rechtecks bestimmt.
Wandeln Sie weitere geschlossene Fräspfade in Fräskreise um, oder klicken Sie mit der rechten Maustaste bzw. drücken Sie Esc, um den Vorgang zu beenden.
Kontur ausfräsen
Ein weiteres automatisches Werkzeug, „Kontur ausfräsen“, erkennt eine Begrenzung auf ähnliche Weise (auch hier ist ein geschlossener Linienzug erforderlich). Es erzeugt jedoch ein Muster aus hin- und herführenden Fräsbahnen, mit dem die gesamte Fläche abgetragen wird, anstatt sie entlang der Kontur auszuschneiden und aus der Leiterplatte oder dem Nutzen herausfallen zu lassen. Wählen Sie in den Hauptmenüs den Befehl Rout » Mill Boundary, um im aktuellen Dokument Fräsbahnen zum Ausfräsen geschlossener Konturen zu erstellen. Nach dem Start des Befehls nimmt der Cursor die Form eines kleinen Quadrats an, und Sie werden aufgefordert, die geschlossenen Konturobjekte auszuwählen, für die Sie Fräsbahnen erstellen möchten. Positionieren Sie den Cursor nacheinander über den gewünschten geschlossenen Konturen und klicken Sie jeweils darauf. Sobald Sie alle gewünschten geschlossenen Konturen ausgewählt haben, klicken Sie mit der rechten Maustaste.
Das Dialogfeld Milling wird angezeigt. Legen Sie in diesem Dialogfeld fest, auf welcher Lage die Fräsbahnen platziert werden sollen. Sie können die aktuelle Lage, eine neue Lage oder eine der vorhandenen Lagen im Dokument auswählen. Wählen Sie im Feld Select Tool aus, welches der verfügbaren Bohrwerkzeuge Sie zum Fräsen der Bahnen verwenden möchten. Mit der Option Delete Old Objects können Sie die ursprünglichen Konturobjekte zu Vergleichszwecken beibehalten.
Schalten Sie die Ansicht von der gefüllten Darstellung auf die Umrissdarstellung (Shift+F) um, um den tatsächlich ermittelten Verlauf der Fräsbahn zu sehen. Beim Gleichlauffräsen verläuft die Fräsbahn in dieselbe Richtung wie die konkave Seite des Werkzeugzahns; das Fräsen in entgegengesetzter Richtung wird als Gegenlauffräsen bezeichnet.
Das Ausfräsen einer Fläche ist besonders nützlich, wenn Sie Ihrem Fräswerkzeug einen Z-Achsen-Parameter zugewiesen haben, der kleiner als die Nutzendicke ist. So können Sie eine Vertiefung in der Leiterplatte erzeugen, wie sie beispielsweise für die Montage spezieller Bauteile erforderlich sein kann.


