Erstellen einer 3D-PDF-Datei

Auf einen Blick

Teilen Sie mithilfe der PDF3D-Exportfunktion von Altium Designer eine interaktive 3D-Ansicht Ihres Leiterplattendesigns mit Herstellern, Bestückungsdienstleistern und Kunden. Dieser Artikel erklärt, wie Sie eine 3D-PDF-Datei erstellen, deren Designinhalte und Darstellung konfigurieren und die exportierte Leiterplatte in Adobe Acrobat Reader erkunden. Lesen Sie weiter, um eine 3D-PDF-Datei zu erstellen, die genau das zeigt, was Ihre Zielgruppe sehen muss.

- Erfahren Sie, wie Sie auf den PDF3D-Export zugreifen und Geometrie, Farbschemata, Startansichten sowie optionale gespeicherte Keyframe-Ansichten konfigurieren.
- Verstehen Sie, wie sich die enthaltenen Designinhalte auf die Dateigröße und die Darstellungsleistung auswirken.
- Entdecken Sie, wie die 3D-Werkzeugleiste und der Modellbaum von Acrobat Reader die Navigation, das Hervorheben und die Sichtbarkeitssteuerung von Bauteilen und Netzen unterstützen.
Mit KI tiefer einsteigen:

Benutzer von Altium Designer können PCB-Designs schon seit Langem interaktiv in vollständig gerendertem 3D betrachten. Dies bietet einen einzigartigen Einblick in den realen Aufbau des Leiterplattendesigns, seine Bauteile und die zugehörigen mechanischen Teile.

Es bietet erhebliche Vorteile, diese 3D-Funktionalität auch Personen außerhalb des unmittelbaren Designteams zugänglich zu machen, etwa Leiterplattenherstellern und Bestückungsdienstleistern und nicht zuletzt den Kunden. Möglich wird dies durch die 3D-PDF-Exportfunktion von Altium Designer. Dieses interaktive 3D-Format ist für jeden zugänglich, der über eine aktuelle Version des weitverbreiteten Adobe® Acrobat® Reader verfügt.

Betrachten Sie ein exportiertes 3D-Design interaktiv in Adobe Reader – zoomen und drehen Sie es und wählen Sie aus, welche Designelemente Sie sehen möchten.
Betrachten Sie ein exportiertes 3D-Design interaktiv in Adobe Reader – zoomen und drehen Sie es und wählen Sie aus, welche Designelemente Sie sehen möchten.

Anders als eine statische Ansicht eines 3D-Leiterplattendesigns, die eine bestimmte Perspektive zeigt, entspricht das exportierte 3D-PDF-Format im Wesentlichen der interaktiven 3D Layout Mode von Altium Designer. Der resultierende 3D-PDF-Export bietet daher dieselben Funktionen zum Drehen, Zoomen und Verschieben sowie Lesezeichen für jedes Bauteil und jedes Netz. Außerdem kann eines von mehreren vordefinierten Farbschemata verwendet werden.

Um die 3D-PDF-Exportfunktion in Altium Designer nutzen zu können, muss die Softwareerweiterung PDF3D Exporter installiert sein. Diese Erweiterung wird standardmäßig mit Altium Designer installiert. Sie kann manuell installiert oder entfernt werden.

Weitere Informationen zur Verwaltung von Erweiterungen finden Sie auf der Seite Extending Your Installation (Altium Designer Develop, Altium Designer Agile, Altium Designer).

3D in Acrobat Reader

Die interaktive 3D-Anzeige von PDF-Dateien wurde mit der Einführung erweiterter 3D-Anzeigefunktionen in Acrobat Reader ab Version 7 möglich. Diese Funktionen wurden in den nachfolgenden Versionen von Acrobat Reader schrittweise verbessert. Der hohe Detailgrad und die Konfigurationsoptionen des 3D-PDF-Exports von Altium Designer sind mit Version 9 und höher kompatibel.

Die Grundlage dieser neuen 3D-Funktionalität bildet das von der Industrie entwickelte Format Universal 3D (U3D) für Computergrafikdateien, das von der European Computer Manufacturers Association (ECMA) als Standard ECMA-363 – Universal 3D File Format standardisiert wurde. U3D wird vom PDF-Format nativ unterstützt und lässt sich zur interaktiven 3D-Anzeige in Acrobat Reader einfach in eine PDF-Datei einbetten und komprimieren.

Das Ergebnis ist ein plattformübergreifendes 3D-Dateiformat mit überschaubarer Dateigröße, das keine spezielle Software zur 3D-Anzeige erfordert. Bei aus Altium Designer exportierten 3D-PDF-Dateien umfasst der eingebettete Inhalt den Großteil der Daten, die in der eigenen 3D-Ansicht von Altium Designer angezeigt werden können – einschließlich aller Leiterbahnen, Pads, Vias, Polygone usw., aller Bauteile und sämtlicher Leiterplattenlagen.

Erstellen einer PDF-Datei

Um eine 3D-PDF-Datei zu exportieren, öffnen Sie das gewünschte PCB-Designdokument im Arbeitsbereich und wählen Sie in den Hauptmenüs den Befehl File » Export » PDF3D aus. Die 3D-PDF-Datei wird unabhängig vom aktuellen Ansichtsmodus des PCB-Editors (2D oder 3D) im 3D-Format erstellt.

Anders als eine statische Ansicht eines 3D-Leiterplattendesigns aus einer bestimmten Perspektive entspricht der neue 3D-PDF-Export im Wesentlichen der interaktiven 3D-Ansicht von Altium Designer.

Der resultierende 3D-PDF-Export bietet daher dieselben Funktionen zum Drehen, Zoomen und Verschieben und kann jedes der in der aktiven Ansichtskonfiguration definierten Farbschemata verwenden. Um die aktuelle Konfiguration und damit die verfügbaren Darstellungsfarben für die exportierte PDF-Datei zu prüfen oder zu bearbeiten, wechseln Sie zur 3D-Ansicht der Leiterplatte (Tastenkombination: 3) und öffnen Sie das Panel „View Configuration“. Die Darstellungsfarben finden Sie im Bereich 3D Settings auf der Registerkarte View Options des Panels.

Die Registerkarte View Options des Panels View Configuration lässt sich mit der Tastenkombination Ctrl+D schnell aufrufen.

Eine 3D-PDF-Datei wird unabhängig vom aktuellen Ansichtsmodus des PCB-Editors (2D oder 3D) im 3D-Format erstellt.

Exportoptionen

Nachdem der 3D-PDF-Export gestartet (File » Export » PDF3D) und im Windows-Standarddialog Export File ein Dateiname und ein Speicherort angegeben wurden, öffnet sich der Dialog Export 3D. Hier können Sie die Darstellung, das Verhalten und die enthaltenen Designinhalte für die PDF-Datei festlegen.

Im Dialog Export 3D können Sie konfigurieren, wie die exportierte PDF-Datei aussieht und sich verhält.
Im Dialog Export 3D können Sie konfigurieren, wie die exportierte PDF-Datei aussieht und sich verhält.

Konfigurieren Sie im Dialog Export 3D die Exportoptionen nach Bedarf und klicken Sie anschließend auf die Schaltfläche Export, um die 3D-PDF-Datei zu erstellen.

3D-Dateien können trotz der im Format integrierten Datenkomprimierung groß sein. Überlegen Sie daher, welche Designinhalte für den vorgesehenen Benutzer wichtig sind. Beispielsweise sind die Inhalte der Kupferlagen (Leiterbahnen, Pads usw.) für jemanden, der die mechanischen Aspekte eines Leiterplattendesigns betrachtet, möglicherweise nicht erforderlich.

  • Beachten Sie, dass Benutzer in Acrobat Reader die Anzeige von Modellelementen nach Bedarf ein- und ausschalten können – gruppenweise oder einzeln. Weitere Informationen finden Sie unten.

  • In einem PCB-Dokument definierte Schlüsselbilder können in den 3D-PDF-Export integriert werden, indem Sie die Option Use 3D Movie views im Dialog Export 3D aktivieren. Die in das 3D-PDF-Dokument exportierten Schlüsselbilder stehen anschließend in Acrobat Reader als auswählbare Ansichten zur Verfügung.

Bei der Auswahl der einzuschließenden 3D-Inhalte sollten Sie auch die 3D-Rendering-Leistung des PCs berücksichtigen, auf dem die Datei betrachtet wird. Auch wenn die Größe der resultierenden 3D-PDF-Datei angemessen ist, können CPU und Grafiksystem des Zielrechners Schwierigkeiten haben, ein komplexes mehrlagiges Design flüssig darzustellen.

Die oben genannten Optionen legen die anfänglichen Einstellungen beim Öffnen der PDF-Datei in Acrobat Reader fest. Diese lassen sich über die Symbolleiste 3D des Readers einfach nach Wunsch ändern. Beachten Sie, dass der Benutzer die Ansicht nicht ändern kann, wenn die Symbolleiste in den 3D-PDF-Exportoptionen deaktiviert ist.

Eine 3D-PDF-Datei betrachten

Wie zu erwarten, ist das Betrachten einer 3D-PDF-Datei in Acrobat Reader recht unkompliziert. Die Befehle und Menüs sind logische Erweiterungen der vertrauten 2D-Funktionen.

Die 3D-Objekte lassen sich durch einfaches Ziehen mit der Maus und Betätigen des Mausrads verschieben, vergrößern, verkleinern und drehen. Die entsprechenden Funktionen werden über die schwebende Symbolleiste 3D ausgewählt.

Die Symbolleiste 3D von Acrobat bietet Steuerelemente für die 3D-Navigation sowie für Beleuchtungs- und Ansichtseinstellungen.
Die Symbolleiste 3D von Acrobat bietet Steuerelemente für die 3D-Navigation sowie für Beleuchtungs- und Ansichtseinstellungen.

Eine besonders nützliche Funktion des Readers ist der Navigationsbereich Model Tree, der sich über die Schaltfläche öffnen lässt, sofern er nicht bereits geöffnet ist. Hier kann der Benutzer durch alle Objekte in der 3D-PDF-Datei navigieren, relevante Objekte auswählen und hervorheben sowie deren Sichtbarkeit ein- und ausschalten.


Der Navigationsbereich „Modellbaum“ ist besonders nützlich
zum Steuern der Anzeige bestimmter Bauteile und Netze.

Der Navigationsbereich Model Tree bietet eine leistungsfähige Möglichkeit, alle Aspekte eines 3D-Designs bis ins kleinste Detail zu untersuchen. Ob es um eine genaue Betrachtung der Bauteilpositionierung und des Layouts oder eine detaillierte Prüfung des inneren Leiterplattenaufbaus geht: Über den Navigationsbaum lassen sich die entsprechenden Objekte finden und anzeigen.

Das Design mit ausgeblendeten Bauteilen und Leiterplatten-Overlays veranschaulicht die umfangreichen Möglichkeiten zur Steuerung der 3D-Darstellung in Acrobat Reader.
Das Design mit ausgeblendeten Bauteilen und Leiterplatten-Overlays veranschaulicht die umfangreichen Möglichkeiten zur Steuerung der 3D-Darstellung in Acrobat Reader.

Wenn einzelne Objekte im Bereich Model Tree ausgewählt werden, werden sie im Ansichtsfenster mit der oben im Bereich festgelegten Farbe hervorgehoben (in diesem Fall Rot). Dadurch lassen sich bestimmte Bauteile oder Netze leicht lokalisieren, ohne ihre Sichtbarkeit umschalten zu müssen, um ihre Position zu finden. Ebenso wird beim Auswählen eines Objekts im 3D-Ansichtsfenster der zugehörige Eintrag im Bereich Model Tree hervorgehoben.

Weitere Informationen zur Verwendung der verschiedenen Steuerelemente, Funktionen und Einstellungen in Acrobat Reader finden Sie in der entsprechenden Adobe-Hilfe: Anzeigen von 3D-Modellen in PDF-Dateien.

Grundlegende Design-Metadaten aus Altium Designer sind ebenfalls in einem exportierten 3D-PDF-Dokument enthalten. Zu diesen Daten gehören die Quelldatei des Designs, der Autor, die Altium Designer-Version, das Erstellungs- und Änderungsdatum usw. Die Informationen können in Adobe Reader auf der Registerkarte Description im Dialog Document Properties angezeigt werden – File » Properties.

3D-PDF-Export über einen OutJob

Um einen 3D-PDF-Dateiexport in einen Projekt-OutJob aufzunehmen, klicken Sie unter dem Eintrag Documentation Outputs auf Add New Documentation Output, wählen Sie PDF3D und anschließend die gewünschte Dokumentquelle aus – entweder ein bestimmtes zu exportierendes PCB-Dokument oder [PCB Document], damit der OutJob allgemein wiederverwendbar bleibt.

Hinzufügen eines PDF3D-Ausgabegenerators zu einer Ausgabekonfigurationsdatei.Hinzufügen eines PDF3D-Ausgabegenerators zu einer Ausgabekonfigurationsdatei.

Die Einstellungen für die 3D-PDF-Erstellung lassen sich vorkonfigurieren, indem Sie den Eintrag des Ausgabegenerators auswählen, mit der rechten Maustaste darauf klicken und anschließend Configure im Kontextmenü wählen. Dadurch wird der Konfigurationsdialog Export 3D geöffnet (wie zuvor beschrieben).

Wenn der Ausgabeauftrag ausgeführt oder manuell gestartet wird, wird die 3D-PDF-Datei gemäß den Einstellungen im Abschnitt Output Containers des OutJobs exportiert. Der Export erfolgt in den konfigurierten Workspace und Pfad oder an das lokale bzw. entfernte Veröffentlichungsziel, das auf der Seite Datenverwaltung – Veröffentlichungsziele des Dialogs Preferences definiert ist.

Erstellen einer 3D-PDF-Datei in einem festgelegten PDF-Ausgabecontainer aus einem konfigurierten OutJob heraus.
Erstellen einer 3D-PDF-Datei in einem festgelegten PDF-Ausgabecontainer aus einem konfigurierten OutJob heraus.

AI-LocalizedKI-lokalisiert
Wenn Sie ein Problem feststellen, wählen Sie den Text/das Bild aus und drücken SieCtrl + Enter, um uns Ihr Feedback zu senden.
Contents
Funktionsverfügbarkeit

Die Ihnen zur Verfügung stehenden Funktionen hängen davon ab, über welche Altium-Lösung Sie verfügen – Altium Develop, Altium Agile Teams, Altium Agile Enterprise oder Altium Designer (mit aktivem Laufzeitvertrag).

Wenn Sie eine dokumentierte Funktion in Ihrer tatsächlich verwendeten Software nicht sehen, wenden Sie sich an den Altium-Vertrieb, um mehr zu erfahren.

Legacy-Dokumentation

Die Dokumentation von Altium Designer wird nicht mehr versioniert. Wenn Sie auf Dokumentation für ältere Versionen von Altium Designer zugreifen müssen, besuchen Sie den Abschnitt Legacy-Dokumentation auf der Seite Andere Installer.

Contents