Berichte vorbereiten

Auf einen Blick

Altium Designer bietet Berichtsausgaben zur Dokumentation von Bauteilen, zur Nachverfolgung von Projektänderungen und zur Vorbereitung von Fertigungsdaten. Dieser Artikel stellt die verfügbaren Berichtstypen vor, erläutert, wie Sie Berichte mit dem Report Manager konfigurieren und exportieren, und zeigt, wo Sie Ausgaben erzeugen und speichern können. Lesen Sie weiter, um die benötigten Berichte auszuwählen und deren Ausgabe für Ihr Projekt zu organisieren.

- Entdecken Sie verschiedene Berichtstypen, darunter Stücklisten, Stücklistenvergleiche, Fertigungsdaten für Kabelbäume, Bauteilquerverweise, Kommentare und den Projektverlauf.
- Erfahren Sie, wie Sie unterstützte Berichte konfigurieren, in der Vorschau anzeigen, drucken und in verschiedene Dateiformate exportieren.
- Erfahren Sie, wie Sie Berichte zu Output-Job-Dateien hinzufügen oder direkt erzeugen und Ausgabeordner verwalten, um ein Überschreiben von Berichten zu vermeiden.
Mit KI tiefer einsteigen:

Für Ihr Design können verschiedene Berichte zum Projekt oder zu einem bestimmten Projektdokument vorbereitet und erstellt werden, darunter:

  • Stückliste – dieses Berichtsdokument bietet eine übersichtliche Auflistung aller Komponenten, die zur Fertigung des Produkts erforderlich sind – einschließlich der unbestückten Leiterplatte, die gewissermaßen die grundlegende „Komponente“ darstellt, auf der alle anderen Bauteile montiert werden. Die Stückliste dient als Leitfaden dafür, was beschafft werden muss, um das Produkt gemäß dem Design zu fertigen. Außerdem ermöglicht sie die Kostenberechnung anhand der benötigten Anzahl bestückter Leiterplatten für einen angeforderten Fertigungslauf.

    Die im Dialog Report Manager angezeigten Daten, mit dem der Stücklistenbericht konfiguriert wird, können aus einer von zwei Quellen stammen. Wenn dem Designprojekt ein ActiveBOM-Dokument (*.BomDoc) zugeordnet ist, wird dieses als Datenquelle verwendet. Andernfalls werden die Daten aus den Quellschaltplandokumenten des Projekts extrahiert.

  • Stücklistenvergleich – ein Bericht mit Informationen darüber, welche Komponenten bei der Freigabe eines Workspace-Projekts geändert wurden (beispielsweise hinzugefügt, entfernt oder ersetzt).

  • Manufacturing Data – eine einzelne Excel-Arbeitsmappe mit Daten für Kabelbaumhersteller. Die erstellte Arbeitsmappe enthält vier separate Tabellenblätter:

    • Bill of Materials – nützlich für die schnelle Angebotserstellung.

    • Wiring List – zur Verwendung mit Kabelverarbeitungsmaschinen.

    • Labels – eine Übersicht der physischen Etiketten, die für Kabelbaumbündel gedruckt werden sollen, zur Verwendung mit Zebra- oder anderen Druckern.

    • Coverings – eine Übersicht der Ummantelungen, die um Kabelbaumbündel angebracht werden sollen.

     

    Es wird empfohlen, das ActiveBOM-Dokument des Kabelbaum-Designprojekts als Quelle für die Fertigungsdatenausgabe zu verwenden.

    Weitere Informationen zum Kabelbaumdesign finden Sie auf der Seite Kabelbaumdesign.

  • Komponenten-Querverweisbericht – erstellt eine Liste der Komponenten, gegliedert nach dem Schaltplanblatt, auf dem sie sich im Design befinden.

    Die Stücklisten- und Komponenten-Querverweisberichte lassen sich mithilfe einer dedizierten, leistungsstarken Berichts-Engine umfassend konfigurieren. Die Benutzeroberfläche dafür bildet der Dialog Report Manager. Sobald der Inhalt des gewünschten Berichts definiert und wie gewünscht angeordnet ist, kann der Bericht erstellt werden – entweder als Ausdruck oder durch Export in eines der folgenden Dateiformate: CSV (kommagetrennt) (*.csv), Microsoft Excel-Arbeitsblatt (*.xls;*.xlsx;*.xlt;*.xltx), Portable Document Format (*.pdf), tabulatorgetrennter Text (*.txt), Webseite (*.htm;*.html), XML-Kalkulationstabelle (*.xml). Eine exportierte Datei kann an einem beliebigen angegebenen Speicherort gespeichert werden. Darüber hinaus kann sie nach ihrer Erstellung in der entsprechenden Softwareanwendung geöffnet und/oder dem Projekt hinzugefügt werden. Verwenden Sie den Befehl Report in den Menüs des Dialogs Report Manager, um den Dialog Report Preview mit dem bereits geladenen Bericht zu öffnen. Mit den verschiedenen Bedienelementen im Fenster können Sie die Berichtsansicht anpassen. Klicken Sie auf die Schaltfläche Print , um den Dialog Print zu öffnen. Dort legen Sie fest, was gedruckt wird und an welches Druckgerät der Auftrag gesendet wird. Die Berichtsvorschau kann auch in verschiedene Dateiformate exportiert werden.

  • Kommentare exportieren – erstellt eine PDF-Datei mit exportierten Kommentaren zu Projektdokumenten.

  • Projektverlauf – erstellt eine PDF-Datei mit dem exportierten Projektverlauf. Konfigurieren Sie die Ausgabe im Dialog Project History Report Configuration. Dort können Sie den Period festlegen, für den der Bericht exportiert werden soll: entweder den gesamten Projektverlauf oder den Zeitraum ab/bis zu einer bestimmten (oder der neuesten) Projektfreigabe.

  • Projekthierarchie ausgeben – erstellt eine Liste der im Projekt verwendeten Quelldokumente. Für diese Ausgabe gibt es keine Konfigurationsoptionen; der ASCII-Bericht wird in den angegebenen Ausgabeordner geschrieben.

  • Netze mit nur einem Pin ausgeben – erstellt einen Bericht mit allen Netzen, die nur einen Anschluss haben. Für diese Ausgabe gibt es keine Konfigurationsoptionen; der ASCII-Bericht wird in den angegebenen Ausgabeordner geschrieben. Ein Bericht, der alle Quellschaltplandokumente des Designs entsprechend ihrer Hierarchie innerhalb des Projekts auflistet. Die Datei wird direkt im Format <ActiveDocumentName>.REP erstellt.

Berichtsausgaben können der aktiven OutputJob-Datei über das Menü des Bedienelements [Add New Report Output] im Bereich Report Outputs der Datei oder über die Untermenüs Edit » Add Report Outputs der Hauptmenüs hinzugefügt werden.

Während OutputJob-Dateien die effiziente Vorbereitung von Ausgaben für Ihre Designs und deren anschließende Erstellung mithilfe des zuverlässigen Projektfreigabeprozesses ermöglichen, können Berichtsausgaben für das aktive Design auch direkt erstellt werden. Verwenden Sie dazu den Befehl im Hauptmenü Reports  des Schaltplaneditors oder im Untermenü Reports » Project Reports des PCB-Editors.
  • Da der Dialog Report Manager so umfassend konfigurierbar ist, kann er auch zum Erstellen von Berichten in jedem benötigten Format verwendet werden, beispielsweise einer Bestückungsdatei, deren Daten für einen bestimmten Bestückungsautomaten auf eine spezielle Weise strukturiert sein müssen.
  • Alle Ausgabedateien werden in den Ausgabeordner geschrieben, der im Feld Output Path auf der Registerkarte Options des Dialogs Options for Project angegeben ist. Standardmäßig ist der Ausgabepfad auf einen Unterordner des Ordners festgelegt, der die Projektdatei enthält und den Namen Project Outputs for <ProjectName> trägt. Der Ausgabepfad kann bei Bedarf geändert werden. Im Panel Projects werden die erstellten Dateien unter den Unterordnern Generated\Text Documents (.csv, .txt, .rep) oder Generated\Documents (.xls, .pdf, .htm, .xml) angezeigt. Beachten Sie, dass beim Erstellen eines anderen Berichtsformats aus demselben aktiven Dokument die zuvor erstellte Berichtsdatei überschrieben wird, sofern sie denselben Dateinamen hat.
  • Wenn die Option Use separate folder for each output type aktiviert ist (ebenfalls auf der Registerkarte Options ), wird die Ausgabe in einen weiteren Unterordner mit dem Namen Reports geschrieben (z. B. Project Outputs for <ProjectName>\Reports). Im Panel Projects wird die Ausgabe unter den Unterordnern Generated (Reports)\Text Documents (.csv, .txt, .rep) oder Generated (Reports)\Documents (.xls, .pdf, .htm, .xml) angezeigt. So können Sie mehrere Berichte aus demselben aktiven Dokument erstellen, ohne dass Dateien überschrieben werden.
AI-LocalizedKI-lokalisiert
Wenn Sie ein Problem feststellen, wählen Sie den Text/das Bild aus und drücken SieCtrl + Enter, um uns Ihr Feedback zu senden.
Contents
Funktionsverfügbarkeit

Die Ihnen zur Verfügung stehenden Funktionen hängen davon ab, über welche Altium-Lösung Sie verfügen – Altium Develop, Altium Agile Teams, Altium Agile Enterprise oder Altium Designer (mit aktivem Laufzeitvertrag).

Wenn Sie eine dokumentierte Funktion in Ihrer tatsächlich verwendeten Software nicht sehen, wenden Sie sich an den Altium-Vertrieb, um mehr zu erfahren.

Legacy-Dokumentation

Die Dokumentation von Altium Designer wird nicht mehr versioniert. Wenn Sie auf Dokumentation für ältere Versionen von Altium Designer zugreifen müssen, besuchen Sie den Abschnitt Legacy-Dokumentation auf der Seite Andere Installer.