Schaltplanplatzierungs- und Bearbeitungstechniken
Auf einen Blick
- Lernen Sie den standardmäßigen Arbeitsablauf zum Platzieren von Schaltplanobjekten kennen: wo Sie die Befehle finden, wie der Platzierungsmodus funktioniert und wie Sie die Platzierung beenden oder wiederholen.
- Erfahren Sie, wie Sie Objekte vor, während und nach der Platzierung mithilfe des Properties-Panels, von Dialogen und grafischen Bearbeitungsgriffen bearbeiten können.
- Erfahren Sie, wie sich das Verschieben und Ziehen, Fangraster und Tastenkürzel auf die Neupositionierung von Objekten auswirken und wie Sie dabei Verbindungen je nach Bedarf beibehalten oder ignorieren können.
Elektronikdesign ist der Prozess, bei dem ein logischer Entwurf im Schaltplan erfasst und anschließend als eine Reihe von Objekten im PCB-Designbereich dargestellt wird. Selbst bei einer kleinen Schaltung kann der Schaltplan viele Bauteile enthalten, die jeweils zahlreiche Modelle und Parameter besitzen. Auch der PCB-Designbereich kann eine große Anzahl von Designobjekten enthalten, aus denen die Leiterplatte besteht. Im Laufe des Designprozesses müssen die Platzierung und die Eigenschaften dieser Objekte angepasst werden, um die verschiedenen Designanforderungen miteinander in Einklang zu bringen.
Gemeinsamkeiten bei der Platzierung und Bearbeitung von Objekten
In Altium Designer ist der Ablauf beim Platzieren eines Objekts weitgehend gleich, unabhängig davon, welches Objekt platziert wird. In seiner einfachsten Form umfasst der Ablauf folgende Schritte:
-
Wählen Sie das zu platzierende Objekt aus, indem Sie:
- Den Befehl in den Place-Hauptmenüs auswählen.
- Den Befehl in der Aktivleiste auswählen.
- Mit der rechten Maustaste in den Designbereich klicken und anschließend den Befehl im Untermenü Place des Kontextmenüs auswählen.
- Legen Sie mit der Maus die Position des platzierten Objekts im Designbereich des Schaltplaneditors und gegebenenfalls seine Größe fest.
- Klicken Sie mit der rechten Maustaste (oder drücken Sie Esc), um den Befehl zu beenden und den Platzierungsmodus zu verlassen.
Platzieren von Designobjekten
Die grundlegenden Schritte zum Platzieren von Schaltplan-Designobjekten werden im Folgenden beschrieben.
- Wählen Sie den gewünschten Objekttyp im Menü „Platzieren“ aus (z. B. Place » Wire) oder klicken Sie auf eines der Symbole in der Active -Symbolleiste. Für die Platzierung stehen auch Tastenkombinationen zur Verfügung (z. B. P, W zum Platzieren einer Leitung). Zum Platzieren von Bauteilen können Sie auch auf die Schaltfläche Place im Panel Components klicken oder den Bauteilnamen aus einer verfügbaren Bibliothek im Panel Components auswählen und in das Dokument ziehen.
- Wenn ein Objekt zur Platzierung ausgewählt wird, ändert sich der Cursor in ein Fadenkreuz. Dies zeigt an, dass Sie sich im Bearbeitungsmodus befinden. Gegebenenfalls erscheint das Objekt „schwebend“ unter dem Cursor.
-
Drücken Sie die Taste Tab , um die Eigenschaften des Objekts vor dem Platzieren zu bearbeiten. Dadurch wird das Panel Properties für dieses Objekt geöffnet, in dem Sie verschiedene Optionen ändern können. Nachdem Sie die Eigenschaften festgelegt haben, klicken Sie auf
, um zum Platzierungsmodus zurückzukehren. Der Vorteil der Bearbeitung während der Platzierung besteht darin, dass numerische Kennungen von Objekten, beispielsweise Bauteilkennzeichnungen, automatisch hochgezählt werden.
-
Positionieren Sie den Cursor und klicken Sie mit der linken Maustaste oder drücken Sie Enter, um das Objekt zu platzieren. Bei komplexen Objekten wie Leitungen oder Polygonen müssen Sie den Vorgang aus Positionieren und Klicken fortsetzen, um alle Eckpunkte des Objekts zu platzieren.
- Nach dem Platzieren eines Objekts bleiben Sie im Platzierungsmodus (erkennbar am Fadenkreuz-Cursor), sodass Sie sofort ein weiteres Objekt desselben Typs platzieren können. Um den Platzierungsmodus zu beenden, klicken Sie mit der rechten Maustaste oder drücken Sie die Taste Esc . In manchen Fällen, etwa beim Platzieren eines Polygons, müssen Sie dies zweimal tun: einmal, um die Platzierung des Objekts abzuschließen, und einmal, um den Platzierungsmodus zu verlassen. Wenn Sie den Platzierungsmodus verlassen, nimmt der Cursor wieder seine Standardform an.
Bearbeitung vor der Platzierung
Die Standardeigenschaften eines Objekts (sofern sie sich sinnvoll vordefinieren lassen) können jederzeit auf der Seite Schaltplan – Standardwerte des Dialogs Preferences geändert werden. Diese Eigenschaften werden beim Platzieren nachfolgender Objekte angewendet.

Verwenden Sie die Spalte Primitive List, um auf die Eigenschaften der Objekte zuzugreifen und die Standardwerte nach Bedarf zu bearbeiten.
Bearbeitung während der Platzierung
Beim erstmaligen Platzieren eines Objekts können verschiedene Attribute bearbeitet werden. Um auf diese Attribute zuzugreifen, drücken Sie im Platzierungsmodus die Taste Tab , um das zugehörige Panel Properties zu öffnen. Durch Drücken der Taste Tab wird die Platzierung unterbrochen, damit Sie die erforderlichen Änderungen am Objekt vornehmen können.
Beispiel eines Panels Properties für ein Net Label-Objekt.
Klicken Sie nach der Bearbeitung auf die im Designbereich eingeblendete Pause-Schaltfläche , um die Platzierung fortzusetzen.
Bearbeitung nach der Platzierung
Nachdem ein Objekt platziert wurde, kann es auf verschiedene Weise bearbeitet werden. Diese Möglichkeiten werden im Folgenden beschrieben.
Das zugehörige Eigenschaften-Panel oder der zugehörige Dialog
Bei dieser Bearbeitungsmethode werden der zugehörige Modus des Panels Properties und der zugehörige Dialog verwendet, um die Eigenschaften eines platzierten Objekts zu ändern.
Nach der Platzierung lässt sich der zugehörige Dialog wie folgt öffnen:
- Doppelklicken Sie auf das platzierte Objekt.
- Den Cursor über dem Objekt platzieren, mit der rechten Maustaste klicken und anschließend Properties aus dem Kontextmenü wählen.
Nach der Platzierung kann der zugehörige Modus des Panels Properties auf eine der folgenden Arten aufgerufen werden:
- Wenn das Panel Properties bereits aktiv ist, das Objekt auswählen.
- Nach der Auswahl des Objekts das Panel Properties über die Schaltfläche Panels unten rechts im Designbereich auswählen oder View » Panels » Properties aus den Hauptmenüs wählen.
Grafische Bearbeitung
Mit dieser Bearbeitungsmethode können Sie ein platziertes Objekt direkt im Designbereich auswählen und seine Größe, Form oder Position grafisch ändern. Form und/oder Größe werden (sofern zutreffend) mithilfe von Bearbeitungsgriffen geändert, die erscheinen, sobald das Objekt ausgewählt wird.

Beispiel für Bearbeitungsgriffe an einem ausgewählten Schaltplansymbol.
Wenn ein Objekt ausgewählt ist, können Sie es verschieben oder seine grafischen Eigenschaften bearbeiten. Klicken Sie auf ein Objekt, um es auszuwählen; seine Bearbeitungsgriffe oder Eckpunkte werden angezeigt. Das ausgewählte Objekt wird in der Auswahlfarbe hervorgehoben, die im Selections Feld des Bereichs Color Options auf der Seite „Schematic - Graphical Editing“ des Preferences Dialogs festgelegt ist. Um ein ausgewähltes Objekt grafisch zu ändern, klicken Sie auf einen Bearbeitungsgriff und halten Sie die Maustaste gedrückt. Dieser Punkt des Objekts wird daraufhin an den Cursor angeheftet. Bewegen Sie die Maus an eine neue Position und lassen Sie die Maustaste los, um die Größe zu ändern. Klicken Sie auf eine beliebige Stelle eines ausgewählten Objekts, um es zu verschieben, oder drücken Sie die Taste Delete , um es zu löschen.
Ein Objekt neu positionieren
Klicken Sie auf ein Objekt (oder eines der Objekte einer Auswahl) und halten Sie die Maustaste gedrückt, um es neu zu positionieren. Dabei kann der Cursor an einer anderen Stelle des Objekts einrasten als an der Stelle, auf die Sie geklickt haben. Dies ist beabsichtigt und wird durch die folgenden Optionen gesteuert, die auf der Seite „Schematic - Graphical Editing“ des Dialogs Preferences konfiguriert werden. Beachten Sie, dass sich elektrische Objekte wie Netzbezeichnungen, Schaltplansymbole und Bauteile anders verhalten als nicht elektrische Objekte wie Rechtecke oder Linien, wenn die Option Always Drag aktiviert ist.
-
Center of Object – Wenn diese Option aktiviert ist, wird der Cursor bei einem grafischen Objekt in dessen geometrische Mitte bewegt und dort festgehalten. Bei einem elektrischen Objekt wird er an der angeklickten Stelle festgehalten, sofern die Option Always Drag aktiviert ist. Ist Always Drag deaktiviert, wird er in der geometrischen Mitte festgehalten. Bei Textzeichenfolgen wird er am Bezugspunkt der Zeichenfolge festgehalten (der durch die aktuelle Einstellung der Eigenschaft „Justification“ der Zeichenfolge bestimmt wird).
-
Object's Electrical Hot Spot – Wenn diese Option aktiviert ist und es sich um ein elektrisches Objekt handelt, wird der Cursor an einem Hotspot festgehalten (der Hotspot ist der Punkt, an dem die elektrische Verbindung hergestellt wird). Bei elektrischen Objekten hat diese Option Vorrang vor der Option Center of Object.
-
Always Drag – Der Begriff „Ziehen“ bezeichnet movement while maintaining connectivity. Wenn diese Option aktiviert ist, weisen Sie die Software durch Klicken und Ziehen an einem elektrischen Objekt an, die bestehende Konnektivität möglichst beizubehalten und die Verdrahtung beim Ziehen entsprechend sauber anzupassen. Halten Sie Ctrl gedrückt, um vorübergehend vom Ziehen zum Verschieben zu wechseln.
Verschiebebefehle
Die Position von Objekten kann mit den Befehlen im Untermenü Edit » Move der Hauptmenüs oder im Verschiebe-Untermenü in Active Bar geändert werden.
- Drag – Ziehen eines einzelnen Objekts im aktuellen Dokument unter Beibehaltung der elektrischen Verbindungen zu anderen elektrischen Objekten (sofern ein elektrisches Objekt ausgewählt wurde).
- Move – Verschieben eines einzelnen Objekts im aktuellen Dokument. Die elektrischen Verbindungen bleiben bei Verwendung dieser Funktion nicht erhalten.
- Move Selection – Neupositionieren ausgewählter Objekte im aktuellen Dokument. Die elektrischen Verbindungen bleiben bei Verwendung dieser Funktion nicht erhalten.
-
Move Selection by X, Y – Versetzen der aktuellen Objektauswahl um einen präzisen Betrag in X- und/oder Y-Richtung. Nach dem Aufrufen des Befehls wird das Dialogfeld Move Selection by X, Y angezeigt. Geben Sie in diesem Dialogfeld die Werte für Delta X und/oder Delta Y an, um die die Auswahl verschoben werden soll. Nach dem Klicken auf OK wird die Auswahl entsprechend verschoben.

Das Dialogfeld Move Selection by X, Y - Drag Selection – Ziehen ausgewählter elektrischer Objekte im aktuellen Dokument unter Beibehaltung der elektrischen Verbindungen zu anderen elektrischen Objekten. Um den Befehl auf eine Auswahl nicht elektrischer Objekte anzuwenden, halten Sie beim Starten der Bewegung die Ctrl-Taste gedrückt. Dadurch wird die Option Always Drag vorübergehend deaktiviert, sodass der Befehl Drag Selection wie der Befehl Move Selection wirkt. Beachten Sie, dass die Ctrl-Taste auch das Einrasten am Raster unterdrückt. Lassen Sie die Ctrl-Taste nach Beginn der Bewegung los, um das Einrasten am Raster wieder zu aktivieren.
-
Move To Front – Mit diesem Befehl wird ein Objekt neu positioniert und in der Zeichenreihenfolge des aktuellen Dokuments vor allen anderen Objekten platziert.
- Rotate Selection – Mit diesem Befehl werden ein oder mehrere ausgewählte Objekte gegen den Uhrzeigersinn gedreht.
- Rotate Selection Clockwise – Mit diesem Befehl werden ein oder mehrere ausgewählte Objekte im Uhrzeigersinn gedreht.
Ausrichtungsbefehle
Objekte können auch durch Ändern ihrer Ausrichtung verschoben werden. Um Objekte an anderen Objekten auszurichten, wählen Sie alle Objekte aus, die in die Ausrichtung einbezogen werden sollen, klicken Sie mit der rechten Maustaste auf ein ausgewähltes Objekt und wählen Sie dann Align. Alternativ können Sie das Untermenü Edit » Align der Hauptmenüs oder das Ausrichtungs-Untermenü in Active Bar verwenden. Das Ausrichtungs-Untermenü enthält mehrere Optionen zum Verteilen ausgewählter Objekte.
Mit dem Befehl Align öffnen Sie das Dialogfeld Align Objects, das Steuerelemente zum schnellen, bedarfsgerechten Ausrichten der aktuell ausgewählten Designobjekte bietet. Legen Sie im Dialogfeld die gewünschten Optionen für die vertikale und/oder horizontale Ausrichtung der ausgewählten Objekte fest und klicken Sie dann auf OK , um die Ausrichtung anzuwenden.

Das Dialogfeld Align Objects
Optionen und Steuerelemente des Dialogfelds „Objekte ausrichten“
-
Horizontal Alignment – Wählen Sie eine der folgenden Optionen, um die horizontale Ausrichtung der ausgewählten Objekte festzulegen:
- No Change – Die horizontale Ausrichtung der Objekte unverändert lassen.
- Left – Objekte an der linken Kante des am weitesten links liegenden Objekts ausrichten.
- Center – Objekte an einer Achse mittig zwischen dem am weitesten links und dem am weitesten rechts liegenden Objekt der Auswahl ausrichten.
- Right – Objekte an der rechten Kante des am weitesten rechts liegenden Objekts ausrichten.
- Distribute equally – Die ausgewählten Objekte horizontal gleichmäßig verteilen, wobei das am weitesten links bzw. rechts liegende Objekt die linke bzw. rechte Begrenzung bildet.
-
Vertical Alignment – Wählen Sie eine der folgenden Optionen, um die vertikale Ausrichtung der ausgewählten Objekte festzulegen:
- No Change – Die vertikale Ausrichtung der ausgewählten Objekte unverändert lassen.
- Top – Objekte an der oberen Kante des obersten Objekts ausrichten.
- Center – Objekte an einer Achse mittig zwischen dem obersten und dem untersten Objekt der Auswahl ausrichten.
- Bottom – Objekte an der unteren Kante des untersten Objekts ausrichten.
- Distribute equally – Die ausgewählten Objekte vertikal gleichmäßig verteilen, wobei das oberste bzw. unterste Objekt die obere bzw. untere Begrenzung bildet.
- Move primitives to grid – Aktivieren Sie diese Option, um die Ausrichtung so einzuschränken, dass nach Abschluss der Ausrichtung alle Grundelemente der Auswahl auf einem gültigen Rasterpunkt liegen.
Mit dem Befehl Align Left / Align Right / Align Top / Align Bottom können Sie ausgewählte Designobjekte an ihren linken/rechten/oberen/unteren Kanten ausrichten. Nach dem Aufrufen des Befehls wird die linke/rechte/obere/untere Kante des am weitesten links/rechts/oben/unten liegenden Objekts als Referenz verwendet. Alle anderen Objekte der Auswahl werden nach links/rechts/oben/unten verschoben, sodass ihre linken Kanten an dieser Referenz ausgerichtet sind.
Der Befehl Align Horizontal Centers / Align Vertical Centers Mit diesem Befehl können Sie ausgewählte Objekte in einer einzelnen Spalte/Zeile anordnen und an ihren horizontalen/vertikalen Mittelpunkten ausrichten. Nach dem Aufrufen des Befehls werden die ausgewählten Objekte horizontal/vertikal verschoben, sodass sie eine einzelne Spalte/Zeile bilden und an ihren horizontalen/vertikalen Mittelpunkten ausgerichtet sind. Die vertikale Mittellinie der Spalte liegt mittig zwischen dem am weitesten links und dem am weitesten rechts liegenden Objekt der Auswahl; die horizontale Mittellinie der Zeile liegt mittig zwischen dem obersten und dem untersten Objekt der Auswahl.
Mit dem Befehl Distribute Horizontally / Distribute Vertically können Sie die horizontalen/vertikalen Abstände zwischen ausgewählten Objekten vereinheitlichen. Nach dem Aufrufen des Befehls bleiben das am weitesten links und das am weitesten rechts liegende bzw. das oberste und das unterste Objekt der Auswahl an ihren Positionen. Alle anderen Objekte werden in gleichmäßigen Abständen dazwischen angeordnet. Die vertikale/horizontale Position der Objekte wird nicht verändert.
Mit dem Befehl Align To Grid werden ausgewählte Objekte auf den nächstgelegenen Punkt des aktuellen Fangrasters verschoben.
Runden von Objektkoordinaten
Sie können die internen Koordinaten von Objekten runden, um Rundungseffekten entgegenzuwirken, die beim Wechsel von imperialen zu metrischen Maßeinheiten während des Entwurfs entstehen. Wählen Sie dazu den Befehl Tools » Convert » Round coordinates of objects in den Hauptmenüs. Dadurch entsprechen die internen Koordinaten aller Designobjekte den Werten, die sie hätten, wenn Sie von Anfang an mit metrischen Einheiten gearbeitet hätten.
Nach dem Aufrufen des Befehls wird das Dialogfeld Rounding coordinates of objects angezeigt. Legen Sie in diesem Dialogfeld fest, auf welche Dokumente der Rundungsvorgang angewendet werden soll:
- Just this document – Koordinaten nur im aktuellen Dokument runden.
- All schematic documents in the current project – Koordinaten in allen Schaltplandokumenten des aktuellen Projekts runden. Derzeit geschlossene Schaltplandokumente des aktuellen Projekts werden geöffnet.
- All open schematic documents – Koordinaten in allen derzeit geöffneten Schaltplandokumenten runden, unabhängig davon, zu welchem Projekt sie gehören.

Das Dialogfeld Rounding coordinates of objects
Nachdem Sie Ihre Auswahl getroffen und auf OK geklickt haben, wird ein Informationsdialogfeld geöffnet. Es fasst zusammen, bei wie vielen Objekten in wie vielen Dokumenten die Koordinaten gerundet wurden.
Verschieben eines Objekts in der Zeichenreihenfolge
Der Schaltplaneditor ordnet Objekte, Texte und Grafiken automatisch in übereinanderliegenden Ebenen an. Jedes Objekt befindet sich abhängig von seiner Erstellungsreihenfolge auf einer anderen Ebene. Daher können Objekte so platziert werden, dass sie sich überlappen. Die zuletzt erstellten oder hinzugefügten Objekte liegen immer auf der obersten Ebene.
Mit den folgenden Befehlen im Untermenü Edit » Move der Hauptmenüs oder im Untermenü zum Verschieben im Active Bar können Sie ein Objekt innerhalb eines Stapels überlappender Objekte verschieben.
Bring To Front / Send To Back – Ein Objekt innerhalb eines Stapels überlappender Objekte vor bzw. hinter alle anderen Objekte dieses Stapels verschieben. Klicken Sie nach dem Aufrufen des Befehls auf das Objekt, das Sie verschieben möchten. Das Objekt wird an die oberste/unterste Position des Stapels vor bzw. hinter alle überlappenden Objekte verschoben, ohne seine x- oder y-Koordinaten zu ändern.
Bring To Front Of / Send To Back Of – Ein Objekt innerhalb eines Stapels überlappender Objekte vor bzw. hinter ein anderes Objekt verschieben. Klicken Sie nach dem Aufrufen des Befehls auf das Objekt, das Sie verschieben möchten, und anschließend auf das „Zielobjekt“, vor bzw. hinter das Sie das erste Objekt verschieben möchten. Das erste Objekt wird vor bzw. hinter dieses Zielobjekt verschoben, ohne seine x- oder y-Koordinaten zu ändern.
Direkte Textbearbeitung
Mit der direkten Textbearbeitung können Sie Texteinträge im aktuellen Dokument, etwa Bezeichner- und Kommentartexte, Textzeichenfolgen, Textrahmen und vollständig aufgeklappte Notizen, direkt bearbeiten, statt das Properties-Panel verwenden zu müssen. Klicken Sie dazu einmal auf das Textobjekt, um es auszuwählen, und nach einer kurzen Pause erneut, um den direkten Bearbeitungsmodus zu aktivieren. Zwischen den Klicks muss genügend Zeit liegen, damit die Software die beiden Einzelklicks nicht als Doppelklick interpretiert, der das Properties-Panel öffnen würde. Alternativ können Sie das Textobjekt auswählen, das Sie direkt bearbeiten möchten, und anschließend das Tastenkürzel F2 verwenden. Wählen Sie das zu bearbeitende Textobjekt aus und aktivieren Sie dann den Befehl. Der Text wird markiert und kann direkt bearbeitet werden.
Um die direkte Textbearbeitung abzuschließen, klicken Sie außerhalb der Textzeichenfolge. Bei Parametertexten oder Textzeichenfolgen können Sie auch Enter drücken. Bei einem Textrahmen oder einer Notiz können Sie auf die Schaltfläche mit dem grünen Häkchen
klicken. Wenn Sie die Änderung verwerfen möchten, klicken Sie auf die Schaltfläche mit dem roten Kreuz
.
Bearbeiten von Polylinienobjekten
Ein Segment eines auf einem Schaltplanblatt platzierten Polylinien-Verbindungsobjekts (Leitung, Bus oder Signal Harness) kann mit dem Befehl Edit » Break Wire aus den Hauptmenüs an einer gewünschten Stelle in zwei Teile aufgetrennt werden. Nach dem Aufrufen des Befehls wird der Cursor entsprechend den Einstellungen für Cutter Box und Extremity Markers auf der Seite Schaltplan – Leitung auftrennen des Dialogfelds Preferences angezeigt.
Positionieren Sie den Cursor über dem Leitungs-, Bus- oder Signal-Harness-Segment, das Sie in zwei Teile auftrennen möchten, und klicken Sie oder drücken Sie Enter. Der gekennzeichnete Abschnitt des Segments wird entfernt, wodurch das Segment in zwei Teile aufgetrennt wird.
Setzen Sie das Auftrennen weiterer Polylinienobjekte fort, oder klicken Sie mit der rechten Maustaste bzw. drücken Sie Esc, um den Modus zu beenden.
Drücken Sie im Modus zum Auftrennen von Drähten Spacebar , um zwischen den folgenden Schnittlängenmodi zu wechseln:
- Snap To Segment - in diesem Modus passt sich die Größe des Schneidwerkzeugs automatisch an ein vollständiges Polyliniensegment an.
- Snap Grid Size Multiple - in diesem Modus wird die Größe des Schneidwerkzeugs auf ein definiertes Vielfaches des aktuellen Fangrasters eingestellt.
- Fixed Length - in diesem Modus wird die Größe des Schneidwerkzeugs auf eine definierte feste Länge eingestellt.
Um den aktuell unter dem Cursor liegenden Eckpunkt des zugehörigen Polygons, einer Linie, eines Drahts, eines Busses, eines Signal-Harness oder eines Linienobjekts auf einem Schaltplanblatt oder in einem Schaltplansymbol zu bearbeiten, können Sie den Befehl Edit <ObjectType> Vertex n aus dem Rechtsklickmenü des gewünschten Eckpunkts verwenden. Nach dem Aufrufen des Befehls wird der Dialog mit den Eigenschaften des übergeordneten Objekts angezeigt. Der gewählte Eckpunkt ist im Bereich Vertices des Panels bereits zur Bearbeitung ausgewählt.
Ausschneiden/Kopieren und Einfügen verwenden
Im Schaltplaneditor können Sie Objekte innerhalb eines Schaltplandokuments oder zwischen Schaltplandokumenten ausschneiden/kopieren und einfügen. Beispielsweise können Bauteile aus einem Schaltplan in ein anderes Schaltplandokument kopiert werden. Sie können Objekte in die Windows-Zwischenablage ausschneiden/kopieren und in andere Dokumente einfügen. Text aus der Windows-Zwischenablage lässt sich in einen Textrahmen im Schaltplan einfügen. Außerdem können Sie eine tabellarische Auswahl direkt aus einer anderen Anwendung wie Microsoft Excel oder aus einem beliebigen tabellenartigen Steuerelement in Altium Designer kopieren und einfügen.
Erweiterte Kopier- und Einfügeaktionen können mit der Funktion Intelligentes Einfügen ausgeführt werden.
Wählen Sie die Objekte aus, die Sie ausschneiden/kopieren möchten, klicken Sie in den Hauptmenüs auf Edit » Cut (Ctrl+X) / Edit » Copy (Ctrl+C) oder wählen Sie den Befehl Cut/Copy im Rechtsklickmenü. Klicken Sie anschließend auf das Objekt, um einen Kopierreferenzpunkt festzulegen, der beim Einfügen zur präzisen Positionierung des Objekts verwendet wird. Sie werden nur dann aufgefordert, per Klick einen Referenzpunkt festzulegen, wenn die Option Clipboard Reference auf der Seite Schaltplan – Grafische Bearbeitung des Dialogs Preferences aktiviert ist. Wenn die Option Clipboard Reference deaktiviert ist, empfiehlt es sich, den Befehl über das Tastenkürzel aufzurufen.
Um die aktuell ausgewählten Designobjekte im Textformat in die Zwischenablage zu kopieren, wählen Sie die Objekte aus und anschließend den Befehl Edit » Copy As Text in den Hauptmenüs. Der Text der textbasierten Objekte in der Auswahl (Beschriftungen, Notizen, Textrahmen, Netzbezeichnungen, blattübergreifende Anschlüsse, Ports, Stromversorgungsanschlüsse usw.) wird in die Zwischenablage kopiert. Diese Informationen können anschließend in ein beliebiges Textfeld oder ein externes Textdokument eingefügt werden.
Um den zuletzt ausgeschnittenen/kopierten Inhalt der Zwischenablage in das aktive Dokument einzufügen, wählen Sie den Befehl Edit » Paste in den Hauptmenüs oder klicken Sie mit der rechten Maustaste in den Designbereich und wählen Sie den Befehl Paste im Kontextmenü (Tastenkürzel: Ctrl+V).
Intelligentes Einfügen verwenden
Mit der Funktion „Intelligentes Einfügen“ des Schaltplaneditors können Kopien eines ausgewählten Objekts bei Bedarf umgewandelt und als anderer Objekttyp eingefügt werden. Beispielsweise lässt sich eine Auswahl von Netzbezeichnungen kopieren und mittels intelligentem Einfügen als Ports einfügen. Ebenso kann eine Gruppe ausgewählter Blatteinträge als Ports+Drähte+Netzbezeichnungen eingefügt werden, wobei Busse in einzelne Drähte aufgelöst werden.
Nachdem die für das intelligente Einfügen benötigten Objekte in die Zwischenablage kopiert wurden, wählen Sie den Befehl Edit » Smart Paste in den Hauptmenüs oder verwenden Sie das Tastenkürzel Shift+Ctrl+V, um den Dialog Smart Paste zu öffnen.
Optionen und Bedienelemente des Dialogs „Intelligentes Einfügen“
Einzufügendes Objekt auswählen
- Schematic Object Type Grid - zeigt eine Liste aller von Ihnen ausgewählten Objekte in der Zwischenablage an, gruppiert nach Objekttyp. Über das Kontrollkästchen legen Sie fest, welche Objektgruppe Sie einfügen möchten. Bevor Sie die Objekte einfügen können, müssen Sie außerdem eine Aktion im Bereich Choose Paste Action des Dialogs auswählen. Diese bestimmt, wie die ausgewählten Objekte auf dem Schaltplanblatt platziert werden. Die Einfügeaktion Themselves ist eine standardmäßige Einfügeaktion, bei der die Objekte so eingefügt werden, wie sie in die Zwischenablage übernommen wurden. Mit den anderen Aktionen können Sie das Quellobjekt beim Einfügen in einen anderen Objekttyp (oder eine Sammlung von Objekten) umwandeln.
- Windows Clipboard Contents Grid - die Software verwendet eine eigene Zwischenablage. Mit der Funktion „Intelligentes Einfügen“ können Sie Einfügeaktionen sowohl aus der Zwischenablage der Software als auch aus der Windows-Zwischenablage steuern. Aktivieren Sie die Inhalte der Windows-Zwischenablage, wenn Sie diese beim intelligenten Einfügen berücksichtigen möchten.
Einfügeaktion auswählen
-
Paste As - bevor Sie Inhalte einfügen können, müssen Sie einen Einfügevorgang auswählen. Dieser bestimmt, wie die ausgewählten Objekte auf Ihrem Schaltplanblatt platziert werden. Der Einfügevorgang Themselves ist ein Standardeinfügevorgang. Mit den anderen Vorgängen können Sie das Quellobjekt beim Einfügen in ein anderes Objekt oder eine Gruppe von Objekten umwandeln. Folgende Umwandlungen sind möglich:
- Ports, Sheet Entries, Net Labels können in entsprechende Ports, Schaltplanblatteinträge, Netzbezeichnungen oder einen Textrahmen/eine Notiz bzw. einen Satz aus Port und Netzbezeichnung pro Objekt (mit Verbindungen) umgewandelt werden.
- Label, Text Frame, Note kann in eine Beschriftung, einen Textrahmen oder eine Notiz umgewandelt werden.
- Windows Clipboard Text kann in Netzbezeichnungen, Ports, Schaltplanblatteinträge, Beschriftungen, Textrahmen, Notizen, gegebenenfalls Bauteile oder einen Satz aus Port und Netzbezeichnung pro Objekt (mit Verbindungen) umgewandelt werden.
- Windows Clipboard Graphics kann in ein Bild umgewandelt werden.
-
Options - je nachdem, welche Objekte Sie unter „Einfügen als“ auswählen, werden unterschiedliche Optionen angezeigt:
- Die Optionen Sort Order und Signal Names werden am häufigsten verwendet. Sie sind verfügbar, wenn Sie die Objekte Netzbezeichnungen, Ports, blattübergreifende Verbinder, Schaltplanblatteinträge, Kabelbaumeinträge sowie alle Gruppen auswählen, in denen eines dieser Objekte verwendet wird. Sie können die Option Sort Order auf By Location setzen, damit die Abstände zwischen den kopierten Objekten beibehalten werden. Wenn Sie Alpha-Numeric auswählen, werden die Namen alphanumerisch sortiert.
- Für die Option Signal Names gibt es weitere Möglichkeiten. Wählen Sie Keep , wenn Sie den kopierten Namen nicht ändern möchten. Sie können Expand Buses auswählen, um freie Objekte zu erhalten. Sie können auch die Option Group Nets mit Lower First oder Higher First auswählen, um das Objekt mit einem Busindex einzufügen. Die letzte Option in diesem Abschnitt ist Inverse Bus Indices – damit können Sie den Index des kopierten Texts umkehren. Wenn Sie beispielsweise den Namen LEDS[ 7..0 ] kopieren, können Sie ihn als LEDS[ 0..7 ] einfügen.
- Wenn Sie einen Port auswählen, können Sie die Option Port Width festlegen. Setzen Sie sie auf Use Default Size, um den Wert aus den Voreinstellungen zu übernehmen. Sie können auch Set Width To Widest auswählen, um den größten Breitenwert für den Port zu verwenden. Die letzte Option ist Set Width To Fit. Damit wird der Port genau so groß erstellt, dass Ihr Text hineinpasst.
- Wenn Sie Schaltplanblatteinträge einfügen möchten, wird die Option Same Side angezeigt. Mit dieser Option können Sie alle kopierten Informationen auf einer Seite des Schaltplanblattsymbols einfügen. Wenn diese Option deaktiviert ist, behalten die Schaltplanblatteinträge ihre Standardseite bei.
- Die Option Wire Length ist verfügbar, wenn Sie eine Gruppe von Objekten auswählen. Hier können Sie die Länge der zu platzierenden Verbindung eingeben.
- Wenn Sie Text in einen Textrahmen einfügen, können Sie Text Frame Size und Aspect Ratio auswählen. Die zweite Option ist nur verfügbar, wenn Set Width/Height using Aspect Ratio eingestellt ist. Der Textrahmen wird mit den Abmessungen platziert, die durch dieses Seitenverhältnis definiert sind. In den anderen Fällen können Sie diese Option auf Use Default Size setzen, um den Wert aus den Voreinstellungen zu übernehmen, oder Set Size To Fit auswählen, damit der Textrahmen an die einzufügenden Informationen angepasst wird. Dieselben Optionen sind auch für Notes verfügbar.
- Wenn Sie Informationen als Kabelbaumverbinder einfügen, können Sie dem Verbinder über die Option Harness Type einen Namen geben. Wenn Sie den Kabelbaumverbinder mit einem Port einfügen, können Sie außerdem Port Name und einen Wire Length.
Als Array einfügen
- Enable Paste Array - aktivieren Sie diese Option, um die ausgewählten Objekte als zweidimensionales Array zu kopieren. Die Gesamtzahl der erstellten Kopien ergibt sich aus der Anzahl der Spalten multipliziert mit der Anzahl der Zeilen. Nachdem Sie auf OK geklickt haben, werden Sie aufgefordert, eine Startposition im Dokument auszuwählen, an der das Array eingefügt werden soll. Positionieren Sie den Cursor an der gewünschten Stelle und klicken Sie oder drücken Sie Enter.
-
Columns
-
Count- gibt die gewünschte Anzahl der Spalten im einzufügenden Array an. Der Abstand zwischen den Spalten wird durch die Einstellung Column Spacing festgelegt. -
Spacing- geben Sie positive oder negative Abstandswerte ein, um festzulegen, ob das Array bei horizontaler Platzierung nach rechts oder links bzw. bei vertikaler Platzierung nach oben oder unten eingefügt wird.
-
-
Rows
-
Count- gibt die gewünschte Anzahl der Zeilen im einzufügenden Array an. Der Abstand zwischen den Zeilen wird durch die Einstellung Row Spacing festgelegt. -
Spacing- geben Sie positive oder negative Abstandswerte ein, um festzulegen, ob das Array bei horizontaler Platzierung nach rechts oder links bzw. bei vertikaler Platzierung nach oben oder unten eingefügt wird.
-
-
Text Increment
-
Direction- wählen Sie die Methode aus, mit der Zeichenfolgen (z. B. Bauteilbezeichner) in den einzufügenden Kopien hochgezählt werden sollen. Folgende Optionen stehen zur Auswahl:-
None- nicht hochzählen. Jede Kopie enthält dieselben Zeichenfolgen. -
Horizontal First- Zeichenfolgen hochzählen, indem der Wert einer Zeichenfolge gegenüber ihrem Vorgänger um den Betrag Primary erhöht wird. Die nächste hochzuzählende Zeichenfolge ist die unmittelbar rechts folgende Zeichenfolge in der Reihe. Sobald eine Zeile neu nummeriert wurde, wird am Anfang der nächsten darüberliegenden Zeile fortgefahren. Pins können ebenfalls über die Einstellung Secondary hochgezählt werden. -
Vertical First- Zeichenfolgen hochzählen, indem der Wert einer Zeichenfolge gegenüber ihrem Vorgänger um den Betrag Primary erhöht wird. Die nächste hochzuzählende Zeichenfolge ist die unmittelbar darüberliegende Zeichenfolge in der Reihe. Sobald eine Spalte neu nummeriert wurde, wird am Anfang der nächsten rechts liegenden Spalte fortgefahren. Pins können ebenfalls über die Einstellung Secondary hochgezählt werden.
-
-
Primary- Zeichenfolgen werden gegenüber ihrem Vorgänger um den Betrag Primary hoch- oder heruntergezählt. Pins können ebenfalls über die Einstellung Secondary geändert werden. -
Secondary- Zeichenfolgen werden gegenüber ihrem Vorgänger um den Betrag Primary hoch- oder heruntergezählt. Pins können ebenfalls über die Einstellung Primär geändert werden. -
Remove Leading Zeroes- aktivieren Sie diese Option, um führende Nullen aus der Zeichenfolge zu entfernen. Beispielsweise wird 000ABC bei aktivierter Option in ABC umgewandelt.
-
Für die Verwendung dieser Funktion müssen im Wesentlichen die folgenden drei Bereiche des Dialogs entsprechend den Anforderungen konfiguriert werden:
- Choose the objects to paste - dieser Abschnitt zeigt eine Liste aller Objekte in der Zwischenablage, gruppiert nach Objekttyp. Wählen Sie die einzufügenden Objekte über das Kontrollkästchen neben dem jeweiligen Schaltplanobjekttyp aus. Altium Designer verwendet eine von der Windows-Zwischenablage getrennte Zwischenablage, um die Details der darin enthaltenen Objekte genauer abbilden zu können. Bei Bedarf kann jedoch auch der Inhalt der Windows-Zwischenablage als Quelle für intelligentes Einfügen verwendet werden.
- Choose Paste Action - Bevor neue Objekte eingefügt werden können, muss ein geeignetes Paste As-Objekt ausgewählt werden, um festzulegen, wie die ausgewählten Objekte umgewandelt werden. Wenn Sie Objekte als Themselves einfügen, wird ein standardmäßiger Einfügevorgang ausgeführt. Die anderen Optionen wandeln das Quellobjekt vor dem Einfügen in das gewählte Objekt oder die gewählte Objektgruppe um. Weitere Optionen werden, sofern verfügbar, unterhalb der gewählten Einfügeobjekte aufgeführt.
- Paste Array - Aktivieren Sie diese Option, um die ausgewählten Objekte als zweidimensionale Anordnung zu kopieren. Die Gesamtzahl der erstellten Kopien entspricht der Anzahl der Spalten multipliziert mit der Anzahl der Zeilen. Verwenden Sie bei Objekten mit Bezeichnern die Steuerelemente für die Textinkrementierung, um festzulegen, wie die primären und gegebenenfalls sekundären Bezeichner inkrementiert werden. Legen Sie im Feld Direction fest, wie die Inkrementierung angewendet wird – Horizontal First oder Vertical First. Um exakte Kopien der Bezeichner ohne Inkrementierung zu erhalten, stellen Sie die Richtung auf None ein.
Wenn Sie die Optionen wie gewünscht konfiguriert haben, klicken Sie auf OK. Wenn keine Anordnung platziert wird, hängt der einzufügende Inhalt am Mauszeiger. Positionieren Sie den Inhalt an der gewünschten Stelle im Designbereich und klicken Sie oder drücken Sie Enter, um ihn einzufügen.
Verschachtelte Bearbeitung
Der Schaltplaneditor bietet eine leistungsfähige Funktion zur verschachtelten Bearbeitung, mit der Sie über Tastenkombinationen einen zweiten Vorgang ausführen können, ohne den aktuellen Vorgang beenden zu müssen. Wenn Sie beispielsweise beim Platzieren eines Bauteils Spacebar drücken, wird das Objekt gedreht, ohne den Platzierungsvorgang zu unterbrechen. Sobald Sie das Bauteil platziert haben, erscheint ein weiteres Bauteil am Mauszeiger – bereits gedreht.
Die verschachtelte Bearbeitung ist auch sehr hilfreich, wenn Sie mit dem Platzieren einer Leitung beginnen, die an einen noch nicht platzierten Port angeschlossen werden soll. Sie müssen den Modus Place Wire nicht verlassen. Drücken Sie einfach die Tastenkombination zum Platzieren eines Ports (P, R), platzieren Sie den Port, drücken Sie Esc , um den Modus zum Platzieren von Ports zu beenden, und verbinden Sie dann die Leitung mit dem Port.
Abstände in einem Schaltplandokument messen
Der Schaltplaneditor verfügt über ein Werkzeug zur Abstandsmessung im Menü Reports (Reports » Measure Distance sowie die Tastenkombination Ctrl+M). Mit diesem Werkzeug können Sie den Abstand zwischen zwei Punkten in einem Schaltplandokument messen. Nach dem Aufrufen des Befehls werden Sie aufgefordert, auf zwei Punkte im Schaltplandokument zu klicken. Sobald Sie zwei Punkte ausgewählt haben, wird das Dialogfeld Information mit einem Gesamtwert für Distance angezeigt. Die Werte für X Distance und Y Distance werden auf zwei Dezimalstellen genau angegeben.
Die Maßeinheiten werden durch die für das Schaltplandokument gewählte Einstellung Units im Bereich General des Modus „Dokumentoptionen“ im Panel „Eigenschaften“ bestimmt. Sie können auch durch Umschalten der Einheiten (View » Toggle Units) zwischen imperialen und metrischen Einheiten wechseln.
Gruppenobjekte bearbeiten
Ein Gruppenobjekt ist eine Gruppe von Grundelementen, die so definiert wurde, dass sie sich wie ein einzelnes Objekt verhält. Ein Bauteil in einem Schaltplan besteht beispielsweise aus Zeichenobjekten, Zeichenfolgen, Parametern, Pins und Verweisen auf Modelle. Die Grundelemente, die zu einem Gruppenobjekt gehören, werden mitunter als untergeordnete Objekte bezeichnet, während das Gruppenobjekt ihr übergeordnetes Objekt ist.
Betrachten wir eine typische Bearbeitung eines Gruppenobjekts. Ihr Design enthält mehrere Kondensatoren. Derzeit ist die Spannung als Teil der Kommentarzeichenfolge der Bauteile angegeben. Sie möchten dies ändern und die Spannung stattdessen als Bauteilparameter angeben und diesen Parameter im Schaltplan sichtbar machen.
Dazu sind die folgenden Schritte erforderlich (weiter unten ausführlich beschrieben):
- Wählen Sie die Kondensatoren mit dem Wert 100uF 16V aus.
- Ändern Sie deren Kommentar in 100uF (entfernen Sie den Text „16V“).
- Fügen Sie diesen Bauteilen einen neuen Parameter mit dem Namen Voltage und dem Wert 16V hinzu.
- Ändern Sie die Sichtbarkeit dieses Parameters, sodass er im Schaltplan angezeigt wird.
Auch wenn diese Bearbeitungsschritte komplex erscheinen mögen, lassen sie sich tatsächlich recht einfach durchführen.
Schritt 1. Kondensatoren auswählen
Um alle 100uF-16V-Kondensatoren auszuwählen, klicken Sie mit der rechten Maustaste auf das Bauteilsymbol eines dieser Kondensatoren und wählen Sie anschließend Find Similar Objects aus dem Kontextmenü.
Wir verwenden die im vorherigen Beispiel beschriebene Vorgehensweise. Diesmal sollen jedoch Bauteile mit demselben Comment und demselben Current Footprint gefunden werden, wie in der Abbildung oben gezeigt.
Beachten Sie, dass Sie auch nach Bauteilen suchen können, deren Bezeichner mit dem Buchstaben C beginnt. Ändern Sie dazu Component Designator in C*. Klicken Sie auf OK, um die passenden Kondensatoren auszuwählen.
Schritt 2. Kommentarzeichenfolge ändern
Nachdem Sie auf OK geklickt haben, öffnet sich das Panel Eigenschaften (sofern die Option Open Properties im Dialogfeld Find Similar Objects aktiviert war). Dahinter wird das Schaltplanblatt angezeigt, auf dem die passenden Objekte ausgewählt sind. Wenn die Optionen Zoom Matching und Mask Matching aktiviert waren, wird die Ansicht vergrößert und alle nicht passenden Objekte werden abgeblendet oder maskiert.
In der Statuszeile am unteren Rand des Panels Eigenschaften können Sie prüfen, ob dieselben Kondensatoren auch auf anderen Blättern vorhanden sind.
Um die Kommentarzeichenfolge zu ändern, löschen Sie 16V aus der Zeichenfolge und drücken Sie anschließend Enter , um die Änderung zu übernehmen.
Schritt 3. Dem Bauteil einen neuen Parameter hinzufügen
Als Nächstes müssen Sie einen neuen Parameter hinzufügen. Klicken Sie dazu im Bereich Parameters des Panels Properties im Modus Component auf Add und wählen Sie anschließend Parameter aus der Dropdown-Liste. Der Tabelle in diesem Bereich wird ein Eintrag Parameter 1 hinzugefügt. Geben Sie für den neuen Parameter Name und Value ein.
Schritt 4. Den Spannungsparameter sichtbar machen
Im letzten Schritt machen Sie den neuen Spannungsparameter sichtbar. Klicken Sie auf das Symbol
, um den Parameter sichtbar zu machen (angezeigt als
Sie haben nun die Kommentarzeichenfolge für alle 100uF-Kondensatoren aktualisiert. Außerdem haben Sie einen neuen Parameter namens Voltage hinzugefügt, seinen Wert auf 16V gesetzt und ihn sichtbar gemacht.
Textsuche
Mit dem Schaltplaneditor und dem Schaltplansymboleditor können Sie anhand festgelegter Suchoptionen schnell nach bestimmten Texten oder Textteilen suchen. Wählen Sie Edit » Find Text Befehl aus den Hauptmenüs, klicken Sie mit der rechten Maustaste in den Designbereich und wählen Sie den Find Text Befehl aus dem Kontextmenü, oder verwenden Sie die Ctrl+F Tastenkombination, um den Dialog Find Text zu öffnen. In diesem Dialog geben Sie den zu suchenden vorhandenen Text an und legen den Suchbereich sowie zusätzliche Optionen fest.

Der Dialog Find Text
Optionen und Bedienelemente des Dialogs „Find Text“
Zu suchender Text
-
Text To Find – geben Sie in dieses Feld die Zeichenfolge ein, nach der Sie suchen möchten. Geben Sie entweder das vollständige Wort ein oder suchen Sie nach einer Teilzeichenfolge. Für Letzteres muss die Option Whole Words Only deaktiviert sein. Die Zeichenfolge kann die Platzhalterzeichen
?(einzelnes Zeichen) und*(beliebige Gruppe von Zeichen) enthalten.
Suchbereich
-
Sheet Scope – legen Sie in diesem Feld fest, welche Schaltplandokumente in die Textsuche einbezogen werden. Wählen Sie eine der folgenden Optionen:
-
Current Document– nur das aktive Dokument durchsuchen. -
Project Documents– alle Schaltplandokumente im aktiven Projekt durchsuchen. -
Open Documents– alle geöffneten Schaltplandokumente durchsuchen, unabhängig davon, zu welchem Projekt sie gehören. -
Project Physical Documents– die Registerkartenansichten „Compiled Document“ der Quellschaltplandokumente des aktiven Projekts durchsuchen.
-
-
Selection – verwenden Sie dieses Feld, um den Suchbereich anhand des aktuellen Auswahlstatus der Objekte weiter einzuschränken. Wählen Sie eine der folgenden Optionen:
-
Selected Objects– die Suche auf aktuell ausgewählte Objekte beschränken. -
DeSelected Objects– die Suche auf aktuell nicht ausgewählte Objekte beschränken. -
All Objects– keine Einschränkung; alle Objekte unabhängig von ihrem Auswahlstatus durchsuchen.
-
-
Identifiers – verwenden Sie dieses Feld, um den Suchbereich anhand des Typs des textbasierten Objekts weiter einzuschränken. Wählen Sie eine der folgenden Optionen:
-
All Identifiers– keine Einschränkung; alle textbasierten Objekte durchsuchen (Textzeichenfolgen, Textrahmen, Pins, Netzkennungen und Bauteilbezeichner). -
Net Identifiers Only– die Suche auf Netzkennungen beschränken (Ports, Versorgungsanschlüsse, Blatteinträge, blattübergreifende Verbinder und Netzlabels). -
Designators Only– die Suche auf Bauteilbezeichner beschränken.
-
Optionen
- Case sensitive – aktivieren Sie diese Option, um bei der Suche die Groß-/Kleinschreibung zu berücksichtigen. Der Zieltext muss dann hinsichtlich der Groß-/Kleinschreibung mit dem Suchtext übereinstimmen, der in das Feld Text To Find eingegeben wurde.
- Whole Words Only – aktivieren Sie diese Option, um die Suche auf ganze Wörter zu beschränken. Der Suchtext muss vollständig und unverändert vorkommen und darf nicht Teil einer längeren Zeichenfolge sein. Wenn diese Option beispielsweise aktiviert ist und Sie nach „cat“ suchen, betrachtet die Software die ersten drei Buchstaben von „category“ nicht als gültigen Suchtreffer. Deaktivieren Sie diese Option, um uneingeschränkt nach Teilzeichenfolgen zu suchen.
- Jump to Results – aktivieren Sie diese Option, um übereinstimmenden bzw. gefundenen Text im Designbereich vergrößert und zentriert anzuzeigen (sofern möglich). Wenn eine Suche mehrere Treffer ergibt, wird der Dialog Find Text - Jump geöffnet. In diesem Dialog können Sie zwischen den übereinstimmenden Suchergebnissen wechseln.
-
Regular expressions – aktivieren Sie diese Option, um mit regulären Ausdrücken zu suchen.
- ^ – nur dann einen Treffer liefern, wenn die Zeichenfolge am Anfang einer Zeile steht.
- $ – nur dann einen Treffer liefern, wenn die Zeichenfolge am Ende einer Zeile steht.
- . – steht für ein beliebiges einzelnes Zeichen (z. B. findet „te.t“ die Zeichenfolgen „test“, „text“ und „tent“, aber nicht „tet“).
- * – steht für eine beliebige Anzahl von Zeichen, einschließlich null Zeichen (z. B. findet „te*“ die Zeichenfolgen „text“, „tent“ und „te“, aber nicht „t“).
- + – steht für eine beliebige Anzahl von Zeichen, jedoch nicht null Zeichen (z. B. findet „te+“ die Zeichenfolgen „text“ und „tent“, aber nicht „te“).
- [ ] – findet jedes der in den Klammern enthaltenen Zeichen.
- [^] – ein Zirkumflex am Anfang einer Zeichenfolge in Klammern bedeutet NICHT (z. B. findet „[^tes]“ alle Zeichen außer t, e oder s).
- [-] – ein Bindestrich innerhalb einer Zeichenfolge in Klammern kennzeichnet einen Zeichenbereich (z. B. findet „[l-o]“ die Zeichen l, m, n und o).
- { } – dient zum Gruppieren von Zeichen oder Ausdrücken. Gruppen können verschachtelt werden, wobei ein einzelnes Muster maximal 10 Gruppen enthalten darf.
- \ – ein umgekehrter Schrägstrich vor einem Platzhalterzeichen weist den Schaltplaneditor oder Schaltplanbibliothekseditor an, dieses Zeichen wörtlich und nicht als Platzhalter zu behandeln (z. B. sucht „\^test“ nicht nach der Zeichenfolge test am Anfang einer Zeile, sondern nach der Zeichenfolge „^test“).
- Mask Matching – aktivieren Sie diese Option, um übereinstimmenden Text im Designbereich gemäß den Einstellungen auf der Seite System – Navigation des Dialogs Preferences vergrößert anzuzeigen und/oder abzudunkeln, wenn die Option Jump to Results aktiviert ist.
Alle übereinstimmenden Texte werden im Panel Messages aufgelistet. Von dort können Sie per Cross-Probing direkt zu einer Fundstelle des gesuchten Textes im Designbereich navigieren (doppelklicken Sie auf einen Meldungseintrag oder klicken Sie mit der rechten Maustaste darauf und wählen Sie Cross Probe aus dem Kontextmenü). Wenn außerdem die Option Jump to Results im Dialog Find Text aktiviert wurde und mehrere Fundstellen des gesuchten Textes gefunden werden, wird der Dialog Find Text - Jump angezeigt. Die erste Fundstelle des Textes, der im Feld Text To Find des Dialogs Find Text angegeben ist, wird dann im Designbereich aufgesucht und zentriert.

Der Dialog Find Text - Jump
Optionen und Bedienelemente des Dialogs „Find Text - Jump“
- Previous - klicken Sie auf diese Schaltfläche, um zur vorherigen Textfundstelle zu navigieren. Klicken Sie wiederholt darauf, um die Fundstellen nacheinander rückwärts zu durchlaufen.
-
Next - klicken Sie auf diese Schaltfläche, um zur nächsten Textfundstelle zu navigieren. Klicken Sie wiederholt darauf, um die Fundstellen nacheinander vorwärts zu durchlaufen.
-
Close - klicken Sie auf diese Schaltfläche, um den Dialog zu schließen. Klicken Sie auf den Dropdown-Pfeil rechts an der Schaltfläche, um ein Menü mit den folgenden Optionen aufzurufen:
- New Search - wählen Sie diesen Befehl, um den Dialog zu schließen und den Dialog Find Text zu öffnen, in dem Sie die Suche nach Bedarf ändern können.
- Close - wählen Sie diesen Befehl, um den Dialog zu schließen und zum Designbereich zurückzukehren. Alternativ können Sie dafür die Tastenkombination Esc verwenden.
Um zu einem anderen gefundenen Vorkommen des gesuchten Textes zu springen, können Sie:
- Die Schaltflächen Previous und Next im Dialog Find Text - Jump verwenden.
- Den Befehl Edit » Find Next (über die Tastenkombination F3) verwenden.
- Cross-Probing über den entsprechenden Meldungseintrag im Panel Messages durchführen.
Sie können auch anhand festgelegter Suchoptionen nach bestimmten Texten oder Textteilen suchen und diese anschließend durch einen angegebenen neuen Text ersetzen. Wählen Sie den Befehl Edit » Replace Text in den Hauptmenüs oder verwenden Sie die Tastenkombination Ctrl+H, um den Dialog Find And Replace Text aufzurufen. Geben Sie in diesem Dialog den zu suchenden vorhandenen Text und den gewünschten Ersatztext an und legen Sie den Suchbereich sowie weitere Optionen fest. Klicken Sie anschließend auf OK. Alle gefundenen Texte werden ersetzt, sofern die Option Prompt On Replace im Dialog nicht aktiviert ist. Ist sie aktiviert, können Sie das Ersetzen jedes übereinstimmenden Textvorkommens manuell bestätigen.

Der Dialog Find and Replace Text
Optionen und Bedienelemente des Dialogs zum Suchen und Ersetzen von Text
Text
-
Text To Find - geben Sie in diesem Feld die Zeichenfolge ein, nach der Sie suchen möchten. Geben Sie entweder das vollständige Wort ein oder suchen Sie nach einer Teilzeichenfolge. Für Letzteres muss die Option Whole Words Only deaktiviert sein. Die Zeichenfolge kann die Platzhalterzeichen
?(einzelnes Zeichen) und*(beliebige Zeichenfolge) enthalten. - Replace With - geben Sie in diesem Feld den Ersatztext ein. Der eingegebene Text ersetzt vollständig die Zeichenfolge, die anhand des Eintrags unter Text To Find und der festgelegten Optionen gefunden wurde.
Suchbereich
-
Sheet Scope - legen Sie in diesem Feld fest, welche Schaltplandokumente durchsucht werden sollen. Wählen Sie eine der folgenden Optionen:
-
Current Document- nur das aktive Dokument durchsuchen. Im Schaltplansymbol-Editor werden bei Auswahl dieser Option alle im Dokument enthaltenen Teilsymbolblätter durchsucht. -
Project Documents- alle Schaltplandokumente im aktiven Projekt durchsuchen. -
Open Documents- alle geöffneten Schaltplandokumente durchsuchen, unabhängig davon, zu welchem Projekt sie gehören.
-
-
Selection - grenzen Sie in diesem Feld den Suchbereich anhand des aktuellen Auswahlstatus der Objekte weiter ein. Wählen Sie eine der folgenden Optionen:
-
Selected Objects- die Suche auf die aktuell ausgewählten Objekte beschränken. -
DeSelected Objects- die Suche auf die aktuell nicht ausgewählten Objekte beschränken. -
All Objects- keine Einschränkung; alle Objekte unabhängig von ihrem Auswahlstatus durchsuchen.
-
-
Identifiers - grenzen Sie in diesem Feld den Suchbereich anhand des Typs des textbasierten Objekts weiter ein. Wählen Sie eine der folgenden Optionen:
-
All Identifiers- keine Einschränkung; alle textbasierten Objekte durchsuchen (Textzeichenfolgen, Textrahmen, Pins, Netzkennungen und Bezeichner). -
Net Identifiers Only- die Suche auf Netzkennungen beschränken (Ports, Versorgungsanschlüsse, Schaltplanblatteinträge, blattübergreifende Verbinder und Netzlabels). -
Designators Only- die Suche auf Bauteilbezeichner beschränken.
-
Optionen
- Case sensitive - aktivieren Sie diese Option, um bei der Suche die Groß- und Kleinschreibung zu berücksichtigen. Der gesuchte Text muss dann hinsichtlich der Groß- und Kleinschreibung mit dem im Feld Text To Find eingegebenen Suchtext übereinstimmen. Diese Option hat keinen Einfluss auf den Ersatztext. Dessen Groß- und Kleinschreibung entspricht stets dem im Feld Replace With eingegebenen Text.
- Prompt On Replace - aktivieren Sie diese Option, um zum manuellen Bestätigen jeder Ersetzung eines übereinstimmenden Textvorkommens aufgefordert zu werden. Die einzelnen Vorkommen werden nacheinander in einem Dialog Confirm behandelt. Abschließend fasst ein Dialog Information die Anzahl der vorgenommenen Ersetzungen zusammen. Wenn diese Option deaktiviert ist, werden alle gefundenen Textvorkommen, die mit dem Suchtext übereinstimmen, ohne manuelle Bestätigung ersetzt. Auch in diesem Fall wird ein Dialog Information mit der Anzahl der vorgenommenen Ersetzungen angezeigt.
- Whole Words Only - aktivieren Sie diese Option, um die Suche auf ganze Wörter zu beschränken. Das bedeutet, dass der Suchtext vollständig und unverändert vorhanden sein muss und nicht Teil einer längeren Zeichenfolge sein darf. Wenn diese Option beispielsweise aktiviert ist und Sie nach „cat“ suchen, wertet die Software die ersten drei Buchstaben von „category“ nicht als gültigen Suchtreffer. Deaktivieren Sie diese Option, um auch nach Teilzeichenfolgen suchen zu können.
-
Regular expressions - aktivieren Sie diese Option, um mit regulären Ausdrücken zu suchen.
- ^ - nur Übereinstimmungen finden, wenn die Zeichenfolge am Anfang einer Zeile steht.
- $ - nur Übereinstimmungen finden, wenn die Zeichenfolge am Ende einer Zeile steht.
- . - steht für ein beliebiges einzelnes Zeichen (z. B. findet „te.t“ die Zeichenfolgen „test“, „text“ und „tent“, aber nicht „tet“).
- * - steht für eine beliebige Anzahl von Zeichen, auch für kein Zeichen (z. B. findet „te*“ die Zeichenfolgen „text“, „tent“ und „te“, aber nicht „t“).
- + - steht für eine beliebige Anzahl von Zeichen, jedoch nicht für kein Zeichen (z. B. findet „te+“ die Zeichenfolgen „text“ und „tent“, aber nicht „te“).
- [ ] - findet eines der in den eckigen Klammern eingeschlossenen Zeichen.
- [^] - ein Zirkumflex am Anfang einer Zeichenfolge in eckigen Klammern bedeutet NICHT (z. B. findet „[^tes]“ beliebige Zeichen außer t, e oder s).
- [-] - ein Bindestrich innerhalb einer Zeichenfolge in eckigen Klammern kennzeichnet einen Zeichenbereich (z. B. findet „[l-o]“ die Zeichen l, m, n und o).
- { } - dient zum Gruppieren von Zeichen oder Ausdrücken. Gruppen können verschachtelt werden, wobei maximal 10 Gruppen in einem einzelnen Muster zulässig sind.
- \ - ein umgekehrter Schrägstrich vor einem Platzhalterzeichen weist den Schaltplaneditor oder Schaltplanbibliothekseditor an, dieses Zeichen wörtlich und nicht als Platzhalter zu behandeln (z. B. sucht „\^test“ nicht nach der Zeichenfolge test am Anfang einer Zeile, sondern nach der Zeichenfolge „^test“).
Arbeiten mit Unions
Eine Union ist eine Sammlung von Objekten, die zu einer Gruppe zusammengefasst wurden. Wenn Objekte als Union gruppiert sind, können Sie schnell alle Mitglieder der Union auswählen bzw. deren Auswahl aufheben und alle gemeinsam verschieben, indem Sie ein einzelnes Mitglied der Union verschieben.
Um aus den aktuell ausgewählten Designobjekten eine Union zu erstellen, wählen Sie in den Hauptmenüs den Befehl Tools » Convert » Create Union from selected objects oder klicken Sie mit der rechten Maustaste in den Designbereich und wählen Sie im Kontextmenü den Befehl Unions » Create Union from selected objects. Es wird eine Union erstellt, deren Mitglieder die ausgewählten Objekte sind. Ein Informationsdialog bestätigt, wie viele Objekte zur Union hinzugefügt wurden.
Um alle Objekte einer Union zu verschieben, klicken Sie grundsätzlich auf ein Mitgliedsobjekt dieser Union, halten die Maustaste gedrückt und bewegen dann den Mauszeiger, um alle Objekte der Union zu verschieben. Der Schaltplaneditor unterstützt jedoch auch das Ziehen elektrischer Objekte (z. B. Bauteile, Leitungen, Ports usw.). Wenn diese Funktion aktiviert ist, hat sie Vorrang vor dem Verschieben der Union, sobald Sie versuchen, ein elektrisches Objekt zu ziehen.
Um alle Objekte der Union auszuwählen bzw. deren Auswahl aufzuheben, zu der das Objekt unter dem Mauszeiger gehört, klicken Sie mit der rechten Maustaste auf ein Objekt der gewünschten Union und wählen Sie im Kontextmenü den Befehl Unions » Select All In Union / Deselect All In Union.
Um ein oder mehrere Mitgliedsobjekte aus einer bestimmten Union zu entfernen, wählen Sie in den Hauptmenüs den Befehl Tools » Convert » Break objects from Union. Nach dem Aufrufen des Befehls wird der Mauszeiger zu einem Fadenkreuz, und Sie werden aufgefordert, das Objekt auszuwählen, das aus einer Union entfernt werden soll. Positionieren Sie den Mauszeiger über dem gewünschten Mitgliedsobjekt und klicken Sie oder drücken Sie Enter. Der Dialog Confirm Break Objects Union wird geöffnet. Legen Sie in diesem Dialog fest, welche Objekte aus der Union entfernt werden sollen (und umgekehrt, welche Objekte Teil dieser Union bleiben sollen). Nachdem Sie auf OK geklickt haben, wird die Objektzugehörigkeit zur Union entsprechend aktualisiert.

Der Dialog Confirm Break Objects Union
Optionen und Bedienelemente des Dialogs Confirm Break Objects Union
Objekte auswählen, die in der Union verbleiben oder daraus entfernt werden sollen
- Object Kind - zeigt den Objekttyp an, z. B. Netzbezeichnung, Bus, Hyperlink usw.
- Description - zeigt die Beschreibung der Objekte an, z. B. Höhe/Breite, Bezeichner usw.
- Keep in Union - aktivieren Sie diese Option, um ein oder mehrere Objekte zum Entfernen aus der Union zu markieren.
- All On - klicken Sie hier, um alle Objekte zum Entfernen aus der Union zu markieren.
- All Off - klicken Sie hier, um die Auswahl aller Objekte aufzuheben.
Alternativ kann ein Objekt aus der übergeordneten Union entfernt werden, indem Sie mit der rechten Maustaste auf das Objekt in der gewünschten Union klicken und im Kontextmenü den Befehl Unions » Break objects from Union wählen.
Um alle für das aktuelle Schaltplandokument definierten Unions aufzulösen, wählen Sie in den Hauptmenüs den Befehl Tools » Convert » Break all objects Unions. Alle Unions im Design werden aufgelöst, und keines der ehemaligen Mitgliedsobjekte bleibt mit anderen gruppiert. Ein Informationsdialog bestätigt, wie viele Objekte aus wie vielen Unions entfernt wurden.

