Working with Design Object Parameters
Auf einen Blick
- Erfahren Sie, wo Parameter in Altium Designer vorkommen – auf Objekt-, Dokument- und Projektebene – und wie sich System- und Benutzerparameter unterscheiden.
- Lernen Sie, wie Sie Parameterzeichenfolgen über das Properties-Panel, im Arbeitsbereich und im Rahmen von Bibliotheksabläufen hinzufügen, bearbeiten, verschieben, sperren und verwalten.
- Verstehen Sie das bauteilspezifische Verhalten von Parametern, einschließlich Bezeichnern, automatischer Positionierung und spezieller Parametertypen wie Links.
Parameter sind universell einsetzbare Textzeichenfolgen, die einem übergeordneten Objekt als untergeordnete Objekte zugeordnet sind. Sie kennzeichnen das übergeordnete Objekt und ergänzen es um zusätzliche Informationen. Wenn sie auf einem Schaltplanblatt ausgewählt werden, sind sie direkt im Panel Properties zugänglich.
Schaltplankomponenten nutzen beispielsweise in großem Umfang Parameter. Allgemeine Komponentenparameter lassen sich für verschiedene Zwecke verwenden, darunter Komponentendetails wie Leistung, Spannung usw., Lieferantendetails wie Lieferantenname und Teilenummer, Entwurfsdetails von Bibliothekskomponenten wie die Revisionsnummer des Symbols sowie Dokumentationsangaben wie eine URL, die auf ein Komponentendatenblatt verweist.
Parameter können auch auf Schaltplanblatt- (Dokument-) und Projektebene definiert werden. Parameter auf Dokumentebene dienen zur Definition von Feldern wie Dokumenttitel und -nummer, während Parameter auf Projektebene ideal für Felder wie den Namen des Entwicklers oder des Projekts geeignet sind.
Parameter werden für Objekte, Dokumente und Projekte verwendet, um dem Design detaillierte Informationen hinzuzufügen. Die obige Abbildung zeigt eine Komponente.
Parameter werden als Eigenschaften des übergeordneten Objekts hinzugefügt oder automatisch aufgenommen und nicht wie eine Textzeichenfolge unabhängig platziert. Die verfügbaren Parametertypen lassen sich grob in System- und Benutzerparameter unterteilen, wobei Letztere manuell hinzugefügt werden.
Kennungs- und Systemparameter
In einem Schaltplan platzierte Objekte enthalten automatisch eine Reihe wichtiger Systemparameter. Diese liefern grundlegende Objektinformationen, anhand derer das System den Namen, den Typ und die Datenquelle des übergeordneten Objekts unterscheidet. Zu den inhärenten Systemparametern von Objekten gehören unter anderem die Eigenschaften Comment, Description und Design Item ID (Bibliotheksreferenz). Die Systemparameter eines Objekts sind im Bereich General des Panels Properties (auf der Registerkarte General) zugänglich, wenn ein übergeordnetes Objekt ausgewählt ist Wenn ein einzelner Parameter im Designbereich sichtbar und ausgewählt ist, ist er über den zugehörigen Modus des Panels Properties zugänglich, wie weiter unten beschrieben
Benutzerparameter
Parameter können jedem der folgenden Designobjekte hinzugefügt werden.
| Component | Fügen Sie benutzerdefinierte Parameter im Bereich Parameters des Panels Properties hinzu, wenn ein Komponentenobjekt (Bauteil) ausgewählt ist, oder während der Komponentendefinition im Schaltplanbibliothekseditor. Systemparameter wie Bezeichner und Kommentar sind bei einem Komponentenobjekt immer vorhanden, wie oben beschrieben. Das Panel Properties öffnen Sie durch einen Doppelklick auf ein Objekt oder indem Sie mit der rechten Maustaste auf ein Objekt klicken und im Kontextmenü Properties wählen. Wenn das Panel Properties bereits aktiv ist, wählen Sie ein Objekt im Designbereich aus. |
| Part | Im Bereich Parameters des Panels Properties , wenn ein Bauteil-Objekt ausgewählt ist. |
| Pin | Auf der Registerkarte Parameters des Panels Properties , wenn ein Pin-Objekt in einer *.SchLib-Datei ausgewählt ist. |
| Port | Auf der Registerkarte Parameters des Panels Properties, wenn ein Port-Objekt ausgewählt ist. |
| Sheet Symbol | Auf der Registerkarte Parameters des Panels Properties, wenn ein Blattsymbol-Objekt ausgewählt ist. |
| Document | Auf der Registerkarte Parameters des Panels Properties im Modus Document Options (heben Sie die Auswahl aller Schaltplanobjekte auf oder klicken Sie auf eine freie Stelle auf dem Dokumentblatt). Ein neues Schaltplanblatt enthält automatisch eine Reihe von Standardparametern, die durch die angewendete bzw. standardmäßig verwendete Blattvorlage festgelegt werden. |
| Project | Im Dialog Projektoptionen (Project » Projektoptionen). Parameter auf Projektebene werden auf der Registerkarte Parameters des Dialogs aufgelistet und hinzugefügt. |
Benutzerparameter sind im Bereich Parameters des Panels Properties oder des modalen Dialogs verfügbar, wenn das übergeordnete Objekt ausgewählt ist. Parameter können sowohl hinzugefügt als auch bearbeitet werden. Ausnahmen sind Projektparameter (über den Dialog Projektoptionen) und Komponenten-Pin-Parameter (über Pin-Eigenschaften oder die modale Ansicht des Dialogs Pin ). Wenn ein einzelner Parameter im Designbereich sichtbar und ausgewählt ist, ist er über den zugehörigen Modus des Panels Properties oder des modalen Dialogs zugänglich, wie weiter unten beschrieben.
Erstens: Benutzerparameter einer Komponente im Panel Properties (Bereich Parameters). Zweitens: Ein einzelner Systemparameter im Panel Properties.
Grafische Bearbeitung
Sichtbare Parameterzeichenfolgen können direkt im Designbereich grafisch bearbeitet werden.
Klicken Sie auf einen Parameter und ziehen Sie ihn, um ihn neu zu positionieren. So bearbeiten Sie die Parameterzeichenfolge direkt an Ort und Stelle:
-
Ziehen Sie bei gedrückter Maustaste einen Auswahlrahmen um das Parameterobjekt.
-
Nach der Auswahl wird das Objekt durch einen grünen Rahmen hervorgehoben.
-
Wählen Sie
Enter, um mit der Textbearbeitung zu beginnen. -
Drücken Sie nach Abschluss der Bearbeitung erneut
Enteroder klicken Sie außerhalb der Zeichenfolge, um den direkten Bearbeitungsmodus zu verlassen.
Eine Parameterzeichenfolge kann direkt im Designbereich ausgewählt und bearbeitet werden. Wählen Sie die gesamte Zeichenfolge aus, um sie zu überschreiben.
Parameter, die im Designbereich sichtbar und auswählbar sind, können an eine neue Position gezogen und dabei gedreht werden. Klicken Sie auf die Parameterzeichenfolge und ziehen Sie sie. Verwenden Sie die Tasten Spacebar und Shift+Spacebar, um sie in 90°-Schritten zu drehen, und klicken Sie anschließend, um die neue Position/Ausrichtung zu bestätigen.
Informationen zu Autopositioning für Komponentenparameter und den zugehörigen Optionen im Panel Properties finden Sie weiter unten unter Positionierung von Parameterzeichenfolgen.
Gesperrte Parameter
Ein Parameter, der einem Komponentenbauteil untergeordnet ist, kann gesperrt werden. Dadurch lassen sich seine Zeichenfolgen Name und Value nicht mehr bearbeiten. Dies ist auf folgende Weise möglich:
-
durch Umschalten des Schlosssymbols neben seinem Eintrag im Bereich Parameters des Panels Properties oder des modalen Dialogs für sein übergeordnetes Objekt oder
-
durch Aktivieren der Option Lock Parameter im Panel Properties, wenn der Parameter direkt im Designbereich ausgewählt ist.
Nach dem Sperren kann die Parameterzeichenfolge weder im Panel Properties noch im modalen Dialog (unter Parameters für das übergeordnete Objekt) oder im Designbereich per Direktbearbeitung geändert werden.
Bauteilparameter
Bauteilparameter, die offensichtlichsten und am häufigsten verwendeten Schaltplanparameter, umfassen zusätzliche Gruppen spezieller Parameter und Funktionen, die die Möglichkeiten zur Definition von Bauteilobjekten erweitern.
Parameter in der Schaltplanbibliothek definieren
Die untergeordneten Parameter eines übergeordneten Bauteilobjekts können vor desseno Platzierung in einem Schaltplan in der Quellbibliothek des Bauteils definiert werden. Mit dem Panel Properties lassen sich Parameter eines Bauteileintrags im Schaltplanbibliothekseditor auf dieselbe Weise bearbeiten und hinzufügen wie bei der Arbeit mit Parametern im Schaltplan-Editor.
Wählen Sie bei geöffnetem Schaltplanbibliotheksdokument einen Bauteileintrag im Panel SCH Library aus, um im Panel Properties auf dessen Parametereigenschaften zuzugreifen.
Greifen Sie auf die Eigenschaften eines Bibliotheksbauteils zu, indem Sie dessen Eintrag im Panel SCH Library auswählen.
Designator und Kommentar eines Bibliotheksbauteils sind im Designbereich des Schaltplanbibliothekseditors standardmäßig nicht sichtbar. Sie können jedoch eingeblendet werden, indem Sie die Option Show Comment/Designator im Modus „Library Options“ des Panels „Properties“ (Tools » Document Options) aktivieren. Dieser Modus ist verfügbar, wenn im Designbereich keine Objekte ausgewählt sind.
Parameter, die zu einem Bibliotheksbauteil gehören, werden auf dieselbe Weise definiert und bearbeitet wie die Parameter platzierter Schaltplanbauteile. Mit der Taste Tab können Parameter direkt während der Platzierung eines Objekts im Designbereich erstellt oder bearbeitet werden. Der Zugriff auf Parameter erfolgt über das Panel Properties oder den modalen Dialog. Die grundlegenden Systemparameter stehen dabei auf der Registerkarte General des Panels zur Verfügung, während Benutzerparameter über das Dropdown-Menü Parameters des Panels hinzugefügt bzw. bearbeitet werden.
Der Designator-Parameter
Im Schaltplanbibliothekseditor erhält der Parameter Designator eines Bauteils üblicherweise ein passendes Präfix, gefolgt von einem Fragezeichen. Wird das Bauteil aus der Bibliothek in einem Schaltplan platziert, erkennt das Annotationswerkzeug des Schaltplaneditors das Fragezeichen und ersetzt es bei der Projektannotation durch ein geeignetes numerisches Suffix.
Der Schaltplaneditor bietet außerdem eine einfache Funktion zum automatischen Hochzählen des Designators, die bei der Platzierung mehrerer Instanzen desselben Bauteils verwendet werden kann. Drücken Sie dazu Tab, während das erste Bauteil am Mauszeiger hängt, um die Platzierung zu unterbrechen, und geben Sie dann im Panel Properties einen geeigneten Designator ein, beispielsweise R1. Nachfolgende Bauteile erhalten dann die Bezeichnungen R2, R3 usw.
Wenn bei der Platzierung mehrteiliger Bauteile der anfängliche Designator auf diese Weise zugewiesen wird, wird automatisch ein Suffix für das Teil hinzugefügt, beispielsweise U3A, U3B usw. Wird kein anfänglicher Designator zugewiesen, erhalten alle Teile dasselbe Suffix. Dies lässt sich mit der Annotationsfunktion des Schaltplaneditors beheben. Das Suffix kann alphabetisch oder numerisch sein, wie durch die Option Alpha Numeric Suffix auf der Seite Schaltplan – Allgemein des Dialogs Preferences festgelegt.
Positionierung von Parameterzeichenfolgen
Standardmäßig wird die Parameterzeichenfolge eines Bauteils automatisch positioniert (d. h., ihre Ausrichtung wird beibehalten), wenn das Bauteil während oder nach der Platzierung gedreht wird. Wenn dieses Verhalten nicht gewünscht ist, deaktivieren Sie die Option Autoposition für den Bauteilparametereintrag im Bereich Parameters des Panels Properties. Um auf diese Option zuzugreifen, wählen Sie den Parameter in der Liste aus und klicken Sie anschließend auf Other. Beachten Sie, dass während der Bauteilplatzierung die Tasten Spacebar und Shift+Spacebar zum Drehen verwendet werden. Ein platziertes Bauteilobjekt lässt sich über das Menü Rotation im Bereich Location des Panels Properties drehen oder indem Sie das Bauteil auswählen und anschließend Spacebar oder Shift+Spacebar drücken.
Klicken Sie auf einen sichtbaren Parameter und ziehen Sie ihn, um ihn im Schaltplan manuell neu zu positionieren. Dabei gelten die üblichen Tastenkombinationen für die Ausrichtung. Wenn die Option Autoposition für diesen Parameter deaktiviert ist and die Option Mark Manual Parameters auf der Seite Schaltplan – Grafische Bearbeitung des Dialogs Preferences aktiviert ist, werden manuell verschobene Parameter durch einen Punkt in der unteren linken Ecke ihres Auswahlrahmens gekennzeichnet.
Bauteilparameter für spezielle Zwecke
Für die Verknüpfung mit zugehörigen URL-Zielen oder dateibasierter Dokumentation stehen spezielle Bauteilparameter zur Verfügung. Bei einem ausgewählten Bauteil werden diese hinzugefügt, indem Sie im Bereich Parameters des Panels Properties auf Add klicken und anschließend Link aus dem Dropdown-Menü auswählen. Spezielle Hilfelinks, die mit der Taste F1 aktiviert werden, können auf der Registerkarte Parameters hinzugefügt werden.
Link-Parameter
Mit der Link-Funktion lassen sich benannte Links zu beliebig vielen Referenz-URLs oder Dokumenten definieren und anzeigen.
Um einem Bauteil einen Referenzlink hinzuzufügen, wählen Sie das Bauteil im Designbereich aus und klicken Sie dann im Bereich Parameters des Panels Properties auf Links . Wählen Sie Link aus dem Dropdown-Menü Add am unteren Rand des Bereichs Parameters . Geben Sie Name und Value (Ziel-URL oder Dateipfad) des Links in die Tabelle ein. Anschließend können Sie auf den Link zugreifen, indem Sie im Designbereich mit der rechten Maustaste auf das Bauteil klicken und den Link <name> im Untermenü References auswählen.
Die im Panel und im Designbereich angezeigten Bauteillinks basieren intern auf Name/Wert-Paaren im Format ComponentLinknDescription/ComponentLinknURL (wobei n die Nummer des Links in der Liste entsprechend der Erstellungsreihenfolge ist). Weitere Details finden Sie im Eintrag dieses Bauteils im Parametertabelleneditor.
Der HelpURL-Parameter
Ähnlich wie der Link-Parameter ermöglicht der HelpURL-Parameter die Definition eines Links von einem Bauteil zu einem externen Dokument, etwa einer PDF-Datei, oder zur URL einer Webseite. Wenn der Link als Bauteilparameter hinzugefügt wurde, wird er aktiviert, wenn die Taste F1 gedrückt wird, während sich der Mauszeiger über dem Bauteil auf dem Schaltplanblatt befindet oder das Bauteil im Panel Libraries ausgewählt ist. Beachten Sie, dass diese Aktion die normale Funktion der Taste F1 außer Kraft setzt, die zur entsprechenden Seite in der Altium-Onlinedokumentation führt.
Der Hilfelink wird als Benutzerparameter im Panel Properties hinzugefügt, wenn ein Bauteil im Designbereich ausgewählt ist. Klicken Sie im Bereich Parameters des Panels Properties auf Parameters und wählen Sie anschließend Parameter aus dem Dropdown-Menü Add am unteren Rand des Bereichs Parameters . Geben Sie „HelpURL“ als Parameter Name und den Zielpfad bzw. die Ziel-URL als Parameter Value ein.
Als Wert für den Parameter können Sie eine URL, einen absoluten Pfad zu einem Dokument oder nur den Dokumentnamen angeben. Wenn Sie F1 drücken, während sich der Cursor über dem platzierten Bauteilobjekt befindet, oder die Option References » Help im Kontextmenü verwenden, wird wie folgt nach der Hilfereferenz gesucht:
- Wenn ein Pfad angegeben ist, wird zuerst an diesem Speicherort gesucht.
-
Wenn das Dokument an diesem Speicherort nicht gefunden wird oder kein Pfad angegeben ist, wird der Ordner
\Helpder Softwareinstallation durchsucht. - Wenn das Ziel eine URL ist, wird die Webseite im internen Browser der Software oder in einem externen Browser geöffnet, je nach Einstellung der Option Open internet links in external Web browser auf der Seite System – Ansicht des Dialogs Preferences.
Indirekte Referenzierung – ein Parameter als Zeichenfolgenwert
Die meisten Bauteilparameter können auf einem Schaltplanblatt angezeigt werden, indem Sie das Sichtbarkeitssymbol im Panel Properties aktivieren, sofern verfügbar. Kennzeichnungs- und Systemparameter finden Sie auf der Registerkarte General des Panels, Benutzerparameter im Bereich Parameters.
Andere Parameter, beispielsweise Dokument- und Projektparameter, können dagegen nicht direkt auf dem Schaltplanblatt angezeigt werden. Sie lassen sich jedoch mithilfe einer als String Indirection bezeichneten Technik in ein Standardtextobjekt einfügen. Bei der indirekten Referenzierung besteht der Werteintrag eines Zeichenfolgenobjekts aus dem Namen eines verfügbaren Parameters (beispielsweise eines Dokument- oder Projektparameters), dem ein Gleichheitszeichen vorangestellt wird, zum Beispiel =Title.
Die Software erkennt solche Zeichenfolgen automatisch und prüft, ob ein verfügbarer Parametername mit dem Werteintrag des platzierten Textobjekts übereinstimmt. Im Beispiel wird Title als Dokumentparameter gefunden, sodass die Zeichenfolge den Wert des Titelparameters interpretiert und anzeigt, zum Beispiel MyDocument. Sie können einen Parameternamen durch direkte Bearbeitung dem Wert einer ausgewählten Zeichenfolge zuweisen (d. h. durch Eingabe von =Title). Eine übersichtlichere Möglichkeit besteht darin, im Dropdown-Menü Text des Panels „Eigenschaften“ eine der verfügbaren Parameterzeichenfolgen auszuwählen.
Spezielle Zeichenfolgen
Parameterzeichenfolgen, die als indirekte Zeichenfolgen verfügbar sind (siehe oben), werden als special strings bezeichnet. Der von diesen Zeichenfolgen angezeigte Wert wird dynamisch aus Vorlagen oder aus System- und Quelldaten ermittelt. Beispielsweise ermittelt die spezielle Zeichenfolge =Time die aktuelle Systemzeit und zeigt sie an, während =DocumentName den Dateinamen des aktuellen Schaltplandokuments anzeigt (z. B. MySchematic.SchDoc).
Es stehen zahlreiche vordefinierte spezielle Zeichenfolgen zur Verfügung. Weitere Informationen zu diesen speziellen Zeichenfolgen finden Sie auf der Seite Arbeiten mit Textobjekten in einem Schaltplan. Auch jeder benutzerdefinierte Dokument- oder Projektparameter kann als spezielle Zeichenfolge verwendet und indirekt von einer Zeichenfolge auf dem Schaltplanblatt referenziert werden.
Parameter unterliegen einer Hierarchie. Das bedeutet, dass Sie einen Parameter mit demselben Namen auf verschiedenen Ebenen des Projekts erstellen und ihm jeweils unterschiedliche Werte zuweisen können. Bei einem Bauteilparameter löst Altium Designer dies in der folgenden Reihenfolge auf:
-
Bauteilparameter (höchste Priorität)
-
Variante
-
Schaltplandokument
-
Blattsymbol (um den Parameterwert des übergeordneten Blattsymbols anzuzeigen, wählen Sie die Registerkarte Compiled am unteren Rand des Designbereichs aus)
-
Projekt
Die meisten Optionen und Bedienelemente dieses Panels sind selbsterklärend und bedürfen keiner weiteren Erläuterung. Eine Ausnahme wird nachfolgend beschrieben.
-
Allow Synchronization with Database (nur im Dialog Preferences ) – Aktivieren Sie diese Option, um die Synchronisierung mit der Datenbank zu ermöglichen. Mit dieser Option wird gesteuert, ob der Kommentar aktualisiert werden kann. Standardmäßig sind diese Optionen aktiviert, damit die Synchronisierung mit der Quellbibliothek bzw. Quelldatenbank stets zulässig ist. Sie können diese Option deaktivieren, um zu verhindern, dass dieser Kommentar in einen Aktualisierungsvorgang einbezogen wird.
Verwenden des Parameter Managers
Benutzerdefinierte Designattribute werden Ihrem Design mithilfe von Parametern hinzugefügt. Parameter können einzeln hinzugefügt und bearbeitet werden. Alternativ können Sie den Dialog Parameter Table Editor (Tools » Parameter Manager) verwenden, um Parameter im gesamten Design oder in einer gesamten Bibliothek hinzuzufügen und zu bearbeiten. Diese Parameter gehören zu verschiedenen Objektarten in den Quellschaltplandokumenten des aktiven Projekts oder zu Bauteilen in der aktiven Bibliothek. So lassen sich alle Parameter schnell und effizient an einer zentralen Stelle zur Bearbeitung zusammenführen. Dabei können Sie einen Engineering Change Order erstellen, um Ihre Parameteränderungen direkt auf jedes betroffene Designobjekt anzuwenden, zu dem die Parameter gehören.
Wenn Sie den Dialog öffnen, werden sämtliche Parameterdaten des gesamten Designs erfasst und in einem tabellenartigen Raster dargestellt. Wenn der Dialog aus einem Schaltplan heraus aufgerufen wird, öffnet sich der Dialog Parameter Editor Options. Wählen Sie die Art der Parameter aus, die in den Dialog Parameter Table Editor geladen werden sollen. Wenn Sie beispielsweise Bauteilparameter bearbeiten, deaktivieren Sie im Bereich Include Parameters Owned By alle Optionen außer Parts. Über das Dropdown-Feld in der Mitte des Dialogs können Sie die einzubeziehenden Objekte weiter eingrenzen. Sie können alle Objekte, nur Objekte mit vorhandenen Parametern oder nur Objekte mit vorhandenen Parametern einbeziehen, die tatsächlich verwendet werden.
Wenn Sie beispielsweise Dokumentparameter bearbeiten, aktivieren Sie nur die Option Documents. Beachten Sie, dass die Option Exclude System Parameters unter anderem Bauteilmodelleinstellungen und in der Vorlage definierte Dokumentparameter umfasst. Sehen Sie sich diese Option genauer an, sobald Sie mit der Verwaltung von Parametern besser vertraut sind.
Wenn Sie nur die Parameter bestimmter Objekte im Design bearbeiten möchten, wählen Sie die gewünschten Objekte aus und aktivieren Sie die Option Selected Objects Only. Es werden nur Objekte aus Ihrer Auswahl einbezogen, sofern die entsprechende Objektart im Bereich Include Parameters Owned By des Dialogs aktiviert ist.
Nachdem Sie die benötigten Optionen ausgewählt haben, klicken Sie auf OK, um den Dialog Parameter Table Editor zu öffnen.
Die meisten Optionen und Felder des Dialogs sind selbsterklärend. Erläuterungen zu den übrigen finden Sie nachfolgend.
-
Remove Columns – Klicken Sie hier, um Spalten zu entfernen. Diese Option ist nur für Spalten mit statischen Informationen verfügbar.
-
Add Column – Klicken Sie hier, um eine Spalte hinzuzufügen. Der Dialog Add Parameter wird geöffnet, in dem Sie den Parameternamen festlegen können.
-
Reset Column Order – Klicken Sie hier, um die Spalten in alphabetischer Reihenfolge anzuzeigen.
-
Accept Changes (Create ECO) – Um diese Änderungen auf die Bauteile anzuwenden, muss ein ECO (Engineering Change Order) erzeugt werden. Klicken Sie hier, um den Dialog Engineering Change Order zu öffnen.
Kontextmenü
-
Revert – Klicken Sie hier, um Bearbeitungen für die ausgewählten Zellen rückgängig zu machen.
-
Add – Klicken Sie hier, um der ausgewählten Zelle Informationen hinzuzufügen. Wählen Sie die gewünschten Informationen aus der daraufhin angezeigten Dropdown-Liste aus.
-
Rename Column - Klicken Sie hier, um den Dialog Vorhandenen Parameter umbenennen zu öffnen, in dem Sie einen vorhandenen Parameter umbenennen können.
-
Remove Columns - Klicken Sie hier, um die ausgewählte Spalte zu löschen.
-
Report - Klicken Sie hier, um den Dialog Report Preview zum Erstellen eines Berichts zu öffnen.
-
Cross Probe - Klicken Sie hier, um das ausgewählte Objekt per Cross-Probing zu lokalisieren. Das ausgewählte Objekt wird im Schaltplanblatt hervorgehoben.
Hinweise
-
Sie können Spalten im Tabellenbereich per Drag-and-drop verschieben, um ihre Anzeigereihenfolge zu ändern. Die neue Reihenfolge wird in der Projektdatei gespeichert und beim erneuten Öffnen des Dialogs beibehalten.
-
Parameter können auf folgende Weise vor Aktualisierungen geschützt werden:
- Aktivieren Sie auf der Ebene einzelner Bauteilparameter die Option Lock Parameter im Modus Component des Panels Properties (durch Doppelklicken auf ein Bauteil zugänglich). Mit der Option Allow Synchronization With Database wird außerdem gesteuert, ob der Kommentar aktualisiert werden kann. Standardmäßig ist diese Option aktiviert, um die Synchronisierung mit der Quellbibliothek/-datenbank immer zuzulassen. Sie können diese Option deaktivieren, um den Kommentar von Aktualisierungen auszuschließen.
- Auf der Ebene der Datenbankverknüpfung enthält der Bereich Field Mapping des jeweiligen Datenbankverknüpfungsdokuments (Datei vom Typ *.DbLink, *.DbLib oder *.SvnDbLib) mehrere Optionen, die steuern, ob Parameter aktualisiert werden können, darunter Update Values, Add to Design und Remove from Design.
Verwenden Sie diesen Dialog, um Parameter im gesamten Projekt hinzuzufügen, zu bearbeiten und zu entfernen. Über den Dialog können Sie vorhandene Parameter im Projekt direkt bearbeiten oder Parameteraktualisierungen aus einer verknüpften Datenbank konfigurieren (verknüpft über eine DbLink-, DbLib- oder SvnDbLib-Datei). Beachten Sie, dass diese Dateien zur Datenbankbibliotheksverknüpfung Optionen enthalten, die steuern, ob ein Parameter aktualisiert werden soll oder nicht. Die Änderungen werden anschließend über einen Engineering Change Order umgesetzt, den Sie in diesem Dialog erstellen.
Parameter hinzufügen
Um einen neuen Parameter hinzuzufügen, klicken Sie auf die Schaltfläche (oder klicken Sie mit der rechten Maustaste an eine beliebige Stelle in der Haupttabelle und wählen Sie im Kontextmenü den Befehl Add Column). Der Dialog Add Parameter wird geöffnet. Wenn Sie den neuen Parameter lediglich erstellen möchten, ohne den Objekten Werte zuzuweisen, geben Sie den gewünschten Namen ein und klicken Sie auf OK. Wenn Sie den Parameter mit einem bestimmten Wert zu allen Objekten hinzufügen möchten, aktivieren Sie die Option Add to all objects, geben Sie den gewünschten Wert ein und klicken Sie anschließend auf OK. Eine Spalte für den neuen Parameter wird am Ende der vorhandenen Spalten hinzugefügt (ganz rechts in der Liste).
Parameter umbenennen
Um einen Parameter umzubenennen, klicken Sie mit der rechten Maustaste auf eine Zelle in der umzubenennenden Spalte und wählen Sie anschließend Rename Column aus dem Dropdown-Menü. Der Dialog Rename Existing Parameter wird geöffnet. Geben Sie den neuen Namen in das Feld Enter the new name for the parameter ein und klicken Sie anschließend auf OK. Beachten Sie, dass sich die Spaltenüberschrift geändert hat und nun ein kleines blaues Dreieck neben dem Namen angezeigt wird. Dieses Symbol zeigt an, dass der Wert dieser Zelle geändert wurde.

Der Dialog Rename Existing Parameter
Parameter zu ausgewählten Bauteilen hinzufügen
Um einen Parameter zu Bauteilen hinzuzufügen, wählen Sie die Zellen im Dialogeditor Parameter Table Editor mithilfe der Tastenkombinationen Shift+Click oder Ctrl+Click aus, klicken Sie mit der rechten Maustaste und wählen Sie anschließend Add aus dem Dropdown-Menü. Nach der Auswahl von Add wird in jeder Zelle ein kleines grünes Pluszeichen angezeigt. Dies zeigt an, dass ein neuer Parameter hinzugefügt wurde.
Nachdem der Parameter hinzugefügt wurde, können Sie den Bauteiltyp für jedes Bauteil festlegen. Der Dialog Parameter Table Editor unterstützt die üblichen Tastenkombinationen zur Tabellenbearbeitung. Drücken Sie F2, um eine Zelle zu bearbeiten, und anschließend Enter , um die Änderung zu übernehmen. Sie können mehrere Zellen bearbeiten, indem Sie die Zellen auswählen, dann mit der rechten Maustaste klicken und Edit aus dem Menü wählen. Geben Sie den neuen Wert ein und drücken Sie anschließend Enter , um die Änderung auf alle ausgewählten Zellen anzuwenden.
Parameteränderungen übernehmen
Die soeben vorgenommenen Parameteränderungen sind derzeit im Dialog Parameter Table Editor gespeichert und wurden noch nicht auf die Bauteile in den Schaltplanblättern angewendet. Um diese Änderungen auf die Bauteile anzuwenden, müssen Sie einen ECO erstellen und diesen anschließend auf das Design anwenden. Klicken Sie im Dialog Parameter Table Editor auf die Schaltfläche Accept Changes (Create ECO) . Der Dialog Parameter Editor Table wird geschlossen und der Dialog Engineering Change Order geöffnet.
Klicken Sie auf die Schaltfläche Validate Changes, um zu prüfen, ob die Änderungen angewendet werden können. Wenn sie gültig sind, wird in der Spalte Check ein grünes Häkchen angezeigt.
Klicken Sie auf Execute Changes, um die Parameteränderungen auf die Bauteile anzuwenden. Schließen Sie nach dem Anwenden der Änderungen den Dialog Engineering Change Order .
).
).







