Arbeiten mit Direktiven in einem Schaltplan

Altium Training

Altium Essentials: Schematic Updating

This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.

Auf einen Blick

Dieser Artikel erklärt, wie Design-Direktiven in Schaltplänen in Altium Designer funktionieren. Im Mittelpunkt stehen dabei Direktiven, die bei der Validierung verwendet werden oder Informationen vom Schaltplan an die Leiterplatte übergeben. Er zeigt, warum Direktiven besonders bei noch nicht abgeschlossenen Designs nützlich sind – vor allem, um ablenkende Validierungsmeldungen aufgrund unvollständiger Schaltungen zu reduzieren. Sie erfahren, worin sich der Einsatz von No ERC für bestimmte Regelverletzungen und die Verwendung einer Compile-Maske zum Ausblenden eines größeren, noch unfertigen Bereichs bei der Validierung unterscheiden. Außerdem lernen Sie, wie sich diese Direktiven verhalten und wie sie sich in den Designablauf einfügen. Wenn Sie besser verstehen möchten, wie Sie die Validierung auf die wesentlichen Bereiche Ihres Schaltplans konzentrieren können, lohnt sich die Lektüre dieses Leitfadens.

- Erfahren Sie, was Design-Direktiven sind und wie sie bei der Schaltplanerfassung und Validierung eingesetzt werden.
- Lernen Sie, wann Sie No ERC und wann eine Compile-Maske verwenden sollten, um unerwünschte Validierungsmeldungen zu unterdrücken.
- Sehen Sie, wie Compile-Masken im Schaltplaneditor platziert, aktiviert, deaktiviert und bearbeitet werden.
Mit KI tiefer einsteigen:

Designanweisungen sind Objekte, die während der Schaltplanerfassung im Schaltplan platziert werden und mit denen sich Anweisungen festlegen lassen, die an andere Teile der Software weitergegeben werden. Verschiedene Designanweisungen stehen für die folgenden beiden Anwendungsbereiche zur Verfügung:

  • Anweisungen im Zusammenhang mit der automatischen Kompilierung von Quellschaltplandokumenten.
  • Anweisungen zur Weitergabe von Informationen, die auf einem Schaltplanblatt definiert sind, an die Leiterplatte.

In den folgenden Abschnitten werden diese Bereiche und die zugehörigen Anweisungen näher erläutert.

Anweisungen für die Kompilierung

Designs entwickeln sich im Laufe der Zeit weiter und werden schrittweise erfasst. Sobald ein Abschnitt ausreichend ausgearbeitet ist, möchte man ihn häufig unabhängig vom restlichen Design prüfen. Die Kompilierung eines einzelnen Schaltplandokuments (oder des gesamten Projekts) während der Erfassung führt oft zu einer Reihe von Fehlermeldungen, die durch noch nicht erfasste Schaltungsteile oder unvollständige Schnittstellenverdrahtungen zwischen Schaltungsfragmenten verursacht werden. Solche Meldungen haben keinen wirklichen Nutzen, da sie lediglich von den relevanten Informationen ablenken. Am schnellsten und einfachsten lassen sich diese Kompilierungsfehler durch das Platzieren von No ERC- oder Compile Mask-Anweisungen unterdrücken.

No ERC-Anweisung

Die No ERC-Anweisung wird an einem Knoten der Schaltung platziert, um alle gemeldeten Warnungen und/oder Fehler der elektrischen Regelprüfung zu unterdrücken, die bei der Validierung des Schaltplanprojekts erkannt werden. Weitere Informationen finden Sie auf der Seite Validieren Ihres Designprojekts.

Compile Mask-Anweisung

No ERC-Anweisungen eignen sich hervorragend zum Unterdrücken einer geringen Anzahl von Regelverletzungen an Pins, Ports, Schaltplanblatteingängen oder Netzen innerhalb eines Designs. In manchen Fällen ist es jedoch sinnvoll, einen ganzen Bereich des Designs einschließlich der Bauteile auszuschließen. Verwenden Sie eine Compile Mask-Anweisung (Befehl Place » Directives » Compile Mask) oder klicken Sie im Dropdown-Menü für Anweisungen auf der Active Bar auf die Schaltfläche „Compile Mask“ (), um den darin enthaltenen Designbereich für den Compiler auszublenden. So können Sie die Fehlerprüfung für Schaltungsteile manuell verhindern, die möglicherweise noch nicht vollständig sind und von denen Sie wissen, dass sie Kompilierungsfehler verursachen werden. Dies ist besonders hilfreich, wenn Sie das aktive Dokument oder Projekt kompilieren müssen, um die Integrität des Designs in bestimmten anderen Bereichen zu prüfen, ohne durch Compiler-Meldungen zu unfertigen Designabschnitten abgelenkt zu werden.

Wie der Name bereits vermuten lässt, weist diese Anweisung den Compiler an, alle Objekte zu ignorieren, die completely innerhalb der Grenzen der definierten Maske liegen. Platzieren Sie die Maske genauso wie ein Notiz- oder Rechteckobjekt.

Betrachten Sie die Beispielschaltung in der folgenden Abbildung, bei der die Verdrahtung des Bauteils LCD1 noch nicht vollständig ist. Wenn nur dieser Schaltplan kompiliert wird (Project » Validate PCB Project), führt dies zu zahlreichen Meldungen über Regelverletzungen (siehe unten), die jeweils durch die unvollständige Schaltung verursacht werden. Bewegen Sie den Mauszeiger über das Bild, um zu sehen, wie sich das Platzieren einer Compile Mask-Anweisung um die unvollständige Schaltung auswirkt. Diese Regelverletzungen werden vom Compiler ignoriert, während der restliche, vollständig verdrahtete Teil der Schaltung auf dem Schaltplan geprüft wird. Beachten Sie, dass tatsächlich maskierte Objekte – also solche, die vollständig innerhalb des Begrenzungsrechtecks der Maske liegen – ausgegraut dargestellt werden.

Bewegen Sie den Mauszeiger über das Bild, um zu sehen, wie eine Compile Mask-Anweisung Compiler-Meldungen zu Regelverletzungen aufgrund unvollständiger Schaltungen ausblendet.
Bewegen Sie den Mauszeiger über das Bild, um zu sehen, wie eine Compile Mask-Anweisung Compiler-Meldungen zu Regelverletzungen aufgrund unvollständiger Schaltungen ausblendet.

Eine Kompilierungsmaske kann entweder ausgeklappt (vollständiger Rahmen) oder eingeklappt (kleines Dreieck) angezeigt werden. Diese Modi entsprechen einer aktivierten bzw. deaktivierten Maske. Klicken Sie auf die obere linke Ecke einer platzierten Kompilierungsmaske, um den Anzeigemodus umzuschalten. Diese Funktion kann hilfreich sein, wenn Simulationen Bestandteil des Designablaufs sind: Weitere Informationen.
Kompilierungsmasken können zwar gedreht oder an der X- bzw. Y-Achse gespiegelt werden, dies hat jedoch keine Auswirkungen auf die Ausrichtung der darin enthaltenen Schaltung.

Leiterplattenbezogene Direktiven

Als einheitliche Designumgebung bietet Altium Designer die Möglichkeit, Leiterplattenanforderungen bereits vor dem Leiterplattenlayout festzulegen. Dazu werden Parameter zu Objekten auf den Schaltplanblättern hinzugefügt und entsprechend definiert.

Bei bestimmten Schaltplanobjekten – etwa Bauteilen, Blattsymbolen, Ports usw. – werden die entsprechenden Parameter als Teil der Objekteigenschaften hinzugefügt. Bei Netzobjekten wie Leitungen und Bussen können Parameter nicht direkt als Eigenschaft der Leitung oder des Busses hinzugefügt werden. Stattdessen werden die zur Aufnahme der Informationen erforderlichen Parameter mithilfe spezieller Designdirektiven festgelegt.

Die folgenden Informationen können mithilfe von Direktiven festgelegt werden und werden bei der Designsynchronisierung in die entsprechenden leiterplattenbezogenen Definitionen übertragen:

  • Vorgaben für das Leiterplattenlayout
  • Differenzielle Paare
  • Netzklassen

Durch das Einbinden von Design-Direktiven in den Schaltplan können Entwicklungsingenieure explizite Designvorgaben festlegen und sicherstellen, dass der Schaltplan die maßgebliche Dokumentation des Designs bleibt. Änderungen am Design werden ausschließlich im Schaltplan vorgenommen und anschließend auf die Leiterplatte übertragen. Dies kann besonders wichtig sein, wenn mehrere Personen an einem Design arbeiten – insbesondere, wenn sie sich an unterschiedlichen Standorten befinden.  Statt sich über lange E-Mail-Verläufe oder Telefonate abzustimmen, kann die für die Schaltplanerfassung zuständige Person sicherstellen, dass bestimmte Vorgaben während der Layoutphase tatsächlich berücksichtigt werden.

Das Herzstück dieser Funktionalität ist die Parametersatz-Direktive.

Dabei handelt es sich im Wesentlichen um benutzerdefinierte Parametersatz-Objekte, die einem Netzobjekt innerhalb eines Schaltplandesigns zugeordnet werden können. Platzieren Sie eine PCB-Layout-Direktive auf einer Leitung, einem Bus oder einem Signal-Harness, um eine oder mehrere Designvorgaben für die zugehörigen Netze festzulegen. Wenn aus dem Schaltplan eine Leiterplatte erstellt wird, werden die Informationen in der PCB-Layout-Direktive verwendet, um entsprechende PCB-Designregeln zu erstellen. Die durch eine PCB-Layout-Direktive festgelegten Informationen gelten nur für das Netz bzw. die Gruppe von Netzen, mit denen die Direktive verbunden ist.

Eine Parametersatz-Direktive.
Eine Parametersatz-Direktive.

Sie dient als Container für eine beliebige Anzahl von Parametern, die für das Netz gelten, mit dem die Parametersatz-Direktive verbunden ist. Eine standardmäßige Parametersatz-Direktive ohne Parameter kann platziert werden (Place » Directives » Parameter Set), und die entsprechenden Parameter können später hinzugefügt werden. In den folgenden Abschnitten wird die Verwendung dieser parameterbasierten Direktiven näher erläutert. Es stehen sowohl benutzerdefinierte (Parametersatz) als auch vordefinierte (Differenzpaar) Parametersatz-Direktiven zur Verfügung. Der einzige Unterschied zwischen einem leeren und einem vordefinierten Parametersatz besteht darin, dass die vordefinierten Parametersätze einen Parameter enthalten, wie nachfolgend beschrieben.

Weitere Informationen zur Verwendung von Differenzpaar-Direktiven finden Sie auf der Seite Definieren von Differenzpaaren in Ihren Schaltplänen.

Moving from Directives to the Constraint Manager

Der ursprüngliche Ansatz zur Definition der Designanforderungen bestand darin, diese im Schaltplan- und im PCB-Editor getrennt zu verwalten: Im Schaltplan-Editor werden sie durch Direktiven und im PCB-Editor durch Designregeln definiert. Diese Trennung wurde mit der Einführung des Constraint Managers aufgehoben, eines separaten Editors zur Definition der Designanforderungen, in dem diese in jeder Phase des Designprozesses konfiguriert und bearbeitet werden können. Für ein bestimmtes Projekt kann nur einer der beiden Ansätze verwendet werden. Eine einfache Möglichkeit zur Überprüfung besteht darin, im Menü Design nach einem Eintrag Constraint Manager zu suchen. Ist dieser nicht vorhanden (und gibt es stattdessen im Menü Design des PCB-Editors einen Eintrag Rules), verwendet das Projekt den älteren Ansatz mit Designregeln.

Wenn der Constraint Manager verwendet wird, werden Netzklassen, Differenzpaare, Differenzpaarklassen und Regeln, die mithilfe von Parametersatz- und Differenzpaar-Direktiven definiert wurden, beim Aktualisieren der Leiterplatte aus dem Schaltplan not erkannt und übertragen. Es werden nur die im Constraint Manager definierten Netzklassen, Differenzpaare, Differenzpaarklassen und Regeln übertragen.

Beachten Sie, dass Sie Regeln, Netzklassen, Differenzpaare und Differenzpaarklassen aus in Schaltplänen platzierten Direktiven importieren können. Verwenden Sie dazu den Befehl Import from Directives aus dem Kontextmenü der Ansicht Physical oder Electrical des Constraint Manager, wenn dieser aus dem Schaltplan heraus geöffnet wurde – mehr erfahren. Beachten Sie, dass nach dem Importieren von Daten aus Direktiven in den Constraint Manager und dem Speichern dieser Änderungen die importierten Direktiven im Schaltplan-Arbeitsbereich durch ihre blaue Farbe (und ein leicht abweichendes Symbol) gekennzeichnet werden. Dies zeigt an, dass der einseitige Übergang von den Direktiven zum Constraint Manager erfolgt ist. Die blauen Direktiven sind dann schreibgeschützte Objekte und können nicht weiter bearbeitet werden.

Parametersatz-Direktiven platzieren

Platzieren Sie eine Direktive dieses Typs, indem Sie den Befehl Place » Directives » Parameter Set im Hauptmenü oder im Kontextmenü des Designbereichs auswählen. Beim Platzieren einer standardmäßigen Parametersatz-Direktive sind noch keine Parameter vorhanden. Ein Parametersatz ist eine Design-Direktive, mit der sich Designvorgaben einem netzartigen Objekt innerhalb eines Schaltplandesigns zuordnen lassen. Verwenden Sie beispielsweise einen Parametersatz, um zwei Netze als Mitglieder eines differenziellen Paars zu deklarieren. Anhand bestimmter benannter Parameter im Parametersatz erkennt die Software, welche Design-Direktive Sie platzieren.

Neben benutzerdefinierten Parameter-Direktiven lässt sich eine regelbasierte Parameter-Direktive im Dialogfeld Choose Design Rule Type definieren, das über den zugehörigen Modus des Panels Properties für den Parameter zugänglich ist. Gehen Sie dazu wie folgt vor:

  1. Drücken Sie vor dem Platzieren des Parametersatzes Tab oder doppelklicken Sie auf eine bereits platzierte Parametersatz-Direktive, um deren Eigenschaften im Panel Properties anzuzeigen.

  2. Klicken Sie anschließend im Bereich Parameters des Panels Properties auf die Schaltfläche  und wählen Sie in der Dropdown-Liste Rule, um im Dialogfeld Select Design Rule Type eine Regel auszuwählen.

Den Wert einer Regel bearbeiten.
Den Wert einer Regel bearbeiten.

Wählen Sie im Dialogfeld Select Design Rule Type den Regeltyp aus, den Sie der Direktive als Regelparameter hinzufügen möchten. Durch Doppelklicken auf einen Regeltyp öffnen Sie das entsprechende Dialogfeld Edit PCB Rule (From Schematic), in dem Sie die Randbedingungen für die Regel festlegen können.

Welche Eigenschaften im Dialogfeld Edit PCB Rule (From Schematic) verfügbar sind, hängt von der ausgewählten Designregel ab. Sie entsprechen den Eigenschaften, die für diese Regel im PCB-Editor definiert sind.

Die folgende Abbildung zeigt beispielsweise das Dialogfeld Edit PCB Rule (From Schematic) für Max-Min Width Rule. Hier können Sie die Einstellungen für Minimum/Vorzugswert/Maximum für alle Lagen konfigurieren, jede Breiteneinstellung für jede Lage manuell festlegen oder ein Impedanzprofil verwenden. Wenn Sie ein Impedanzprofil auswählen und der tatsächliche physische Leiterplattenaufbau bereits im PCB-Editor definiert wurde, können Sie auch die Leiterplattendatei für Load the PCB Layer Stack and calculate the track width values auswählen.

Wenn die Leiterplatte vorhanden und der Lagenaufbau definiert ist, können die berechneten Breiten in den Schaltplan geladen werden.Wenn die Leiterplatte vorhanden und der Lagenaufbau definiert ist, können die berechneten Breiten in den Schaltplan geladen werden.

Die oben gezeigte Regel wurde auf eine Netzklasse angewendet. Dazu wurde eine Blanket-Direktive mit einer angehängten PCB-Routing-Direktive platziert, um die Netze zu einer Klasse zusammenzufassen. Anschließend wurde die Regel für maximale und minimale Breite auf diese Klasse angewendet ().

Ausführliche Informationen zu den einzelnen PCB-Designregeln und Randbedingungen finden Sie hier.

Wählen Sie im Dropdown-Feld Measurement Units die Einheit Metric oder Imperial aus.

Randbedingungen für eine ausgewählte Regel festlegen.
Randbedingungen für eine ausgewählte Regel festlegen.

Der Eintrag im Bereich Parameters enthält den ausgewählten Regeltyp sowie die festgelegten Randbedingungen. Die folgende Abbildung zeigt die definierten Parameter der Breitenregel für eine Parameter Set-Direktive. Um die Regel im Designbereich anzuzeigen, klicken Sie im Bereich Rules auf das Sichtbarkeitssymbol ().

Mehrere durch eine Parametersatz-Direktive definierte Regelvorgaben für ein bestimmtes Netz.
Mehrere durch eine Parametersatz-Direktive definierte Regelvorgaben für ein bestimmtes Netz.

Wenn das Design im Rahmen der Synchronisierung auf die Leiterplatte übertragen wird, werden die entsprechenden Designregeln anhand der in einer Direktive enthaltenen Informationen erstellt. Das Wort Schematic wird im Namen jeder generierten Regel verwendet, um die Herkunft der Regel kenntlich zu machen.

Generierte Designregeln auf der PCB-Seite.
Generierte Designregeln auf der PCB-Seite.

Denken Sie daran, dass Sie derselben Parametersatz-Direktive mehrere Parameter hinzufügen können, um den Schaltplan übersichtlicher zu gestalten.

Netzklassen-Direktiven platzieren

Mit einer Netzklassen-Direktive können Sie benutzerdefinierte Netzklassen im Schaltplan erstellen. Sie können eine Netzklassen-Direktive platzieren, indem Sie den Befehl Place » Directives » Parameter Set in den Hauptmenüs auswählen und anschließend den Parametersatz als Netzklassen-Direktive definieren, wie in Tipp Nr. 2 auf der Seite zum Befehl beschrieben. Wenn aus dem Schaltplan eine Leiterplatte erstellt wird, werden die Informationen in einer Netzklassen-Direktive verwendet, um die entsprechende Netzklasse auf der Leiterplatte zu erstellen. Um ein Netz einer Netzklasse zuzuordnen, hängen Sie eine Netzklassen-Direktive an die entsprechende Verbindung, den Bus oder den Signal-Harness an und setzen Sie den Parameter ClassName der Direktive auf den Namen der gewünschten Klasse. Die Option Generate Net Classes (für benutzerdefinierte Klassen) muss auf der Registerkarte „Class Generation“ im Dialogfeld „Project Options“ aktiviert sein, um diese Funktion nutzen zu können.

Wenn für ein Netz eine Netzklassen-Direktive definiert wurde, erhalten alle PCB-Designregeln, die ebenfalls von diesem Parametersatz-Objekt erstellt werden, beim Übertragen des Designs in den PCB-Editor den Geltungsbereich „Netzklasse“. Sie können aus einer platzierten Parametersatz-Direktive eine Netzklassen-Direktive erstellen, indem Sie eine Klasse hinzufügen, deren Wert auf die gewünschte PCB-Netzklasse gesetzt werden muss.

Netzklassen lassen sich zwar auch im PCB-Editor erstellen, doch die logische Funktion oder Gruppierung von Netzen ist im Schaltplan meist deutlich besser erkennbar. Daher ist es sinnvoller, den Prozess von dort aus zu steuern.

Wenn das Design im Rahmen der Synchronisierung auf die Leiterplatte übertragen wird, werden die entsprechenden Netzklassen anhand der in einer Direktive enthaltenen Informationen erstellt.

Hängen Sie eine Netzklassen-Direktive an ein Blanket-Objekt an, um eine Netzklasse zu erstellen, deren Mitglieder die einzelnen von diesem Blanket erfassten Netze sind. Wenn an dieses Blanket auch eine PCB-Layout-Direktive angehängt ist, beziehen sich deren Regelparameter auf diese Netzklasse und nicht auf jedes einzelne Netz. Beim Importieren der Änderungen in das PCB-Dokument wird dadurch pro Parameter eine einzige Designregel erstellt, deren Geltungsbereich auf die Netzklasse festgelegt ist.

Blanket-Direktiven platzieren

Parameter-Set-Direktiven können nur auf das jeweilige Netz angewendet werden, mit dem sie verbunden sind. In Kombination mit einer Blanket-Direktive lässt sich ihr Geltungsbereich jedoch auf alle Netze innerhalb des Blankets erweitern.

Platzieren Sie eine Direktive dieses Typs, indem Sie in den Hauptmenüs den Befehl Place » Directives » Blanket wählen. Beim Platzieren eines Blankets können Sie entweder eine einfache rechteckige oder eine polygonale Form definieren. Letztere ermöglicht eine präzisere Kontrolle darüber, welche Netzobjekte auf einem Schaltplanblatt erfasst werden.

Das Blanket kennzeichnet die betreffenden Netze – platzieren Sie eine Parameter Set-Direktive an einer beliebigen Stelle am Rand des Blankets, um Designanforderungen auf diese Netze anzuwenden. Damit die am Rand platzierte Direktive auf ein Netz unter einer Blanket-Direktive angewendet wird, muss ein mit diesem Netz verknüpftes Objekt – ein Pin, ein Port, ein Netzlabel, ein Versorgungsanschluss oder ein Leitungs-/Bus-/Harness-Segment (einschließlich beider Enden) – innerhalb der Grenzen des Blankets liegen. Beachten Sie, dass bei Netzkennungen wie Netzlabels der Hotspot innerhalb des Blankets liegen muss. Wenn zugehörige Netze nicht wie erwartet in das PCB-Parameter-Set übernommen werden, versuchen Sie, den Bereich des Blankets entsprechend anzupassen.

Um zu prüfen, auf welche Netze die Blanket-Direktive angewendet wird, heben Sie diese mit der Funktion Netzfarben hervor. Wählen Sie im Menü View » Set Net Colors die gewünschte Farbe und klicken Sie anschließend auf den Rand der gewünschten Blanket-Direktive. Um die Hervorhebung für ein bestimmtes Netz aufzuheben, verwenden Sie den Befehl View » Set Net Colors » Clear Net Color und klicken Sie anschließend auf das Netz, dessen Einfärbung Sie entfernen möchten. Um die Netzeinfärbung auf allen Schaltplanblättern zu entfernen, verwenden Sie den Befehl View » Set Net Colors » Clear All Net Colors.

Beispiel für die Verwendung einer Blanket-Direktive, um eine Parameter-Set-Direktive auf Netze innerhalb des Blankets anzuwenden.
Beispiel für die Verwendung einer Blanket-Direktive, um eine Parameter-Set-Direktive auf Netze innerhalb des Blankets anzuwenden.

Beispiele für die Verwendung einer Blanket-Direktive:

  • Anbringen einer Parameter-Set-Direktive an einem Blanket-Objekt, um ihre Regelparameter auf jedes einzelne vom Blanket erfasste Netz anzuwenden.
  • Anbringen einer Parameter-Set-Direktive an einem Blanket-Objekt, um ein Parameter-Set zu erstellen, dessen Mitglieder die einzelnen vom Blanket erfassten Netze sind.
  • Anbringen einer Differential-Pair-Direktive an einem Blanket-Objekt, um Differentialpaar-Objekte auf Grundlage der differentiellen Netze innerhalb dieses Blankets zu erstellen.
Bringen Sie eine Parameter-Set-Direktive an einem Blanket-Objekt an, um ihre Regelparameter auf jedes einzelne vom Blanket erfasste Netz anzuwenden. Wenn an diesem Blanket auch eine Parameter-Set-Direktive angebracht ist und das Parameter-Set außerdem einen Net-Class-Parameter enthält, gelten die Regelparameter der Parameter-Set-Direktive für diese Netzklasse und nicht für jedes einzelne Netz. Beim Importieren der Änderungen in das PCB-Dokument wird dadurch pro Parameter eine einzige Designregel erstellt, deren Geltungsbereich auf die Netzklasse festgelegt ist.
Sie können eine am Rand angebrachte Parameter-Set-Direktive auch kopieren und an einer anderen Blanket-Direktive oder sogar an einzelnen Leitungen, Bussen oder Harnesses anbringen. Dadurch werden alle zusätzlichen Netze, die derselben Parameter-Set-Direktive zugeordnet sind, derselben erzeugten PCB-Netzklasse hinzugefügt.

Ein Blanket kann in Verbindung mit einer Parameter-Set-Direktive auch verwendet werden, um Bauteilklassen und Parameter auf Bauteile anzuwenden, die vollständig innerhalb des vom Blanket definierten Bereichs liegen. Verwenden Sie dazu die Optionen Component Class und Parameter im Dropdown-Menü der Schaltfläche Add in den Eigenschaften der am Blanket angebrachten Parameter-Set-Direktive. Die Informationen zur Bauteilklasse und zum Parameter werden beim Aktualisieren der Leiterplatte im Rahmen des ECO-Prozesses in das PCB-Dokument des Projekts übertragen.

Indirekte (parameterbasierte) Direktiven

Parameter-Set-Direktiven sind erforderlich, wenn Designobjekte im Schaltplan adressiert werden sollen, die keine Parameter enthalten können. Bei Objekten, die Parameter enthalten können, lassen sich Designdirektiven hingegen indirekt anwenden, indem sie dem jeweiligen Schaltplanobjekt als Parameter hinzugefügt (und definiert) werden. Im Wesentlichen handelt es sich dabei um parameter-based directives.

Parameterbasierte Direktiven können beispielsweise verwendet werden, um die Höhe eines bestimmten Bauteils zu begrenzen oder eine Abstandsbedingung hinzuzufügen, die für alle Objekte im Design gilt. Der erforderliche Parameter, der die Bedingung definiert, wird dem Objekt als Regel hinzugefügt.

Bei der Synchronisierung mit der Leiterplatte werden parameterbasierte Direktiven, die Objekten im Schaltplan hinzugefügt wurden, in PCB-Designregeln umgewandelt. Der Geltungsbereich der entsprechenden PCB-Designregel wird durch die Art des Objekts bestimmt, dem der Parameter ursprünglich zugewiesen wurde. Die folgende Tabelle fasst die unterstützten Zuordnungen zwischen Schaltplanparametern und dem Geltungsbereich von PCB-Regeln zusammen.

Parameter (als Regel) hinzufügen zu … Über … Für den PCB-Regelgeltungsbereich …
Pin die Registerkarte Parameters im Pin-Modus des Properties-Panels. Pad
Port die Registerkarte Parameters im Port-Modus des Properties-Panels. Netz
Bauteil den Bereich Parameters im Components-Modus des Properties-Panels. Bauteil
Schaltplansymbol die Registerkarte Parameters im Sheet Symbol-Modus des Properties-Panels, wenn im Bereich Source die Option Local ausgewählt ist. Bauteilklasse
Device-Schaltplansymbol die Registerkarte Parameters im Sheet Symbol-Modus des Properties-Panels, wenn im Bereich Source die Option Device ausgewählt ist. Bauteilklasse
Verwaltetes Schaltplansymbol den Bereich Parameters im Sheet Symbol-Modus des Properties-Panels, wenn im Bereich Source die Option Managed ausgewählt ist. Bauteilklasse
Schaltplanblatt die Registerkarte Parameters im Document Options-Modus des Properties-Panels. Alle Objekte

Das Vorgehen zum Hinzufügen eines regelbasierten Parameters ist in allen Fällen gleich. Führen Sie auf der jeweiligen Registerkarte bzw. im jeweiligen Dialog folgende Schritte aus:

  1. Fügen Sie einen Parameter als Regel hinzu.
  2. Wählen Sie den zu verwendenden Regeltyp aus.
  3. Konfigurieren Sie die Bedingungen für den ausgewählten Regeltyp.
Wenn Sie Objekten in einem Schaltplan Designregelparameter hinzufügen, erhält jeder Regelparameter eine eindeutige ID. Die entsprechenden Designregeln, die auf der Leiterplatte erstellt werden, erhalten dieselben IDs. Mithilfe dieser eindeutigen ID können die Bedingungen einer Regel sowohl im Schaltplan als auch auf der Leiterplatte bearbeitet und die Änderungen bei der Synchronisierung übertragen werden.

Bauteilklassen festlegen

Auf ähnliche Weise können Bauteilklassen im Schaltplan definiert werden, indem den betreffenden Bauteilen ein Parameter ClassName hinzugefügt und dessen Wert auf den gewünschten Klassennamen gesetzt wird. Wenn das Design auf die Leiterplatte übertragen wird, werden die definierten Bauteilklassen erstellt.

Damit die im Schaltplan definierten Bauteilklassen auf die Leiterplatte übertragen werden, müssen im Dialog Project Options die folgenden Optionen eingestellt werden:

  • Aktivieren Sie die Option Generate Component Classes im Bereich User-Defined Classes auf der Registerkarte Class Generation des Dialogs.
  • Setzen Sie auf der Registerkarte Comparator des Dialogs die Einstellung Differences Associated with Components » Extra Component Classes Mode auf Find Differences.

Die oben aufgeführte Option auf der Registerkarte Class Generation ist in der folgenden Abbildung dargestellt. Bewegen Sie den Mauszeiger über die Abbildung, um die Optionseinstellung auf der Registerkarte Comparator anzuzeigen.

Um Bauteilklassen auf die Leiterplatte zu übertragen, aktivieren Sie die Option Generate Component Classes auf der Registerkarte Class Generation. Bewegen Sie den Mauszeiger über die Abbildung, um die Registerkarte Comparator anzuzeigen, auf der Sie die Einstellung Extra Component Classes Mode auf Find Differences setzen müssen.
Um Bauteilklassen auf die Leiterplatte zu übertragen, aktivieren Sie die Option Generate Component Classes auf der Registerkarte Class Generation. Bewegen Sie den Mauszeiger über die Abbildung, um die Registerkarte Comparator anzuzeigen, auf der Sie die Einstellung Extra Component Classes Mode auf Find Differences setzen müssen.

Nach ihrer Definition können Klassen im Bereich Properties des Panels Properties der jeweiligen Bauteileigenschaften gesperrt werden.

Im PCB-Editor kann ein Bauteil mehreren Bauteilklassen angehören. Um dies im Schaltplan zu definieren, trennen Sie die Namen der einzelnen PCB-Bauteilklassen im Parameterwert des Schaltplanbauteils durch Kommas (Abbildung anzeigen).

Drucken von Direktiven steuern

Standardmäßig werden beim Drucken der Schaltplanblätter alle Designdirektiven mit ausgegeben. Dies lässt sich jedoch ändern:

Steuern Sie den Druck von Direktiven nach Bedarf. Bei No-ERC-Direktiven können Sie bestimmte Symbolstile drucken und andere ausschließen.
Steuern Sie den Druck von Direktiven nach Bedarf. Bei No-ERC-Direktiven können Sie bestimmte Symbolstile drucken und andere ausschließen.

AI-LocalizedKI-lokalisiert
Wenn Sie ein Problem feststellen, wählen Sie den Text/das Bild aus und drücken SieCtrl + Enter, um uns Ihr Feedback zu senden.
Nav
Contents
Funktionsverfügbarkeit

Die Ihnen zur Verfügung stehenden Funktionen hängen davon ab, über welche Altium-Lösung Sie verfügen – Altium Develop, Altium Agile Teams, Altium Agile Enterprise oder Altium Designer (mit aktivem Laufzeitvertrag).

Wenn Sie eine dokumentierte Funktion in Ihrer tatsächlich verwendeten Software nicht sehen, wenden Sie sich an den Altium-Vertrieb, um mehr zu erfahren.

Legacy-Dokumentation

Die Dokumentation von Altium Designer wird nicht mehr versioniert. Wenn Sie auf Dokumentation für ältere Versionen von Altium Designer zugreifen müssen, besuchen Sie den Abschnitt Legacy-Dokumentation auf der Seite Andere Installer.

Contents