Creating a Harness Wiring Component for Use with Harness Design in Altium Designer

Created: May 9, 2023 | Updated: September 15, 2023
Applies to Altium Designer versions: 23 and 24

Parent page: Harness Design

Note that Harness Design functionality is not supported with the Altium Designer Standard Subscription.

You can define the connectivity on your Harness Wiring Diagram not only by placing wires one-by-one and then changing their properties (and adding cable, shield and twist objects), but also by creating components with predefined structure and properties as required, which are then placed into the Wiring Diagram document from your Altium 365 Workspace library. Such a component is created in the Component Editor (in its Single Component Editing or Batch Component Editing mode) by adding/defining a Harness Wiring model for it and then saving the component to your connected Altium 365 Workspace.

Creation Using the Component Editor (Single Component Editing Mode)

To create a new component:

  1. Select the File » New » Component command from the main menus. Alternatively, select File » New » Library from the main menus, then select Create Library Content » Component from the Workspace region of the New Library dialog that opens.
  2. In the Create new component dialog that opens, choose a component type. If there is a component template linked to the selected component type, this template will be used to predefine the component with the data from it.

    • If a component type is referenced by multiple Component Templates, these Templates will be presented under the entry of this component type.
    • If a Component Template has no default component type defined, it will be presented under the <Undefined> entry of the Create new component dialog.

    Access the Create new component dialog to select the type of component to be created.
    Access the Create new component dialog to select the type of component to be created.

  3. Click OK in the dialog to access the Component Editor in its Single Component Editing Mode. Use the Component, Parameters and Part Choices regions of the Component Editor to define the key properties of the component, component parameters and part choices, respectively. Refer to the ComponentParameters and Part Choices sections of the Single Component Editing page to learn more.

    Define key component data in the Component, Parameters and Part Choices regions of the Component Editor.
    Define key component data in the Component, Parameters and Part Choices regions of the Component Editor.

  4. When the current component definition does not include any model, the Add Harness Wiring entry will be available in the Models region of the Component Editor. Click the drop-down icon on the button below the entry and choose New from the associated menu to create a new Harness Wiring model or Existing to select a Harness Wiring model created and saved to the connected Workspace previously.

    Create a new Harness Wiring model or add an existing one.
    Create a new Harness Wiring model or add an existing one.

    If a symbol, footprint or simulation model is added to the component definition, the Add Harness Wiring entry will not be shown.
  5. When the New option is selected, a temporary Harness Wiring model editor will open in the design space. Use the editor to define the wiring structure you would like to reuse in your harness designs. Place one or more Harness Wire objects with the properties configured as required. Add Cable, Shield and Twist objects if needed.

    An example Harness Wiring model defined in the temporary editor.
    An example Harness Wiring model defined in the temporary editor.

  6. In the Symbol mode of the Properties panel (active when no object is selected in the design space), define the model Name as required.

  7. Once the Harness Wiring model is defined, save the changes by selecting the File » Save command from the main menus and close the editor by right-clicking the model document tab and selecting the Close <ModelName> command from the context menu. The Harness Wiring model will appear linked back in the Models region of the Component Editor. Note that the Revision State field below the preview of the model will show Not released. Upon saving the component to the Workspace, the newly defined model will automatically be saved to the Workspace also, into the initial revision of a new Harness Wiring Item.

    The defined Harness Wiring model will be shown in the Component Editor.
    The defined Harness Wiring model will be shown in the Component Editor.

  8. With the component defined, select the File » Save to Server command from the main menus to save the component to the Workspace. The Edit Revision dialog will appear, in which you can change Name and Description of the component and add release notes as required. The editor will close after the save.

Your new component will be available in the Components panel for placing in your Wiring Diagram documents: learn more.

Creation Using the Component Editor (Batch Component Editing Mode)

A component can also be defined using the Component Editor in its Batch Component Editing mode. When in this mode (which can be accessed by choosing the Tools » Switch to Batch Editor command from the main menus of the Component Editor in its Single Component Editing mode or by opening multiple components for editing), the Harness Wiring model can be added as follows:

  1. In the Required Models/Parameters region of the Editor, click the Add control and select HarnessWiring to specify that the Harness Wiring model is required by the components being defined.

    Add the Harness Wiring model entry to the list of required models.
    Add the Harness Wiring model entry to the list of required models.

  2. In the Required Models/Parameters region of the Editor, click the Add control and select HarnessWiring, then choose the Harness Wiring model through the Choose Models dialog that opens. Any number of model links may be added, including links to different revisions of the same model. In this way, add links to the required Harness Wiring models to be used by components being defined in the Editor.

    Add links to the required Harness Wiring models.
    Add links to the required Harness Wiring models.

  3. In the component definition region below, click within the HarnessWiring model cell and use the drop-down field to access the pop-up window, which presents a grid of added Harness Wiring model links. Double-click the required model entry to assign that model to the component definition.

    Assign an added model link to a component definition.
    Assign an added model link to a component definition.

    Note that if a component definition has other type models already assigned (for example, a schematic symbol or PCB footprint), you cannot assign a Harness Wiring model to that definition. The pop-up window with the list of added harness wiring models will not be available, and the corresponding tooltip will be shown when hovering the cursor over the cell in the HarnessWiring column for that component definition.

    To assign a Harness Wiring model to this component definition, other models must be removed from it – to do so, select the cell of the model to be removed and press Delete.

    Similarly, models of other types cannot be assigned to a component definition when a Harness Wiring model is assigned to this definition.

  4. Complete the component definitions with other required data (e.g., parameters, part choices and datasheets).
  5. Save the components to the Workspace by selecting the File » Save to Server command.

Editing a Harness Wiring Model

Harness Wiring models can be browsed using the Components panel. Enable visibility of models by clicking the  button at the top of the panel and selecting Models, then selecting the Harness Wirings category.

To edit an existing Harness Wiring model, right-click its entry in the Components panel and select the Edit command. The temporary editor will open, with the model opened for editing. Make changes as required, then save the document into the next revision of the Harness Wiring model.

You can also update the Harness Wiring model being used by a component directly on the fly as part of editing that component in the Component Editor in its Single Component Editing mode or Batch Component Editing mode.

When you make a change to a Harness Wiring model, the moment you save that change into a new revision of the model, any components that use that model will become effectively out of date, still using the previous revision. In most cases, you will no doubt want to re-save those components, with the respective model links updated to use the latest revisions available. To streamline this process, a Workspace, in conjunction with Altium Designer, facilitates the ability to update related components – at the point of re-saving a Workspace model – after having made any modifications to that model through the direct editing feature.

The option to perform this update to the parent components can be found in the Create Revision dialog that appears when saving the modified Harness Wiring model back to the target Workspace. This option – Update items related to <ModelItemRevision> – is enabled by default.

<ModelItemRevision> is the current revision of the model, that is, the revision currently being used by any related components. Once the Workspace model itself is saved, this would naturally be the previous (earlier) revision and no longer the latest.

Accessing the option to update related components referencing the Harness Wiring model being re-saved.
Accessing the option to update related components referencing the Harness Wiring model being re-saved.

If you want to keep all related components using the current revision of the Harness Wiring model, disable this option. Only the Harness Wiring model itself will then be saved.

Once you click OK in the Create Revision dialog, the modified Harness Wiring model is saved back to the Workspace, and its associated temporary editor is closed. All components referencing that Harness Wiring model will be re-saved to use its new revision automatically (the next revision of each component is automatically created and the save performed).

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Contact Us

Contact our corporate or local offices directly.

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
You are reporting an issue with the following selected text
and/or image within the active document: