Understanding Connectivity on Your PCB

In the PCB editor, the connectivity between the nodes in a net is represented by a series of point-to-point connection lines, which are collectively referred to as the ratsnest. When the design is transferred from the schematic (Design » Update PCB), the components are placed on the PCB design space and the connection lines are displayed (as thin, solid lines).

Within an individual net, the connection lines join all of the nodes in that net. The pattern, or order they connect, is called the Net Topology, which is discussed below.

The nodes in the net are connected by connection lines in accordance with the applicable Routing Topology rule (the default is Shortest).
The nodes in the net are connected by connection lines in accordance with the applicable Routing Topology rule (the default is Shortest).

In this design, the GND and 5V nets use a different color for their connection lines.
In this design, the GND and 5V nets use a different color for their connection lines.

As well as being a helpful guide during component placement, the connection lines are also a valuable guide during interactive routing and autorouting.

To learn more about how the connectivity is created in the schematic, refer to the Creating Circuit Connectivity in Your Schematics page.

The PCB editor includes a net analyzer that constantly monitors the location of all objects in the design space and updates the connection lines when any net-type object is edited (including an object being moved). For example, when a component is moved, the far end of each connection from that component can jump from one target pad to another target pad, as they are updated to maintain the topology defined by the applicable design rule. An example of this is shown for the GND net in the video below; this net has a topology of shortest.

Note how the GND connection lines jump around as the resistor is moved, automatically being rearranged to keep the shortest overall connection length.
Note how the GND connection lines jump around as the resistor is moved, automatically being rearranged to keep the shortest overall connection length.

Finding a Net on the Board

An un-routed board can appear intimidating - a mass of connection lines crisscrossing all over the board. A good approach to routing is to work from the schematic, where you can easily locate important components and critical nets. You can cross-select and cross-probe directly from the schematic components and nets, highlighting the equivalent item on the PCB. Learn more about Working Between the Schematic and the Board.

A valuable feature is the PCB editor's ability to mask or dim objects in the design space. This filtering feature will fade out everything, except the object(s) that pass through the filter. The image below shows a single net has been selected, with the filtering system set to Dim all objects that do not pass the filter.

To explore this, set the PCB panel to Nets mode, this will display a list of nets on the board. Use the dropdown to set the filter mode to Dim or Mask, then enable the Select and Zoom options, as shown in the image below.

As you click on a net name in the panel the design space display will change, zooming to show the nodes in the net, and fading out everything except the pads and connection lines in the net - effectively pulling that net out from the rest of the board. Note that even when you click in the workspace the filter remains, the chosen net remains clearly visible, making it easy to examine or route.

Use the filter feature to make it easier to find a net or net class.
Use the filter feature to make it easier to find a net or net class.

Click the Clear button at the top of the PCB panel to clear the filter and restore the entire design space to normal brightness (or press the Shift+C shortcut).

Note that as well as an individual net, you can filter out a class of nets (if any classes are defined) in the Net Classes section of the panel, and also interactively select multiple nets (hold Ctrl as you click in the PCB panel to select a net name).

Browsing Nets

In the PCB panel's Nets mode, its three main regions change to reflect the net hierarchy of the current PCB design (in order from the top):

  • Net Classes, as defined by the board.
  • Individual member Nets within a class.
  • Individual Primitives within a Net (pads, vias, tracks, and fills).

Net Classes

In the top region of the panel (Net Classes), right-click on a net or net item entry then choose Properties from the subsequent menu (or double-click on the entry directly) to access the Edit Net Class dialog in which you can view or edit the net membership of the class, rename it, or add additional classes.

You can also manage net classes using the following commands of the Design » Netlist sub-menu of the main menus or the Net Actions sub-menu of the right-click menu of selected net object(s):

  • Create NetClass from Selected Nets - this command is used to create a new net class from two or more selected nets in the design space. After launching the command, the Object Class Name dialog will open. Use this to specify the required name for the new Net Class. After clicking OK, the net class will be created and the selected nets will be added as members.
  • Add Selected Net(s) to NetClass - this command is used to add one or more selected nets to an existing net class. After launching the command, the Choose Net Class dialog will open. This dialog lists all of the existing net classes. Select the target class then click OK. The net(s) will be added as members of that class.
  • Remove Selected Net(s) From NetClass - this command is used to remove one or more selected nets from an existing net class. After launching the command, the Choose Net Class dialog will open. This dialog lists all of the existing net classes. Select the target class then click OK. The net(s) will be removed as members from that class.

The Choose Net Class dialog
The Choose Net Class dialog

The easiest and quickest way to select nets (or rather the objects thereof) in the design space is to use the PCB panel configured in its Nets mode. Choose <All Nets> in the Net Classes region then select the required net(s) in the Nets region. Filtering is applied to the design workspace, leaving just those electrical objects associated with the chosen net(s) selected (make sure the Select option is enabled on the panel and also that the highlighting mode is either set to Mask or Dim). This makes it especially easier to distinguish the objects if using the right-click method of access.
To learn more about working with classes, refer to the Working with Classes on a Schematic & PCB page.

Nets

The middle region of the panel displays nets from the Net Class(es) selected in the region above.

The following information is listed with each Net by default:

  • - this feature has two functions:
    • Color background - the color assigned to the net. This color is always applied to the net's connection lines. It can also be applied to that net's routing using the net color display override feature. Double-click to edit the color for this net, or right-click to edit the color for all currently selected nets.
    • checkbox - check this to apply the color to the routing (enable the net color display override feature) for this net. Right-click to enable (or disable) the display override feature for all currently selected nets. Press F5 to enable/disable net color display override in the design space.

      See Net Color Override - Displaying the Net Color on Routed Nets to learn more.

  • Name - name of the net.
  • Node Count - the total number of pads in this net.
  • Routed Length - the sum of the lengths of the placed track and arc segments that form the routing, plus the vertical distance traversed through vias (see note below). The routed length calculator does not attempt to resolve overlapping track segments or routing wiggles inside pads.
  • Signal Length - accurate calculation of the total node-to-node distance. Placed objects are analyzed to: resolve stacked or overlapping objects and wandering paths within pads; and via lengths are included. If the net is not completely routed the Manhattan (X + Y) length of the connection line is also included.

    If there are Length design rules configured, the routed state of each net targeted by the rule is also colored, highlighted in yellow if the route length < rule minimum, clear if the net passes the rule, or red if the route length > rule maximum.

    The following notes apply to Signal Length calculations:

    • Resolves overlaps and wiggles inside pads.
    • Handles routing paths created with objects other than tracks and arcs (e.g., a region or a fill).
    • Includes vertical distances through vias (see note below).
    • Includes the Total Pin/Package Length for this net.
    • Includes the Un-Routed (Manhattan) Length for this net.
    • Failure to comply with applicable Length/Matched Length design rules is flagged by the signal length being displayed on a colored background: signal lengths that are too short in yellow, signal lengths that are too long in red.

      See Length Tuning to learn more about how the Length and Matched Length design rules are applied.

    • A signal is a point-to-point entity; for this reason, only nets with two nodes will show a Signal Length in the Nets mode of the panel (nets with other Node counts will display n/a). For nets with more than two nodes, define xSignals to calculate their signal length.

      See PCB - xSignals.

      See Defining High Speed Signal Paths with xSignals to learn more about xSignals.

    • Total Pin/Package Length - the sum of all the Pin Package Length values in all pads in that net. This value is defined as a property of the PCB pad and can also be specified in the schematic pin.
    • Un-Routed (Manhattan) Length - the vertical plus horizontal (X+Y) distance of all unrouted sections.

Right-click in the region then use the Columns sub-menu to add the following columns:

  • Min/Max - settings from the applicable Length and Matched Length design rules. If there is no applicable rule(s) defined, the internal defaults of Min=0mil and Max=99999mil are used.

    See Length Tuning to learn more how the Min and Max settings are derived from the Length and Matched Length design rules.

  • Estimated Length - this is the Routed Length plus the length of connection lines for any section still to be routed. It does not use the Manhattan length for the unrouted portion; instead it uses the direct point to point distance.
  • Delay - the time it takes for a signal to propagate along that route.
Vertical distance through a via - the vertical distance a signal travels through a via is the sum of all layer thicknesses (copper and dielectric) between the start and stop layers copper layers, plus half the thickness of the start layer and half the thickness of the stop layer.

Double-click on the entry for a specific net in the Nets region (or right-click on the net entry then choose the Properties command from the context menu) to open the Edit Net dialog from which you can modify the properties of the net.

The Edit Net dialog can also be accessed from the design space by right-clicking over a placed design object then choosing the Net Actions » Properties command from the context menu. The dialog will open for the parent net to which the object is associated.

Primitives

The display/inclusion of each net item type in the bottom Primitives region of the panel is dependent on whether the corresponding option for each has been enabled on the right-click menu, accessed from either the Nets or Primitives regions.

Right-click on a net or net item entry to select the included items.
Right-click on a net or net item entry to select the included items.

Note that the Primitives list right-click context menu also offers the option to create an xSignal between two selected items. See PCB - xSignals for more information.

Managing the Display of the Connection Lines

Related page: Your View of the PCB

The connection lines are a valuable aid to help with placing and orienting the components and to guide you during routing. However, their presence can also create a lot of visual clutter. To help with this, the PCB editor includes the features described below to help the designer manage the display of connection lines.

Changing the Connection Line Color

When the design is transferred from the schematic into the PCB workspace, default layer and color settings are applied. As part of this process, all of the connection lines are assigned the default Connection Lines color, as defined in the System Colors section of the Layers & Colors tab of the View Configuration panel (L shortcut). View configurations are available for use in both 2D and 3D workspaces, and can be saved and re-applied (View Options tab of the View Configuration panel).

An easy way to make important nets stand out during the routing process is to change the color of their connection lines. To do this, double-click the net name in the PCB panel to open the Edit Net dialog, where you can edit the connection line color (set the panel to Nets mode).

Alternatively, to change the color of one or multiple nets, first select the required nets in the PCB panel, then right-click on a selected net and choose the Change Net Color command.

In the PCB panel, right-click on selected nets to change the color of their connection lines.
In the PCB panel, right-click on selected nets to change the color of their connection lines.

Displaying Connection Lines using the Layer Colors

As well as assigning the connection line color for individual nets, you can also display the connection lines using the colors of the start and end layers that the connection line travels between. If a connection line travels from an object on one layer to an object on a different layer, the connection starts in the color of the layer of the first object, then morphs to the color of the layer it ends on, as it approaches the object on that layer (as shown in the image below).

Note that this gradient color override is only applied to nets that travel from one layer to another; if the connection starts and ends on the same layer, it retains its defined color.

This feature is helpful when you are routing a multi-layer board, as it indicates the target layer that the connection being routed, must go to. Note that color morphing is only applied to connections that travel from one layer to another, if the connection starts and ends on the same layer it retains the assigned net color.  

To use the layer color feature, enable the Use Layer Colors for Connection Drawing option in the View Options tab of the View Configurations panel, as shown below.

Connection lines can be displayed using their start-and-end layer colors. In the image on the right, a number of nets have had routing segments removed to show how the connection lines display. Connection lines can be colored to show their starting and ending layers
Connection lines can be displayed using their start-and-end layer colors. In the image on the right, a number of nets have had routing segments removed to show how the connection lines display.

Displaying Connection Lines in Single Layer Mode

A multi-layer board is visually dense, making it difficult to interpret what is going on. To help with this, you can easily switch the layer display from the enabled layers to Single Layer mode, by pressing the Shift+S shortcut.

Normally, when you do this, all connection lines that do not either start or end on the current layer are also hidden, as it is assumed that they are not relevant. To always display the connection lines, enable the All Connections in Single Layer Mode option in the View Options tab of the View Configurations panel, as shown below.

Control the display of connection lines in Single Layer mode.
Control the display of connection lines in Single Layer mode.

Hiding/Displaying Connection Lines

As an alternate to filtering nets via the PCB panel, you can completely hide one, many, or all of the connection lines. There are a number of commands to control the display of connection lines in the View » Connections submenu. You can also access these commands while you are working by pressing the N shortcut key. Use the available commands to:

  • Show or hide all connection lines for the design.
  • Show or hide all connection lines associated with a chosen net.

    • If you do not know the location of a pad on the net, or one of its connection lines, click in free space and a dialog will pop up, prompting for the net name. If you are unsure of the net name, type ? and click OK to launch the Nets Loaded dialog, which lists all loaded nets for the design. The connection lines for the net you choose in the dialog will be hidden when you click OK.
    • To show or hide the connection lines of the net to which an object in the design space is assigned, you can right-click over the net object and choose the Net Actions » Show Nets or Hide Nets command from the context menu.
  • Show or hide the connection lines for all nets associated with a chosen component.

    • If you do not know the location of a component, click in free space and a dialog will pop up, prompting for the component's designator. If you are unsure of the designator, type ? and click OK to launch the Components Placed dialog, which lists all components in the design. The connection lines for all nets associated to the component you choose in the dialog will be hidden when you click OK.
    • To hide the connection lines with respect to all nets associated with selected components, you can right-click over a component (or select more than one component) and choose the Component Actions » Show Nets or Hide Nets command from the context menu.
  • All of the available commands have accelerator keys, making it an efficient method of performing such tasks as hiding all connection lines (N, H, A), then displaying the connection lines for a specific net (N, S, N).
  • During component moves, all connection lines are automatically hidden. You may cycle through the display of these connection lines while moving a component. To do so, press the key while in movement mode. When pressing the key in movement mode, the Heads Up display cycles between displaying Breaks, Hidden, or Pad To Pad, depending on which connection you'd like to display.

Net Topology

The pattern or order that the nodes in the net are connected to each other is called the net topology. Net topology is controlled by the applicable Routing Topology design rule, which defaults to a topology of Shortest. Shortest means the nodes in the net are connected to each other in a pattern that gives the shortest overall connection length for that net. This overall length is monitored as you move a component, and the pattern of the connection lines will change dynamically to keep the overall length shortest. This can be observed in the animation shown above, where the lines connecting downward from the bottom of the moving component jump as the component is being moved - this happens each time one of the connected pads moves closer to another pad in their net.

Applying a Pre-defined Topology using the Routing Topology design rule

Additional Routing Topology design rules can be created to configure a net (or net class ) to use a different topology. To demonstrate this, in the images shown below the default topology rule is shown on the left, and that same net with a new routing topology of Starburst having been applied is shown on the right. In a Starburst topology, the connections radiate from the pad with an Electrical Type of Source (the default type for all pads is Load).

For the default topology, the connection lines are placed to give the shortest overall connection length. In the Starburst topology, the connection lines all radiate from a Source pad. Image showing the connection lines arranged in a Starburst net topology
For the default topology, the connection lines are placed to give the shortest overall connection length. In the Starburst topology, the connection lines all radiate from a Source pad.

Applying a Custom Topology

Within an individual net, the connection between two nodes is referred to as a From-To. To control the path of the connection lines down at the individual pin-to-pin level, you can manually define From-Tos within a net, effectively creating a custom net topology.

From-Tos are defined by setting the PCB panel to From-To Editor mode. The process of defining a From-To is to select two Nodes on Net in the panel, and click the Add From To button. To clearly identify From-Tos in the design space, they are shown as a dashed line instead of a solid line.

A From-To has been defined between 2 pads, note how the From-To line is displayed as dashed rather than solid.
A From-To has been defined between 2 pads, note how the From-To line is displayed as dashed rather than solid.

When the PCB panel is in From-To Editor mode, all of the connection lines that are not From-Tos, are hidden.

The PCB panel’s From-To Editor mode is divided into three sections:

  • Nets
  • Nodes of the selected net
  • From-Tos on Net

As you click on a net entry, all of the nodes on that net will be loaded into the middle region of the panel. Double-clicking on a net entry will open the Edit Net dialog in which you can edit the properties of the net, including node membership.

Adding From-Tos

To add a user-defined From-To between two nodes in a selected net, select the two nodes in the Nodes on Net region of the panel then click the Add From To button.

You can select the two nodes (pads) for a From-To directly within the design space. As you select a node, its corresponding entry in the Nodes on Net region of the panel will become selected.

The newly added From-To will appear listed in the From-To on Net region of the panel and appears in the design space as a dotted line between the two nodes.

A new From-To has been created on the net.
A new From-To has been created on the net.

A user-defined From-To in the design space.
A user-defined From-To in the design space.

To remove a From-To, select its entry in the From-To on Net region of the panel then click the Remove button.

Choosing a Predefined Topology

The topology of a net is the arrangement or pattern of the pin-to-pin connections. By default, pin-to-pin connections of each net are arranged to give the shortest overall connection length.

A topology is applied to a net for a variety of reasons: for high speed designs where signal reflections must be minimized, the net is arranged with a daisy chain topology; for ground nets, a star topology could be applied to ensure that all tracks come back to a common point. You can either create dedicated From-Tos for node pairs in a net or you can choose to generate From-Tos for the net based on one of the predefined routing topologies available.

The following topologies are available and can be accessed from the From-To on Net region of the panel by clicking the Generate button:

  • Shortest - this topology connects all nodes in the net to give the shortest overall connection length.
  • Daisy Simple - this topology chains all the nodes together, one after the other. The order they are chained is calculated to give the shortest overall length. If a source and terminator pad are specified, then all other pads are chained between them to give the shortest possible length. If multiple sources (or terminators) are specified, they are chained together at each end.

  • Daisy Balanced - this topology divides all the loads into equal chains, the total number of chains equal to the number of terminators. These chains then connect to the source in a star pattern. Multiple source nodes are chained together.

  • Daisy Mid-Driven - this topology places the source node(s) in the center of the daisy chain, divides the loads equally and chains them off either side of the source(s). Two terminators are required, one for each end. Multiple source nodes are chained together in the center. If there are not exactly two terminators, the Daisy-Simple topology is used.

  • Starburst - this topology connects each node directly to the source node. If terminators are present, they are connected after each load node. Multiple source nodes are chained together, as in the Daisy Balanced topology.

A pad can be defined as a Source, Terminator or Load by changing the entry for the Electrical Type field accordingly in the Pad mode of the Properties panel. Access to the Pad mode of the Properties panel is made by double-clicking on the entry for the pad in the Nodes on Net region.

Setting a pad's Electrical Type to Source in the Pad mode of the Properties panel.
Setting a pad's Electrical Type to Source in the Pad mode of the Properties panel.

When you change the electrical type for a pad to Source or Terminator, an "[S]" or "[T]" will be placed in the design space to distinguish it.

Notes

  • A system-generated connection line does not appear in the design space as a separate entity. Only the associated pin-to-pin connection line for the From-To is displayed, which is used for interactive routing/Autorouting guidance.
  • A user-defined From-To appears in the design space as a dotted line, separate and distinct from the pin-to-pin connection line that is also displayed when the FromTo is added. The user-defined From-To line controls where the associated pin-to-pin connection line starts and finishes. This is best demonstrated by example. Consider a user-defined From-To added between the logically connected pins of two components. A connection line is also added and displayed (PCB panel configured in Nets mode):

  • The pin-to-pin connection line - used for routing purposes - conceals the presence of the distinctly separate user-defined From-To line. However, as you start to route the connection, you can see the distinct and separate nature of the two lines:

  • If the routing is now suspended, the net analyzer adds a connection line so as to maintain the required topology, shown as a dotted line (called a Broken Net Marker), indicating that the net should be routed between these two points to maintain the topology determined by the user through the addition of the user-defined FromTo:

  • If you specify user-defined From-Tos for only part of a net, the PCB Editor will set the remaining pin-to-pin connections (system-generated From-Tos) to the Shortest topology.
  • The type of From-To determines how the Connectivity Analyzer treats the connection line in the design space when, for example, a net object is moved or part of a net is manually routed:
    • System-generated From-To - the connection line can be moved as required as part of the net analyzer's re-optimization to keep the default topology of the net (i.e., Shortest).
    • User-defined From-To - if the From-To is not the result of selecting a predefined topology, the connection line is not considered as part of the net analyzer's re-optimization process. If the From-To is part of a predefined net topology (other than Shortest), the net analyzer can include it in re-optimization, as long as the chosen topology is kept.

The Netlist Manager

The Netlist Manager dialog accessed by choosing the Design » Netlist » Edit Nets command from the main menus provides controls to effectively manage the netlist for the board. Nets can be added, edited or deleted as required, and the pins (or pads) of the components in those nets also can be edited with respect to their properties. Access to other netlist management tools is also provided through this dialog, including the ability to create the netlist based on connected copper on the PCB and the ability to export the netlist from the PCB.

The Netlist Manager dialog The Netlist Manager dialog

Reporting on Nets

To generate a Netlist Status report from the active PCB document, choose the Reports » Netlist Status command from the main menus. This report provides detailed information regarding the netlist for the routed board. It lists all nets and for each net, indicates the layers used for routing and the total physical routed track length. After launching the command, a report - Net Status - <PCBDocumentName>.html - is generated and opened as the active document. Each net is listed; click a net name to highlight that net on the PCB document. The physically-routed track length data is initially displayed in the measurement units specified for the board design itself. Use the Units field in the report to quickly change between imperial and metric units as required.

  • The report is also generated in .txt format. Both report formats are stored in the folder specified by the Output Path entry on the Options tab of the Options for Project dialog. Only the HTML-formatted report is added to the parent project in the Projects panel and can be found in the Generated\Documents sub-folder.
  • The report includes the Routed Length, which includes the vertical distance traversed through the vias in that net. Note that the Routed Length calculator does not attempt to resolve overlapping track segments or routing wiggles inside pads, so may not be accurate. For a more accurate length use the Signal Length, which can be displayed in the Nets mode of the PCB panel. The PCB panel also supports creating a report, right-click in the list of nets in the panel to configure the required columns, then right-click and select Reports to open the Report Preview dialog, where you can export the report in a variety of formats.
Note

The features available depend on your level of Altium Designer Software Subscription.

Content