Altium NEXUS Documentation

Importing a Design from OrCAD CIS into Altium NEXUS

Created: March 6, 2019 | Updated: March 7, 2019
All Contents

Supporting the need to work with database component libraries from OrCAD® CIS, Altium NEXUS’s Import Wizard provides a flexible, automated OrCAD CIS library conversion option to create an equivalent Altium NEXUS Database Library and the associated schematic/PCB libraries.

Using a connectivity system that is not unlike OrCAD’s Component Information System (CIS), an Altium NEXUS Database Library hosts links to component data in an ODBC Compliant data source, such as a company component database. The records in the centralized database reference the source models (symbols, footprints, etc.,) and parameters for sets of company ratified components.

An Altium NEXUS Database Library provides library-based links to those component definitions, which allows database-sourced company components to be placed directly into designs that are in turn synchronized back the data source.

The elementary database link mapping file for OrCAD CIS is a CIS Configuration file (*.dbc), which is processed by the Import Wizard to create a corresponding Altium NEXUS Database Library structure (*.DBLib). The associated OrCAD library files (*.olb , *.llb), which are essentially the linked sources of component symbols and footprints, are also handled by the importer to create Altium NEXUS Library files (*.SchLib, *.PcbLib).

Enabling the Importer

If support has not already been added during initial installation of the software, it can be added from the Configure Platform page when managing the extensions and updates for your installation through the Extensions & Updates view (click on the  control at the top-right of the workspace then choose Extensions and Updates from the menu).

This option serves both OrCAD and OrCAD CIS import functions.
  1. From the Installed page of the view, click the Configure button at the top-right to access the Configure Platform page.

Access the Configure Platform page of the Extensions & Updates view.

  1. Scroll down the page and enable the entry for OrCAD in the Importers\Exporters region of the page.

Enable the OrCAD option under Importers\Exporters.

  1. Click the Apply button at the top-right of the page. Altium NEXUS must be restarted for the changes to take effect; click Yes at the dialog prompt.

Importing OrCAD CIS Files

The OrCAD CIS design file importer is available through Altium NEXUS's Import Wizard  (File » Import Wizard) by selecting the Orcad CIS Configuration Files and Libraries option on the Wizard's Select Type of Files to Import page. The Wizard provides options for nominating the main component database, the source OrCAD CIS Configuration and library files, and the target Altium NEXUS Database Library.

Altium NEXUS currently only supports OrCAD CIS .DBC files in binary format.
Directly opening an OrCAD CIS file (*.dbc, *.olb, *.llb) in Altium NEXUS (File » Open) will activate the Import Wizard with that file already specified for import.
See the OrCAD CIS Configuration Files and Libraries entry in the Import Wizard page for more information on the Wizard's import steps.

File Processing

The Import Wizard translates or processes OrCAD CIS library-based files as follows:

  • The OrCAD CIS Configuration File (*.dbc), which defines the link to the external component database and includes the database field-to-design parameter mapping information, is interpreted to create an Altium NEXUS Database Library file (*.DBLib).
  • OrCAD CIS files translate as follows:

    • OrCAD OLB (schematic library) files will be translated into Altium NEXUS schematic library files (*.SchLib).
    • OrCAD LLB (PCB library) files will be translated into Altium NEXUS PCB library files (*.PcbLib).

The final result is that the OrCAD CIS linking structure that accesses data fields in the external component database (such as a Microsoft® Access *.mdb file) is replicated in the Altium NEXUS Database Library (DBLib). Also, the OrCAD library files that are used as sources for component symbols and models are converted to Altium NEXUS library files, which then become the symbol/model sources for the new DBLib database field mapping.

Using the Wizard

Altium NEXUS’s Import Wizard steps you through the processes of nominating the range of source and target files for the OrCAD CIS translation.

Ensure that you choose the Orcad CIS Configuration File and Libraries option as the type of files to import in the Wizard’s Select Type of Files to Import page then use the subsequent pages to specify:

  • The location of the external database – typically, your ODBC-compliant company component database.
  • The location of the OrCAD CIS Configuration file.
  • The location of the target DBLib file, which will be created or added to in the final Wizard steps.
  • The OrCAD Schematic and/or PCB libraries referenced by the external database.

Note that the external database and OrCAD source files are not altered (written to) during the import process since the Wizard simply reads the data to create the new database linking structure.

Database Library Document

When the Import Wizard steps are complete, the specified Database Library file will be made active in Altium NEXUS.

The library document can be reviewed and edited if necessary. Relevant notes are:

  • The Import Wizard automatically adds a library search path to the DBLib file that points to the nominated directory that contains the translated library files.
  • The defined lookup key determines the data relationship between the external database and the DBLib parameters (or properties, in OrCAD terms). If necessary, the key lookup field/parameter pair can be changed in the Field Settings region by selecting an alternative relationship from the drop-down menus.
Once the initial review and/or editing is complete, the DBLib file must be saved.

When used as a source library in Altium NEXUS, components placed from the active Database Library will draw the mapped parameter and symbol/model data from the external database.

Use the Update From Libraries command to update a placed component in response to changes made in the external component database or the associated source libraries (Tools » Update From Libraries). To update the component’s parameters from the source database, select Tools » Update Parameters From Database.

See Update From Libraries for information on library updates.
Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Contact Us

Contact our corporate or local offices directly.

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
You are reporting an issue with the following selected text
and/or image within the active document: