Creación y definición de la biblioteca de base de datos
De un vistazo
- Comprende la función de los archivos DbLib y SVNDbLib y dónde crearlos.
- Explora las opciones de conexión a bases de datos, incluidos los métodos abreviados para Access y Excel, las cadenas de conexión y los archivos de vínculo de datos de Microsoft.
- Aprende a explorar y editar las tablas conectadas, controlar su inclusión en la biblioteca y definir criterios de coincidencia de componentes para cada tabla.
La base de la funcionalidad de bibliotecas de base de datos es el archivo de biblioteca de base de datos. Este se presenta en dos modalidades, según se utilice una biblioteca de base de datos estándar o una biblioteca de base de datos con control de versiones:
- Standard Database Library - el archivo de biblioteca de base de datos. Este archivo se crea y se gestiona mediante el editor DatabaseLib de Altium Designer. Este editor está disponible cuando el documento activo en la ventana principal de diseño es un archivo *.DbLib.
- Version-Controlled Database Library - el archivo de biblioteca de base de datos SVN. Este archivo se crea y se gestiona mediante el editor SVNDatabaseLib de Altium Designer. Este editor está disponible cuando el documento activo en la ventana principal de diseño es un archivo *.SVNDbLib.
Ejemplo de archivo DbLib abierto en el editor DatabaseLib. Pase el cursor sobre la imagen para ver un ejemplo de archivo SVNDbLib abierto en el editor SVNDatabaseLib.
Cree un nuevo archivo de estos tipos eligiendo el comando File » New » Library en los menús principales y seleccionando la opción Database Library o SVN Database Library en la sección Database del cuadro de diálogo New Library que se abre.
Conexión a una base de datos externa
Los datos de las tablas y de las correspondencias solo aparecerán en la ventana principal de un editor después de que el archivo activo de biblioteca de base de datos o biblioteca de base de datos SVN se haya conectado correctamente a la base de datos externa requerida. La conexión se define mediante los controles de la sección Source of Connection.
Especificación de la conexión a la base de datos externa mediante un archivo DbLib. Pase el cursor sobre la imagen para ver la conexión mediante un archivo SVNDbLib.
Es posible conectarse a cualquier base de datos compatible con OLE DB. Cada una de las opciones de esta sección utiliza una cadena de conexión OLE DB para conectarse a la base de datos de destino. Algunas bases de datos pueden no ser compatibles con OLE DB. Sin embargo, prácticamente todos los sistemas de gestión de bases de datos utilizados hoy en día son accesibles a través de la interfaz Open Database Connectivity (ODBC). La funcionalidad de enlace a bases de datos utiliza el proveedor ODBC de Microsoft, que permite que un ADO (ActiveX Data Object) se conecte a cualquier origen de datos ODBC. Por lo tanto, es posible conectarse a cualquier base de datos ODBC. El proveedor OLE DB para la base de datos ODBC se especifica como parte de la cadena de conexión.
La conexión también se puede definir en la pestaña Connection del cuadro de diálogo Database Connection, al que se accede eligiendo el comando Tools » Database Connection en los menús principales o haciendo clic en el botón Advanced (a la derecha del botón Connect , en la parte inferior de la sección).
Opciones y controles del cuadro de diálogo de conexión a la base de datos
Pestaña Conexión
-
Source of Connection
- Use Data Link File - una cadena de conexión es una representación textual de la información de conexión a una base de datos y puede guardarse como un archivo independiente con la extensión .udl, denominado archivo de vínculo de datos de Microsoft. Si desea utilizar un archivo de vínculo de datos como origen de la conexión a una base de datos, seleccione esta opción y haga clic en Browse para abrir el cuadro de diálogo Select Data Link File, o utilice la lista desplegable para buscar el archivo .udl deseado.
- Use Connection String - seleccione esta opción y haga clic en Build para abrir el cuadro de diálogo Propiedades de vínculo de datos y volver a generar la cadena de conexión a una base de datos para establecer las correspondencias de los parámetros de los componentes. La información especificada en una cadena de conexión puede variar en función del proveedor OLE DB especificado.
Pestaña Opciones avanzadas
-
SQL Options
-
Quote Tables - active esta opción para utilizar caracteres delimitadores específicos en los nombres de las tablas.
- Left Quote Character - especifique el carácter delimitador izquierdo. El valor predeterminado es "[".
- Right Quote Character - especifique el carácter delimitador derecho. El valor predeterminado es "]".
-
Quote Tables - active esta opción para utilizar caracteres delimitadores específicos en los nombres de las tablas.
- Include Table Schema Names - active esta opción para incluir tablas con nombres de esquema de tabla. De forma predeterminada, esta opción está desactivada y solo se utilizan tablas con nombres de tabla normales.
- Field Data Type - especifique el tipo de datos de los campos nuevos. Por ejemplo, se puede utilizar TEXT(N) o VARCHAR(N) para bases de datos de MS Access o MySQL; VARCHAR2(N) se puede utilizar para bases de datos de Oracle.
Conexión rápida a bases de datos de Access y Excel
La opción Select Database Type ofrece un método rápido para crear una cadena de conexión cuando la base de datos de destino se ha creado con Microsoft Access o Microsoft Excel. Al utilizar esta opción, seleccione el tipo de base de datos y, a continuación, busque y seleccione el archivo de base de datos requerido. La cadena de conexión correspondiente se generará automáticamente y se introducirá en el campo de la opción Use Connection String.
Creación de una cadena de conexión
Si la base de datos de su empresa no está basada en Access ni en Excel y desea crear la cadena de conexión de forma explícita, active la opción Use Connection String y, a continuación, haga clic en el botón Build asociado, situado a la derecha. Aparecerá el cuadro de diálogo Data Link Properties.
Creación de una cadena de conexión mediante el cuadro de diálogo Data Link Properties.
El cuadro de diálogo se abre en la pestaña Connection . El proveedor OLE DB Microsoft Office <Version> Access Database Engine OLE DB Provider está configurado de forma predeterminada en la pestaña Provider del cuadro de diálogo. Esta es la configuración de proveedor predeterminada para los nuevos archivos de biblioteca de base de datos o biblioteca de base de datos SVN y también se utiliza para conectarse a archivos de base de datos de Access (*.mdb). Cambie el proveedor según sea necesario.
En la pestaña Connection , introduzca el nombre (incluida la ruta) de la base de datos a la que desea conectarse.
Si su base de datos requiere credenciales de inicio de sesión, introdúzcalas según corresponda, junto con cualquier otra configuración avanzada disponible en la pestaña Advanced del cuadro de diálogo. La pestaña All muestra un resumen de las opciones de vínculo definidas, así como opciones adicionales relacionadas con el proveedor OLE DB seleccionado. Las opciones pueden modificarse según sea necesario desde esta pestaña.
Una vez definidas las opciones de vínculo, puede comprobar si la conexión se realiza correctamente haciendo clic en el botón Test Connection (en la pestaña Connection ). Si la conexión se realiza correctamente, aparecerá un cuadro de diálogo de confirmación.
Especificación de un archivo de vínculo de datos
Si el origen de datos al que desea conectarse se describe mediante un archivo de vínculo de datos de Microsoft (*.udl), active la tercera opción de conexión, Use Data Link File, y haga clic en el botón Browse asociado para localizar el archivo requerido. Un archivo de vínculo de datos es, en esencia, un contenedor para almacenar una cadena de conexión.
Continuación con la conexión
Después de definir la conexión con la base de datos externa, el texto del botón Connect aparecerá en negrita, lo que indica que puede proceder con la conexión. Si los datos de conexión son correctos, la información de las tablas y las asignaciones de la base de datos de destino se cargará en el archivo Database Library/SVN Database Library. El texto del botón Connect cambiará a Connected y el botón quedará deshabilitado.
Si hay algún problema con los datos de conexión, por ejemplo, si la cadena de conexión se ha creado incorrectamente o se ha introducido una ruta errónea, la conexión fallará y aparecerá un mensaje para avisarle. Compruebe la configuración de conexión y vuelva a hacer clic en el botón Connect .
Ejemplos de indicación de un fallo de conexión en una biblioteca de base de datos.
Después de establecer correctamente la conexión inicial y guardar el archivo Database Library/SVN Database Library, la conexión se establecerá automáticamente cada vez que se abra el archivo, siempre que no se modifiquen la ubicación ni el nombre del archivo de la base de datos de destino.
Especificar el vínculo al repositorio de control de versiones (solo SVNDbLib)
Con una DbLib, las bibliotecas de símbolos y modelos se almacenan en el disco duro o en otro medio local o de red. Recuerde que, en el caso de una SVNDbLib, estas bibliotecas se almacenan bajo control de versiones en un repositorio de Subversion. Como parte del archivo SVNDbLib, debe definir el vínculo a este repositorio. La conexión con el repositorio SVN se define en la pestaña SVN Repository del cuadro de diálogo Database Library Options (Tools » Options). También puede acceder a este cuadro de diálogo haciendo clic en el botón Options de la sección Field Settings de la vista del documento.
Ejemplo de conexión con un repositorio SVN basado en archivos.
Lista de tablas de la base de datos
Tras establecer correctamente la conexión con la base de datos externa, se cargarán los datos de las tablas y las asignaciones. En el lado izquierdo del documento DbLib/SVNDbLib se muestran todas las tablas que existen en la base de datos conectada.
Tablas existentes en la base de datos conectada.
La opción Enable situada junto a cada entrada de tabla permite controlar si esa tabla formará parte de la biblioteca de base de datos resultante. Cuando la biblioteca de base de datos se añade a la lista de bibliotecas basadas en archivos disponibles para su consulta en el panel Components, cada tabla aparecerá como una biblioteca independiente. Por tanto, aunque en realidad solo se añade una biblioteca de base de datos, desde la perspectiva del panel Components es como si se hubieran añadido varias bibliotecas distintas. Para obtener más información, consulte Buscar componentes en bibliotecas basadas en archivos y bases de datos.
Al hacer clic en una entrada de tabla de la lista, su icono cambia de
a
para indicar que es la tabla activa. La tabla, con todos sus datos, aparece en la pestaña Table Browser del documento. Esta es una vista editable de la tabla que permite consultar rápidamente su contenido y realizar las modificaciones necesarias sin tener que abrir la propia base de datos externa.
Explorar una tabla de origen en la base de datos conectada.
Especificar los criterios de coincidencia
Después de colocar un componente desde la base de datos externa, debe existir alguna forma de mantener el vínculo entre el componente colocado y el registro de la base de datos cuya información se utilizó para crearlo. En esencia, es necesario establecer una correspondencia entre ambos.
Al colocar un componente, la información de sus parámetros se crea sobre la marcha a partir de los campos correspondientes del registro de la base de datos. El vínculo posterior a la colocación entre el componente del esquema y el registro de la base de datos se establece mediante uno o varios de estos parámetros. La sección Field Settings del documento permite definir los criterios de coincidencia: una búsqueda sencilla con una sola clave o una coincidencia más avanzada mediante una cláusula WHERE.
Controlar los criterios de coincidencia posteriores a la colocación.
Búsqueda con una sola clave
Si la opción Single key lookup está habilitada (valor predeterminado), los campos Database field y Part parameter estarán disponibles. El primero enumera todos los nombres de campo disponibles (encabezados de columna) en la tabla activa de la base de datos. Como los parámetros de un componente del esquema se añaden al colocarlo, el campo Part parameter reflejará el campo de la base de datos que se haya elegido.
Normalmente, como campo de clave de búsqueda se utiliza uno que identifique de forma única cada componente de la base de datos externa, como un número de pieza. El campo de búsqueda elegido se distingue en la pestaña Field Mappings del documento por la entrada Design Parameter, que aparece atenuada.
Asignación con una sola clave por número de pieza.
Al utilizar la función Update Parameters From Database en algún momento posterior a la colocación, se lee la información del parámetro clave elegido en los componentes colocados en el esquema y, a continuación, se busca en el campo (clave) elegido de la base de datos, en todas las tablas habilitadas. Cuando se encuentra una coincidencia, la información de otras celdas de ese registro de la tabla de origen puede transferirse a los parámetros correspondientes del componente del esquema.
Coincidencia avanzada: la cláusula WHERE
Aunque la opción Single key lookup funciona bien cuando hay un número de pieza o identificador único con el que establecer la coincidencia, no resulta tan eficaz cuando se utiliza un parámetro que no es único, como la capacitancia o la resistencia. En este caso, debe utilizarse la cláusula WHERE, más avanzada, que permite especificar coincidencias con varias claves para vincular el componente del esquema con su registro de origen en la base de datos.
En su forma más sencilla, la cláusula WHERE (escrita con sintaxis SQL) refleja las entradas seleccionadas que definen la búsqueda con una sola clave. Por ejemplo, si se seleccionara Part Number —el valor predeterminado— para Database field, el campo Part parameter también se establecería automáticamente en Part Number, y la entrada de la cláusula WHERE sería:
[Part Number] = '{Part Number}'
Los corchetes que rodean el campo de la base de datos (columna de la tabla) son caracteres delimitadores, tal como se especifica en la pestaña Advanced del cuadro de diálogo Database Connection. Acceda a este cuadro de diálogo haciendo clic en el botón Advanced de la sección Source of Connection del documento o desde el menú principal Tools .
La pestaña Advanced del cuadro de diálogo Database Connection proporciona opciones SQL adicionales para delimitar
tablas o utilizar nombres de esquema de tabla en una cláusula WHERE construida.
Las llaves especifican que la entrada a la que se hace referencia es un parámetro de diseño. Las comillas simples se utilizan para especificar que el parámetro de diseño debe tratarse como una cadena, en lugar de como un número (sin comillas). La coincidencia de tipos es muy importante, ya que SQL distingue entre tipos de datos. El parámetro de diseño debe tener el mismo tipo que la columna de la base de datos.
Con la sintaxis SQL estándar, la cláusula WHERE se puede ampliar para buscar coincidencias mediante varias entradas Database field/Part parameter, por ejemplo:
[Capacitance] = '{Capacitance}' AND [Tolerance] = {Tolerance} AND [Manufacturer] = '{Manufacturer}'
En este caso, se establecería un vínculo con un único registro de la tabla correspondiente de la base de datos mediante tres parámetros de diseño distintos. Observe que la entrada del parámetro de diseño Tolerance no está entre comillas. Esto significa que el tipo de columna en la tabla asociada de la base de datos es Number y no String.
Con la sintaxis SQL estándar, puede hacer que la cláusula WHERE sea tan sencilla o tan compleja como desee.
Asignación de campos de la base de datos a parámetros de diseño
Los parámetros de diseño de un componente colocado desde una biblioteca de base de datos se crean o añaden en el momento de la colocación. Los parámetros que se crean y las opciones utilizadas para actualizar su información después de la colocación, mediante el comando Tools » Update Parameters From Database, se determinan mediante la información de asignación y actualización especificada en el archivo de biblioteca de base de datos o de biblioteca de base de datos SVN. Estos ajustes se configuran en la pestaña Field Mappings de la vista principal del documento.
Especifique las opciones de asignación y actualización de parámetros en la pestaña Field Mappings del documento DbLib/SVNDbLib.
Asignación de modelos y parámetros
Las dos primeras columnas (desde la izquierda) de la pestaña Field Mappings se utilizan para controlar qué información de la base de datos se asignará a los atributos, modelos y parámetros del componente.
- Database Field Name - esta columna muestra todos los nombres de campo (columna) de la tabla actualmente activa de la base de datos.
- Design Parameter - esta columna define cómo se utilizará cada campo correspondiente de la base de datos. Puede utilizarse como origen del símbolo o del modelo de huella de un componente (en cuyo caso aparecerá entre corchetes), o incluirse como parámetro del componente (estos no aparecen entre corchetes).
La asignación inicial se realiza automáticamente al conectarse a la base de datos y abarca todos sus campos.
Atributos y modelos
Si el nombre del campo de la base de datos es uno de los siguientes nombres reservados, la entrada de asignación del atributo o modelo correspondiente se establecerá automáticamente en el campo Design Parameter:
- Description → [Description]
- Footprint Ref → [Footprint Ref]
- Footprint Path → [Footprint Path]
- Footprint Ref n → [Footprint Ref n]
- Footprint Path n → [Footprint Path n]
- Library Ref → [Library Ref]
- Library Path → [Library Path]
- Orcad Footprint → [Orcad Footprint]
- Orcad Library → [Orcad Library]
- PCB3D Ref → [PCB3D Ref]
-
PCB3D Path → [PCB3D Path]
- Sim Description → [Sim Description]
- Sim Excluded Parts → [Sim Excluded Parts]
- Sim File → [Sim File]
- Sim Kind → [Sim Kind]
- Sim Model Name → [Sim Model Name]
- Sim Netlist → [Sim Netlist]
- Sim Parameters → [Sim Parameters]
- Sim Port Map → [Sim Port Map]
- Sim Spice Prefix → [Sim Spice Prefix]
-
Sim SubKind → [Sim SubKind]
Estas asignaciones definen la información de atributos y modelos del componente. Al colocar el componente, el símbolo esquemático especificado por el campo [Library Ref] del registro correspondiente de la base de datos se extraerá de la biblioteca de esquemáticos especificada. Del mismo modo, la información de la huella de PCB y del modelo de simulación almacenada en el registro se añadirá al componente como modelos vinculados de huella y de simulación, respectivamente.
La entrada [Library Ref] debe existir en la columna Design Parameter y estar asignada al Database Field Name que especifica el símbolo esquemático para poder colocar un componente de la biblioteca de base de datos o de la biblioteca de base de datos SVN en un esquemático. Si la tabla de la base de datos contiene la referencia del símbolo bajo un Database Field Name diferente, por ejemplo SCH Symbol, deberá establecer manualmente la entrada Design Parameter asociada a este campo en [Library Ref], utilizando la lista desplegable disponible para esa celda.
Del mismo modo, si la información de referencia de los modelos se introduce en la base de datos utilizando nombres de campo diferentes, deberá realizar la asignación manualmente seleccionando la entrada Design Parameter adecuada ([Footprint Ref], [Footprint Ref n], [PCB3D Ref], [Sim Model Name], etc.) en la lista desplegable de cada campo.
Para definir la información de símbolos y modelos de un componente al colocarlo, los campos de referencia de símbolos y modelos de la base de datos son los elementos fundamentales
de la asignación: asegúrese de que la asignación definida incluya una referencia a un símbolo y al menos una referencia a una huella de PCB.
Asignación de modelos de simulación
Esta sección describe cada uno de los campos de base de datos que se pueden añadir a una tabla de base de datos externa para definir el vínculo del modelo de simulación, que se creará al colocar el componente.
-
Sim Model Name – el nombre del modelo que desea utilizar. Después de colocar el componente, esta información aparecerá en el campo Model Name del cuadro de diálogo Sim Model.
- Sim Description – una descripción del modelo vinculado. Esta información es opcional y no afecta al funcionamiento del vínculo del modelo de simulación.
-
Sim File – un archivo de modelo específico en el que buscar el modelo de simulación indicado en el campo Sim Model Name. Este campo se puede utilizar de varias maneras:
-
Puede introducir una ruta absoluta a un archivo de modelo (p. ej.,
C:\DbLibs\Switching Diodes\Libraries\JAS33.mdl). Se buscará en este archivo el modelo indicado en el campo Sim Model Name y, si se encuentra, se utilizará. -
Puede introducir una ruta relativa (respecto al archivo DbLib) a un archivo de modelo (p. ej.,
Libraries\JAS33.mdl). Se buscará en este archivo el modelo indicado en el campo Sim Model Name y, si se encuentra, se utilizará. -
Puede introducir únicamente el nombre del archivo de modelo (p. ej.,
JAS33.mdl)). Se utilizarán las rutas de búsqueda definidas como parte del archivo DbLib para localizar el primer archivo de modelo cuyo nombre coincida con el especificado y que contenga un modelo que coincida con el indicado en el campo Sim Model Name. - Puede dejar el campo en blanco. Se utilizarán las rutas de búsqueda definidas como parte del archivo DbLib para localizar el primer archivo de modelo que contenga un modelo que coincida con el indicado en el campo Sim Model Name.
-
Puede introducir una ruta absoluta a un archivo de modelo (p. ej.,
- Sim Kind – la categoría principal del modelo que se va a vincular.
- Sim SubKind – el tipo de modelo que se va a vincular.
-
Sim Netlist – la información de la plantilla de netlist, según el tipo de modelo que se va a vincular. Este campo cobra especial importancia si especifica su propia plantilla de netlist y ha establecido el campo Sim SubKind en
Generic Editor, lo que le permite controlar mejor qué información se incluye en la netlist.Sintaxis de la plantilla de netlist
Al definir la plantilla de netlist, la información introducida debe ajustarse a los requisitos de SPICE y a las reglas de sintaxis descritas a continuación.
Los caracteres introducidos en la plantilla se escriben literalmente en la netlist de SPICE, excepto los siguientes caracteres especiales:
% signo de porcentaje @ arroba & et comercial ? signo de interrogación ~ virgulilla # almohadilla Estos caracteres se interpretan al crear la netlist, como se muestra en la siguiente tabla:
Sintaxis en la plantilla de netlist... El generador de netlist la sustituye por... @<param> Valor de <param>. Se genera un error si no existe un parámetro con este nombre o si no tiene un valor asignado. &<param> Valor de <param>. No se genera ningún error si el parámetro no está definido. ?<param>s...s Texto entre los separadores s...s si <param> está definido. ?<param>s...ss...s Texto entre el primer par de separadores s...s si <param> está definido; de lo contrario, el texto entre el segundo par de separadores s...s. ~<param>s...s Texto entre los separadores s...s si <param> NO está definido. ~<param>s...ss...s Texto entre el primer par de separadores s...s si <param> NO está definido; de lo contrario, el texto entre el segundo par de separadores s...s. #<param>s...s Texto entre los separadores s...s si <param> está definido, pero se ignora el resto de la plantilla si <param> NO está definido. #s...s Texto entre los separadores s...s si hay algún texto que introducir en la netlist de XSpice a partir de las entradas posteriores de la plantilla de netlist. %<pin id> El nombre de la red a la que se conecta el pin del esquema asignado a <pin id>. %% Un carácter de porcentaje literal. En la tabla anterior,
- s representa un carácter separador (, . ; / |).
- <param> hace referencia al nombre de un parámetro.
Si el nombre del parámetro contiene algún carácter no alfanumérico, debe escribirse entre comillas dobles. Por ejemplo:
@"DC Magnitude"- aquí se utilizan comillas dobles porque el nombre contiene un espacio.
&"Init_Cond"- aquí se utilizan comillas dobles porque el nombre contiene un guion bajo.También deben utilizarse comillas dobles cuando se desee añadir un prefijo alfanumérico al nombre de un parámetro. Por ejemplo:
@"DESIGNATOR"A- el uso de comillas dobles garantiza que se añada A al designador del componente.A continuación se muestran ejemplos de las entradas de sintaxis con caracteres especiales de la tabla anterior. En cada caso, se explica cómo interpreta la entrada de sintaxis el generador de netlist.
@"AC Phase"El nombre del parámetro AC Phase se escribe entre llaves porque contiene un espacio. Se sustituirá en la netlist por el valor del parámetro AC Phase. Si no existe ningún parámetro con este nombre o su valor está en blanco, se generará un error.
&AreaSi existe un parámetro llamado Area y tiene un valor, dicho valor se introducirá en la netlist. Si el parámetro no está definido (es decir, no existe o no tiene ningún valor asignado), no se escribirá nada en la netlist, pero tampoco se generará ningún error. Esto puede utilizarse para parámetros opcionales.
?IC|IC=@IC|Si el parámetro llamado IC está definido, el texto entre los separadores || se insertará en la netlist. Por ejemplo, si el parámetro IC tuviera el valor 0.5, se insertaría IC=0.5 en la netlist en lugar de esta entrada. Si el parámetro no está definido, no se insertará nada en la netlist.
?IC/IC=@IC//IC=0/Es igual que el ejemplo anterior, salvo que, si el parámetro IC no está definido, se insertará IC=0 en la netlist. Observe también que se ha utilizado un carácter separador diferente.
~VALUE/1k/Si NO se ha definido un parámetro llamado VALUE, se insertará el texto 1k en la netlist.
~VALUE/1k//@VALUE/Es igual que el ejemplo anterior, salvo que, si el parámetro VALUE está definido, se insertará su valor de texto en la netlist.
#"AC Magnitude"|AC@"AC Magnitude"|@"AC Phase"Este ejemplo puede verse en la plantilla de netlist predefinida para la fuente de tensión sinusoidal.
Si se ha definido el parámetro AC Magnitude, se evalúa el contenido entre los separadores y se inserta en la netlist. Todas las entradas posteriores también se evalúan y se insertan en la netlist (en este caso, @"AC Phase").
Por ejemplo, si AC Magnitude=1 y AC Phase=0, se insertará AC 1 0 en la netlist. Sin embargo, si AC Phase no estuviera definido, se generaría un error.
Si el parámetro AC Magnitude no está definido, no se insertará en la netlist nada de lo que siga a la entrada #"AC Magnitude" en la plantilla de netlist.
#|PARAMS:|?Resistance|Resistance=Resistance|?Current|Current=@Current|Este ejemplo puede verse en la plantilla de netlist predefinida para un subcircuito parametrizado (consulte F1 en Fuse.PrjPcb).
Si los parámetros Resistance y Current no están definidos, no habrá texto que insertar en la netlist después de la entrada #|PARAMS:|, por lo que también se omitirá el texto entre los separadores.
Por ejemplo, si los parámetros tienen los valores Resistance=1k y Current=5mA, habrá texto después de la entrada #|PARAMS:| y la entrada que se insertará en la netlist será PARAMS: Resistance=1k Current=5mA.
@DESIGNATOR%1%2@VALUEEste ejemplo muestra el uso del carácter %.
Por ejemplo, si los parámetros tienen los valores DESIGNATOR=R1 y VALUE=1k, y los pines se asignan en la región Pin Mapping del cuadro de diálogo Sim Model según la siguiente tabla:
Pin del esquema Pin del modelo Nombre de la red a la que se conecta el pin del esquema 1 (N+) 1 (1) GND 2 (N-) 2 (2) OUT Entonces se insertará el texto R1 GND OUT 1k en la netlist SPICE de este componente.
- Sim Spice Prefix – el prefijo SPICE para el tipo de modelo que está vinculando.
-
Sim Port Map – la asignación de los pines del componente del esquema a los pines del modelo vinculado. Después de colocar el componente, esta información aparecerá en la región Pin Mapping del cuadro de diálogo Sim Model.
Cada par de pines debe introducirse con el siguiente formato:
(SchematicPinNumber:ModelPinNumber),con cada par asignado separado por una coma.
Por ejemplo, al asignar un modelo de simulación de diodo en el que el pin 1 del esquema (ánodo) debe asignarse al pin 1 del modelo (ánodo), y el pin 3 del esquema (cátodo) debe asignarse al pin 2 del modelo (cátodo), se introduciría lo siguiente en el campo de la base de datos:
(1:1),(3:2) -
Sim Excluded Parts – cree este campo en la base de datos si desea excluir de la simulación ciertas partes de un componente multiparte. Esta información corresponde a la opción Exclude part from simulation de la región Pin Mapping del cuadro de diálogo Sim Model.
De forma predeterminada, todas las partes de un componente multiparte se incluyen en una simulación, por lo que solo necesita especificar, por su número, las partes que desea excluir. Separe con comas las distintas partes de la lista de exclusión. Por ejemplo, si un componente tiene cuatro partes y no desea que las partes 2 y 4 se incluyan en ninguna simulación, introduciría lo siguiente en el campo de la base de datos:
2,4 -
Sim Parameters – cree este campo en la base de datos si desea asignar valores a los parámetros de simulación del modelo. Estos son parámetros que pueden definirse a nivel de componente, a diferencia de los parámetros más avanzados que pueden incluirse en un archivo de modelo.
Un parámetro debe introducirse con el siguiente formato:
ParameterName=Value,Los distintos parámetros deben separarse mediante el carácter de barra vertical (|).
Recordará que un parámetro de simulación a nivel de componente también puede establecerse como parámetro del componente, de modo que aparezca en la región Parameters del cuadro de diálogo Component Properties asociado y pueda mostrarse posteriormente en la hoja del esquema. De forma predeterminada, una entrada de parámetro en el campo Sim Parameters se añadirá automáticamente como parámetro del componente. Si no desea que un parámetro de simulación se añada como parámetro del componente, simplemente anteponga un signo de exclamación al nombre del parámetro (por ejemplo,
!Initial Voltage=100mV).Considere un modelo de diodo que tenga los siguientes cuatro parámetros a nivel de componente:
- Factor de área
- Condición de arranque
- Tensión inicial
- Temperatura.
Ahora suponga que añade valores en la base de datos para el factor de área (por ejemplo, 2) y la temperatura (por ejemplo, 22 °C). Además, ninguno de los dos debe añadirse como parámetro del componente. La entrada en el campo Sim Parameters sería:
!Area Factor=2|!Temperature=22
Parámetros
Todos los demás nombres de campo de la base de datos se asignarán automáticamente a parámetros de diseño con los mismos nombres. Por ejemplo, si un campo de la base de datos se llama Tolerance, se le asignará un parámetro de diseño con el nombre Tolerance. Puede cambiar el nombre de un parámetro de diseño haciendo clic en su celda y escribiendo directamente el nuevo nombre. Estos nombres de parámetros de diseño son los que aparecerán en la región Parameters del cuadro de diálogo de propiedades asociado al componente, una vez que se haya colocado en una hoja del esquema.
Puede que tenga una gran cantidad de campos de datos asociados a un componente en la base de datos y que no quiera, o ni siquiera necesite, añadirlos todos como parámetros de diseño al componente cuando lo coloque en una hoja de esquemático. Es posible que gran parte de esta información solo sea necesaria al generar una lista de materiales. El cuadro de diálogo Report Manager permite añadir información de parámetros a una BOM directamente desde una base de datos vinculada, lo que permite reducir la cantidad de información que se «arrastra» con los documentos fuente del esquemático. Para obtener más información, consulte la sección Preparación de una BOM en Report Manager.
Para los campos que no desee asignar desde la base de datos, establezca la entrada Design Parameter en [None]. Los campos de la base de datos sin asignar se distinguen en la pestaña mediante un icono de aspa roja Los campos de la base de datos asignados se distinguen mediante un icono de marca de verificación verde
Configure la asignación de parámetros según sea necesario. Establezca el valor en [None] para impedir que un parámetro de la base de datos se asigne al componente colocado. Los parámetros sin asignar pueden incluirse directamente en la BOM, si es necesario.
Opciones de actualización de parámetros
Las columnas restantes de la pestaña Field Mappings permiten especificar las acciones que se aplican a los parámetros al colocar un componente de la biblioteca de base de datos por primera vez o al actualizar un componente ya colocado mediante el comando Tools » Update Parameters From Database.
Las cuatro columnas son las siguientes:
- Update Values - una celda de esta columna se utiliza para determinar la acción que debe realizarse si el parámetro existe tanto en una hoja de esquemático como en la base de datos, pero sus valores actuales son distintos. Puede optar por actualizar el parámetro del componente colocado con el valor almacenado en la base de datos (Update) o por no actualizarlo (Do not update). Esta opción se aplica al utilizar el comando Update Parameters From Database, una vez colocado el componente.
- Add To Design - una celda de esta columna se utiliza para determinar la acción que debe realizarse si el parámetro se encuentra en la base de datos, pero no existe en el componente colocado. Puede optar por añadir el parámetro (Add), no añadirlo (Do not add) o añadirlo solo si tiene un valor asignado en la base de datos (Add only if not blank in database). Esta opción se aplica tanto al colocar inicialmente el componente desde la biblioteca de base de datos como al utilizar el comando Update Parameters From Database, una vez colocado el componente.
- Visible On Add - una casilla de verificación de esta columna se utiliza para determinar si un parámetro recién añadido, ya sea durante la colocación inicial o durante una actualización posterior, se muestra en el componente de la hoja de esquemático (activada) o no (desactivada).
- Remove From Design - una celda de esta columna se utiliza para determinar la acción que debe realizarse si el parámetro existe en el componente colocado, pero no está en la base de datos o está en ella, pero no tiene valor. Puede optar por no eliminar el parámetro en ningún caso (Do not remove) o por eliminarlo solo si no tiene un valor asignado en la base de datos (Remove only if blank in database). Esta opción se aplica al utilizar el comando Actualizar parámetros desde la base de datos, una vez colocado el componente.
Inicialmente, los campos Update Values, Add To Design y Remove From Design de cada campo asignado de la base de datos estarán establecidos en la entrada Default, y la opción Visible On Add estará desactivada, como se muestra en la siguiente imagen.
Opciones iniciales (predeterminadas) de actualización de parámetros.
En relación con la imagen, hay cuatro puntos importantes que destacar sobre las opciones de actualización:
- Los campos de la base de datos sin asignar no tendrán opciones de actualización asociadas.
- Las asignaciones basadas en atributos y modelos (entradas entre corchetes en la columna Design Parameter) no tendrán opciones de actualización asociadas, ya que no son parámetros de diseño.
- El campo clave (por ejemplo, Part Number en la imagen) no tendrá opciones de actualización asociadas. Este campo se utiliza únicamente para establecer la correspondencia de parámetros.
- El valor Default hace que una opción de actualización siga su definición predeterminada correspondiente, tal como se especifica en la pestaña Default Actions del cuadro de diálogo Database Library Options (Tools » Options desde los menús principales o Options desde el menú contextual de la pestaña Table Browser). También puede acceder a este cuadro de diálogo haciendo clic en el botón Options de la región Field Settings de la vista del documento.
Defina las opciones predeterminadas de actualización de parámetros en una ubicación central para una DbLib. Pase el cursor sobre la imagen para ver el equivalente para una SVNDbLib.
El cuarto punto resulta útil porque permite especificar las opciones de actualización desde una ubicación central y, después, hacer referencia a ella al definir las opciones de actualización de cada campo asignado. Por eso, la entrada Default se carga automáticamente en los campos de actualización correspondientes al asignar un campo de la base de datos a un parámetro de diseño.
Si desea modificar la configuración predeterminada de una opción de actualización, haga clic en el campo de actualización correspondiente de la pestaña Field Mappings y, a continuación, vuelva a hacer clic para acceder a una lista desplegable con las opciones de actualización disponibles.
Las opciones de actualización de parámetros pueden modificarse manualmente, si es necesario.
De este modo, tiene pleno control sobre cómo se actualizan los parámetros del diseño. Puede establecer todos los campos en Default y tomar las decisiones de actualización necesarias desde el cuadro de diálogo Database Library Options, configurar cada campo de actualización individualmente o combinar ambos métodos: usted decide lo que más le convenga. En el caso de los componentes colocados, la actualización se realiza mediante un cuadro de diálogo Engineering Change Order. Si en esta etapa hay actualizaciones que prefiere no realizar, puede optar por no incluir esos cambios concretos, de modo que usted tenga la última palabra sobre qué parámetros de diseño se actualizan.
Especificación de las ubicaciones de las bibliotecas de símbolos y modelos
Al colocar un componente desde una biblioteca de base de datos, su símbolo, especificado mediante la asignación [Library Ref], se extrae de la biblioteca de esquemáticos indicada (*.SchLib). Del mismo modo, las referencias a modelos (huella, PCB3D, simulación) especificadas en la base de datos residirán en los archivos correspondientes de biblioteca de PCB (*.PcbLib), biblioteca PCB3D (*.PCB3DLib) y modelos de simulación (*.mdl, *.ckt). Las rutas a estos archivos pueden especificarse explícitamente en la base de datos de las siguientes formas:
- Introduciendo una ruta absoluta al archivo.
- Introduciendo una ruta relativa al archivo.
Si ha definido campos en la base de datos para la información de las rutas, estos deben asignarse a los parámetros de diseño correspondientes: [Library Path], [Footprint Path], [PCB3D Path], [Sim File], etc. (consulte de nuevo Asignación de modelos y parámetros).
Introducir rutas, incluso relativas, en una tabla de base de datos puede resultar algo restrictivo. Si cambia la ubicación de un archivo de biblioteca o de modelo, tendrá que actualizar la tabla de la base de datos en consecuencia. Para ofrecerle mayor libertad, puede especificar la información de búsqueda de bibliotecas en el propio archivo DbLib/SVNDbLib. Esto permite especificar el nombre de la biblioteca de origen o del archivo de modelo en la base de datos, o no definirlo en absoluto.
Para una biblioteca de base de datos
Para una DbLib, las rutas de búsqueda de bibliotecas se definen en la pestaña Symbol and Model Search Paths del cuadro de diálogo Database Library Options (Tools » Options). También se puede acceder a este cuadro de diálogo haciendo clic en el botón Options de la sección Field Settings de la vista del documento.
Especificación de las rutas de búsqueda para las bibliotecas de símbolos y modelos.
Para añadir una ruta a la lista:
-
Escriba la ruta directamente en el campo situado debajo de la sección Rutas de búsqueda de bibliotecas, o haga clic en el botón
para acceder al cuadro de diálogo Browse for Folder, desde el que puede localizar el directorio donde se encuentran los archivos de biblioteca/modelo necesarios.
- Puede añadir una ruta absoluta o una ruta relativa (respecto a la ubicación del archivo DbLib). Utilice la opción Add/Update As Relative Path para controlar este ajuste.
- Después de especificar la ruta necesaria, añádala a la lista de rutas de búsqueda haciendo clic en el botón Add .
- Siga añadiendo rutas de búsqueda según sea necesario.
Las rutas de búsqueda de bibliotecas determinan dónde se pueden encontrar los archivos de bibliotecas y modelos al colocar componentes desde la biblioteca de base de datos y al buscar un modelo después de la colocación. El modelo específico que se utilice dependerá de cómo haya configurado las rutas de búsqueda de bibliotecas y de si ha añadido información específica de bibliotecas a la base de datos. La búsqueda se realizará en el siguiente orden:
- Si existe una ruta absoluta en el campo de ruta asignado al símbolo o modelo, se utilizará ese archivo de biblioteca/modelo y se extraerá el símbolo o modelo especificado en el campo de referencia correspondiente.
- Si existe una ruta relativa en el campo de ruta asignado al símbolo o modelo, se utilizará ese archivo de biblioteca/modelo y se extraerá el símbolo o modelo especificado en el campo de referencia correspondiente.
- Si solo existe un nombre de archivo de biblioteca/modelo en el campo de ruta asignado al símbolo o modelo, se utilizarán las rutas de búsqueda para localizar el primer archivo de biblioteca/modelo que coincida con el nombre especificado y que contenga una coincidencia para el símbolo o modelo especificado en el campo de referencia correspondiente.
- Si no existe información sobre el archivo de biblioteca/modelo en la base de datos, se utilizarán las rutas de búsqueda para localizar el primer archivo de biblioteca/modelo que contenga una coincidencia para el símbolo o modelo especificado en el campo de referencia correspondiente.
Para una biblioteca de base de datos SVN
Para una SVNDbLib, los directorios base dentro del repositorio de Subversion, en los que residen los símbolos y los modelos de huella, se especifican en la pestaña SVN Repository del cuadro de diálogo Database Library Options (Tools » Options). También se puede acceder a este cuadro de diálogo haciendo clic en el botón Options de la sección Field Settings de la vista del documento.
Especificación de los directorios base del repositorio para símbolos y huellas.
Utilice los campos disponibles en la sección Models Location para especificar el directorio base de los símbolos y las huellas. Haga clic en el botón
situado a la derecha de un campo para acceder al cuadro de diálogo Browse for directory, una ventana al repositorio vinculado. Utilice este cuadro de diálogo para seleccionar la carpeta necesaria.
Búsqueda del directorio correspondiente en el repositorio SVN vinculado.
Las ubicaciones de los modelos determinan dónde se pueden encontrar los archivos de bibliotecas y modelos al colocar componentes desde la biblioteca de base de datos con control de versiones y al buscar un modelo después de la colocación. El símbolo de esquema y los modelos de huella específicos que se utilicen dependerán de cómo haya configurado estas ubicaciones y de si ha añadido información específica de bibliotecas a la base de datos. La búsqueda se realizará en el siguiente orden:
- Si existe una ruta absoluta en el campo de ruta asignado al símbolo o modelo de huella (por ejemplo, http://MyServer/svn/MyCompany/ParentDirectory/SchematicSymbols/Capacitor_NonPolarized.SchLib), se utilizará ese archivo de biblioteca y se extraerá el símbolo o la huella especificados en el campo de referencia correspondiente.
- Si existe una ruta relativa (respecto a la raíz del repositorio) en el campo de ruta asignado al símbolo o modelo de huella (por ejemplo, /ParentDirectory/SchematicSymbols/Capacitor_NonPolarized.SchLib), se utilizará ese archivo de biblioteca y se extraerá el símbolo o la huella especificados en el campo de referencia correspondiente. La URL del repositorio, especificada en la sección Conexión al servidor del repositorio del cuadro de diálogo, se antepondrá a la ruta introducida para obtener la dirección absoluta.
- Si solo existe un nombre de archivo de biblioteca en el campo de ruta asignado al símbolo o modelo de huella (por ejemplo, Capacitor_NonPolarized.SchLib), se utilizarán las ubicaciones de modelos especificadas dentro del repositorio para localizar el primer archivo de biblioteca que coincida con el nombre especificado y que contenga una coincidencia para el símbolo o modelo de huella especificado en el campo de referencia correspondiente.
- Si no existe información sobre el archivo de biblioteca en la base de datos, se utilizarán las ubicaciones de modelos especificadas para localizar el primer archivo de biblioteca que contenga una coincidencia para el símbolo o modelo de huella especificado en el campo de referencia correspondiente.