Herramientas de migración de bibliotecas de bases de datos

De un vistazo

Explora las herramientas de migración de bibliotecas de base de datos disponibles en Altium Designer, con instrucciones paso a paso para convertir bibliotecas integradas en bibliotecas de base de datos estándar (DbLib) o en bibliotecas de base de datos SVN con control de versiones (SVNDbLib). El artículo explica cómo los asistentes de conversión gestionan los datos de los componentes, los símbolos y las huellas, y destaca las restricciones de las bases de datos y los requisitos de configuración. Sigue leyendo para elegir la opción de conversión adecuada y preparar tus bibliotecas para la migración.

- Comprende cuándo utilizar una DbLib en lugar de una SVNDbLib.
- Aprende a configurar los asistentes de conversión, seleccionar las bibliotecas de origen y especificar los destinos de la base de datos y del repositorio.
- Identifica los requisitos y las limitaciones importantes, como la compatibilidad de conversión exclusiva con Access, la preparación del repositorio SVN y la gestión de los enlaces a modelos.
Profundiza con IA:

El software de diseño de Altium permite colocar componentes directamente desde una base de datos de la empresa mediante la creación y el uso de una biblioteca de base de datos. El tipo de biblioteca de base de datos utilizado dependerá de cómo desee gestionar sus bibliotecas de símbolos y modelos de origen. Si las bibliotecas se van a almacenar en una ubicación de un disco duro o una unidad de red, bastará con utilizar una biblioteca de base de datos (DbLib). Si, por el contrario, desea someter sus bibliotecas a control de versiones mediante un repositorio Subversion, deberá utilizar una biblioteca de base de datos SVN (SVNDbLib).

Independientemente del tipo de biblioteca de base de datos utilizado, el principio subyacente de esta función es el mismo en todos los casos: la capacidad de colocar componentes directamente desde la base de datos externa vinculada. Para que esta potente función sea lo más accesible posible, se proporcionan herramientas que permiten trasladar rápidamente las bibliotecas existentes a la estructura de bibliotecas de base de datos. Estas herramientas permiten migrar de:

  • Una biblioteca integrada a una biblioteca de base de datos (DbLib o SVNDbLib).
  • Una biblioteca de base de datos (DbLib o SVNDbLib) a una biblioteca integrada.
  • Bibliotecas de esquemáticos/PCB de origen a una biblioteca de base de datos SVN.
  • Una biblioteca de base de datos a una biblioteca de base de datos SVN.
  • Un sistema de información de componentes (CIS) de OrCAD a una biblioteca de base de datos (DbLib).

En las siguientes secciones se explica con más detalle cómo se realizan estas migraciones en el software.

Creación de una biblioteca de base de datos a partir de una biblioteca integrada

Las bibliotecas integradas son, por su propia naturaleza, seguras. A esto se suma su excelente portabilidad para los diseños que salen de las instalaciones de la empresa. Si el diseño se va a mantener en las instalaciones y/o desea que sus componentes de diseño de Altium estén estrechamente vinculados a la base de datos de su empresa, las bibliotecas de base de datos son la opción perfecta. El software permite convertir rápidamente las bibliotecas integradas de su empresa a la estructura de biblioteca de base de datos (DbLib) o biblioteca de base de datos SVN (SVNDbLib). Se pueden incluir varias bibliotecas integradas en la conversión; cada una se añadirá como una tabla independiente a la base de datos de destino.

Conversión a una DbLib

La creación de una biblioteca de base de datos estándar (DbLib) a partir de una biblioteca integrada (IntLib) se realiza mediante el Integrated Library to Database Library Translator Wizard. Básicamente, el asistente descompila las bibliotecas integradas especificadas y utiliza cada una de ellas para crear una tabla independiente en la base de datos de destino elegida, con toda la información de parámetros y modelos extraída de los componentes que contiene. A continuación, se utiliza un archivo de biblioteca de base de datos especificado para establecer una conexión con esa base de datos.

El asistente también se puede utilizar para importar o añadir componentes adicionales a una base de datos existente, vinculada mediante un archivo DbLib existente.
La conversión solo admite el uso de bases de datos de tipo Access.

La incorporación de una o varias bibliotecas integradas de origen a la estructura de bibliotecas de base de datos es un proceso sencillo mediante el Integrated Library to Database Library Translator Wizard.La incorporación de una o varias bibliotecas integradas de origen a la estructura de bibliotecas de base de datos es un proceso sencillo mediante el Integrated Library to Database Library Translator Wizard.

El proceso consta de los siguientes pasos:

  1. Cree un nuevo archivo de biblioteca de base de datos o abra uno existente (*.DbLib). Normalmente, se utiliza un archivo DbLib existente al convertir una o varias bibliotecas integradas a una base de datos Access existente a la que dicho archivo DbLib ya está conectado.
  2. Con el archivo de biblioteca de base de datos (*.DbLib) abierto como documento activo, seleccione el comando Tools » Import From Integrated Libraries en los menús principales para acceder al Integrated Library to Database Library Translator Wizard.
  3. Utilice la página inicial Specify your Database details del asistente para especificar la base de datos de destino, ya sea una nueva base de datos Access o una existente. Si va a crear una nueva base de datos, haga clic en el icono de carpeta a la derecha del campo Database Location para acceder a un cuadro de diálogo estándar Open . Utilice este cuadro de diálogo para determinar dónde y con qué nombre se creará la nueva base de datos. El nombre y la ruta elegidos se introducirán en el campo Database Location.

    Si se ha accedido al asistente desde un archivo DbLib existente, la opción Existing Access Database estará seleccionada de forma predeterminada y el campo Database Location se rellenará previamente con la base de datos a la que se conecta dicho archivo DbLib.
  4. Utilice la siguiente página Specify your Target Database Library del asistente para especificar el archivo de biblioteca de base de datos de destino. Especifique la ruta y el nombre del nuevo archivo DbLib que se va a crear o busque y abra un archivo existente. Normalmente, se utiliza un archivo DbLib existente al convertir una o varias bibliotecas integradas a la base de datos Access existente a la que dicho archivo DbLib ya está conectado. De forma predeterminada, el campo se rellenará con el archivo DbLib activo.

    Si utiliza un archivo DbLib existente y cambia la base de datos de destino, al finalizar el asistente, el archivo DbLib quedará conectado a la nueva base de datos de destino.
  5. Utilice la siguiente página Locate the Integrated Libraries to Import del asistente para especificar las bibliotecas integradas que desea convertir. Utilice el botón Add para abrir el cuadro de diálogo Select Source Integrated Libraries, desde el que podrá buscar y seleccionar las bibliotecas necesarias. Las bibliotecas de símbolos de esquemático y modelos que las componen (si existen) se extraerán y guardarán en la ubicación especificada en el campo Destination Folder. Utilice los botones Remove y Clear para quitar o eliminar la biblioteca seleccionada.

    De forma predeterminada, Destination Folder apuntará a una subcarpeta, Libraries, situada dentro de la carpeta que contiene el archivo DbLib (especificado en la página anterior del asistente).
  6. Después de elegir las bibliotecas integradas de origen, haga clic en Next para iniciar la conversión. Se mostrará una barra de progreso junto con información sobre la biblioteca que se está convirtiendo. Una vez completada la conversión, haga clic en Finish en la última página del asistente para activar el archivo DbLib especificado en la ventana principal de diseño (si aún no está activo).

    Cada biblioteca integrada incluida en la conversión dará lugar a una tabla independiente en la base de datos, con el mismo nombre que la biblioteca integrada. En el caso de una base de datos existente, si ya existe una tabla con el mismo nombre que la biblioteca integrada, la información de esa biblioteca se añadirá a la tabla existente.

Archivo DbLib resultante una vez completado el proceso de conversión.
Archivo DbLib resultante una vez completado el proceso de conversión.

Una vez completado el proceso de conversión, puede acceder a las bibliotecas de esquemáticos de origen y eliminar toda la información de parámetros y modelos de los símbolos. A continuación, puede realizar los ajustes necesarios en la configuración de las correspondencias de campos del documento DbLib para que hagan referencia a las columnas adecuadas de la base de datos. Para obtener más información, consulte la sección Asignación de campos de base de datos a parámetros de diseño de la página Creación y definición de la biblioteca de base de datos.

El asistente solo extraerá la información de los modelos de huella correspondiente a la referencia del modelo y la ruta a los modelos definidos. En el caso de los modelos de simulación, la información de vinculación deberá introducirse manualmente en la base de datos externa.
Asegúrese de que los componentes de la biblioteca de esquemáticos incluidos en la IntLib no tengan un parámetro Part Number. La información del número de pieza que se introduce en la base de datos (para identificar cada registro de componente) se obtiene del campo Design Item ID del componente de esquemático, en la sección Properties de la pestaña General del panel Propiedades, al consultar las propiedades del componente de biblioteca seleccionado. Si también se introduce como parámetro, la conversión fallará debido a la duplicación de valores.

Conversión a una SVNDbLib

La creación de una biblioteca de base de datos con control de versiones (SVNDbLib) a partir de una biblioteca integrada (IntLib) se realiza mediante el SVN Database Library Conversion Wizard. Básicamente, el asistente descompila las bibliotecas integradas seleccionadas y utiliza cada biblioteca para crear una tabla independiente en una nueva base de datos de destino, con toda la información de parámetros y modelos extraída de sus componentes. A continuación, se crea el archivo de biblioteca de base de datos SVN especificado, que se utiliza para proporcionar la conexión a esa base de datos. Las bibliotecas de esquemas y de PCB que la componen se dividen y se confirman en los directorios especificados de un repositorio de control de versiones SVN seleccionado, a los que hace referencia el archivo SVNDbLib.

La conversión solo admite el uso de una base de datos de tipo Access.

Incorporar una o más bibliotecas integradas de origen a la estructura de bibliotecas de base de datos SVN es un proceso simplificado que utiliza el SVN Database Library Conversion Wizard.Incorporar una o más bibliotecas integradas de origen a la estructura de bibliotecas de base de datos SVN es un proceso simplificado que utiliza el SVN Database Library Conversion Wizard.

El proceso consta de los siguientes pasos:

  1. Acceda al SVN Database Library Conversion Wizard. Para ello:
  • Seleccione el comando Tools » SVN Database Library Maker en los menús principales del editor de bibliotecas de esquemas, del editor de bibliotecas de PCB o del editor de bibliotecas de base de datos.
  • En el panel Projects, haga clic con el botón derecho en la entrada de una biblioteca del proyecto (SchLib, PcbLib o IntLib) y, a continuación, seleccione el comando SVN Database Library Maker en el menú contextual.
  1. Utilice la página Libraries to Convert para especificar las bibliotecas integradas que desea convertir. Inicialmente, la lista contendrá una o más bibliotecas (la biblioteca activa o todas las bibliotecas que se hayan añadido al proyecto, según el método de acceso utilizado). Elimínelas de la lista antes de seleccionar las bibliotecas integradas que desea convertir. Utilice el botón Add para acceder al cuadro de diálogo Library Files, desde el que puede buscar y seleccionar las bibliotecas integradas necesarias.
  2. Utilice la página Options para definir las opciones de conversión, incluido cómo deben dividirse las bibliotecas de origen, en qué directorios de qué repositorio deben almacenarse y el directorio de salida del archivo SVNDbLib. Para las bibliotecas de esquemas, también se proporcionan dos opciones que permiten eliminar la información de parámetros y/o modelos de cada componente, dejando únicamente el símbolo.

    El repositorio SVN y su estructura de carpetas deben definirse previamente. Solo se seleccionan como destino el repositorio y las carpetas de su estructura en las que se almacenarán los archivos de biblioteca divididos. El repositorio y las carpetas no se crean sobre la marcha.
  3. Después de seleccionar las bibliotecas integradas de origen y configurar las opciones de conversión correspondientes según sea necesario, haga clic en Next para iniciar la conversión. Se mostrará una barra de progreso junto con información sobre la biblioteca que se está convirtiendo. El proceso de conversión incluye:
    1. La extracción de las bibliotecas de origen de las bibliotecas integradas proporcionadas.
    2. La división de las bibliotecas de esquemas y de PCB en archivos de biblioteca con un único símbolo o una única huella.
    3. La confirmación de las bibliotecas de símbolos y huellas divididas en el repositorio, en los directorios base especificados.
    4. El asistente solo extraerá la información de referencia de los modelos de huella. Las bibliotecas de base de datos con control de versiones (SVNDbLib) admiten modelos de simulación vinculados; sin embargo, no se admite el almacenamiento de archivos de modelos de simulación en el repositorio Subversion. Si existen estos vínculos, se añadirán como parámetros.
    5. La creación de una tabla independiente en la base de datos Access generada (que recibe el mismo nombre especificado para el archivo SVNDbLib) por cada biblioteca integrada que se convierta, con toda la información de parámetros y modelos extraída de sus componentes. Cada tabla recibe el nombre de la biblioteca integrada con el sufijo _IntLib (por ejemplo, Capacitor - Ceramic_IntLib).
    6. La creación del archivo SVNDbLib especificado, que se conecta a la base de datos y al repositorio.
  4. Una vez finalizada la conversión, haga clic en Finish para cerrar el asistente y establecer el archivo SVNDbLib como documento activo.

Archivo SVNDbLib resultante una vez finalizado el proceso de conversión.Archivo SVNDbLib resultante una vez finalizado el proceso de conversión.

Asegúrese de que los componentes de la biblioteca de esquemas de la IntLib no tengan un parámetro Part Number. La información del número de pieza introducida en la base de datos (para identificar el registro de cada componente) se obtiene del campo Design Item ID del componente de esquema, en la sección Properties de la pestaña General del panel Properties, al consultar las propiedades del componente de biblioteca seleccionado. Si también se introduce como parámetro, la conversión fallará debido a la duplicación de valores.

Creación de una biblioteca integrada a partir de una biblioteca de base de datos

Las bibliotecas de base de datos son una opción ideal si desea que sus componentes de Altium Design estén estrechamente vinculados a la base de datos de su empresa. Si el diseño debe salir de las instalaciones de su empresa o si prefiere que sus diseñadores trabajen con bibliotecas integradas seguras, puede lograrlo fácilmente. El software permite compilar una biblioteca integrada directamente a partir de una biblioteca de base de datos, ya sea una biblioteca de base de datos estándar (DbLib) o una biblioteca de base de datos SVN con control de versiones (SVNDbLib). De este modo, los responsables de las bibliotecas CAD pueden seguir utilizando bibliotecas de base de datos, mientras que los diseñadores utilizan bibliotecas integradas que se regeneran periódicamente, trabajando, por así decirlo, «sin conexión».

La conversión se realiza mediante el Offline Integrated Library Maker. El proceso se lleva a cabo por tabla de base de datos, con un control total sobre las tablas que se incluyen. Los componentes de esquema y los modelos de PCB, PCB3D y simulación se incluyen en el proceso de conversión. Se generará una biblioteca integrada independiente por cada tabla incluida. Estas tablas se convierten en bibliotecas integradas individuales que luego se añaden al Installed Libraries.

Convierta sus bibliotecas de base de datos (DbLib o SVNDbLib) en bibliotecas integradas «sin conexión» mediante el Offline Integrated Library Maker.
Convierta sus bibliotecas de base de datos (DbLib o SVNDbLib) en bibliotecas integradas «sin conexión» mediante el Offline Integrated Library Maker.

El proceso consta de los siguientes pasos:

  1. Con el archivo de biblioteca de base de datos (*.DbLib) o el archivo de biblioteca de base de datos SVN (*.SVNDbLib) que desea convertir abierto como documento activo, seleccione el comando Tools » Offline Integrated Library Maker en los menús principales para acceder al Offline Integrated Library Maker.
  2. Utilice la página Library to Convert para especificar la DbLib o SVNDbLib que se procesará. De forma predeterminada, la biblioteca activa desde la que se accedió al Offline Integrated Library Maker  se establecerá como la biblioteca que se va a convertir. Si es necesario, puede buscar y seleccionar otra biblioteca de base de datos.

  3. Utilice la página Options para especificar qué tablas de la base de datos vinculada se incluirán en la conversión. De forma predeterminada, se incluyen todas las tablas de la base de datos. Para excluir una tabla, asegúrese de que su opción Convert esté desactivada. Esta página también permite especificar un directorio de salida en el que se almacenarán las bibliotecas integradas generadas. Introduzca directamente la ruta de este directorio base o haga clic en el icono Browse icon situado a la derecha del campo para acceder a un cuadro de diálogo desde el que puede buscar y seleccionar el directorio necesario. El resultado generado (biblioteca integrada) para cada tabla de base de datos incluida se almacenará en su propia subcarpeta dentro del directorio de salida especificado, con el nombre de la tabla.

  4. Después de elegir la biblioteca de base de datos y configurar las opciones de conversión correspondientes según sea necesario, haga clic en Next para continuar con la conversión. Se mostrará una barra de progreso junto con información sobre la tabla de la base de datos que se está convirtiendo. Recuerde que el proceso de conversión se realiza para cada tabla de la base de datos que haya seleccionado para convertir. A continuación se detallan las etapas de este proceso:
    1. Se crea un paquete de biblioteca integrada (*.LibPkg) y se abre en el panel Projects. El paquete recibe el nombre de la tabla. Por ejemplo, para una tabla denominada Capacitor - Ceramic, el resultado sería Capacitor - Ceramic.LibPkg.
    2. Se crea un documento de biblioteca de esquemas y se añade al LibPkg. La biblioteca de esquemas también recibe el nombre de la tabla (p. ej., Capacitor - Ceramic.SchLib).
    3. A continuación, se procesa cada registro de la tabla y se crea el componente correspondiente de Altium Design. Para ello, se recupera el símbolo esquemático referenciado de la biblioteca de origen correspondiente y se añade como componente al nuevo documento de biblioteca de esquemas. Después, se añade a ese componente la información de parámetros y enlaces a modelos definida en el registro.
    4. Se recuperan los modelos de huella referenciados en el registro y se añaden a un documento de biblioteca de PCB. Este documento también recibe el nombre de la tabla (p. ej., Capacitor - Ceramic.PcbLib). A continuación, el documento de biblioteca de PCB se añade al LibPkg.
    5. Si la biblioteca de origen es una DbLib y se han definido enlaces a modelos de simulación en el registro de la base de datos, los archivos de modelos de simulación referenciados también se añaden al LibPkg. La ubicación de estos modelos no cambia. La ruta completa de un modelo se especifica como parte de su enlace al modelo correspondiente.
    6. A continuación, se compila el LibPkg para generar la biblioteca integrada (p. ej., Capacitor - Ceramic.IntLib), que posteriormente se añade a las bibliotecas instaladas del software.

Las bibliotecas instaladas actualmente se pueden consultar en la pestaña Installed del cuadro de diálogo Available File-based Libraries, al que se accede haciendo clic en el botón Open Libraries dialogs in Components Panel situado en la parte superior derecha del panel Components y seleccionando después File-based Libraries Preferences.

Resultados del proceso de conversión: proyectos de paquetes de bibliotecas con sus documentos de símbolos y modelos de huella, y las IntLib compiladas, que también se añaden como bibliotecas instaladas y, por tanto, quedan disponibles para todos los proyectos de diseño de PCB.
Resultados del proceso de conversión: proyectos de paquetes de bibliotecas con sus documentos de símbolos y modelos de huella, y las IntLib compiladas, que también se añaden como bibliotecas instaladas y, por tanto, quedan disponibles para todos los proyectos de diseño de PCB.

Creación de una SVNDbLib a partir de bibliotecas de origen (SCHLib/PCBLib)

El SVN Database Library Conversion Wizard le ayuda a convertir sus bibliotecas de esquemas, de PCB, de base de datos e integradas en bibliotecas de base de datos SVN. Este asistente simplifica el proceso de transformar diversas metodologías de gestión de componentes en una biblioteca de base de datos SVN (*.SVNDBLib). Una biblioteca de base de datos SVN aprovecha la posibilidad de colocar componentes directamente desde una base de datos y amplía este método de vinculación para admitir bibliotecas bajo control de versiones, alojando los símbolos esquemáticos y los modelos de huella en un repositorio basado en Subversion. El enlace al repositorio y a la base de datos externa se define en un archivo de biblioteca de base de datos SVN (*.SVNDBLib), una extensión del archivo de biblioteca de base de datos (*.DBLib) que suele denominarse Version-Controlled Database Library.

Utilice el asistente para definir las opciones de conversión, incluido cómo deben dividirse las bibliotecas de origen, en qué directorios de qué repositorio deben almacenarse y el directorio de salida del archivo SVNDBLib. 

Deberá elegir qué bibliotecas de base de datos, de esquemas (*.SchLib), de PCB (*.PcbLib) o integradas (*.IntLib) desea convertir; estas se incorporarán después a un repositorio SVN. También se creará una única biblioteca de base de datos SVN. 

Con este asistente, puede definir la conexión al repositorio SVN, el directorio base para los símbolos y modelos, y la ruta al documento de biblioteca de base de datos SVN. De forma predeterminada, el directorio de salida será el mismo en el que se almacena la biblioteca de origen.

Si desea que el archivo SVNDBLib generado y la base de datos estén en la misma ubicación, dispone básicamente de dos opciones. La primera es establecer como ruta de salida del SVNDBLib el mismo directorio en el que reside actualmente la base de datos. La segunda opción consiste en generar el SVNDBLib en otro directorio y después mover la base de datos a ese directorio. En este caso, deberá recordar modificar la conexión en el archivo SVNDBLib para que apunte a la nueva ubicación de la base de datos y volver a conectarse.

  • Como los archivos de biblioteca divididos se añadirán al repositorio SVN, deberá configurar externamente, en su disco duro local, la estructura de carpetas que desea utilizar en el repositorio para los archivos de símbolos y modelos. La estructura de carpetas del repositorio se gestiona mediante un cliente SVN, como TortoiseSVN.
  • Debe disponer de un repositorio SVN y de un sistema de control de versiones SVN instalado en su equipo o accesible a través de una red. Asegúrese también de que Provider en la página Data Management - Version Control del cuadro de diálogo Preferences esté configurado en SVN - Subversion.
  • La conversión solo admite bases de datos de tipo Access.

SVN Database Library Conversion WizardLa incorporación de una o varias bibliotecas de origen de esquemas y de PCB a la estructura de biblioteca de base de datos SVN es un proceso sencillo mediante el SVN Database Library
Conversion
Wizard.

El proceso consta de los siguientes pasos:

  1. Abra el SVN Database Library Conversion Wizard de las siguientes maneras:

    • Haga clic en Tools » SVN Database Library Maker desde un archivo de biblioteca de esquemas (*.SchLib), un archivo de biblioteca de PCB (*.PcbLib), un archivo de biblioteca integrada (*.IntLib) o un archivo de biblioteca de base de datos (*.DbLib). Sin embargo, si desea incluir los modelos de huella vinculados en la conversión al acceder al asistente desde una biblioteca de esquemas, deberá buscar y añadir las bibliotecas de huellas de PCB correspondientes. Además, la conversión únicamente de bibliotecas de huellas de PCB no es un caso habitual, por lo que deberá buscar y añadir las bibliotecas de componentes de esquemas correspondientes.
    • En el panel Projects , haga clic con el botón derecho en la entrada de la biblioteca que necesite (*.SchLib, *.PcbLib o *.IntLib) y seleccione SVN Database Library Maker. El asistente cargará automáticamente todas las bibliotecas del proyecto. Este es, con diferencia, el método más sencillo y requiere que las bibliotecas de origen de esquemas y de PCB estén añadidas a un proyecto. Esto suele ser así cuando no se han utilizado bibliotecas integradas.
    El asistente se rellena previamente con entradas de bibliotecas en función del lugar desde el que se accede a él; por tanto, para ahorrar tiempo, inicie el asistente desde el editor adecuado, como se indica a continuación.

  2. Utilice la página Libraries to Convert para seleccionar las bibliotecas que desea convertir. Elija entre bibliotecas de base de datos o bibliotecas de esquemas, de PCB e integradas. Las bibliotecas seleccionadas se dividirán en bibliotecas de componentes individuales y después se incorporarán a un repositorio SVN. Se creará una única base de datos SVN.

    • Converting a Database Library

      Al convertir Database Libraries, el proceso de conversión incluye:

      1. Dividir las bibliotecas de esquemas y PCB a las que hacen referencia los registros de componentes de la base de datos vinculada en archivos de biblioteca de un único símbolo o huella.
      2. Incorporar las bibliotecas de símbolos y huellas divididas al repositorio, en los directorios base especificados.
      3. Crear el archivo SVNDBLib especificado y conectarlo a la base de datos y al repositorio.
    • Converting Schematic, PCB, and Integrated Libraries

      Utilice el botón Add para acceder a un cuadro de diálogo estándar que permite buscar y seleccionar el archivo que desea añadir. Haga clic en el botón Remove  para eliminar la biblioteca seleccionada actualmente.

      Al convertir bibliotecas de esquemas, de PCB e integradas, el proceso de conversión incluye:

      1. Extraer las bibliotecas de origen de las bibliotecas integradas proporcionadas.
      2. Dividir las bibliotecas de esquemas y PCB en archivos de biblioteca de un único símbolo o huella
      3. Incorporar las bibliotecas de símbolos y huellas divididas al repositorio en los directorios base especificados.
      4. El asistente solo extraerá la información de referencia de los modelos de huella. Los modelos PCB3D y de simulación vinculados no son compatibles con una SVNDBLib. Si existen estos vínculos, se añadirán como parámetros.
      5. Crear una tabla independiente en la base de datos de Access generada para cada biblioteca de esquemas o biblioteca integrada que se convierta, con toda la información de parámetros y modelos extraída de los componentes. Cada tabla recibe el nombre de la biblioteca de esquemas, con el sufijo _SchLib(p. ej., Mixer_SchLib), o el nombre de la biblioteca integrada, con el sufijo _IntLib (p. ej., AD Differential Amplifier_IntLib).
      6. Crear el archivo SVNDBLib especificado y conectarlo a la base de datos y al repositorio.
  3. Utilice la página Options para definir las opciones de conversión, incluido cómo deben dividirse las bibliotecas de origen, en qué directorios de qué repositorio deben almacenarse y el directorio de salida del archivo SVNDbLib. Para una biblioteca de esquemas, también se proporcionan dos opciones que permiten eliminar la información de parámetros o modelos de cada componente que la integra, dejando únicamente el símbolo.

    El repositorio SVN y su estructura de carpetas deben definirse previamente. Solo se seleccionan el repositorio y las carpetas de su estructura en las que se almacenarán los archivos de biblioteca divididos. El repositorio y las carpetas no se crean sobre la marcha.

    SVN Options

    Utilice esta sección para definir los ajustes de conexión al repositorio SVN. 

    Utilice la lista desplegable Method para seleccionar el método de conexión: file (un repositorio basado en archivos), http (un repositorio en la nube), https (un repositorio seguro en la nube), svn o svn+ssh. 

    La sección Location (disponible solo cuando se selecciona file para Method) se utiliza para establecer la ruta de ubicación del repositorio. Utilice el icono de búsqueda de carpetas para buscar y seleccionar la ubicación deseada. 

    La sección Server (disponible solo cuando file es not seleccionado para Method) se utiliza para establecer el servidor deseado.

    Establezca Server Port en Default o Non-Default. Si selecciona Non-Default, introduzca el puerto del servidor en el cuadro de texto. También deberá introducir el nombre de Repository folder en el cuadro de texto.

    Server Port y Repository folder son opciones que solo están disponibles cuando el Method seleccionado es not file. 

    Indique el directorio base del repositorio para Symbols y Footprints haciendo clic en ... para buscar y seleccionar las carpetas deseadas para ambos.

    SVN DB Library Options

    La sección SVN DB Library Options permite especificar la ruta del documento de biblioteca de base de datos SVN. Si todavía no existe una base de datos de Access de respaldo, se creará una en la misma carpeta. Utilice el icono de búsqueda de carpetas para buscar y seleccionar la ruta.

    Si desea que el archivo SVNDBLib generado y la base de datos estén en la misma ubicación, dispone básicamente de dos opciones. La primera consiste en establecer como ruta de salida del SVNDBLib el directorio en el que se encuentra actualmente la base de datos. La segunda opción consiste en generar el SVNDBLib en otro directorio y, después, mover la base de datos a ese directorio. En este caso, deberá recordar modificar la conexión del archivo SVNDBLib para que apunte a la nueva ubicación de la base de datos y volver a conectarse.

    Library Splitting Options

    Utilice la lista desplegable para seleccionar si desea que los archivos se Overwrite Existing Files o Append Incrementing Number To File Names (para crear archivos nuevos con un sufijo añadido al dividir las bibliotecas). Cuando se selecciona Overwrite Existing Files, los archivos existentes en los repositorios se sobrescribirán al dividir las bibliotecas. Si se selecciona Append Incrementing Number To File Names, todos los archivos de los repositorios especificados quedarán protegidos y no se sobrescribirán, y a las nuevas bibliotecas de componentes con el mismo nombre se les añadirá el sufijo "_#IncrementNumber".

    Para una biblioteca de esquemas, también se proporcionan dos opciones que permiten eliminar la información de parámetros o modelos de los componentes de esquemas divididos, dejando únicamente el símbolo. Seleccione Remove All Parameters o Remove All Models, o ambas opciones. Dado que la base de datos externa ya existe —vinculada al archivo DBLib original—, no se creará ninguna. La base de datos permanecerá en su ubicación actual.

  4. Después de elegir las bibliotecas de esquemas y PCB de origen y configurar las opciones de conversión según sea necesario, haga clic en Next para continuar con la conversión. Se mostrará una barra de progreso junto con información sobre la biblioteca que se está convirtiendo. El proceso de conversión incluye:
    1. Dividir las bibliotecas de esquemas y PCB en archivos de biblioteca de un único símbolo o huella.
    2. Incorporar las bibliotecas de símbolos y huellas divididas al repositorio, en los directorios base especificados.
    3. El asistente solo extraerá la información de referencia de los modelos de huella. Los modelos de simulación vinculados son compatibles con una biblioteca de base de datos con control de versiones (SVNDbLib); sin embargo, no se admite el almacenamiento de archivos de modelos de simulación en el repositorio Subversion. Si existen estos vínculos, se añadirán como parámetros.
    4. Crear una tabla independiente en la base de datos de Access generada (que recibe el mismo nombre que el especificado para el SVNDbLib) para cada biblioteca de esquemas que se convierta, con toda la información de parámetros y modelos extraída de sus componentes. Cada tabla recibe el nombre de la biblioteca de esquemas con el sufijo _SchLib (p. ej., Capacitor - Ceramic_SchLib).
    5. Crear el archivo SVNDbLib especificado y conectarlo a la base de datos y al repositorio.
  5. Una vez finalizada la conversión, haga clic en Finish para cerrar el asistente y establecer el archivo SVNDbLib como documento activo.

Archivo SVNDbLib resultante tras finalizar el proceso de conversión.Archivo SVNDbLib resultante tras finalizar el proceso de conversión.

Asegúrese de que los componentes de su biblioteca de esquemas no tengan un parámetro Part Number. La información del número de pieza introducida en la base de datos, para identificar cada registro de componente, se obtiene del campo Design Item ID del componente de esquema en la sección Properties de la pestaña General del panel Properties al consultar las propiedades del componente de biblioteca seleccionado. Introducirla también como parámetro provocará un fallo en la conversión debido a la duplicación de valores. Aunque el proceso se completará, los componentes de esquema que tengan este parámetro no se crearán en la base de datos y, por lo tanto, no aparecerán en la lista de componentes de la base de datos de la pestaña Table Browser del documento SVNDbLib.

Conversión de una DbLib en una SVNDbLib

Es posible que ya esté aprovechando la potencia de la función de biblioteca de base de datos tras haber convertido sus bibliotecas integradas existentes a la estructura DbLib o haber creado una DbLib desde cero. Como siguiente paso, quizá desee poner sus bibliotecas de símbolos y huellas de origen bajo la protección y seguridad de un repositorio de control de versiones. El software proporciona los medios para realizar esta migración de su biblioteca de base de datos estándar actual (DbLib) a una biblioteca de base de datos con control de versiones (SVNDbLib).

La conversión se realiza con SVN Database Library Conversion Wizard de forma muy similar a la conversión de una biblioteca integrada.

SVN Database Library Conversion WizardLa conversión de una biblioteca de base de datos estándar existente (DbLib) en una biblioteca de base de datos con control de versiones (SVNDbLib) es un proceso simplificado mediante SVN Database
Library Conversion Wizard
.

El proceso consta de los siguientes pasos:

  1. Abra la DbLib existente que desea convertir y, a continuación, seleccione Tools » SVN Database Library Maker en los menús principales. Se abrirá SVN Database Library Conversion Wizard.
  2. Utilice la página Libraries to Convert para especificar la biblioteca de base de datos de origen que desea convertir. La opción Database Libraries ya estará activada, y el campo asociado contendrá la ruta de la biblioteca activa. Si desea convertir otra DbLib, haga clic en el botón Browse icon y utilice el cuadro de diálogo que aparece para buscarla.
  3. Tras hacer clic en Next, se analiza el archivo DbLib seleccionado y aparece un cuadro de diálogo de confirmación que le informa de que la base de datos subyacente podría modificarse. Haga clic en Yes para continuar.
  4. Utilice la página Options para definir las opciones de conversión, incluido cómo deben dividirse las bibliotecas de origen, en qué directorios de qué repositorio deben almacenarse y el directorio de salida del archivo SVNDbLib. Para las bibliotecas de esquemas, también se proporcionan dos opciones que permiten eliminar la información de parámetros o modelos, o ambas, de cada componente y dejar únicamente el símbolo.
El repositorio SVN y su estructura de carpetas deben definirse de antemano. Solo está seleccionando el repositorio y las carpetas de su estructura en las que se almacenarán los archivos de biblioteca divididos. El repositorio y las carpetas no se crean sobre la marcha.
Como la base de datos externa ya existe y está vinculada al archivo DbLib original, no se creará otra. La base de datos permanecerá en su ubicación actual. Si desea que el archivo SVNDbLib generado y la base de datos estén en la misma ubicación, básicamente tiene dos opciones. La primera es establecer como ruta de salida de la SVNDbLib el mismo directorio en el que se encuentra actualmente la base de datos. La segunda opción es generar la SVNDbLib en otro directorio y, a continuación, mover la base de datos a ese directorio. En este caso, deberá recordar modificar la conexión en el archivo SVNDbLib para que apunte a la base de datos en su nueva ubicación y volver a conectarse.
  1. Tras seleccionar el archivo DbLib de origen y configurar las opciones de conversión según sea necesario, haga clic en Next para iniciar la conversión. Se mostrará una barra de progreso junto con información sobre la biblioteca que se está convirtiendo. El proceso de conversión incluye:
    1. Dividir las bibliotecas de esquemas y de PCB a las que hacen referencia los registros de componentes de la base de datos vinculada en archivos de biblioteca de un solo símbolo o una sola huella.
    2. Incorporar las bibliotecas de símbolos y huellas divididas al repositorio en los directorios base especificados.
    3. Crear el archivo SVNDbLib especificado y conectarlo a la base de datos y al repositorio.
  2. Una vez completada la conversión, haga clic en Finish para cerrar el asistente y establecer el archivo SVNDbLib como documento activo.

Archivo SVNDbLib resultante una vez completado el proceso de conversión.Archivo SVNDbLib resultante una vez completado el proceso de conversión.

Una observación sobre las asignaciones de campos

En la SVNDbLib generada, las asignaciones definidas entre los campos de la base de datos y los parámetros de diseño en la pestaña Field Mappings se mantienen tal como se definieron originalmente en la DbLib.

Las asignaciones de campos se mantienen iguales en la DbLib original y en la SVNDbLib generada.Las asignaciones de campos se mantienen iguales en la DbLib original y en la SVNDbLib generada.

Sin embargo, hay dos aspectos importantes que conviene destacar:

  • Se ignoran todas las asignaciones de rutas definidas para símbolos y modelos de huellas. La SVNDbLib utiliza únicamente los campos de referencia asignados, [Library Ref] y [Footprint Ref], para localizar el símbolo y la huella necesarios en las bibliotecas incorporadas al repositorio. La información de rutas definida en la base de datos se ignora, ya que apunta a bibliotecas ubicadas en un disco duro u otro medio local o de red.
Si desea seguir incluyendo información de rutas en la base de datos, modifíquela para que apunte a las bibliotecas del repositorio. Conviene recordar que no especificar información sobre las rutas de las bibliotecas en la base de datos hace que esta sea mucho más robusta. La ubicación del repositorio o su estructura interna de carpetas podrían cambiar sin necesidad de actualizar la base de datos.
  • Todas las asignaciones de modelos de simulación definidas también se conservarán en el archivo SVNDbLib. Sin embargo, no se admite el almacenamiento de archivos de modelos de simulación en el repositorio Subversion. Aunque los vínculos a los modelos se añadirán a una instancia de componente al colocarla, los modelos en sí no se encontrarán.

Compatibilidad directa con OrCAD® CIS

Basado en el sistema de bibliotecas de base de datos, el software ofrece compatibilidad completa para conectarse a los sistemas de información de componentes (CIS) de OrCAD existentes y utilizarlos. Básicamente, la estructura CIS se convierte en la estructura de biblioteca de base de datos estándar de Altium Designer (DbLib).

De OrCAD a Altium Designer: conversiones necesarias

Para permitir la colocación directa desde la base de datos externa (*.mdb, *.xls), se requieren las siguientes conversiones de archivos:

  • El archivo de configuración de OrCAD CIS (*.dbc), que gestiona el vínculo con la base de datos externa e incluye la información de asignación entre los campos de la base de datos y los parámetros de diseño, debe convertirse en un archivo de biblioteca de base de datos de Altium Designer (*.DbLib).
Actualmente, Altium Designer solo admite archivos .dbc de OrCAD CIS en formato binario.
  • Los archivos de biblioteca de OrCAD correspondientes deben convertirse en archivos de biblioteca de Altium Designer:
    • Biblioteca de OrCAD Capture (*.olb) ---> Biblioteca de esquemas (*.SchLib).
    • Archivo de biblioteca de OrCAD Max (*.llb) ---> Biblioteca de PCB (*.PcbLib).

Creación automática de la biblioteca de base de datos

El método más sencillo y eficiente para crear el archivo DbLib y las bibliotecas de origen de Altium Designer es utilizar el asistente de importación (File » Import Wizard). En la segunda página del asistente, asegúrese de que la entrada OrCAD CIS Configuration Files and Libraries esté seleccionada como tipo de archivo de importación.

Utilice Import Wizard para convertir rápidamente su archivo de configuración de CIS y las bibliotecas de OrCAD relacionadas en archivos DbLib y de bibliotecas de origen (SchLib y PcbLib) de Altium Designer.
Utilice Import Wizard para convertir rápidamente su archivo de configuración de CIS y las bibliotecas de OrCAD relacionadas en archivos DbLib y de bibliotecas de origen (SchLib y PcbLib) de Altium Designer.

Utilice Import Wizard para convertir rápidamente su archivo de configuración de CIS y las bibliotecas de OrCAD relacionadas en archivos DbLib y de bibliotecas de origen (SchLib y PcbLib) de Altium NEXUS.
Utilice Import Wizard para convertir rápidamente su archivo de configuración de CIS y las bibliotecas de OrCAD relacionadas en archivos DbLib y de bibliotecas de origen (SchLib y PcbLib) de Altium NEXUS.

Siga las páginas posteriores del asistente, en las que deberá especificar:

  • La ubicación de la base de datos externa.
  • La ubicación del archivo de configuración de CIS (*.dbc); recuerde que debe estar en formato binario y no en XML.
  • Dónde y con qué nombre se creará el archivo DbLib de destino.
  • Las bibliotecas de esquemas y/o de PCB de OrCAD a las que hace referencia la base de datos externa.
Al especificar las bibliotecas de origen de OrCAD, también puede controlar dónde se guardan las bibliotecas de Altium Designer resultantes. De forma predeterminada, estas bibliotecas se guardarán en la subcarpeta \Libraries ubicada en el mismo directorio que el archivo DbLib de destino.

Siga las páginas del asistente y especifique la base de datos, el archivo de configuración de CIS, las bibliotecas de origen de OrCAD y el archivo DbLib de destino.
Siga las páginas del asistente y especifique la base de datos, el archivo de configuración de CIS, las bibliotecas de origen de OrCAD y el archivo DbLib de destino.

Siga las páginas del asistente y especifique la base de datos, el archivo de configuración de CIS, las bibliotecas de origen de OrCAD y el archivo DbLib de destino.
Siga las páginas del asistente y especifique la base de datos, el archivo de configuración de CIS, las bibliotecas de origen de OrCAD y el archivo DbLib de destino.

Después de especificar los archivos y directorios de origen y destino según sea necesario, haga clic en Next para continuar con la importación. Una vez finalizada la importación, haga clic en Finish para cerrar el asistente y establecer el archivo DbLib como documento activo.

Archivo DbLib resultante tras finalizar el proceso de importación.
Archivo DbLib resultante tras finalizar el proceso de importación.

Archivo DbLib resultante tras finalizar el proceso de importación.
Archivo DbLib resultante tras finalizar el proceso de importación.

Aspectos que se deben tener en cuenta:

  • Se añade automáticamente una ruta de búsqueda de bibliotecas al archivo DbLib en la pestaña Symbol & Model Search Paths del cuadro de diálogo Opciones de biblioteca de base de datos, que apunta al directorio que contiene los archivos de biblioteca convertidos.
  • La información de asignación de parámetros, incluida la clave de búsqueda definida, se obtiene directamente del archivo de configuración de CIS de OrCAD.
  • Se establecen automáticamente dos entradas de asignación de modelos. A continuación se muestran ejemplos de nombres de campos de la base de datos para estas entradas y las entradas Design Parameter asignadas:
    • Footprint Name ---> [Orcad Footprint]
    • Symbol Name ---> [Orcad Library]

Estas entradas proporcionan el vínculo al símbolo de esquema de origen para un registro de componente concreto de la base de datos externa y al modelo de huella de PCB correspondiente vinculado a ese componente.

Creación manual de la biblioteca de base de datos

  1. Crear el archivo DbLib mediante Import Wizard es el método más rápido, pero no el único. También puede crear el archivo DbLib manualmente. Para ello:
  2. Cree un nuevo archivo DbLib, conéctelo a la base de datos externa y defina las opciones de asignación y actualización de parámetros según sea necesario.
  3. A continuación, deberá importar las bibliotecas de OrCAD. Para ello, puede utilizar Import Wizard para convertir los archivos de biblioteca de OrCAD (*.olb, *.llb) en bibliotecas de Altium Designer (*.SchLib, *.PcbLib).
    1. Al elegir los tipos de archivo que desea importar, seleccione la entrada OrCAD Designs and Libraries Files.

    2. Omita la página de Importing OrCAD Designs y continúe con la página de Importing OrCAD Libraries. Añada todas las bibliotecas de origen de OrCAD a las que hace referencia la base de datos.

    3. Omita las demás páginas posteriores relacionadas con la importación de archivos de diseño.

    4. En la página Output Library Options, deje activada la opción predeterminada Output Libraries as PCB Project.

    5. En la página Output Libraries, especifique el directorio de salida para los archivos de biblioteca generados.

Importación de las bibliotecas de origen de OrCAD que contienen los símbolos y las huellas a los que se hace referencia en la base de datos.
Importación de las bibliotecas de origen de OrCAD que contienen los símbolos y las huellas a los que se hace referencia en la base de datos.

Importación de las bibliotecas de origen de OrCAD que contienen los símbolos y las huellas a los que se hace referencia en la base de datos.
Importación de las bibliotecas de origen de OrCAD que contienen los símbolos y las huellas a los que se hace referencia en la base de datos.

  1. Una vez finalizada la importación, se generará una carpeta denominada Imported OrCAD Libraries.PrjPcb en el directorio especificado. Puede mover las bibliotecas de Altium Designer generadas a otra ubicación según sea necesario. Por ejemplo, puede mover las bibliotecas a una carpeta denominada Libraries creada dentro del directorio que contiene el archivo DbLib.
  2. Una vez que disponga de las bibliotecas de símbolos y huellas, deberá volver al archivo DbLib y configurar las rutas de búsqueda de bibliotecas (en la pestaña Symbol & Model Search Paths del cuadro de diálogo Opciones de biblioteca de base de datos) para que apunten a la carpeta del directorio en la que se almacenan esas bibliotecas.
AI-LocalizedLocalizado por IA
Si encuentra un problema, seleccione el texto/imagen y presioneCtrl + Enterpara enviarnos sus comentarios.
Nav
Contents
Disponibilidad de funciones

Las funciones disponibles para usted dependen de qué solución de Altium tenga: Altium Develop, Altium Agile Teams, Altium Agile Enterprise o Altium Designer (con suscripción activa).

Si no ve una función documentada en su software actual, contacte con Ventas de Altium para obtener más información.

Documentación heredada

La documentación de Altium Designer ya no está versionada. Si necesita acceder a la documentación de versiones anteriores de Altium Designer, visite la sección Documentación heredada de la página de Otros instaladores.

Contents