Vinculación de componentes existentes a una base de datos de la empresa mediante un archivo de enlace de base de datos
De un vistazo
- Comprenda cuándo utilizar DbLink en lugar de DbLib o SVNDbLib.
- Aprenda a crear un archivo Database Link y a configurar conexiones con Access, Excel y otras bases de datos compatibles.
- Identifique los requisitos de vinculación mediante campos clave y las consideraciones relativas a los motores de bases de datos de 64 bits.
Un requisito habitual en muchas organizaciones es vincular los componentes de CAD electrónico con la base de datos central de componentes de la empresa. Altium Designer lo permite mediante la vinculación de componentes existentes con registros de la base de datos de la empresa, a través de la creación y el uso de un archivo Database Link. El archivo de enlace a base de datos se añade al proyecto de diseño o al paquete de bibliotecas, lo que permite vincular, respectivamente, componentes ya colocados en hojas de esquemático o, como es más habitual, componentes definidos en una biblioteca de esquemáticos de origen.
Una vez establecido el vínculo, puede transferir la información paramétrica asignada desde los registros de la base de datos a los parámetros de diseño de los componentes mediante el comando Tools » Update Parameters From Database. Esta información se puede incluir después en la lista de materiales (BOM) final, lista para la adquisición de componentes.
Unas palabras sobre las opciones de vinculación...
Altium Designer ofrece tres métodos para vincular un componente con una base de datos: mediante un archivo de enlace a base de datos (*.DbLink), un archivo de biblioteca de base de datos (*.DbLib) o un archivo de biblioteca de base de datos SVN (*.SVNDbLib), respectivamente. El enfoque DbLink proporciona un medio eficaz para vincular los componentes utilizados en el diseño (o en las bibliotecas) y mantenerlos sincronizados con los datos introducidos en la base de datos. El enfoque DbLib/SVNDbLib aprovecha esta eficacia de vinculación ya probada y le añade la libertad de colocar un componente directamente desde la base de datos; en esencia, crea el componente de forma dinámica a partir de la información almacenada para él en el registro correspondiente de la base de datos.
Antes de profundizar en la función de enlace a base de datos, conviene explicar las diferencias entre estos dos métodos en cuanto a su uso.
Vinculación mediante un archivo de enlace a base de datos
- Con este método, el archivo de enlace a base de datos define la vinculación entre el componente del esquemático y un registro coincidente de una base de datos. La coincidencia del registro se establece mediante la vinculación por campos clave, que puede utilizar un único campo clave (por ejemplo, un número de pieza) o varios campos clave (mediante la definición de una cláusula Where).
- Con este método de vinculación, la información de modelos y parámetros del componente debe estar predefinida como parte del componente de biblioteca de Altium Designer. El componente de biblioteca también debe incluir la información necesaria de los campos clave como parte de su definición. Una vez definida esta información, se añade un archivo de enlace a base de datos al paquete de bibliotecas o al proyecto de diseño, y entonces se puede sincronizar la información del componente (parámetros) con el contenido de los campos de la base de datos.
- Aunque no es necesario que cada componente físico definido por cada registro de la base de datos se corresponda con un componente de biblioteca único de Altium Designer —varios componentes de la base de datos pueden compartir el mismo símbolo de componente—, este método de vinculación suele utilizarse con una relación de «un registro de base de datos por cada componente de Altium Designer». El componente único de Altium Designer puede ser una instancia colocada en una hoja de esquemático o un componente único de una biblioteca de componentes.
- Con la vinculación a bases de datos de tipo DbLink, el archivo de enlace a base de datos se incluye en el paquete de bibliotecas o en el proyecto de diseño.
Vinculación mediante un archivo de biblioteca de base de datos
Related page: Bibliotecas de bases de datos
- Con este método, el archivo de biblioteca de base de datos también define la vinculación entre el componente del esquemático y un registro coincidente de una base de datos. De nuevo, la coincidencia del registro se establece mediante la vinculación por campos clave, que puede utilizar un único campo clave (por ejemplo, un número de pieza) o varios campos clave (mediante la definición de una cláusula Where).
- Con este método de vinculación, la información del símbolo, los modelos y los parámetros de un componente se almacena como parte de la definición del registro de ese componente en la base de datos externa. El componente de esquemático referenciado (almacenado en una biblioteca de componentes subyacente (*.SchLib)) es únicamente el símbolo; no tiene modelos vinculados ni parámetros de diseño definidos.
- Cuando se coloca el componente, la información de sus parámetros y modelos se crea sobre la marcha, utilizando los campos correspondientes del registro coincidente de la base de datos y de acuerdo con la asignación definida. A continuación, se utilizan uno o varios de estos parámetros para mantener un vínculo permanente con la base de datos, según los criterios de coincidencia definidos, lo que permite realizar sincronizaciones posteriores a la colocación.
- Este método de vinculación, debido a la creación dinámica de componentes en el momento de colocarlos, se presta muy bien a su uso con una relación de «varios registros de base de datos por cada componente de Altium Designer». Por ejemplo, la base de datos podría incluir la serie de resistencias E96, con todos los registros haciendo referencia al mismo símbolo de resistencia del esquemático y a la misma huella de PCB.
- A diferencia de la vinculación a bases de datos de tipo DbLink, en la que el archivo DbLink debe incluirse en el paquete de bibliotecas (o en el proyecto de diseño), no es necesario añadir el archivo DbLib/SvnDbLib al proyecto. La biblioteca de base de datos (DbLib) se incluye en las bibliotecas disponibles, accesibles desde el panel Componentes. Recuerde que las bibliotecas disponibles pueden incluir bibliotecas del proyecto, bibliotecas instaladas o bibliotecas encontradas en las rutas de búsqueda especificadas.
- Normalmente, los archivos DbLib/SVNDbLib se configuran con una organización por bibliotecas. Por ejemplo, podría tener uno para todas las resistencias detalladas en la base de datos de su empresa, otro para los condensadores, etc.
Creación del archivo de enlace a base de datos
Como se ha mencionado, la base de la función de enlace a base de datos es el archivo de enlace a base de datos. Este archivo se crea y gestiona mediante el editor DatabaseLink de Altium Designer. Este editor está disponible cuando el documento activo en la ventana principal de diseño es un archivo *.DbLink.
Ejemplo de archivo DbLink abierto en el editor DatabaseLink.
Para crear un nuevo archivo de este tipo:
- Seleccione el comando File » New » Library » Database Link File en los menús principales.
- Haga clic con el botón derecho en la entrada del proyecto correspondiente en el panel Proyectos y seleccione el comando Add New to Project » Database Link File en el menú contextual.
Conexión a una base de datos externa
Los datos de las tablas y de las correspondencias solo aparecerán en la ventana principal del editor una vez que el archivo de vínculo a base de datos activo se haya conectado correctamente a la base de datos externa requerida. La conexión se define mediante los controles de la sección Source of Connection.
Especificación de la conexión a la base de datos externa.
Es posible conectarse a cualquier base de datos compatible con OLE DB. Cada una de las opciones de esta sección utiliza una cadena de conexión OLE DB para conectarse a la base de datos de destino. Es posible que algunas bases de datos no sean compatibles con OLE DB. Sin embargo, prácticamente todos los sistemas de gestión de bases de datos que se utilizan actualmente son accesibles a través de la interfaz Open Database Connectivity (ODBC). La función de vínculo a base de datos utiliza el proveedor ODBC de Microsoft, que permite que un ADO (ActiveX Data Object) se conecte a cualquier origen de datos ODBC. Por lo tanto, es posible conectarse a cualquier base de datos ODBC. El proveedor OLE DB para la base de datos ODBC se especifica como parte de la cadena de conexión.
Conexión rápida a bases de datos de Access y Excel
La opción Select Database Type ofrece un método rápido para crear una cadena de conexión cuando la base de datos de destino se ha creado con Microsoft Access o Microsoft Excel. Con esta opción, seleccione el tipo de base de datos y, a continuación, busque y seleccione el archivo de base de datos requerido. La cadena de conexión correspondiente se generará automáticamente y se introducirá en el campo de la opción Use Connection String.
Creación de una cadena de conexión
Si la base de datos de su empresa no está basada en Access o Excel y desea crear la cadena de conexión de forma explícita, active la opción Use Connection String y, a continuación, haga clic en el botón Build asociado, situado a la derecha. Aparecerá el cuadro de diálogo Data Link Properties.
Creación de una cadena de conexión mediante el cuadro de diálogo Data Link Properties.
El cuadro de diálogo se abre en la pestaña Connection . El proveedor OLE DB Microsoft Office <Version> Access Database Engine OLE DB Provider está configurado de forma predeterminada en la pestaña Provider del cuadro de diálogo. Este es el proveedor predeterminado para los nuevos archivos de vínculo a base de datos y también se utiliza para conectarse a archivos de base de datos de Access (*.mdb). Cambie el proveedor según sea necesario.
En la pestaña Connection , introduzca el nombre (incluida la ruta) de la base de datos a la que desea conectarse.
Si su base de datos requiere credenciales de inicio de sesión, introdúzcalas según corresponda, junto con cualquier otra configuración avanzada disponible en la pestaña Advanced del cuadro de diálogo. La pestaña All proporciona una lista resumida de las opciones de vínculo definidas, así como opciones ampliadas relacionadas con el proveedor OLE DB seleccionado. También se pueden modificar las opciones en esta pestaña según sea necesario.
Una vez definidas las opciones de vínculo, puede comprobar si la conexión se establece correctamente haciendo clic en el botón Test Connection (en la pestaña Connection ). Si la conexión se establece correctamente, aparecerá un cuadro de diálogo de confirmación.
Especificación de un archivo de vínculo de datos
Si el origen de datos al que desea conectarse se describe mediante un archivo de vínculo de datos de Microsoft (*.udl), active la tercera opción de conexión, Use Data Link File, y haga clic en el botón Browse asociado para localizar el archivo requerido. Un archivo de vínculo de datos es, esencialmente, un contenedor para almacenar una cadena de conexión.
Establecimiento de la conexión
Después de definir la conexión a la base de datos externa, el texto del botón Connect aparecerá en negrita, lo que indica que puede proceder a establecer la conexión. Si los datos de conexión son correctos, la información de las tablas y de las correspondencias de la base de datos de destino se cargará en el archivo de vínculo a base de datos. El texto del botón Connect cambiará a Connected y el botón quedará deshabilitado.
Si hay algún problema con los datos de conexión, por ejemplo, si la cadena de conexión se ha creado incorrectamente o se ha introducido una ruta errónea, la conexión fallará y aparecerá un mensaje para avisarle. Compruebe la configuración de conexión y vuelva a hacer clic en el botón Connect .
Ejemplos de avisos de error de conexión.
Una vez establecida correctamente la conexión inicial y guardado el archivo de vínculo a base de datos, la conexión se realizará automáticamente cada vez que se abra el archivo, siempre que no se cambien la ubicación ni el nombre del archivo de la base de datos de destino.
Lista de tablas de la base de datos
Tras conectarse correctamente a la base de datos externa, se cargarán los datos de las tablas y de las correspondencias. En el lado izquierdo del documento DbLink se muestran todas las tablas que existen en la base de datos conectada.
Tablas existentes en la base de datos conectada.
La opción Enable situada junto a cada entrada de tabla permite controlar si esa tabla se utilizará al actualizar los parámetros desde la base de datos.
Al hacer clic en una entrada de tabla de la lista, su icono cambia de
a
para identificarla como la tabla activa. La tabla, con todos sus datos, aparece en la pestaña Table Browser del documento. Se trata de una copia no editable de la tabla que permite consultar rápidamente su contenido sin tener que abrir la propia base de datos externa.
Exploración de una tabla de origen en la base de datos conectada.
Especificación de los criterios de coincidencia
Para actualizar la información de los parámetros de los componentes con la almacenada en los campos de la base de datos externa, primero se debe establecer una correspondencia entre cada componente del diseño y una fila de una tabla de la base de datos. La sección Field Settings del documento permite definir los criterios de coincidencia, ya sea mediante una búsqueda sencilla con una sola clave o mediante una coincidencia más avanzada utilizando una cláusula WHERE.
Control de los criterios de coincidencia.
Búsqueda con una sola clave
Si la opción Single key lookup está activada (de forma predeterminada), los campos Database field y Part parameter estarán disponibles. El campo Database field muestra todos los nombres de campo disponibles (encabezados de columna) en la tabla activa de la base de datos. El campo Part parameter muestra todos los parámetros presentes en los componentes del diseño, tanto los del sistema como los definidos por el usuario.
Utilice estos campos para especificar la correspondencia entre un campo de la tabla y un parámetro de un componente (común a todos los componentes). Normalmente, el campo de correspondencia en ambos casos es un dato que identifica de forma unívoca cada componente en la base de datos externa, como un número de pieza. El campo de búsqueda elegido se distingue en la pestaña Field Mappings del documento por la entrada Design Parameter, que aparece atenuada.
Asignación de clave única por número de pieza
Al utilizar la función Tools » Update Parameters From Database, se lee la información del parámetro clave elegido en los componentes colocados en el esquema y, a continuación, se busca en el campo (clave) elegido de la base de datos, en todas las tablas habilitadas. Cuando se encuentra una coincidencia, la información de otras celdas de ese registro de la tabla de origen puede transferirse a los parámetros asignados del componente del esquema.
Correspondencia avanzada: la cláusula WHERE
Aunque la opción Single key lookup funciona bien si existe un número de pieza o identificador único con el que establecer la correspondencia, no resulta tan eficaz cuando se utiliza un parámetro que no es único, como la capacitancia o la resistencia. En este caso, debe utilizarse la cláusula WHERE, más avanzada, que permite especificar una correspondencia mediante varias claves para vincular el componente del esquema con la fila requerida de la tabla correspondiente de la base de datos.
En su forma más sencilla, la cláusula WHERE (escrita con sintaxis SQL) refleja las entradas elegidas que definen la búsqueda por clave única. Por ejemplo, si se ha seleccionado Part Number como Database field y se ha seleccionado Part Number como Part parameter único (presente en todos los componentes del diseño), la entrada de la cláusula WHERE sería:
[Part Number] = '{Part Number}'
Los corchetes que rodean el campo de la base de datos (columna de la tabla) son caracteres delimitadores, tal como se especifica en la pestaña Advanced del cuadro de diálogo Database Connection. Acceda a este cuadro de diálogo haciendo clic en el botón Advanced de la sección Source of Connection del documento, o desde el menú principal Tools .
La pestaña Advanced del cuadro de diálogo Database Connection proporciona opciones SQL adicionales para delimitar tablas o utilizar nombres de esquema de tabla en una cláusula WHERE construida.
Las llaves especifican que la entrada a la que se hace referencia es un parámetro de diseño. Las comillas simples se utilizan para especificar que el parámetro de diseño debe tratarse como una cadena de texto, en lugar de como un número (sin comillas). La coincidencia de tipos es muy importante, ya que SQL distingue entre tipos de datos. El parámetro de diseño debe tener el mismo tipo que la columna de la base de datos.
Mediante la sintaxis SQL estándar, la cláusula WHERE puede ampliarse para establecer correspondencias utilizando varias entradas Database field/Part parameter, por ejemplo:
[Capacitance] = '{Capacitance}' AND [Tolerance] = {Tolerance} AND [Manufacturer] = '{Manufacturer}'
En este caso, se establecería un vínculo con un único registro de la tabla correspondiente de la base de datos utilizando tres parámetros de diseño diferentes. Observe que la entrada del parámetro de diseño Tolerance no está entre comillas. Esto significa que el tipo de columna de la tabla asociada de la base de datos es Number y no String.
Mediante la sintaxis SQL estándar, puede crear una cláusula WHERE tan sencilla o compleja como desee. Un ejemplo de una cláusula más compleja podría ser:
[Tolerance] BETWEEN {Min Tolerance} AND {Max Tolerance} AND [Price] <= {Max Price} AND [Manufacturer] IN ('{Preferred Manufacturer 1}', '{Preferred Manufacturer 2}')
En este caso, se consultaría la tabla para buscar componentes coincidentes basándose en tres campos de la base de datos: Tolerance, Price y Manufacturer. La tolerancia debe estar dentro del intervalo definido por los parámetros de diseño Min Tolerance y Max Tolerance. El precio debe ser menor o igual que el especificado en el parámetro de diseño Max Price, y el fabricante puede ser cualquiera de los dos candidatos especificados por los parámetros de diseño Preferred Manufacturer 1 y Preferred Manufacturer 2.
Creación de un parámetro de componente
Si no existe un parámetro adecuado en sus componentes de Altium Designer para utilizarlo como Part parameter a efectos de correspondencia en el archivo DbLink, deberá crear uno. Este parámetro «base» puede añadirse rápidamente mediante el comando Tools » Parameter Manager o el panel Properties del editor correspondiente.
Adición de un parámetro mediante la función de gestión de parámetros
Para añadir un nuevo parámetro mediante la función de gestión de parámetros:
- Desde un documento de esquema (o un documento de biblioteca de esquemas), seleccione Tools » Parameter Manager en los menús principales. Aparecerá el cuadro de diálogo de opciones del editor de parámetros. Para añadir el nuevo parámetro a todos los componentes, asegúrese de que la opción Parts esté habilitada en la sección Include Parameters Owned By y de que All Objects esté establecido como criterio en la sección That Meet the Following Criteria.
Configuración de las opciones de gestión de parámetros.
- Al hacer clic en OK, se abrirá el cuadro de diálogo del editor de tablas de parámetros, que muestra todos los parámetros que pertenecen actualmente a todos los objetos de componente de los documentos de esquema de origen del proyecto activo (o a los componentes de la biblioteca de esquemas activa). Haga clic en el botón Add Column y utilice el cuadro de diálogo para añadir un parámetro que aparece para definir el nombre del parámetro. Asegúrese de que la opción Add to all objects esté habilitada para que el nuevo parámetro se añada a todos los componentes.
Ejemplo de uso de la función de gestión de parámetros para añadir un nuevo parámetro a todos los componentes de todos los esquemas de origen de un proyecto de diseño.
- Una vez añadida la nueva columna, haga clic en el botón Accept Changes (Create ECO). Utilice el cuadro de diálogo Engineering Change Order que aparece para Validate y, a continuación, Execute los cambios, añadiendo el parámetro a cada uno de los componentes requeridos.
Ejecución de los cambios de parámetros (adición del nuevo parámetro a todos los componentes) mediante una orden de cambio de ingeniería.
Adición de un parámetro mediante el panel de propiedades
Puede añadirse un nuevo parámetro a todos los componentes seleccionados mediante el panel Properties. El siguiente procedimiento describe cómo añadir el mismo parámetro a todos los componentes del documento de biblioteca de esquemas activo mediante los paneles Filtro SCHLIB y Properties.
- En primer lugar, seleccione todos los componentes de la biblioteca mediante el panel SCH Filter y una consulta IsPart. Asegúrese de que la opción Whole Library esté habilitada; de lo contrario, solo se tendrá en cuenta el componente activo de la biblioteca.
Configure un filtro para seleccionar todos los componentes del documento de biblioteca de esquemas activo.
- En el panel Properties del editor de bibliotecas, compruebe, mediante el texto situado en la parte inferior del panel, que todos los componentes de la biblioteca estén seleccionados. Si el panel Properties no está visible, haga clic en el botón
situado en la parte inferior derecha del espacio de trabajo para mostrarlo.
Compruebe que todos los componentes estén seleccionados.
- Añada el parámetro necesario mediante la pestaña Parameters del panel. Haga clic en el botón Add para añadir un nuevo parámetro predeterminado y, a continuación, edite el nombre según sea necesario. Tenga en cuenta que el parámetro ya se ha añadido a todos los componentes seleccionados; si vuelve a hacer clic en el botón Add, se añadirá un segundo parámetro nuevo.
Añada el nuevo parámetro necesario a todos los componentes seleccionados.
Asignación de campos de la base de datos a parámetros de diseño
Los parámetros de diseño de los componentes existentes, ya sean los colocados en las hojas de esquemático de origen de un proyecto de diseño o los definidos en una biblioteca de componentes de esquemático que se haya añadido a un paquete de bibliotecas, se actualizan con información almacenada externamente en una base de datos de la empresa mediante el comando Update Parameters From Database, disponible en el menú principal Tools cuando el documento de esquemático o de biblioteca de esquemáticos está activo.
Cuando se encuentra una coincidencia entre un componente del diseño y un registro de una tabla de la base de datos vinculada, lo que sucede a continuación depende de la información de asignación y actualización especificada en el archivo Database Link. Estos ajustes se configuran en la pestaña Field Mappings de la vista principal del documento.
Especifique las opciones de asignación y actualización de parámetros en la pestaña Field Mappings del documento DbLink.
Asignación de parámetros
Las dos primeras columnas de la pestaña Field Mappings, empezando por la izquierda, permiten controlar qué información de la base de datos se asignará a los parámetros de un componente.
La columna Database Field Name enumera todos los nombres de los campos (columnas) de la tabla activa de la base de datos. La columna Design Parameter permite especificar el parámetro de diseño que se debe asignar al campo correspondiente de la base de datos. La asignación inicial se realiza automáticamente al conectarse a la base de datos: todos los campos de la base de datos se asignan a parámetros de diseño con los mismos nombres. Por ejemplo, si un campo de la base de datos se llama Tolerance, se le asignará un parámetro de diseño con el nombre Tolerance.
Puede cambiar la entrada de un parámetro de diseño de las siguientes maneras:
- Haciendo clic en su celda y escribiendo directamente el nombre de otro parámetro.
- Utilizando la lista desplegable asociada a la celda para elegir un parámetro de diseño existente.
Es posible que tenga un gran número de campos de datos asociados a un componente en la base de datos y que no quiera, o ni siquiera necesite, añadirlos todos como parámetros de diseño al componente existente. Gran parte de esta información puede ser necesaria únicamente al generar una lista de materiales. El cuadro de diálogo del gestor de informes incluye una opción que permite añadir información de parámetros a una BOM directamente desde una base de datos vinculada, lo que permite reducir la cantidad de información que se «arrastra» con los documentos de esquemático de origen. Para obtener más información, consulte la sección Adición de información de la base de datos directamente a una BOM.
Para los campos de la base de datos que explícitamente no desee asignar, establezca la entrada Design Parameter en [None]. Los campos de la base de datos sin asignar se distinguen en la pestaña mediante un icono de aspa roja Los campos asignados se distinguen mediante un icono de marca de verificación verde
Defina la asignación de parámetros según sea necesario.
Opciones de actualización de parámetros
Las columnas restantes de la pestaña Field Mappings permiten especificar las acciones que se realizarán sobre los parámetros al actualizar un componente mediante el comando Tools » Update Parameters From Database. En las siguientes descripciones, el término Altium component se utiliza para representar un componente colocado en una hoja de esquemático o un componente definido en una biblioteca de componentes de esquemático que forme parte de un paquete de bibliotecas.
Las cuatro columnas son las siguientes:
- Update Values - una celda de esta columna se utiliza para determinar la acción que debe realizarse si el parámetro existe tanto en el componente de Altium como en la base de datos, pero sus valores son distintos. Puede optar por actualizar el parámetro del componente de Altium con el valor almacenado en la base de datos (Update) o por no actualizarlo (Do not update).
- Add To Design - una celda de esta columna se utiliza para determinar la acción que debe realizarse si el parámetro se encuentra en la base de datos, pero no existe en el componente de Altium Designer. Puede optar por añadir el parámetro (Add), no añadirlo (Do not add) o añadirlo solo si tiene un valor asignado en la base de datos (Add only if not blank in database).
- Visible On Add - una casilla de verificación de esta columna se utiliza para determinar si un parámetro recién añadido se hace visible en el componente de Altium (activada) o no (desactivada).
- Remove From Design - una celda de esta columna se utiliza para determinar la acción que debe realizarse si el parámetro existe en el componente de Altium Designer, pero no está en la base de datos o está, pero no tiene ningún valor. Puede optar por no eliminar el parámetro en ningún caso (Do not remove) o por eliminarlo solo si no tiene ningún valor asignado en la base de datos (Remove only if blank in database).
Inicialmente, los campos Update Values, Add To Design y Remove From Design de cada campo de la base de datos asignado se establecerán en la entrada Default, y la opción Visible On Add estará desactivada, como se muestra en la siguiente imagen.
Opciones iniciales (predeterminadas) de actualización de parámetros.
En relación con la imagen, cabe destacar tres puntos importantes sobre las opciones de actualización:
- Los campos de la base de datos sin asignar no tendrán opciones de actualización asociadas.
- El campo clave (por ejemplo, Part Number en la imagen) no tendrá opciones de actualización asociadas. Este campo se utiliza únicamente para buscar coincidencias de parámetros.
- El ajuste Default hace que una opción de actualización siga su definición predeterminada correspondiente, tal como se especifica en la pestaña Default Actions del cuadro de diálogo Database Link Options (Tools » Options). También se puede acceder a este cuadro de diálogo haciendo clic en el botón Options de la región Field Settings de la vista del documento.
Defina las opciones predeterminadas de actualización de parámetros en una ubicación centralizada.
El tercer punto resulta útil porque permite especificar las opciones de actualización desde una ubicación centralizada y, a continuación, hacer referencia a ella al definir las opciones de actualización de cada campo asignado. Por eso, la entrada Default se carga automáticamente en los campos de actualización correspondientes al asignar un campo de la base de datos a un parámetro de diseño.
Si desea anular el ajuste predeterminado de una opción de actualización, haga clic en el campo de actualización correspondiente de la pestaña Field Mappings y, a continuación, vuelva a hacer clic para acceder a una lista desplegable con las opciones de actualización aplicables.
Las opciones de actualización de parámetros se pueden modificar manualmente si es necesario.
De este modo, tiene pleno control sobre cómo se actualizan los parámetros del diseño. Puede establecer todos los campos en Default y tomar las decisiones de actualización necesarias desde el cuadro de diálogo Database Link Options, configurar cada campo de actualización individualmente o combinar ambas opciones: la decisión es enteramente suya, según lo considere oportuno. La actualización, cuando se realiza, se lleva a cabo mediante un cuadro de diálogo Engineering Change Order. Si en esta fase hay actualizaciones que prefiere no realizar, puede optar por excluir esos cambios concretos, lo que le da la última palabra sobre qué parámetros del diseño se actualizan.
Garantizar la sincronización
Una vez especificadas las opciones de asignación y actualización en el archivo Database Link según sea necesario y guardado el archivo, podrá transferir información de la base de datos a los parámetros asignados de los componentes de Altium Designer. Recuerde que el parámetro elegido como campo clave se utiliza para garantizar que un componente de Altium Designer conserve su vínculo con el registro correspondiente a ese componente en la base de datos externa. Esto significa que, en cualquier momento posterior, los cambios en la información de los parámetros de la base de datos se pueden transferir fácilmente al componente de Altium Designer, manteniendo ambos sincronizados. Las actualizaciones se realizan mediante el comando Update Parameters From Database, disponible en el menú principal Tools del editor de esquemáticos o del editor de bibliotecas de esquemáticos.
Sincronización dual: DbLib/SVNDbLib y DBLink
Es posible que tenga un proyecto de diseño existente en el que la mayoría de los componentes colocados se hayan vinculado a una base de datos externa mediante un archivo DbLink. Los cambios de diseño pueden dar lugar a circuitos adicionales, cuyos componentes podrían colocarse mediante la función Biblioteca de base de datos. El archivo DbLib/SVNDbLib asociado podría perfectamente apuntar a una base de datos externa diferente.
Al utilizar el comando Update Parameters From Database, se consultarán todos los parámetros vinculados de los componentes colocados, en todas las bases de datos vinculadas, independientemente del método de vinculación utilizado, y las diferencias detectadas para esos parámetros se mostrarán en el cuadro de diálogo Seleccionar cambios de parámetros.
Añadir información de la base de datos directamente a una BOM
Related page: Configuración de la BOM en el Administrador de informes
Tradicionalmente, la información de origen de una lista de materiales (BOM) se obtenía de la información de los parámetros de los componentes colocados en el diseño. Sin embargo, esto puede hacer que se añada al esquemático una gran cantidad de información que solo se utiliza para la BOM. Si los componentes de Altium Designer colocados están vinculados a una base de datos externa mediante un archivo DbLink, el generador de BOM puede extraer cualquier otra información del registro que no se haya añadido a los componentes como parámetros de diseño.
Al configurar el informe de la lista de materiales mediante el cuadro de diálogo Administrador de informes, haga clic en el botón Database Parameters (
) de la pestaña Columnas del cuadro de diálogo para incluirlos como origen de datos de la BOM, tal como se muestra a continuación. Esta opción solo estará disponible si uno o más componentes del diseño están vinculados a una base de datos externa.
En la lista Columnas, el icono
se utiliza para distinguir un parámetro que existe para uno o más componentes colocados en una base de datos externa vinculada. Haga clic en el icono de visibilidad para que se convierta en un ojo (
) e incluir así esa columna (parámetro) en la BOM.
Incluya información adicional de los componentes que solo exista en una base de datos externa.