Trabajar con directivas en un esquemático
Altium Essentials: Schematic Updating
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
De un vistazo
- Aprende qué son las directivas de diseño y cómo se utilizan en la captura y la validación de esquemáticos.
- Comprende cuándo usar No ERC y cuándo una máscara de compilación para suprimir mensajes de validación no deseados.
- Descubre cómo se colocan, activan, desactivan y editan las máscaras de compilación en el editor de esquemáticos.
Las directivas de diseño son objetos que se colocan en el esquema durante la captura del diseño y permiten especificar instrucciones que se transmitirán a otras partes del software. Hay diversas directivas de diseño disponibles para los dos usos siguientes:
- Directivas asociadas con la compilación automática de los documentos esquemáticos de origen.
- Directivas utilizadas para transmitir a la PCB la información definida en una hoja de esquema.
Las siguientes secciones analizan con más detalle estas áreas y las directivas asociadas.
Directivas relacionadas con la compilación
Los diseños evolucionan con el tiempo y se capturan por etapas. A medida que cada etapa se consolida, es habitual querer comprobarla de forma aislada del resto del diseño. La compilación de un documento esquemático individual (o del proyecto completo) en distintos momentos del proceso de captura suele generar mensajes de error causados por circuitos que aún no se han capturado o por conexiones entre fragmentos de circuitos que todavía están incompletos. Estos mensajes no aportan ningún valor real, ya que solo añaden ruido a la información relevante. La forma más rápida y sencilla de suprimir estos errores de compilación es colocar directivas No ERC o Máscara de compilación.
Directiva No ERC
La directiva No ERC se coloca en un nodo del circuito para suprimir todas las advertencias y/o infracciones de error notificadas por la comprobación de reglas eléctricas que se detectan al validar el proyecto esquemático. Consulte la página Validación de su proyecto de diseño para obtener más información.
Directiva Máscara de compilación
Las directivas No ERC resultan muy útiles para suprimir un número reducido de pines, puertos, entradas de hoja o redes con infracciones dentro de un diseño. Sin embargo, en algunos casos puede ser conveniente excluir una sección completa del diseño, incluidos sus componentes. Utilice una directiva Máscara de compilación (comando Place » Directives » Compile Mask) o haga clic en el botón Máscara de compilación del menú desplegable de directivas de Active Bar para ocultar al compilador el área del diseño que contiene. Esto le permite impedir manualmente la comprobación de errores en circuitos que quizá aún no estén completos y que sabe que generarán errores de compilación. Puede resultar muy útil si necesita compilar el documento activo o el proyecto para comprobar la integridad del diseño en otras áreas específicas, pero no desea el «ruido» de los mensajes generados por el compilador asociados a las partes sin terminar del diseño.
Como su nombre indica, esta directiva indica al compilador que ignore cualquier objeto que quede completely dentro de los límites de la máscara definida. Coloque la máscara del mismo modo que colocaría una nota o un objeto rectangular.
Observe el circuito esquemático de ejemplo de la siguiente imagen, donde las conexiones al dispositivo LCD1 aún no están completas. Compilar únicamente este esquema (Project » Validate PCB Project) generará numerosos mensajes de infracción (mostrados a continuación), todos ellos causados por los circuitos incompletos. Pase el cursor sobre la imagen para ver el efecto de colocar una directiva Máscara de compilación alrededor de los circuitos incompletos. El compilador ignorará estas infracciones, mientras comprueba el resto del circuito del esquema, cuyas conexiones están completas. Observe que los objetos realmente enmascarados —aquellos que quedan completamente dentro del rectángulo delimitador de la máscara— aparecerán atenuados en gris.

Pase el cursor sobre la imagen para mostrar el efecto de utilizar una directiva Máscara de compilación para ocultar las infracciones del compilador debidas a circuitos incompletos.
Máscara de compilación
Una máscara de compilación colocada, mostrada en el lado izquierdo del esquema anterior.
Resumen
Una máscara de compilación es una directiva de diseño que se utiliza para ocultar al compilador el área del diseño que contiene al realizar la validación mediante el comando Project » Validate Project . Permite impedir manualmente la comprobación de errores en circuitos que quizá aún no estén completos y que generarán errores de validación. La máscara de compilación resulta útil cuando es necesario validar el proyecto actual para comprobar la integridad del diseño en otras áreas específicas, pero no se desea la acumulación de mensajes generados por el compilador asociados a las partes sin terminar del diseño.
Disponibilidad
Las máscaras de compilación solo pueden colocarse en el editor de esquemas. Para colocar una máscara de compilación:
- Haga clic en el comando Place » Directives » Compile Mask de los menús principales.
- Haga clic en el botón Máscara de compilación del menú desplegable de directivas de Active Bar , situado en la parte superior del espacio de diseño. Mantenga pulsado un botón Active Bar para acceder a otros comandos relacionados. Una vez utilizado un comando, este pasará a ser el primer elemento de esa sección de Active Bar.
- Haga clic con el botón derecho en el editor de esquemas y, a continuación, haga clic en Place » Directives » Compile Mask.
Colocación
Tras ejecutar el comando, el cursor cambiará a una cruz para indicar el modo de colocación de máscaras de compilación. Para colocar una máscara, realice la siguiente secuencia de acciones:
- Sitúe el cursor y haga clic o pulse Enter para fijar la primera esquina de la máscara.
- Mueva el cursor para ajustar el tamaño de la máscara de modo que abarque por completo el área del diseño que debe ocultarse al compilador. A continuación, haga clic o pulse Enter para fijar la esquina diagonalmente opuesta y completar la colocación de la máscara. Los objetos del diseño que queden completamente dentro de los límites de la máscara se atenuarán en gris.
- Continúe colocando otras máscaras de compilación o haga clic con el botón derecho o pulse Esc para salir del modo de colocación.
Edición gráfica
Este método de edición permite seleccionar un objeto de máscara de compilación colocado directamente en el espacio de diseño y modificar gráficamente su tamaño, forma o ubicación.
Una máscara de compilación puede mostrarse en modo activo (marco completo) o contraído (triángulo enmarcado), que corresponden a la máscara habilitada y deshabilitada, respectivamente. Alterne el modo de visualización haciendo clic en el icono ▲ o ▼ de la esquina superior izquierda de una máscara de compilación colocada.
Haga clic en el triángulo de la esquina superior izquierda para contraer (y deshabilitar) una máscara de compilación.
Cuando se selecciona un objeto de máscara de compilación activo (expandido), están disponibles los siguientes controles de edición:
Una máscara de compilación seleccionada (cuando está activa).
- Haga clic y arrastre A para cambiar el tamaño de la máscara de compilación en las direcciones vertical y horizontal simultáneamente.
- Haga clic y arrastre B para cambiar el tamaño de la máscara de compilación en las direcciones vertical y horizontal por separado.
- Haga clic en cualquier punto de la máscara de compilación, alejado de los controladores de edición – y arrastre para cambiar su posición. Mientras la arrastra, puede girar la máscara de compilación (Spacebar/Shift+Spacebar) o reflejarla (teclas X o Y para reflejarla respecto al eje X o al eje Y, respectivamente).
Edición no gráfica
Están disponibles los siguientes métodos de edición no gráfica.
Edición mediante el cuadro de diálogo Máscara de compilación o el panel Propiedades
Panel page: Propiedades de la máscara de compilación
Este método de edición utiliza el cuadro de diálogo Compile Mask asociado y el modo del panel Properties para modificar las propiedades de un objeto de máscara de compilación.
Tras la colocación, se puede acceder al cuadro de diálogo Compile Mask de las siguientes maneras:
- Haciendo doble clic en el objeto de máscara de compilación colocado.
- Seleccionando el objeto de máscara de compilación, haciendo clic con el botón derecho y eligiendo Properties en el menú contextual.
Durante la colocación, se puede acceder al modo Máscara de compilación del panel Properties pulsando la tecla Tab. Una vez colocada la máscara de compilación, aparecen todas las opciones.
Tras la colocación, se puede acceder al modo Máscara de compilación del panel Properties de una de las siguientes maneras:
- Si el panel Properties ya está activo, seleccionando el objeto de máscara de compilación.
- Tras seleccionar el objeto de máscara de compilación, seleccione el panel Properties desde el botón Panels situado en la sección inferior derecha del espacio de diseño o seleccionando View » Panels » Properties en el menú principal.
Edición de varios objetos
El panel Properties permite editar varios objetos a la vez y modificar los ajustes de propiedades que sean idénticos en todos los objetos seleccionados. Cuando se seleccionan varios objetos del mismo tipo de forma manual, mediante el cuadro de diálogo Buscar objetos similares o mediante un panel Filtro o Lista, cualquier entrada de campo del panel Properties que no se muestre como un asterisco (*) se puede editar para todos los objetos seleccionados.
Edición mediante un panel Lista
Panel pages: Paneles Lista, Filtro SCH
Un panel List muestra los tipos de objetos de diseño de uno o más documentos en formato de tabla, lo que permite inspeccionar y modificar rápidamente los atributos de los objetos. Si se utiliza junto con el filtrado adecuado, ya sea seleccionando tipos de objetos (mediante las opciones Include del panel) o utilizando el panel Filter correspondiente o el cuadro de diálogo Buscar objetos similares, permite mostrar únicamente los objetos incluidos en el ámbito del filtro activo. Las propiedades de los objetos enumerados se pueden editar directamente en el panel List.
Propiedades de la máscara de compilación
Las propiedades de los objetos del editor de esquemáticos son opciones configurables que especifican el estilo visual, el contenido y el comportamiento del objeto colocado. Los ajustes de propiedades de cada tipo de objeto se definen de la siguiente manera:
- Post-placement settings – todas las propiedades de los objetos de máscara de compilación se pueden editar en el cuadro de diálogo Compile Mask y en el panel Properties cuando se selecciona una máscara de compilación colocada en el espacio de diseño.
Ubicación
-
(X/Y)
- X (primer campo): la coordenada X (horizontal) actual del punto de referencia del objeto, relativa al origen actual del espacio de diseño. Edítela para cambiar la posición X del objeto. El valor se puede introducir en unidades métricas o imperiales; incluya las unidades al introducir un valor cuyas unidades no sean las predeterminadas actualmente.
- Y (segundo campo): la coordenada Y (vertical) actual del punto de referencia del objeto, relativa al origen actual. Edítela para cambiar la posición Y del objeto. El valor se puede introducir en unidades métricas o imperiales; incluya las unidades al introducir un valor cuyas unidades no sean las predeterminadas actualmente.
Propiedades
- Width - introduzca el ancho del objeto.
- Height - introduzca la altura del objeto.
- Border - utilice la lista desplegable para seleccionar el borde deseado.
- Fill Color - haga clic en el recuadro de color para seleccionar el color deseado para el objeto.
- Collapsed and Disabled - marque la casilla para contraer y desactivar el objeto.
Directivas relacionadas con la PCB
Como entorno de diseño unificado, Altium Designer permite definir los requisitos de la PCB antes de realizar el diseño físico de la placa. Esto se consigue añadiendo y especificando parámetros para los objetos colocados en las hojas de esquemático.
Para determinados objetos de diseño del esquemático, como componentes, símbolos de hoja, puertos, etc., esto implica añadir los parámetros pertinentes como parte de las propiedades del objeto. Para los objetos de red, como hilos y buses, los parámetros no se pueden añadir directamente como una propiedad del hilo o del bus. En su lugar, los parámetros necesarios para almacenar la información se especifican mediante directivas de diseño específicas.
La siguiente información se puede especificar mediante directivas y se transferirá a las definiciones correspondientes de la PCB durante la sincronización del diseño:
- Restricciones del diseño físico de la PCB
- Pares diferenciales
- Clases de redes
Al incluir directivas de diseño en el esquema, los ingenieros pueden especificar restricciones de diseño explícitas y garantizar que el esquema siga siendo el registro principal del diseño. Cualquier modificación del diseño se realizaría únicamente en el esquema y se transferiría a la PCB. Esto puede resultar especialmente importante cuando varias personas trabajan en el diseño, sobre todo si se encuentran en distintas ubicaciones geográficas. En lugar de intentar comunicarse mediante cadenas de correos electrónicos o llamadas telefónicas, la persona que plasma el diseño en el esquema puede asegurarse de que se utilicen determinadas restricciones durante la fase de diseño físico.
El elemento central de esta funcionalidad es la directiva de conjunto de parámetros.
Se trata, en esencia, de objetos de conjunto de parámetros definidos por el usuario que pueden asociarse a un objeto de red dentro de un diseño esquemático. Coloque una directiva de diseño físico de PCB en un hilo, bus o arnés de señales para definir una o varias restricciones de diseño aplicables a las redes asociadas. Cuando se crea una PCB a partir del esquema, la información de la directiva de diseño físico de PCB se utiliza para crear las reglas de diseño de PCB pertinentes. La información especificada por una directiva de diseño físico de PCB se aplica únicamente a la red (o conjunto de redes) a la que está conectada la directiva.

Una directiva de conjunto de parámetros.
Actúa como contenedor de cualquier número de parámetros aplicables a la red a la que está conectada la directiva de conjunto de parámetros. Se puede colocar una directiva de conjunto de parámetros predeterminada sin parámetros (Place » Directives » Parameter Set) y añadir los parámetros pertinentes más adelante. Las siguientes secciones examinan con más detalle el uso de estas directivas basadas en parámetros. Hay disponibles directivas de conjunto de parámetros tanto definidas por el usuario (conjunto de parámetros) como predefinidas (par diferencial). La única diferencia entre un conjunto de parámetros vacío y uno predefinido es que los conjuntos predefinidos incluyen un parámetro, tal como se describe a continuación.
Conjunto de parámetros
Resumen
Un conjunto de parámetros es una directiva de diseño que permite asociar especificaciones de diseño a un objeto de tipo red dentro de un diseño esquemático. Por ejemplo, puede utilizar un conjunto de parámetros para declarar que dos redes forman parte de un par diferencial. El software utiliza la presencia de parámetros con nombres específicos en el conjunto de parámetros para determinar qué directiva de diseño está colocando.
Disponibilidad
Los conjuntos de parámetros solo se pueden colocar en el editor de esquemas. Hay disponibles directivas de conjunto de parámetros tanto predeterminadas (vacías) como predefinidas (par diferencial). La única diferencia entre un conjunto de parámetros vacío y uno predefinido es que los conjuntos predefinidos incluyen un parámetro, tal como se describe a continuación.
Acceda a los comandos correspondientes desde el menú principal Place del siguiente modo:
| • | Place » Directives » Parameter Set | |
| • | Place » Directives » Differential Pair | |
Colocación
Se puede utilizar un conjunto de parámetros para asociar parámetros a un:
- Hilo
- Bus
- Arnés de señales
- Símbolo de hoja
Tras ejecutar el comando, el cursor cambiará a una cruz y se activará el modo de colocación de directivas de diseño. La colocación se realiza mediante las siguientes acciones:
- Sitúe el cursor sobre un hilo u otro objeto de red y haga clic o pulse Enter para colocar la directiva.
- Continúe colocando más directivas o haga clic con el botón derecho o pulse Esc para salir del modo de colocación.
Durante la colocación, mientras el conjunto de parámetros sigue unido al cursor, también puede realizar las siguientes acciones:
-
Pulse la tecla Tab para pausar la colocación y acceder al modo Conjunto de parámetros del panel Properties, desde donde puede modificar sus propiedades sobre la marcha. Haga clic en el botón de pausa superpuesto en el espacio de diseño para reanudar la colocación.
-
Pulse la tecla Alt para restringir la dirección del movimiento al eje horizontal o vertical, según la dirección inicial del movimiento.
-
Pulse Spacebar para girar el arco en sentido antihorario o Shift+Spacebar para girarlo en sentido horario. Esta acción también se puede realizar mientras se arrastra el objeto. El giro se realiza en incrementos de 90°.
-
Pulse las teclas X o Y en el modo de colocación para voltear el conjunto de parámetros respecto al eje X o al eje Y.
Edición gráfica
Este método de edición permite seleccionar una directiva de conjunto de parámetros ya colocada directamente en el espacio de diseño y cambiar gráficamente su ubicación u orientación.
Cuando se selecciona una directiva de conjunto de parámetros en el espacio de diseño, aparece un recuadro discontinuo a su alrededor. El recuadro abarca únicamente el área ocupada por la directiva. Para cada parámetro del conjunto cuya visibilidad esté habilitada, se mostrará una línea discontinua que conecta el campo de texto del parámetro con el cuerpo de la directiva, lo que confirma su asociación:
Haga clic en cualquier punto dentro del recuadro discontinuo y arrastre para reubicar el conjunto de parámetros según sea necesario. Mientras lo arrastra, puede girarlo (Spacebar/Shift+Spacebar) o reflejarlo (teclas X o Y para reflejarlo respecto al eje X o al eje Y).
El tamaño de los campos de texto del conjunto de parámetros (que pueden editarse gráficamente de forma independiente de la directiva principal) solo puede ajustarse cambiando la opción Style en la página Esquema – Valores predeterminados del cuadro de diálogo Preferences. Por lo tanto, no hay controles de edición disponibles al seleccionar cualquiera de estos objetos.
Haga clic en cualquier punto dentro del recuadro discontinuo y arrastre para reubicar el objeto de texto según sea necesario. Mientras lo arrastra, puede girarlo (Spacebar/Shift+Spacebar) o reflejarlo (teclas X o Y para reflejarlo respecto al eje X o al eje Y).
Si la opción Enable In-Place Editing está habilitada en la página Esquema – General del cuadro de diálogo Preferences, podrá editar el valor de un parámetro directamente en el espacio de diseño (a excepción de los parámetros que se hayan añadido como reglas). Seleccione el objeto de texto y, a continuación, haga clic una vez para activar esta función. Escriba el nuevo valor según sea necesario y, después, haga clic fuera del objeto de texto o pulse Enter para aplicar el cambio.
Edición no gráfica
Están disponibles los siguientes métodos de edición no gráfica.
Edición mediante el cuadro de diálogo Conjunto de parámetros o el panel Propiedades
Panel page: Propiedades del conjunto de parámetros
Este método de edición utiliza el cuadro de diálogo Parameter Set asociado y el modo Properties del panel para modificar las propiedades de un objeto de conjunto de parámetros.

El cuadro de diálogo Parameter Set en la primera imagen y el modo Parameter Set del panel Propiedades en la segunda imagen
Tras la colocación, se puede acceder al cuadro de diálogo Parameter Set de las siguientes formas:
- Haciendo doble clic en el objeto de conjunto de parámetros colocado.
- Situando el cursor sobre el objeto de conjunto de parámetros, haciendo clic con el botón derecho y seleccionando Properties en el menú contextual.
Durante la colocación, se puede acceder al modo Parameter Set del panel Properties pulsando la tecla Tab. Una vez colocado el conjunto de parámetros, aparecen todas las opciones.
Tras la colocación, se puede acceder al modo Parameter Set del panel Properties de una de las siguientes formas:
- Si el panel Properties ya está activo, seleccionando el objeto de conjunto de parámetros.
- Tras seleccionar el objeto de conjunto de parámetros, seleccionando el panel Properties desde el botón Panels situado en la parte inferior derecha del espacio de diseño o seleccionando View » Panels » Properties en el menú principal.
Edición de varios objetos
El panel Properties permite editar varios objetos y modificar los ajustes de las propiedades que sean idénticos en todos los objetos seleccionados. Cuando se seleccionan varios objetos del mismo tipo manualmente, mediante el cuadro de diálogo Buscar objetos similares o a través de un panel de filtro o de lista, cualquier valor de campo del panel Properties que no se muestre como un asterisco (*) puede editarse para todos los objetos seleccionados.
Edición mediante un panel de lista
Panel pages: Paneles de lista, Filtro de esquemáticos
Un panel List permite mostrar objetos de diseño de uno o varios documentos en formato de tabla, lo que facilita la inspección y modificación de sus atributos. Utilizado junto con el filtrado adecuado —mediante el panel Filter correspondiente o el cuadro de diálogo Buscar objetos similares—, permite mostrar únicamente los objetos incluidos en el ámbito del filtro activo, para seleccionar y editar varios objetos de diseño con mayor precisión y eficiencia.
Notas
- Al colocar una directiva de conjunto de parámetros predeterminada, no habrá parámetros existentes. Una vez colocada, añada los parámetros pertinentes mediante la sección Parameters del panel Properties .
- Una directiva de conjunto de parámetros permite asignar información de diseño físico de PCB a una red del esquemático. Cuando se crea una PCB a partir del esquemático, la información del conjunto de parámetros se utiliza para crear las reglas de diseño de PCB pertinentes. La información especificada por una directiva de conjunto de parámetros se aplica únicamente a las redes a las que está conectada.
- Cuando se añade una directiva de conjunto de parámetros a una red, los campos Power Net y High Speed están disponibles en el panel Properties de la red. Al actualizar el documento de PCB a partir de los esquemáticos, se propone añadir la regla de diseño Redes de alimentación a cada red que tenga habilitado el parámetro Power Net.
- Las directivas de clase de red permiten crear clases de redes definidas por el usuario en el esquemático. Cuando se crea una PCB a partir del esquemático, la información de una directiva de clase de red se utiliza para crear la clase de red correspondiente en la PCB. Para que una red forme parte de una clase de redes, adjunte una directiva de conjunto de parámetros al hilo o bus correspondiente y añada una clase cuyo nombre coincida con el de la clase deseada. La opción Generate Net Classes (para las clases definidas por el usuario) debe estar habilitada en la pestaña Class Generation del cuadro de diálogo Opciones del proyecto para utilizar esta función.
- Si se ha definido una directiva de clase de red para una red, todas las reglas de diseño de PCB que también se creen mediante ese objeto de conjunto de parámetros tendrán un ámbito de regla de clase de red cuando el diseño se transfiera al editor de PCB.
- Se puede crear una directiva de clase de red a partir de una directiva de conjunto de parámetros ya colocada añadiendo una clase cuyo valor debe establecerse en la clase de red de PCB requerida.
-
Un Blanket, junto con una directiva de conjunto de parámetros, también se puede utilizar para aplicar clases de componentes y parámetros a los componentes que se encuentren completamente dentro del área definida por el Blanket. Para ello, utilice las opciones Component Class y Parameter del menú desplegable del botón Add en las propiedades de la directiva de conjunto de parámetros vinculada al Blanket. La información sobre la clase de componentes y el parámetro se transferirá al documento de PCB del proyecto durante el proceso ECO al actualizar la PCB.
Propiedades del conjunto de parámetros
Las propiedades de los objetos del editor de esquemas son opciones configurables que especifican el estilo visual, el contenido y el comportamiento del objeto colocado.
Los ajustes de las propiedades de cada tipo de objeto se definen de dos formas distintas:
-
Pre-placement settings – la mayoría de las propiedades del objeto Conjunto de parámetros, o aquellas que se pueden predefinir de forma lógica, están disponibles como ajustes predeterminados editables en la página Esquema – Valores predeterminados del cuadro de diálogo Preferences (al que se accede desde el botón
situado en la parte superior derecha del espacio de diseño). Seleccione el objeto en Primitive List para mostrar sus opciones a la derecha.
-
Post-placement settings – todas las propiedades del objeto Conjunto de parámetros se pueden editar en los cuadros de diálogo Parameter Set y en el panel Properties cuando se selecciona un conjunto de parámetros en el espacio de diseño.
Ubicación
-
(X/Y)
- X (primer campo) – la coordenada X (horizontal) actual del punto de referencia del objeto, relativa al origen actual del espacio de diseño. Edítela para cambiar la posición X del objeto. El valor se puede introducir en unidades métricas o imperiales; incluya las unidades al introducir un valor cuyas unidades no sean las predeterminadas actualmente.
- Y (segundo campo) – la coordenada Y (vertical) actual del punto de referencia del objeto, relativa al origen actual. Edítela para cambiar la posición Y del objeto. El valor se puede introducir en unidades métricas o imperiales; incluya las unidades al introducir un valor cuyas unidades no sean las predeterminadas actualmente.
- Rotation – utilice el menú desplegable para seleccionar la rotación.
Propiedades
- Label – la etiqueta del conjunto de parámetros. Edítela si lo desea.
- Style – utilice el menú desplegable para seleccionar el estilo. Haga clic en el recuadro de color para acceder a un menú desplegable en el que puede seleccionar el color predeterminado.
Parámetros
- Grid – muestra el Name y el Value de los parámetros asociados al parámetro seleccionado actualmente. Una vez añadidos, los campos Name y Value se pueden editar. Se puede asignar un nombre al Value haciendo clic en el campo e introduciendo el texto deseado. El campo Name solo se puede cambiar en el modo Properties del panel del objeto Conjunto de parámetros mediante Ctrl+Click. Este método abre el modo Parameter del panel Properties, donde puede introducir el nombre deseado en el campo Name. Utilice el icono de candado para bloquear o desbloquear un parámetro de la lista. Utilice el icono del ojo para mostrar u ocultar el parámetro. En esta sección se pueden mostrar todos los parámetros, algunos de ellos o ninguno mediante el botón All y los botones de cada parámetro. Los parámetros están desactivados cuando sus respectivos botones están en gris y activados cuando están en azul.
-
Add – utilice el menú desplegable para añadir un tipo de clase:
-
Net Class – seleccione esta opción para añadir una nueva clase de red.
- Component Class – seleccione esta opción para añadir una nueva clase de componentes. Esta opción solo está disponible en la variante Conjunto de parámetros del cuadro de diálogo Parameter Set o del panel Properties.
-
Diff. Pair Net Class – seleccione esta opción para añadir una nueva clase de redes de pares diferenciales. Esta opción solo está disponible en la variante Par diferencial del cuadro de diálogo Parameter Set o del panel Properties.
-
Parameter – seleccione esta opción para añadir un nuevo parámetro.
-
Rule – haga clic para abrir el cuadro de diálogo Select Design Rule Type, en el que puede seleccionar el tipo de una nueva regla Tras elegir un tipo de regla y hacer clic en
, se abre el cuadro de diálogo Edit PCB Rule (From Schematic) para que pueda editar la nueva regla si lo desea.
-
Haga clic en el icono del lápiz para abrir el cuadro de diálogo Edit PCB Rule (From Schematic) y editar el elemento seleccionado. Haga clic en
para eliminar el elemento seleccionado.
- Font Settings – haga clic en la fuente mostrada para cambiar el estilo de fuente. Esta opción solo está disponible una vez que se ha añadido una clase de red, una clase de redes de pares diferenciales, un parámetro o una regla.
-
Other – si se ha añadido una clase de red, una clase de redes de pares diferenciales, un parámetro o una regla, haga clic para abrir un menú desplegable y cambiar opciones adicionales:
- Show Parameter Name – active esta opción para mostrar el nombre del parámetro.
- Allow Synchronization with Database – active esta opción para sincronizar con la base de datos.
- X/Y – introduzca las coordenadas X e Y.
- Rotation – utilice la lista desplegable para seleccionar la rotación.
- Autoposition – marque esta casilla para activar el posicionamiento automático.
Colocación de directivas de conjunto de parámetros
Coloque una directiva de este tipo seleccionando el comando Place » Directives » Parameter Set en el menú principal o en el menú que aparece al hacer clic con el botón derecho en el espacio de diseño. Al colocar una directiva de conjunto de parámetros predeterminada, no habrá parámetros existentes. Un conjunto de parámetros es una directiva de diseño que permite asociar especificaciones de diseño a un objeto de tipo red dentro de un diseño esquemático. Por ejemplo, utilice un conjunto de parámetros para declarar que dos redes forman parte de un par diferencial. El software utiliza la presencia de parámetros con nombres específicos en el conjunto de parámetros para determinar qué directiva de diseño está colocando.
Además de las directivas de parámetros definidas por el usuario, se puede definir una directiva de parámetros basada en reglas desde el cuadro de diálogo Choose Design Rule Type, al que se accede desde el modo Properties del panel asociado al parámetro. Para acceder, siga estos pasos:
-
Pulse
Tabantes de colocar el conjunto de parámetros o haga doble clic en una directiva de conjunto de parámetros ya colocada para mostrar sus propiedades en el panel Properties. -
A continuación, haga clic en el botón
de la sección Parameters del panel Properties y elija Rule en la lista desplegable para seleccionar una regla en el cuadro de diálogo Select Design Rule Type.

Edición del valor de una regla.
Utilice el cuadro de diálogo Select Design Rule Type para seleccionar el tipo de regla que desea añadir a la directiva como parámetro de regla. Al hacer doble clic en un tipo de regla, accederá al cuadro de diálogo Edit PCB Rule (From Schematic) correspondiente, donde podrá definir las restricciones de la regla.

Especificación de las restricciones de una regla seleccionada.
La entrada de la sección Parameters será el tipo de regla elegido, junto con las restricciones especificadas. La siguiente imagen muestra los parámetros definidos de la regla de restricción de anchura para una directiva Parameter Set. Para mostrar la regla en el espacio de diseño, haga clic en el icono de visibilidad de la sección Rules.

Varias restricciones de regla definidas para una red concreta mediante una directiva de conjunto de parámetros.
Cuando el diseño se transfiera a la PCB mediante el proceso de sincronización, se crearán las reglas de diseño pertinentes a partir de la información contenida en una directiva. La palabra Schematic se utiliza en el nombre de cada regla generada para distinguir su origen.

Reglas de diseño generadas en la PCB.
Colocación de directivas de clase de redes
Una directiva de clase de redes permite crear clases de redes definidas por el usuario en el esquemático. Para colocar una directiva de clase de redes, seleccione el comando Place » Directives » Parameter Set en los menús principales y, a continuación, defina el conjunto de parámetros como una directiva de clase de redes, tal como se indica en el consejo n.º 2 de la página del comando. Cuando se crea una PCB a partir del esquemático, la información de una directiva de clase de redes se utiliza para crear la clase de redes correspondiente en la PCB. Para que una red forme parte de una clase de redes, asocie una directiva de clase de redes al cable, bus o arnés de señales correspondiente y, a continuación, establezca el parámetro ClassName de la directiva en el nombre de la clase deseada. La opción Generate Net Classes (para clases definidas por el usuario) debe estar activada en la pestaña Generación de clases del cuadro de diálogo Opciones del proyecto para utilizar esta función.
Si se ha definido una directiva de clase de redes para una red, las reglas de diseño de PCB que también se creen mediante ese objeto de conjunto de parámetros tendrán como ámbito la clase de redes cuando el diseño se transfiera al editor de PCB. Puede crear una directiva de clase de redes a partir de una directiva de conjunto de parámetros ya colocada añadiendo una clase cuyo valor debe establecerse en la clase de redes de PCB requerida.
Requisitos importantes de las opciones del proyecto
Para garantizar que los conjuntos de parámetros definidos en el esquemático se propaguen a la PCB, deben configurarse las siguientes opciones en el cuadro de diálogo Options for PCB Project:
- Active la opción Generate Net Classes, situada en la sección User-Defined Classes de la pestaña Generación de clases del cuadro de diálogo.
-
En la pestaña Comparador del cuadro de diálogo, establezca el modo de comprobación Differences Associated with Nets » Extra Net Classes en
Find Differences.

Para propagar las directivas de conjunto de parámetros a la PCB, es necesario configurar dos opciones del proyecto. Primero, active la opción Generate Net Classes en la pestaña Class Generation. Pase el cursor sobre la imagen para mostrar la pestaña Comparator, donde deberá establecer la opción Extra Net Classes en Find Differences.
Cuando el diseño se transfiera a la PCB mediante el proceso de sincronización, se crearán las clases de redes pertinentes a partir de la información contenida en una directiva.
Colocación de directivas de cobertura
Las directivas de conjunto de parámetros solo pueden aplicarse a la red a la que están conectadas, pero, al combinarlas con una directiva de cobertura, su alcance puede ampliarse para abarcar todas las redes dentro de la cobertura.
Coloque una directiva de este tipo seleccionando el comando Place » Directives » Blanket en los menús principales. Al colocar una cobertura, puede definir una forma rectangular simple o una forma poligonal. Esta última permite controlar con mayor precisión qué objetos de red de una hoja quedan incluidos.
La cobertura identifica las redes de interés: coloque una directiva Parameter Set en cualquier punto del borde de la cobertura para aplicar requisitos de diseño a esas redes. Para aplicar la directiva del perímetro a una red situada bajo una directiva de cobertura, un objeto asociado a esa red —un pin, un puerto, una etiqueta de red, un puerto de alimentación o un segmento de hilo/bus/arnés (incluidos ambos extremos)— debe quedar dentro de los límites de la cobertura. Tenga en cuenta que, en el caso de los identificadores de red, como las etiquetas de red, el punto de anclaje debe estar dentro de la cobertura. Si las redes que deben formar parte del conjunto de parámetros de la PCB no se transfieren como se espera, pruebe a ajustar el área de la cobertura.

Ejemplo de uso de una directiva de cobertura para aplicar una directiva de conjunto de parámetros a las redes incluidas en la cobertura.
Algunos ejemplos de uso de una directiva de cobertura son:
- Conectar una directiva de conjunto de parámetros a un objeto de cobertura para aplicar sus parámetros de regla a cada una de las redes incluidas en esa cobertura.
- Conectar una directiva de conjunto de parámetros a un objeto de cobertura para crear un conjunto de parámetros cuyos miembros sean las redes individuales incluidas en esa cobertura.
- Conectar una directiva de par diferencial a un objeto de cobertura para crear objetos de par diferencial a partir de las redes diferenciales situadas dentro de los límites de esa cobertura.
Una cobertura, junto con una directiva de conjunto de parámetros, también puede utilizarse para aplicar clases de componentes y parámetros a los componentes que se encuentren completamente dentro del área definida por la cobertura. Para ello, utilice las opciones Component Class y Parameter del menú desplegable del botón Add en las propiedades de la directiva de conjunto de parámetros conectada a la cobertura. La información sobre la clase de componente y el parámetro se transferirá al documento de PCB del proyecto durante el proceso ECO al actualizar la PCB.
Cobertura
Una cobertura rectangular y una cobertura poligonal, cada una con una directiva conectada
Resumen
Una cobertura es un objeto de directiva de grupo, de forma rectangular o poligonal, que se coloca sobre un conjunto de redes y/o componentes. Una directiva (objeto de conjunto de parámetros) aplicada a la cobertura se aplicará a todas las redes y componentes incluidos en ella. Al colocar una cobertura, puede definir una forma rectangular simple o una forma poligonal. Esta última permite controlar con mayor precisión qué objetos de red de una hoja quedan incluidos.
La cobertura se aplica a todas las redes que:
- estén completamente dentro del área definida por la cobertura, o
- tengan al menos un vértice de extremo conectado del hilo / bus / arnés bajo la cobertura, o
- tengan una etiqueta de red conectada al hilo / bus / arnés y dicha etiqueta esté bajo la cobertura.
En el caso de los componentes, la cobertura se aplica a todos los componentes situados dentro del área que define.
Una directiva aplicada al perímetro de la cobertura (Place » Directive), como No ERC, par diferencial o un conjunto de parámetros de regla/clase específico, se aplicará a todas las redes y componentes identificados por el objeto de cobertura. Las coberturas pueden desactivarse y ocultarse.
Disponibilidad
Las coberturas solo pueden colocarse en el editor de esquemas. Para colocar una cobertura:
- Haga clic en Place » Directives » Blanket en los menús principales.
- Haga clic en el botón Cobertura del menú desplegable de directivas de la Active Bar situada en la parte superior del espacio de diseño. Mantenga pulsado un botón Active Bar para acceder a otros comandos relacionados. Una vez utilizado un comando, este pasará a ocupar la primera posición de esa sección de la Active Bar.
- Haga clic con el botón derecho en el editor de esquemas y, a continuación, haga clic en Place » Directives » Blanket.
Colocación
Para colocar una cobertura rectangular:
- Inicie el comando tal como se ha descrito anteriormente.
- Sitúe el cursor y, a continuación, haga clic o pulse Enter para colocar la esquina superior izquierda.
- Sitúe el cursor y, a continuación, haga clic o pulse Enter para colocar la esquina inferior derecha.
- Haga clic con el botón derecho o pulse Enter para finalizar la colocación.
- Continúe colocando más coberturas o haga clic con el botón derecho o pulse Esc para salir del modo de colocación.
Para colocar una cobertura poligonal:
- Inicie el comando de colocación.
- Sitúe el cursor y, a continuación, haga clic o pulse Enter para fijar el punto inicial de la cobertura.
- Sitúe el cursor y, a continuación, haga clic o pulse Enter para fijar una serie de segmentos que definan la forma de la cobertura.
- Tras colocar el último segmento, haga clic con el botón derecho o pulse Esc para finalizar la colocación. No es necesario «cerrar» el polígono, ya que el software completará automáticamente la forma añadiendo los segmentos necesarios para conectar el punto inicial con el último segmento colocado.
- Continúe colocando más coberturas o haga clic con el botón derecho o pulse Esc para salir del modo de colocación.
Durante la colocación de los segmentos de la cobertura, también puede realizar las siguientes acciones:
- Pulse la tecla Tab para pausar la colocación y acceder al modo Blanket del panel Propiedades, desde donde puede cambiar las propiedades de línea sobre la marcha. Haga clic en el botón de pausa superpuesto en el espacio de diseño para reanudar la colocación.
- Pulse Spacebar para cambiar la dirección de la esquina de un segmento aún no confirmado.
- Pulse Backspace para eliminar el segmento confirmado anteriormente al definir una forma poligonal para la directiva Blanket. El uso sucesivo de Backspace eliminará los segmentos anteriores en orden.
Edición gráfica
Este método de edición permite seleccionar un objeto Blanket colocado directamente en el espacio de diseño y cambiar gráficamente su tamaño, forma o ubicación. Al seleccionar un objeto Blanket, están disponibles los siguientes controles de edición:
Directivas Blanket rectangulares y poligonales seleccionadas que muestran sus controles de edición gráfica.
Haga clic y arrastre un control de edición situado en el centro de un segmento para mover ese borde de la directiva Blanket.
Para una directiva Blanket rectangular, haga clic y arrastre un control de edición de esquina para cambiar su tamaño simultáneamente en los planos vertical y horizontal.
Haga clic en cualquier punto del contorno de la directiva Blanket alejado de los controles de edición y arrastre para cambiar su posición. La directiva Blanket se puede girar o voltear mientras se arrastra:
- Pulse Spacebar para girar la directiva Blanket en sentido antihorario alrededor de la posición del cursor. Shift+Spacebar gira la directiva Blanket en sentido horario alrededor del cursor. El giro se realiza en incrementos de 90°.
- Pulse las teclas X o Y para voltear la directiva Blanket a lo largo del eje X o del eje Y, con respecto a la posición del cursor.
Edición no gráfica
Están disponibles los siguientes métodos de edición no gráfica.
Edición mediante el cuadro de diálogo Blanket o el panel Propiedades
Panel page: Propiedades de Blanket
Este método de edición utiliza el modo de cuadro de diálogo Blanket y el modo de panel Properties asociados para modificar las propiedades de un objeto Blanket.
El cuadro de diálogo Blanket , a la izquierda, y el modo Blanket del panel Propiedades, a la derecha
Después de la colocación, se puede acceder al cuadro de diálogo Blanket de las siguientes formas:
- Haciendo doble clic en el objeto Blanket colocado.
- Situando el cursor sobre el objeto Blanket, haciendo clic con el botón derecho y seleccionando Properties en el menú contextual.
Durante la colocación, se puede acceder al modo Blanket del panel Properties pulsando la tecla Tab. Una vez colocada la directiva Blanket, aparecen todas las opciones.
Después de la colocación, se puede acceder al modo Blanket del panel Properties de una de las siguientes formas:
- Si el panel Properties ya está activo, seleccionando el objeto Blanket.
- Después de seleccionar el objeto Blanket, seleccionando el panel Properties desde el botón Panels situado en la parte inferior derecha del espacio de diseño o seleccionando View » Panels » Properties en el menú principal.
Edición de varios objetos
El panel Properties permite editar varios objetos a la vez y modificar los ajustes de propiedades que sean idénticos en todos los objetos seleccionados. Cuando se seleccionan varios objetos del mismo tipo manualmente, mediante el cuadro de diálogo Buscar objetos similares o a través de un panel Filtro o Lista, cualquier valor de campo del panel Properties que no se muestre como un asterisco (*) puede editarse para todos los objetos seleccionados.
Edición mediante un panel Lista
Panel pages: Paneles Lista, Filtro SCH
Un panel List muestra los tipos de objetos de diseño de uno o varios documentos en formato de tabla, lo que permite inspeccionar y modificar rápidamente los atributos de los objetos. Si se utiliza junto con un filtrado adecuado, ya sea seleccionando tipos de objetos (mediante las opciones Include del panel) o utilizando el panel Filter correspondiente o el cuadro de diálogo Buscar objetos similares, permite mostrar únicamente los objetos incluidos en el ámbito del filtro activo. Las propiedades de los objetos enumerados pueden editarse directamente en el panel List.
Compatibilidad con el filtrado
Hay dos palabras clave especialmente útiles para buscar objetos Blanket mediante expresiones de consulta lógicas. Estas complementan el conjunto de otras palabras clave utilizadas para buscar una directiva Blanket en función de sus propiedades.
-
Collapsed– el objeto está contraído (también resulta útil al buscar máscaras de compilación). Esta palabra clave se encuentra en la categoría SCH Functions - Fields al utilizar el Asistente de consultas. -
IsBlanket– comprueba si el objeto es una directiva Blanket. Esta palabra clave se encuentra en la categoría SCH Functions - Object Type Checks al utilizar el Asistente de consultas.
Cree expresiones lógicas para que las consultas busquen y devuelvan las directivas Blanket de su diseño según sea necesario. Algunos ejemplos de expresiones de consulta lógicas para buscar directivas Blanket son:
IsBlanket And Collapsed – busca todos los objetos Blanket que están contraídos actualmente.
IsBlanket And Not Collapsed – busca todos los objetos Blanket que no están contraídos actualmente.
Desactivación de una directiva Blanket
Una vez colocadas, las directivas Blanket pueden desactivarse temporalmente haciendo clic en el pequeño triángulo de la esquina superior izquierda Haga clic una vez para desactivar y ocultar la directiva Blanket; haga clic de nuevo para volver a activarla. Esto ofrece una forma práctica de controlar el efecto de la directiva Blanket sin tener que eliminarla por completo del diseño.
Propiedades de la cobertura
Las propiedades de los objetos del editor de esquemáticos son opciones configurables que especifican el estilo visual, el contenido y el comportamiento del objeto colocado. Las propiedades de cada tipo de objeto se definen de dos maneras diferentes:
-
Pre-placement settings – la mayoría de las propiedades de los objetos de cobertura, o aquellas que pueden predefinirse de forma lógica, están disponibles como ajustes predeterminados editables en la página Esquemático - Valores predeterminados del cuadro de diálogo Preferences (accesible desde el botón
situado en la esquina superior derecha del espacio de diseño). Seleccione el objeto en Primitive List para mostrar sus opciones a la derecha.
- Post-placement settings – todas las propiedades de los objetos de cobertura se pueden editar en el cuadro de diálogo Blanket y en el panel Properties cuando se selecciona una cobertura colocada en el espacio de diseño.
Propiedades
- Border Width - utilice la lista desplegable para seleccionar el grosor de borde deseado.
- Estilo de línea - utilice la lista desplegable para seleccionar el estilo de línea deseado.
- Border Color - haga clic en el recuadro de color para seleccionar el color deseado para el borde.
- Fill Color - haga clic en el recuadro de color para seleccionar el color deseado para el relleno.
- Collapsed and Disabled - marque esta casilla para contraer y deshabilitar las coberturas.
Directivas indirectas (basadas en parámetros)
Las directivas de conjunto de parámetros son necesarias para aplicarlas a objetos de diseño del esquemático que no pueden contener parámetros; sin embargo, para los objetos que sí pueden contenerlos, las directivas de diseño se pueden aplicar indirectamente añadiéndolas (y definiéndolas) como parámetros del objeto esquemático correspondiente. En esencia, son parameter-based directives.
Algunos ejemplos de uso de las directivas basadas en parámetros incluyen limitar la altura de un componente específico o añadir una restricción de separación aplicable a todos los objetos del diseño. El parámetro necesario que define la restricción se añade al objeto como una regla.
Al sincronizar con la PCB, las directivas basadas en parámetros que se hayan añadido a los objetos del esquemático se convertirán en reglas de diseño de PCB. El ámbito de la regla de diseño de PCB correspondiente estará determinado por la naturaleza del objeto al que se asignó inicialmente el parámetro. La siguiente tabla resume las opciones admitidas para la correspondencia entre los parámetros del esquemático y el ámbito de las reglas de PCB.
| Añadir un parámetro (como regla) a un... | Desde... | Para un ámbito de regla de PCB de... |
|---|---|---|
| Pin | la pestaña Parameters del modo Pin del panel Propiedades. | Pad |
| Puerto | la pestaña Parameters del modo Puerto del panel Propiedades. | Red |
| Componente | la región Parameters del modo Componentes del panel Propiedades. | Componente |
| Símbolo de hoja | la pestaña Parameters del modo Símbolo de hoja del panel Propiedades, cuando se selecciona Local en la región Origen. | Clase de componentes |
| Símbolo de hoja de dispositivo | la pestaña Parameters del modo Símbolo de hoja del panel Propiedades, cuando se selecciona Dispositivo en la región Origen. | Clase de componentes |
| Símbolo de hoja gestionada | la región Parameters del modo Símbolo de hoja del panel Propiedades, cuando se selecciona Gestionada en la región Origen. | Clase de componentes |
| Hoja | la pestaña Parameters del modo Opciones del documento del panel Propiedades. | Todos los objetos |
En cada caso, el método para añadir un parámetro basado en reglas es el mismo. Desde la pestaña o el cuadro de diálogo correspondiente, realice lo siguiente:
- Añada un parámetro como regla.
- Seleccione el tipo de regla que desea utilizar.
- Configure las restricciones para el tipo de regla elegido.
Especificación de clases de componentes
De forma similar, las clases de componentes se pueden definir en el esquemático añadiendo un parámetro ClassName a los componentes deseados y estableciendo su valor en el nombre de clase deseado. Cuando el diseño se transfiera a la PCB, se crearán las clases de componentes definidas.
Para garantizar que las clases de componentes definidas en el esquemático se transfieran a la PCB, deben establecerse las siguientes opciones en el cuadro de diálogo Project Options:
- Habilite la opción Generate Component Classes situada en la región User-Defined Classes de la pestaña Generación de clases del cuadro de diálogo.
-
En la pestaña Comparador del cuadro de diálogo, establezca el ajuste Differences Associated with Components » Extra Component Classes Mode en
Find Differences.
La opción de la pestaña Class Generation indicada anteriormente se muestra en la imagen siguiente. Pase el cursor sobre la imagen para ver la configuración de la opción de la pestaña Comparator .

Para transferir las clases de componentes a la PCB, habilite la opción Generate Component Classes en la pestaña Class Generation. Pase el cursor sobre la imagen para mostrar la pestaña Comparator, donde deberá establecer el ajuste Extra Component Classes Mode en Find Differences.
Una vez definidas, las clases se pueden bloquear en la región Properties del panel Properties de las propiedades del componente correspondiente.
Control de la impresión de directivas
De forma predeterminada, todas las directivas de diseño se incluyen al imprimir las hojas del esquemático. Sin embargo, esto se puede cambiar:
- Desde el cuadro de diálogo Propiedades de impresión del esquemático, al imprimir directamente desde el esquemático o como parte de una salida configurada en un archivo de configuración de trabajos de salida.
- Desde la región Schematics include, en la página Additional PDF Settings del Asistente de PDF inteligente.

Controle la impresión de las directivas según sea necesario. En el caso de las directivas No ERC, puede optar por imprimir determinados estilos de símbolo y excluir otros.



).
).