Publication vers un espace de travail
En un coup d'œil
- Identifiez les jeux de données sources, de fabrication, d’assemblage, de variantes et personnalisées à inclure, et découvrez comment attribuer les tâches de sortie requises.
- Comprenez les options de destination de publication, les schémas de nommage des éléments de l’espace de travail et les paramètres des révisions cibles.
- Suivez les étapes de publication et découvrez comment les commandes de publication automatisée influent sur la vérification, la génération de rapports et la publication vers un système PLM.
Avec la vue Release dans Online Mode, le processus de publication se déroule par étapes. Les entrées situées à gauche de la vue vous permettent de voir d’un coup d’œil à quelle étape vous vous trouvez :
-
Configure Server Release – cette étape du processus de publication vous permet de spécifier les types de données à générer : données sources (toujours générées), données de fabrication, données d’assemblage (pour la conception de base et chaque variante détectée).
-
Validate Project – cette étape du processus de publication s’exécute automatiquement lorsqu’un ou plusieurs rapports de type Validation sont détectés dans les fichiers OutJob affectés. Tous les générateurs de sorties de validation définis dans un fichier Output Job affecté à l’élément de données en cours de publication sont exécutés.
-
Generate Data – cette étape du processus de publication s’exécute automatiquement. Toutes les autres sorties définies dans les fichiers OutJob affectés aux éléments de données inclus sont alors générées, afin de produire les données à publier dans les éléments cibles correspondants du Workspace.
-
Review Data – une fois tous les contrôles de validation réussis et les données de sortie générées, cette étape du processus de publication vous permet d’examiner les données générées.
-
Upload Data – après confirmation de la publication à l’étape précédente, cette étape démarre automatiquement. Elle affiche simplement la progression du transfert des données vers les révisions des éléments de données correspondants dans le Workspace cible.
-
Execution Report – il s’agit de la dernière étape du processus, qui fournit un récapitulatif de la publication. Des liens de navigation permettent d’accéder rapidement aux révisions d’éléments générées dans le panneau Explorer. Si vous avez accédé au Project Releaser dans le cadre d’un processus de publication puis de transfert vers un PLM, le bouton
s’affiche. Cliquez dessus pour poursuivre le workflow sous-jacent du processus et transférer les données vers le PLM.
-
Publish to PLM – cette étape n’est présente que lorsque la publication est exécutée dans le cadre du processus activé correspondant (pour publier, puis transférer les données vers un PLM). Elle démarre automatiquement lorsque vous cliquez sur le bouton
à l’étape précédente (ou directement si la commande Prepare & Release & Publish to PLM, dans le menu associé au bouton
, a été utilisée). La boîte de dialogue Login Credentials s’affiche. Saisissez le Username et le Password de votre instance PLM, puis sélectionnez le modèle PLM à utiliser (qui apparaît sous la forme <PLMInstance>:<PublishingTemplate>).
Étape en ligne 1 – Configurer la publication sur le serveur
Cette étape du processus de publication vous permet de spécifier les types de données à générer. Les éléments de données pouvant être publiés sont les suivants :
- Source Data – un instantané de la conception source.
- Fabrication Data – les données nécessaires à un fabricant de circuits imprimés pour produire la carte nue.
- Assembly Data for the Base Design (no variations) – les données nécessaires à un prestataire d’assemblage pour équiper entièrement la carte nue conformément à une nomenclature, pour la conception de base sans variante.
-
Assembly Data for Design
Variant n– les données nécessaires à un prestataire d’assemblage pour équiper la carte nue conformément à une nomenclature, pourVariant nde la conception de base.
Le nombre de jeux de données d’assemblage correspond à la conception de base (sans variante) et à toutes les variantes détectées définies pour cette conception.

Étape 1 du processus de publication du projet : configuration du contenu de la publication (données à générer).
L’élément Source Data est toujours inclus dans une publication. Les autres éléments de données sont facultatifs.
Affectation des fichiers Output Job
Pour que les éléments Fabrication Data et Assembly Data soient inclus dans une publication, au moins un fichier Output Job doit leur être affecté. Si les noms de vos fichiers Output Job commencent par les sous-chaînes « fab » et « ass », ces fichiers OutJob seront automatiquement affectés aux sections Fabrication Data et Assembly Data respectivement, lors du premier accès à la vue Release. Dans le cas contraire, vous devrez affecter manuellement les fichiers OutJob appropriés dans chaque cas. Pour cela, utilisez l’onglet Release Options de la boîte de dialogue Project Release Options (cliquez sur le bouton
en bas à gauche de la vue pour y accéder).

Affectez les fichiers OutJob aux jeux de données appropriés selon vos besoins.
Modification de la cible de publication
L’onglet Release Options de la boîte de dialogue Project Release Options permet également de modifier la cible de publication, en basculant entre les modes de fonctionnement géré (Online) et non géré (Offline). Trois options sont disponibles :
-
Unmanaged - Folder(Offline) : sélectionnez cette option pour publier les données générées dans un dossier local. Le chemin du dossier racine est spécifié dans l’onglet Output Path de la boîte de dialogue. Par défaut, il est défini sur[OutputPath](à l’aide du chemin défini dans le champ Output Path, dans l’onglet Options de la boîte de dialogue Project Options). -
Unmanaged - Zip(Offline) : sélectionnez cette option pour publier les données générées dans un dossier local. Les données seront regroupées dans un seul fichier ZIP. Le chemin et le nom du fichier ZIP sont spécifiés dans l’onglet Output Path de la boîte de dialogue. Par défaut, ils sont définis sur[OutputPath][ProjectName].zip(à l’aide du chemin défini dans le champ Output Path de l’onglet Options de la boîte de dialogue Project Options). -
Managed - <WorkspaceName>(Online) : sélectionnez cette option pour publier dans le Workspace (avecWorkspaceName) auquel vous êtes actuellement connecté.

Modifiez la destination de publication – l’emplacement où les données générées doivent être envoyées – dans les options de publication du projet.
Définition des schémas de nommage des éléments de l’espace de travail
Lorsque vous publiez un projet pour la première fois dans l’espace de travail cible, vous pouvez définir le nom des éléments de données cibles de cet espace de travail (dont les révisions reçoivent les données générées). Cette opération s’effectue dans l’onglet Item Naming de la boîte de dialogue Project Release Options, accessible en cliquant sur le bouton
en bas à gauche de la vue (ou en cliquant sur le lien Target Revision d’un jeu de données à publier, puis en choisissant Edit dans le menu contextuel). Cet onglet permet de :
- Définir le nom du projet. Par défaut, ce champ contient le nom actuel du projet.
-
Définir les schémas de nommage par défaut des différents éléments de données pouvant être générés lors de la publication. Cliquez dans un champ de la colonne Item ID, puis sur le bouton
à droite du champ pour ouvrir la boîte de dialogue Choose Item (une variante du panneau Explorer), qui vous permet de cibler un élément existant dans l’espace de travail actuellement connecté.
Pour modifier l’un des schémas de nommage, cliquez sur le bouton Settings afin d’ouvrir la boîte de dialogue Naming Template Settings.

Définissez le nom du projet et le nommage des éléments de données générés dans l’espace de travail cible. Ici, les champs sont modifiables, car le projet n’a pas encore été publié.
Les formats de macros suivants sont pris en charge dans les modèles de nommage :
-
Parameter-based – permet d’utiliser des paramètres entre crochets (par exemple
[ProjectName],[VariantName],[ProjectParameter]). -
Numeric-based – permet d’utiliser des quantificateurs numériques entre accolades (par exemple
{0000},{9000}).
Contrôle de la révision cible
De retour dans la vue principale, cliquez sur le lien situé à côté d’une entrée Target Revision pour accéder au menu de commandes illustré dans l’image suivante :

Accès aux commandes permettant de spécifier la révision cible d’un jeu de données à générer lors de la publication – survolez l’image pour les voir.
Les commandes disponibles dépendent du fait que l’élément ait déjà fait l’objet ou non d’une première publication. Voici la liste de toutes les commandes possibles :
-
Auto <RevisionID> – cette entrée laisse le système gérer les révisions, afin que vous n’ayez pas à créer de révisions planifiées lorsqu’il n’en existe pas encore.
RevisionIDindique la prochaine révision de l’élément au même niveau dans le schéma de nommage des révisions attribué (par exemple, si la révision actuelle estA.1, cette commande indiqueA.2comme cible). -
Next <RevisionID> – cette entrée n’est disponible qu’après la première publication de l’élément. Utilisez-la pour incrémenter rapidement la révision cible au niveau suivant dans le schéma de nommage des révisions attribué.
RevisionIDindique la prochaine révision (par exemple, si la révision actuelle estA.1, cette commande fait passer la cible àB.1). -
Custom – utilisez cette entrée pour cibler une révision spécifique d’un élément cible en définissant un identifiant de révision personnalisé dans la boîte de dialogue Custom Revision ID. Selon le schéma de nommage des révisions utilisé, la boîte de dialogue peut comporter jusqu’à trois champs d’identifiant de niveau. Notez que l’identifiant de la première révision planifiée de l’élément peut être modifié à tout moment après la création de l’élément et avant la publication des données dans cette révision initiale (c’est-à-dire tant qu’elle est encore à l’état
Planned). - Browse – utilisez cette entrée pour sélectionner une révision existante d’un élément cible dans laquelle publier les données. La boîte de dialogue Choose Target Item (une variante du panneau Explorer) s’ouvre à cet effet.
- Edit – utilisez cette entrée pour accéder à l’onglet Item Naming de la boîte de dialogue Project Release Options, où vous pouvez modifier le nom de l’élément cible (et sa révision initiale) qui sera créé.
- Navigate – utilisez cette entrée pour accéder rapidement à l’élément dans le panneau Explorer (lorsqu’il a déjà été publié et que la révision suivante existe à l’état planifié).
L’entrée en haut du menu reflète la révision cible actuellement sélectionnée ou définie.
Accès aux détails de génération des données
Cliquez sur la commande Details – à l’extrémité droite de l’en-tête d’un jeu de données – pour consulter les détails de ce qui sera exactement généré par ce jeu de données. Repliez cette vue détaillée en cliquant sur la commande Hide Details. À l’exception du jeu Source Data, les données générées proviennent d’un ou plusieurs fichiers Output Job attribués. Vous pouvez accéder rapidement au fichier OutJob source en cliquant sur la commande Configure.

Accédez à la vue détaillée d’un jeu de données pour voir quelles données seront générées – survolez l’image pour la voir.
Paramètres supplémentaires
Des paramètres supplémentaires relatifs à la publication du projet peuvent être définis sur la page Data Management – Servers de la boîte de dialogue Preferences :
-
Le dossier utilisé pour stocker temporairement les fichiers générés avant leur transfert vers l’espace de travail actuellement connecté peut être défini sur l’emplacement automatique (
\Users\<ProfileName>\AppData\Local\Temp\Releasespour une installation par défaut), ou remplacé manuellement par un dossier de votre choix. - Activez l’option Delete contents after exiting release mode pour que le dossier de stockage temporaire soit vidé à la fin du processus de publication.
- Le nom de chaque sortie générée peut, si vous le souhaitez, être précédé de l’identifiant de l’élément et de l’identifiant de révision (par exemple
[FAB-Kame_FMU-A.1] Validation.PDF). Pour ce faire, activez l’option Prepend revision HRID to file names.

Préférences supplémentaires relatives au processus de publication du projet.
Une fois les éléments de données à créer dans le cadre de la publication configurés selon vos besoins, cliquez sur le bouton
en bas à droite de la vue pour continuer.
Plusieurs vérifications préalables à la publication sont effectuées pendant la préparation, notamment :
- Vérifier que le projet et tous les fichiers ont été enregistrés.
- Vérifier que le projet et tous les fichiers concernés ont été validés dans le système de contrôle de version (VCS), le cas échéant.
- Vérifier qu’un nom a été attribué à chaque élément de données activé.
- Vérifier que l’utilisateur dispose des droits nécessaires pour créer l’élément cible (et sa révision).
- Créer les éléments cibles requis (et les révisions prévues) dans l’espace de travail lorsqu’ils n’existent pas encore, et veiller à utiliser la révision suivante pour ceux qui existent déjà.
Si des problèmes sont détectés, des solutions vous seront proposées pour les résoudre (par exemple, enregistrer les fichiers modifiés localement et les valider dans le VCS).
L’élément Source Data est généré à ce stade : un instantané des fichiers sources du projet de conception est publié dans la révision de l’élément cible.
Étape en ligne 2 – Valider le projet
Une fois l’étape 1 terminée sans problème, cette étape suivante du processus de publication s’exécute automatiquement lorsqu’un ou plusieurs rapports de type Validation sont détectés dans les fichiers OutJob affectés. Tous les générateurs de sorties de validation définis dans un fichier Output Job affecté à l’élément de données en cours de publication sont exécutés. Cela inclut l’exécution des vérifications suivantes :
- Differences Report – utilisation du comparateur pour déterminer si les documents sources et les documents de conception du PCB sont correctement synchronisés.
- Electrical Rules Check – vérification de la validité électrique et graphique de la conception source saisie.
- Design Rules Check – vérification de la validité du document PCB par rapport aux contraintes de conception spécifiées au niveau de la carte.
-
BOM Checks – recherche d’éventuelles violations associées aux éléments de conception ou aux choix de composants dans le document de nomenclature source (
*.BomDoc), le cas échéant. - Footprint Comparison Report – comparaison des empreintes de la carte avec celles de leur bibliothèque source pour vérifier qu’elles sont à jour et qu’elles correspondent.
- Component State Checking – recherche de composants se trouvant dans des états soumis à des restrictions. Lors de la configuration, vous définissez l’action à effectuer pour chaque état actuellement défini, dans chaque définition de cycle de vie actuellement définie dans l’espace de travail cible : aucune action, émission d’un avertissement ou génération d’une erreur. Cette dernière option empêchera la publication de la conception. En outre, cette vérification génère un rapport HTML pratique qui vous permet de repérer en un coup d’œil les composants de la conception dont l’état n’est pas valide.
- Environment Configuration Compliance Check – vérification que seuls les éléments de données autorisés par la configuration d’environnement accessible au rôle qui vous est attribué (le cas échéant) sont utilisés. Cette vérification peut également garantir que tous les éléments de conception proviennent d’un espace de travail.
Si la validation réussit, l’icône
s’affiche avec le texte Passed. Dans le cas contraire, l’icône
s’affiche avec le texte Failed.
Étape en ligne 3 – Générer les données
Une fois l’étape 2 terminée sans problème, cette étape suivante du processus de publication s’exécute automatiquement. Toutes les autres sorties, définies dans les fichiers OutJob affectés aux éléments de données inclus, sont alors générées afin de produire les données à publier dans les éléments cibles correspondants de l’espace de travail.
Comme pour les autres étapes, mais de façon plus visible ici en raison de sa durée d’exécution plus longue, des icônes indiquent la progression de la génération :
– pas encore exécuté/généré.
– en cours d’exécution/de génération.
– généré avec succès.
– échec de la génération.
Étape en ligne 4 – Examiner les données
Une fois toutes les vérifications de validation réussies et les données de sortie générées, cette étape du processus de publication vous permet d’examiner les données générées.

Examinez les données générées et vérifiez que tout est conforme avant de confirmer la publication et de transférer les données vers l’espace de travail.
Par défaut, la page présente une vue simple (compacte) des données générées. Pour passer à une vue plus détaillée, cliquez sur la commande Details associée à la section qui vous intéresse.

Cliquez sur une commande Details pour passer de la vue simple à la vue détaillée des données générées pour la section correspondante. Pour revenir à la vue simple, cliquez sur la commande Hide Details.
États de génération des sorties dans la vue détaillée
Le tableau suivant répertorie les états possibles des sorties lors de la génération des données, tels qu’ils apparaissent dans la vue détaillée :
État |
Description |
|---|---|
|
La sortie n’a pas encore été générée ou n’existe pas. |
|
La sortie a été générée, mais des modifications ont depuis été apportées à la conception, rendant ces données obsolètes. |
|
La sortie est en cours de génération. |
|
La sortie repose sur une validation et a généré un rapport ne contenant aucune erreur. Dans le cas d’un rapport ERC, soit aucune erreur n’est présente, soit le niveau de ces erreurs reste dans la limite maximale tolérée spécifiée pour ce rapport. |
|
La sortie (à l’exception des sorties reposant sur une validation) a été générée avec succès. |
|
La sortie n’a pas pu être générée correctement. Pour une sortie reposant sur une validation, cela signifie que les documents sources de conception contiennent des erreurs entraînant l’échec de certaines vérifications. Pour une sortie standard, la génération n’a pas abouti. Il se peut que des erreurs fatales aient été détectées lors de la validation préalable à la génération, ou que la configuration du générateur de sortie associé dans le fichier Output Job présente un problème. |
Dans la vue compacte des données générées, cliquez sur un lien View pour ouvrir le fichier ou l’ensemble de fichiers de données associé, soit dans l’éditeur approprié d’Altium Designer (par exemple, l’éditeur CAM pour les fichiers Gerber ou les fichiers ODB++ compressés/non compressés), soit dans l’application externe appropriée (par exemple, Microsoft Excel pour une nomenclature). Dans la vue détaillée, double-cliquez sur une entrée pour afficher uniquement ce fichier.
Un contrôle couramment effectué par les concepteurs avant la publication consiste à comparer les fichiers Gerber générés pour la version actuelle avec ceux de la version précédente. Cliquez sur le lien Compare Gerber à côté d’une sortie Gerber et sélectionnez une version précédente dans le menu déroulant pour comparer les données Gerber préparées à celles de la version choisie. Votre navigateur par défaut ouvrira l’espace de travail de votre entreprise et affichera les résultats.

Accès à la fonctionnalité de comparaison Gerber depuis Project Releaser, avant la publication des données dans un espace de travail.
► En savoir plus sur la fonctionnalité Gerber Comparison (Espace de travail Altium 365, Espace de travail Enterprise Server).
Si, après avoir examiné les données, vous constatez que des modifications sont nécessaires, cliquez sur le bouton
en bas à droite de la vue. Une boîte de dialogue de confirmation s’affiche pour vous avertir que toutes les données générées seront perdues. Un clic sur OK annule la publication et vous ramène à l’étape 1 du processus.
Si toutes les données générées semblent correctes, poursuivez la publication en cliquant sur le bouton
(également en bas à droite de la vue). La boîte de dialogue Confirm Release s’affiche et récapitule les configurations du projet qui seront publiées dans l’espace de travail. Vous pouvez également y ajouter un Name (par défaut, la valeur indiquée est [ProjectName]), une Description, ainsi que toute note de publication pertinente.

Confirmation des éléments qui seront publiés, en termes de révisions d’éléments générées, avec possibilité de modifier le nom et la description et d’ajouter des notes de publication.
Étape en ligne 5 – Téléversement des données
Après la confirmation de la publication à l’étape précédente, cette étape démarre automatiquement. Elle affiche simplement la progression du téléversement des données dans les révisions des éléments de données correspondants de l’espace de travail.

Cette étape indique simplement la progression du téléversement des données générées vers les révisions d’éléments associées dans l’espace de travail.
Étape en ligne 6 – Rapport d’exécution
Il s’agit de la dernière étape du processus, qui fournit un récapitulatif de la publication.

Rapport final de la publication.
Utilisez les liens de navigation pour accéder rapidement à la révision d’élément associée contenant les données publiées (données de fabrication, données d’assemblage et ensembles de données personnalisées), dans le panneau Explorer, votre point d’accès à l’espace de travail.

Consultation des données publiées pour le projet, directement dans l’espace de travail, grâce au panneau Explorer.
Consultation du projet publié
Pour un projet d’espace de travail, une fonctionnalité supplémentaire est disponible une fois la publication terminée. En cliquant sur le lien Project Page, le dernier des liens de navigation en haut de la page Execution Report, vous ouvrez le panneau Explorer, qui présente le projet dans Project View, disponible uniquement pour les projets d’espace de travail.

Vous pouvez explorer un projet d’espace de travail plus en détail dans le panneau Explorer, grâce à Project View.
La zone Releases (en bas à gauche de la vue) affiche une synthèse des publications associées au projet, comprenant un récapitulatif de chaque publication et des packages qui la composent. Cliquez sur le bouton
dans cette zone pour ouvrir la boîte de dialogue Batch state change, qui permet de modifier l’état du cycle de vie de plusieurs éléments liés à une même publication en une seule opération par lots.
Des informations supplémentaires sur les publications du projet sont disponibles dans la visionneuse Web de l’espace de travail cible, accessible via le bouton
du panneau Explorer. Dans la visionneuse Web d’un espace de travail, toutes les publications associées au projet sont accessibles dans la vue Releases, ou dans la vue Manufacture pour un espace de travail hébergé sur un serveur sur site. La page répertorie toutes les publications du projet, de la plus récente à la plus ancienne. Chaque publication peut être ouverte dans Manufacturing Portal de l’espace de travail à l’aide de son bouton d’ouverture La vue Manufacturing Portal fournit des informations plus détaillées sur la publication sélectionnée, notamment les fichiers des packages qui la composent, l’ensemble des documents de conception ainsi que les informations sur les fabricants et les fournisseurs des composants. Notez que la fonctionnalité Send to Manufacturer est disponible uniquement dans un espace de travail Altium 365. ► Consultez la page Vue des publications de l’espace de travail Altium 365 pour en savoir plus.
Et voilà ! Une fois votre projet publié, vous pouvez simplement fermer la vue Release (à l’aide du bouton
en bas à droite de la vue). Lorsque vous devrez publier à nouveau ce même projet, Project Releaser vous permettra de le faire rapidement et facilement, tout en incrémentant automatiquement les révisions d’éléments cibles.
Publication vers une instance PLM
Related pages: Intégration PLM (espace de travail Altium 365, espace de travail Enterprise Server), Publication vers un PLM
Vous pouvez publier une conception vers une instance PLM lors de l’exécution du Project Releaser dans Altium Designer. L’opération de publication utilise un modèle de publication, défini dans la configuration d’intégration de cette instance PLM, pour contrôler la manière dont les données doivent être transférées vers le PLM. Cette fonctionnalité est disponible via un processus configuré de manière appropriée. Un exemple de définition de processus est fourni avec l’installation, Project Releaser with Publish, dont le workflow sous-jacent permet de publier vers l’instance PLM intégrée lors d’une étape supplémentaire du Project Releaser. Le diagramme du workflow est présenté ci-dessous.

Diagramme du workflow de l’exemple de définition de processus Project Releaser with Publish par défaut
Une fois activé, le processus de publication vers une instance PLM dans le cadre du Project Releaser est accessible depuis Altium Designer, dans le sous-menu Project » Project Releaser du projet actif ou dans le sous-menu contextuel Project Releaser, accessible par un clic droit sur l’entrée du projet de conception dans le panneau Projects.

Accès au processus de publication vers une instance PLM dans le cadre du Project Releaser
Le Project Releaser apparaît, avec une étape supplémentaire : 7. Publish to PLM. De plus, une commande est disponible dans le menu associé au bouton
, Prepare & Release & Publish to PLM, si vous souhaitez exécuter le Project Releaser sans vous arrêter pour examiner les données générées et le rapport d’exécution.

Commande supplémentaire permettant d’exécuter le Project Releaser sans s’arrêter pour examiner les données générées et le rapport d’exécution
Si vous exécutez le Project Releaser avec la commande standard Prepare, après l’examen et la mise à disposition des données, le bouton
s’affiche à l’étape Execution Report. Cliquez dessus pour poursuivre le workflow sous-jacent du processus et publier vers le PLM. La boîte de dialogue Login Credentials apparaît. Saisissez le Username et le Password de votre instance PLM, puis sélectionnez le modèle PLM à utiliser (qui apparaît sous la forme <PLMInstance>:<PublishingTemplate>).

La boîte de dialogue Login Credentials affichée lors de la première publication vers l’instance PLM.
Cliquez sur l’onglet Diagram pour afficher le workflow sous-jacent du processus.

L’onglet Diagram de la boîte de dialogue Login Credentials
Cliquez sur le bouton
pour poursuivre le processus de publication conformément à ce workflow.
).
