Inspection des données de fabrication avec l’éditeur CAM
En un coup d'œil
- Apprenez à sélectionner, exécuter, répéter et annuler des commandes dans l’éditeur CAM.
- Comprenez les différences d’affichage des images de fabrication, des points de perçage et des trajectoires de fraisage entre les modes CAM et CN.
- Découvrez comment gérer la visibilité des couches, sélectionner la couche active et accéder aux commandes des couches depuis le panneau CAMtastic.
L'éditeur CAMtastic (CAM) d'Altium Designer propose une variété d'outils, dont les plus élémentaires permettent de visualiser et de modifier les données CAM. Une fois les fichiers d'image et de perçage importés, l'éditeur CAM peut recevoir des instructions définissant les types de couches et l'empilage, après quoi une netlist peut être extraite et comparée à une netlist IPC générée par le logiciel de conception de PCB d'origine. Ces netlists prennent en charge non seulement les composants traversants, mais aussi les vias borgnes et enterrés. L'éditeur CAM propose également des outils de vérification des règles de conception, de panélisation et de détourage à commande numérique (ainsi que de fraisage).
Principes de base des actions CAM
L'environnement de l'éditeur CAM utilise des méthodes légèrement différentes de celles auxquelles vous êtes peut-être habitué pour effectuer des actions et des procédures.
L'action avant la sélection
La manière dont les actions sont effectuées dans l'éditeur CAM peut sembler inversée aux nouveaux utilisateurs habitués à sélectionner des objets before d'indiquer au programme ce qu'il doit en faire. Comme d'autres outils CAM, l'éditeur CAM inverse ce processus : vous choisissez d'abord l'action, puis vous sélectionnez les objets concernés, avant de terminer par une commande d'exécution.
Si vous n'avez pas l'habitude de travailler ainsi, quelques repères peuvent vous aider à vous familiariser avec cette méthode. Tout d'abord, observez le curseur. Lorsqu'il apparaît sous forme de réticule dans l'espace de conception, cela signifie qu'il n'est pas en mode sélection (un curseur carré de sélection s'affiche en mode sélection). Le fait que les boutons de sélection soient tous grisés vous rappelle que vous n'avez pas encore choisi d'action, du moins pas une action nécessitant une sélection générale. La barre d'état, située au bas de la fenêtre d'édition principale, est particulièrement utile lors des processus en plusieurs étapes, lorsque vous vous demandez pourquoi rien ne se passe : elle vous indique ce que l'éditeur CAM attend de vous.
Exécution par clic droit
Vous choisissez d'abord une commande, puis vous sélectionnez un ensemble d'objets. L'éditeur CAM attend ensuite une commande d'exécution. Cela vous permet de constituer soigneusement votre sélection sur plusieurs couches et groupes d'objets. La méthode de base pour envoyer la commande d'exécution consiste à faire un clic droit. Les invites dans Status Bar indiquent quand un clic droit peut être utilisé de cette manière. Vous pouvez également utiliser le raccourci clavier Shift+F9 pour exécuter la fonction en cours une fois que tous les objets nécessaires à cette fonction ont été sélectionnés.
Vous remarquerez peut-être qu'après l'exécution d'une fonction, le curseur ne revient pas à son état inactif. Le carré de sélection reste affiché et la barre d'état vous invite à recommencer la sélection. Cela se produit lorsque l'option Auto Repeat Functions est activée sur la page CAM Editor - General de la boîte de dialogue Preferences.
Le bouton droit de la souris peut parfois servir à annuler les processus en cours. Cela fonctionne lorsque vous n'avez pas encore terminé une étape requise, comme la sélection d'objets. Toutefois, la touche Esc est généralement un moyen plus sûr de procéder à une annulation.
Modes d'édition
L'éditeur CAM prend en charge deux modes d'édition : CAM et NC (détourage). Ces modes sont activés à l'aide des commandes respectives CAM Editor et NC Editor, accessibles en sélectionnant View » CAM Editor ou View » NC Editor dans le menu principal. Vous pouvez également définir le mode d'édition directement dans la liste déroulante du panneau CAMtastic . Ces modes se distinguent essentiellement par la manière dont les données sont affichées. Le mode CAM Editor affiche les images exactement telles qu'elles seront tracées ou flashées sur le film photographique utilisé pour la fabrication du PCB. Le mode NC Editor ajoute des marqueurs aux trous de perçage et aux trajectoires de détourage.
Une trajectoire de détourage affichée en mode NC Editor.
Le CAM Editor est toujours dans l'un de ces deux modes d'édition. En mode CAM Editor, les outils de détourage sont grisés dans les menus. De même, lorsque le mode NC Editor est actif, les outils d'édition CAM habituels sont désactivés. Lorsque le mode CAM Editor est actif, le panneau CAMtastic permet d'accéder rapidement aux codes D définis dans la liste des ouvertures, à l'aide d'une liste déroulante. Lorsque le mode NC Editor est actif, cette liste déroulante affiche à la place l'ensemble des outils de perçage, de détourage et de fraisage. Plus important encore, l'espace de conception correspond au mode d'édition en cours. Le mode NC Editor indique les points de perçage et les trajectoires de détourage à l'aide de marqueurs spéciaux : chaque point de perçage est marqué d'un X, tandis que les trajectoires de détourage comportent des points de plongée et de retrait ainsi que, si nécessaire, des marqueurs de direction. Ces marqueurs d'instruction sont invisibles lorsque vous travaillez en mode CAM Editor.
Le panneau CAMtastic
Ce panneau, disponible dès qu'un document CAM est actif, contient les principales informations relatives à ce document, notamment les couches, le code D ou l'outil en cours, les paramètres de grille et d'unités, ainsi que la position absolue du curseur dans l'espace de conception. Vous pouvez également basculer entre les sections Info, DRC, Nets et Steps du panneau pour obtenir d'autres informations propres à la conception.
La section Layers affiche toutes les couches créées ou importées, ainsi que leur état de visibilité. La couche active présente un X blanc sur sa pastille de couleur et est également indiquée en haut de la section. Vous pouvez double-cliquer sur le nom d'une autre couche pour en faire la couche active.
Lorsque des couches sont présentes, un clic droit n'importe où dans cette section permet d'accéder rapidement aux commandes de gestion des couches, notamment pour les verrouiller, les renommer ou en ajouter. Si vous avez créé un nouveau document et souhaitez commencer à ajouter des couches, utilisez la commande Edit » Layers » Add pour ajouter la première couche.
Vous pouvez mettre en surbrillance n'importe quelle couche de cette liste, puis utiliser les touches Up Arrow et Down Arrow du clavier pour parcourir les données CAM en mode monocouche. La touche Right Arrow rend toutes les couches visibles, tandis que la touche Left Arrow isole la couche en surbrillance. Vous pouvez sélectionner plusieurs couches à l'aide des fonctions standard Shift+Click et Ctrl+Click, ce qui vous permet d'afficher, de masquer ou de supprimer plusieurs couches à la fois. Vous pouvez utiliser les touches +/- et * du pavé numérique pour parcourir respectivement toutes les couches visibles ou uniquement les couches de signal et de plan.
Il est possible de supprimer des couches depuis le panneau, mais cette action est irréversible. La commande Undo du menu Edit ne permet pas de restaurer les couches supprimées.
Vous pouvez basculer entre le panneau CAMtastic et le document CAM actif à l’aide du raccourci clavier Shift+F5. La touche F4 permet d’afficher ou de masquer tous les panneaux flottants.
Contenu et utilisation du panneau CAMtastic
Fonctionnalités du panneau
La liste déroulante située en haut du panneau vous permet de basculer rapidement entre les modes Éditeur CAM et Éditeur CN. La section située juste en dessous de ce champ répertorie toutes les couches disponibles dans le document CAM actuel (*.cam). Les couches sont répertoriées dans le même ordre que dans la boîte de dialogue Layers Table, accessible en sélectionnant Tables » Layers dans le menu principal.
Pour chaque couche de la liste, le nom et le numéro sont indiqués, ainsi qu’une option permettant de contrôler sa visibilité (affichée ou masquée). Une case de couleur indique également la couleur actuellement attribuée à la couche. Un clic sur cette couleur ouvre la boîte de dialogue Change Layer Color , qui propose un choix de couleurs.
Le nom de la couche courante est affiché en haut de la liste des couches. La couche courante est celle sur laquelle sont placés tous les nouveaux objets, tels que les lignes, les polylignes et les points de perçage. Elle se distingue également par une croix blanche dans la case de couleur de son entrée. Pour définir une couche comme couche courante, double-cliquez sur son entrée dans la liste.
Un clic droit sur l’entrée d’une seule couche dans la liste ouvre un menu contenant les commandes suivantes :
- Type - permet d’afficher le type attribué à la couche dans la boîte de dialogue Layers Table.
- ON - permet d’afficher ou de masquer la couche. Lorsque la couche est affichée (c’est-à-dire visible dans l’espace de conception), une coche apparaît à gauche de la commande et l’option de visibilité correspondante est activée.
- Current - permet de définir la couche sélectionnée comme couche courante. Une coche apparaît à gauche de la commande, le nom de la couche s’affiche dans le champ Current Layer (en haut de la liste des couches) et une croix blanche apparaît dans la case de couleur associée à la couche.
- Lock / Lock Selected - permet de verrouiller les couches sélectionnées afin d’empêcher tout dessin sur celles-ci. Lorsque cette option est activée, une coche apparaît à gauche de la commande.
- RESCan / RESCan Selected - permet de comparer, pour la couche sélectionnée, les dates des données (Gerber/ODB ++ Feature) présentes dans le document CAM actif et des dernières données générées à partir du même document PCB source. Si les dernières données générées sont plus récentes que les données existantes, la commande Reload est activée.
- Reload / Reload Selected - permet de régénérer les données de la couche sélectionnée dont la modification a été détectée par le processus Rescan . Toutes les modifications apportées à la couche sont intégrées au document CAM actif afin de le resynchroniser avec le document PCB source.
- All On - permet de rendre toutes les couches visibles dans l’espace de conception.
- All Off - permet de masquer toutes les couches dans l’espace de conception.
- Isolate - permet de masquer toutes les couches dans l’espace de conception, à l’exception de la couche choisie, qui reste visible.
- Scroll Up - permet de parcourir les couches de la liste vers le haut, à partir de la couche actuellement sélectionnée. Chaque couche sélectionnée devient la couche courante et toutes les autres couches sont masquées dans l’espace de conception.
- Scroll Down - permet de parcourir les couches de la liste vers le bas, à partir de la couche actuellement sélectionnée. Chaque couche sélectionnée devient la couche courante et toutes les autres couches sont masquées dans l’espace de conception.
- Compare - permet d’ouvrir la boîte de dialogue Compare Layers, dans laquelle vous pouvez comparer deux couches, modifier la tolérance des couches et régler la résolution de la couche de correspondance.
- Compress Layers - permet de réunir en une seule couche les couches pour lesquelles le même type est spécifié dans la table des couches. Cela ne s’applique qu’aux couches qui ne doivent exister qu’en un seul exemplaire par conception (par exemple : face supérieure, face inférieure, masque, sérigraphie, perçage supérieur, perçage inférieur).
- Rename - permet de renommer la couche actuellement sélectionnée. Après le lancement de la commande, la boîte de dialogue Enter Value s’affiche. Saisissez un nouveau nom pour la couche (en minuscules uniquement), puis cliquez sur OK : le nouveau nom remplace l’ancien.
-
Add Layer - permet de créer une couche et de l’ajouter à la liste. Après le lancement de la commande, la boîte de dialogue Enter Value s’affiche. Saisissez un nom pour la nouvelle couche (en minuscules uniquement), puis cliquez sur OK : la couche est ajoutée à la fin de la liste.
Si plusieurs couches sont sélectionnées dans la liste, l’entrée Type du menu affiche Sélection multiple et les commandes suivantes ne sont pas disponibles : Afficher, Couche courante, Verrouiller, Parcourir vers le haut, Parcourir vers le bas et Ajouter une couche. - Turn On / Turn On Selected - permet de rendre toutes les couches sélectionnées visibles dans l’espace de conception. Cette commande n’est disponible que si au moins une des couches sélectionnées est actuellement masquée.
- Turn Off / Turn Off Selected - permet de masquer toutes les couches sélectionnées dans l’espace de conception. Cette commande n’est disponible que si au moins une des couches sélectionnées est actuellement visible.
- Lock / Lock Selected - permet de verrouiller les couches sélectionnées afin d’empêcher tout dessin sur celles-ci. Une fois la couche verrouillée, une coche apparaît à droite de la commande pour l’indiquer. Pour déverrouiller les couches, cliquez à nouveau sur les couches verrouillées.
- Delete / Delete Selected - permet de supprimer les couches sélectionnées du document CAM.
Onglet Info
L’onglet Info
L’onglet Info affiche des informations après l’exécution de l’une des commandes de requête (Objet, Groupe, Net, Couronne annulaire minimale), accessibles depuis le menu Analysis .
Onglet DRC
L’onglet DRC
L’onglet DRC répertorie les violations présentes après l’exécution d’une vérification des règles de conception (DRC) sur le document actif. Lorsque des violations sont présentes, un dossier de premier niveau correspondant au contrôle de conception concerné est affiché, avec des sous-dossiers pour chaque objet en infraction. Cliquez sur un sous-dossier pour sélectionner, agrandir et centrer les objets concernés dans la fenêtre de l’éditeur de conception.
Si l’erreur DRC peut être corrigée à l’aide de la fonction Auto Fix, cliquez avec le bouton droit sur le sous-dossier de l’erreur et sélectionnez Fix DRC Error dans le menu contextuel.
Onglet Nets
L’onglet Nets
L’onglet Nets affiche les nets inclus dans la conception après l’extraction de la netlist à l’aide de la commande Tools » Netlist » Extract. La longueur totale de chaque net est également indiquée. Cliquez sur un net pour sélectionner, agrandir et centrer tous les objets qui lui sont associés dans la fenêtre de l’éditeur de conception.
Onglet Steps
L’onglet Steps
L’onglet Steps affiche les étapes ODB actuellement définies pour le document. Le nom de l’étape active est affiché en haut de l’onglet. Double-cliquez sur une étape pour la rendre active.
Cliquez avec le bouton droit sur une étape dans l’onglet pour accéder à un menu contextuel contenant les commandes suivantes :
- Current - permet de rendre active l’étape choisie. Une coche apparaît à gauche de la commande.
- Delete - permet de supprimer l’étape choisie du document de conception. Il est impossible de supprimer l’étape active ou une étape insérée dans une autre étape.
- Rename - permet de renommer l’étape choisie. Après le lancement de la commande, la boîte de dialogue Enter Value s’affiche. Saisissez le nouveau nom de l’étape (en minuscules uniquement), puis cliquez sur OK : le nouveau nom remplace toutes les occurrences du nom actuel.
-
Add Insert - permet d’insérer une étape dans une autre. La boîte de dialogue Add Insert to ODB Step s’affiche. Utilisez-la pour sélectionner l’étape à insérer dans la liste des étapes disponibles, puis définir l’emplacement, les dimensions de la matrice et l’orientation. Cliquez sur OK pour ajouter l’insertion en tant que sous-étape de l’étape parente désignée dans l’onglet, au format suivant : n: NomÉtape (Lignes, Colonnes), où [n] correspond au prochain numéro disponible attribué à l’étape insérée, à partir de 1.
Dans la fenêtre de l’éditeur de conception, l’étape insérée apparaît sous la forme de rectangles blancs vides, dont le nombre est déterminé par les dimensions de la matrice choisies dans la boîte de dialogue Add Insert to ODB Step. Des croix blanches sont également affichées, à raison d’une par étape de la matrice. La croix inférieure gauche est située aux coordonnées du point de base choisi, également définies dans la boîte de dialogue. Ces croix définissent l’emplacement des objets de l’étape insérée si vous choisissez de décomposer la matrice d’étapes. La commande permettant de décomposer la matrice d’étapes est accessible par un clic droit sur la sous-étape dans l’onglet. Le menu contextuel qui s’affiche contient également des commandes permettant de modifier et de supprimer la matrice d’étapes insérée. - Add Step - permet de créer une étape. La boîte de dialogue Enter Value s’affiche. Saisissez un nom pour la nouvelle étape (en minuscules uniquement), puis cliquez sur OK : l’étape est ajoutée en bas de la liste et devient l’étape active.
-
Move Objects - permet de déplacer des objets d’une étape à une autre. Cette commande n’est disponible que si l’étape source du déplacement est l’étape active.
Après le lancement de la commande, le curseur prend la forme d’un petit carré et vous êtes invité à sélectionner les objets à déplacer. Placez le curseur sur chaque objet et cliquez pour le sélectionner, ou utilisez l’un des nombreux outils de sélection disponibles.
Une fois la sélection effectuée, cliquez avec le bouton droit pour ouvrir la boîte de dialogue New Step for Objects. Sélectionnez l’étape vers laquelle vous souhaitez déplacer les objets et cliquez sur OK : les objets sont retirés de l’étape active et ajoutés à l’étape cible. - Copy Objects - permet de copier des objets d’une étape à une autre. Cette commande n’est disponible que si l’étape source de la copie est l’étape active. Elle est semblable à la commande Move Objects, à la seule différence que les objets sélectionnés ne sont pas retirés de l’étape source : ils sont simplement copiés.
- Add Venting - permet d’ajouter un motif d’équilibrage du cuivre autour des PCB regroupés dans un panneau. Cette commande n’est disponible que si les PCB ont été mis en panneau à l’aide de la commande Tools » Panelize PCB ou par le chargement de données ODB++ contenant un panneau.
- Remove Venting - permet de supprimer tout motif d’équilibrage du cuivre d’un PCB mis en panneau. Cette commande peut être utilisée, par exemple, si les contours du PCB ont été modifiés après l’ajout du motif.
- Refresh Inserts - permet d’actualiser les insertions disponibles pour refléter les modifications.
La partie inférieure du panneau contient les champs suivants :
- 1 - Selon que vous utilisez le mode CAM Editor ou NC Editor, cette commande permet de sélectionner respectivement le code D ou l’outil de perçage actif.
- 2 - Cette commande permet de sélectionner le mode d’accrochage aux objets actif.
- 3 - Cette commande permet de modifier les unités de l’espace de conception. Vous pouvez choisir entre les millimètres et les pouces.
- 4 - Ce champ du panneau affiche les coordonnées X-Y du curseur dans l’espace de conception principal. Il utilise les unités sélectionnées dans la commande 3.
Informations complémentaires sur les étapes
- Chaque étape ODB définie dans la conception contient la même liste de couches. Les étapes se distinguent par les objets qu’elles contiennent sur ces couches.
- Au moins deux étapes doivent être définies pour le document actif avant de pouvoir insérer une étape dans une autre.
- Contrairement à une matrice de répétition classique (Step & Repeat), lorsqu’une étape est insérée dans une autre, la matrice obtenue est entièrement constituée de contours. L’élément inférieur gauche n’affiche pas l’intégralité des objets de l’étape. Si vous cliquez sur l’entrée de premier niveau de l’étape insérée (et non sur son entrée sous l’étape parente définie), les objets qu’elle contient s’affichent à l’emplacement indiqué par la croix blanche inférieure gauche. L’étape parente et tous les autres éléments de la matrice de l’étape insérée ne sont pas affichés.
-
L’onglet Steps est automatiquement actualisé chaque fois que vous cliquez sur OK dans la boîte de dialogue Steps Table, accessible en sélectionnant Tables » Steps dans le menu principal.
Le code D, le mode d’accrochage aux objets et les unités de l’espace de conception peuvent être modifiés pendant le placement de tracés (lignes, polylignes, rectangles, etc.). Par exemple, vous pouvez placer une ligne dont les segments utilisent différents codes D, au cours d’une même session de placement. Vous pouvez tracer une polyligne et changer de code D pendant son placement ; lorsque vous terminez le placement, le code D actif est appliqué à l’ensemble de la polyligne.
Remarques
- Par défaut, les couleurs de tracé (Draw) et de flash (Flash) attribuées à une couche sont identiques. La modification de la couleur attribuée à une couche dans le panneau met à jour les couleurs Draw et Flash dans la boîte de dialogue Layers Table. Si vous souhaitez modifier les couleurs Draw ou Flash individuellement, vous devez modifier leurs entrées respectives dans la boîte de dialogue. Lorsque vous modifiez les couleurs dans cette boîte de dialogue, seule la couleur Draw est répercutée dans le panneau.
- Sélectionnez une entrée dans la liste des couches et appuyez sur la touche Left Arrow pour masquer toutes les couches sauf celle-ci. Sélectionnez une entrée dans la liste des couches et appuyez sur la touche Right Arrow pour afficher toutes les couches.
- Les commandes de réanalyse et de rechargement ne sont disponibles que si l’option Reset auto-load options after generation a été activée avant la génération initiale des fichiers de sortie Gerber/ODB++. Cette option se trouve dans la boîte de dialogue Output Job Options, accessible depuis le menu Tools lorsque le fichier Output Job associé (*.OutJob) est actif. L’activation de cette option empêche le chargement des données de sortie dans un nouveau document CAM lors des générations ultérieures à partir du document PCB source.
- Après l’extraction de la netlist à partir des informations Gerber contenues dans le document actif, les nets sont répertoriés dans l’onglet Nets du panneau avec des noms par défaut. Ces noms sont au format $Netn (où n est l’entier suivant, attribué selon l’ordre d’extraction). Si vous avez importé une netlist au format IPC-D-356 générée à partir du document PCB, vous pouvez renommer les nets pour leur donner les noms plus explicites qui leur avaient été attribués dans la conception PCB d’origine. Pour ce faire, choisissez Tools » Netlist » Rename Nets dans les menus principaux.
- Vous pouvez sélectionner plusieurs nets dans l’onglet Nets ; ils sont alors tous sélectionnés dans la fenêtre de l’éditeur de conception.
- Lors de l’examen des erreurs DRC, la sélection d’une entrée dans l’onglet DRC affiche uniquement la ou les couches sur lesquelles se trouvent les objets en infraction. Toutes les autres couches sont masquées. Lors de l’examen des nets, les couches concernées doivent être affichées au préalable, sans quoi vous risquez de ne rien voir.
