Publication du projet de conception
En un coup d'œil
- Comprenez comment les données sources, de fabrication et d’assemblage sont organisées et conservées, y compris les fichiers de sortie d’assemblage des variantes de conception.
- Découvrez comment la gestion des versions, les publications en une seule opération et les contrôles de validation facultatifs contribuent à préserver l’intégrité des publications.
- Découvrez comment préparer et ouvrir le Project Releaser, examiner les fichiers de sortie générés avant de finaliser la publication et partager les données publiées à l’aide des options de diffusion prises en charge.
Lorsqu’une conception est considérée comme prête à prendre son envol, elle doit être publiée, un processus dont l’importance est souvent sous-estimée.
Sans un processus de publication rigoureux et fondamentalement fiable, le suivi d’un produit qui évolue au fil du temps peut se heurter à de nombreux écueils. Imaginez devoir revenir en arrière pour publier une révision antérieure de votre produit, et découvrir que tous les fichiers sources de conception nécessaires n’ont jamais été inclus, sous forme d’instantané, dans cette publication ! Pas de problème : il suffit de récupérer les fichiers de sortie générés dans les dossiers correspondant à cette publication, à savoir les fidèles fichiers Gerber et les informations complémentaires de fabrication et d’assemblage ; après tout, c’est tout ce dont on a réellement besoin. Mais imaginez que ces fichiers de sortie « fiables » aient été écrasés ou endommagés d’une manière ou d’une autre. Si seulement le processus de publication avait été plus robuste.
Altium Designer répond à ce besoin en proposant une gestion puissante des publications de projets de conception, qui garantit une grande intégrité des données. Le processus de publication des projets de conception est automatisé, ce qui vous permet de publier vos projets sans les risques associés aux procédures manuelles. Lorsqu’un projet est publié, un instantané des sources de conception est créé et archivé avec tous les fichiers de sortie générés, lesquels représentent un produit concret fabriqué à partir de ce projet de conception et vendu par l’entreprise. Les données de publication sont stockées dans le dossier ou le fichier ZIP désigné sur votre disque dur, ou dans les révisions de l’élément associé au projet dans l’espace de travail cible :
- Source Data (PCB Project Design Item) – une copie horodatée (instantané) des fichiers de conception principaux du projet, comprenant tous les documents sources. Elle est publiée dans un élément distinct de l’espace de travail, ce qui permet de conserver votre précieuse propriété intellectuelle à l’écart des données de fabrication et d’assemblage générées dont les intervenants externes ont besoin pour fabriquer le produit.
- Fabrication Data (PCB Fabrication Data Item) – l’ensemble des données nécessaires au fabricant pour produire la carte nue (fichiers Gerber, fichiers de perçage CN, etc.).
- Assembly Data (PCB Assembly Data Item) – l’ensemble des données nécessaires au prestataire d’assemblage pour monter les composants spécifiés sur la carte nue, conformément à une nomenclature (fichiers de placement, plans d’assemblage, nomenclatures, etc.). Un élément unique est utilisé pour la conception de base (entièrement équipée) et pour chaque variante définie de la conception (variantes assemblées).

Les données générées à partir d’un projet de conception sont stockées de manière sécurisée dans l’espace de travail, au sein des révisions des éléments associés au projet. Ces données à haute intégrité sont ensuite utilisées par la chaîne d’approvisionnement pour fabriquer la révision requise du produit.
Le résultat global est une gestion des publications de projets de conception offrant le plus haut niveau d’intégrité possible. Non seulement votre projet de conception lui-même fait l’objet d’un suivi rigoureux, de sauvegardes et d’un contrôle de version, mais les publications de ses données bénéficient également du même traitement dans l’espace de travail cible, pour un résultat robuste, sûr et sécurisé.
Principaux avantages
- Intégration au contrôle de version. Si votre projet est sous contrôle de version, le système exige que tous les fichiers soient archivés dans le référentiel et à jour avant la publication. Ainsi, aucune « copie privée » d’un document de conception essentiel ne peut rester sur le disque dur d’un ingénieur, au risque d’être perdue. Cette règle simple peut éviter, par la suite, des heures de recherche coûteuses pour retrouver le bon ensemble de documents de conception ayant servi à générer un produit publié.
- « Publication unique ». Le système n’autorise qu’une seule publication dans une révision donnée d’un élément cible. En effet, lorsqu’une publication réussit, les données de publication sont enregistrées dans la révision d’élément référencée, puis cette révision est fermée. Aucune autre donnée ne peut être générée et publiée dans cette même révision.
- Processus de publication de conception automatisé et reproductible. Une publication en un clic, sans étapes manuelles ni risques associés. De la création de l’instantané des fichiers de conception à la génération des sorties, en passant par la validation, aucune intervention n’est nécessaire. Si une partie du processus échoue, la publication échoue. C’est aussi simple que cela. Vous pouvez en outre examiner toutes les données générées avant leur enregistrement définitif dans la révision d’élément de l’espace de travail cible.
-
Possibilité de valider la conception dans le cadre même du processus de publication. Le processus de publication s’appuie sur un instantané « verrouillé » des sources de conception (dépendances comprises), et une validation préalable a très probablement déjà été effectuée avant son lancement. Toutefois, pour plus de tranquillité d’esprit et pour garantir l’intégrité des données de conception, vous pouvez ajouter des contrôles de validation au déroulement du processus de publication, au moyen de configurations de tâches de sortie adaptées. Il peut s’agir des vérifications ERC standard des schémas sources et des vérifications DRC du circuit imprimé, mais aussi de la vérification de la synchronisation entre le projet source et le circuit imprimé, ainsi que de la comparaison des empreintes de la carte avec celles de leur bibliothèque source, afin de s’assurer qu’elles sont à jour et concordantes. La publication échoue si l’un des contrôles de validation n’est pas concluant.
- Tous les fichiers de données générés par le processus de publication de conception peuvent, si vous le souhaitez, être préfixés par l’identifiant de l’élément et celui de sa révision, afin d’éviter toute ambiguïté quant à la révision et à l’élément que ces données doivent servir à fabriquer.
- Diffusion. Possibilité de diffuser les données de publication directement depuis un espace de travail vers un espace de stockage partagé, tel qu’Amazon S3, des serveurs FTP, Box.com ou un simple dossier réseau. Cela facilite le partage sécurisé des données de l’espace de travail, sans donner aux intervenants externes accès à cet espace.
L’outil de publication de projet
Altium Designer offre une gestion puissante et fiable des publications de projets de conception, grâce à son Project Releaser. Son interface utilisateur intuitive vous permet de générer simultanément toutes les données de production de votre projet : données de fabrication, données d'assemblage, sources de conception, etc. Le Project Releaser permet également de générer en même temps les données d'assemblage de plusieurs variantes détectées dans votre conception de PCB. Vous n'avez même pas à vous inquiéter si vous n'avez pas créé de fichiers Output Job : il s'en chargera pour vous si vous le lui demandez !
Avec le Project Releaser, vous pourrez générer vos données de production en toute simplicité, tout en garantissant leur intégrité maximale. Vous pourrez également examiner les données générées avant de finaliser la publication (par exemple, en visualisant les données Gerber/ODB++ dans l'éditeur FAO), afin de vous assurer qu'elles correspondent exactement aux données nécessaires pour faire fabriquer votre conception dans les délais, et ce, dès la première tentative.
Les conditions préalables à la publication d'un projet de conception dans un Workspace sont les suivantes :
- Altium Designer est connecté au Workspace qui héberge le référentiel cible de la publication.
- Le projet comprend des Output Jobs appropriés, à savoir des générateurs de sorties de données de conception (pour des sorties telles que des impressions, des fichiers ou des PDF). Si aucun OutJob n'est disponible, le Project Releaser proposera de créer les OutJobs appropriés pour exécuter le processus.
- Le projet utilisé par le processus de publication dispose de tous les éléments requis : les données sources sont valides et à jour, l'utilisateur dispose de droits suffisants pour publier ce projet dans le Workspace, etc.
Accès au Project Releaser
Le processus de publication proprement dit est exécuté à l'aide du Project Releaser d'Altium Designer, dont l'interface utilisateur est accessible dans une vue dédiée : la vue Release. Vous pouvez y accéder de l'une des manières suivantes :
- En sélectionnant la commande Project » Project Releaser dans les menus principaux (avec un document source du projet souhaité ouvert en tant que document actif).
- En cliquant avec le bouton droit sur l'entrée du projet souhaité dans le panneau Projects, puis en sélectionnant la commande Project Releaser dans le menu contextuel.

La vue Release : l'interface utilisateur du Project Releaser.
Publication vers un PLM
Related page: Intégration PLM (Workspace Altium 365, Workspace Enterprise Server)
Si vous disposez d'un processus activé pour la publication vers une instance PLM dans le cadre du Project Releaser, celui-ci apparaîtra dans le sous-menu Project Releaser du projet. Le lancement de ce processus ajoutera à la vue une étape supplémentaire dédiée à cette opération.
L'exemple de définition de processus Publish to PLM (User selects) est disponible avec votre Workspace, dans le thème de processus Project Activities, pour effectuer cette publication standard (c'est-à-dire une publication qui ne s'inscrit pas dans le cadre du Project Releaser, comme décrit précédemment). Ce processus permet de publier les sorties de projet déjà publiées vers l'instance PLM intégrée, tout en laissant l'utilisateur sélectionner précisément les sorties à transmettre. Le diagramme du flux de travail est présenté ci-dessous.

Le diagramme du flux de travail de l'exemple de définition de processus Publish to PLM (User selects) par défaut
Les processus de publication standard vers un PLM sont accessibles depuis Altium Designer, dans le sous-menu Project » Project Activities du projet actif.

Accès à un processus activé de publication standard des données publiées d'un projet de Workspace vers une instance PLM, depuis Altium Designer.
Mode et cible de publication
Le Project Releaser prend en charge tous les types de projets de conception — locaux/sans gestion de versions, gérés par un système de gestion de versions (VCS) externe ou par le système de gestion de versions natif d'un Workspace connecté — en proposant deux modes de fonctionnement :
- Managed (Online) Mode – publication de toutes les données générées dans des révisions d'éléments d'un Workspace cible. Vous n'avez même pas à penser à incrémenter les révisions des éléments : tout est pris en charge pour vous. Et si vous avez défini un processus de publication vers une instance PLM via le Project Releaser, le lancement de ce processus ajoutera à la vue une étape supplémentaire dédiée à cette opération.
- Unmanaged (Offline) Mode – publication de toutes les données générées dans une arborescence de dossiers, qui peut éventuellement être regroupée dans un fichier ZIP unique.
Le Project Releaser tente de détecter automatiquement le mode de publication à utiliser ainsi que la cible de la publication. Lorsqu'un choix est possible, généralement lorsque le projet a été publié dans un Workspace et que vous êtes actuellement connecté à un autre, le système vous présente les options disponibles.
Détection des fichiers Output Job
La méthode fondamentale de génération des sorties de conception dans Altium Designer repose sur les différents générateurs de sorties de conception disponibles. Ceux-ci produisent les fichiers de données et les tracés nécessaires à la réalisation physique de la conception : impressions des schémas et des PCB, fichiers de fabrication Gerber et de perçage CN, nomenclature (BOM), fichiers d'assemblage de placement des composants, plans de fabrication, etc., requis pour fabriquer et assembler la conception.
Les générateurs de sorties sélectionnés et les fichiers de sortie spécifiques qu'ils créeront pour une conception sont définis collectivement à l'aide du Output Job Editor, qui enregistre les configurations de correspondance entre les générateurs et les sorties dans un fichier Output Job (*.OutJob), créé via la commande File » New » Output Job File.
En tant que mécanisme central de génération groupée des fichiers de production d'une conception, les Output Jobs d'Altium Designer offrent les fonctionnalités supplémentaires suivantes :
- Un nombre quelconque d'OutJobs peut être ajouté à une conception donnée, afin de disposer de configurations adaptées à des tâches spécifiques, telles que la génération de sorties pour la fabrication, l'assemblage, l'archivage, l'approvisionnement et la documentation.
-
Les fichiers OutJob sont en fait portables et peuvent être appliqués à tout projet de conception nécessitant un ensemble standardisé de sorties de conception. Par exemple, choisissez
[Project]comme option de source de document, plutôt qu'un fichier de conception spécifique, pour créer un Output Job générique (et donc portable). - Les OutJobs peuvent inclure des fichiers destinés aux contrôles de validation de la conception, tels que les contrôles électriques (ERC), les contrôles des règles de conception (DRC) et les comparaisons entre les empreintes et leurs sources. À ce titre, les tâches de sortie de validation constituent un cas « actif » particulier : la conception est vérifiée et la sortie produite (par exemple, un document PDF) présente les résultats du processus de validation.
- Les OutJobs prennent en charge les variantes d’une conception de circuit imprimé assemblé, pour lesquelles différents jeux de fichiers de sortie sont nécessaires afin de fabriquer d’autres versions de la conception, par exemple des versions standard ou améliorées du produit utilisant des composants supplémentaires ou de types différents. Consultez Variantes de conception pour en savoir plus sur les variantes de conception de circuits imprimés.
Si aucun fichier Output Job n’est actuellement associé à votre projet, le Project Releaser le détectera et vous proposera d’ajouter des fichiers par défaut. Si vous acceptez, les éléments suivants seront créés :
-
Pour un projet de conception de circuit imprimé :
-
Assembly.OutJob– avec les sorties suivantes définies :-
Documentation Outputs :
PCB 3D Print,Schematic Prints -
Assembly Outputs :
Generates pick and place files,Assembly Drawings -
Report Outputs :
Bill of Materials -
Export Outputs :
Export STEP
-
Documentation Outputs :
-
Fabrication.OutJob– avec les sorties suivantes définies :-
Documentation Outputs :
PCB Prints -
Fabrication Outputs :
Gerber Files,NC Drill FilesetIPC-2581 -
Validation Outputs :
Design Rules Check,Footprint Comparison Report -
Export Outputs :
Save As/Export PCB
-
Documentation Outputs :
Ces fichiers Output Job par défaut proviennent du dossier d’installation par défaut suivant :
\Users\Public\Documents\Altium\AD<Solution/Version>\OutputJobs. -
-
Pour un projet de conception de faisceau :
-
Assembly.OutJob– avec les sorties suivantes définies :- Documentation Outputs : Draftsman
-
Report Outputs :
Bill of Materials -
Validation Outputs :
Electrical Rules Check
Ce fichier Output Job par défaut provient du dossier d’installation par défaut suivant :
\Users\Public\Documents\Altium\AD<Solution/Version>\OutputJobs\Harness. -
Détection des variantes
Pour les projets de circuits imprimés, l’un des grands atouts du Project Releaser est sa capacité à détecter les variantes définies pour votre conception et à créer pour chacune des jeux de données d’assemblage prêts à être publiés. Chaque jeu de données d’assemblage apparaît avec un nom d’élément cible par défaut sous la forme suivante :
PCBA-[ProjectName]-[VariantName]
Le suffixe [VariantName] garantit que la bonne variante est utilisée lors de la génération des données à partir des fichiers OutJob affectés.

Jeux de données d’assemblage supplémentaires créés après la détection des variantes définies pour la conception.
Processus de publication
Le processus de publication se déroule par étapes. Les entrées situées à gauche de la vue Release vous indiquent en un coup d’œil l’étape à laquelle vous vous trouvez.
Pour en savoir plus sur le processus de publication en mode en ligne, consultez la page Publication dans un espace de travail. Pour en savoir plus sur les particularités du mode de publication hors ligne, consultez la page Publication locale.
Diffusion des données publiées
Related page: Utilisation des destinations de diffusion
Pour les données publiées générées à partir d’un projet de conception de circuit imprimé (données de fabrication de circuits imprimés, données d’assemblage de circuits imprimés et éléments de conception de projets de circuits imprimés uniquement), vous pouvez diffuser directement ces données depuis votre espace de travail ou un fichier Output Job vers un espace de stockage, tel que Box.com, Amazon S3, un serveur FTP ou un simple dossier sur un réseau partagé. En matière de distribution et de collaboration, cela offre un avantage inégalé dans un monde où les membres de l’ensemble de l’« équipe produit » — l’équipe de conception, l’équipe de fabrication et toutes les autres personnes impliquées dans le passage d’une idée à un produit concret — sont souvent dispersés aux quatre coins du globe.
La diffusion consiste à définir un Publishing Destination, puis à transférer vers cette destination les données publiées correspondant à la révision d’élément requise. De l’usine de fabrication en Chine aux équipes de conception à Kiev, Stanstead Abbotts et San Diego, en passant par le directeur de projet en vol quelque part au-dessus du Pacifique, toutes les personnes qui doivent être informées de la nouvelle publication peuvent recevoir une invitation contenant un lien vers le dossier diffusé. Elles disposent ainsi d’un accès partagé et contrôlé pour consulter les données, en discuter et les utiliser afin de fabriquer l’élément.

Diffusez vos données publiées vers un espace de stockage et partagez les informations entre les membres de l’équipe à travers le monde.
Partage mondial des données du dossier de fabrication
L’un des principaux atouts des projets de conception stockés dans un espace de travail Altium 365 est la possibilité de créer un Build Package de publication et de le partager avec d’autres personnes. Lorsqu’il est partagé directement avec votre fabricant, il peut être considéré comme un Manufacturing Package, puisqu’il s’agit du dossier que le fabricant peut consulter, télécharger et utiliser pour fabriquer et assembler le circuit imprimé.
Pour permettre le partage d’un tel dossier avec d’autres personnes et avec votre fabricant (qui est généralement extérieur à votre organisation), la plateforme Altium 365 propose un Manufacturing Package Viewer dédié, qui fait partie de sa prise en charge du Global Sharing. Celui-ci permet de consulter un dossier de fabrication depuis n’importe quel navigateur web, partout dans le monde, mais en dehors de votre espace de travail, afin que vos conceptions elles-mêmes et vos autres éléments de propriété intellectuelle de valeur restent inaccessibles.
Chaque utilisateur avec lequel le dossier est partagé reçoit une invitation par e-mail contenant un lien pour consulter le dossier de fabrication via le Manufacturing Package Viewer. Les dossiers de fabrication partagés sont présentés sur la page Shared with Me de l’interface web de la plateforme Altium 365.
Le Manufacturing Package Viewer lui-même permet aux principales parties prenantes, et avant tout au personnel de fabrication, de consulter une vue d’ensemble de la conception avec les données essentielles du circuit imprimé, ainsi que de parcourir la structure des données sources, de fabrication et d’assemblage (et d’en télécharger chaque fichier individuellement si nécessaire). La visionneuse propose également des sous-pages consacrées aux données de fabrication, d’assemblage et de nomenclature. La page de fabrication présente une visionneuse Gerber et permet à tous les utilisateurs avec lesquels le dossier a été partagé d’ajouter des commentaires.
Enfin, le personnel de fabrication peut télécharger, depuis n’importe quelle page de la visionneuse, un dossier de production correspondant à la publication consultée, afin de réaliser physiquement cette révision du circuit imprimé.
Visionneuse web
Related page: Web Viewer (Espace de travail Altium 365, Espace de travail Enterprise Server)
L’interface Web Viewer de l’espace de travail offre un accès universel aux documents des projets PCB depuis un navigateur Web standard. Bien plus qu’une simple visionneuse Web, la technologie de navigation avancée de Web Viewer's permet aux utilisateurs de parcourir la structure du projet, d’interagir avec les documents de conception, d’extraire des informations sur les éléments de la conception et de mettre en évidence des zones ou des objets pour y ajouter des commentaires.
Lors de la consultation des documents, le format Web ne compromet en rien la qualité visuelle des schémas et des PCB. Il offre également toutes les fonctions de déplacement panoramique et de zoom, ainsi que la possibilité de rechercher, de sélectionner et d’inspecter des composants et des nets dans l’ensemble de la conception, et d’effectuer une sélection croisée entre les documents.

L’interface Web Viewer de l’espace de travail offre une expérience immersive et interactive pour examiner, par exemple, les documents sources de schéma et de PCB de votre projet de conception. L’illustration présente ici un schéma dans l’interface Web Viewer d’Altium 365 : survolez l’image pour afficher le PCB en 3D.
En tant que plateforme de visualisation indépendante accessible depuis un navigateur, l’interface Web Viewer offre un accès interactif en lecture seule aux documents de conception, sans qu’il soit nécessaire d’ouvrir le projet dans l’environnement d’édition. Les autres personnes travaillant sur la conception, comme l’ingénieur qui en est responsable, ne sont pas affectées par les actions effectuées dans l’espace Web Viewer, à l’exception des éventuelles notifications de commentaires associées.
