Maintenir la synchronisation entre le schéma et le PCB
Altium Essentials: Transfer to PCB
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
En un coup d'œil
- Découvrez la différence entre les processus de comparaison bidirectionnelle et de mise à jour directe, ainsi que les situations dans lesquelles chaque approche est utilisée.
- Comprenez ce qu’Altium Designer peut synchroniser entre le schéma et le PCB, notamment les composants, la connectivité, les classes et certaines règles de conception.
- Découvrez comment les options du projet, telles que les paramètres du comparateur et de génération des ECO, influencent le processus de synchronisation et les modifications pouvant être appliquées.
La tâche la plus courante lors du passage du schéma au PCB consiste à maintenir leur cohérence ou leur synchronisation. Que vous transfériez pour la première fois un schéma saisi vers un nouveau PCB ou que vous apportiez des modifications à une conception existante, côté schéma ou côté PCB, vous avez besoin d’un moyen de garder les deux synchronisés. Altium Designer intègre de puissantes fonctionnalités de synchronisation qui simplifient cette tâche et permettent au concepteur de rester concentré sur les aspects créatifs du processus de conception.
Le processus de synchronisation détecte et résout les différences entre le schéma et le PCB.
La synchronisation de la conception s’effectue directement entre les éditeurs de schémas et de PCB, sans document intermédiaire de type netlist. Le logiciel utilise un moteur de comparaison pour comparer tous les aspects de la conception et présente les résultats sous forme de liste de différences. Le concepteur décide quel côté doit être modifié pour résoudre ces différences, puis un ensemble d’ordres de modification technique (ECO) est créé. Une fois ces ordres appliqués, les deux côtés de la conception sont de nouveau synchronisés.
Quels éléments peuvent être synchronisés ?
Le processus de synchronisation garantit que les données des composants et des connexions du schéma correspondent à celles du PCB. Outre ces données, il garantit également la synchronisation d’autres contraintes de conception, telles que les classes de nets, les classes de composants et les règles de conception.
Configuration des options du comparateur
Dialog page: Options du projet PCB, onglet Comparateur
Les données du schéma et du PCB à comparer what sont définies dans l’onglet Comparateur de la boîte de dialogue Options for PCB Project. Sélectionnez Project » Project Options pour ouvrir la boîte de dialogue.

Le moteur de comparaison respecte les paramètres définis dans l’onglet Comparator de la boîte de dialogue Options for Project.
La zone principale de la boîte de dialogue contient une longue liste de types de comparaison, tels que Different Designators et Changed Net Name, regroupés en 5 catégories. La colonne Mode, à droite, contient une liste déroulante pour chacun d’eux, dans laquelle vous sélectionnez le mode de comparaison, par exemple Find Differences ou Ignore Differences. Les comparaisons de texte disposent d’une troisième option permettant d’ignorer la casse.
Pour un nouveau projet, le réglage par défaut consiste à rechercher les différences pour chaque type de comparaison. Définissez les options selon les besoins de votre projet.
Au bas de la boîte de dialogue se trouvent les options de configuration de Object Matching Criteria. La mise en correspondance est un processus sophistiqué en plusieurs passes, qui ne repose pas sur une simple correspondance exacte de chaînes de caractères. Pour en savoir plus, consultez la section Mise en correspondance des nets et des classes.
Notez l’option Ignore Rules Defined in the PCB Only au bas de la boîte de dialogue : activez-la pour exclure du processus de comparaison les règles que vous avez définies dans le PCB.
Synchronisation des classes de nets et de composants
Dialog page: Options du projet PCB, onglet Génération des classes
Outre les données des composants et des connexions, vous pouvez également générer et synchroniser des classes et des règles de conception lorsque vous effectuez une Design » Update PCB.
Synchronisation des règles de conception
Les règles de conception peuvent être définies dans le schéma à l’aide d’un objet Ensemble de paramètres. Lorsqu’un objet Ensemble de paramètres est sélectionné, le panneau Properties ou la boîte de dialogue modale contient une zone Rules. Cliquez sur la liste déroulante Add pour ajouter une règle de conception. La règle s’appliquera au net, au bus, au faisceau ou aux objets situés sous la couverture auxquels l’objet Ensemble de paramètres est rattaché.
Dans l’image ci-dessous, une règle de conception imposant une contrainte de largeur est appliquée à la classe de nets USB_data (la classe de nets est également définie dans cet ensemble de paramètres, dans la zone Classes de la liste déroulante Parameters ).

L’ensemble de paramètres sert à définir une classe de nets et une règle de conception pour les nets situés sous l’objet couverture du schéma. Notez que les unités de mesure requises sont configurées au bas de la boîte de dialogue Modifier la règle PCB.
Ajout d’une règle de conception dans le schéma
- Rattachez un ensemble de paramètres au net, au bus, au faisceau ou à la couverture (ajoutez une définition de classe de nets dans l’ensemble de paramètres si nécessaire).
- Add une définition de règle dans l’ensemble de paramètres. La boîte de dialogue Choose Design Rule Type s’ouvre alors, comme illustré ci-dessus.
- Sélectionnez le Rule Type requis.
- Cliquez sur le bouton OK pour ouvrir la boîte de dialogue Edit PCB Rule.
- Configurez les exigences de la règle PCB selon vos besoins. Notez que les unités de mesure requises pour cette règle PCB sont sélectionnées au bas de la boîte de dialogue.
Dans l’image ci-dessus comme dans celle ci-dessous, la règle de conception est définie dans un objet Ensemble de paramètres rattaché à une couverture. Si une définition de classe est incluse dans cet objet, une classe de nets PCB sera également créée. La présence de cette définition de classe limitera la portée de la règle PCB à InNetClass('<PCB_NetClassName >').
Dans l’image ci-dessous, vous remarquerez que l’objet Ensemble de paramètres est affiché sous la forme d’une directive de paire différentielle. Il s’agit d’un type particulier d’objet Ensemble de paramètres, placé à l’aide de la commande Place » Directives » Differential Pair.

La directive de paire différentielle sert à définir une classe de nets et une règle de conception, qui est ensuite appliquée aux paires différentielles ciblées.
Configuration des options de génération des ECO
La boîte de dialogue Options for Project comprend également un onglet Génération des ECO. Cet onglet définit les modifications de conception pour lesquelles des ECO peuvent être créés. Généralement, toutes ces options sont activées, et les options de l’onglet Comparateur de la boîte de dialogue servent à configurer les modifications de conception à synchroniser entre le schéma et le PCB.

L’onglet Génération des ECO définit les types de modifications pour lesquels des ECO peuvent être créés.
Recherche des différences
La fonction de synchronisation de la conception peut détecter et résoudre les différences dans les deux sens : du schéma vers le PCB ou du PCB vers le schéma.
Le logiciel peut résoudre ces différences en appliquant simultanément des modifications des deux côtés. Par exemple, imaginez que le concepteur électronique ait modifié la valeur d’un condensateur, tandis que le concepteur du PCB ait modifié l’empreinte de ce même condensateur. Ces deux différences peuvent être résolues au cours d’un seul processus de mise à jour, en appliquant la modification du commentaire du schéma vers le PCB et la modification de l’empreinte du PCB vers le schéma.
Lorsque le moteur de comparaison compare le projet schématique au PCB, une liste complète des différences est créée ; à ce stade, aucune hypothèse n’est faite quant au côté à modifier pour les synchroniser à nouveau.
La liste des différences est affichée dans la boîte de dialogue Differences between.
Options et commandes de la boîte de dialogue Differences between
La boîte de dialogue est essentiellement divisée en trois zones principales : Differences, Update et Change Order.
Différences
Cette zone de la boîte de dialogue répertorie toutes les différences détectées par le comparateur entre les documents choisis. Chaque différence est affichée dans la colonne correspondant au document dans lequel elle se trouve. Les différences sont regroupées par type de comparaison, selon les types répertoriés et activés dans l’onglet Comparateur de la boîte de dialogue Project Options . L’entrée au niveau de ce groupe indique le nombre de différences de ce type.
Double-cliquez sur une entrée pour accéder à l’objet correspondant dans le document source concerné à l’aide de la navigation croisée.
Mise à jour
Utilisez cette zone de la boîte de dialogue pour indiquer quel document doit être mis à jour afin de résoudre la différence. Par défaut, toutes les entrées Decision se voient initialement attribuer la décision No Change .
La décision de mise à jour pour chaque différence peut être définie individuellement en cliquant sur l’entrée correspondante dans la colonne Decision , puis en sélectionnant l’action de mise à jour souhaitée dans la boîte de dialogue Décision ECO qui s’affiche ensuite. Il suffit de choisir le sens de mise à jour (le document comparé à mettre à jour) ou No Updates.
Ordre de modification
Cette zone de la boîte de dialogue répertorie, pour chaque différence sur laquelle vous décidez d’agir, l’action à effectuer, l’objet concerné par cette action et le document dans lequel l’action sera exécutée. Ces informations servent à élaborer l’ECO qui sera ensuite utilisé pour effectuer les mises à jour. Les actions courantes répertoriées dans cette zone sont les suivantes :
- Remove - lorsque la mise à jour cible le document contenant l’objet à l’origine de la différence ; l’objet sera supprimé.
- Add - lorsque la mise à jour cible le document qui ne contient pas l’objet à l’origine de la différence ; l’objet sera ajouté.
- Update - lorsque les deux documents contiennent le même objet, mais que celui-ci présente une différence ; l’objet modifié dépend du sens choisi.
Menu contextuel
- Create Change Order - permet de créer un ordre de modification technique (ECO).
- Generate Report - permet de générer un rapport sur les différences détectées par le comparateur. Les décisions de mise à jour que vous avez prises et les actions seront incluses dans l’ECO généré. Le rapport sera chargé dans la boîte de dialogue Report Preview. Utilisez cette boîte de dialogue pour consulter le rapport avant de l’exporter vers l’un des différents formats pris en charge ou de l’imprimer directement.
- << Update All in - permet de définir le sens de mise à jour de toutes les différences vers le document de gauche (le cas échéant).
- Update All in >> - permet de définir le sens de mise à jour de toutes les différences vers le document de droite (le cas échéant).
- Reverse Direction For All - permet d’inverser rapidement le sens de mise à jour de toutes les différences (le cas échéant). S’il n’est pas possible de modifier le sens pour une différence, l’entrée sera définie sur No Change.
- Set No Action For All - permet de définir rapidement la décision de mise à jour de toutes les différences sur No Change.
- << Update Same Kind in - permet de définir le sens de mise à jour de toutes les différences du même type de comparaison que la différence actuellement sélectionnée vers le document de gauche (le cas échéant).
- Update Same Kind in >> - permet de définir le sens de mise à jour vers le document de droite pour toutes les différences du même type de comparaison que la différence actuellement active (le cas échéant).
- Reverse Direction For Same Kind - permet d’inverser rapidement le sens de mise à jour pour toutes les différences du même type de comparaison que la différence actuellement active, le cas échéant. Si le sens ne peut pas être modifié pour une différence, l’entrée sera définie sur No Change.
- Set No Action For Same Kind - permet de définir rapidement le sens de mise à jour sur No Change pour toutes les différences du même type de comparaison que la différence actuellement active.
- << Update Selected in - permet de définir le sens de mise à jour vers le document de gauche pour toutes les différences sélectionnées (le cas échéant).
- Update Selected in >> - permet de définir le sens de mise à jour vers le document de droite pour toutes les différences sélectionnées (le cas échéant).
- Reverse Direction For Selected - permet d’inverser rapidement le sens de mise à jour pour toutes les différences sélectionnées (le cas échéant). Si le sens ne peut pas être modifié pour une différence, l’entrée sera définie sur No Change.
- Set No Action For Selected - permet de définir rapidement la décision de mise à jour sur No Change pour toutes les différences sélectionnées.
- Invert Selection - permet de sélectionner toutes les différences qui ne sont pas actuellement sélectionnées dans la liste ou de désélectionner celles qui le sont.
Commandes supplémentaires
Les boutons suivants sont disponibles au bas de la boîte de dialogue :
- Create Engineering Change Order - cliquez sur ce bouton pour générer un ECO. La boîte de dialogue Engineering Change Order s’affiche et vous permet de valider et d’exécuter les mises à jour afin de synchroniser les documents.
- Report Differences - cliquez sur ce bouton pour générer un rapport sur les différences détectées par le comparateur. Les décisions de mise à jour que vous avez prises et les actions seront incluses dans l’ECO généré. Le rapport sera chargé dans la boîte de dialogue Report Preview. Utilisez cette boîte de dialogue pour consulter le rapport avant de l’exporter dans l’un des différents formats pris en charge ou de l’imprimer directement.
- Explore Differences - cliquez sur ce bouton pour examiner plus en détail les différences détectées par le comparateur avant de générer un ECO. La boîte de dialogue Differences between se ferme et vous revenez à l’espace de travail principal, avec le panneau Differences ouvert. Ce panneau contient toutes les différences répertoriées par le comparateur, dans les mêmes catégories. Utilisez le panneau pour accéder, par navigation croisée, à un objet à l’origine d’une différence dans son document parent.
Pour ouvrir la boîte de dialogue Difference between et afficher une liste des différences :
-
Pour ouvrir la boîte de dialogue Choose Documents to Compare, comme illustré ci-dessous, exécutez la commande Project » Show Differences ou cliquez avec le bouton droit sur l’entrée du projet souhaité (ou de l’un de ses documents source) dans le panneau Projects et choisissez la commande Show Differences dans le menu contextuel. La boîte de dialogue Choose Documents to Compare permet de sélectionner les deux documents ou ensembles de documents à comparer. Il s’agit généralement de comparer le projet schématique au PCB. Vous pouvez également utiliser cette boîte de dialogue pour comparer n’importe quel document à un autre en cochant l’option Advanced Mode. Par exemple, vous pouvez comparer une netlist à un PCB, ou un PCB à un autre PCB.
En général, la configuration par défaut de la boîte de dialogue, en mode de base comme en mode avancé, convient à la plupart des besoins de comparaison de conceptions, lorsque les documents source et la conception PCB cible doivent être comparés en vue de leur synchronisation. La boîte de dialogue permet toutefois de comparer d’autres documents, ce qui peut être utile si vous devez charger différentes versions d’un projet et comparer les différences entre les documents source correspondants.

Sélectionnez le PCB auquel comparer le projet schématique. - Sélectionnez le PCB dans la partie principale de la boîte de dialogue, puis cliquez sur OK pour ouvrir la boîte de dialogue Difference between, comme illustré ci-dessous. Si le document PCB est déjà synchronisé avec les documents source, une boîte de dialogue s’affiche pour indiquer qu’aucune différence n’a été détectée.
La boîte de dialogue Differences between s’ouvre. Le synchroniseur est bidirectionnel. Cela signifie que vous pouvez spécifier des mises à jour pour les deux documents dans le même ECO. Pour synchroniser les documents comparés, l’objectif est de déterminer, pour chaque différence, s’il faut intervenir et dans quel sens effectuer la modification, en précisant quel document doit être mis à jour pour corriger la différence. L’étape suivante consiste donc à attribuer un sens de mise à jour à chaque différence :
- Pour une différence individuelle, cliquez dans la colonne Update pour afficher un sélecteur de sens, comme illustré ci-dessous.
- Pour plusieurs différences du même type, cliquez avec le bouton droit sur un en-tête, par exemple Empreintes différentes, et sélectionnez la commande Update Same Kind souhaitée.
- Pour toutes les différences, cliquez avec le bouton droit n’importe où dans la boîte de dialogue et sélectionnez la commande Update All souhaitée.

Pour chaque différence, le sens de mise à jour doit être défini afin qu’un ECO puisse être créé pour la résoudre.
Cliquez sur le bouton Explore Differences pour accéder au panneau Differences et explorer les différences comme décrit dans la section Exploration des modifications de conception avec le panneau Differences ci-dessous.
Cliquez sur Report Differences pour configurer et imprimer ou exporter un rapport sur les différences détectées par le comparateur, les décisions de mise à jour spécifiées et les actions qui seront incluses dans l’ECO généré.
Une fois le sens de mise à jour attribué, cliquez sur le bouton Create Engineering Change Order pour ouvrir la boîte de dialogue Engineering Change Order, décrite dans la section Résolution des différences : application des ECO ci-dessous.
Exploration des modifications de conception avec le panneau Differences

Le panneau Differences affiche une vue hiérarchique des différences entre les documents.
Résumé
Le panneau Differences permet d’afficher les différences logiques ou physiques détectées par le comparateur de différences intégré au logiciel lors de la comparaison de documents de conception (par exemple, lors de la comparaison de la hiérarchie des documents sources (schémas) d’un projet avec le document de conception du PCB). Ce panneau vous permet d’explorer les différences de manière interactive avant de décider de créer un ordre de modification technique (ECO) qui servira à synchroniser les documents du projet.
Accès au panneau
Pour ouvrir le panneau Differences :
- Choisissez View » Panels » Differences dans les menus principaux.
- Cliquez sur le bouton Panels en bas à droite de l’espace de travail de conception, puis cliquez sur Differences.
Affichage des différences
L’utilisation du panneau Differences dépend de l’objectif :
- Analyser l’intégrité de l’ensemble du projet en matière de contenu et de structure en détectant les différences logiques au sein de sa hiérarchie.
- Comparer deux versions d’un même document de schéma ou de PCB en détectant leurs différences graphiques (physiques).
Affichage des différences logiques
La comparaison des documents du projet visant à détecter les différences logiques s’effectue dans la boîte de dialogue Choose Documents To Compare, accessible en faisant un clic droit sur un projet (ou un document du projet) dans le panneau Projets, puis en sélectionnant Show Differences dans le menu contextuel associé.

Faites un clic droit sur le nom d’un projet, puis sélectionnez Show Differences pour ouvrir la boîte de dialogue Choose Documents To Compare.
En général, le document PCB est comparé à la hiérarchie des documents sources du projet parent afin de détecter les différences logiques entre le contenu du schéma et celui du PCB.
Après avoir cliqué sur OK, si des différences existent entre les documents sélectionnés, la boîte de dialogue Différences entre s’ouvre. Les informations ne s’affichent dans le panneau Differences qu’après avoir cliqué sur le bouton Explore Differences dans la boîte de dialogue Differences between.
Le panneau Differences affiche uniquement les différences répertoriées dans la boîte de dialogue Differences between. Celles-ci sont déterminées par les sélections effectuées dans l’onglet Comparateur de la boîte de dialogue Project Options (Project » Options). Cet onglet répertorie tous les types de comparaison, notamment les différences liées aux composants, aux nets et aux paramètres. Le réglage de Mode sur Find Differences ou Ignore Differences pour chaque catégorie de comparaison détermine si le comparateur de différences transmet ses résultats à la boîte de dialogue Differences between .

Configurez la détection et le signalement des différences dans la boîte de dialogue Project Options .
Le panneau Differences affiche les différences détectées entre les documents sources sous forme d’arborescence, dont le dossier de premier niveau indique le nombre total de différences détectées. Des sous-dossiers sont ensuite créés pour chaque type de comparaison figurant dans la boîte de dialogue Différences entre. Chaque sous-dossier répertorie les différences spécifiques détectées, lesquelles sont à leur tour détaillées en objets des documents à l’origine de ces différences.
Si le document associé est ouvert (ou ouvert mais masqué), cliquer sur l’entrée d’un objet dans le panneau permet de localiser cet objet dans le document par navigation croisée.
L’affichage de l’objet utilise un effet de zoom et d’atténuation : l’objet est mis en évidence en atténuant tous les autres objets. Le contraste de l’atténuation peut être modifié à l’aide du curseur Dimming situé dans la section Highlight Methods de la page Système - Navigation de la boîte de dialogue Preferences .
Affichage des différences physiques
La comparaison graphique (physique) de deux versions d’un même document de schéma ou de PCB s’effectue globalement de la même manière que la comparaison logique décrite ci-dessus, mais utilise également Advanced Mode dans la boîte de dialogue Choose Documents To Compare.
Effectuez une comparaison physique de documents à l’aide de la commande Show Differences (menu contextuel du panneau Projects) pour ouvrir la boîte de dialogue Choose Documents To Compare, puis cochez la case Advanced Mode. Tous les fichiers du projet étant désormais affichés dans la boîte de dialogue, sélectionnez les deux versions d’un document à comparer.

Sélection des documents à comparer physiquement dans la boîte de dialogue Choose Documents To Compare de Advanced Mode.
Cliquer sur OK lance la comparaison graphique et ouvre la boîte de dialogue Différences entre, comme décrit précédemment. Cliquez sur Explore Differences pour ouvrir la liste interactive des différences dans le panneau Differences.
Le panneau affiche les différences détectées entre les documents sous forme d’arborescence. Le dossier de premier niveau indique le nombre total de différences détectées. Des entrées sont créées pour chaque type de différence ; chacune contient les références spécifiques et l’objet concerné (port, composant, etc.).
La sélection de l’entrée d’un objet correspondant à une différence détectée met cet objet en évidence et effectue un zoom sur celui-ci dans l’espace de conception de l’éditeur.
Remarques
- Si un objet du panneau se trouve dans un document actuellement masqué, ce document s’ouvre automatiquement et devient le document actif dans la fenêtre de l’éditeur de conception lorsque vous cliquez sur l’entrée associée.
- Le filtrage appliqué lors de la navigation croisée depuis le panneau Differences est temporaire. Vous pouvez donc toujours sélectionner ou modifier les objets de conception qui ne correspondent pas au filtre.
- Les informations du panneau Differences sont effacées lors d’une nouvelle comparaison de documents ou de la compilation du projet parent.
- Utilisez la commande Project » Show Physical Differences depuis les menus principaux pour détecter les différences physiques entre deux versions d’un document de schéma ou de PCB et les présenter graphiquement lorsque les deux documents sont affichés côte à côte dans l’espace de conception. Cette fonctionnalité d’affichage des différences physiques propose une comparaison purement visuelle : aucun des documents comparés ne peut être mis à jour par la génération d’ECO. Elle est destinée à comparer deux versions d’un même document. Toutefois, si elle est utilisée pour comparer des documents différents, par exemple la hiérarchie des documents sources du projet et le PCB, le panneau Differences s’affiche et répertorie les différences logiques détectées.
Mise à jour directe
Comme le concepteur sait généralement dans quel sens appliquer les mises à jour et que celles-ci vont toutes dans le même sens, vous pouvez choisir d’ignorer le processus de détection des différences et de définition du sens de mise à jour qui vient d’être décrit.
Plutôt que de sélectionner la commande Show Differences dans le menu Project, choisissez la commande Update dans le menu Design, depuis l’éditeur de schémas ou l’éditeur PCB. Le choix de l’éditeur depuis lequel vous exécutez la commande indique le sens dans lequel vous souhaitez appliquer les modifications : de l’éditeur this vers l’éditeur that. Par exemple, choisissez Design » Update dans l’éditeur de schémas pour transférer toutes les modifications du schéma vers le PCB.
La boîte de dialogue Differences between sera ignorée et vous passerez directement à la boîte de dialogue Engineering Change Order.
Si toutes les mises à jour doivent être appliquées dans le même sens, utilisez la commande Design » Update.
Résolution des différences - Application des ECO
Chaque différence est résolue par l’application d’un ordre de modification technique (Engineering Change Order, ECO). Les ECO sont répertoriés dans la boîte de dialogue Engineering Change Order, à raison d’un ECO par ligne, chacun disposant de sa propre case à cocher Enable.
Lors de l’utilisation de la boîte de dialogue Engineering Change Order :
- La boîte de dialogue s’ouvre avec toutes les modifications activées. Désactivez celles que vous souhaitez reporter. La boîte de dialogue prend en charge la sélection multiple : utilisez le menu contextuel accessible par clic droit pour activer ou désactiver les ECO sélectionnés.
- Utilisez la commande de repérage croisé du menu contextuel pour examiner les objets concernés par cet ECO.
- Utilisez le bouton Validate Changes pour vérifier que les modifications peuvent être effectuées. Les ECO échouent généralement parce qu’un objet n’est pas disponible : par exemple, l’empreinte PCB spécifiée n’existe pas dans les Bibliothèques basées sur des fichiers disponibles, ou la pastille spécifiée n’existe pas sur l’empreinte.
- Un ECO peut également échouer parce qu’un objet nécessaire à un ECO donné était absent, mais a été ajouté pendant le traitement des ECO en cours. Dans ce cas, exécutez à nouveau la commande de mise à jour pour terminer cet ECO.

Chaque modification de conception est présentée sous forme d’ECO ; activez ceux qui sont nécessaires.
Options et commandes de la boîte de dialogue Engineering Change Order
La boîte de dialogue est divisée en deux zones principales : Modifications et Status.
Modifications
Cette zone de la boîte de dialogue répertorie toutes les modifications nécessaires à la synchronisation. Les modifications sont regroupées par type, tels qu’ils sont répertoriés et activés dans la boîte de dialogue Options du projet - Génération des ECO. L’entrée de chaque groupe indique le nombre de modifications de ce type. Chaque modification de cette zone est décrite par les éléments suivants :
- Enable - cette option détermine si la modification sera incluse ou non lors de l’exécution de l’ECO. Cliquez directement sur la case à cocher pour basculer entre les états activé/inclus (cochée) et désactivé/exclu (décochée). Vous pouvez cocher ou décocher la case Enable à l’aide de la barre d’espace.
- Action - l’action précise à effectuer. Les types d’actions dépendent du type d’ECO à réaliser.
- Affected Object - l’objet concerné par l’action.
- Affected Document - le document sur lequel l’action sera effectuée.
Menu contextuel
Par défaut, toutes les modifications sont activées pour être incluses lors de l’exécution de l’ECO. Activez ou désactivez chaque modification selon vos besoins, soit individuellement, soit à l’aide des commandes suivantes du menu contextuel pour modifier l’état d’activation de plusieurs modifications :
- Validate Changes - cliquez pour lancer une vérification de validation des modifications activées pour inclusion dans l’ECO. Les résultats de la validation s’affichent dans la colonne Check de la zone Status de la boîte de dialogue.
- Execute Changes - cliquez pour exécuter l’ECO. Les résultats de l’exécution s’affichent dans la colonne Done de la zone Status de la boîte de dialogue. N’oubliez pas que seules les modifications qui passent l’étape de validation seront exécutées.
- Create Report - cliquez pour générer un rapport sur les modifications contenues dans l’ECO. Le rapport sera chargé dans la boîte de dialogue Report Preview.
- Cross Probe - cliquez pour effectuer un repérage croisé des objets cibles et de référence concernés par une action de modification dans les documents schématiques et PCB associés.
- Expand All - cliquez pour développer l’affichage de toutes les modifications de la liste.
- Contract All - cliquez pour réduire l’affichage de toutes les modifications de la liste.
- Enable All - permet d’activer toutes les modifications.
- Disable All - permet de désactiver toutes les modifications.
- Enable Selected - permet d’activer toutes les modifications sélectionnées.
- Disable Selected - permet de désactiver toutes les modifications sélectionnées.
- Enable all of same Kind - permet d’activer toutes les modifications du même type que la modification actuellement ciblée.
- Disable all of same Kind - permet de désactiver toutes les modifications du même type que la modification actuellement ciblée.
- Invert Selection - permet de sélectionner rapidement toutes les modifications qui ne sont pas actuellement sélectionnées dans la liste et de désélectionner celles qui le sont.
État
Cette zone de la boîte de dialogue présente les informations d’état suivantes pour chaque modification activée :
- Check - ce champ indique le résultat de la vérification de validation de la modification. Une coche verte signifie que la modification proposée est prise en charge et sera appliquée lors de l’exécution de l’ECO. Une croix rouge signifie que la modification proposée n’est pas valide et ne sera pas appliquée lors de l’exécution de l’ECO.
- Done - ce champ indique le résultat de l’exécution de la modification. Une coche verte signifie que la modification valide a été exécutée avec succès.
- Message - si la modification échoue à l’étape de validation, une entrée apparaît dans ce champ (ainsi que dans le panneau Messages), indiquant la raison de l’échec.
Commandes supplémentaires
Les commandes suivantes sont disponibles en bas de la boîte de dialogue et dans le menu contextuel :
- Validate Changes - cliquez pour lancer une vérification de validation des modifications activées pour inclusion dans l’ECO. Les résultats de validation apparaissent dans la colonne Check de la zone Status de la boîte de dialogue.
- Execute Changes - cliquez pour exécuter l’ECO et appliquer les modifications valides qu’il contient. Les résultats de l’exécution apparaissent dans la colonne Done de la zone Status de la boîte de dialogue. N’oubliez pas que seules les modifications ayant passé l’étape de validation seront exécutées.
- Report Changes - cliquez pour générer un rapport sur les modifications contenues dans l’ECO. Le rapport sera chargé dans la boîte de dialogue Report Preview.
- Only Show Errors - cochez cette option pour afficher uniquement les erreurs de l’ordre de modification technique (ECO). Les modifications validées ne seront pas affichées. L’affichage de la seule liste des erreurs vous permet de les examiner rapidement et d’apporter les changements nécessaires à votre conception afin que l’ECO résultant soit entièrement validé.
Comprendre la liaison entre le schéma et le PCB
Correspondance des composants par identifiants uniques
Chaque composant du schéma est lié à son composant PCB par un identifiant unique (UID). L’UID est attribué lorsque le composant du schéma est placé sur la feuille, et cette valeur est transférée au composant PCB lorsque la conception est transférée dans l’éditeur PCB. Lorsque les informations des composants sont transférées pour la première fois des documents schématiques sources vers le document de conception PCB vierge, à l’aide de Synchronizer, tous les composants sont automatiquement liés par identifiant unique : l’identifiant de chaque composant du schéma est attribué à l’empreinte du composant correspondant.
Ce mécanisme convient à une conception simple, mais ne permet pas de prendre en charge une conception multicanal. Dans une conception multicanal, le même composant du schéma est répété dans chaque canal physique, ce qui signifierait que les composants PCB répétés auraient le même UID. Pour gérer ce cas, l’UID du composant PCB est créé en combinant l’UID du symbole de feuille parent avec celui du composant du schéma. La syntaxe de l’UID du PCB varie légèrement selon la manière dont la conception multicanal a été créée.
Pour une conception multicanal créée en plaçant plusieurs symboles de feuille qui font tous référence à la même feuille de schéma, chaque symbole de feuille peut fournir un identifiant unique ; l’UID du PCB présente donc le format suivant :
\SheetSymbolUID\SchComponentUID
Pour une conception multicanal créée à l’aide du mot-clé Repeat, un seul UID de symbole de feuille est disponible ; l’UID du PCB inclut donc également la valeur ChannelIndex, selon le format suivant :
\ChannelIndex+SheetSymbolUID\SchComponentUID
Lorsque les composants ne sont pas liés
L’avantage d’utiliser un UID pour établir la correspondance entre les composants du schéma et du PCB est que leurs repères peuvent devenir désynchronisés (par exemple après plusieurs réannotations du PCB), sans risquer de rendre impossible la resynchronisation du schéma et du PCB.
Si un composant présent sur le schéma ou le PCB n’a pas de composant correspondant (avec le même UID) dans l’autre éditeur, voici ce qui se produit :
- Si le composant supplémentaire est présent uniquement dans l’éditeur source, un ECO est généré pour l’ajouter dans l’éditeur cible.
- Si le composant supplémentaire est présent uniquement dans l’éditeur cible, un ECO est généré pour le supprimer.
- Lorsque des composants sans correspondance sont présents dans les deux éditeurs, le logiciel a besoin d’instructions pour les traiter ; la boîte de dialogue Failed to Match Unique Identifiers s’ouvre alors.
La boîte de dialogue e Failed to Match Unique Identifiers
Les boutons de la boîte de dialogue proposent les options suivantes :
- Automatically Create Component Links - cliquez sur ce bouton si vous savez que les composants sans correspondance ont déjà des repères correspondants. À l’aide des repères des composants, le logiciel attribue des UID correspondants à ces composants supplémentaires. Pour les composants pouvant être associés par leur repère, toute autre différence de propriété (telle que des paramètres non concordants) entraîne la génération d’ECO. Si certains composants ne peuvent pas être associés par leur repère, des ECO sont générés pour les ajouter ou les supprimer (les composants supplémentaires présents dans l’éditeur source sont ajoutés, ceux présents dans l’éditeur cible sont supprimés).
-
Manual Component Links - cliquez sur ce bouton si vous savez que certains composants correspondent, mais que vous ne connaissez pas l’état de leurs repères. La boîte de dialogue Edit Component Links s’ouvre (décrite ci-dessous). Vous pouvez y sélectionner manuellement chaque composant source et cible, puis les transférer dans la liste des composants associés, en leur attribuant des UID correspondants. Des ECO sont ensuite générés pour synchroniser les repères (ainsi que toute autre propriété de composant non concordante).
- Cancel - cliquez sur ce bouton pour générer des ECO afin d’ajouter les composants supplémentaires présents dans l’éditeur source et de supprimer ceux présents dans l’éditeur cible.
Liaison manuelle des composants
L’état des liaisons entre les composants du schéma et leurs empreintes de composants PCB correspondantes peut être vérifié et géré à tout moment dans la boîte de dialogue Edit Component Links (éditeur PCB, commande Projects » Component Links).

La boîte de dialogue Modifier les liaisons des composants permet de détecter et de résoudre les incohérences d’UID ; elle est ouverte depuis l’éditeur PCB.
Résumé des fonctionnalités de la boîte de dialogue :
- Les composants sans correspondance sont présentés dans les deux colonnes Un-Matched Components à gauche ; les composants partageant un UID correspondant sont présentés dans la zone Matched Components à droite de la boîte de dialogue.
- Les boutons fléchés au centre de la boîte de dialogue permettent d’associer (ou de dissocier) manuellement les composants sélectionnés, ou de dissocier tous les composants actuellement associés.
- Le bouton Add Pairs Matched By et les options en bas de la boîte de dialogue permettent de parcourir la liste des composants actuellement sans correspondance et de tenter de les associer selon les propriétés activées (Repère, Commentaire, Empreinte).
- Lorsque vous cliquez sur le bouton Perform Update, chaque composant PCB nouvellement associé reçoit l’UID de son équivalent dans le schéma. Si vous avez déplacé des entrées dans Matched section de la boîte de dialogue vers les Unmatched sections, une boîte de dialogue de confirmation apparaît pour vous avertir que les associations de composants existantes seront rompues si vous poursuivez. Cliquez sur Yes pour poursuivre la mise à jour ; une boîte de dialogue d’information apparaît alors et présente un récapitulatif des liens de composants modifiés dans le document PCB. Une nouvelle entrée dans la Matched section est récapitulée comme Link Modified, tandis qu’une entrée précédemment liée dont vous avez supprimé la correspondance est récapitulée comme Link Removed.
- Après avoir utilisé cette boîte de dialogue pour lier manuellement les composants, il est recommandé de vérifier l’état de synchronisation (exécutez la commande Design » Update).
Mise en correspondance des nets et des classes
Les nets comme les classes possèdent un parent (le net ou la classe) et des enfants (les membres de ce net ou de cette classe). Leur mise en correspondance nécessite une approche différente du mécanisme d’UID utilisé pour lier les composants, afin de prendre en charge les modifications du parent, des enfants, ou du parent et de ses enfants. Par exemple, une opération aussi simple que le changement de nom d’un net sur le schéma ne doit pas nécessiter de supprimer du PCB ce net et toutes ses broches enfants, puis d’ajouter le net renommé et, enfin, d’ajouter toutes les broches enfants à ce nouveau net.
Pour cela, le logiciel comprend des algorithmes distincts permettant de mettre en correspondance les nets et les classes selon leurs membres, mais aussi selon leur nom. Le processus de mise en correspondance se configure dans la section Object Matching Criteria de l’onglet Comparator de la boîte de dialogue Options for Project.

Par défaut, la mise en correspondance s’effectue d’abord selon les membres, puis selon le nom du type d’objet.
La mise en correspondance de ces types d’objets s’effectue de la manière suivante :
- Lors de la synchronisation de la conception, le comportement par défaut consiste à tenter d’abord une mise en correspondance selon les membres, conformément aux paramètres Min Match % et Min Match Member.
- Si la mise en correspondance selon les membres échoue, le logiciel tente ensuite une mise en correspondance selon le nom (si l’option Use Name Matching est activée).
- Si l’un de ces processus de mise en correspondance réussit, vous accédez à la boîte de dialogue Engineering Change Order.
-
Si les deux méthodes de mise en correspondance échouent (ou si l’option Use Name Matching est définie sur
Never), la boîte de dialogue Match Manually s’ouvre.
- Cliquer sur No dans la boîte de dialogue Match Manually permet d’ignorer le processus de mise en correspondance manuelle et d’accéder directement à la boîte de dialogue Engineering Change Order. Puisque vous n’avez tenté de mettre en correspondance aucun objet sans correspondance, le logiciel considère que les objets de référence et les objets cibles ne sont pas liés. Des ECO sont donc générés pour supprimer les Unmatched Reference Objects de la carte et ajouter les Unmatched Target Objects en tant que nouveaux objets.
- Si vous cliquez sur Yes dans la boîte de dialogue pour effectuer une mise en correspondance manuelle, la boîte de dialogue Match s’ouvre, comme illustré ci-dessous (son titre change selon le type d’objet sans correspondance).
La boîte de dialogue Match sert à mettre manuellement en correspondance les objets dont vous savez qu’ils correspondent. Laissez la partie droite vide et cliquez sur Continue en cas de doute.
Options et commandes de la boîte de dialogue de mise en correspondance
-
Unmatched <Object>
- Unmatched Reference Objects - répertorie les objets sans correspondance. Utilisez les commandes de développement/réduction pour ouvrir ou fermer la liste.
- Unmatched Target Objects - répertorie les objets cibles. Utilisez les commandes de développement/réduction pour ouvrir ou fermer la liste.
-
- cliquez pour mettre en correspondance les objets de référence et cibles sélectionnés et déplacer les objets sélectionnés de la zone Unmatched vers la zone Matched Pairs.
-
- cliquez pour déplacer les objets sélectionnés de la zone Matched Pairs vers la zone Unmatched. Cette action supprime la correspondance des objets déplacés.
-
- cliquez pour déplacer tous les objets de la zone Matched Pairs vers la zone Unmatched. Cette action supprime la correspondance des objets déplacés.
- Matched Pairs - répertorie les Reference Object et les Target Object qui sont désormais mis en correspondance.
- Continue - cliquez pour accepter les mises à jour des correspondances et ouvrir la boîte de dialogue Engineering Change Order.
- Dans cette boîte de dialogue, sélectionnez les objets que vous souhaitez mettre en correspondance dans Unmatched Reference Objects et Unmatched Target Objects, puis transférez-les vers la section Matched Pairs de la boîte de dialogue. Pour ces objets, le logiciel génère un ECO afin de mettre à jour les noms pour qu’ils correspondent, ainsi que des ECO pour supprimer ou ajouter des membres afin qu’ils correspondent également.
- En cas de doute, vous n’êtes pas obligé de mettre manuellement les objets en correspondance. Pour tout objet sans correspondance, le logiciel considère que les objets de référence et les objets cibles ne sont pas liés. Il génère donc des ECO pour supprimer les Unmatched Reference Objects de la carte et ajouter les Unmatched Target Objects en tant que nouveaux objets.
- Une fois les objets dont vous connaissez la correspondance mis en correspondance, cliquez sur Continue pour ouvrir la boîte de dialogue Engineering Change Order.
- Si vous cliquez sur Cancel, le processus de mise à jour s’arrête.
Mise en correspondance des règles de conception
Les règles de conception définies sur le schéma doivent également être liées aux règles correspondantes sur le PCB. Sans mécanisme de liaison, vous ne pourriez pas mettre à jour une règle sur le schéma et transférer ces modifications au PCB. Les UID servent à lier les règles de conception du schéma à celles du PCB.
L’UID est automatiquement attribué dans l’ensemble de paramètres qui contient la définition de la règle sur le schéma, puis transféré au PCB lors de la synchronisation de la conception.
Les règles de conception utilisent un UID pour mettre en correspondance la définition de la règle de conception du schéma avec la règle de conception du PCB.
En général, vous n’aurez pas besoin de gérer manuellement la correspondance des règles, sauf si vous avez modifié manuellement l’UID dans la boîte de dialogue PCB Rules and Constraints de l’éditeur PCB. Si les UID ne correspondent pas, le logiciel ajoutera au PCB une nouvelle règle pour chaque règle de schéma sans règle PCB correspondante, et supprimera toute règle de conception PCB sans règle de conception de schéma correspondante.
