Recherche de composants dans les bibliothèques de base de données et basées sur des fichiers
Altium Essentials: Schematic Capture
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
En un coup d'œil
- Comprenez les différences entre les bibliothèques du projet, les bibliothèques installées et les bibliothèques accessibles via les chemins de recherche, ainsi que leur incidence sur la disponibilité des composants dans Altium Designer.
- Découvrez où gérer les bibliothèques disponibles, comment fonctionne l’ordre de recherche et pourquoi certains choix de configuration des bibliothèques peuvent affecter la rapidité et la fiabilité.
- Découvrez comment fonctionne la recherche de composants dans les bibliothèques basées sur des fichiers et les bibliothèques de bases de données, notamment ce à quoi vous attendre lorsque vous utilisez des sources DbLib et SVNDbLib.
Gestion des bibliothèques disponibles basées sur des bases de données et des fichiers
Dans Altium Designer, les composants des bibliothèques basées sur des bases de données et des fichiers ne peuvent être placés qu'à partir des bibliothèques actuellement disponibles. Celles-ci comprennent :
-
Libraries in the current project – si une bibliothèque fait partie du projet, ses composants sont automatiquement disponibles pour être placés dans ce projet.
-
Installed libraries – ces bibliothèques ont été installées dans Altium Designer ; leurs composants peuvent être utilisés dans tout projet ouvert.
-
Libraries on a defined search path – il est également possible de définir un chemin de recherche vers un dossier contenant plusieurs bibliothèques. Comme tous les fichiers du chemin de recherche sont parcourus chaque fois qu'un nouveau composant est sélectionné dans un panneau, cette approche n'est recommandée que pour les petites bibliothèques contenant des définitions de modèles simples, tels que les modèles de simulation. Les chemins de recherche ne sont pas recommandés pour les modèles complexes, tels que les empreintes qui incluent des modèles 3D.
Pour gérer les bibliothèques disponibles basées sur des bases de données et des fichiers, vous pouvez utiliser la boîte de dialogue Libraries Preferences, accessible en cliquant sur le bouton
en haut du panneau Components et en sélectionnant Libraries Preferences dans le menu.
La boîte de dialogue Libraries Preferences comporte trois onglets. L'ensemble des bibliothèques et des emplacements de modèles définis dans ces onglets constitue votre liste de bibliothèques disponibles. Lorsqu'une action nécessite la recherche d'un modèle, comme le transfert de la conception du schéma vers le routage du PCB, les bibliothèques sont parcourues dans l'ordre des onglets, puis, dans chaque onglet, dans l'ordre d'affichage des bibliothèques et des modèles. Dès que le modèle approprié est trouvé, la recherche s'arrête.
Bibliothèques du projet
Les bibliothèques qui font partie du projet actif sont répertoriées dans l'onglet Project de la boîte de dialogue Libraries Preferences lorsque ce projet est actif dans le logiciel. L'avantage des bibliothèques du projet est que les modèles et les bibliothèques deviennent automatiquement disponibles à chaque ouverture du projet. L'inconvénient est que, si les modèles et les bibliothèques ne sont pas stockés dans la même arborescence de dossiers du projet que les fichiers de conception, ils peuvent facilement être oubliés lors du déplacement des fichiers du projet.

L'onglet Project fournit une liste des bibliothèques disponibles dans le projet actuel.
Bibliothèques installées
Les bibliothèques et les modèles mis à disposition dans votre installation du logiciel sont appelés bibliothèques installées. Ils sont répertoriés dans l'onglet Installed de la boîte de dialogue Libraries Preferences.
Les bibliothèques installées peuvent être répertoriées à l'aide d'un chemin absolu ou d'un chemin relatif au paramètre Library Path Relative To. L'avantage d'un chemin relatif est qu'il permet de créer un sous-environnement commun sur plusieurs PC, ce qui facilite le déplacement des fichiers de conception entre ces machines. De plus, les bibliothèques installées peuvent être temporairement désactivées en décochant la case Activated, plutôt qu'en les supprimant.

L'onglet Installed répertorie les bibliothèques mises à disposition dans cette installation d'Altium Designer.
Chemin de recherche
L'onglet Search Path présente une liste des bibliothèques trouvées selon les paramètres de chemin définis dans l'onglet Chemins de recherche de la boîte de dialogue Options du projet, accessible en cliquant sur le bouton Paths. Chaque chemin de recherche définit un dossier et peut inclure des sous-dossiers si l'option Recursive est activée (disponible dans l'onglet Search Paths de la boîte de dialogue Project Options après l'ajout d'un chemin). Tous les fichiers de modèles et de bibliothèques trouvés dans le chemin de recherche seront disponibles. Les chemins de recherche sont enregistrés avec le projet.

L'onglet Search Path répertorie les bibliothèques trouvées dans les chemins de recherche définis.
La récupération des modèles à l'aide de chemins de recherche peut être lente si les dossiers concernés contiennent un grand nombre de fichiers. C'est pourquoi il n'est pas recommandé d'utiliser cette approche pour les bibliothèques de PCB, car celles-ci peuvent être des fichiers volumineux contenant de nombreuses empreintes. Cette fonctionnalité a été développée pour permettre de référencer les modèles de simulation et d'intégrité du signal disponibles.
Parcourir les composants de la base de données
Une fois le fichier DbLib/SVNDbLib ajouté à la liste des bibliothèques disponibles basées sur des fichiers, les composants de la base de données peuvent être parcourus dans le panneau Components. Bien qu'un seul fichier DbLib/SVNDbLib soit ajouté, chaque table de la base de données liée apparaît comme une bibliothèque distincte.
La liste déroulante supérieure du panneau sera remplie avec des entrées de la forme :
- <LibraryName>.DbLib - <TableName> ou <LibraryName>.SVNDbLib - <TableName> ----lorsque votre base de données contient des tables
- <LibraryName>.DbLib - <SheetName>$ ou <LibraryName>.SVNDbLib - <SheetName>$ ----où votre base de données est constituée de feuilles d’un classeur Excel.
Exemple d’une DbLib chargée comportant trois tables, d’une autre comportant une table et d’une SVNDbLib comportant une table.
Chaque entrée de composant du panneau correspond à un enregistrement dans cette table de la base de données. En fait, lorsque vous parcourez les bibliothèques de bases de données chargées, le panneau Components se comporte comme un navigateur de base de données direct. Les informations sur les symboles et les modèles proviennent des bibliothèques de symboles et de modèles sous-jacentes indiquées par les champs correspondants de la base de données (en tenant également compte des chemins/emplacements de recherche définis).
Parcours des composants d’une base de données externe liée via une bibliothèque de base de données.
Par défaut, seuls les champs Part Number et Library Ref sont affichés dans la zone de liste des composants du panneau. Pour afficher d’autres champs de la table de la base de données, faites un clic droit dans cette zone et choisissez Select Columns dans le menu contextuel. Vous accéderez ainsi à la boîte de dialogue Sélectionner les colonnes, dans laquelle vous pouvez activer l’affichage de tous les champs supplémentaires de cette table.
Mise en cache locale des symboles et modèles utilisés par les bibliothèques de bases de données SVN
Lorsqu’un fichier SVNDbLib est ajouté à la liste des bibliothèques disponibles, les bibliothèques de symboles et de modèles du dépôt sont mises en cache dans un dossier temporaire sur l’ordinateur du concepteur. Lorsqu’une action dans le logiciel nécessite l’utilisation d’un symbole schématique ou d’un modèle, ce symbole ou modèle est récupéré dans le cache local.
Mise à jour automatique du cache
Les bibliothèques du cache sont automatiquement mises à jour avec les dernières versions du dépôt de gestion de versions lors de l’exécution de l’une des actions suivantes dans le logiciel :
-
Placement d’un composant à partir d’un fichier SVNDbLib installé (depuis le panneau Composants).
-
Transfert d’une conception (c’est-à-dire mise à jour du PCB).
-
Utilisation de la commande Tools » Update From Libraries dans l’éditeur de schémas.
-
Utilisation de la commande Tools » Update From PCB Libraries dans l’éditeur de PCB.
Bien que la mise à jour soit automatique, elle peut être contrôlée à l’aide de l’option Do not check files more often than xx minutes sur la page Gestion des données - Bibliothèques SVN de la Preferences boîte de dialogue. Cette option définit essentiellement un délai de mise à jour du cache local. Si le temps spécifié s’est écoulé depuis la dernière mise à jour du cache, celui-ci est automatiquement mis à jour lorsque l’une des actions répertoriées est exécutée. Si une action est exécutée avant l’expiration de ce délai, le contenu actuel du cache est utilisé ; il peut alors être obsolète par rapport au contenu du dépôt.
Forcer manuellement la mise à jour du cache
Il peut arriver que vous souhaitiez forcer la mise à jour du cache local pour vous assurer de disposer des bibliothèques les plus récentes actuellement stockées dans le dépôt de gestion de versions. Par exemple, lorsque vous vous préparez à transférer la conception du schéma vers le PCB.
Vous pouvez forcer manuellement la mise à jour du cache à l’aide de l’une des méthodes suivantes :
- Utiliser l’une des Refresh commandes disponibles dans le menu contextuel du panneau Composants.
- Désinstaller puis réinstaller le fichier SVNDbLib dans la liste des bibliothèques disponibles.
Recherche de composants dans les bibliothèques de bases de données et les bibliothèques basées sur des fichiers
Pour faciliter la recherche d’un composant dans les bibliothèques basées sur des fichiers (installées ou non) et les bibliothèques de bases de données, Altium Designer propose une fonction de recherche dans les bibliothèques.
La recherche d’un composant dans les bibliothèques de bases de données et les bibliothèques basées sur des fichiers est possible à l’aide du champ Search du panneau Components. Saisissez une chaîne de caractères et appuyez sur Enter pour rechercher cette chaîne dans la bibliothèque actuelle, parmi tous les paramètres de composants visibles.
Vous pouvez effectuer une recherche directement dans le panneau Components.
La boîte de dialogue File-based Libraries Search permet d’effectuer des recherches plus détaillées. Pour y accéder, cliquez sur le bouton
du panneau Components, puis sélectionnez File-based Libraries Search dans le menu. La moitié supérieure de la boîte de dialogue sert à définir what vous recherchez ; la moitié inférieure sert à définir where effectuer la recherche.
Effectuez une recherche dans les bibliothèques installées (Available libraries) ou dans les bibliothèques présentes sur le disque dur (Libraries on path).Le processus de recherche peut être résumé comme suit :
-
La recherche s’effectue en définissant Filters qui sont appliqués à toutes les bibliothèques dans lesquelles la recherche est possible selon les paramètres Scope actuels de la recherche.
-
Le Scope inclut le type de bibliothèques à rechercher. La recherche ne peut porter que sur un seul type à la fois.
-
Pour activer la recherche de composants de base de données, définissez le champ Search in sur Database Components et sélectionnez le Table souhaité. Notez que les Fields disponibles dans la liste déroulante ci-dessus changent pour refléter les en-têtes de colonnes disponibles dans la table choisie. Les autres options de la boîte de dialogue sont grisées, car elles ne s’appliquent pas à la recherche dans les bibliothèques de bases de données.
-
Le Scope définit les bibliothèques dans lesquelles effectuer la recherche : soit les bibliothèques auxquelles le logiciel a actuellement accès (Available libraries), soit toutes les bibliothèques d’un dossier (Libraries on path).
-
Lors d’une recherche dans les bibliothèques d’un chemin donné, la cible est un dossier spécifique et peut également Include Subdirectories.
-
Vous pouvez également effectuer une recherche dans les résultats de recherche en définissant le Scope sur Refine last search.
-
Cliquez sur Clear pour effacer les paramètres de recherche saisis.
Définition du filtre de recherche
La zone Filters sert à définir les chaînes de texte à utiliser pour la recherche. Trois zones sont à configurer :
-
Field – il s’agit de l’attribut du composant sur lequel porte la recherche. Il peut s’agir de n’importe quel attribut de composant ou d’empreinte, notamment le nom, la description, le commentaire, l’empreinte ou tout paramètre ajouté à un composant. Sélectionnez un champ disponible dans la liste déroulante ou saisissez un champ dans la zone de texte.
-
Operator – définit la manière dont une correspondance est déterminée. Cela peut être lorsque la valeur equals, contains, starts with ou ends with. Notez que equals nécessite une correspondance exacte de la chaîne ; cette option ne doit donc être utilisée que si vous êtes certain que la chaîne de recherche est correcte et complète.
-
Value – les caractères à rechercher dans le Field choisi, selon le Operator choisi. Sélectionnez une valeur disponible dans la liste déroulante ou saisissez une valeur dans le champ de texte.
Par défaut, trois critères de filtrage sont disponibles ; vous pouvez ajouter jusqu’à sept lignes supplémentaires, pour un total de 10 lignes, à l’aide de la Add Row commande. La dernière ligne de critère de filtrage ajoutée peut être supprimée à l’aide de Remove Row. Vous pouvez supprimer les lignes inutilisées.
Définition du périmètre
Il existe essentiellement deux approches de recherche :
-
Bibliothèques actuellement disponibles – il s’agit de la liste des bibliothèques affichée dans la liste déroulante en haut du panneau Components .
-
Bibliothèques stockées dans un dossier spécifique, ainsi que dans ses sous-répertoires si l’option est activée.
La recherche renverra tous les éléments du type de recherche choisi dans la liste déroulante Search in (Components/Footprints/3D Models/Database Components) trouvés dans toutes les bibliothèques relevant du périmètre Scope défini :
- Available libraries - activez cette option pour rechercher les types de modèles spécifiés uniquement dans les bibliothèques disponibles.
-
Libraries on path - activez cette option pour rechercher les types de modèles spécifiés dans les bibliothèques disponibles dans un ou plusieurs dossiers spécifiques. Dans la zone Path de la boîte de dialogue, qui devient disponible lorsque l’option de périmètre Libraries on path est sélectionnée, vous pouvez définir le chemin, inclure les sous-répertoires et définir le masque des fichiers de bibliothèque pour préciser et restreindre les critères de recherche :
- Path - modifiez ce champ pour définir le dossier dans lequel rechercher les bibliothèques, ou cliquez sur l’icône de navigation à la fin du champ pour sélectionner un dossier.
- Include Subdirectories - activez cette option si vous souhaitez rechercher des bibliothèques dans le chemin spécifié et ses sous-répertoires.
-
File Mask - saisissez le masque de fichiers ou choisissez l’un des masques existants dans la liste déroulante. La recherche est filtrée pour ne retenir que les fichiers correspondant à cette chaîne. Vous pouvez utiliser le caractère générique * (n’importe quel caractère) dans la chaîne. Par exemple, saisissez * pour rechercher tous les fichiers, et M pour rechercher tous les fichiers dont le nom commence par la lettre M.
Par exemple, si vous souhaitez trouver un composant que vous pensez être dans une bibliothèque située dans des dossiers spécifiques du disque dur, et que cette bibliothèque ne figure pas actuellement dans Available File-based Libraries, définissez la recherche comme suit :
- Dans la zone Scope, définissez Search in sur Components et sélectionnez Libraries on path.
- Dans la zone Path, définissez Path de manière à pointer vers le dossier contenant le document de bibliothèque dans lequel vous souhaitez effectuer la recherche.
- Cliquez sur Search. Les résultats s’affichent dans le panneau Components au fur et à mesure de la recherche.
Mode de recherche avancée
La recherche dans les bibliothèques s’effectue en réalité au moyen de requêtes. Dans la boîte de dialogue File-based Libraries Search, passez en mode Advanced pour examiner la requête.
Dans le mode Advanced de la boîte de dialogue, vous pouvez également créer vos propres requêtes à l’aide des mots-clés du langage de requête pour effectuer une recherche basée sur une requête. Consultez la section ci-dessous pour en savoir plus sur les mots-clés disponibles dans le langage de requête.
Utilisez les commandes supplémentaires suivantes lorsque le mode Advanced est sélectionné :
-
Helper - cliquez pour ouvrir la boîte de dialogue Assistant de requête afin de créer facilement une requête de recherche dans les bibliothèques à l’aide de fonctions de bibliothèque et de fonctions système prédéfinies. Vous pouvez également utiliser les boutons History et Favorites pour choisir une requête de bibliothèque récemment appliquée ou prédéfinie.
-
History - cliquez pour ouvrir la boîte de dialogue Gestionnaire d’expressions afin de choisir l’une des expressions de requête précédemment appliquées à utiliser pour la recherche dans les bibliothèques. Vous pouvez également utiliser le bouton Favorites pour utiliser une requête prédéfinie pour une recherche spécifique dans les bibliothèques.
-
Favorites - cliquez pour ouvrir la boîte de dialogue Gestionnaire d’expressions afin de choisir l’une de vos expressions de requête favorites à utiliser dans une recherche de bibliothèque. Vous pouvez également modifier la liste Favorites en supprimant, renommant ou copiant des expressions de la liste History.
Lors d’une recherche parmi Database Components, le mode Advanced vous permet d’effectuer une recherche par requête SQL. Ce niveau de recherche permet une recherche précise basée sur une expression de requête spécifiée, en saisissant directement une requête SQL dans la zone d’édition de requête de la boîte de dialogue.
Cliquez sur Advanced pour accéder à une puissante recherche par requête SQL. Cliquez de nouveau sur Advanced pour revenir à la recherche simple.
Fonctions de requête pour les composants et les bibliothèques

Fonctions de requête pour les composants et les bibliothèques dans la boîte de dialogue Query Helper
Les éditeurs de schémas et de PCB d’Altium Designer reposent sur un puissant moteur de requête. En saisissant des requêtes dans ce moteur, vous pouvez délimiter logiquement et précisément les objets dont vous avez besoin.
Une requête est une chaîne que vous saisissez à l’aide de mots-clés et d’une syntaxe spécifiques, et qui renvoie les objets ciblés. De nombreux mots-clés sont disponibles, ce qui vous permet de cibler les objets selon leur type, leurs propriétés ou les deux.
Les sections ci-dessous détaillent les mots-clés du langage de requête disponibles lors de la recherche de composants issus de bases de données ou de fichiers dans Altium Designer. Pour obtenir de l’aide sur un mot-clé de requête spécifique, utilisez les sections repliables suivantes ou sélectionnez un mot-clé (ou cliquez à l’intérieur de celui-ci) dans Query Helper.
Composants
Commentaire
Résumé
Renvoie tous les composants dont Comment correspond à la requête.
Syntaxe
Comment : String
Exemples d’utilisation
Comment = 'Res1'
Renvoie tous les composants dont Comment est Res1.
Comment = '100nF'
Renvoie tous les composants dont Comment est 100nF.
Comment Like '*33*'
Renvoie tous les composants dont Comment contient 33.
Remarques
-
Assurez-vous que le périmètre de recherche est défini sur Components à l’aide du champ Search in dans la boîte de dialogue de recherche dans les bibliothèques de fichiers.
-
Lors de la recherche de composants, toutes les bibliothèques SchLib et IntLib disponibles ou situées dans le chemin de recherche défini sont interrogées.
-
Tous les résultats figurent dans la liste Query Results du panneau Composants.
Type de composant
Résumé
Renvoie tous les composants dont la propriété Component Type correspond à la requête.
Syntaxe
ComponentType = ComponentType_String
ComponentType_String doit être l’une des chaînes de la liste suivante :
- 'Graphical'
- 'Jumper'
- 'Mechanical'
- 'Net Tie'
- 'Net Tie (In BOM)'
- 'Standard'
- 'Standard (No BOM)'
Exemples d’utilisation
ComponentType = 'Graphical'
Renvoie tous les composants dont Component Type est Graphical.
ComponentType = 'Standard'
Renvoie tous les composants dont Component Type est Standard.
Remarques
-
Assurez-vous que la portée de la recherche est définie sur Components à l’aide du champ Search in de la boîte de dialogue Recherche dans les bibliothèques de fichiers.
-
Lors de la recherche de composants, toutes les bibliothèques SchLib et IntLib disponibles ou situées sur un chemin de recherche défini sont interrogées.
-
Tous les résultats sont répertoriés dans la liste Query Results, dans le panneau Composants.
-
Les apostrophes (') au début et à la fin de
ComponentType_Stringsont obligatoires.
Désignateur
Résumé
Renvoie tous les composants dont la propriété Designator satisfait aux critères de la requête.
Syntaxe
Designator : String
Exemples d’utilisation
Designator = 'U2'
Renvoie tous les composants dont la propriété Designator est U2.
Designator Like '*Channel*'
Renvoie tous les composants dont la propriété Designator contient Channel.
Designator <> 'C*'
Renvoie tous les composants except ceux dont la propriété Designator commence par C.
Remarques
-
Assurez-vous que la portée de la recherche est définie sur Components à l’aide du champ Search in de la boîte de dialogue Recherche dans les bibliothèques de fichiers.
-
Lors de la recherche de composants, toutes les bibliothèques SchLib et IntLib disponibles ou situées sur un chemin de recherche défini sont interrogées.
-
Tous les résultats sont répertoriés dans la liste Query Results du panneau Composants.
HasModel
Résumé
Renvoie chaque composant lié à un modèle de domaine (ou qui le référence) dont les propriétés satisfont aux critères de la requête.
Syntaxe
HasModel(ModelType : String,ModelName : String,CurrentModelOnly : Boolean) : Boolean/Boolean_String
La chaîne ModelType spécifie la propriété Type d’un modèle lié et doit être l’une des chaînes de la liste suivante :
- 'PCB3DLIB' - utilisez cette chaîne pour cibler un modèle lié dont la propriété Type est PCB3D.
- 'PCBLIB' - utilisez cette chaîne pour cibler un modèle lié dont la propriété Type est Footprint.
- 'IBIS' - utilisez cette chaîne pour cibler un modèle lié dont la propriété Type est Ibis Model.
- 'SI' - utilisez cette chaîne pour cibler un modèle lié dont la propriété Type est Signal Integrity.
- 'SIM' - utilisez cette chaîne pour cibler un modèle lié dont la propriété Type est Simulation.
La chaîne ModelName spécifie la propriété Name d’un modèle lié.
Le paramètre CurrentModelOnly spécifie si le modèle lié doit être le modèle courant de chaque composant. Lorsqu’il est défini sur False, le modèle lié ne doit pas nécessairement être le modèle courant (mais il peut l’être) ; lorsqu’il est défini sur True, le modèle lié doit être le modèle courant.
Exemples d’utilisation
HasModel('PCBLIB','SOIC14',False)
HasModel('PCBLIB','SOIC14',False) = True
HasModel('PCBLIB','SOIC14',False) = 'True'
Renvoie tous les composants liés à un modèle d’empreinte dont la propriété Name est SOIC14 ; ce modèle ne doit pas nécessairement être le modèle d’empreinte courant de chaque composant (mais il peut l’être).
HasModel('PCBLIB','DIP14',True)
HasModel('PCBLIB','DIP14',True) = True
HasModel('PCBLIB','DIP14',True) = 'True'
Renvoie tous les composants liés à un modèle d’empreinte dont la propriété Name est DIP14 ; ce modèle doit être le modèle d’empreinte courant du composant.
HasModel('SI','RES1',False)
HasModel('SI','RES1',False) = True
HasModel('SI','RES1',False) = 'True'
Renvoie tous les composants liés à un modèle d’intégrité du signal dont la propriété Name est RES1 ; ce modèle ne doit pas nécessairement être le modèle d’intégrité du signal courant de chaque composant (mais il peut l’être).
HasModel('SIM','RESISTOR',True)
HasModel('SIM','RESISTOR',True) = True
HasModel('SIM','RESISTOR',True) = 'True'
Renvoie tous les composants liés à un modèle de simulation dont la propriété Name est RESISTOR ; ce modèle doit être le modèle de simulation courant du composant.
Remarques
-
Assurez-vous que la portée de la recherche est définie sur Components à l’aide du champ Search in de la boîte de dialogue Recherche dans les bibliothèques de fichiers.
-
Lors de la recherche de composants, toutes les bibliothèques SchLib et IntLib disponibles ou situées sur un chemin de recherche défini sont interrogées.
-
Tous les résultats sont répertoriés dans la liste Query Results du panneau Composants.
HasModelParameter
Résumé
Renvoie chaque composant lié à un modèle de domaine (ou qui le référence) contenant un objet paramètre dont les propriétés Parameter Name et Value satisfont aux critères de la requête.
Syntaxe
HasModelParameter(Parameter Name : String,Value : String,CurrentModelOnly : Boolean) : Boolean/Boolean_String
Le paramètre CurrentModelOnly spécifie si le modèle lié (qui contient un paramètre satisfaisant aux critères) doit être le modèle courant de chaque composant. Lorsqu’il est défini sur False, le modèle lié ne doit pas nécessairement être le modèle courant (mais il peut l’être) ; lorsqu’il est défini sur True, le modèle lié doit être le modèle courant.
Exemples d’utilisation
HasModelParameter('Inductance A','1mH',False)
HasModelParameter('Inductance A','1mH',False) = True
HasModelParameter('Inductance A','1mH',False) = 'True'
Renvoie tous les composants liés à un modèle contenant un objet paramètre dont la propriété Parameter Name est Inductance A et dont la propriété Value est 1mH. Ce modèle ne doit pas nécessairement être le modèle courant de chaque composant (mais il peut l’être).
HasModelParameter('Coupling Factor','0.999',True)
HasModelParameter('Coupling Factor','0.999',True) = True
HasModelParameter('Coupling Factor','0.999',True) = 'True'
Renvoie tous les composants liés à un modèle contenant un objet paramètre dont la propriété Parameter Name est Coupling Factor et dont la propriété Value est 0.999. Ce modèle doit être le modèle courant du composant.
Remarques
-
Assurez-vous que la portée de la recherche est définie sur Components à l’aide du champ Search in de la boîte de dialogue Recherche dans les bibliothèques de fichiers.
-
Lors de la recherche de composants, toutes les bibliothèques SchLib et IntLib disponibles ou situées sur un chemin de recherche défini sont interrogées.
-
Tous les résultats sont répertoriés dans la liste Query Results du panneau Composants.
LibReference
Résumé
Renvoie tous les composants dont la propriété Library Reference satisfait aux critères de la requête.
Syntaxe
LibReference : String
Exemples d’utilisation
LibReference = 'LM833'
Renvoie tous les composants dont la propriété Library Reference est LM833.
LibReference Like 'C*'
Renvoie tous les composants dont la propriété Library Reference commence par C.
Remarques
-
Assurez-vous que la portée de la recherche est définie sur Components à l’aide du champ Search in de la boîte de dialogue Recherche dans les bibliothèques de fichiers.
-
Lors de la recherche de composants, toutes les bibliothèques SchLib et IntLib disponibles ou situées sur un chemin de recherche défini sont interrogées.
-
Tous les résultats sont répertoriés dans la liste Query Results du panneau Composants.
Nombre de parties
Résumé
Renvoie tous les composants dont la propriété Part Count satisfait à la requête.
Syntaxe
PartCount : Number
Exemples d’utilisation
PartCount = 2
Renvoie tous les composants dont Part Count est égal à 2.
PartCount > 4
Renvoie tous les composants dont Part Count est supérieur à 4 (c’est-à-dire tous les composants multiparties contenant plus de quatre sous-parties).
Remarques
-
Assurez-vous que le périmètre de recherche est défini sur Components à l’aide du champ Search in de la boîte de dialogue de recherche dans les bibliothèques de fichiers.
-
Lors de la recherche de composants, toutes les bibliothèques SchLib et IntLib disponibles ou situées sur un chemin de recherche défini sont interrogées.
-
Tous les résultats sont affichés dans la liste Query Results du panneau Composants.
Nombre de broches
Résumé
Renvoie tous les composants dont la propriété Pin Count satisfait à la requête.
Syntaxe
PinCount : Number
Exemples d’utilisation
PinCount = 2
Renvoie tous les composants dont Pin Count est égal à 2.
PinCount > 14
Renvoie tous les composants dont Pin Count est supérieur à 14.
Remarques
-
Assurez-vous que le périmètre de recherche est défini sur Components à l’aide du champ Search in de la boîte de dialogue de recherche dans les bibliothèques de fichiers.
-
Lors de la recherche de composants, toutes les bibliothèques SchLib et IntLib disponibles ou situées sur un chemin de recherche défini sont interrogées.
-
Tous les résultats sont affichés dans la liste Query Results du panneau Composants.
Tous
Description
Résumé
Renvoie tous les composants ou empreintes dont la propriété Description satisfait à la requête.
Syntaxe
Description : String
Exemples d’utilisation
Description = 'TTL-RS232 DRIVER'
Renvoie tous les composants ou empreintes dont la propriété Description est égale à TTL-RS232 DRIVER.
Description Like '*RS485*'
Renvoie tous les composants ou empreintes dont la propriété Description contient RS485.
Remarques
-
Les entités renvoyées, composants ou empreintes, dépendent du périmètre choisi, défini à l’aide du champ Search in de la boîte de dialogue de recherche dans les bibliothèques de fichiers.
-
Tous les résultats sont affichés dans la liste Query Results du panneau Composants.
Possède un paramètre
Résumé
Renvoie tous les composants contenant un objet paramètre dont les propriétés Parameter Name et Value satisfont à la requête.
Syntaxe
HasParameter(Parameter Name : String,Value : String) : Boolean/Boolean_String
Exemples d’utilisation
HasParameter('Comment','1K')
HasParameter('Comment','1K') = True
HasParameter('Comment','1K') = 'True'
Renvoie tous les composants contenant un objet paramètre dont la propriété Parameter Name est égale à Comment et dont la propriété Value est égale à 1K.
Remarques
-
Les entités renvoyées, composants ou empreintes, dépendent du périmètre choisi, défini à l’aide du champ Search in de la boîte de dialogue de recherche dans les bibliothèques de fichiers.
-
Tous les résultats sont affichés dans la liste Query Results du panneau Composants.
Nom de la bibliothèque
Résumé
Renvoie tous les composants ou empreintes dont le nom de la bibliothèque parente satisfait à la requête.
Syntaxe
LibraryName : String
Exemples d’utilisation
LibraryName = 'Miscellaneous Devices.SchLib'
Renvoie tous les composants dont la bibliothèque parente est Miscellaneous Devices.SchLib.
LibraryName Like 'Miscellaneous*.IntLib'
Renvoie tous les composants ou empreintes dont le nom de la bibliothèque parente commence par Miscellaneous et se termine par .IntLib.
LibraryName Like '*Vishay*'
Renvoie tous les composants dont le nom de la bibliothèque parente contient Vishay.
Remarques
-
Les entités renvoyées, composants ou empreintes, dépendent du périmètre choisi, défini à l’aide du champ Search in de la boîte de dialogue de recherche dans les bibliothèques de fichiers.
-
Lors de la recherche de composants, toutes les bibliothèques SchLib, IntLib et DbLib disponibles ou situées sur un chemin de recherche défini sont interrogées. Lors de la recherche d’empreintes, toutes les bibliothèques PcbLib et IntLib sont interrogées.
-
Tous les résultats sont affichés dans la liste Query Results du panneau Composants.
Chemin de la bibliothèque
Résumé
Renvoie tous les composants ou empreintes présents dans la bibliothèque spécifiée dans la requête.
Syntaxe
LibraryPath : String
Exemples d’utilisation
LibraryPath = 'C:\Documents\Altium\Library\MyExampleLibrary.SchLib'
Renvoie tous les composants dont la bibliothèque parente est MyExampleLibrary.SchLib et se trouve dans le dossier C:\Documents\Altium\Library.
LibraryPath Like ' C:\Documents\Altium\Library\Miscellaneous*.IntLib'
Renvoie tous les composants ou empreintes dont le nom de la bibliothèque parente commence par Miscellaneous et se termine par .IntLib, et dont cette bibliothèque se trouve dans le dossier C:\Documents\Altium\Library.
LibraryPath = 'C:\Test Projects\Example DBLib\VishayCapacitor.DBLib'
Renvoie tous les composants dont la bibliothèque parente est VishayCapacitor.DBLib et se trouve dans le dossier C:\Test Projects\Example DBLib.
Remarques
-
Les entités renvoyées, composants ou empreintes, dépendent du périmètre choisi, défini à l’aide du champ Search in de la boîte de dialogue de recherche dans les bibliothèques de fichiers.
-
Lors de la recherche de composants, toutes les bibliothèques SchLib, IntLib et DbLib disponibles sur le chemin de bibliothèque défini sont interrogées. Lors de la recherche d’empreintes, toutes les bibliothèques PcbLib et IntLib sont interrogées.
-
Tous les résultats sont affichés dans la liste Query Results du panneau Composants.
Nom
Résumé
Renvoie tous les composants ou empreintes dont le nom satisfait à la requête.
Syntaxe
Name : String
Exemples d’utilisation
Name = 'Res1'
Renvoie tous les composants ou empreintes dont le nom est Res1.
Name Like 'DIP*'
Renvoie tous les composants ou empreintes dont le nom commence par DIP.
Name Like '*33*'
Renvoie tous les composants ou empreintes dont le nom contient 33.
Remarques
-
Les entités renvoyées, composants ou empreintes, dépendent du périmètre choisi, défini à l’aide du champ Search in de la boîte de dialogue de recherche dans les bibliothèques de fichiers.
-
Lors de la recherche de composants, toutes les bibliothèques SchLib et IntLib disponibles ou situées sur un chemin de recherche défini sont interrogées. Lors de la recherche d’empreintes, toutes les bibliothèques PcbLib et IntLib sont interrogées.
-
Tous les résultats sont affichés dans la liste Query Results, dans le panneau Composants.
-
Le nom d’un composant de schéma est vérifié à l’aide de sa propriété Design Item ID , et le nom d’une empreinte PCB est vérifié à l’aide de sa propriété Footprint .
Nom de la bibliothèque source
Résumé
Renvoie tous les composants ou empreintes dont le nom de la bibliothèque source parente satisfait à la requête.
Syntaxe
SourceLibraryName : String
Exemples d’utilisation
SourceLibraryName = 'Miscellaneous Devices.SchLib'
Renvoie tous les composants dont la bibliothèque source parente est Miscellaneous Devices.SchLib.
SourceLibraryName = 'Miscellaneous Devices.PcbLib '
Renvoie toutes les empreintes dont la bibliothèque source parente est Miscellaneous Devices.PcbLib.
Remarques
-
Les entités renvoyées, composants ou empreintes, dépendent du périmètre choisi, défini à l’aide du champ Search in dans la boîte de dialogue Recherche dans les bibliothèques de fichiers.
-
Lors de la recherche de composants, seules les bibliothèques sources de schémas — disponibles ou situées dans un chemin de recherche défini — seront interrogées. Seules les bibliothèques PCB seront interrogées lors de la recherche d’empreintes.
-
Tous les résultats sont affichés dans la liste Query Results du panneau Composants.
Chemin de la bibliothèque source
Résumé
Renvoie tous les composants ou toutes les empreintes qui se trouvent dans la bibliothèque source spécifiée dans la requête.
Syntaxe
SourceLibraryPath : String
Exemples d’utilisation
SourceLibraryPath = ' C:\Documents\Altium\Library\MyExampleLibrary.SchLib'
Renvoie tous les composants dont la bibliothèque source parente est MyExampleLibrary.SchLib et dont cette bibliothèque se trouve dans le dossier C:\Documents\Altium\Library.
SourceLibraryPath = ' C:\Documents\Altium\Library\Miscellaneous Devices.PcbLib'
Renvoie toutes les empreintes dont la bibliothèque source parente est Miscellaneous Devices.PcbLib et dont cette bibliothèque se trouve dans le dossier C:\Documents\Altium\Library.
SourceLibraryPath Like ' C:\Documents\Altium\Library\*'
Renvoie tous les composants ou toutes les empreintes dont la bibliothèque source parente se trouve dans le dossier C:\Documents\Altium\Library.
Remarques
-
Les entités renvoyées, composants ou empreintes, dépendent du périmètre choisi, défini à l’aide du champ Search in dans la boîte de dialogue Recherche dans les bibliothèques de fichiers.
-
Lors de la recherche de composants, seules les bibliothèques de schémas — disponibles dans le chemin de bibliothèque défini — seront interrogées. Seules les bibliothèques PCB seront interrogées lors de la recherche d’empreintes.
-
Tous les résultats sont affichés dans la liste Query Results du panneau Composants.
Empreintes
Hauteur
Résumé
Renvoie toutes les empreintes dont la propriété Height satisfait à la requête.
Syntaxe
Height : Number
Number utilisera les unités de mesure actuellement définies pour la bibliothèque : impériales (mil ; 1 mil = 0,001 pouce) ou métriques (mm ; 1 mm = 0,001 mètre).
Exemples d’utilisation
Height = 300
Renvoie toutes les empreintes dont la propriété Height est égale à 300 dans les unités de mesure actuelles.
Height >= 5.08
Renvoie toutes les empreintes dont la propriété Height est supérieure ou égale à 5.08 dans les unités de mesure actuelles.
Height <> 550
Renvoie toutes les empreintes dont la propriété Height est not égale à 550 dans les unités de mesure actuelles.
Remarques
-
Assurez-vous que le périmètre de recherche est défini sur Components à l’aide du champ Search in dans la boîte de dialogue Recherche dans les bibliothèques de fichiers.
-
Lors de la recherche d’empreintes, toutes les bibliothèques PcbLib et IntLib — disponibles ou situées dans un chemin de recherche défini — seront interrogées.
-
Tous les résultats sont affichés dans la liste Query Results du panneau Composants.
Nombre de pastilles
Résumé
Renvoie toutes les empreintes dont la propriété Pad Count satisfait à la requête.
Syntaxe
PadCount : Number
Exemples d’utilisation
PadCount = 2
Renvoie toutes les empreintes dont la propriété Pad Count est égale à 2.
PadCount > 14
Renvoie toutes les empreintes dont la propriété Pad Count est supérieure à 14.
Remarques
-
Assurez-vous que le périmètre de recherche est défini sur Components à l’aide du champ Search in dans la boîte de dialogue Recherche dans les bibliothèques de fichiers.
-
Lors de la recherche d’empreintes, toutes les bibliothèques PcbLib et IntLib — disponibles ou situées dans un chemin de recherche défini — seront interrogées.
-
Tous les résultats sont affichés dans la liste Query Results du panneau Composants.