Creazione di un modello di simulazione
A colpo d'occhio
- Come creare o reperire i modelli di simulazione, utilizzando file scaricati dai produttori, modelli testuali copiati e file di sottocircuito scritti manualmente.
- Come creare, salvare, collegare e modificare i modelli di simulazione del Workspace in Altium Designer e in un Workspace connesso.
- Quali informazioni sono necessarie per definire correttamente un modello di simulazione, inclusi i nomi dei modelli, i file di riferimento e i parametri a livello di modello.
Per simulare un progetto circuitale utilizzando il simulatore circuitale a segnali misti di Altium Designer, tutti i componenti del circuito devono essere predisposti per la simulazione, ovvero ciascuno deve avere un modello di simulazione collegato.
Il tipo di modello e il modo in cui viene ottenuto dipendono in larga misura dal componente e, in parte, dalle preferenze personali del progettista. Molti produttori di dispositivi forniscono modelli di simulazione corrispondenti ai dispositivi che producono. In genere, è sufficiente scaricare il file del modello richiesto e collegarlo al componente nello schema elettrico. Per saperne di più, consulta Aggiunta di modelli di simulazione al progetto.
Alcuni modelli potrebbero dover essere scritti da zero, ad esempio utilizzando la sintassi gerarchica dei sottocircuiti per creare il file del modello di sottocircuito richiesto (*.ckt).
Creazione di un nuovo modello di simulazione
Alcuni modelli sono messi a disposizione da produttori e fornitori come file di testo scaricabili. A volte i dettagli del modello sono presentati come testo in una pagina del browser anziché come file da scaricare; in questo caso, puoi creare un nuovo file di modello in Altium Designer e copiare e incollare il contenuto dalla pagina del browser nel nuovo file di modello. Utilizza il comando pertinente nel sottomenu File » New » Mixed Simulation, come mostrato di seguito.

Comandi per creare un nuovo file di modello vuoto.
Puoi quindi copiare e incollare le informazioni del file di modello nell'editor dei modelli.

Esempio di contenuto testuale di un modello di simulazione.
Creazione di un modello di simulazione del Workspace
Altium Designer, insieme a un Workspace connesso, consente di creare e gestire modelli di simulazione del Workspace. Una volta creato, un modello di simulazione del Workspace può essere utilizzato per creare uno o più componenti del Workspace.
Sebbene i modelli di simulazione del Workspace vengano creati automaticamente quando aggiungi un file di modello di simulazione a un componente in fase di definizione nell'editor dei componenti in modalità di modifica di un singolo componente e poi salvi il componente nel Workspace, puoi anche creare modelli di simulazione del Workspace direttamente nel Workspace, come descritto di seguito.
-
Apri il pannello Components e abilita la visualizzazione dei modelli facendo clic sul pulsante
nella parte superiore del pannello e selezionando Models.

Abilita la visualizzazione di Models nel pannello Components -
Vai alla categoria Simulations e seleziona Create Component dal menu del pulsante
.

Accedi ai modelli di simulazione nel pannello Components e seleziona il comando per creare un nuovo modello -
Nella finestra di dialogo Create New Item che si apre, inserisci le informazioni richieste, assicurati che l'opzione Open for editing after creation sia abilitata e fai clic su OK. Verrà creato il modello di simulazione del Workspace e si aprirà l'editor temporaneo SimModel, con un documento
.SimModelattivo nell'area di progettazione. Questo documento verrà denominato in base alla revisione dell'elemento, nel formato:<Item><Revision>.SimModel(ad esempio,SIM-001-0001-1.SimModel).
Esempio di modifica della revisione iniziale di un modello di simulazione del Workspace: l'editor temporaneo SimModel fornisce il documento con cui definire il modello di simulazione. - Utilizza il documento per definire il modello di simulazione del Workspace secondo le tue esigenze. Per ulteriori informazioni, consulta Definizione del modello di simulazione.
- Salva il modello nel Workspace utilizzando il controllo Save to Server a destra della voce del modello di simulazione nel pannello Projects. Verrà visualizzata la finestra di dialogo Edit Revision, in cui puoi modificare il nome e la descrizione e aggiungere note di rilascio secondo necessità. Il documento e l'editor si chiuderanno dopo il salvataggio.
-
Il documento contenente la definizione sorgente del modello di simulazione,
*.SimModel, verrà memorizzato nella revisione del modello di simulazione del Workspace. Il modello di simulazione verrà visualizzato nel pannello Components, nella categoria Simulations.
Un modello di simulazione del Workspace salvato nel pannello ComponentsI dati salvati nel Workspace comprendono la definizione del modello nel file
.SimModel, nonché eventuali file.mdlo.cktreferenziati. Nel pannello Explorer, passa alla scheda della vista Preview, quindi fai clic su un file referenziato per visualizzare un'anteprima del suo contenuto. Ove applicabile, verranno visualizzati anche i parametri a livello di modello.
Esamina il modello di simulazione del Workspace salvato nel pannello Explorer. Passa alla scheda della vista Preview per vedere i dati salvati.
Un modello di simulazione del Workspace salvato può quindi essere collegato a un componente del Workspace durante la definizione del componente nell'editor dei componenti, in modalità modifica di un singolo componente o modifica in batch dei componenti.
Definizione del modello di simulazione
Le informazioni necessarie per definire il modello in un file SimModel sono le seguenti:
-
Model Name – utilizzare questo campo per specificare il nome del modello. Quando viene salvata nel Workspace, questa voce verrà utilizzata come Name della revisione dell'elemento Modello di simulazione.
Quando si fa riferimento a un file MDL, il nome deve essere quello presente nella riga
.MODELdella definizione del modello. Si consideri un modello di diodo con la seguente definizione:.MODEL 1N4002 D(IS=2.55E-9 RS=0.042 N=1.75 TT=5.76E-6 CJO=1.85E-11 + VJ=0.75 M=0.333 BV=100 IBV=1E-5 )Il nome del modello in questo caso è
1N4002. Questo è il nome da inserire nel campo Model Name.Quando si fa riferimento a un file CKT, il nome deve essere quello presente nella riga
.SUBCKTdella definizione del modello. Si consideri un modello di fusibile con la seguente definizione:.SUBCKT FUSE 1 2 PARAMS: CURRENT=1 RESISTANCE=1m SW1 1 2 3 0 SMOD OFF BNLV 3 0 V=(abs(v(1,2)))
.MODEL SMOD SW (VT=\{(CURRENT*RESISTANCE)\} RON=1g ROFF=\{RESISTANCE\})
.ENDS FUSEIl nome del modello in questo caso è
FUSE. Questo è il nome da inserire nel campo Model Name. -
Model File – per un modello definito utilizzando un file
.mdlo.ckt, utilizzare il pulsante Browse per selezionare il file richiesto da una libreria disponibile. - Description – inserire una descrizione del modello, ad esempio il suo scopo. Quando viene salvata nel Workspace, questa voce verrà utilizzata come Description della revisione del modello di simulazione.
- Parameters – parametri a livello di modello (vedere Parametri a livello di modello).
-
Model Preview – visualizzazione in sola lettura del contenuto del file
.mdlo.ckta cui si fa riferimento.
Parametri a livello di modello
Ove applicabile, i parametri a livello di modello possono essere definiti direttamente nel file SimModel, poiché fanno naturalmente parte della definizione di un modello. L'area Parameters del documento verrà popolata automaticamente con i parametri applicabili al modello scelto. I valori dei parametri possono essere modificati direttamente sul posto: fare clic sul campo Parameter Value associato a un parametro nell'elenco e inserire direttamente il valore richiesto.

Definire i parametri del modello come parte della sua definizione, modificandoli direttamente sul posto.
Modifica di un modello di simulazione del Workspace
In qualsiasi momento, è possibile tornare a un modello di simulazione del Workspace e modificarlo direttamente. Selezionare la categoria Simulations nel pannello Components (per accedere a questa categoria, l'opzione Models deve essere abilitata nel menu
del pannello), fare clic con il pulsante destro del mouse sulla voce di un modello di simulazione e scegliere il comando Edit dal menu contestuale. Si aprirà nuovamente l'editor temporaneo, con il file (contenente la definizione sorgente del modello di simulazione) incluso nel modello di simulazione del Workspace, aperto per la modifica. Apportare le modifiche necessarie, quindi salvare il documento nella revisione successiva del modello di simulazione del Workspace.
Generazione di file SimModel
I file SimModel possono essere generati dal documento di libreria schematica o di libreria database attivo utilizzando il comando Tools » Generate SimModel Files.
Dopo aver avviato il comando, verrà visualizzata la finestra di dialogo Generate SimModel Files. Ogni file SimModel (e la definizione del modello di simulazione che contiene) viene creato in base al collegamento al modello di simulazione di un componente schematico nella libreria schematica attiva (o alle informazioni di simulazione di un record di componente nella libreria database attiva). Utilizzare i controlli della finestra di dialogo per configurare la generazione di uno o più file SimModel secondo necessità. Per impostazione predefinita, verrà creata una sottocartella denominata Sim Models. Se necessario, sostituire questo nome con uno più adatto. Se la cartella specificata esiste, verrà utilizzata; in caso contrario, verrà creata.

La finestra di dialogo Generate SimModel Files
Dopo aver definito le opzioni secondo necessità, fare clic su OK. La generazione verrà avviata e, al termine del processo, verrà visualizzata una finestra di dialogo di conferma che indica quanti file SimModel sono stati generati. Anche gli eventuali file .mdl, .ckt o .scb a cui si fa riferimento verranno archiviati insieme ai file SimModel.
Se si esegue la migrazione da una libreria integrata, è possibile ottenere le librerie schematiche sorgente (SchLib) aprendo il file IntLib in Altium Designer e scegliendo di estrarre le librerie sorgente. Quando si generano file SimModel da una libreria database, verranno presi in considerazione solo i componenti delle tabelle attualmente abilitate.
La denominazione dei file SimModel dipende dal tipo di libreria sorgente:
- Schematic Library - ogni file SimModel viene denominato utilizzando il nome del modello di simulazione. Se più componenti schematici includono la stessa implementazione del modello di simulazione (modello di simulazione con lo stesso nome), verrà generato un solo file SimModel, utilizzando quel nome.
- Database Library - ogni file SimModel viene denominato utilizzando il nome del modello di simulazione, come specificato nel campo Sim Model Name di un record di componente. Se più record di componenti (nelle tabelle abilitate) includono la stessa implementazione del modello di simulazione (stessa voce nel campo Sim Model Name), verrà generato un solo file SimModel, utilizzando quel nome.
Procedura guidata per i modelli SPICE
Alcuni modelli di dispositivi analogici integrati in SPICE prevedono un file di modello associato (*.mdl) in cui definire parametricamente caratteristiche comportamentali avanzate (ad esempio, resistore a semiconduttore, diodo, BJT). Creare manualmente questo file di modello e poi collegarlo al componente desiderato nello schema può essere piuttosto laborioso. SPICE Model Wizard semplifica questa attività. Utilizzando la procedura guidata, è possibile definire le caratteristiche di un dispositivo di questo tipo in base ai dati acquisiti dall'utente. I parametri, immessi direttamente o estratti dai dati forniti, vengono scritti automaticamente in un file di modello, che viene poi collegato al componente designato nello schema.
SPICE Model Wizard offre una soluzione pratica e semiautomatica per creare e collegare un modello di simulazione SPICE per diversi dispositivi analogici: dispositivi integrati in SPICE che richiedono un file di modello collegato (*.mdl). Le caratteristiche comportamentali del modello vengono definite in base alle informazioni fornite alla procedura guidata. La quantità di informazioni richieste dipende dal tipo di dispositivo per cui si desidera creare un modello: dalla semplice immissione dei parametri del modello all'inserimento di dati del dispositivo ricavati dalla scheda tecnica del produttore o da misurazioni effettuate sul dispositivo fisico.
Le sezioni seguenti illustrano l'utilizzo della procedura guidata, dall'accesso alla verifica.
Accesso alla procedura guidata
Per accedere alla procedura guidata dall'editor dei simboli schematici, scegliere il comando Tools » XSpice Model Wizard dai menu principali.

La pagina iniziale di SPICE Model Wizard
Nelle due pagine successive della procedura guidata sarà possibile scegliere:
- Il dispositivo specifico da modellare, dall'elenco dei tipi di dispositivo supportati.
- Se aggiungere il modello SPICE generato successivamente a un componente esistente nel documento di libreria oppure a un nuovo componente creato dalla procedura guidata e aggiunto a tale documento.
Tipi di dispositivo supportati
La procedura guidata consente di creare modelli SPICE per i seguenti tipi di dispositivi analogici:
- Diodo
- Condensatore a semiconduttore
- Resistore a semiconduttore
- Interruttore controllato in corrente
- Interruttore controllato in tensione
- Transistor a giunzione bipolare
- Linea di trasmissione con perdite
- Linea di trasmissione RC a parametri distribuiti uniformi
Assegnazione del nome al modello
Uno dei passaggi più importanti durante l'esecuzione della procedura guidata è assegnare un nome al modello che si sta creando. Infatti, non è possibile passare alla fase di definizione dei parametri della procedura guidata finché non viene immesso un nome.
Dopo la creazione, questo nome apparirà nel campo Model Name della finestra di dialogo Sim Model. Anche il file di modello viene creato con questo nome (<ModelName>.mdl). Quando si utilizza la procedura guidata per aggiungere un modello a un nuovo componente di libreria, il nome specificato per il modello viene utilizzato anche per il componente.
Quando si assegna un nome al modello, è anche possibile immettere una breve descrizione. Può trattarsi della funzione del modello (ad esempio, Semiconductor Resistor) oppure di un riferimento più specifico a un valore o a una configurazione (ad esempio, NPN BJT).
Caratteristiche da modellare
Dopo aver assegnato un nome al modello, si passerà a una o più pagine dedicate alle caratteristiche da modellare. I tipi di modello supportati dalla procedura guidata possono essere suddivisi nei due gruppi seguenti:
- Modelli che richiedono l'immissione diretta dei valori dei vari parametri del modello. Per ulteriori informazioni, consultare la sezione Modelli di dispositivo creati mediante immissione diretta dei parametri.
- Modelli che richiedono l'immissione di dati da cui estrarre i parametri che definiscono le caratteristiche del dispositivo scelte. I dati immessi sono ricavati da misurazioni dirette sul dispositivo fisico oppure dalla scheda tecnica del produttore. Per ulteriori informazioni, consultare la sezione Modelli di dispositivo creati mediante estrazione dei parametri dai dati.
Generazione del modello
Dopo aver definito i dati/parametri richiesti, la procedura guidata visualizza il modello generato. Questo è il contenuto che verrà salvato nel file MDL.

Anteprima del contenuto del file di modello generato.
È possibile modificare il modello direttamente in questa pagina, per avere il massimo controllo sulla sua definizione.
Una volta soddisfatti della definizione del modello, fare clic su Next per passare alla fine della procedura guidata. Facendo clic su Finish sarà possibile salvare il modello. Utilizzare la finestra di dialogo Save SPICE Model File per stabilire dove salvare il file MDL risultante. Per impostazione predefinita, il file viene salvato nella stessa cartella del documento di libreria degli schemi. In questa fase è anche possibile modificare il nome del file, se lo si desidera.
Se è stato richiesto di associare il modello a un nuovo componente, tale componente verrà creato e aggiunto al documento di libreria.
Modelli di dispositivo creati mediante immissione diretta dei parametri
Per i seguenti modelli di dispositivo, la procedura guidata non estrae le informazioni sui parametri dai dati immessi. I modelli vengono invece creati mediante l'immissione diretta dei valori dei parametri associati. Quando si immettono i valori dei parametri, occorre tenere presente quanto segue:
- Se non si specifica un valore per un parametro, nel file di modello creato non verrà inserita alcuna voce corrispondente. In questo caso, verrà utilizzato il valore predefinito memorizzato internamente in SPICE. In altre parole, se si specifica il valore di un parametro in un file di modello, tale valore sostituisce il valore predefinito del parametro.
- Se la voce predefinita per un parametro nella procedura guidata è '-' e non viene immesso esplicitamente un valore per tale parametro, nei calcoli verrà utilizzato il valore predefinito zero, interno a SPICE.
Condensatore a semiconduttore
Per questo modello di dispositivo, la procedura guidata consente di definire i seguenti parametri. Immettendo un valore, il parametro corrispondente verrà scritto nel file MDL generato.
CJ |
Capacità del fondo della giunzione (in F/m²). |
|
CJSW |
Capacità delle pareti laterali della giunzione (in F/m). |
|
DEFW |
Larghezza predefinita del dispositivo (in metri). (Valore predefinito = 1e-6). |
|
NARROW |
Restringimento dovuto all'incisione laterale (in metri). (Valore predefinito = 0). |
Resistore a semiconduttore
I seguenti parametri possono essere definiti per questo modello di dispositivo tramite la procedura guidata. Inserendo un valore, il relativo parametro verrà scritto nel file MDL generato.
TC1 |
Coefficiente di temperatura del primo ordine (in ohm/˚C). (Valore predefinito = 0) |
|
TC2 |
Coefficiente di temperatura del secondo ordine (in ohm/˚C²). (Valore predefinito = 0) |
|
RSH |
Resistenza di strato (in ohm). |
|
DEFW |
Larghezza predefinita (in metri). (Valore predefinito = 1e-6). |
|
NARROW |
Restringimento dovuto all'incisione laterale (in metri). (Valore predefinito = 0). |
|
TNOM |
Temperatura di misurazione dei parametri (in ˚C). Se non viene specificato alcun valore, verrà utilizzato il valore predefinito assegnato a TNOM nella scheda Advanced della finestra di dialogo Advanced Analyses Settings (Valore predefinito = 27). |
Interruttore controllato in corrente
I seguenti parametri possono essere definiti per questo modello di dispositivo tramite la procedura guidata. Inserendo un valore, il relativo parametro verrà scritto nel file MDL generato.
IT |
Corrente di soglia (in ampere). (Valore predefinito = 0). |
|
IH |
Corrente di isteresi (in ampere). (Valore predefinito = 0). |
|
RON |
Resistenza nello stato ON (in ohm). (Valore predefinito = 1). |
|
ROFF |
Resistenza nello stato OFF (in ohm). Per impostazione predefinita, è impostata su 1/GMIN. GMIN è un parametro SPICE avanzato, specificato nella scheda Advanced della finestra di dialogo Advanced Analyses Settings. Imposta la conduttanza minima (resistenza massima) di qualsiasi dispositivo nel circuito. Il suo valore predefinito è 1e-12 mho, che determina un valore predefinito di ROFF pari a 1000G ohm. |
Interruttore controllato in tensione
I seguenti parametri possono essere definiti per questo modello di dispositivo tramite la procedura guidata. Inserendo un valore, il relativo parametro verrà scritto nel file MDL generato.
VT |
Tensione di soglia (in volt). (Valore predefinito = 0). |
|
VH |
Tensione di isteresi (in volt). (Valore predefinito = 0). |
|
RON |
Resistenza nello stato ON (in ohm). (Valore predefinito = 1). |
|
ROFF |
Resistenza nello stato OFF (in ohm). Per impostazione predefinita, è impostata su 1/GMIN. GMIN è un parametro SPICE avanzato, specificato nella scheda Advanced della finestra di dialogo Advanced Analyses Settings. Imposta la conduttanza minima (resistenza massima) di qualsiasi dispositivo nel circuito. Il suo valore predefinito è 1e-12 mho, che determina un valore predefinito di ROFF pari a 1000G ohm. |
Linea di trasmissione con perdite
I seguenti parametri possono essere definiti per questo modello di dispositivo tramite la procedura guidata. Inserendo un valore (o attivando un flag), il relativo parametro verrà scritto nel file MDL generato.
R |
Resistenza per unità di lunghezza (in ohm/unità). (Valore predefinito = 0). |
|
L |
Induttanza per unità di lunghezza (in henry/unità). (Valore predefinito = 0). |
|
G |
Conduttanza per unità di lunghezza (in mho/unità). (Valore predefinito = 0). |
|
C |
Capacità per unità di lunghezza (in farad/unità). (Valore predefinito = 0). |
|
LEN |
Lunghezza della linea di trasmissione. |
|
REL |
Controllo dei punti di interruzione (in unità arbitrarie). (Valore predefinito = 1). |
|
ABS |
Controllo dei punti di interruzione (in unità arbitrarie). (Valore predefinito = 1). |
|
NOSTEPLIMIT |
Flag che, se attivato, rimuove il vincolo che limita i passi temporali a valori inferiori al ritardo della linea. (Impostazione predefinita = disattivato). |
|
NOCONTROL |
Flag che, se attivato, impedisce la limitazione del passo temporale in base ai criteri di errore di convoluzione. (Impostazione predefinita = disattivato). |
|
LININTERP |
Flag che, se attivato, utilizza l'interpolazione lineare anziché l'interpolazione quadratica predefinita per il calcolo dei segnali ritardati. (Impostazione predefinita = disattivato). |
|
MIXEDINTERP |
Flag che, se attivato, utilizza una metrica per determinare se l'interpolazione quadratica è applicabile e, in caso contrario, utilizza l'interpolazione lineare. (Impostazione predefinita = disattivato). |
|
COMPACTREL |
Grandezza specifica utilizzata per controllare la compattazione dei valori storici utilizzati per la convoluzione. Per impostazione predefinita, questa grandezza utilizza il valore specificato per il parametro di tolleranza dell'errore relativo di simulazione (RELTOL), definito nella scheda Advanced della finestra di dialogo Advanced Analyses Settings. |
|
COMPACTABS |
Grandezza specifica utilizzata per controllare la compattazione dei valori storici utilizzati per la convoluzione. Per impostazione predefinita, questa grandezza utilizza il valore specificato per il parametro di tolleranza dell'errore assoluto di corrente (ABSTOL), definito nella scheda Advanced della finestra di dialogo Advanced Analyses Settings. |
|
TRUNCNR |
Flag che, se attivato, abilita l'uso del metodo iterativo di Newton-Raphson per determinare un passo temporale appropriato nelle routine di controllo del passo temporale. (Impostazione predefinita = disattivato; in questo caso viene utilizzato un metodo per tentativi, dimezzando ogni volta il passo temporale precedente). |
|
TRUNCDONTCUT |
Flag che, se attivato, elimina la riduzione predefinita del passo temporale applicata per limitare gli errori nel calcolo effettivo delle grandezze relative alla risposta impulsiva. (Impostazione predefinita = disattivato). |
Linea di trasmissione RC a parametri distribuiti uniformi
I seguenti parametri possono essere definiti per questo modello di dispositivo tramite la procedura guidata. Inserendo un valore, il relativo parametro verrà scritto nel file MDL generato.
K |
Costante di propagazione. (Valore predefinito = 2). |
|
FMAX |
Frequenza massima di interesse (in hertz). (Valore predefinito = 1.0G). |
|
RPERL |
Resistenza per unità di lunghezza (in ohm/metro). (Valore predefinito = 1000). |
|
CPERL |
Capacità per unità di lunghezza (in farad/metro). (Valore predefinito = 1.0e-15). |
|
ISPERL |
Corrente di saturazione per unità di lunghezza (in ampere/metro). (Valore predefinito = 0). |
|
RSPERL |
Resistenza del diodo per unità di lunghezza (in ohm/metro). (Valore predefinito = 0). |
Modelli di dispositivi creati mediante estrazione dei parametri dai dati
Per i diodi e i BJT, la procedura guidata estrae le informazioni sui parametri dai dati immessi. I parametri specifici estratti per essere inclusi nel file del modello dipendono dalle particolari caratteristiche del diodo o del BJT che si è scelto di modellare.
Il metodo di immissione dei dati varia in base alle caratteristiche. In alcuni casi è necessario immettere direttamente valori numerici, in altri dati ricavati da grafici. In ogni caso, tutti i dati provengono da misurazioni dirette sul dispositivo, dalla scheda tecnica del produttore o da una combinazione delle due fonti.
Quando è richiesto di immettere dati ricavati da grafici, inserire nella griglia della procedura guidata una serie di punti ricavati dal grafico di origine. Se i dati sono memorizzati in formato con valori separati da virgole (*.csv), è possibile importarli utilizzando il pulsante Import Data disponibile. La procedura guidata utilizza i dati immessi per estrarre i parametri richiesti dal modello. I risultati dell'estrazione vengono presentati in una pagina successiva della procedura guidata, sotto forma dei valori dei parametri estratti e di un grafico di confronto tra i dati immessi e i valori calcolati utilizzando tali parametri. L'immagine seguente mostra un esempio di questa visualizzazione dei risultati.

Immettere i dati di origine per consentire alla procedura guidata di estrarre i parametri richiesti dal modello.
È possibile modificare i valori dei parametri estratti per migliorare ulteriormente l'accuratezza del modello del diodo. Il confronto grafico viene aggiornato per riflettere le modifiche.
Diodo
Le sezioni seguenti descrivono in dettaglio ciascuna delle caratteristiche che è possibile scegliere di modellare per un diodo. Ogni sezione illustra i parametri estratti e i dati di origine richiesti dalla procedura guidata per consentirne l'estrazione.
Corrente in polarizzazione diretta
I seguenti parametri vengono utilizzati per descrivere le caratteristiche corrente-tensione in continua del diodo nella regione di polarizzazione diretta:
IS |
Corrente di saturazione (in ampere). |
|
N |
Coefficiente di emissione. |
|
RS |
Resistenza ohmica (in ohm). |
Per estrarre questi parametri è necessario un grafico della corrente diretta del diodo (IF) in funzione della tensione diretta del diodo (VF). Questo grafico può essere ricavato dalla scheda tecnica del produttore oppure da misurazioni eseguite su un dispositivo fisico.
L'immagine seguente mostra un esempio di tale grafico, tratto da una scheda tecnica, e un esempio di circuito di prova sul quale è possibile eseguire misurazioni dirette per ottenere i dati di origine richiesti.

Esempio di grafico e circuito per le caratteristiche I-V del diodo nella regione di polarizzazione diretta.
I dati vengono immessi nella procedura guidata come una serie di punti ricavati dal grafico di origine.
Capacità di giunzione in polarizzazione inversa
I seguenti parametri vengono utilizzati per descrivere la capacità del diodo quando opera nella regione di polarizzazione inversa:
CJO |
Capacità di giunzione a polarizzazione nulla (in farad). |
|
M |
Coefficiente di gradazione. |
|
VJ |
Potenziale di giunzione (in volt). |
Per estrarre questi parametri è necessario un grafico della capacità in polarizzazione inversa (Cd) in funzione della tensione inversa del diodo (VR). Questo grafico può essere ricavato dalla scheda tecnica del produttore oppure da misurazioni eseguite su un dispositivo fisico.
L'immagine mostra un esempio di tale grafico, tratto da una scheda tecnica, e un esempio di circuito di prova sul quale è possibile eseguire misurazioni dirette per ottenere i dati di origine richiesti. Quest'ultimo può essere utilizzato se non si dispone di un capacimetro.

Esempio di grafico e circuito per la capacità del diodo nella regione di polarizzazione inversa.
I dati vengono immessi nella procedura guidata come una serie di punti ricavati dal grafico di origine.
Il circuito di esempio nell'immagine precedente si basa sull'equazione:
I = C * (dv/dt)
Risolvendo questa equazione rispetto a C si ottiene:
C = I/(dv/dt)
Il circuito genera una rampa di tensione a partire dalla sorgente V1. Calcolando la pendenza di questa rampa di tensione è possibile ottenere il termine dv/dt dell'equazione. Dividendo la corrente misurata nel diodo per la pendenza della rampa di tensione, è possibile ottenere la curva della capacità del diodo.
Corrente in polarizzazione inversa
I seguenti parametri vengono utilizzati per descrivere la corrente del dispositivo in polarizzazione inversa dopo il breakdown:
BV |
Tensione di breakdown inverso (in volt). |
|
IBV |
Corrente alla tensione di breakdown (in ampere). |
Per estrarre questi parametri, la procedura guidata richiede l'immissione dei due valori seguenti:
-
Valore della tensione di breakdown inverso.
-
Valore della corrente che attraversa il diodo nel punto di breakdown inverso.
Questi valori possono essere ricavati dalla scheda tecnica del produttore oppure da misurazioni eseguite su un dispositivo fisico. Le schede tecniche riportano generalmente le caratteristiche elettriche in continua (DC) di un diodo in forma tabellare: è quindi sufficiente individuare questi valori e immetterli esattamente come riportati.
Se i dati di origine sono in forma grafica, come avviene tipicamente per le misurazioni effettuate direttamente su un dispositivo fisico, è necessario leggere questi due valori nel punto in cui il diodo entra in breakdown. L'immagine seguente mostra un esempio di tale grafico.

Determinazione grafica dei valori di corrente e tensione nel punto di breakdown inverso.
Anche se i valori visualizzati sul grafico possono essere negativi, nei rispettivi campi della procedura guidata devono essere immessi esclusivamente come valori positivi.
Caratteristiche di recupero inverso
Il seguente parametro viene utilizzato per modellare il tempo di recupero inverso del diodo durante la commutazione dalla polarizzazione diretta a quella inversa:
TT |
Tempo di transito (in secondi). |
Per estrarre questo parametro, la procedura guidata richiede l'immissione del tempo di recupero inverso del diodo (Trr), nel punto in cui la corrente diretta è uguale alla corrente inversa (ovvero IR/IF=1). Questo dato si trova generalmente nelle schede tecniche dei produttori di diodi di commutazione sotto forma di semplici valori numerici.
L'immagine seguente mostra come questa informazione viene presentata nella scheda tecnica di un produttore. Il valore di interesse nell'immagine – quello da immettere nella procedura guidata – è 4ns.

Determinazione del tempo di recupero inverso di un diodo.
Transistor a giunzione bipolare (BJT)
Quando si crea un modello di transistor a giunzione bipolare (BJT), la procedura guidata per i modelli SPICE richiede di scegliere i dati di origine da cui estrarre le informazioni sui parametri:
- Dati misurati – selezionare questa opzione se i dati di origine provengono da misurazioni effettuate sul dispositivo fisico e si desidera sviluppare un modello accurato che descriva tutti gli aspetti del comportamento in continua.
- Scheda tecnica del produttore – selezionare questa opzione se i dati di origine provengono da una scheda tecnica. Le schede tecniche generalmente non contengono il livello di informazioni necessario per modellare tutti gli aspetti del dispositivo BJT. Tuttavia, in genere contengono informazioni sufficienti per creare un modello del dispositivo da utilizzare esclusivamente nella regione attiva diretta.
Le differenze tra queste due opzioni riguardano principalmente le modalità di estrazione dei parametri che modellano le caratteristiche corrente-tensione in continua del BJT. Per quanto riguarda le capacità delle giunzioni polarizzate inversamente e i tempi di transito, le modalità di estrazione dei parametri sono identiche per entrambe le opzioni.
Le sezioni seguenti descrivono in dettaglio ciascuna delle caratteristiche che è possibile modellare per un dispositivo BJT, in relazione al tipo di dati di origine (dati misurati o scheda tecnica). Vengono illustrati i parametri estratti in ciascun caso e i dati di origine richiesti dalla procedura guidata per consentirne l'estrazione.
Caratteristiche modellate utilizzando dati misurati
Le seguenti caratteristiche possono essere modellate utilizzando dati acquisiti da misurazioni dirette effettuate sul dispositivo fisico.
-
Forward-Bias Parameters
I seguenti parametri vengono utilizzati per descrivere le caratteristiche corrente-tensione in continua del BJT nella regione di polarizzazione diretta:
IS
Corrente di saturazione di trasporto (in ampere).
BF
Beta diretto massimo ideale.
NF
Coefficiente di emissione della corrente diretta.
RB
Resistenza di base a polarizzazione nulla (in ohm).
RC
Resistenza di collettore (in ohm).
RE
Resistenza di emettitore (in ohm).
IKF
Corrente di inizio del calo del beta diretto alle alte correnti (in ampere).
ISE
Corrente di saturazione di dispersione B-E (in ampere).
NE
Coefficiente di emissione della corrente di dispersione B-E.
VAF
Tensione di Early diretta (in volt).
Le sezioni seguenti descrivono in dettaglio i dati di misura richiesti, il cui inserimento consentirà alla procedura guidata di estrarre questi parametri.
-
Base-Emitter Voltage versus Base Current
Questi dati vengono utilizzati per l'estrazione iniziale del parametro RC. L'immagine seguente mostra un esempio di grafico della tensione base-emettitore (VBE) in funzione della corrente di base (IB), nonché un esempio di circuito di prova su cui effettuare le misurazioni per ottenere i dati. Il circuito impone una corrente nella base, misurando al contempo la tensione base-emettitore a circuito aperto.

Esempio di grafico e circuito per VBE in funzione di IB.I dati vengono inseriti nella procedura guidata come una serie di punti ricavati dal grafico di origine.
-
Collector-Emitter Voltage versus Base Current
Questi dati vengono utilizzati per l'estrazione iniziale del parametro RE. L'immagine seguente mostra un esempio di grafico della tensione collettore-emettitore (VCE) in funzione della corrente di base (IB), nonché un esempio di circuito di prova su cui effettuare le misurazioni per ottenere i dati. Il circuito impone una corrente nella base, misurando al contempo la tensione collettore-emettitore a circuito aperto.

Esempio di grafico e circuito per VCE in funzione di IB.I dati vengono inseriti nella procedura guidata come una serie di punti ricavati dal grafico di origine.
-
Forward Gummel Plot
Questi dati vengono utilizzati principalmente per estrarre i parametri IS, BF, NF, RB, IKF, ISE e NE. Vengono utilizzati anche per ottimizzare i parametri RC, RE e VAF. L'immagine seguente mostra un esempio di diagramma di Gummel, nonché un esempio di circuito di prova su cui effettuare le misurazioni per ottenere i dati. Il diagramma di Gummel illustra:
-
La corrente di base in funzione della tensione base-emettitore (IB in funzione di VBE).
-
La corrente di collettore in funzione della tensione base-emettitore (IC in funzione di VBE).
La tensione base-collettore (VBC) viene mantenuta a zero volt.

Esempio di diagramma di Gummel diretto e circuito di prova.I dati vengono inseriti nella procedura guidata come una serie di punti ricavati dal diagramma di Gummel di origine. È necessario inserire i valori grezzi di IB e IC – la procedura guidata applicherà la funzione LN ai dati delle curve.
-
-
Collector Current versus Base-Emitter Voltage
Questi dati vengono utilizzati per l'estrazione iniziale del parametro VAF. L'immagine seguente mostra un esempio di grafico della corrente di collettore (IC) in funzione della tensione base-emettitore (VBE), nonché un esempio di circuito di prova su cui effettuare le misurazioni per ottenere i dati. Il circuito viene utilizzato per generare due curve di IC in funzione di VBE, per due diversi valori della tensione base-collettore (VBC). Le curve devono essere misurate con correnti quanto più basse possibile e con VBC il più vicino possibile a zero volt, compatibilmente con le condizioni pratiche.

Esempi di grafici e circuito per VBE in funzione di IC.I dati vengono inseriti nella procedura guidata come una serie di punti in due tabelle, una per ciascuna curva dei dati di origine. In ciascun caso è necessario inserire anche il valore utilizzato per VBC.
-
-
Reverse-Bias Parameters
I seguenti parametri vengono utilizzati per descrivere le caratteristiche corrente-tensione in continua del BJT nella regione di polarizzazione inversa:
IS
Corrente di saturazione di trasporto (in ampere).
BR
Beta inverso massimo ideale.
NR
Coefficiente di emissione della corrente inversa.
RB
Resistenza di base a polarizzazione nulla (in ohm).
RC
Resistenza di collettore (in ohm).
RE
Resistenza di emettitore (in ohm).
IKR
Corrente di inizio del calo del beta inverso alle alte correnti (in ampere).
ISC
Corrente di saturazione di dispersione B-C (in ampere).
NC
Coefficiente di emissione della corrente di dispersione B-C.
VAR
Tensione di Early inversa (in volt).
Le sezioni seguenti descrivono in dettaglio i dati di misura richiesti, il cui inserimento consentirà alla procedura guidata di estrarre questi parametri.
-
Reverse Gummel Plot
Questi dati vengono utilizzati principalmente per estrarre i parametri IS, BR, NR, RB, IKR, ISC e NC. Vengono inoltre utilizzati per ottimizzare i parametri RC, RE e VAR. L'immagine seguente mostra un esempio di diagramma di Gummel e un esempio di circuito di prova, dal quale è possibile effettuare le misure necessarie per ottenere i dati. Il diagramma di Gummel illustra:
-
La corrente di base in funzione della tensione base-collettore (IB rispetto a VBC).
-
La corrente di emettitore in funzione della tensione base-collettore (IE rispetto a VBC).
La tensione base-emettitore (VBE) viene mantenuta a zero volt.

Esempio di diagramma di Gummel inverso e circuito di prova.I dati vengono inseriti nella procedura guidata come una serie di punti ricavati dal diagramma di Gummel di origine. È necessario inserire i valori grezzi di IB e IE: la procedura guidata applicherà la funzione LN ai dati della curva.
-
-
Emitter Current versus Base-Collector Voltage
Questi dati vengono utilizzati per l'estrazione iniziale del parametro VAR. L'immagine seguente mostra un esempio di grafico della corrente di emettitore (IE) in funzione della tensione base-collettore (VBC) e un esempio di circuito di prova, dal quale è possibile effettuare le misure necessarie per ottenere i dati. Il circuito viene utilizzato per generare due curve di IE in funzione di VBC, per due diversi valori della tensione base-emettitore (VBE). Le curve devono essere misurate con correnti quanto più basse possibile e con VBE quanto più vicina possibile a zero volt.

Esempi di grafici e circuito per IE in funzione di VBC.I dati vengono inseriti nella procedura guidata come una serie di punti in due tabelle, una per ciascuna curva dei dati di origine. In ciascun caso è necessario inserire anche il valore utilizzato per VBE.
-
Caratteristiche modellate utilizzando i dati della scheda tecnica del produttore
Le seguenti caratteristiche possono essere modellate utilizzando i dati ricavati dalla scheda tecnica di un produttore.
-
Forward-Bias Parameters
I seguenti parametri vengono utilizzati per descrivere le caratteristiche corrente-tensione in continua del BJT nella regione di polarizzazione diretta:
IS
Corrente di saturazione di trasporto (in ampere).
BF
Beta diretto massimo ideale.
NF
Coefficiente di emissione della corrente diretta.
RE
Resistenza di emettitore (in ohm).
IKF
Corrente di inizio della diminuzione del beta diretto alle alte correnti (in ampere).
ISE
Corrente di saturazione di dispersione B-E (in ampere).
NE
Coefficiente di emissione della corrente di dispersione B-E.
Le sezioni seguenti descrivono in dettaglio i dati necessari, il cui inserimento consentirà alla procedura guidata di estrarre questi parametri.
-
Base-Emitter Voltage versus Collector Current
Questi dati vengono utilizzati per estrarre i parametri IS, NF, RE e IKF. L'immagine seguente mostra un esempio di grafico della tensione base-emettitore (VBE) in funzione della corrente di collettore (IC), ricavato da una scheda tecnica.
I dati vengono inseriti nella procedura guidata come una serie di punti ricavati dal grafico di origine. È necessario inserire i valori grezzi di IC: la procedura guidata applicherà la funzione LN ai dati della curva.
È inoltre necessario inserire il valore del rapporto beta forzato della curva (β = IC/IB). Nel grafico di esempio dell'immagine precedente, questo valore è indicato in alto a sinistra; pertanto, il valore da inserire è 10.
-
DC Current Gain versus Collector Current
Questi dati vengono utilizzati per estrarre i parametri BF, NE, ISE e IKF. L'immagine seguente mostra un esempio di grafico del guadagno di corrente in continua (hFE) in funzione della corrente di collettore (IC), ricavato da una scheda tecnica.
I dati vengono inseriti nella procedura guidata come una serie di punti ricavati dal grafico di origine. Per garantire l'accuratezza, è opportuno inserire i valori del guadagno di corrente in continua per valori bassi, medi e alti della corrente di collettore.
-
-
Forward Early Voltage
Il seguente parametro viene utilizzato per modellare l'effetto della modulazione della larghezza della base nel modello di transistor Gummel-Poon:
VAF
Tensione di Early diretta (in volt).
Per estrarre questo parametro, è necessario inserire un punto della curva dell'ammettenza di uscita (hOE) in funzione della corrente di collettore (IC). L'immagine seguente mostra un esempio di questa curva.
Leggere un valore qualsiasi sulla curva. Nell'esempio dell'immagine precedente, si possono leggere IC = 1mA e hOE = 30μmhos.
In genere, i dati sono presentati in formato tabellare, come nell'esempio mostrato nell'immagine seguente.

Esempio di voce tabellare per l'ammettenza di uscita.I valori di interesse nell'immagine, da inserire nella procedura guidata, sono 1mA per la corrente di collettore e 30μmhos per l'ammettenza di uscita (in genere viene utilizzato il valore massimo).
Caratteristiche modellate utilizzando dati misurati o forniti dal produttore
Le seguenti caratteristiche possono essere modellate utilizzando dati ricavati dalla scheda tecnica di un produttore oppure da misure dirette effettuate su un dispositivo fisico.
-
Base-Emitter Capacitance
I seguenti parametri vengono utilizzati per descrivere la capacità di giunzione in polarizzazione inversa della giunzione base-emettitore:
CJE
Capacità di svuotamento B-E a polarizzazione nulla (in farad).
MJE
Fattore esponenziale della giunzione B-E.
VJE
Potenziale interno B-E (in volt).
Per estrarre questi parametri, è necessario un grafico della capacità della giunzione B-E polarizzata inversamente (Cj) in funzione della tensione (VBE). Se non è disponibile un capacimetro, è possibile utilizzare il circuito di prova di esempio nell'immagine seguente per ottenere i dati. L'immagine mostra anche esempi di grafici ottenuti da tale circuito, che rappresentano rispettivamente VBE e Cj in funzione del tempo. Da questi grafici è possibile leggere facilmente i valori di VBE e Cj in corrispondenza degli stessi istanti di tempo.

Esempio di circuito e grafici per la capacità della giunzione B-E in polarizzazione inversa.I dati vengono inseriti nella procedura guidata come una serie di punti ricavati dai grafici di origine.
Il circuito di esempio nell'immagine precedente si basa sull'equazione:
I = C * (dv/dt)Risolvendo questa equazione rispetto a C si ottiene:
C = I/(dv/dt)Il circuito genera una rampa di tensione a partire dalla sorgente V1. Calcolando la pendenza di questa rampa di tensione si può ottenere la parte
dv/dtdell'equazione. Dividendo la corrente misurata del diodo per la pendenza della rampa di tensione, si può ottenere la curva della capacità del diodo. I due grafici nell'immagine sopra si riferiscono al circuito come segue:-
Grafico superiore – VBE è V1.
-
Grafico inferiore – Cj è q1[ie]/(dV1/dt).
-
-
Base-Collector Capacitance
I seguenti parametri vengono utilizzati per descrivere la capacità della giunzione base-collettore in polarizzazione inversa:
CJC
Capacità di svuotamento B-C a polarizzazione nulla (in farad).
MJC
Fattore esponenziale della giunzione B-C.
VJC
Potenziale interno B-C (in volt).
Per estrarre questi parametri, è necessario un grafico della capacità della giunzione B-C polarizzata inversamente (Cj) in funzione della tensione (VBC). Se non è disponibile un capacimetro, è possibile utilizzare il circuito di prova di esempio nell'immagine seguente per ottenere i dati. L'immagine mostra anche alcuni grafici di esempio ottenuti da tale circuito, che rappresentano rispettivamente VBC e Cj in funzione del tempo. Da questi grafici è possibile leggere facilmente i valori di VBC e Cj in corrispondenza degli stessi istanti di tempo.

Circuito e grafici di esempio per la capacità della giunzione B-C in polarizzazione inversa.I dati vengono inseriti nella procedura guidata come una serie di punti ricavati dal grafico di origine.
Il circuito di esempio nell'immagine sopra si basa sull'equazione:
I = C * (dv/dt)Risolvendo questa equazione rispetto a C si ottiene:
C = I/(dv/dt)Il circuito genera una rampa di tensione a partire dalla sorgente V1. Calcolando la pendenza di questa rampa di tensione si può ottenere la parte
dv/dtdell'equazione. Dividendo la corrente misurata del diodo per la pendenza della rampa di tensione, si può ottenere la curva della capacità del diodo. I due grafici nell'immagine sopra si riferiscono al circuito come segue:-
Grafico superiore – VBC è V1.
-
Grafico inferiore – Cj è q1[ic]/(dV1/dt).
-
-
Collector-Substrate Capacitance
I seguenti parametri vengono utilizzati per descrivere la capacità della giunzione collettore-substrato in polarizzazione inversa:
CJS
Capacità collettore-substrato a polarizzazione nulla (in farad).
MJS
Fattore esponenziale della giunzione del substrato.
VJS
Potenziale interno della giunzione del substrato (in volt).
Per estrarre questi parametri, è necessario un grafico della capacità della giunzione C-S polarizzata inversamente (Cj) in funzione della tensione (VCS). Se non è disponibile un capacimetro, è possibile utilizzare il circuito di prova di esempio nell'immagine seguente per ottenere i dati. L'immagine mostra anche alcuni grafici di esempio ottenuti da tale circuito, che rappresentano rispettivamente VCS e Cj in funzione del tempo. Da questi grafici è possibile leggere facilmente i valori di VCS e Cj in corrispondenza degli stessi istanti di tempo.

Circuito e grafici di esempio per la capacità della giunzione C-S in polarizzazione inversa.I dati vengono inseriti nella procedura guidata come una serie di punti ricavati dal grafico di origine.
Il circuito di esempio nell'immagine sopra si basa sull'equazione:
I = C * (dv/dt)Risolvendo questa equazione rispetto a C si ottiene:
C = I/(dv/dt)Il circuito genera una rampa di tensione a partire dalla sorgente V1. Calcolando la pendenza di questa rampa di tensione si può ottenere la parte
dv/dtdell'equazione. Dividendo la corrente misurata del diodo per la pendenza della rampa di tensione, si può ottenere la curva della capacità del diodo. I due grafici nell'immagine sopra 24 si riferiscono al circuito come segue:-
Grafico superiore – VCS è V1.
-
Grafico inferiore – Cj è q1[is]/(dV1/dt).
-
-
Transit Times
I seguenti parametri vengono utilizzati per descrivere il tempo di transito del BJT:
TF
Tempo di transito diretto ideale (in secondi).
TR
Tempo di transito inverso ideale (in secondi).
Per estrarre questi parametri, la procedura guidata richiede l'inserimento della frequenza a guadagno unitario (fT) del transistor. Si tratta della frequenza alla quale il guadagno di corrente del transistor diventa unitario. Questo dato si trova generalmente nelle schede tecniche dei produttori sotto forma di semplici dati numerici.
L'immagine seguente mostra come viene presentata questa informazione nella scheda tecnica di un produttore. Il valore di interesse nell'immagine, da inserire nella procedura guidata, è 100 MHz.

Esempio di voce tabellare per il prodotto guadagno di corrente-banda passante.
Parametri non estratti dalla procedura guidata
I seguenti parametri sono difficili da estrarre dai dati di misura e solitamente non sono presenti nelle schede tecniche dei produttori. Non vengono né estratti dalla procedura guidata né aggiunti al file del modello risultante per un BJT. Sebbene non siano presenti nel file MDL, SPICE utilizza comunque questi parametri durante la simulazione del dispositivo BJT, applicando i rispettivi valori predefiniti. Questi valori sono riportati di seguito per facilitarne la consultazione.
IRB |
Corrente alla quale la resistenza di base scende a metà strada verso il suo valore minimo (in ampere). (Valore predefinito = infinito). |
|
RBM |
Resistenza di base minima a correnti elevate (in ohm). (Valore predefinito = RB). |
|
XTF |
Coefficiente della dipendenza di TF dalla polarizzazione. (Valore predefinito = 0). |
|
VTF |
Tensione che descrive la dipendenza di TF da VBC (in volt). (Valore predefinito = infinito). |
|
ITF |
Parametro relativo all'effetto delle correnti elevate su TF (in ampere). (Valore predefinito = 0). |
|
PTF |
Eccesso di fase alla frequenza=1.0/(TF*2PI)Hz (in gradi). (Valore predefinito = 0). |
|
XCJC |
Frazione della capacità di svuotamento B-C collegata al nodo interno di base. (Valore predefinito = 1). |
|
XTB |
Esponente di temperatura del beta diretto e inverso. (Valore predefinito = 0). |
|
EG |
Gap energetico per l'effetto della temperatura su IS (in eV). (Valore predefinito = 1.11). |
|
XTI |
Esponente di temperatura per l'effetto su IS. (Valore predefinito = 3). |
|
KF |
Coefficiente del rumore flicker. (Valore predefinito = 0). |
|
AF |
Esponente del rumore flicker. (Valore predefinito = 1). |
|
FC |
Coefficiente per la formula della capacità di svuotamento in polarizzazione diretta. (Valore predefinito = 0,5). |
|
TNOM |
Temperatura di misurazione del parametro (in ˚C). (Il valore predefinito di questo parametro è uguale al valore immesso per il parametro TNOM nella pagina Opzioni SPICE della finestra di dialogo Configurazione analisi. Per impostazione predefinita, questo valore è 27 ˚C). |
Naturalmente, è possibile aggiungere manualmente uno qualsiasi di questi parametri al file MDL, specificando i valori da utilizzare in base alle proprie esigenze.