Creazione di un disegno di fabbricazione

A colpo d'occhio

Questo articolo illustra come creare un disegno di fabbricazione di un cablaggio in Altium Designer utilizzando l'editor Draftsman: dall'aggiunta e configurazione del documento nel progetto all'inserimento di viste di sola lettura dello schema di cablaggio e del disegno di layout, fino all'aggiunta di viste di dettaglio e dei componenti e all'utilizzo di annotazioni, quote e tabelle per documentare il progetto ai fini della produzione. Spiega inoltre come riportare nel disegno di fabbricazione gli aggiornamenti dello schema di cablaggio e del disegno di layout e come gestire proprietà, unità di misura, parametri e navigazione tra più fogli all'interno del documento. Se desideri capire come i dati di progettazione dei cablaggi vengono trasformati in una documentazione di produzione organizzata, continua a leggere: questo articolo ti guiderà attraverso l'intero flusso di lavoro.

- Scopri come creare e configurare un documento di disegno di fabbricazione di un cablaggio in Draftsman, inclusi modelli, impostazioni del documento, unità di misura e parametri importati dal progetto.
- Esplora i tipi di viste, annotazioni, quote e strumenti di disegno aggiuntivi che puoi inserire per rappresentare chiaramente le informazioni di progettazione del cablaggio.
- Scopri quali tabelle di produzione sono disponibili, tra cui distinte base, elenchi dei fili e tabelle delle connessioni, e come vengono ricavati e presentati i relativi dati.
Approfondisci con l'IA:

Una volta completati lo schema di cablaggio e il disegno di layout, è possibile inserire copie di sola lettura dei relativi contenuti nel documento del disegno di produzione (*.HarDwf) e aggiungere le annotazioni necessarie. Il disegno di produzione di un progetto di cablaggio viene creato nell'editor Draftsman.

Per una panoramica su Draftsman, consulta la pagina Semplificare la documentazione di progettazione delle schede con Draftsman.

Aggiungi un disegno di produzione al progetto di cablaggio dal pannello Projects facendo clic con il pulsante destro del mouse sulla voce del progetto e selezionando Add New to Project » Draftsman Document dal menu contestuale (oppure utilizza il comando File » New » Draftsman Document dai menu principali). Nella finestra di dialogo New Document che si apre, seleziona un modello di disegno di produzione disponibile in base alle esigenze e assicurati che siano selezionati il Project e il disegno di layout del cablaggio Document corretti.

La finestra di dialogo New Document
La finestra di dialogo New Document

Per ulteriori informazioni sulla creazione di modelli di disegni di produzione, consulta la pagina Creazione di documenti modello per il cablaggio.

Configurazione di un documento di disegno di produzione

Le opzioni di un documento di disegno di produzione possono essere configurate nel pannello Properties quando non è selezionato alcun oggetto nell'area di progettazione del documento. Per ulteriori informazioni, consulta la pagina Configurazione di un documento Draftsman.

Le schede del pannello Properties quando non è selezionato alcun oggetto nel documento del disegno di produzione del cablaggio
Le schede del pannello Properties quando non è selezionato alcun oggetto nel documento del disegno di produzione del cablaggio

  • Una volta creato il documento del disegno di produzione, qualsiasi modifica apportata allo schema di cablaggio o al disegno di layout può essere importata nel disegno di produzione utilizzando il comando Tools » Import Changes From <LayoutDrawing.LdrDoc> dai menu principali o dal menu contestuale dell'area di progettazione. Nota che, nonostante la descrizione del comando di menu, questa operazione importerà le modifiche da both the wiring diagram and the layout drawing.

  • Le proprietà predefinite degli oggetti del disegno di produzione possono essere configurate nella pagina Draftsman – Impostazioni predefinite della finestra di dialogo Preferences. Queste proprietà verranno applicate agli oggetti inseriti successivamente.

  • Il pannello Segnalibri offre un modo pratico per esplorare e gestire un disegno di produzione composto da più fogli. Il pannello presenta una vista ad albero espandibile dell'intera struttura del documento e include tutti i fogli del documento e gli oggetti vista principali al loro interno.

  • Utilizzando le opzioni Units e Dual_Units nel pannello Properties quando non è selezionato alcun oggetto nell'area di progettazione, puoi selezionare le unità di misura predefinite del documento per i valori delle quote e i valori di lunghezza mostrati nelle tabelle. Se necessario, le unità specificate a livello di documento possono essere sovrascritte nelle proprietà dei singoli oggetti. Le unità supportate sono Millimeters, Mils, Inches, Centimetri, Metri e Feet.

  • I parametri del documento del disegno di layout vengono importati nel documento del disegno di produzione del cablaggio associato. Questi parametri sono elencati nella scheda Parameters del pannello Properties del documento (la visibilità dei parametri di layout nell'elenco può essere attivata o disattivata utilizzando la casella di controllo accanto all'icona  nel pannello) e possono essere utilizzati nelle stringhe speciali. Anche i valori dei parametri calcolati, come =ItemRevision e =ItemRevisionLevel1, vengono inclusi e interpretati negli output generati durante il rilascio.

Utilizzo delle viste

In un documento di disegno di produzione, puoi inserire viste di sola lettura dello schema di cablaggio e del disegno di layout del cablaggio inclusi nel progetto.

Vista dello schema di cablaggio

Una vista dello schema di cablaggio (Place » Wiring Diagram View) è una rappresentazione grafica composita generata automaticamente dallo schema di cablaggio del progetto di cablaggio attivo.

Un esempio di vista dello schema di cablaggio
Un esempio di vista dello schema di cablaggio

Le proprietà di una vista dello schema di cablaggio inserita possono essere configurate nel pannello Properties quando la vista è selezionata nell'area di progettazione.

Il pannello Properties quando è selezionata una vista dello schema di cablaggio
Il pannello Properties quando è selezionata una vista dello schema di cablaggio

  • Se il progetto di cablaggio include più documenti di schema di cablaggio (scopri di più), puoi scegliere il documento da cui generare e aggiornare una vista dello schema di cablaggio inserita. Quando la vista dello schema di cablaggio è selezionata, utilizza il menu a discesa Document nella sezione Properties del pannello Properties per scegliere il documento dello schema di cablaggio per questa vista ().

  • Quando Auto Size è abilitato, la vista dello schema di cablaggio adatta automaticamente le proprie dimensioni per eliminare gli spazi vuoti ai bordi.

  • Seleziona Justification facendo clic sulla freccia corrispondente all'allineamento desiderato oppure sul cerchio per centrare. L'opzione scelta per Justification definisce il punto rispetto al quale cambia la posizione della vista quando ne vengono aggiornate le dimensioni.

Vista del disegno di layout

Una vista del disegno di layout (Place » Layout Drawing View) è una rappresentazione grafica composita generata automaticamente dal disegno di layout del progetto di cablaggio attivo.

Un esempio di vista del disegno di layout
Un esempio di vista del disegno di layout

Le proprietà di una vista del disegno di layout inserita possono essere configurate nel pannello Properties quando la vista è selezionata nell'area di progettazione.

Il pannello Properties quando è selezionata una vista del disegno di layout
Il pannello Properties quando è selezionata una vista del disegno di layout

  • Quando Auto Size è abilitato, la vista del disegno di layout adatta automaticamente le proprie dimensioni per eliminare gli spazi vuoti ai bordi.

  • Seleziona Justification facendo clic sulla freccia corrispondente all'allineamento desiderato oppure sul cerchio per centrare. L'opzione scelta per Justification definisce il punto rispetto al quale cambia la posizione della vista quando ne vengono aggiornate le dimensioni.

Viste aggiuntive

Per completare il disegno di produzione, puoi utilizzare viste aggiuntive: la vista di dettaglio del cablaggio e la vista del componente.

Una vista di dettaglio del cablaggio consente di visualizzare un'area definita di un disegno esistente come vista separata e ingrandita del relativo dettaglio. Per una vista di dettaglio del cablaggio sono disponibili aree circolari e rettangolari. Per inserire la vista desiderata, seleziona un'opzione (Circle area detail view o Rectangle area detail view) dal menu principale Place » Additional Views » Harness Detail View.

Javascript ID: Harness_MD_HarnessDetailView_AD24

Un esempio di vista di dettaglio del cablaggio con area circolare applicata a una vista dello schema di cablaggio

Un esempio di vista di dettaglio del cablaggio con area rettangolare applicata a una vista dello schema di cablaggio

La vista del componente (Place » Additional Views » Component View) è una vista di disegno di un singolo componente del progetto di cablaggio corrente.

Un esempio di vista del componente
Un esempio di vista del componente

Annotazione e quotatura del disegno

Sono disponibili diversi strumenti aggiuntivi di annotazione, quotatura e disegno per aggiungere informazioni importanti a un disegno di produzione. Questi includono sistemi automatici per note ed evidenziazione, nonché strumenti per indicare lunghezze, dimensioni e angoli dei contorni degli oggetti o la distanza tra oggetti specificati.

Esempio di una vista annotata del disegno di layout
Esempio di una vista annotata del disegno di layout

  • Un richiamo associato a un connettore o a un punto di connessione e impostato per visualizzare la voce della distinta base mostra i numeri di posizione nella distinta base del connettore/punto di connessione stesso e delle parti associate. Un richiamo aggiunto alla vista fisica di un componente in una vista del disegno di layout mostrerà anche i numeri di posizione nella distinta base di tutte le cavità assegnate a questo componente.

  • Quando si posiziona una quota lineare tra punti di connessione in una vista del disegno di layout, il campo Value  (la lunghezza della quota) viene compilato automaticamente con la lunghezza del fascio di cablaggio corrispondente.

Per saperne di più, consulta le seguenti pagine:

Utilizzo delle tabelle

Un documento di disegno di produzione consente di inserire nel disegno una distinta base (BOM), un elenco dei fili, una tabella delle connessioni e una tabella generica. I dati tabellari vengono ricavati direttamente dai documenti del progetto e offrono un modo semplice e visivo per comunicare informazioni essenziali per i processi di produzione del cablaggio.

  • Nelle proprietà della distinta base, dell'elenco dei fili e delle tabelle delle connessioni, puoi specificare Length Units e Value Precision della lunghezza (sovrascrivendo quelli specificati a livello di documento). Le opzioni selezionate verranno applicate ai valori di lunghezza mostrati nella tabella corrispondente.

  • Per i componenti di cablaggio, la colonna Length di una tabella della distinta base presenta la lunghezza totale dei fili/cavi appartenenti alla stessa voce della distinta base anziché le loro singole lunghezze.

  • I rivestimenti di fili, cavi e cablaggi sono oggetti basati sulla lunghezza e il valore viene visualizzato nel campo Length . Il campo Quantity  per questi oggetti è As Required.

  • Quando si copia un oggetto tabella dal documento di disegno di produzione, il suo contenuto può essere incollato in un foglio di calcolo Microsoft Excel.

Scopri di più sull'utilizzo della distinta base e delle tabelle.

Elenco dei fili

Un elenco dei fili (Place » Wiring List) è un oggetto tabella generato automaticamente che visualizza i punti iniziali e finali e i valori dei parametri di ciascun filo del cablaggio.

Esempio di un elenco dei fili
Esempio di un elenco dei fili

Le proprietà di un elenco dei fili inserito (come gli attributi visivi e il contenuto dei dati) possono essere configurate nel pannello Properties quando l'elenco dei fili è selezionato nell'area di progettazione.

Le schede del pannello Properties quando è selezionato un elenco dei fili 
Le schede del pannello Properties quando è selezionato un elenco dei fili

  • I designatori degli oggetti schermatura con connessione vengono visualizzati nell'elenco dei fili quando un filo è collegato all'oggetto.

  • Se un filo ha il valore No per il parametro Include Cut, tale filo non verrà visualizzato nell'elenco dei fili.

  • I parametri dei fili (e i relativi valori) specificati nello schema di cablaggio vengono riportati nell'elenco dei fili. Per ogni parametro del filo viene aggiunta una colonna all'elenco dei fili. Queste colonne aggiuntive sono nascoste per impostazione predefinita. Quando l'elenco dei fili è selezionato, utilizza i controlli di visibilità nella scheda Columns del pannello Properties per mostrare queste colonne nell'area di progettazione (e nascondere le colonne predefinite, se necessario).

  • I fili multicolore sono supportati negli elenchi dei fili ():

    • Le celle della colonna Color sono suddivise per mostrare i colori secondario e terziario assegnati al filo.

    • La colonna ColorName include i nomi dei colori principale, secondario e terziario.

    • È possibile rendere visibili colonne aggiuntive per i colori secondario, terziario e del bordo.

  • Per i fili all'interno di un cavo, la colonna Length di un elenco dei fili visualizza la lunghezza di ciascun filo.

  • Per il connettore passaparete (il connettore con il maggior numero di cavità), viene applicato un raggruppamento automatico all'elenco dei fili, assicurando che tutte le sue cavità siano raggruppate correttamente nella colonna From.

  • Utilizza i pulsanti  e  per spostare di una posizione a sinistra o a destra nell'elenco dei fili una colonna visibile la cui voce è selezionata nella scheda Columns.

  • Fai clic su una cella nella colonna Order per passare da un'opzione di ordinamento dei dati della colonna della tabella all'altra (disattivato, crescente e decrescente). È possibile applicare l'ordinamento a più colonne in base alla priorità tenendo premuto Ctrl e facendo clic sulle celle nella colonna Order.

  • Il connettore con il maggior numero di fili (e tutte le sue cavità) viene raggruppato automaticamente nella colonna From  ().

Suddivisione di un elenco dei fili

L'elenco dei fili di un progetto di cablaggio avanzato può contenere un numero elevato di voci, che può essere difficile inserire in un documento di disegno sotto forma di un'unica tabella. Anziché ricorrere al ridimensionamento dei caratteri e della tabella, a più voci di tabella personalizzate o a un documento esterno, puoi «suddividere» una tabella dell'elenco dei fili in modo che l'elenco venga presentato su più «pagine».

Nel pannello Properties  di un elenco dei fili inserito, abilita l'opzione Limit Page Height nella sezione Pages  per limitare l'altezza della tabella al valore specificato (Max Page Height) e, di conseguenza, il numero di righe mostrate nella tabella.

Javascript ID: Harness_MD_WiringList_LimitPageHeight_AD25_3

L'editor rileva che l'elenco dei fili non è visualizzato per intero, come indicato dalla voce Page del pannello (ad esempio, Page 1 from 2), e il menu a discesa associato consente di scegliere quale pagina visualizzare. Per aggiungere altre pagine dell'elenco dei fili, inserisci un altro elenco dei fili e specifica il successivo Page nella sezione Pages del pannello Properties .

Poiché ogni pagina dell'elenco dei fili viene inserita aggiungendo un'altra tabella dell'elenco dei fili e configurandola di conseguenza, le singole pagine dell'elenco possono essere posizionate su qualsiasi foglio del documento di disegno di produzione.

Nota che la proprietà Max Page Height specifica l'altezza della pagina first nella tabella dell'elenco dei fili. Quando è selezionata la seconda pagina (Pagina 2), la proprietà Max Page Height definisce l'altezza della prima pagina esclusa (Pagina 1). La pagina 2, pertanto, mostra le voci rimanenti dell'elenco dei fili. Inizia impostando Max Page Height proprietà identica per ogni pagina.

Tabella delle connessioni

Una tabella delle connessioni (Place » Connection Table) è un oggetto tabella generato automaticamente che mostra i fili collegati a ogni punto di connessione (pin del connettore, giunzione, ecc.) del cablaggio.

Esempio di tabella delle connessioni (per tutti i componenti)
Esempio di tabella delle connessioni (per tutti i componenti)

Le proprietà di una tabella delle connessioni posizionata (come gli attributi visivi e i dati contenuti) possono essere configurate nel pannello Properties quando la tabella delle connessioni è selezionata nell'area di progettazione.

Le schede del pannello Properties quando è selezionata una tabella delle connessioni 
Le schede del pannello Properties quando è selezionata una tabella delle connessioni

  • È possibile utilizzare l'opzione Component per mostrare nella tabella i dati di tutti i componenti del progetto oppure quelli di un componente o di una giunzione specifici.

  • Se il parametro Include Cut di un filo ha il valore No, il filo non verrà visualizzato nella tabella delle connessioni.

  • I parametri dei fili (e i relativi valori) specificati nello schema di cablaggio vengono riportati nella tabella delle connessioni. Per ogni parametro del filo viene aggiunta una colonna alla tabella delle connessioni. Queste colonne aggiuntive sono nascoste per impostazione predefinita. Quando la tabella delle connessioni è selezionata, utilizzare i controlli di visibilità nella scheda Columns del pannello Properties per mostrare queste colonne nell'area di progettazione (e nascondere le colonne predefinite, se necessario).

  • I fili multicolore sono supportati nelle tabelle delle connessioni ():

    • Le celle della colonna Color sono suddivise per mostrare i colori secondario e terziario assegnati al filo.

    • La colonna ColorName include i nomi dei colori principale, secondario e terziario.

    • È possibile rendere visibili colonne aggiuntive per i colori secondario, terziario e del bordo.

  • Per i fili all'interno di un cavo, la colonna Length di una tabella delle connessioni mostra la lunghezza di ciascun filo.

  • Utilizzare i pulsanti  e  per spostare di una posizione verso sinistra o verso destra nella tabella delle connessioni una colonna visibile la cui voce è selezionata nella scheda Columns.

  • Fare clic su una cella nella colonna Order per scorrere le opzioni di ordinamento dei dati delle colonne della tabella (disattivato, crescente e decrescente). È possibile applicare l'ordinamento a più colonne secondo un ordine di priorità tenendo premuto Ctrl e facendo clic sulle celle nella colonna Order.

  • Utilizzare il menu a discesa Display nel pannello Properties per configurare i dati visualizzati nella tabella:

    • Wires Only – mostra solo i pin a cui sono collegati dei fili.

    • Wires & Parts – mostra i pin a cui sono collegati dei fili e gli eventuali accessori per cavità aggiunti, come un tappo nel caso di un connettore sigillato senza filo.

    • All Cavities – mostra tutti i pin di tutti i componenti, indipendentemente dai fili collegati e dalle cavità aggiunte (ad esempio, se è presente un componente a 10 pin, tutti e 10 i pin verranno mostrati nella tabella).

    • No Connect – mostra solo gli oggetti «non connesso».

Suddivisione di una tabella delle connessioni

La tabella delle connessioni di un progetto di cablaggio avanzato può contenere un numero elevato di voci, che può essere difficile inserire in un documento di disegno sotto forma di un'unica tabella. Anziché ricorrere al ridimensionamento dei caratteri e della tabella, a più voci di tabella personalizzate o a un documento esterno, è possibile «suddividere» una tabella delle connessioni in un documento Harness Draftsman (*.HarDwf), in modo che venga presentata su più «pagine». Nel pannello Properties di una tabella delle connessioni posizionata, abilitare l'opzione Limit Page Height nell'area Pages  per utilizzare la nuova funzionalità. In questo modo, l'altezza della tabella delle connessioni verrà limitata al valore specificato (Max Page Height) e, di conseguenza, verrà limitato anche il numero di righe mostrate nella tabella.

 

L'editor rileva che la tabella delle connessioni non è visualizzata per intero, come indicato dalla voce Page del pannello (ad esempio, 1 from 2), e il menu a discesa associato consente di specificare quale pagina visualizzare. Per aggiungere altre pagine della tabella delle connessioni, posizionare un'altra tabella delle connessioni (Place » Connection Table) e specificare il valore Page successivo nell'area Pages del pannello Properties .

AI-LocalizedLocalizzato tramite A
Se trovi un problema, seleziona il testo/l’immagine e premi Ctrl + Enter per inviarci il tuo feedback.
Contents
Disponibilità delle funzionalità

Le funzionalità a tua disposizione dipendono dalla soluzione Altium di cui disponi: Altium Develop, Altium Agile Teams, Altium Agile Enterprise oppure Altium Designer (con abbonamento attivo).

Se non vedi una funzionalità documentata nel software che stai effettivamente utilizzando, contatta il reparto vendite di Altium per saperne di più.

Documentazione legacy

La documentazione di Altium Designer non è più suddivisa per versione. Se è necessario accedere alla documentazione delle versioni precedenti di Altium Designer, visitare la sezione Documentazione legacy della pagina Altri programmi di installazione.

Contents