Lavorare con le tabelle

A colpo d'occhio

Questo articolo spiega come inserire e configurare le tabelle Draftsman in Altium Designer, con particolare attenzione alle tabelle della distinta base (BOM) e al modo in cui i loro dati provengono direttamente dal progetto PCB, da ActiveBOM, dalle varianti e dalle viste di assemblaggio. Illustra le principali impostazioni disponibili nel pannello Properties, tra cui la formattazione, la selezione dell'origine dei dati, le modalità di visualizzazione, i filtri basati sulle varianti, la gestione delle colonne e la suddivisione della distinta base su più pagine per i progetti più complessi. Se vuoi capire meglio come presentare i dati di fabbricazione e assemblaggio in modo preciso e ordinato nei tuoi documenti Draftsman, questo articolo ti mostrerà quali opzioni sono disponibili e come utilizzarle al meglio. Continua a leggere per avere un maggiore controllo sulla documentazione dei tuoi PCB.

- Scoprirai da dove provengono i dati delle tabelle BOM e in che modo opzioni come Project, Board, le varianti e le viste di assemblaggio influiscono sui contenuti visualizzati.
- Vedrai come personalizzare l'aspetto e la struttura di una tabella BOM, inclusi titoli, caratteri, colori delle righe, colonne, ordinamento e alias.
- Capirai come funzionano le tabelle BOM suddivise, così da poter distribuire distinte base di grandi dimensioni su più oggetti tabella e pagine.
Approfondisci con l'IA:

Un documento Draftsman consente di inserire nel disegno una serie di tabelle di dati e di configurarle secondo le esigenze. I dati tabellari sono ricavati direttamente dal documento PCB del progetto e offrono un modo semplice e visivo per comunicare informazioni fondamentali per i processi di fabbricazione e assemblaggio del PCB.

Il tipo di tabella da inserire può essere selezionato dal menu principale Place.

Distinta base

Una distinta base di Draftsman (Place » Bill Of Materials) è un oggetto tabella generato automaticamente che elenca gli elementi fisici di assemblaggio di un progetto PCB. I dati della tabella BOM sono ricavati direttamente dal documento ActiveBOM del progetto oppure, se il documento ActiveBOM non è presente nel progetto corrente, direttamente dai documenti sorgente del progetto. Una tabella BOM può anche rappresentare gli elementi costitutivi di una variante di progetto specificata o di una vista di assemblaggio della scheda inserita.

Una tabella della distinta base suddivisa in due oggetti BOM. Nell'esempio sopra, il contenuto della distinta base è filtrato per includere gli elementi della vista di assemblaggio del lato superiore della scheda.
Una tabella della distinta base suddivisa in due oggetti BOM. Nell'esempio sopra, il contenuto della distinta base è filtrato per includere gli elementi della vista di assemblaggio del lato superiore della scheda.

Lo stile visivo e i dati inclusi in una tabella della distinta base inserita sono configurabili nel pannello Properties quando la tabella è selezionata nell'area di progettazione. Le proprietà generali della tabella si configurano nella scheda General del pannello ().

Titolo

Titolo

La stringa del titolo che verrà visualizzata (se abilitata) insieme alla tabella. Utilizzare il pulsante associato per attivare o disattivare la visibilità del titolo nel disegno.

Il campo può includere testo statico e qualsiasi parametro desiderato sotto forma di stringhe speciali. Utilizzare la sintassi =<ParameterName> per includere un parametro nel titolo. I valori dei parametri inclusi verranno visualizzati nel titolo sul foglio di disegno. Per un elenco dei parametri di sistema e del PCB disponibili, consultare la pagina Configurazione di un documento Draftsman.

Location Aprire il menu a discesa per scegliere tra diverse posizioni relative per il titolo. L'opzione Manual viene selezionata automaticamente se il titolo viene spostato manualmente (trascinato e rilasciato in una nuova posizione).
Font

Imposta il carattere utilizzato per il titolo.

  • Quando l'opzione Use Document Font è abilitata, il carattere utilizzato per il titolo è quello definito dalle opzioni del documento (la voce Document Font nella sezione General della scheda General del pannello Properties quando non è selezionato alcun oggetto nell'area di progettazione).

  • Quando l'opzione Use Document Font è disabilitata, utilizzare le opzioni disponibili per scegliere il tipo di carattere, le dimensioni, il colore e gli attributi del testo desiderati.

Proprietà

Table Line Style

Utilizzare i menu a discesa per selezionare la linea utilizzata per disegnare la tabella. Le opzioni disponibili sono definite nella sezione Line Styles del pannello Properties quando non è selezionato alcun oggetto nell'area di progettazione. Per ulteriori informazioni, consultare la pagina Configurazione di un documento Draftsman. Utilizzare il pulsante del colore associato per specificare il colore della linea.

Justification Selezionare il punto rispetto al quale viene modificata la posizione della tabella se le sue dimensioni vengono aggiornate.
Even Row Color Selezionare il colore di contrasto per le righe pari della tabella.
Non-Even Row Color Selezionare il colore di contrasto per le righe dispari della tabella.
Font

Imposta il carattere utilizzato per i dati della tabella.

  • Quando l'opzione Use Document Font è abilitata, il carattere utilizzato è quello definito dalle opzioni del documento (la voce Document Font nella sezione General della scheda General del pannello Properties quando non è selezionato alcun oggetto nell'area di progettazione).

  • Quando l'opzione Use Document Font è disabilitata, utilizzare le opzioni disponibili per scegliere il tipo di carattere, le dimensioni, il colore e gli attributi del testo desiderati.

La tabella verrà ridimensionata automaticamente per adattarsi alle dimensioni del carattere selezionate.

Data Source Questa opzione e l'eventuale presenza di un documento ActiveBOM nel progetto determinano i dati inclusi nella tabella:

 

  • Project – quando questa opzione è selezionata e il documento ActiveBOM è incluso nel progetto corrente, la sua configurazione e il suo contenuto diventano l'origine dati per una tabella BOM di Draftsman. Utilizzare il comando Tools » Import Changes From <PCBDocumentName>.PcbDoc di Draftsman per recepire le modifiche in tempo reale apportate a un documento ActiveBOM.
    Se il documento ActiveBOM non è incluso nel progetto corrente, i dati di una tabella BOM di Draftsman vengono ricavati direttamente dai documenti sorgente del progetto.

  • Board – quando questa opzione è selezionata, le voci della tabella BOM di Draftsman sono limitate ai componenti presenti sul PCB fisico del progetto.

Assembly View Utilizzare le opzioni del menu a discesa per filtrare le voci della distinta base elencate in modo da includere gli elementi mostrati in una vista di assemblaggio della scheda specificata.
View Mode
  • Base – viene assegnata una riga della tabella a ciascun tipo di componente univoco e tutti gli elementi inclusi vengono elencati nella colonna Designator.

  • Flat – viene assegnata una riga della tabella a ciascun componente.

  • Consolidated – se il progetto sorgente include varianti, la tabella includerà le voci dei componenti di tutte le varianti di progetto. Selezionando questa opzione, l'opzione Variant verrà impostata automaticamente su [No Variations].

Variant

Utilizzare il menu a discesa per selezionare una variante di progetto, se disponibile, come origine dati per la tabella BOM. La tabella riporterà le voci non incluse o con parametri modificati, in base all'opzione Show Components.

Quando l'opzione Document : <VariantName> è selezionata come Variation, alla tabella viene applicata una variante specificata per il documento. La variante a livello di documento viene selezionata utilizzando il menu a discesa Variants nella sezione Source della scheda General del pannello Properties quando non è selezionato alcun oggetto nell'area di progettazione. Per ulteriori informazioni, consultare la pagina Configurazione di un documento Draftsman.

Show Components

Quando è selezionata una variante, utilizzare il menu a discesa per selezionare quali voci dei componenti includere nell'elenco:

  • Fitted – mostra solo i componenti montati nella variante di progetto attualmente selezionata.

  • All – mostra tutti i componenti.

  • Not Fitted – mostra solo i componenti non montati nella variante di progetto attualmente selezionata.

  • Replaced – mostra solo i componenti per i quali sono state selezionate parti alternative o i componenti montati con valori dei parametri modificati nella variante di progetto attualmente selezionata.

Una tabella BOM con le opzioni Fitted, Not Fitted o Replaced selezionate per Show Components funziona con le opzioni Base e Flat selezionate per View Mode (non Consolidated).

Paginei

BOM Table ID Un identificatore numerico per un'istanza della tabella BOM. La tabella completa può essere suddivisa in più oggetti tabella BOM (pagine) e l'ID rimane comune a tutti.
Limit Page Height Se selezionata, la tabella BOM viene suddivisa in una sequenza di pagine virtuali, ciascuna con l'altezza specificata nella proprietà Max Page Height.
Max Page Height Imposta l'altezza e, di conseguenza, il numero di righe incluse in ciascuna pagina della tabella. Un oggetto tabella BOM posizionato include una sola pagina (vedere Page di seguito); per coprire tutte le pagine, vengono posizionati ulteriori oggetti tabella BOM.
Page Indica il numero di pagina della tabella (1 from 2, 3 from 5, ecc.) visualizzato nell'oggetto tabella BOM selezionato. Utilizzare il menu a discesa associato per specificare la pagina desiderata per l'oggetto tabella BOM attualmente selezionato.
Show Empty Lines Se selezionata, vengono visualizzate le righe vuote nella tabella BOM. Queste si trovano in genere nell'ultima pagina di una tabella BOM, quando l'altezza di pagina specificata supera il numero di righe di dati BOM disponibili.

Utilizzare la scheda Columns del pannello Properties per gestire le colonne di dati della tabella BOM.

Modificare le colonne di una tabella BOM posizionata nella scheda Columns del pannello Properties.
Modificare le colonne di una tabella BOM posizionata nella scheda Columns del pannello Properties.

  • Le voci possono essere modificate per specificare le colonne incluse (visibili) nella tabella BOM e l'allineamento del relativo testo (Align).

  • Utilizzare la voce Width per definire la larghezza della colonna in relazione al testo che contiene. Immettere Auto per fare in modo che la larghezza vari dinamicamente adattandosi al testo più largo tra le celle della colonna.

  • Fare clic nella colonna Order per scorrere le opzioni di ordinamento dei dati della colonna della tabella (disattivato, crescente e decrescente). L'ordinamento può essere applicato a più colonne in base alla priorità: le colonne ordinate più a sinistra nella tabella hanno priorità maggiore.

  • Le intestazioni della tabella BOM possono essere modificate immettendo un Alias per il nome del parametro di una colonna della tabella. Questa opzione si applica se il contenuto della tabella non è determinato da un documento ActiveBOM (vedere Data Source sopra).

  • Utilizzare le caselle di controllo del filtro per tipo di colonna per popolare l'elenco delle colonne disponibili con i tipi di dati dei parametri corrispondenti: BOM (), schema elettrico (), server (), PCB (). Deselezionare tutti i tipi per elencare solo le colonne visibili nella tabella BOM.

  • Utilizzare i pulsanti  e  per spostare la voce selezionata di una posizione verso l'alto o verso il basso e, di conseguenza, verso sinistra o verso destra nell'ordine delle colonne della tabella BOM. Disponibile per le colonne impostate come visibili.

  • Fare clic sul pulsante  per ripristinare le voci predefinite delle colonne della tabella (come definite dalle impostazioni predefinite dell'oggetto tabella BOM nella pagina Draftsman – Impostazioni predefinite della finestra di dialogo Preferences).

Tabelle BOM suddivise

La distinta base dei progetti PCB più avanzati tende ad avere un numero elevato di voci, che può essere difficile riprodurre in una tabella che rientri in un documento di disegno. Anziché ricorrere al ridimensionamento di caratteri e tabelle, a più voci di tabella personalizzate o a un documento esterno, la funzionalità di suddivisione della BOM consente di presentare una tabella BOM su più «pagine».

Per creare una tabella BOM di più pagine, selezionare una BOM posizionata (che probabilmente supera l'altezza del foglio del documento) e selezionare la casella Limit Page Height nell'area Pages del pannello Properties. In questo modo l'altezza della tabella viene limitata al valore specificato (Max Page Height, mm) e, di conseguenza, viene limitato il numero di righe visualizzate nella tabella BOM.

Javascript ID: Draftsman_BOM_LimitPageHeight

Draftsman rileva che non viene visualizzata l'intera BOM, come indicato dalla voce Page del pannello (ad esempio, Page 1 from 2), e il menu a discesa associato consente di scegliere quale pagina visualizzare. Per aggiungere altre pagine della BOM (qui, BOM Table ID = 0), posizionare un'altra BOM e specificare il successivo Page nell'area Pages del pannello Properties .

Poiché ogni pagina della BOM viene posizionata aggiungendo un'altra tabella BOM e configurandola di conseguenza, le singole pagine (sezioni) della BOM possono essere posizionate su qualsiasi foglio di un documento Draftsman. Per posizionare un altro insieme different di pagine BOM suddivise, specificare un BOM Table ID alternativo su una BOM posizionata, ad esempio 1 anziché 0.

Si noti che la proprietà Max Page Height specifica l'altezza della pagina first nella tabella BOM. Quando è selezionata la seconda pagina (Pagina 2), la proprietà Max Page Height definisce l'altezza della prima pagina esclusa (Pagina 1). La pagina 2 mostra quindi le voci BOM rimanenti. Iniziare impostando lo stesso valore della proprietà Max Page Height per ogni pagina.

Tabella di foratura

Una tabella di foratura di Draftsman (Place » Drill Table) è un oggetto tabella generato automaticamente che contiene i simboli e i dati di foratura della scheda. La tabella di foratura, combinata con la vista del disegno di foratura di Draftsman, fornisce informazioni sia tabulari sia grafiche per il processo di fabbricazione della scheda. Una riga di simbolo, che rappresenta un tipo specifico di foro, può includere una serie di informazioni sui fori, come le dimensioni, la metallizzazione e il numero di occorrenze. I tipi di foro sono raggruppati sotto i simboli come specificato nella finestra di dialogo Drill Symbol Configurations.

Una tabella di foratura posizionata con le voci dei fori raggruppate per dimensione
Una tabella di foratura posizionata con le voci dei fori raggruppate per dimensione

Quando l'estensione software GOST 2.701-2008/2.106-1996 è installata nell'installazione di Altium Designer, i valori nella colonna Plated della tabella di foratura vengono visualizzati come Есть (per i fori metallizzati) e Нет (per i fori non metallizzati). 

Per ulteriori informazioni sulla gestione delle estensioni, consultare la pagina Extending Your Installation (Altium Designer Develop, Altium Designer Agile, Altium Designer).

Lo stile visivo e il contenuto dei dati di una tabella di foratura posizionata, incluso il simbolo utilizzato, sono configurabili nel pannello Properties quando la tabella è selezionata nell'area di progettazione. Le proprietà generali della tabella vengono configurate nella scheda General del pannello ().

Titolo

Title

La stringa del nome del titolo che verrà visualizzata (se abilitata) insieme alla tabella. Utilizzare il pulsante associato per attivare o disattivare la visibilità del titolo nel disegno.

Il campo può includere testo statico e qualsiasi parametro desiderato sotto forma di stringhe speciali. Utilizzare la sintassi =<ParameterName> per includere un parametro nel titolo. I valori dei parametri inclusi verranno visualizzati nel titolo sul foglio di disegno. Per un elenco dei parametri di sistema e PCB disponibili, consultare la pagina Configurazione di un documento Draftsman.

Location Aprire il menu a discesa per scegliere tra diverse posizioni relative per il titolo. L'opzione Manual viene selezionata automaticamente se il titolo viene spostato manualmente (trascinandolo e rilasciandolo in una nuova posizione).
Font

Imposta il carattere utilizzato per il titolo.

  • Quando l'opzione Use Document Font è abilitata, il carattere utilizzato per il titolo è quello definito dalle opzioni del documento (la voce Document Font in General regione della scheda General del pannello Properties quando non è selezionato alcun oggetto nell'area di progettazione).

  • Quando l'opzione Use Document Font è disabilitata, utilizzare le opzioni disponibili per scegliere il tipo, la dimensione, il colore e gli attributi di testo del carattere desiderato.

Proprietà

Layer Pairs Selezionare i fori della coppia di layer di foratura del PCB da visualizzare nella vista del disegno. Utilizzare il menu a discesa per scegliere tra le coppie di layer disponibili nel progetto della scheda sorgente, visualizzabili e modificabili nell'editor PCB, accessibile da Layer Stack Manager. Tutti i progetti di schede avranno una coppia di layer Top - Bottom, mentre le altre coppie rappresenteranno i fori dei via che attraversano o raggiungono altri layer, come i layer interni o i piani.

Le opzioni Counterhole Bottom e Counterhole Top sono disponibili solo quando il documento PCB include pad con funzionalità di lamatura o svasatura abilitate sui lati corrispondenti del PCB (ulteriori informazioni).

Si noti che le lamature e le svasature sono escluse dalle coppie di layer diverse da Counterhole Bottom e Counterhole Top. Sono escluse anche dalla coppia di layer All Layers.

Pads / Vias Utilizzare il menu a discesa per selezionare il tipo di foro (Pads, Vias o All) da visualizzare nella tabella.
Plated / Non-Plated Utilizzare il menu a discesa per selezionare il tipo di metallizzazione dei fori (Plated, Non-Plated o All) da visualizzare nella tabella.
Border Line Style

Utilizzare i menu a discesa per selezionare la linea utilizzata per tracciare il bordo/contorno della tabella. Le opzioni disponibili sono definite nella regione Line Styles del pannello Properties quando non è selezionato alcun oggetto nell'area di progettazione. Per ulteriori informazioni, consultare la pagina Configurazione di un documento Draftsman. Utilizzare il pulsante del colore associato per specificare il colore della linea.

Justification Selezionare il punto rispetto al quale viene modificata la posizione della tabella se le sue dimensioni vengono aggiornate.
Even Row Color Selezionare il colore di contrasto per le righe pari della tabella.
Non-Even Row Color Selezionare il colore di contrasto per le righe dispari della tabella.
Font

Imposta il carattere utilizzato per i dati della tabella.

  • Quando l'opzione Use Document Font è abilitata, il carattere utilizzato è quello definito nelle opzioni del documento (la voce Document Font nella regione General della scheda General del pannello Properties quando non è selezionato alcun oggetto nell'area di progettazione).

  • Quando l'opzione Use Document Font è disabilitata, utilizzare le opzioni disponibili per scegliere il tipo, la dimensione, il colore e gli attributi di testo del carattere desiderato.

La tabella si ridimensiona automaticamente in base alla dimensione del carattere selezionata.

Show Footer Selezionare per abilitare il piè di pagina della tabella, che mostra il numero totale di fori.
Selezionare per aprire la finestra di dialogo Drill Symbol Configurations, che fornisce una vista tabellare di tutti i dati dei fori e consente di impostare lo stile e le dimensioni del simbolo di ciascun foro (ulteriori informazioni).

Unità

Primary Units

Selezionare il tipo di unità di misura primaria da visualizzare nella tabella. Utilizzare il pulsante  associato per attivare o disattivare la visualizzazione delle unità di misura.

Quando l'opzione Document : <Units> è selezionata come Primary Units, alla tabella vengono applicate le unità primarie specificate per il documento. Le unità primarie a livello di documento vengono selezionate tramite il menu a discesa Primary Units nella regione Units della scheda General del pannello Properties quando non è selezionato alcun oggetto nell'area di progettazione. Per ulteriori informazioni, consultare la pagina Configurazione di un documento Draftsman.

Dual Units

Selezionare il tipo di unità di misura secondaria (doppia) da visualizzare nella tabella. Utilizzare il pulsante  associato per attivare o disattivare la visualizzazione dei valori nelle unità secondarie.

Quando l'opzione Document : <Units> è selezionata come Dual Units, alla tabella vengono applicate le unità doppie specificate per il documento. Le unità doppie a livello di documento vengono selezionate tramite il menu a discesa Dual Units nella regione Units della scheda General del pannello Properties quando non è selezionato alcun oggetto nell'area di progettazione. Per ulteriori informazioni, consultare la pagina Configurazione di un documento Draftsman.

Precisione

Primary Units

Utilizzare il menu a discesa Value Precision per impostare la precisione (fino a cinque cifre decimali, con arrotondamento dell'ultima cifra) per le voci della tabella relative alle dimensioni dei fori espresse nelle unità primarie (principali).

Quando è selezionata l'opzione Document : <Precision>, alla tabella viene applicata la precisione dei valori e delle tolleranze nelle unità primarie specificata per il documento. La precisione dei valori e delle tolleranze nelle unità primarie a livello di documento viene selezionata tramite le opzioni Value Precision e Tolerance Precision per Primary Units nella regione Units della scheda General del pannello Properties quando non è selezionato alcun oggetto nell'area di progettazione. Per ulteriori informazioni, consultare la pagina Configurazione di un documento Draftsman.

Dual Units

Utilizzare il menu a discesa Value Precision per impostare la precisione (fino a cinque cifre decimali, con arrotondamento dell'ultima cifra) per le voci relative alle dimensioni dei fori espresse nelle unità doppie (secondarie), se abilitate.

Quando è selezionata l'opzione Document : <Precision>, alla quota viene applicata la precisione dei valori e delle tolleranze nelle unità doppie specificata per il documento. La precisione dei valori e delle tolleranze nelle unità doppie a livello di documento viene selezionata tramite le opzioni Value Precision e Tolerance Precision per Dual Units nella regione Units della scheda General del pannello Properties quando non è selezionato alcun oggetto nell'area di progettazione. Per ulteriori informazioni, consultare la pagina Configurazione di un documento Draftsman.

Utilizzare la scheda Columns del pannello Properties per gestire le colonne di dati della tabella di foratura ().

  • Le voci possono essere modificate per specificare le colonne incluse (visibili) nella tabella di foratura e il relativo allineamento Horizontal e Vertical.

  • Utilizzare la voce Width per definire la larghezza della colonna in relazione al testo che contiene. Immettere Auto per fare in modo che la larghezza vari dinamicamente adattandosi al testo più largo tra le celle della colonna.

  • Fare clic all'interno della colonna Order per scorrere le opzioni di ordinamento dei dati delle colonne della tabella (disattivato, crescente e decrescente). L'ordinamento può essere applicato a più colonne in base a una priorità, in cui le colonne ordinate più a sinistra nella tabella hanno priorità maggiore.

  • Le intestazioni della tabella di foratura possono essere modificate immettendo un Caption per il nome del parametro di una colonna della tabella.

  • Utilizzare  e  pulsanti per spostare la voce selezionata verso l'alto o verso il basso di una posizione e, di conseguenza, verso sinistra o verso destra nell'ordine delle colonne della tabella di foratura. Disponibile per le colonne impostate come visibili.

Gli stili dei simboli della tabella di foratura e il raggruppamento dei tipi di fori sotto tali simboli sono determinati dalle impostazioni nella finestra di dialogo Drill Symbol Configurations, che si apre facendo clic sul pulsante nel pannello Properties (nell'area Properties della scheda General) quando la tabella è selezionata nell'area di progettazione.

Si tratta della stessa finestra di dialogo attivata dal pannello Properties per una vista del disegno di foratura, ma in questo caso vengono mostrate solo le colonne attivate (rese visibili) per la tabella di foratura. Si noti che le due versioni della finestra di dialogo Drill Symbol Configuration condividono la stessa origine e, pertanto, interagiscono.

Symbol Graphics Utilizzare il menu a discesa per selezionare la rappresentazione grafica desiderata del foro tra una serie di forme e lettere predefinite.
Sync Symbols with PCB Quando l'opzione è abilitata, i simboli nella tabella di foratura vengono sincronizzati con quelli del PCB.
Symbol Size Table

Immettere la dimensione desiderata dei simboli nella tabella.

  • Si noti che la dimensione verrà modificata per i simboli di foratura attualmente selezionati nella griglia nella parte superiore della finestra di dialogo. Per selezionare più simboli di foratura nella griglia, utilizzare la tecnica Ctrl+Click o Shift+Click.

  • Si noti inoltre che la dimensione è collegata tra la vista del disegno di foratura e la tabella di foratura se l'icona di collegamento indica che il collegamento è attivo (). Per impostare le dimensioni dei simboli di foratura in modo indipendente, fare clic sull'icona di collegamento per scollegare le due dimensioni e impostare quelle desiderate per ciascuna.

Symbol Size View Immettere la dimensione desiderata dei simboli nella vista. Per accedere a questo campo e modificarlo, l'icona di collegamento deve indicare che il collegamento è disattivato (). Fare clic sull'icona di collegamento per attivare o disattivare il collegamento.
Symbol Line Style

Utilizzare i menu a discesa per selezionare la linea utilizzata per disegnare il bordo/contorno della grafica dei simboli. Le opzioni disponibili sono definite nell'area Line Styles del pannello Properties quando non è selezionato alcun oggetto nell'area di progettazione. Per ulteriori informazioni, consultare la pagina Configurazione di un documento Draftsman. Utilizzare il pulsante del colore associato per specificare il colore della linea.

Grouping I criteri scelti raggrupperanno le selezioni sotto un unico simbolo. Ad esempio, se è selezionato solo HoleSize, verrà assegnato un simbolo distinto a ogni dimensione di foro utilizzata nel PCB. Man mano che vengono selezionate ulteriori opzioni di raggruppamento, l'assegnazione dei simboli distinguerà i criteri aggiuntivi creando uno schema di raggruppamento più dettagliato.

È possibile definire le impostazioni predefinite per Symbol Size Table, Symbol Size View, Symbol Line Style e Grouping utilizzando la pagina Draftsman – Impostazioni predefinite della finestra di dialogo Preferences. In questa pagina, selezionare Drill Table in Primitive List e aprire la scheda Drill Symbol nell'area delle proprietà a destra ().

Tabella delle linee di trasmissione

I calcoli applicati all'instradamento a impedenza controllata producono strutture delle piste volte a soddisfare un'impedenza obiettivo della linea di trasmissione e, pertanto, i requisiti di alta velocità e/o di campo elettromagnetico del progetto della scheda. Gli strati della scheda e le relative proprietà specificate o calcolate sono accessibili tramite il Layer Stack Manager, dove gli strati di instradamento a impedenza controllata sono associati a profili di impedenza definibili. I materiali e le dimensioni della scheda in ciascun profilo vengono utilizzati nei calcoli dell'impedenza della linea di trasmissione, ottenendo una determinata struttura delle piste. La struttura supporta sia piste singole sia coppie differenziali, nonché configurazioni degli strati della scheda di tipo stripline (interni) o microstrip (superficiali).

Per ulteriori informazioni sulla configurazione dei profili di impedenza, consultare la pagina Definizione dello stackup degli strati.

Poiché la struttura e i dati associati a ciascuna definizione di linea di trasmissione nello stackup degli strati della scheda costituiscono informazioni importanti per il processo di fabbricazione del PCB, Draftsman include un oggetto dedicato, la tabella delle linee di trasmissione (Place » Transmission Line Table), per documentare tali informazioni. La tabella viene popolata con i dati ricavati dal Layer Stack Manager e dai relativi calcoli dell'impedenza delle linee di trasmissione.

Una tabella delle linee di trasmissione posizionata
Una tabella delle linee di trasmissione posizionata

Lo stile visivo e i dati contenuti in una tabella delle linee di trasmissione posizionata sono configurabili nel pannello Properties quando la tabella è selezionata nell'area di progettazione. Le proprietà generali della tabella vengono configurate nella scheda General del pannello ().

Titolo

Title

La stringa di testo del titolo che verrà visualizzata (se abilitata) con la tabella. Utilizzare il pulsante associato per attivare o disattivare la visibilità del titolo nel disegno.

Il campo può includere testo statico e qualsiasi parametro desiderato sotto forma di stringhe speciali. Utilizzare la sintassi =<ParameterName> per includere un parametro nel titolo. I valori dei parametri inclusi verranno mostrati nel titolo sul foglio di disegno. Per un elenco dei parametri di sistema e del PCB disponibili, consultare la pagina Configurazione di un documento Draftsman.

Location Aprire il menu a discesa per scegliere tra diverse posizioni relative del titolo. L'opzione Manual viene selezionata automaticamente se il titolo viene spostato manualmente (trascinato e rilasciato in una nuova posizione).
Font

Imposta il carattere utilizzato per il titolo.

  • Quando l'opzione Use Document Font è abilitata, il carattere utilizzato per il titolo è quello definito dalle opzioni del documento (la voce Document Font nell'area General della scheda General del pannello Properties quando non è selezionato alcun oggetto nell'area di progettazione).

  • Quando l'opzione Use Document Font è disabilitata, utilizzare le opzioni disponibili per scegliere il tipo, la dimensione e il colore del carattere e gli attributi del testo desiderati.

Proprietà

Table Line Style

Utilizzare i menu a discesa per selezionare la linea utilizzata per disegnare le linee della tabella. Le opzioni disponibili sono definite nell'area Line Styles del pannello Properties quando non è selezionato alcun oggetto nell'area di progettazione. Per ulteriori informazioni, consultare la pagina Configurazione di un documento Draftsman. Utilizzare il pulsante del colore associato per specificare il colore della linea.

Justification Selezionare il punto rispetto al quale viene modificata la posizione della tabella quando le sue dimensioni vengono aggiornate.
Even Row Color Selezionare il colore di contrasto per le righe pari della tabella.
Non-Even Row Color Selezionare il colore di contrasto per le righe dispari della tabella.
Caption Font

Imposta il carattere utilizzato per i dati contenuti nella tabella.

  • Quando l'opzione Use Document Font è abilitata, il carattere utilizzato è quello definito dalle opzioni del documento (la voce Document Font nell'area General della scheda General del pannello Properties quando non è selezionato alcun oggetto nell'area di progettazione).

  • Quando l'opzione Use Document Font l'opzione è disabilitata, utilizza le opzioni disponibili per scegliere il tipo, la dimensione, il colore e gli attributi del testo desiderati.

La tabella si ridimensionerà automaticamente per adattarsi alla dimensione del carattere selezionata.

Rows Font

Imposta il carattere utilizzato per il corpo della tabella (il testo nelle righe della tabella).

  • Quando l'opzione Use Document Font è abilitata, viene utilizzato il carattere definito nelle opzioni del documento (la voce Document Font nell'area General della scheda General del pannello Properties quando non è selezionato alcun oggetto nell'area di progettazione).

  • Quando l'opzione Use Document Font è disabilitata, utilizza le opzioni disponibili per scegliere il tipo, la dimensione, il colore e gli attributi del testo desiderati.

La tabella si ridimensionerà automaticamente per adattarsi alla dimensione del carattere selezionata.

Unità

Primary Units

Seleziona il tipo di unità di misura primaria da visualizzare nella tabella. Utilizza il pulsante  associato per attivare o disattivare la visualizzazione delle unità di misura.

Quando è selezionata l'opzione Document : <Units>, alla tabella vengono applicate le unità primarie specificate per il documento. Le unità primarie a livello di documento vengono selezionate tramite il menu a discesa Units nell'area Units della scheda General del pannello Properties quando non è selezionato alcun oggetto nell'area di progettazione. Per ulteriori informazioni, consulta la pagina Configurazione di un documento Draftsman.

Primary Precision

Seleziona la precisione (fino a cinque cifre a destra del separatore decimale, con l'ultima cifra arrotondata) per i valori delle unità primarie.

Quando è selezionata l'opzione Document : <Precision>, alla tabella viene applicata la precisione dei valori e delle tolleranze delle unità primarie specificata per il documento. La precisione dei valori e delle tolleranze delle unità primarie a livello di documento viene selezionata tramite le opzioni Value Precision e Tolerance Precision per Primary Units nell'area Units della scheda General del pannello Properties quando non è selezionato alcun oggetto nell'area di progettazione. Per ulteriori informazioni, consulta la pagina Configurazione di un documento Draftsman.

Dual Units

Seleziona il tipo di unità di misura secondaria (doppia) da visualizzare nella tabella. Utilizza il pulsante  associato per attivare o disattivare la visualizzazione dei valori delle unità secondarie.

Quando è selezionata l'opzione Document : <Units>, alla tabella vengono applicate le unità doppie specificate per il documento. Le unità doppie a livello di documento vengono selezionate tramite il menu a discesa Dual_Units nell'area Units della scheda General del pannello Properties quando non è selezionato alcun oggetto nell'area di progettazione. Per ulteriori informazioni, consulta la pagina Configurazione di un documento Draftsman.

Dual Precision

Seleziona la precisione (fino a cinque cifre a destra del separatore decimale, con l'ultima cifra arrotondata) per i valori delle unità secondarie, se abilitate.

Quando è selezionata l'opzione Document : <Precision>, alla quota viene applicata la precisione dei valori e delle tolleranze delle unità doppie specificata per il documento. La precisione dei valori e delle tolleranze delle unità doppie a livello di documento viene selezionata tramite le opzioni Value Precision e Tolerance Precision per Dual Units nell'area Units della scheda General del pannello Properties quando non è selezionato alcun oggetto nell'area di progettazione. Per ulteriori informazioni, consulta la pagina Configurazione di un documento Draftsman.

Utilizza la scheda Columns del pannello Properties per gestire le colonne e le righe dei dati della linea di trasmissione ().

  • L'area Columns fornisce un elenco delle colonne incluse nella tabella. Ogni voce di colonna può essere modificata attivandone o disattivandone la visibilità, rinominandone l'intestazione (Caption), scorrendo le opzioni di allineamento del testo (Align) oppure impostando una larghezza di colonna specifica o automatica (Width). L'ordine delle voci nell'elenco, e quindi l'ordine delle colonne nella tabella posizionata, può essere modificato spostando una voce di colonna selezionata tramite i pulsanti  e  associati.

  • L'area Rows fornisce un elenco dei dati delle righe della tabella ordinati in base alla colonna Impedance Id, che fa riferimento ai layer della scheda identificati per nome nello stackup di origine. Utilizza il controllo di visibilità associato a ciascuna voce di riga per attivarne o disattivarne la visualizzazione nella tabella.

Tabella

Un documento Draftsman consente di posizionare una tabella generica sul disegno e di configurarla successivamente nel pannello Properties e nelle celle della tabella stessa. Il layout e il contenuto della tabella personalizzata possono essere definiti liberamente in base allo scopo previsto e offrono un modo flessibile per includere informazioni aggiuntive in qualsiasi documento Draftsman.

Una tabella posizionata con varie formattazioni delle celle
Una tabella posizionata con varie formattazioni delle celle

  • Utilizzando sia le opzioni disponibili nelle proprietà della tabella sia i comandi della tabella, è possibile creare una tabella personalizzata adatta a un'ampia gamma di esigenze informative in un documento Draftsman. La tabella mostrata di seguito, ad esempio, è stata creata per visualizzare le informazioni ricavate da un report dello stackup della scheda.

    È possibile creare una tabella personalizzata per includere un'ampia gamma di informazioni sull'assemblaggio e sulla fabbricazione dei PCB.
    È possibile creare una tabella personalizzata per includere un'ampia gamma di informazioni sull'assemblaggio e sulla fabbricazione dei PCB.

  • Le tabelle possono essere incluse sia nei modelli di foglio sia nei modelli di documento.

L'avvio del comando di posizionamento della tabella (Place » Table) apre la finestra di dialogo Insert table, in cui è possibile specificare il numero di righe e colonne della nuova tabella. Dopo aver fatto clic su OK nella finestra di dialogo Insert table, la nuova tabella viene agganciata al cursore e può essere posizionata nel punto desiderato con un ulteriore clic.

Specifica il numero di celle nelle righe e nelle colonne della tabella: questi valori possono essere modificati in seguito tramite i comandi Table disponibili facendo clic con il pulsante destro del mouse su una cella.
Specifica il numero di celle nelle righe e nelle colonne della tabella: questi valori possono essere modificati in seguito tramite i comandi Table disponibili facendo clic con il pulsante destro del mouse su una cella.

La posizione di una tabella posizionata può essere modificata graficamente selezionando l'oggetto tabella nell'area di progettazione e trascinandolo in una nuova posizione tramite la relativa maniglia di spostamento, ossia l'icona  nell'angolo superiore sinistro.

Trascina l'icona di spostamento di una tabella selezionata per riposizionarla nell'area di progettazione.
Trascina l'icona di spostamento di una tabella selezionata per riposizionarla nell'area di progettazione.

Un oggetto tabella viene selezionato facendo clic su una cella o sul suo titolo. Tuttavia, il comando Delete verrà applicato all'elemento specifico su cui si fa clic. 

Il contenuto viene aggiunto a una tabella digitandolo (o incollandolo) direttamente nelle celle. Utilizza Ctrl+Enter per aggiungere una nuova riga all'interno di una cella.

Gli attributi grafici e di testo della tabella vengono definiti nel pannello Properties quando la tabella è selezionata nell'area di progettazione (). L'oggetto tabella offre un'ampia gamma di funzionalità di modifica del testo e della struttura, applicabili a singole celle, righe o colonne utilizzando i comandi standard Shift+Click o Click, Hold&Drag tecnica.

Titolo

Title

La stringa del titolo che verrà visualizzata (se abilitata) con la tabella. Utilizzare il pulsante associato per attivare o disattivare la visibilità del titolo nel disegno.

Il campo può includere testo statico e qualsiasi parametro desiderato sotto forma di stringhe speciali. Utilizzare la sintassi =<ParameterName> per includere un parametro nel titolo. I valori dei parametri inclusi verranno visualizzati nel titolo sul foglio di disegno. Per un elenco dei parametri di sistema e del PCB disponibili, consultare la pagina Configurazione di un documento Draftsman.

Location Aprire il menu a discesa per scegliere tra diverse posizioni relative per il titolo. L'opzione Manual viene selezionata automaticamente se il titolo viene spostato manualmente (trascinandolo e rilasciandolo in una nuova posizione).
Font

Imposta il carattere utilizzato per il titolo.

  • Quando l'opzione Use Document Font è abilitata, il carattere utilizzato per il titolo è quello definito nelle opzioni del documento (la voce Document Font nella sezione General della scheda General del pannello Properties quando nessun oggetto è selezionato nell'area di progettazione).

  • Quando l'opzione Use Document Font è disabilitata, utilizzare le opzioni disponibili per scegliere il tipo, la dimensione e il colore del carattere e gli attributi del testo desiderati.

Proprietà

Linea esterna

Utilizzare i menu a discesa per selezionare la linea utilizzata per tracciare il bordo/contorno della tabella. Le opzioni disponibili sono definite nella sezione Line Styles del pannello Properties quando nessun oggetto è selezionato nell'area di progettazione. Per ulteriori informazioni, consultare la pagina Configurazione di un documento Draftsman. Utilizzare il pulsante del colore associato per specificare il colore della linea.

Inner Line Utilizzare i menu a discesa per selezionare la linea utilizzata per tracciare le linee interne della tabella che separano le celle. Le opzioni disponibili sono definite nella sezione Line Styles del pannello Properties quando nessun oggetto è selezionato nell'area di progettazione. Per ulteriori informazioni, consultare la pagina Configurazione di un documento Draftsman. Utilizzare il pulsante del colore associato per specificare il colore della linea.
Column Width

Imposta la larghezza delle celle selezionate e, di conseguenza, la larghezza della colonna che le contiene. Se è selezionata l'intera tabella (facendo clic sul contorno o sul titolo), l'impostazione della larghezza verrà applicata a tutte le celle. Utilizzare il pulsante del colore associato per specificare il colore delle celle attualmente selezionate.

Row Height Utilizzare questo campo per regolare l'altezza di una riga selezionata nell'area di progettazione. Immettere l'altezza desiderata, seguita dall'unità di misura imperiale o metrica.
Cell Padding Vertical Imposta la spaziatura sotto e sopra il testo nelle celle selezionate.
Cell Padding Horizontal Imposta la spaziatura a sinistra e a destra del testo nelle celle selezionate.
Font

Imposta il carattere utilizzato per il testo nelle celle selezionate.

  • Quando l'opzione Use Document Font è abilitata, il carattere utilizzato è quello definito nelle opzioni del documento (la voce Document Font nella sezione General della scheda General del pannello Properties quando nessun oggetto è selezionato nell'area di progettazione).

  • Quando l'opzione Use Document Font è disabilitata, utilizzare le opzioni disponibili per scegliere il tipo, la dimensione e il colore del carattere e gli attributi del testo desiderati.

La tabella verrà ridimensionata automaticamente per adattarsi alla dimensione del carattere selezionata.

Alignment Utilizzare i pulsanti per impostare l'allineamento e il posizionamento del testo Horizontal (a sinistra, al centro o a destra) e Vertical (in alto, al centro o in basso) nelle celle selezionate.
Justification Selezionare il punto rispetto al quale viene modificata la posizione della tabella quando le sue dimensioni vengono aggiornate.

Stringhe speciali nelle celle della tabella

Una tabella supporta l'inclusione dei parametri del documento Draftsman sotto forma di stringhe speciali. I parametri di progetto (sia locali sia sul lato Workspace), di sistema, del PCB e utente verranno convertiti nei rispettivi valori quando vengono immessi come stringhe speciali nelle celle della tabella. I parametri del documento Draftsman sono accessibili nella scheda Parameters del pannello Properties quando nessun oggetto è selezionato nell'area di progettazione. Per ulteriori informazioni, consultare la pagina Configurazione di un documento Draftsman.

La gestione delle stringhe di parametro nella tabella include anche la possibilità di trasferire correttamente i dati delle stringhe speciali da e verso un foglio di calcolo utilizzando le tecniche standard di copia e incolla.

  • Quando si incollano stringhe speciali da Draftsman in un foglio di calcolo, le celle di destinazione vengono compilate con il valore interpretato della stringa.

  • Quando si incollano dati di stringhe speciali da un foglio di calcolo in Draftsman, il testo incollato viene interpretato come valore di una stringa speciale, a condizione che la stringa speciale corrisponda a un parametro di sistema, di progetto o utente disponibile.

    Quando si preparano voci di stringhe speciali in un foglio di calcolo, è necessario anteporre a ciascun valore un apostrofo ('), in modo che il contenuto della cella venga trattato come testo. Ad esempio, la stringa speciale per il parametro Units verrebbe immessa come '=DocumentUnits. In alternativa, è possibile impostare tutte le celle del foglio di calcolo sul formato Testo.

Struttura della tabella

Fare clic con il pulsante destro del mouse in una cella e selezionare il menu Table dal menu contestuale per accedere ai comandi di configurazione delle celle. Questi offrono un insieme completo di funzioni di modifica della tabella per aggiungere e rimuovere colonne/righe e unire le celle.

I comandi Table del menu contestuale offrono una serie di funzioni standard per la modifica delle tabelle.
I comandi Table del menu contestuale offrono una serie di funzioni standard per la modifica delle tabelle.

  • Il comando Merge Cells è disponibile solo se nella tabella sono attualmente selezionate due o più celle consecutive.

    • Quando si uniscono celle che contengono testo, nella cella unita rimarrà solo il testo della cella più a sinistra o più in alto, a seconda dei casi.

  • Il comando Unmerge Cells è disponibile solo se il cursore si trova all'interno di una cella unita della tabella o se l'intervallo di celle selezionato include almeno una cella unita.

    • Si noti che, se la cella contiene testo, dopo la separazione il testo comparirà nella cella più a sinistra o più in alto, a seconda dei casi.

    • Quando si separano le celle e la selezione include più celle unite, questo comando separa solo la cella unita più a sinistra o più in alto.

AI-LocalizedLocalizzato tramite A
Se trovi un problema, seleziona il testo/l’immagine e premi Ctrl + Enter per inviarci il tuo feedback.
Contents
Disponibilità delle funzionalità

Le funzionalità a tua disposizione dipendono dalla soluzione Altium di cui disponi: Altium Develop, Altium Agile Teams, Altium Agile Enterprise oppure Altium Designer (con abbonamento attivo).

Se non vedi una funzionalità documentata nel software che stai effettivamente utilizzando, contatta il reparto vendite di Altium per saperne di più.

Documentazione legacy

La documentazione di Altium Designer non è più suddivisa per versione. Se è necessario accedere alla documentazione delle versioni precedenti di Altium Designer, visitare la sezione Documentazione legacy della pagina Altri programmi di installazione.

Contents