Creazione del disegno di layout

A colpo d'occhio

Questo articolo ti guida nella creazione di un disegno di layout del cablaggio in Altium Designer una volta completato lo schema di cablaggio, partendo dall’aggiunta del documento di layout, dalla configurazione delle principali opzioni del documento e dall’importazione dei dati dallo schema di cablaggio. Illustra inoltre come vengono visualizzati i componenti nel layout, quali proprietà puoi configurare e come passare dalla rappresentazione simbolica a quella del modello fisico per una visualizzazione più chiara del layout. Se cerchi una panoramica pratica su come trasformare i dati di progettazione del cablaggio in un disegno di layout fisico e comprendere le principali opzioni di configurazione disponibili, questo articolo ti aiuterà a orientarti e a prepararti al lavoro. Continua a leggere per creare il layout del tuo cablaggio con sicurezza.

- Scopri come creare e configurare un documento di disegno di layout del cablaggio, inclusi unità di misura, griglie, opzioni di pagina e modelli.
- Scopri come importare i dati dello schema di cablaggio nel disegno di layout e come recepire successivamente gli aggiornamenti dello schema.
- Comprendi come vengono rappresentati e configurati i componenti nel disegno di layout, incluse le viste simboliche e dei modelli fisici e le relative impostazioni delle proprietà.
Approfondisci con l'IA:

Una volta acquisito il progetto del cablaggio sotto forma di schema di cablaggio, è possibile crearne la rappresentazione fisica come disegno di layout del cablaggio (*.LdrDoc). Aggiungi questo documento al progetto di cablaggio dal pannello Projects, facendo clic con il pulsante destro del mouse sulla voce del progetto e selezionando Add New to Project » Harness Wiring Diagram dal menu contestuale (oppure utilizza il comando File » New » Harness Layout Drawing dai menu principali).

Configurazione di un documento di disegno di layout del cablaggio

Le opzioni di un documento di disegno di layout possono essere configurate nel pannello Properties quando non è selezionato alcun oggetto nell'area di progettazione del documento. Le impostazioni principali sono:

  • Nella sezione General della scheda General del pannello – seleziona le unità di misura da applicare al documento e ai relativi elementi grafici e imposta le griglie per facilitare il posizionamento. Altium Designer offre tre tipi di griglia: griglia visibile per la navigazione, griglia di aggancio per il posizionamento e distanza di aggancio per facilitare la creazione delle connessioni.

  • Nella sezione Page Options della scheda General del pannello – configura le dimensioni del foglio e il cartiglio del documento oppure seleziona uno dei modelli di disegno di layout del cablaggio disponibili.

Le schede General e Parameters del pannello Properties quando non è selezionato alcun oggetto nel documento di disegno di layout del cablaggio 
Le schede General e Parameters del pannello Properties quando non è selezionato alcun oggetto nel documento di disegno di layout del cablaggio

  • La configurazione di un documento di disegno di layout del cablaggio è simile a quella di un documento schematico (*.SchDoc) di un progetto PCB. Per ulteriori informazioni, consulta la pagina Configurazione di un documento schematico.

  • Utilizza il menu a discesa Length Units per scegliere le unità di lunghezza del documento. I valori Fascio Length e i valori Length Value e Offset Length degli oggetti fascio verranno visualizzati nelle unità selezionate. Le unità supportate sono mm, cm, m, in e ft. Le unità di lunghezza predefinite dei nuovi documenti di disegno di layout possono essere definite nella pagina Progettazione del cablaggio – Generale della finestra di dialogo Preferences.

  • Per ulteriori informazioni sulla creazione di modelli di documenti di disegno di layout, consulta la pagina Creazione di documenti modello per cablaggi.

  • Le proprietà predefinite degli oggetti del disegno di layout del cablaggio possono essere configurate nella pagina Progettazione del cablaggio – Impostazioni predefinite della finestra di dialogo Preferences. Queste proprietà verranno applicate agli oggetti posizionati successivamente.

  • Durante la creazione di un documento di disegno di layout del cablaggio, puoi utilizzare anche oggetti di testo e di disegno. L'utilizzo di questi oggetti in un documento di disegno di layout del cablaggio è simile al loro utilizzo in un documento schematico (*.SchDoc) di un progetto PCB. Per ulteriori informazioni su questi oggetti, consulta Utilizzo degli oggetti di testo in uno schema e Utilizzo degli oggetti di disegno in uno schema.

    • Tieni presente che i collegamenti attivi agli oggetti dello schema di cablaggio (ad esempio fili e componenti) e agli oggetti del disegno di layout del cablaggio (ad esempio fasci e punti di connessione) sono supportati anche nei riquadri di testo e nelle note. Fai clic su un collegamento nel riquadro di testo o nella nota posizionati per individuare tramite cross-probing l'oggetto nel documento associato.

  • Per verificare la presenza di violazioni logiche, elettriche e di disegno nel disegno di layout del cablaggio, sono disponibili diversi controlli. Per ulteriori informazioni, consulta la pagina Convalida del progetto di cablaggio.

  • Un documento di disegno di layout del cablaggio può essere salvato in formato ASCII, utile per la condivisione. Utilizza il comando File » Save As e seleziona Harness Layout ascii (*.LdrDoc) dal menu a discesa Save as type nella finestra di dialogo Save As che si apre. Quando salvi un disegno di layout ASCII utilizzando il comando File » Save, si apre la finestra di dialogo File Format, che ti avvisa che è in uso il formato ASCII. Scegli la versione ASCII nella finestra di dialogo  per continuare a utilizzare questo formato.

Importazione dei dati dallo schema di cablaggio

Seleziona il comando Design » Import Wiring Diagram dai menu principali per importare i dati di progetto dallo schema di cablaggio. Il componente verrà posizionato sul foglio del disegno di layout nelle posizioni relative definite nello schema di cablaggio. Anche i punti di connessione associati ai componenti verranno posizionati accanto a ciascun componente nel disegno di layout.

Un documento di disegno di layout del cablaggio con i dati importati dallo schema di cablaggio
Un documento di disegno di layout del cablaggio con i dati importati dallo schema di cablaggio

 
 
 
 
 
  • Dopo aver utilizzato il comando, le modifiche applicate vengono elencate nel pannello Messages ().

  • Qualsiasi modifica allo schema di cablaggio può essere importata nel disegno utilizzando lo stesso comando Design » Import Wiring Diagram.

Utilizzo dei componenti

Inizialmente, ogni componente è rappresentato nel disegno di layout dal proprio simbolo. Le proprietà di un componente posizionato possono essere configurate nel pannello Properties quando il componente è selezionato nell'area di progettazione. Il pannello Properties di un componente include le seguenti schede:

 
 
 
 
 
  • General – proprietà generali del componente, come designatore e commento, posizione, rappresentazione del modello, parametri, ecc.

  • Pins – l'elenco dei pin del componente.

  • Cavities – una vista di sola lettura delle cavità del connettore assegnate al componente. Le assegnazioni delle cavità possono essere modificate solo nello schema di cablaggio – scopri di più.

  • Associated Parts – consente di assegnare al componente parti aggiuntive, come guaine termorestringenti.

Quando si incollano componenti di cablaggio tagliati o copiati in un disegno di layout del cablaggio, i designatori dei componenti incollati rispettano l'opzione Reset Parts Designators On Paste nella pagina Schematic – Graphical Editing della finestra di dialogo Preferences. Quando i componenti vengono incollati, la parte numerica dei relativi designatori viene reimpostata su ? se l'opzione è abilitata.

Configurazione della rappresentazione di un componente

Utilizzando l'opzione Graphical Symbol / Physical Model nell'area Model del pannello Properties (nella scheda General) quando è selezionato un componente, è possibile passare dalla rappresentazione simbolica (il simbolo del componente) alla proiezione del modello 3D (il footprint del componente). Utilizzare le altre impostazioni nell'area del pannello per configurare la rappresentazione.

Javascript ID: Harness_LD_HarnessComponent_ModelType_AD25

Un componente rappresentato dal suo simbolo schematico

Lo stesso componente rappresentato dalla proiezione del suo modello 3D

Quando si utilizza la rappresentazione Physical Model, utilizzare le opzioni Style per visualizzare il modello come Solid (senza linee) oppure come Wireframe. Utilizzare le opzioni del menu a discesa Side per selezionare il lato desiderato della vista del modello (sono disponibili opzioni ortogonali e isometriche). Le immagini seguenti mostrano alcune impostazioni con i risultati corrispondenti nell'area di progettazione.

Javascript ID: Harness_LD_HarnessComponent_ModelType_Footprint_Config_AD25

Una vista del modello fisico può essere ruotata graficamente nell'area di progettazione trascinando con il mouse la maniglia di rotazione situata in basso a destra della vista del modello; il campo Rotation si aggiornerà automaticamente (la rotazione avviene con incrementi di 1 grado). È inoltre possibile tenere premuto il tasto Alt per vincolare la rotazione a incrementi di 45 gradi. Come utile riferimento, durante la rotazione della vista con il mouse, l'angolo corrente viene visualizzato in Status Bar.

Se un progetto contenente modelli ruotati utilizzando valori personalizzati viene aperto in una versione di Altium Designer precedente alla 26.9, viene visualizzato un messaggio di avviso sulla compatibilità con le versioni precedenti. È possibile rigenerare i modelli fisici utilizzando la funzionalità precedente, ovvero le selezioni dei menu a discesa. 

  • Per entrambi gli stili Solid e Wireframe, il valore Zoom definisce le dimensioni del rettangolo di delimitazione verde della vista del modello nell'area di progettazione; la vista del modello si adatta sempre al rettangolo di delimitazione.

  • Per facilitare l'integrazione quando si utilizza Altium MCAD CoDesigner con progetti di cablaggio, i modelli 3D utilizzati nelle viste fisiche dei componenti di cablaggio vengono incorporati (in formato Parasolid) nel documento del disegno di layout. Gli eventuali modelli 3D mancanti (esistenti ma non incorporati) verranno incorporati dopo il salvataggio del documento (File » Save). Questa funzionalità è in Open Beta ed è disponibile quando l'opzione HarnessDesign.Embed3DModel è abilitata nella finestra di dialogo Advanced Settings.

Adding Multiple Physical Model Views

  • Utilizzare la freccia del menu a discesa per visualizzare e modificare le proprietà di una vista fisica ().

  • È possibile aggiungere più viste del modello fisico per un componente utilizzando il controllo Add Component View nel pannello Properties ().

  • Le viste fisiche aggiuntive inserite per un componente possono essere spostate indipendentemente nell'area di progettazione mediante trascinamento.

  • Indipendentemente dalla vista del modello fisico di un componente selezionata nell'area di progettazione, il pannello Properties visualizza le proprietà del componente stesso.

Definizione della disposizione fisica in un disegno di layout del cablaggio

Tutti i collegamenti fisici all'interno del cablaggio sono definiti come fasci di cablaggio (anche se un fascio contiene un solo filo). Ogni fascio deve iniziare e terminare in un punto di connessione. Durante l'importazione iniziale dei dati di progettazione del cablaggio (come descritto sopra), accanto a ciascun componente viene posizionato automaticamente un punto di connessione, che viene associato al componente e a tutti i suoi pin. Se la struttura fisica del progetto lo richiede, è possibile posizionare nuovi punti di connessione e configurare gli oggetti assegnati a un punto di connessione.

Per comprendere meglio la connettività dei componenti nel documento del disegno di layout del cablaggio, puoi visualizzare il grafo di connettività nel documento. Quando l'opzione Connective Graph è abilitata nella pagina System – Navigation della finestra di dialogo Preferences, usa la scorciatoia Alt+Click su un componente per visualizzare il grafo di connettività nell'area di progettazione (). Cancella il grafo usando la scorciatoia Shift+C o il comando Clear Filter dal menu contestuale dell'area di progettazione.

Utilizzo dei punti di connessione

Per posizionare un nuovo punto di connessione, usa il comando Place » Connection Point dai menu principali. I punti di connessione vengono visualizzati nell'area di progettazione come mostrato di seguito.

Le proprietà di un punto di connessione posizionato (posizione, rappresentazione visiva, ecc.) possono essere configurate nel pannello Properties quando il punto di connessione è selezionato nell'area di progettazione.

Il pannello Properties quando è selezionato un punto di connessione
Il pannello Properties quando è selezionato un punto di connessione

Usa l'area Associated Parts del pannello Properties per un punto di connessione selezionato per gestire l'elenco delle parti associate al punto di connessione, ovvero gli oggetti fisici che desideri associare alla rappresentazione grafica visualizzata. Il modello 3D di una parte associata a un punto di connessione può essere utilizzato per rappresentare il punto di connessione nel documento. Quando è selezionato un punto di connessione, scegli Physical Model nell'area Properties del pannello Properties, quindi usa il menu a discesa Associated Part nell'area Type per selezionare la parte associata desiderata (). Il modello verrà generato e visualizzato nel documento. Usa le opzioni nell'area Type per configurare la visualizzazione del modello ().

Per facilitare l'integrazione quando si utilizza Altium MCAD CoDesigner con i progetti di cablaggio, i modelli 3D utilizzati nelle viste fisiche dei punti di connessione vengono incorporati (in formato Parasolid) nel documento del disegno di layout. Eventuali modelli 3D mancanti (esistenti ma non incorporati) verranno incorporati dopo il salvataggio del documento (File » Save). Questa funzionalità è in Open Beta ed è disponibile quando l'opzione HarnessDesign.Embed3DModel è abilitata nella finestra di dialogo Advanced Settings.

Assegnazione di oggetti ai punti di connessione

Gli oggetti assegnati a un punto di connessione possono essere configurati secondo le esigenze progettuali. È possibile assegnare uno o più oggetti (componenti, giunzioni/derivazioni, oggetti 'non connesso' e schermature con connessione) a un punto di connessione utilizzando la finestra di dialogo Add Assigned Objects, accessibile facendo clic sul pulsante   nell'area Assigned Objects  del pannello Properties .

  • Per impostazione predefinita, l'opzione Show only unassigned objects è abilitata nella finestra di dialogo e vengono elencati solo gli oggetti che non sono attualmente assegnati ad altri punti di connessione. Disabilita l'opzione per visualizzare un elenco di tutti gli oggetti nel disegno di layout.

  • Se nella finestra di dialogo viene selezionato un oggetto già assegnato a un altro punto di connessione, verranno visualizzati le icone e gli avvisi corrispondenti ().

  • Per evitare di assegnare una giunzione a più di un punto di connessione, una giunzione viene rimossa automaticamente da un punto di connessione se è già assegnata a un altro punto di connessione.

Quando un componente viene assegnato a un punto di connessione, nell'area di progettazione viene visualizzata una linea tratto-punto tra il componente e il punto di connessione, come mostrato di seguito. In Properties, puoi selezionare quali pin del componente assegnare. Fai clic sulla cella nella colonna Pins della griglia nell'area Assigned Objects per accedere al menu a discesa e selezionare i pin del componente desiderati.

Quando trascini un punto di connessione su un altro (dove consentito) nel disegno di layout, i due vengono uniti in un unico oggetto e i rispettivi elenchi di oggetti assegnati vengono combinati.

Utilizzo dei fasci di cablaggio

Per posizionare un nuovo fascio di cablaggio, usa il comando Place » Harness Bundle dai menu principali (scorciatoia: Shift+B).

Dopo aver selezionato il comando, fai clic su un punto di connessione (una croce rossa appare in corrispondenza del cursore quando si trova sull'hotspot di un punto di connessione) per posizionare il punto iniziale del fascio di cablaggio. Posiziona il cursore e fai clic per fissare una serie di vertici che definiscono la forma del fascio di cablaggio. Dopo aver posizionato l'ultimo vertice sull'hotspot di un altro punto di connessione, fai clic con il pulsante destro del mouse per completare il posizionamento.

Per impostazione predefinita, un fascio di cablaggio viene posizionato utilizzando la modalità di posizionamento Any Angle. Durante il posizionamento di un fascio di cablaggio, premi Shift+Spacebar per scorrere le modalità di posizionamento. La modalità determina come vengono creati gli angoli durante il posizionamento dei fasci e con quali angolazioni è possibile posizionarli.  Nelle modalità 90 Degree o 45 Degree (modalità ortogonali vere e proprie), premi Spacebar per passare dalla sottomodalità iniziale a quella finale e viceversa. La modalità e la sottomodalità correnti vengono visualizzate nella barra di stato.

Esempio di un fascio di cablaggio posizionato tra i punti di connessione CP1 e CP_P2.
Esempio di un fascio di cablaggio posizionato tra i punti di connessione CP1 e CP_P2.

Una volta posizionato e selezionato un fascio di cablaggio, è possibile trascinarne i vertici per modificare l'angolo tra due sezioni adiacenti.

  • Quando i fasci di cablaggio vengono collegati a un punto di connessione, le giunzioni attualmente non assegnate vengono assegnate automaticamente al punto di connessione in base allo schema di cablaggio.

  • È possibile posizionare un punto di connessione direttamente su un fascio di cablaggio esistente. In questo modo il fascio di cablaggio originale viene diviso in due fasci separati.

  • Quando si rimuove un punto di connessione che divide in due un fascio in un disegno di layout, i due fasci vengono automaticamente uniti in un unico oggetto fascio.

Le proprietà di un fascio di cablaggio posizionato (posizione, rappresentazione visiva, ecc.) possono essere configurate nel pannello Properties quando il fascio di cablaggio è selezionato nell'area di progettazione.

Il pannello Properties quando è selezionato un fascio di cablaggio
Il pannello Properties quando è selezionato un fascio di cablaggio

Ogni fascio di cablaggio contiene automaticamente gli oggetti (fili e/o cavi) in base alla connettività definita nello schema di cablaggio. Questi oggetti sono elencati nella sezione Bundle Objects del pannello Properties quando il fascio è selezionato. Fare clic su un oggetto in questo elenco per evidenziare tutti i fasci attraversati dall'oggetto selezionato.

Nel caso di una struttura fisica complessa e ramificata di un fascio, potrebbe essere necessario modificare l'assegnazione di un filo a un altro fascio. Utilizzare il menu a discesa nella sezione Bundle Objects Assignment del pannello Properties quando il fascio desiderato è selezionato nell'area di progettazione, per aggiornare l'assegnazione del filo a questo fascio secondo necessità.

Utilizzando il campo Length nella sezione Properties del pannello, è possibile definire la lunghezza del fascio selezionato. Le lunghezze dei fili e dei cavi che attraversano i fasci vengono calcolate in base ai valori di Length di questi fasci. I valori calcolati della lunghezza di fili/cavi sono visualizzati nella colonna Length Value della griglia nella sezione Bundle Objects del pannello.

Aggiunta di una vista della sezione dei fili

La vista della sezione dei fili mostra i fili presenti all'interno del segmento, ovvero fili singoli, coppie di fili intrecciati e fili che fanno parte di cavi. Ciò consente di vedere esattamente come sono disposti fisicamente i fili all'interno del segmento del fascio di cablaggio. Ogni filo è etichettato e visualizzato con il colore definito per il filo e con uno spessore basato sul valore del relativo parametro Thickness (definito nello schema di cablaggio (*.WirDoc)). È possibile inserire una vista della sezione di un segmento di fascio posizionato in un disegno di layout (*.LdrDoc) utilizzando il comando Add Segment View nella sezione Model del pannello Properties . La sezione Segment View mostra quindi un menu a discesa in cui è possibile selezionare il livello di Zoom per la vista aggiunta. L'area di progettazione ingrandisce la vista, come mostrato nella presentazione di esempio seguente. Per eliminare una vista della sezione, utilizzare il comando Delete nella sezione Segment View. Fare clic per selezionare la vista e spostarla nella posizione desiderata nell'area di progettazione.

Fare clic su Add Segment View per aggiungere una nuova vista.

Il menu a discesa Zoom consente di scegliere il livello di zoom desiderato per la vista della sezione. 

Le proprietà dei fili dello schema di cablaggio vengono trasferite alla vista della sezione, come mostrato per W9.

Per rimuovere la vista della sezione, fare clic su Delete.  

Aggiunta di un punto di interruzione

È possibile posizionare un punto di interruzione su un fascio di cablaggio per indicare che il fascio non è in scala (NTS). Il fascio mostrerà un simbolo di interruzione al centro del segmento più lungo, come illustrato nella prima immagine seguente, e nelle proprietà verrà visualizzato Drawn Length. Per inserire un'interruzione, abilitare l'opzione Add Break Symbol nella sezione Properties delle proprietà del fascio. Anche i rivestimenti che ricoprono un fascio di cablaggio con un punto di interruzione mostreranno l'interruzione nella stessa posizione. Se il rivestimento termina in corrispondenza del punto di interruzione del fascio di cablaggio, verrà disegnato leggermente più lungo, come mostrato nella seconda immagine.

Un punto di interruzione posizionato su un fascio

Un rivestimento posizionato sopra un punto di interruzione esistente

 
  • Se lo si desidera, è possibile sovrascrivere la lunghezza calcolata per un filo/cavo. Immettere il valore Offset Length desiderato oppure scegliere Manual nel menu a discesa della colonna Length Type per definire manualmente la lunghezza assoluta desiderata.

  • Per i fili la cui lunghezza è stata definita in uno strumento MCAD e successivamente importata in Altium Designer tramite MCAD CoDesigner, la voce MCAD CoDesigner verrà visualizzata nella voce Length Type. In questo caso, non è possibile definire Offset Length, ma è possibile sovrascrivere il valore della lunghezza selezionando Manual dal menu a discesa (). Per saperne di più, consultare Sincronizzazione di un progetto di cablaggio tramite MCAD CoDesigner.

  • Le unità con cui il valore Length di un fascio e i valori Length Value e Offset Length dei suoi oggetti vengono visualizzati nel pannello Properties quando il fascio è selezionato si specificano utilizzando il menu a discesa Length Units nella scheda General del pannello Properties quando nessun oggetto è selezionato nel documento.

Riassegnazione degli oggetti del fascio

È possibile riassegnare gli oggetti del fascio in un disegno di layout in cui un filo può seguire più percorsi tra il connettore di origine e quello di destinazione. Per impostazione predefinita, il filo viene assegnato automaticamente al percorso più breve, ma è possibile modificare questa assegnazione. Il controllo Assign Objects to Bundle compare nella parte inferiore della sezione Bundle Objects del pannello Properties (con il fascio selezionato nell'area di progettazione), e solo quando esiste un percorso alternativo. Si apre la finestra di dialogo Assign Objects to Bundle , nella quale è possibile selezionare gli oggetti (fili/cavi) da spostare tra i fasci applicabili e validi.

Rivestimento dei fasci di cablaggio

È possibile posizionare un oggetto rivestimento del cablaggio (Place » Harness Covering) su un fascio di cablaggio. La lunghezza del rivestimento può essere modificata graficamente nell'area di progettazione durante o dopo il posizionamento.

Dopo aver selezionato un comando di posizionamento del rivestimento del cablaggio, quando il cursore si trova sopra un fascio di cablaggio, nell'area di progettazione compare un punto arancione, che indica che il rivestimento può essere posizionato (un punto grigio indica che il rivestimento non può essere posizionato in quel punto specifico). Fare clic nel punto in cui si desidera far iniziare il rivestimento, quindi spostare il cursore lungo il fascio fino al punto in cui si desidera farlo terminare e fare nuovamente clic. I rivestimenti del cablaggio possono sovrapporsi, come mostrato nel video seguente. È inoltre possibile applicare o estendere un rivestimento del cablaggio oltre un punto di giunzione (un punto di connessione nel disegno di layout in cui si incontrano due o più fasci). In questo modo non è necessario avere rivestimenti separati tra i punti di giunzione in una sezione che contiene più connettori.

L'inizio di un rivestimento viene identificato come il punto più a sinistra e più in alto del suo percorso, e il percorso include solo i fasci su cui poggia il rivestimento.

Le proprietà di un rivestimento del cablaggio posizionato possono essere configurate nel pannello Properties quando il rivestimento è selezionato nell'area di progettazione.

Il pannello Properties quando è selezionato un rivestimento del cablaggio
Il pannello Properties quando è selezionato un rivestimento del cablaggio

È possibile definire le dimensioni di un oggetto rivestimento del cablaggio rispetto alle dimensioni del fascio che ricopre (il valore Line Width del fascio) utilizzando il menu a discesa Size nel pannello Properties. Scorrere le immagini seguenti per vedere esempi di rivestimenti di diverse dimensioni applicati a fasci di cablaggio di varie dimensioni.

 
 
 
 
 
 

Una volta posizionato un rivestimento del cablaggio nel disegno di layout, è possibile assegnargli un componente di libreria (oppure, se al rivestimento è già assegnato un componente, è possibile selezionarne un altro). A tale scopo, selezionare il rivestimento e fare clic sul pulsante  a destra del campo Design Item ID nella sezione General del pannello Properties. Nella finestra di dialogo Replace che si apre, individuare e selezionare il componente desiderato. Il rivestimento posizionato verrà aggiornato con i parametri del componente scelto.

Aggiunta di etichette di layout

È possibile posizionare etichette fisiche nel disegno di layout (Place » Layout Label).

Le proprietà di un'etichetta di layout posizionata (designatore, testo, rappresentazione visiva, ecc.) possono essere configurate nel pannello Properties quando l'etichetta è selezionata nell'area di progettazione.

Il pannello Properties quando è selezionata un'etichetta di layout
Il pannello Properties quando è selezionata un'etichetta di layout

Quando si definisce il testo dell'etichetta nel campo Text, utilizzare Ctrl+Enter o Shift+Enter per aggiungere una nuova riga di testo. Abilitare Show only first line per visualizzare solo la prima riga del campo Text nell'area di progettazione. Il testo dell'etichetta di layout può anche essere allineato secondo le proprie esigenze utilizzando i controlli Alignment.

Javascript ID: Harness_LD_LayoutLabel_TextOptions_AD25

Aggiunta di etichette di layout ai fasci

Le etichette di layout seguono automaticamente l'orientamento del fascio di cablaggio a cui sono associate. L'etichetta di layout si «aggancia» al fascio per seguirne l'orientamento e il percorso. Durante o dopo il posizionamento dell'etichetta di layout, premere Spacebar per ruotare l'etichetta con incrementi di 90 gradi oppure aggiornare il valore Rotation nel pannello Properties .

Se non si desidera che l'etichetta segua l'orientamento del fascio (ovvero che non sia «agganciata»), premere il tasto Alt durante il posizionamento per posizionare l'etichetta nel punto desiderato, come mostrato nel video seguente.

Quando si sposta il fascio che include un'etichetta «agganciata», la posizione dell'etichetta di layout viene ricalcolata e segue il fascio.

  • Per visualizzare il testo dell'etichetta nella BOM, puoi abilitare la colonna Label Text nel documento ActiveBOM del progetto () oppure nella tabella BOM del disegno di produzione (). Tieni presente che la proprietà Type dell'etichetta di layout deve essere impostata su Standard affinché compaia nella BOM ().

  • Una volta posizionata un'etichetta di layout nel disegno di layout, puoi assegnarle un componente di libreria (oppure, se all'etichetta di layout è già assegnato un componente, puoi selezionarne un altro). A tale scopo, seleziona l'etichetta di layout e fai clic sul pulsante  a destra del campo Design Item ID nell'area General del pannello Properties. Nella finestra di dialogo Replace che si apre, cerca e seleziona il componente desiderato. L'etichetta di layout posizionata verrà aggiornata con i parametri del componente scelto.

Aggiornamento degli oggetti del disegno di layout dalle librerie

I seguenti oggetti possono essere aggiornati dalla rispettiva libreria di origine del Workspace:

  • Componenti del cablaggio

  • Parti associate ai componenti del cablaggio

  • Parti associate ai punti di connessione

  • Rivestimenti del cablaggio

  • Etichette di layout

Quando è selezionato un oggetto, le informazioni sul componente del Workspace collegato sono disponibili nel pannello Properties (ad esempio, nella scheda Associated Parts per le parti associate a un componente del cablaggio o nell'area General per un'etichetta di layout).

Se è disponibile una revisione più recente del componente del Workspace, la voce relativa allo stato della revisione lo segnalerà con il testo Out of date. Per il singolo oggetto, il collegamento può essere aggiornato all'ultima revisione del componente del Workspace facendo clic sul pulsante .

Esempio di indicazione di una revisione non aggiornata di un componente del cablaggio​
Esempio di indicazione di una revisione non aggiornata di un componente del cablaggio

La funzionalità Update from Libraries (Tools » Update from Libraries) può essere utilizzata anche per aggiornare i componenti non aggiornati collegati agli oggetti elencati sopra. Tieni presente che, affinché un oggetto venga incluso nell'aggiornamento tramite la funzionalità Update from Libraries, il componente assegnato all'oggetto deve includere un collegamento a un simbolo schematico.

Annotazione degli oggetti del disegno di layout del cablaggio

Utilizza i comandi nel menu Tools » Annotation per annotare i seguenti oggetti nel documento del disegno di layout del cablaggio:

  • Componenti del cablaggio

  • Punti di connessione

  • Fasci del cablaggio

  • Rivestimenti del cablaggio

  • Etichette di layout

L'annotazione degli oggetti in un documento del disegno di layout del cablaggio è simile all'annotazione dei componenti in un documento schematico (*.SchDoc) di un progetto PCB. Utilizza i seguenti collegamenti per saperne di più sui comandi di annotazione disponibili per un documento del disegno di layout del cablaggio:

Cross-probing tra schema di cablaggio e disegno di layout

È supportato il cross-probing tra lo schema di cablaggio e il disegno di layout di un progetto di cablaggio. Il comando Cross Probe è accessibile dal menu principale Tools e dal menu contestuale nello spazio di progettazione.

Il cross-probing può essere eseguito:

  • Tra i componenti nello schema di cablaggio e nel disegno di layout.

  • Da un filo nello schema di cablaggio al fascio o ai fasci attraverso cui passa nel disegno di layout.

  • Da un fascio nel disegno di layout al filo o ai fili che passano attraverso tale fascio nello schema di cablaggio.

Javascript ID: Harness_CrossProbe_AD25

Individuazione incrociata da un componente nello schema di cablaggio al componente corrispondente nel disegno di layout.

Individuazione incrociata da un componente nel disegno di layout al componente corrispondente nello schema di cablaggio.

Individuazione incrociata da un filo nello schema di cablaggio ai fasci corrispondenti nel disegno di layout.

Individuazione incrociata da un fascio nel disegno di layout ai fili corrispondenti nello schema di cablaggio.

AI-LocalizedLocalizzato tramite A
Se trovi un problema, seleziona il testo/l’immagine e premi Ctrl + Enter per inviarci il tuo feedback.
Contents
Disponibilità delle funzionalità

Le funzionalità a tua disposizione dipendono dalla soluzione Altium di cui disponi: Altium Develop, Altium Agile Teams, Altium Agile Enterprise oppure Altium Designer (con abbonamento attivo).

Se non vedi una funzionalità documentata nel software che stai effettivamente utilizzando, contatta il reparto vendite di Altium per saperne di più.

Documentazione legacy

La documentazione di Altium Designer non è più suddivisa per versione. Se è necessario accedere alla documentazione delle versioni precedenti di Altium Designer, visitare la sezione Documentazione legacy della pagina Altri programmi di installazione.

Contents