문서 탐색

Altium Training

Altium Essentials: Navigating Schematics

This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.

Schematic 시트, PCB 문서 또는 Draftsman 문서와 같은 그래픽 문서로 작업할 때 문서를 확대/축소하고 이동하여 특정 영역에 집중할 수 있습니다. 이를 위한 기본 단축키는 다음과 같습니다.

  • Ctrl+Mouse Wheel 확대 및 축소
  • Right-Click, Hold&Drag 문서 이동

View 주 메뉴에는 현재 문서의 보기를 제어할 수 있는 여러 명령이 포함되어 있습니다.

View 주 메뉴의 명령을 사용하여 문서의 보기를 제어합니다. 위쪽 이미지는 Schematic Editor의 View 메뉴를, 아래쪽 이미지는 PCB Editor의 View 메뉴를 보여줍니다.

View 주 메뉴의 명령을 사용하여 문서의 보기를 제어합니다. 위쪽 이미지는 Schematic Editor의 View 메뉴를, 아래쪽 이미지는 PCB Editor의 View 메뉴를 보여줍니다.

이러한 명령에는 다음이 포함됩니다.

  • Fit Document - 현재 문서의 전체 영역을 표시합니다.

  • Fit All Objects - 현재 문서의 모든 설계 객체를 표시합니다.

  • Area - 현재 문서에서 사용자가 지정한 영역을 확대합니다.

  • Around Point - 현재 문서에서 지정한 지점을 중심으로 표시 영역을 다시 설정합니다.

  • Selected Objects - 선택한 모든 객체가 보이도록 설계 공간의 보기를 변경합니다.

  • Zoom In - 현재 문서에서 커서 위치를 기준으로 설계를 확대합니다.

  • Zoom Out - 현재 문서에서 커서 위치를 기준으로 설계를 축소합니다.

  • Zoom Last - 현재 문서의 화면을 이전 보기로 되돌립니다.

Z 단축키를 사용하여 확대/축소 명령이 있는 팝업 메뉴에 접근할 수도 있습니다.

PCB 및 PCB 풋프린트 Editor에서는 이 메뉴를 통해 Select 명령에 접근할 수 있습니다. 이 명령은 Zoom Value (0.001x..4x) 대화 상자를 열며, 여기서 지정한 값으로 현재 문서의 표시 배율을 변경할 수 있습니다. 1보다 큰 값을 입력하면 더 크게 확대됩니다(배율 증가). 1보다 작은 값을 사용하면 더 작게 축소됩니다(배율 감소).

Zoom Value 대화 상자
Zoom Value 대화 상자

PCB 또는 PCB 풋프린트 문서를 3D로 볼 때는 보기를 원활하게 탐색할 수 있는 추가 명령, 단축키 및 컨트롤을 사용할 수 있습니다. 자세한 내용은 3D 보기 제어 페이지를 참조하세요.

문서의 특정 지점으로 이동

Schematic, Schematic 심볼, PCB 또는 PCB 풋프린트 Editor의 주 메뉴에 있는 Edit » Jump 하위 메뉴의 명령을 사용하면 활성 문서의 특정 지점으로 이동할 수 있습니다. 설계 공간에서 J 키를 눌러 Jump 팝업 메뉴에 접근할 수도 있습니다. 예를 들어 다음 위치로 이동할 수 있습니다.

  • 문서의 원점 좌표:
    • Schematic 시트의 원점(왼쪽 아래 모서리에 해당) - Origin;

    • PCB 문서의 절대 원점 - Absolute Origin;

    • 현재 PCB 문서의 상대 원점 - Current Origin;

    • PCB 풋프린트 문서의 컴포넌트 기준점 위치 - Reference;

  • 사용자가 지정한 XY 좌표에 따른 현재 문서 내의 임의 위치 - New Location 명령을 선택하고, 나타나는 Jump To Location 대화 상자에서 커서를 이동하려는 설계 공간 내 위치의 X 및 Y 좌표 값을 입력합니다. PCB Editor에서는 Delta X 및 Delta Y 필드를 사용하여 이동하려는 위치의 델타 X 및 Y 좌표를 지정할 수도 있습니다.

    Jump To Location 대화 상자 - Schematic Editor(첫 번째 이미지) 및 PCB Editor(두 번째 이미지)
    Jump To Location 대화 상자 - Schematic Editor(첫 번째 이미지) 및 PCB Editor(두 번째 이미지)

  • 문서 내의 객체. 원하는 객체로 이동하려면 다음 명령을 사용합니다.
    • Schematic 시트의 컴포넌트 - Jump Component. 명령을 실행하면 Component Designator 대화 상자가 나타납니다. 이동하려는 컴포넌트의 Designator를 입력합니다. Designator가 유효하고 활성 프로젝트의 Schematic 소스 문서에 해당 컴포넌트가 존재하면, 관련 Schematic 문서가 활성 문서로 설정되고 타겟 컴포넌트가 확대되어 설계 공간의 중앙에 표시됩니다(가능한 경우). 찾은 컴포넌트(또는 멀티파트 컴포넌트의 모든 파트)는 Messages Panel에도 나열됩니다. 메시지 Entry를 두 번 클릭하면 설계 공간에서 해당 컴포넌트(또는 해당 파트)로 이동합니다.

      Component Designator 대화 상자
      Component Designator 대화 상자

      멀티파트 컴포넌트를 타겟으로 지정할 때는 기본 Designator만 입력하세요. 파트 접미사는 포함하지 마세요. 예를 들어 파트가 IC1_CPA 및 IC1_CPB으로 지정된 2파트 IC 컴포넌트로 이동하려면 Component Designator 대화 상자에 IC1_CP을 입력합니다. 멀티파트 컴포넌트의 경우 첫 번째 파트가 강조 표시되고 Find Text - Jump 대화 상자가 열립니다. 이 대화 상자를 사용하여 컴포넌트의 하위 파트 간에 이동할 수 있습니다.
      Component Designator 대화 상자에서 Physical 옵션을 활성화하면 이동 기능의 대상을 Physical 컴포넌트 Designator, 즉 소스 Schematic 문서의 Compiled Document 탭 보기에 표시되는 Designator로만 제한할 수 있습니다. 이 옵션을 비활성화하면 이동 기능은 Logical Designator, 즉 소스 Schematic 문서의 Editor 탭 보기에 표시되는 Designator만 고려합니다.
    • PCB 문서의 특정 컴포넌트 - Component. 명령을 실행하면 Component Designator 대화 상자가 나타납니다. 컴포넌트 Designator를 입력하여 해당 컴포넌트로 이동합니다. Designator를 잘 모르는 경우 ?을 입력하고 OK 을 클릭하여 설계의 모든 컴포넌트가 나열된 Components Placed 대화 상자를 엽니다. Mask 필드에 텍스트를 입력하여 원하는 컴포넌트를 검색합니다. 입력하는 동안 마스크 문자열과 일치하는 문자열만 표시되도록 목록이 필터링됩니다. 문자열에 ?(임의의 한 문자) 및 *(임의의 문자들) 와일드카드를 사용할 수 있습니다. 커서는 선택한 컴포넌트의 기준점으로 이동합니다.

      Component Designator 대화 상자에 ?을 입력하면 PCB의 모든 컴포넌트가 나열된 Components Placed 대화 상자에 접근할 수 있습니다.
      Component Designator 대화 상자에 ?을 입력하면 PCB의 모든 컴포넌트가 나열된 Components Placed 대화 상자에 접근할 수 있습니다.

    • PCB 문서의 특정 Net - Net. 명령을 실행하면 Net Name 대화 상자가 나타납니다. 이동하려는 Net의 이름을 입력하거나, ?을 입력하고 OK 을 눌러 설계에 로드된 모든 Net 목록이 포함된 Nets Loaded 대화 상자를 엽니다. Mask 필드에 텍스트를 입력하여 원하는 Net을 검색합니다. 입력하는 동안 마스크 문자열과 일치하는 문자열만 표시되도록 목록이 필터링됩니다. 마스크 문자열에 ?(임의의 한 문자) 및 *(임의의 문자들) 와일드카드를 사용할 수 있습니다. 타겟 Net이 이미 기본 설계 창에 표시되어 있으면 커서는 해당 Net에 속한 가장 가까운 설계 객체로 이동합니다. Net이 현재 보기에 표시되어 있지 않으면 커서는 해당 Net에 속한 가장 가까운 설계 객체에 위치하며, 해당 객체가 설계 공간의 중앙에 표시됩니다(가능한 경우).

      Net Name 대화 상자에 ?을 입력하면 PCB의 모든 Net이 나열된 Nets Loaded 대화 상자에 접근할 수 있습니다.Net Name 대화 상자에 ?을 입력하면 PCB의 모든 Net이 나열된 Nets Loaded 대화 상자에 접근할 수 있습니다.

    • PCB 문서의 특정 컴포넌트 Pad - Pad. 명령을 실행하면 Jump To Pad Number 대화상자가 나타납니다. 원하는 컴포넌트의 Pad를 ComponentDesignator-PadDesignator 형식(예: U1-6)으로 입력하고 OK을 클릭합니다. 타겟 Pad가 설계 공간에 이미 표시되어 있으면 커서가 해당 Pad의 중심으로 바로 이동합니다. Pad가 현재 화면에 보이지 않으면 커서가 해당 Pad의 중심에 놓이고, 가능한 경우 해당 위치가 설계 공간의 중앙에 표시됩니다.

      Jump To Pad Number 대화상자
      Jump To Pad Number 대화상자

    • PCB 문서의 특정 문자열 - String. 명령을 실행하면 Jump To String 대화상자가 나타납니다. 이동하려는 문자열을 입력하거나, ?을 입력하고 OK 을 클릭하여 Strings 대화상자를 엽니다. 이 대화상자에는 활성 보드 문서에 있는 모든 문자열(독립 문자열 및 다른 그룹 객체의 하위 문자열) 목록이 표시됩니다. 이 대화상자를 사용하면 이동하려는 문자열을 빠르게 찾을 수 있습니다. 타겟 문자열이 설계 공간에 이미 표시되어 있으면 커서가 해당 문자열의 기준점으로 바로 이동합니다. 기준점은 이동 작업 중 문자열을 잡는 지점이자 회전의 중심이 되는 지점입니다. 문자열이 현재 화면에 보이지 않으면 커서가 문자열의 기준점에 놓이고, 가능한 경우 해당 위치가 설계 공간의 중앙에 표시됩니다.

      Jump To String 대화상자에 ?을 입력하면 PCB의 모든 네트를 나열하는 Strings 대화상자를 열 수 있습니다.
      Jump To String 대화상자에 ?을 입력하면 PCB의 모든 네트를 나열하는 Strings 대화상자를 열 수 있습니다.

      시스템은 세 차례에 걸쳐 검색합니다. 먼저 지정된 문자열과 대소문자, 문자 및 길이가 모두 일치하는 문자열을 찾습니다. 다음으로 동일한 문자를 포함하되 문자가 더 있을 수 있는 문자열을 찾습니다. 마지막으로 대소문자를 구분하지 않고 동일한 문자를 포함하는 문자열을 찾습니다.

    • 현재 설계 문서의 모든 오류 마커로 이동하고 순차적으로 탐색 - Error Marker. 명령을 실행하면 커서가 첫 번째 Design Rule 검사(DRC) 오류 마커로 이동하고, 해당 마커가 기본 설계 창의 중앙에 표시됩니다. 명령을 반복해서 실행하면 두 번째 오류 마커 등으로 차례로 이동합니다. 이 명령은 위반 사항의 예외 처리 여부와 관계없이 오류 마커로 이동합니다.

      커서 아래 객체와 관련된 위반 사항을 확인하려면 마우스 오른쪽 버튼을 클릭하고 Violations 하위 메뉴에서 해당 명령을 선택합니다.

  • 현재 문서에서 선택된 모든 설계 객체로 이동하고 순차적으로 탐색 - Selection. 명령을 실행하면 커서가 첫 번째 선택 객체로 이동하며, 해당 객체가 확대되어 기본 설계 창의 중앙에 표시됩니다. 명령을 반복해서 실행하면 두 번째 선택 객체 등으로 차례로 이동하면서 현재 문서에서 선택된 모든 객체를 순환합니다. 이 명령은 객체가 처음 선택 항목에 추가된 순서대로 선택 객체를 순환합니다.

  • 지정된 위치 마커에 좌표가 미리 저장된 현재 Schematic 또는 PCB 문서의 위치 - Location Marks » n 명령을 선택하면 Set Location Marks » n 명령을 사용하여 지정된 위치 마커에 저장한 위치로 이동합니다.

    Schematic 문서에서는 문서가 열려 있는 동안에만 저장된 위치를 사용할 수 있습니다. 문서의 활성 여부는 관계없습니다. 문서를 닫았다가 다시 열면 위치 마커는 비어 있게 됩니다. PCB 문서에서는 위치 마커가 설계와 함께 저장되므로, 설계 세션이 바뀌어도 마커에 저장된 사용자 정의 위치에 계속 접근할 수 있습니다.
AI-LocalizedAI로 번역됨
만약 문제가 있으시다면, 텍스트/이미지를 선택하신 상태에서 Ctrl + Enter를 누르셔서 저희에게 피드백을 보내주세요.
Contents
기능 가용성

사용할 수 있는 기능은 보유한 Altium 솔루션(Altium Develop, Altium Agile Teams, Altium Agile Enterprise, 또는 Altium Designer(활성 기간 중))에 따라 달라집니다.

실제 소프트웨어에서 문서화된 기능이 보이지 않는 경우, Altium 영업팀에 문의하여 자세한 내용을 확인하세요.

구버전 문서

Altium Designer 문서는 더 이상 버전별로 제공되지 않습니다. 이전 버전의 Altium Designer 문서가 필요하신 경우, Other Installers 페이지의 Legacy Documentation 섹션을 방문해 주세요.