워크스페이스에 릴리스하기
개요
- 포함할 소스, 제작, 조립, Variant 및 Custom 데이터 세트를 파악하고 필요한 Output 작업을 할당하는 방법을 알아보세요.
- 릴리스 타겟 옵션, 워크스페이스 Item 명명 규칙, 타겟 리비전 제어 기능을 이해하세요.
- 릴리스 단계를 따라가며 자동화된 릴리스 명령이 검토, 보고서 생성 및 PLM 게시에 어떤 영향을 미치는지 알아보세요.
Online Mode의 Release 보기에서 릴리스 프로세스는 단계별로 진행되며, 보기 왼쪽의 항목을 통해 현재 진행 중인 단계를 한눈에 확인할 수 있습니다.
-
Configure Server Release – 릴리스 프로세스의 이 단계에서는 생성할 데이터 유형을 지정합니다. 소스 데이터(항상 생성됨), 제작 데이터, 조립 데이터(기본 설계 및 감지된 각 Variant용)를 지정할 수 있습니다.
-
Validate Project – 릴리스 프로세스의 다음 단계로, 할당된 OutJob 파일에서 하나 이상의 검증 유형 보고서가 감지되면 자동으로 실행됩니다. 릴리스할 데이터 Item에 할당된 Output Job 파일에 정의된 모든 검증 Output 생성기가 실행됩니다.
-
Generate Data – 릴리스 프로세스의 다음 단계로, 자동으로 실행됩니다. 이 단계에서는 포함된 데이터 Item에 할당된 OutJob 파일에 정의된 나머지 모든 Output을 실행하여, 워크스페이스의 해당 타겟 Item으로 릴리스할 데이터를 생성합니다.
-
Review Data – 모든 검증을 통과하고 Output 데이터가 생성되면, 릴리스 프로세스의 이 단계에서 생성된 데이터를 검토할 수 있습니다.
-
Upload Data – 이전 단계에서 릴리스를 확인하면 이 다음 단계로 자동 진입합니다. 이 단계에서는 타겟 워크스페이스에 있는 해당 데이터 Item의 리비전으로 데이터를 업로드하는 진행 상황을 보여줍니다.
-
Execution Report – 프로세스의 마지막 단계로, 릴리스 요약을 제공합니다. Explorer 패널에서 생성된 Item 리비전으로 빠르게 이동할 수 있는 탐색 링크가 제공됩니다. PLM으로 릴리스 및 게시하는 프로세스의 일부로 Project Releaser에 액세스한 경우
버튼이 표시됩니다. 이 버튼을 클릭하면 해당 프로세스의 워크플로를 계속 진행하여 PLM에 게시할 수 있습니다.
-
Publish to PLM – 이 단계는 관련 활성화 프로세스(릴리스 후 PLM에 게시하는 프로세스)를 통해 릴리스를 실행할 때만 표시됩니다. 이전 단계에서
버튼을 클릭하면 이 단계로 자동 진입합니다. 또는
버튼과 연결된 메뉴에서 Prepare & Release & Publish to PLM 명령을 사용한 경우 바로 이 단계로 진입합니다. Login Credentials 대화 상자가 표시됩니다. PLM 인스턴스의 Username 및 Password을(를) 입력하고 사용할 PLM 템플릿(<PLMInstance>:<PublishingTemplate>형식으로 표시됨)을 선택합니다.
온라인 1단계 – 서버 릴리스 구성
릴리스 프로세스의 이 단계에서는 생성할 데이터 유형을 지정합니다. 릴리스할 수 있는 데이터 Item은 다음과 같습니다.
- Source Data – 소스 설계의 스냅샷입니다.
- Fabrication Data – 제작 업체가 베어 보드를 제작하는 데 필요한 데이터입니다.
- Assembly Data for the Base Design (no variations) – 조립 업체가 BOM에 따라 베어 보드에 모든 부품을 실장하는 데 필요한 데이터로, 변경이 적용되지 않은 기본 설계용입니다.
-
Assembly Data for Design
Variant n– 조립 업체가 BOM에 따라 베어 보드에 부품을 실장하는 데 필요한 데이터로, 기본 설계의Variant n용입니다.
조립 데이터 세트의 수는 기본 설계(변경이 적용되지 않은 설계)와 해당 설계에 정의되어 감지된 모든 Variant의 수에 따라 결정됩니다.

프로젝트 릴리스 프로세스의 1단계 – 릴리스에 포함할 항목(생성할 데이터) 구성.
Source Data Item은 릴리스에 항상 포함됩니다. 나머지 데이터 Item은 선택적으로 포함할 수 있습니다.
Output Job 할당
Fabrication Data 및 Assembly Data Item을 릴리스에 포함하려면 각 Item에 하나 이상의 OutputJob 파일이 할당되어 있어야 합니다. 이름이 'fab' 및 'ass' 하위 문자열로 시작하는 Output Job 파일이 있으면, Release 보기에 처음 액세스할 때 해당 OutJob이 각각 Fabrication Data 및 Assembly Data 섹션에 자동으로 할당됩니다. 그렇지 않으면 각 경우에 해당하는 OutJob을 수동으로 할당해야 합니다. Project Release Options 대화 상자의 Release Options 탭에서 할당할 수 있습니다. 이 대화 상자에 액세스하려면 보기 왼쪽 하단의
버튼을 클릭합니다.

필요에 따라 해당 데이터 세트에 OutJob을 할당합니다.
릴리스 타겟 전환
Project Release Options 대화 상자의 Release Options 탭에서도 릴리스 타겟을 변경하여 관리형(Online) 및 비관리형(Offline) 작동 모드 간에 전환할 수 있습니다. 다음 세 가지 옵션을 사용할 수 있습니다.
-
Unmanaged - Folder(Offline): 생성된 데이터를 로컬 폴더로 릴리스하려면 이 옵션을 설정합니다. 루트 폴더 경로는 대화 상자의 Output Path 탭에서 지정합니다. 기본적으로[OutputPath](으)로 설정됩니다(Project Options 대화 상자의 Options 탭에 있는 Output Path 필드에 정의된 경로 사용). -
Unmanaged - Zip(Offline): 생성된 데이터를 로컬 폴더로 릴리스하려면 이 옵션을 설정합니다. 데이터는 하나의 Zip 파일로 압축됩니다. Zip 경로/이름은 대화 상자의 Output Path 탭에서 지정합니다. 기본적으로[OutputPath][ProjectName].zip(으)로 설정됩니다(Project Options 대화 상자의 Options 탭에 있는 Output Path 필드에 정의된 경로 사용). -
Managed - <WorkspaceName>(Online): 현재 연결된 워크스페이스(WorkspaceName포함)로 릴리스하려면 이 옵션을 설정합니다.

프로젝트의 릴리스 옵션에서 생성된 데이터를 전송할 위치인 릴리스 타겟을 변경합니다.
워크스페이스 Item 명명 체계 설정
프로젝트를 타겟 워크스페이스에 처음 릴리스할 때, 해당 워크스페이스에서 생성된 데이터를 리비전으로 받을 타겟 데이터 항목의 이름 지정 방식을 정의할 수 있습니다. 이 설정은 Project Release Options 대화 상자의 Item Naming 탭에서 수행합니다. 이 대화 상자는 보기 왼쪽 하단의
버튼을 누르거나, 릴리스할 데이터 세트의 Target Revision 링크를 클릭하고 컨텍스트 메뉴에서 Edit을 선택하여 열 수 있습니다. 이 탭에서 다음을 수행할 수 있습니다.
- 프로젝트 이름을 정의합니다. 기본적으로 프로젝트의 실제 이름이 입력됩니다.
-
릴리스 과정에서 생성할 수 있는 다양한 데이터 항목의 기본 명명 체계를 정의합니다. Item ID 열의 필드 내부를 클릭한 다음 필드 오른쪽의
버튼을 클릭하면 Choose Item 대화 상자(Explorer 패널의 한 형태)가 열립니다. 이 대화 상자에서 현재 연결된 워크스페이스의 기존 Item을 타겟으로 지정할 수 있습니다.
명명 체계를 변경하려면 Settings 버튼을 클릭하여 Naming Template Settings 대화 상자를 엽니다.

프로젝트 이름을 설정하고 타겟 워크스페이스에 생성될 데이터 항목의 이름 지정 방식을 정의합니다. 여기서는 프로젝트가 아직 릴리스되지 않았으므로 필드를 편집할 수 있습니다.
명명 템플릿에서는 다음 매크로 형식을 사용할 수 있습니다.
-
Parameter-based – 대괄호로 묶은 매개변수 사용을 지원합니다(예:
[ProjectName],[VariantName],[ProjectParameter]). -
Numeric-based – 중괄호로 묶은 숫자 수량자 사용을 지원합니다(예:
{0000},{9000}).
타겟 리비전 제어
기본 보기로 돌아가 Target Revision 항목 옆의 링크를 클릭하면 다음 이미지에 표시된 명령 메뉴가 열립니다.

릴리스 과정에서 생성할 데이터 세트의 타겟 리비전을 지정하는 컨트롤에 접근합니다. 이미지 위에 마우스를 올려 확인하세요.
사용 가능한 명령은 해당 항목이 최초 릴리스되었는지 여부에 따라 달라집니다. 사용 가능한 모든 명령은 다음과 같습니다.
-
Auto <RevisionID> – 이 항목을 선택하면 시스템이 리비전을 처리하므로, 아직 존재하지 않는 예정 리비전을 직접 생성할 필요가 없습니다.
RevisionID에는 지정된 리비전 명명 체계 내에서 동일한 수준에 해당하는 Item의 다음 리비전이 표시됩니다(예: 현재 리비전이A.1이면 이 명령은 타겟을A.2로 표시합니다). -
Next <RevisionID> – 이 항목은 해당 항목의 최초 릴리스 이후에만 사용할 수 있습니다. 지정된 리비전 명명 체계 내에서 다음 수준의 타겟 리비전으로 빠르게 올릴 때 사용합니다.
RevisionID에는 다음 리비전이 표시됩니다(예: 현재 리비전이A.1이면 이 명령은 타겟을B.1로 전환합니다). -
Custom – 이 항목을 사용하면 Custom 리비전 ID 대화 상자에서 사용자 지정 리비전 ID를 정의하여 타겟 항목의 특정 리비전을 타겟으로 지정할 수 있습니다. 사용하는 리비전 명명 체계에 따라 대화 상자에 최대 3개의 수준 ID 필드가 표시될 수 있습니다. 항목의 첫 번째 예정 리비전 ID는 Item이 생성된 후 해당 최초 리비전에 데이터가 릴리스되기 전까지(즉, 아직
Planned상태인 동안) 언제든지 변경할 수 있습니다. - Browse – 이 항목을 사용하여 데이터를 릴리스할 기존 타겟 Item-리비전을 지정합니다. 이를 위한 Choose Target Item 대화 상자(Explorer 패널의 한 형태)가 나타납니다.
- Edit – 이 항목을 사용하여 Project Release Options 대화 상자의 Item Naming 탭을 열면 생성될 타겟 Item의 이름(및 최초 리비전)을 변경할 수 있습니다.
- Navigate – 이 항목을 사용하면 Explorer 패널에서 해당 Item으로 빠르게 이동할 수 있습니다(이미 릴리스되었으며 다음 리비전이 예정 상태로 존재하는 경우).
메뉴 맨 위의 항목에는 현재 선택하거나 정의한 타겟 리비전이 반영됩니다.
데이터 생성 세부 정보 확인
데이터 세트 헤더의 맨 오른쪽에 있는 Details 컨트롤을 클릭하면 해당 데이터 세트에서 정확히 무엇이 생성되는지 세부 정보를 확인할 수 있습니다. Hide Details 컨트롤을 클릭하면 확장된 보기가 접힙니다. Source Data 세트를 제외하고, 생성되는 데이터는 하나 이상의 지정된 Output Job 파일에서 가져옵니다. Configure 컨트롤을 클릭하면 소스 OutJob에 빠르게 접근할 수 있습니다.

데이터 세트의 상세 보기를 열어 어떤 데이터가 생성될지 확인합니다. 이미지 위에 마우스를 올려 확인하세요.
추가 설정
Preferences 대화 상자의 데이터 관리 – 서버 페이지에서 프로젝트 릴리스와 관련된 추가 설정을 정의할 수 있습니다.
-
생성된 파일을 현재 연결된 워크스페이스에 업로드하기 전에 임시로 저장할 폴더를 자동 지정 위치(기본 설치의 경우
\Users\<ProfileName>\AppData\Local\Temp\Releases)로 설정하거나, 원하는 폴더로 직접 변경할 수 있습니다. - 릴리스 프로세스가 완료된 후 임시 저장 폴더를 비우려면 Delete contents after exiting release mode 옵션을 활성화합니다.
- 생성되는 각 출력의 이름 앞에 Item ID와 리비전 ID를 선택적으로 붙일 수 있습니다(예:
[FAB-Kame_FMU-A.1] Validation.PDF). 이렇게 하려면 Prepend revision HRID to file names 옵션을 활성화하세요.
릴리스의 일부로 생성할 데이터 항목을 필요에 맞게 설정한 후, 뷰 오른쪽 하단의
버튼을 클릭하여 계속 진행하세요.
준비 과정에서 다음을 비롯한 여러 릴리스 전 검사가 수행됩니다.
- 프로젝트와 모든 파일이 저장되었는지 확인합니다.
- 해당하는 경우 프로젝트와 모든 관련 파일이 VCS에 커밋되었는지 확인합니다.
- 활성화된 각 데이터 항목에 이름이 지정되었는지 확인합니다.
- 사용자에게 타겟 항목과 리비전을 생성할 권한이 있는지 확인합니다.
- 필요한 타겟 Item과 예정된 리비전이 워크스페이스에 아직 없으면 생성하고, 이미 있는 항목에는 다음 리비전이 사용되는지 확인합니다.
문제가 발견되면 이를 해결할 수 있는 방법이 제시됩니다(예: 로컬에서 수정한 파일 저장 및 VCS에 커밋).
이때 Source Data Item이 생성되며, 소스 설계 프로젝트 파일의 스냅샷이 타겟 항목 리비전으로 릴리스됩니다.
온라인 2단계 – 프로젝트 검증
1단계가 문제없이 완료되면, 할당된 OutJob 파일에서 검증 유형 보고서가 하나 이상 감지되는 경우 릴리스 프로세스의 다음 단계가 자동으로 실행됩니다. 릴리스할 데이터 항목에 할당된 Output Job 파일에 정의된 모든 검증 출력 생성기가 실행됩니다. 여기에는 다음 검사가 포함됩니다.
- Differences Report – 비교기를 사용하여 소스 문서와 PCB 설계 문서가 올바르게 동기화되어 있는지 확인합니다.
- Electrical Rules Check – 작성된 소스 설계의 전기적 유효성과 제도상의 유효성을 확인합니다.
- Design Rules Check – 지정된 보드 수준 설계 제약 조건에 따라 PCB 문서의 유효성을 확인합니다.
-
BOM Checks – 소스 BOM 문서(
*.BomDoc)가 있는 경우, 해당 문서의 설계 Item 또는 부품 선택과 관련된 위반 가능성을 확인합니다. - Footprint Comparison Report – 보드의 풋프린트를 소스 라이브러리와 비교하여 최신 상태이며 서로 일치하는지 확인합니다.
- Component State Checking – 제한된 상태에 있는 부품을 확인합니다. 설정 과정에서 타겟 워크스페이스에 현재 정의된 각 수명 주기 정의의 각 상태에 대해 수행할 동작을 지정합니다. 동작 없음, 경고 또는 오류 생성 중에서 선택할 수 있습니다. 오류를 생성하면 설계를 릴리스할 수 없습니다. 또한 이 검사를 실행하면 유효한 상태가 아닌 설계 부품을 한눈에 확인할 수 있는 유용한 HTML 기반 보고서가 생성됩니다.
- Environment Configuration Compliance Check – 할당된 역할에 사용이 허용된 환경 설정을 통해 승인된 데이터 항목만 사용되고 있는지 확인합니다(해당하는 경우). 이 검사를 통해 모든 설계 항목을 워크스페이스에서 가져왔는지도 확인할 수 있습니다.
검증에 성공하면
아이콘과 Passed 텍스트가 표시됩니다. 그렇지 않으면
아이콘과 Failed 텍스트가 표시됩니다.
온라인 3단계 – 데이터 생성
2단계가 문제없이 완료되면 릴리스 프로세스의 다음 단계가 자동으로 실행됩니다. 이 단계에서는 포함된 데이터 Item에 할당된 OutJob 파일에 정의된 나머지 모든 출력을 실행하여, 워크스페이스의 해당 타겟 항목으로 릴리스할 데이터를 생성합니다.
다른 단계와 마찬가지로 아이콘을 통해 생성 진행 상황을 표시합니다. 이 단계는 실행 시간이 더 오래 걸리므로 이러한 표시가 더욱 눈에 띕니다.
– 아직 실행/생성되지 않았습니다.
– 실행/생성 중입니다.
– 생성에 성공했습니다.
– 생성에 실패했습니다.
온라인 4단계 – 데이터 검토
모든 검증 검사를 통과하고 출력 데이터가 생성되면, 릴리스 프로세스의 이 단계에서 생성된 데이터를 검토할 수 있습니다.

릴리스를 확정하고 데이터를 워크스페이스에 업로드하기 전에, 생성된 데이터를 검토하여 모든 것이 올바른지 확인하세요.
기본적으로 이 페이지는 생성된 데이터를 간단한(간략) 보기로 표시합니다. 원하는 섹션의 Details 컨트롤을 클릭하면 상세 보기로 전환할 수 있습니다.

Details 컨트롤을 클릭하면 해당 섹션의 생성된 데이터가 간단한 보기에서 상세 보기로 전환됩니다. Hide Details 컨트롤을 클릭하면 다시 돌아갑니다.
상세 보기의 Output 생성 상태
다음 표에는 데이터를 생성하는 동안 상세 보기에서 확인할 수 있는 출력 상태가 나와 있습니다.
상태 |
설명 |
|---|---|
|
Output이 아직 생성되지 않았거나 존재하지 않습니다. |
|
Output이 생성되었지만 이후 설계 측에서 변경이 발생하여 이 데이터의 유효성이 더 이상 최신 상태가 아닙니다. |
|
현재 출력이 생성되고 있습니다. |
|
검증 기반 출력이며, 오류가 없는 보고서가 생성되었습니다. ERC 보고서의 경우 오류가 없거나, 오류 수준이 해당 보고서에 지정된 최대 허용 오류 수준 이내입니다. |
|
출력(검증 기반 출력 제외)이 성공적으로 생성되었습니다. |
|
출력이 성공적으로 생성되지 않았습니다. 검증 기반 출력의 경우, 소스 설계 문서에 특정 검사를 실패하게 만드는 오류가 있음을 의미합니다. 일반 출력의 경우, 출력을 성공적으로 생성할 수 없었음을 의미합니다. 생성 전 검증을 수행할 때 치명적 오류가 발생했거나, Output Job 파일에서 해당 출력 생성기의 설정에 문제가 있을 수 있습니다. |
생성된 데이터의 간략 보기에서 View 링크를 클릭하면 Altium Designer의 해당 Editor(예: Gerber 파일 또는 압축/비압축 ODB++ 파일용 CAM Editor)나 해당 외부 애플리케이션(예: BOM용 Microsoft Excel)에서 관련 데이터 파일 또는 파일 세트가 열립니다. 상세 보기에서는 항목을 두 번 클릭하면 해당 파일만 볼 수 있습니다.
많은 설계자가 사용하는 일반적인 릴리스 준비 상태 테스트는 현재 릴리스에서 생성된 Gerber 파일을 이전 릴리스의 Gerber 파일과 비교하는 것입니다. Gerber Output 옆의 Compare Gerber 링크를 클릭하고 드롭다운 메뉴에서 이전 릴리스를 선택하면 준비된 Gerber 데이터를 선택한 릴리스의 데이터와 비교할 수 있습니다. 기본 브라우저에서 회사 워크스페이스가 열리고 결과가 표시됩니다.

데이터를 워크스페이스에 릴리스하기 전에 Project Releaser에서 Gerber 비교 기능에 액세스하는 모습입니다.
► Gerber Comparison 기능에 대해 자세히 알아보세요(Altium 365 워크스페이스, Enterprise Server 워크스페이스).
데이터를 검토한 후 수정이 필요하다면 보기 오른쪽 하단의
버튼을 클릭하세요. 생성된 모든 데이터가 손실된다는 확인 대화 상자가 나타납니다. OK을 클릭하면 릴리스가 취소되고 프로세스의 1단계로 돌아갑니다.
생성된 데이터에 모두 문제가 없다면
버튼(보기 오른쪽 하단)을 클릭하여 릴리스를 진행하세요. Confirm Release 대화 상자가 나타나 워크스페이스에 릴리스할 프로젝트 구성을 요약해서 보여줍니다. 여기에서 Name(기본 입력값은 [ProjectName]), Description 및 관련 릴리스 노트를 추가할 수도 있습니다.

생성된 Item-리비전을 기준으로 릴리스할 내용을 확인하고, 이름/설명을 변경하고 릴리스 노트를 추가할 수 있습니다.
온라인 5단계 – 데이터 업로드
이전 단계에서 릴리스를 확인하면 자동으로 이 단계로 진행됩니다. 이 단계에서는 워크스페이스에 있는 관련 데이터 Item의 리비전으로 데이터를 업로드하는 진행 상황을 보여줍니다.

이 단계는 생성된 데이터를 워크스페이스의 연결된 Item-리비전으로 업로드하는 진행 상황을 보여줍니다.
온라인 6단계 – 실행 보고서
프로세스의 마지막 단계로, 릴리스 요약을 제공합니다.
탐색 링크를 사용하면 워크스페이스에 액세스하는 창구인 Explorer Panel에서 릴리스된 데이터(제작 데이터, 조립 데이터 및 모든 Custom 데이터 세트)가 포함된 관련 Item 리비전에 빠르게 액세스할 수 있습니다.

Explorer Panel을 통해 워크스페이스에서 프로젝트의 릴리스된 데이터를 직접 확인하는 모습입니다.
릴리스된 프로젝트 보기
워크스페이스 프로젝트의 경우 릴리스가 완료된 후 사용할 수 있는 추가 기능이 하나 있습니다. Execution Report 페이지 상단의 탐색 링크 중 마지막 링크인 Project Page 링크를 클릭하면 Explorer Panel이 열리고 Project View에 프로젝트가 표시됩니다. 이 기능은 워크스페이스 프로젝트에서만 사용할 수 있습니다.

Project View을 통해 Explorer Panel에서 워크스페이스 프로젝트를 더욱 자세히 살펴볼 수 있습니다.
Releases Region(보기 왼쪽 하단)에는 프로젝트와 관련된 프로젝트 릴리스 목록이 표시되며, 각 릴리스 및 구성 패키지에 대한 요약이 포함됩니다. 이 Region의
버튼을 클릭하면 일괄 상태 변경 대화 상자가 열리며, 이를 사용하여 동일한 릴리스와 관련된 여러 Item의 수명 주기 상태를 한 번의 일괄 처리로 변경할 수 있습니다.
대상 워크스페이스의 웹 뷰어에서도 프로젝트 릴리스 정보에 추가로 액세스할 수 있으며, Explorer Panel의
버튼을 통해 열 수 있습니다. 워크스페이스의 웹 뷰어에서는 Releases 보기에서 프로젝트와 관련된 모든 릴리스에 액세스할 수 있습니다. 온사이트 서버에서 제공하는 워크스페이스의 경우에는 Manufacture 보기를 사용합니다. 이 페이지에는 모든 프로젝트 릴리스가 나열되며 최신 항목이 맨 위에 표시됩니다. 각 릴리스의 열기 버튼을 사용하면 워크스페이스의 Manufacturing Portal에서 해당 릴리스를 열 수 있습니다. Manufacturing Portal 보기에서는 선택한 릴리스에 대한 더 자세한 정보를 제공하며, 여기에는 릴리스를 구성하는 패키지 파일, 전체 설계 문서, 컴포넌트 제조업체 및 공급업체 세부 정보가 포함됩니다. Send to Manufacturer 기능은 Altium 365 워크스페이스에서만 사용할 수 있습니다. ► 자세한 내용은 Altium 365 워크스페이스 릴리스 보기 페이지를 참조하세요.
이제 완료되었습니다. 프로젝트가 릴리스되었으므로 Release 보기를 닫으면 됩니다(보기 오른쪽 하단의
버튼 사용). 나중에 동일한 프로젝트를 다시 릴리스해야 할 때는 Project Releaser을 통해 빠르고 간편하게 진행할 수 있으며, 타겟 Item-리비전이 자동으로 증가합니다.
PLM 인스턴스에 게시
Related pages: PLM 통합(Altium 365 워크스페이스, Enterprise Server 워크스페이스), PLM에 게시
Altium Designer에서 Project Releaser을 실행하는 과정의 일부로 설계를 PLM 인스턴스에 게시할 수 있습니다. 게시 작업은 해당 PLM 인스턴스의 통합 구성에 정의된 게시 템플릿을 사용하여 데이터를 PLM으로 전달하는 방식을 제어합니다. 이 기능은 적절하게 구성된 프로세스를 통해 사용할 수 있습니다. 설치 시 샘플 프로세스 정의인 Project Releaser with Publish이 제공되며, 이 정의의 기본 워크플로를 통해 Project Releaser의 추가 단계로 통합된 PLM 인스턴스에 게시할 수 있습니다. 워크플로 다이어그램은 아래에 나와 있습니다.

기본 Project Releaser with Publish 샘플 프로세스 정의의 워크플로 다이어그램
활성화한 후에는 Altium Designer에서 활성 프로젝트의 Project » Project Releaser 하위 메뉴 또는 Projects 패널에서 설계 프로젝트 항목을 마우스 오른쪽 버튼으로 클릭하여 여는 Project Releaser 컨텍스트 하위 메뉴를 통해 Project Releaser의 일부로 PLM 인스턴스에 게시하는 프로세스에 접근할 수 있습니다.
의 일부로 PLM 인스턴스에 게시하는 프로세스에 접근Project Releaser이 나타나며, 추가 단계인 7. Publish to PLM이 포함됩니다. 또한 생성된 데이터와 실행 보고서를 검토하기 위해 중단하지 않고 Project Releaser을 실행하려는 경우,
버튼에 연결된 메뉴에서 Prepare & Release & Publish to PLM 명령을 사용할 수 있습니다.

생성된 데이터와 실행 보고서를 검토하기 위해 중단하지 않고 Project Releaser을 실행하는 추가 명령
표준 Prepare 명령으로 Project Releaser을 실행하면 데이터를 검토하고 릴리스한 후 Execution Report 단계에서
버튼이 표시됩니다. 이 버튼을 클릭하면 프로세스의 기본 워크플로를 계속 진행하여 PLM에 게시할 수 있습니다. Login Credentials 대화 상자가 나타납니다. PLM 인스턴스의 Username 및 Password을 입력하고, 사용할 PLM 템플릿(<PLMInstance>:<PublishingTemplate> 형식으로 표시됨)을 선택하세요.

PLM 인스턴스에 처음 게시할 때 표시되는 Login Credentials 대화 상자.
Diagram 탭을 클릭하면 프로세스의 기본 워크플로를 확인할 수 있습니다.

Login Credentials 대화 상자의 Diagram 탭
버튼을 클릭하면 해당 워크플로에 따라 게시 프로세스가 진행됩니다.

)


