Creating the BOM Document
W skrócie
- Dowiesz się, jak utworzyć dokument BomDoc, co się dzieje po dodaniu go do projektu oraz na czym polega istotne ograniczenie: jeden dokument BomDoc na projekt.
- Zobaczysz, jak zorganizowana jest lista pozycji BOM, w tym tryby widoku, opcje zarządzania kolumnami, narzędzia edycji, zasady grupowania i ustawienia wyświetlania.
- Zrozumiesz, jak ActiveBOM obsługuje zgrupowane komponenty i niestandardowe pozycje BOM, co pozwoli Ci uwzględnić zarówno komponenty użyte w projekcie, jak i dodatkowe elementy projektu.
Tworzenie dokumentu BOM
Roboczy dokument BOM w ActiveBOM jest nazywany dokumentem BomDoc. Dodaj nowy dokument BomDoc do projektu za pomocą podmenu File » New lub kliknij projekt prawym przyciskiem myszy w panelu Projects. Jeśli w projekcie znajduje się co najmniej jeden komponent, nowy dokument BomDoc można utworzyć, klikając przycisk + Create obok pozycji ActiveBOM w strukturze projektu w panelu Projects. Pamiętaj, że każdy projekt PCB może zawierać tylko jeden dokument BomDoc.
Po dodaniu nowego dokumentu BomDoc do projektu schemat jest automatycznie kompilowany, a wszystkie istniejące komponenty są wyświetlane w dokumencie BomDoc. W przypadku komponentów z biblioteki Workspace, które zawierają wybrane części (Part Choices), szczegółowe informacje o rozwiązaniach są wyświetlane w dolnej części interfejsu, zgodnie z opisem w sekcji Omówienie rozwiązania poniżej.
Kolejne komponenty umieszczane na schemacie są automatycznie dodawane do dokumentu BomDoc. Dodatkowe pozycje BOM i parametry można również dodawać ręcznie bezpośrednio w ActiveBOM za pomocą przycisku Add new znajdującego się nad listą komponentów. Więcej informacji znajdziesz w sekcji Niestandardowe pozycje i kolumny BOM.
Lista pozycji BOM
Górna część dokumentu BomDoc zawiera tabelaryczną listę wszystkich komponentów wykrytych w projekcie PCB oraz dodatkowych pozycji BOM dodanych bezpośrednio do dokumentu BomDoc. Ten obszar jest nazywany listą pozycji BOM.

Lista komponentów, czyli pozycji BOM, wyświetlana w widoku Base.
Dostępne są 3 tryby wyświetlania pozycji BOM. Wybierz wymagany tryb za pomocą przycisków znajdujących się nad listą:
Flat view — osobny wiersz dla każdego komponentu.
Base view — osobny wiersz dla każdego unikatowego komponentu w projekcie; kolumna Designator zawiera oznaczenia wszystkich komponentów tego typu. Dostępnych jest wiele opcji prezentacji zgrupowanych oznaczeń. Wybierz wymagany tryb Designator Grouping w panelu Properties.
Consolidated view — używany w projektach zawierających warianty do wyświetlania zbiorczego zestawienia BOM dla wszystkich wariantów.
Funkcje edycji listy pozycji BOM
Lista komponentów obsługuje szereg funkcji edycji podobnych do tych dostępnych w arkuszu kalkulacyjnym, w tym:
- Użyj karty Column w panelu Properties, aby wyświetlić lub ukryć kolumnę oraz zdefiniować jej alias. Alias można również zdefiniować w oknie dialogowym Enter Column Properties, dostępnym po kliknięciu prawym przyciskiem myszy nazwy kolumny w obszarze nagłówków kolumn dokumentu BomDoc, a następnie wybraniu polecenia Rename Column z menu kontekstowego. Pamiętaj, że alias jest używany jako nazwa kolumny w generowanych zestawieniach BOM.
-
Kolumny można również dodawać i usuwać za pomocą okna dialogowego Select Columns dostępnego po kliknięciu prawym przyciskiem myszy nazwy kolumny w obszarze nagłówków kolumn dokumentu BomDoc, a następnie wybraniu Select Columns.
Opcje i elementy sterujące okna dialogowego Select Columns
- Search — wpisz znaki w polu, aby przefiltrować listę kolumn i wyświetlić tylko te, których nazwy zawierają wpisane znaki.
-
Visibility column — określa, czy kolumna ActiveBOM jest widoczna w dokumencie ActiveBOM (
*.BomDoc). Kliknij ikonę oka, aby przełączać widoczność kolumny. Widoczne kolumny są zawsze wyświetlane u góry okna dialogowego w kolejności, w jakiej występują w dokumencie BomDoc. -
Data Source column — wyświetla źródło danych kolumny. Obsługiwane źródła danych obejmują:
-
— pozycje dodane bezpośrednio do BOM
-
— parametry komponentów na schemacie
-
— parametry komponentów z Workspace
-
— parametry połączonej bazy danych (DbLink, DbLib)
-
— parametry dokumentu schematu
-
— Altium Cloud Services
-
- Column Name — wyświetla nazwę źródła danych, która jest używana jako nazwa kolumny w dokumencie BomDoc.
- Up / Down — umożliwia przesunięcie aktualnie zaznaczonej kolumny w górę lub w dół listy. W rezultacie po kliknięciu OK kolumna zostanie przesunięta w lewo lub w prawo w dokumencie BomDoc. Pamiętaj, że kolejność można zmieniać tylko dla widocznych kolumn.
-
— kliknij symbol filtra obok każdego nagłówka, aby przefiltrować informacje w tabeli według wybranej pozycji listy.
- Przeciągaj i upuszczaj kolumny, aby zmienić ich kolejność.
- Sortuj według dowolnej kolumny; przytrzymaj Shift, aby dodatkowo sortować według kolejnych kolumn.
-
Kliknij ikonę filtra, aby filtrować według wartości w kolumnach.
- Zaznaczaj komórki przy użyciu standardowych metod zaznaczania systemu Windows.
- Kopiuj zawartość komórek z ActiveBOM i wklejaj wartości z zewnętrznego edytora arkuszy kalkulacyjnych do niestandardowych kolumn ActiveBOM.
- W widoku Base zestawienia BOM można zdefiniować numery wierszy konfigurowane przez użytkownika. W widoku Base kliknij przycisk Set line numbers , aby dodać numer do każdego wiersza. Kliknij ikonę rozwijania po prawej stronie przycisku, aby otworzyć okno dialogowe Line # Options, w którym można zdefiniować wartość początkową i przyrost. Więcej informacji znajdziesz w sekcji Kolumna numerów wierszy.
- Kliknij przycisk rozwijany Add New , aby dodać kolejne wiersze lub kolumny. Więcej informacji znajdziesz w sekcji Niestandardowe pozycje i kolumny BOM.
- Kliknij przycisk Group by , aby pogrupować tabelę według włączonej kolumny. Można włączyć wiele kolumn grupowania (pokaż ilustrację) i zmieniać ich kolejność przez przeciąganie i upuszczanie. Jest to funkcja wyświetlania tabeli — grupowanie nie jest przenoszone do okna dialogowego Report Manager po uruchomieniu polecenia Bill of Materials.
- Kliknij przycisk Reset Supply Chain , aby usunąć z wybranych pozycji BOM zdefiniowany przez użytkownika ranking rozwiązań oraz ręcznie przypisane priorytety SPN.
- Bieżącą konfigurację tabeli pozycji BOM można zapisać jako zestaw BOM. Więcej informacji znajdziesz w sekcji Konfigurowanie i zapisywanie widoku tabeli pozycji BOM.
-
Do przewijania listy pozycji BOM używaj standardowych skrótów systemu Windows:
- Przewijanie w pionie = MouseWheel Roll
- Przewijanie w poziomie = Shift + MouseWheel Roll
Grupy kolumn

Lista komponentów ActiveBOM zawiera odrębne grupy kolumn występujące w każdym trybie widoku. Powyższa ilustracja przedstawia widok Base.
Tabela pozycji BOM jest podzielona na następujące główne grupy:
- Item Details (wyróżnienie pomarańczowe na ilustracji) — te kolumny wyświetlają szczegółowe dane parametrów komponentów, takie jak oznaczenie, opis, odwołanie do biblioteki i inne parametry komponentów.
- Solutions (wyróżnienie zielone na ilustracji) — najwyżej oceniony producent i dostawcy z łańcucha dostaw. Liczbę rozwiązań (części producentów) oraz liczbę dostawców każdego rozwiązania konfiguruje się w panelu Properties narzędzia ActiveBOM — są one oznaczone jednolitym, kolorowym paskiem na kafelku dostawcy. Ranking jest tworzony automatycznie, ale można go również zdefiniować ręcznie, zgodnie z opisem w sekcji Zrozumienie rozwiązania poniżej.
- BOM Status (wyróżnienie jasnoniebieskie na ilustracji) — wskazanie bieżącego ryzyka związanego z każdym komponentem. Najedź kursorem na ikonę, aby wyświetlić opis, lub włącz szczegółową kolumnę BOM Status w panelu Properties, aby wyświetlać ten opis.
Niestandardowe pozycje i kolumny BOM
Zarządzanie BOM w projekcie PCB wymaga uwzględnienia komponentów i pozycji BOM wykraczających poza elementy umieszczone na schemacie i płytce PCB, na przykład części, których szczegóły nie są jeszcze określone, elementów złącznych, nieobsadzonej płytki lub kleju montażowego. Istnieje wiele sytuacji, w których w projekcie PCB używa się niestandardowych pozycji BOM lub parametrów. W takich przypadkach ActiveBOM umożliwia dodawanie dodatkowych pozycji BOM i kolumn (parametrów), które można następnie uwzględnić w generowanym zestawieniu BOM:
- Custom row — łatwy sposób dodania niestandardowej pozycji BOM, którą należy uwzględnić w projekcie (nieobsadzona płytka, klej itp.). Wszystkie pola w niestandardowym wierszu są definiowane przez użytkownika. Niestandardowe wiersze nie są zarządzane przez ActiveBOM. Na przykład jeśli ilość zostanie ustawiona na 3, w widoku Flat nie pojawią się 3 oddzielne pozycje. W przypadku niestandardowych wierszy nie jest również obsługiwane wyszukiwanie w łańcuchu dostaw.
- Custom column — dodatkowa kolumna BOM, zarządzana w ActiveBOM, która może zawierać dowolny tekst zdefiniowany przez użytkownika.
- Custom Item — dodatkowa pozycja BOM, zazwyczaj przeznaczona dla elementów, które będą potrzebne, ale nie są jeszcze w pełni określone lub nie istnieją jeszcze w bibliotece. Pozwala to uwzględnić ich koszt w szacunkowym całkowitym koszcie płytki.
-
Managed Component — dodatkowa pozycja BOM zarządzana ręcznie w dokumencie BOM. Otworzy się okno dialogowe Component Search z listą komponentów z aktualnie połączonego obszaru roboczego Workspace.
Opcje i elementy sterujące okna dialogowego Component Search
- Search — użyj pola wyszukiwania tekstowego, aby ręcznie wyszukać określony komponent.
-
— kliknij, aby otworzyć menu i wybrać jedną z opcji:
- File-based Libraries Preferences — kliknij, aby otworzyć okno dialogowe Available File-based Libraries i dodać lub usunąć biblioteki.
- File-based Libraries Search — kliknij, aby otworzyć okno dialogowe File-based Libraries Search i wyszukać biblioteki.
- Refresh — kliknij, aby odświeżyć okno dialogowe.
-
— kliknij, aby otworzyć lub zamknąć Details obszar okna dialogowego (opisany poniżej).
Kategorie
Użyj tego filtru, aby wyświetlić określone typy komponentów lub wszystkie dostępne komponenty. Użyj
, aby uzyskać dostęp do paska wyszukiwania Categories , który umożliwia ręczne wyszukanie określonego komponentu lub pliku .IntLib.
Filtry
Kliknij ikonę Filters , aby otworzyć obszar Filters , w którym możesz dodatkowo filtrować kategorie wybrane na liście Components .
Komponenty
- Name - nazwa komponentu.
- Description - opis każdego komponentu.
- Footprint - obudowa montażowa komponentu.
- Operating Temperature Range - odpowiedni zakres temperatur pracy tych komponentów.
- Package Description - opis obudowy komponentu.
- Manufacturer Part Search - kliknij, aby otworzyć panel Wyszukiwanie części producentów i wyszukać oraz wybrać najbardziej odpowiednią część.
- Create component - kliknij, aby otworzyć okno dialogowe Create new component i wybrać typ komponentu.
- Results - pokazuje łączną liczbę komponentów znalezionych/wyświetlonych w wynikach wyszukiwania.
Szczegóły
- Component Revision ID - pokazuje identyfikator rewizji i cenę danego komponentu. Kliknij identyfikator rewizji, aby otworzyć panel Eksplorator i uzyskać więcej informacji o komponencie.
- References - kliknij, aby otworzyć informacje referencyjne dotyczące komponentu w przeglądarce internetowej. Użyj listy rozwijanej, aby uzyskać dostęp do Manufacturer URL lub Datasheet.
- Place - kliknij, aby umieścić wybrany komponent w dokumencie schematu.
- Component information - pokazuje istotne informacje o komponencie, w tym producenta, datę wydania i opis. Kliknij łącze Show More , aby wyświetlić wszystkie informacje; kliknij Show Less , aby je zwinąć.
- Models - rozwiń, aby wyświetlić dostępne modele. Użyj dostępnych łączy, aby wyświetlić poszczególne części jednego modelu.
- References - rozwiń, aby uzyskać dostęp do Manufacturer URL lub Datasheet.
- Part Choices - rozwiń, aby wyświetlić dostępne warianty części. Dla każdego z nich podano nazwę, cenę i opis. Wyświetlana jest również karta katalogowa komponentu.
- Where Used - rozwiń, aby wyświetlić projekty wykorzystujące ten komponent.
Menu kontekstowe
- Place <component> - kliknij, aby umieścić komponent w odpowiednim dokumencie.
- Edit - kliknij, aby otworzyć dokumenty biblioteki komponentów dla wybranego komponentu.
- Navigate to <revision> - kliknij, aby otworzyć wybrany komponent w panelu Eksplorator.
- Operations - najedź kursorem, aby uzyskać dostęp do opcji Submit Request, Create, Download, Make a copy, Change Component Type, Create / Edit PCL i Full Item History.
- Refresh - kliknij, aby odświeżyć widok i wyświetlić najnowsze aktualizacje lub zmiany. Możesz również odświeżyć widok za pomocą skrótu F5.
Dodawanie wystąpień zarządzanego komponentu lub niestandardowej pozycji
Po dodaniu zarządzanego komponentu lub niestandardowej pozycji kliknij je prawym przyciskiem myszy i wybierz polecenie Operations » Add Instances of, aby otworzyć okno dialogowe Add to BOM Components. Użyj tego okna, aby określić liczbę wystąpień komponentu w zestawieniu BOM.
Określ Designator prefix, opcjonalnie Separator (które można zdefiniować tak, aby uzyskać wyniki takie jak X-1 lub X:1) oraz Quantity wymaganych komponentów (wartość ta służy do określenia zakresu oznaczeń i pojawi się również w kolumnie Quantity dokumentu ActiveBOM). Wszystkie pozostałe parametry, takie jak opis, można edytować bezpośrednio w tabeli pozycji BOM.
Zmienianie/usuwanie zarządzanego komponentu lub niestandardowej pozycji
Aby edytować oznaczenie lub usunąć wystąpienie zarządzanego komponentu albo niestandardowej pozycji, kliknij je prawym przyciskiem myszy i wybierz polecenie Operations » Edit item. Otworzy się okno dialogowe Change / Remove.
Opcje i elementy sterujące okna dialogowego Zmień/Usuń
- BOM Components - tabela w oknie dialogowym zawiera wszystkie wystąpienia nowej pozycji. Aby edytować prefiks lub wartość oznaczenia, kliknij odpowiednią komórkę New Designator i wprowadź wymagane zmiany.
- Remove All - kliknięcie tego przycisku spowoduje zaznaczenie wszystkich wystąpień dodatkowej pozycji BOM wymienionych w oknie dialogowym i oznaczenie ich do usunięcia. Po kliknięciu przycisku OK w tym oknie wszystkie pozycje oznaczone do usunięcia zostaną usunięte z tabeli pozycji BOM w ActiveBOM. Ponieważ nie pozostanie już żadne wystąpienie nowej pozycji, sama pozycja również zostanie usunięta. Tej operacji nie można cofnąć.
- Remove None - kliknij ten przycisk, aby wyczyścić wszystkie oznaczenia do usunięcia.
- Remove Selected - jeśli wybrano wystąpienie nieoznaczone do usunięcia, trzeci przycisk umożliwia oznaczenie aktualnie wybranych wystąpień do usunięcia.
- Restore Selected - jeśli wybrano wystąpienie oznaczone do usunięcia, trzeci przycisk umożliwia wyczyszczenie tego oznaczenia dla aktualnie wybranych wystąpień.
Źródła danych
Domyślne źródła danych dostępne w ActiveBOM to parametry komponentów schematu , parametry komponentów z przestrzeni roboczej dla zawartości tej przestrzeni oraz dane dostarczane przez ActiveBOM Na podstawie tych źródeł ActiveBOM generuje główną tabelę pozycji BOM projektu. Źródła danych włącza się, a ich wyświetlaniem zarządza na karcie Columns w panelu Właściwości dokumentu ActiveBOM.
Po włączeniu odpowiedniego przycisku Sources (nad listą kolumn) zestawienie BOM może również zawierać informacje pochodzące z następujących dodatkowych źródeł danych:
The PCB - włącz te opcje, aby dla każdego komponentu uwzględnić dane dotyczące położenia na PCB, obrotu i strony płytki w dostępnych Columns. Jeśli projekt zawiera wiele dokumentów PCB, otworzy się okno dialogowe Wybierz PCB do użycia, w którym można wybrać odpowiednią płytkę PCB.
Database - umożliwia wczytanie dodatkowych parametrów komponentów z zewnętrznej bazy danych (za pośrednictwem plików *.DbLib, *.SVNDbLib lub *.DbLink).
Altium Cloud Services - włącz tę opcję, aby uzyskać dostęp do szerokiego zakresu dodatkowych danych komponentów dla tych pozycji BOM, które zostały zidentyfikowane przez Altium Parts Provider i dla których dostępne jest rozwiązanie w zakresie łańcucha dostaw.
Document Parameters - włącz tę opcję, aby uwzględnić wszystkie wykryte parametry dokumentów schematów ze wszystkich schematów w projekcie PCB w dostępnych Columns.

Źródło każdego parametru jest wskazane przez ikonę na liście kolumn.
Priorytet parametrów ze źródeł danych
Jeśli ten sam parametr występuje w więcej niż jednym źródle danych, w ActiveBOM stosowane są następujące priorytety (od najwyższego do najniższego):
- BOM
- PCB
- Dokumenty
- Serwer
- Baza danych
- Chmura
- Schemat
- Dane wprowadzone ręcznie
Kolumna numerów wierszy
W projektach PCB z rysunkami montażowymi lub podczas wymiany danych BOM między projektantami, inżynierami ds. kosztów a specjalistami ds. zakupów numer wiersza BOM (numer pozycji BOM) jest prostym sposobem jednoznacznego rozróżniania wierszy BOM. Można go następnie wykorzystać do jednoznacznej identyfikacji lub find odpowiedniego odnośnika, komponentu i jego przedstawienia w projekcie.
Jako źródło danych BOM projektu ActiveBOM obsługuje numery wierszy definiowane przez użytkownika dla zestawienia BOM projektu i oferuje funkcje zarówno ręcznego, jak i automatycznego zarządzania numerami wierszy (numerami pozycji BOM).
-
Aby automatycznie ustawić numery pozycji dla wszystkich pozycji BOM projektu (w widoku Base), kliknij przycisk Set Line #
. Numery wierszy są wyświetlane w kolumnie Line #, w grupie kolumn Item Details. Kliknij ikonę rozwijania po prawej stronie przycisku, aby otworzyć okno dialogowe Line # Options, w którym można określić wartość początkową i przyrost.

Okno dialogowe Line Number Options- Start number — wartość używana, gdy pierwsza komórka Line # jest pusta.
- Increment — wartość, o którą zwiększany jest numer w każdym pustym polu Line #.
-
Aby ręcznie zmienić numery wierszy, przełącz na tryb widoku Base, a następnie zaznacz odpowiednie komórki w kolumnie Line # i:
- Naciśnij klawisz Delete na klawiaturze, aby wyczyścić komórki, a następnie
- wpisz ręcznie nowe wartości lub
- wklej zakres wartości ze schowka systemu Windows.
-
Aby zmienić numerację lub kontynuować ją od ręcznie dodanego numeru, kliknij komórkę Line # odpowiedniej pozycji, a następnie kliknij przycisk Set Line #
. Otworzy się okno dialogowe Line Numbering, w którym możesz użyć istniejących numerów jako punktów odniesienia i nadać kolejne numery zaznaczonym lub wszystkim pustym komórkom, zaczynając od najbliższych niepustych komórek powyżej (Continue numbering), albo usunąć wszystkie istniejące numery i ponownie ponumerować wszystkie wiersze (Renumber all). Do obliczania dodawanych numerów używane są wartości początkowa i przyrostu ostatnio zdefiniowane w oknie dialogowym Line # Options. W razie potrzeby możesz wprowadzić wartość początkową w zaznaczonej komórce Line #, aby określić numer początkowy.
Konfigurowanie i zapisywanie sposobu wyświetlania tabeli pozycji BOM
Podobnie jak w każdym dobrym arkuszu kalkulacyjnym, tabelę pozycji BOM można skonfigurować odpowiednio do swoich potrzeb. Oprócz standardowych funkcji zmiany kolejności kolumn i sortowania dostępna jest możliwość zapisania bieżącej konfiguracji jako zestawu BOM.
Funkcje konfiguracji tabeli
- Wyświetlanie lub ukrywanie dowolnej kolumny — za pomocą funkcji Columns w panelu Properties. Użyj pola Search u góry panelu, aby szybko znaleźć kolumnę.
- Zmiana kolejności kolumn — kliknij i przytrzymaj nagłówek kolumny, a następnie przeciągnij go i upuść w nowym miejscu.
- Zmiana szerokości kolumny — najedź kursorem na krawędź kolumny w obszarze nagłówka, a następnie kliknij i przeciągnij (zwróć uwagę na kursor lub kliknij dwukrotnie w tym miejscu, aby automatycznie dopasować szerokość do zawartości kolumny.
-
Sortowanie całej tabeli według kolumny:
- Kliknij nagłówek kolumny, aby posortować tabelę alfanumerycznie według zawartości tej kolumny.
- Kliknij ponownie, aby odwrócić kolejność sortowania.
- Przytrzymaj klawisz Shift i kliknij nagłówek innej kolumny, aby dodać kolejny poziom sortowania według jej zawartości.
-
Filtrowanie tabeli według określonej wartości — kliknij ikonę filtra
, aby przefiltrować tabelę według wartości występującej w danej kolumnie. Wybierz (Custom), aby otworzyć okno dialogowe Filter Editor i zdefiniować warunek, operator, wartość, typ operatora itp. służące do filtrowania wybranej kolumny.
- Zapisywanie konfiguracji jako zestawu BOM — więcej informacji poniżej.
Praca z zestawami BOM
Można zapisać dowolną liczbę konfiguracji tabeli pozycji BOM — każda z nich jest określana jako zestaw BOM. Po skonfigurowaniu tabeli zgodnie z wymaganiami kliknij przycisk Add w obszarze BOM Sets panelu Properties ActiveBOM, aby dodać zestaw BOM do listy.

Kliknij ikonę oka, aby uaktywnić zestaw BOM.
Zestawy BOM konfiguruje się w panelu Properties ActiveBOM.
Zastępowanie komponentu
Podczas sprawdzania dokumentu BomDoc i przygotowywania go do zamówienia części nierzadko można wykryć problem z komponentem. Na przykład projektant mógł zapomnieć o ostatecznym wyborze komponentu albo komponent został wycofany z produkcji (EOL) i projektant chce sprawdzić ceny oraz dostępność potencjalnych zamienników. Wcześniej jedynym sposobem rozwiązania takiego problemu był powrót do schematu, edycja komponentu, wybranie odpowiedniej części, a następnie odświeżenie dokumentu BomDoc.
Można też zmienić komponent w dokumencie BomDoc, a następnie przenieść tę zmianę na schemat za pomocą zlecenia zmiany inżynierskiej (ECO). Kliknij prawym przyciskiem myszy zaznaczone komponenty i wybierz polecenie Operations » Change <ComponentName>. Otworzy się okno dialogowe Replace Component, w którym można wyszukać komponent zastępczy.
Po kliknięciu przycisku Replace Component OK otworzy się okno dialogowe Engineering Change Order ze szczegółowym wykazem zmian niezbędnych do zsynchronizowania schematu z dokumentem BomDoc.
Praca z wariantami
ActiveBOM obsługuje projekty PCB zawierające warianty projektu. Funkcja wariantów projektu umożliwia utworzenie jednego bazowego projektu PCB, który jest następnie obsadzany komponentami na różne sposoby. Każda wersja obsadzenia zmontowanej płytki jest nazywana design variant.
Praca z wariantami projektu:
- Warianty projektu konfiguruje się w oknie dialogowym zarządzania wariantami lub w menedżerze wariantów (Project » Variants).
- Aby przejrzeć wariant, kliknij dwukrotnie jego nazwę w folderze wariantów projektu w panelu Projects, jak pokazano na poniższym obrazie.
ActiveBOM obsługuje warianty w następujący sposób:
- Wyświetlanie BOM dla określonego wariantu w trybie widoku bazowego lub płaskiego
- Możliwość uwzględnienia nieobsadzonych elementów na liście pozycji BOM
- Wyświetlanie zbiorczej listy wszystkich części używanych we wszystkich wariantach w trybie widoku skonsolidowanego
- Ręczne definiowanie rozwiązań zarówno dla komponentów bazowych, jak i komponentów zmienionych w wariantach
Warianty w trybie widoku bazowego
Dla wybranego wariantu włącz opcję Show Not Fitted w panelu Properties, aby uwzględnić te części w tabeli pozycji BOM. Po włączeniu tej opcji kolumna Fitted jest automatycznie wyświetlana w szczegółach pozycji.
W trybie widoku bazowego kolumna Fitted będzie wyświetlać Fitted lub Not Fitted. Jeśli komponent został zmieniony (w tym wariancie wybrano część zamienną), szczegóły części zamiennej są automatycznie wyświetlane dla danej pozycji BOM.

Pamiętaj, że bieżący wariant jest wyświetlany w wierszu stanu ActiveBOM.
Warianty w trybie widoku skonsolidowanego
Tryb widoku skonsolidowanego wyświetla wszystkie komponenty używane we wszystkich wariantach. Widok skonsolidowany oferuje następujące funkcje:
- Jeśli komponent został zmieniony, dla każdego używanego komponentu zamiennego zostanie utworzona pozycja BOM, a każda z tych pozycji będzie miała ten sam desygnator. Na przykład na poniższym obrazie komponenty DS1 i DS2 są wymienione po dwa razy, ponieważ wariant BGA wykorzystuje diodę LED o innym kolorze niż wariant TSOP. Komponent R1 występuje trzy razy, ponieważ zarówno wariant BGA, jak i TSOP wykorzystują rezystor inny niż oryginalny rezystor w projekcie bazowym.
-
W trybie widoku skonsolidowanego po włączeniu opcji Show Not Fitted kolumna Fitted będzie wyświetlać
FittedlubVaried. Ponieważ widok skonsolidowany pokazuje wszystkie komponenty używane we wszystkich wariantach, każdy wyświetlany komponent jest obsadzany w projekcie bazowym lub w jednym z wariantów. - Dla każdego wariantu dostępna jest kolumna <VariantName> - Qty (wskazująca, ile sztuk danego komponentu jest używanych w tym wariancie) oraz kolumna <VariantName> - Price, której wartość stanowi iloczyn ceny jednostkowej i wartości w kolumnie ilości.
- Ponieważ niektórzy projektanci tworzą dokumentację montażową zarówno dla projektu bazowego, jak i dla wariantów, dostępna jest również kolumna Quantity, odzwierciedlająca liczbę wystąpień danego komponentu podczas montażu projektu bazowego. Ukryj tę kolumnę, jeśli nie tworzysz dokumentacji montażowej dla projektu bazowego.
- Tabela w trybie widoku skonsolidowanego oznacza kolorem komórki, których wartości różnią się od wartości odpowiadających im komórek w projekcie bazowym, jak pokazano poniżej.

Kolor komórki wskazuje, że jej wartość różni się od wartości odpowiadającej jej komórki w projekcie bazowym.
Aby dowiedzieć się więcej o wariantach, zapoznaj się ze stroną Warianty projektu.
Praca między dokumentem BomDoc, schematem a PCB
Dostępne są dwie funkcje ułatwiające pracę między dokumentem BomDoc, schematem a projektem PCB: zaznaczanie krzyżowe i nawigacja krzyżowa. Działanie tych funkcji konfiguruje się na stronie System – Nawigacja w oknie dialogowym Preferences.
Obie te funkcje umożliwiają zlokalizowanie tego samego komponentu w innych dokumentach. Różnica między zaznaczaniem krzyżowym a nawigacją krzyżową polega na tym, że tryb zaznaczania krzyżowego zaznacza komponent w dokumencie docelowym, ale nie wyświetla aktywnie tego dokumentu, natomiast nawigacja krzyżowa aktywnie wyświetla dokument docelowy, a także może przełączyć się do jego edytora i go uaktywnić.
Zaznaczanie krzyżowe i nawigacja krzyżowa są dostępne w kierunku od dokumentu BomDoc do schematu i PCB, ale nie w kierunku od schematu lub PCB do dokumentu BomDoc.
Tryb zaznaczania krzyżowego
Tryb zaznaczania krzyżowego należy włączyć w każdym edytorze, w którym ma być używany. Wybierz polecenie Tools » Cross Select Mode (Shift+Ctrl+X). Gdy tryb zaznaczania krzyżowego jest włączony, ikona menu jest wyróżniona obramowaniem
.
Tryb zaznaczania krzyżowego wymaga otwarcia dokumentu docelowego. Po wybraniu komponentu na liście pozycji BOM w dokumencie BomDoc komponent ten zostanie zaznaczony i wyśrodkowany w docelowych dokumentach schematu i PCB (jeśli włączono Zooming w opcjach Cross Select Mode na stronie System – Nawigacja w oknie dialogowym Preferences). Pamiętaj, że dokument docelowy nie zostanie uaktywniony.
Jeśli dokument BomDoc jest w trybie widoku bazowego, wszystkie wystąpienia danej części zostaną zaznaczone na schemacie i PCB, jak pokazano na poniższym obrazie.

Użyj funkcji zaznaczania krzyżowego, aby zlokalizować i zaznaczyć na schemacie oraz PCB komponent wybrany na liście pozycji BOM.
Nawigacja krzyżowa
Zaznaczanie krzyżowe jest po prostu trybem, który po włączeniu wyświetla wynik za każdym razem, gdy klikniesz pozycję na liście pozycji BOM, natomiast nawigacja krzyżowa jest działaniem wywoływanym celowo.
Wybierz Tools » Cross Probe z menu głównego lub kliknij prawym przyciskiem myszy pozycję BOM i wybierz Cross Probe z menu kontekstowego, aby wskazać odpowiadający jej komponent na schemacie. Jeśli plik płytki jest otwarty, wskazany zostanie również komponent na PCB.
Ważną funkcją wskazywania krzyżowego jest możliwość przełączenia do edytora dokumentu docelowego. Aby wykonać wskazywanie krzyżowe i przełączyć edytor, przytrzymaj klawisz Ctrl podczas wybierania polecenia Cross Probe.

Kliknij prawym przyciskiem myszy, aby uzyskać dostęp do polecenia wskazywania krzyżowego. Dostępna będzie osobna pozycja dla oznaczenia każdego komponentu należącego do danej pozycji BOM.
Panel właściwości
Gdy aktywnym dokumentem jest dokument BOM (*.BomDoc), panel Properties wyświetla Document Options.
Poniższe rozwijane sekcje zawierają informacje o dostępnych opcjach i elementach sterujących:
Ogólne
- Production Quantity – liczba płytek do wyprodukowania. Ważne jest określenie wartości w tym polu, ponieważ jest ona używana podczas wyszukiwania w łańcuchu dostaw do sprawdzania dostępności komponentów u dostawców.
- Currency – preferowana waluta wyświetlania cen komponentów. Kursy wymiany walut są odświeżane codziennie, pod warunkiem zalogowania się na konto Altium. Po rozłączeniu z Altium (na stronie System – Zarządzanie kontem w oknie dialogowym Preferences) dostęp do aktualizowanych kursów zostaje utracony. W takiej sytuacji w oknie dialogowym raportów BOM dostępna jest opcja użycia danych z pamięci podręcznej.
- Price Per Board – wartość obliczana na podstawie danych dostawców, stanowiąca sumę Supplier Subtotals per Board, zgodnie z opisem poniżej. Należy pamiętać, że Price Per Board nie uwzględnia minimalnych wielkości zamówienia (MOQ).
- Order Price – suma Supplier Subtotals. Należy pamiętać, że Order Price uwzględnia minimalne wielkości zamówienia (MOQ) — jest to kwota płacona dostawcy.
Łańcuch dostaw
Informacje o łańcuchu dostaw są prezentowane w dolnym obszarze interfejsu ActiveBOM. Po lewej stronie znajduje się komponent producenta, a po prawej co najmniej jeden kolorowy kafelek dostawcy. W tym obszarze wyświetlane są dane, gdy dla pozycji BOM można znaleźć prawidłowe informacje o łańcuchu dostaw. Każdy z tych wierszy Manufacturer & Supplier(s) Details jest nazywany rozwiązaniem. Szczegóły producenta są określane skrótem MPN (numery części producenta), a szczegóły dostawcy — skrótem SPN (numery części dostawcy).
- Solutions per Item – liczba części producentów, które mają zostać znalezione dla każdej pozycji BOM.
- Suppliers per Solution – liczba dostawców, którzy mają zostać znalezieni dla każdej części producenta.
-
Solutions
- Exclude Invalid SPNs – zaznacz, aby wykluczyć nieprawidłowe numery SPN.
- Favorite Suppliers List – otwiera okno dialogowe ulubionych dostawców, w którym można skonfigurować ogólną listę dostawców dla tego dokumentu BomDoc.
-
Manufacturer Link – otwiera okno dialogowe definiowania pól powiązań z producentem, w którym wskazuje się parametry komponentów schematu zawierające nazwę producenta i numer części producenta. Jeśli projekt zawiera części biblioteczne spoza Workspace (części, które nie zostały umieszczone z Workspace i nie mają również danych dostawcy), ActiveBOM może wysłać zapytanie do Altium Parts Provider, aby znaleźć odpowiednie rozwiązania w łańcuchu dostaw. Można zdefiniować wiele par parametrów Nazwa / Numer części. W oknie dialogowym kliknij przycisk Detect fields, aby automatycznie dodać wszystkie pary parametrów, które zawierają wyrażenie
manufacturerw nazwie i można je logicznie połączyć w pary.
Pozycje BOM
Ten obszar służy do konfigurowania sposobu grupowania pozycji BOM w tabeli pozycji BOM.
-
Items
-
Show not Fitted – jeśli projekt PCB zawiera warianty, a w wybranym wariancie niektóre części są ustawione jako
Not Fitted, włącz tę opcję, aby wyświetlać nieobsadzane pozycje w tabeli pozycji BOM. - Designator Grouping – tryby widoku podstawowego i skonsolidowanego wyświetlają takie same części w jednym wierszu tabeli pozycji BOM. Ta opcja pozwala określić, czy oznaczenia mają być wyświetlane pojedynczo, czy w zakresach, gdy wiersz zawiera wiele części.
- Component Grouping – kliknięcie przycisku Edit otwiera okno dialogowe Component Grouping. W widoku Base lub Consolidated ActiveBOM uznaje komponenty za takie same, jeśli mają ten sam ItemID (biblioteka Workspace) lub LibRef (biblioteka plikowa lub bazodanowa). Włącz parametry w oknie dialogowym, aby dokładniej określić sposób grupowania komponentów. Należy pamiętać, że jeśli projekt zawiera wyłącznie komponenty zarządzane, przycisk Edit będzie niedostępny, ponieważ komponenty zarządzane są zawsze grupowane według ItemID.
-
Show not Fitted – jeśli projekt PCB zawiera warianty, a w wybranym wariancie niektóre części są ustawione jako
Zestawy BOM
Zestawy BOM umożliwiają zapisanie układu i konfiguracji tabeli pozycji BOM jako nazwanego zestawu. Można zdefiniować dowolną liczbę zestawów BOM.
-
Current BOM Set – kliknij ikonę oka, aby zastosować dany zestaw BOM do tabeli pozycji BOM.
-
Add – skonfiguruj widoczność, kolejność i szerokość kolumn, a następnie kliknij Add, aby zapisać tę konfigurację jako zestaw BOM. Aby edytować nazwę zestawu BOM, kliknij ją raz, aby ją zaznaczyć, a następnie kliknij ponownie, aby edytować tekst.
-
Update – jeśli konfiguracja siatki pozycji BOM zostanie zmieniona, kliknij Update, aby ponownie zapisać tę konfigurację.
-
Delete – kliknij
, aby usunąć aktualnie wybrany zestaw BOM.
Kontrole BOM
ActiveBOM przeprowadza kompleksową kontrolę każdej pozycji BOM oraz wszelkich wykrytych dla niej danych łańcucha dostaw.
- Violation Type grid – wyświetla listę wszystkich typów naruszeń występujących obecnie w dokumencie BomDoc wraz z ich liczbą. Kliknij ikonę filtra, aby wyświetlić tylko te pozycje BOM, które nie przeszły danej kontroli BOM. Pamiętaj, że pozycja BOM może nie przejść kilku kontroli BOM.
-
BOM Checks – kliknij
, aby otworzyć okno dialogowe kontroli BOM, w którym można skonfigurować tryb raportowania dla każdego możliwego typu naruszenia.
Kolumny
Ta sekcja panelu służy do konfigurowania parametrów wyświetlanych dla każdej pozycji BOM oraz źródeł danych dostępnych dla tych parametrów.
-
Sources – oprócz danych dodanych bezpośrednio do dokumentu BomDoc domyślnymi źródłami danych dostępnymi w ActiveBOM są parametry komponentów schematu oraz parametry komponentów bibliotecznych obszaru roboczego w przypadku zawartości tego obszaru Na podstawie tych źródeł ActiveBOM generuje główną siatkę pozycji BOM projektu. BOM może również zawierać informacje pochodzące z następujących dodatkowych źródeł danych:
-
PCB – włącz, aby uwzględnić dane dotyczące położenia, obrotu i strony płytki PCB wśród dostępnych Columns dla każdego komponentu.
-
Database – włącz, aby wczytać dodatkowe parametry komponentów z zewnętrznej bazy danych (*.DbLib,*.SVNDbLiblub*.DbLink). -
Document – włącz, aby uwzględnić wszystkie wykryte parametry dokumentów schematów ze wszystkich schematów w projekcie PCB wśród dostępnych Columns.
-
Altium Cloud Services – włącz, aby uzyskać dostęp do szerokiego zakresu dodatkowych danych komponentów dla tych pozycji BOM, które zostały zidentyfikowane przez dostawcę Altium Parts Provider i dla których wyświetlane jest rozwiązanie w zakresie łańcucha dostaw.
-
-
Columns – lista wszystkich źródeł informacji o częściach dostępnych w ActiveBOM. Sekcję Kolumny można sortować, klikając dowolny nagłówek.
- Visibility – każdy wiersz ma ikonę oka; kliknij ją, aby sterować widocznością danej kolumny w głównej siatce pozycji BOM.
- Source – wyświetla ikonę wskazującą źródło danego parametru.
- Name – nazwa właściwości/parametru zdefiniowana w dokumencie źródłowym lub wprowadzona dla kolumny dokumentu BomDoc utworzonej przez użytkownika.
- Alias – w razie potrzeby można zdefiniować alias, aby zmienić nazwę kolumny.
- Add – kliknij, aby dodać nową kolumnę niestandardową do siatki pozycji BOM.






