Power Analyzer by Keysight QuickStart Guide

W skrócie

Ten skrócony przewodnik przedstawia, jak Power Analyzer by Keysight pomaga ocenić sieć dystrybucji zasilania prądem stałym w projekcie PCB bezpośrednio w Altium Designer. Dzięki temu zamiast polegać na przypuszczeniach, możesz sprawdzić, czy połączenia miedziane, płaszczyzny, ścieżki i przelotki sprostają wymaganiom zasilania Twojego projektu. Przewodnik wyjaśnia, jak rozszerzenie integruje się z bieżącym projektem, jak je zainstalować i uruchomić, jakie informacje są potrzebne przed rozpoczęciem analizy oraz jak zacząć definiować i symulować sieci zasilania. Jeśli szukasz jasnych wskazówek, jak włączyć Power Analyzer by Keysight do swojego obecnego procesu projektowego, ten artykuł przedstawia najważniejsze kroki na początek. Czytaj dalej, aby nabrać pewności w korzystaniu z tego narzędzia.

- Dowiedz się, do czego służy Power Analyzer by Keysight w Altium Designer i jak wspiera analizę integralności zasilania prądem stałym, wykorzystując istniejące dane projektowe.
- Poznaj podstawowy proces instalacji rozszerzenia, otwierania dokumentu analizatora oraz przygotowania ustawień płytki i sieci do symulacji.
- Zapoznaj się z kluczowymi wymaganiami dotyczącymi przygotowania analizy, w tym synchronizacją schematu z PCB, opcjami konfiguracji, wymaganiami dotyczącymi subskrypcji oraz wyborem sieci zasilania.
Zagłęb się w temat dzięki AI:

W nowoczesnych projektach cyfrowych, obejmujących szybkie układy, gęsto upakowane płytki i wiele niskonapięciowych szyn zasilających, wymagania stawiane sieci dystrybucji zasilania prądem stałym wymuszają analityczne podejście do jej projektowania. Analiza stałoprądowa sieci dystrybucji zasilania, czyli analiza integralności zasilania prądem stałym (PI-DC), ma na celu zapewnienie wystarczającej ilości miedzi na drodze od źródeł napięcia do obciążeń — innymi słowy, sprawdzenie, czy płaszczyzny, ścieżki i przelotki na płytce mają odpowiednie wymiary (i właściwości), aby sprostać wymaganiom dotyczącym poboru mocy przez elementy na płytce.

Na szczęście ocenę sieci dystrybucji zasilania płytki PCB można oprzeć na konkretnych danych zamiast na przypuszczeniach, korzystając z narzędzia do symulacji integralności zasilania prądem stałym (PI-DC), które analizuje działanie projektu płytki w warunkach stałoprądowych na podstawie jej właściwości elektrycznych i fizycznych. Takie narzędzie jest dostępne w Altium Designer — to Power Analyzer by Keysight.

Power Analyzer, udostępniany jako rozszerzenie Altium do pobrania, integruje się bezpośrednio z Altium Designer, umożliwiając symulację i analizę PI-DC bieżącego projektu PCB. Ponieważ Power Analyzer działa w środowisku Altium Designer, nie trzeba ręcznie importować ani eksportować danych, konwertować ich ani uruchamiać oddzielnych aplikacji — wystarczy uruchomić Power Analyzer z poziomu edytora schematów lub PCB, ustawić żądane parametry testu, a następnie rozpocząć symulację. Wyniki są prezentowane przede wszystkim w postaci modeli 2D/3D układu miedzi na płytce drukowanej, co pozwala szybko je ocenić oraz przeprowadzać eksperymentalne testy typu „co jeśli” dla projektu układu PCB.

Dostęp do funkcji Power Analyzer by Keysight

Aby uzyskać dostęp do funkcji Power Analyzer by Keysight w Altium Designer, należy zainstalować rozszerzenie Power Analyzer by Keysight . Rozszerzenie to można instalować i usuwać ręcznie.

Więcej informacji o zarządzaniu rozszerzeniami można znaleźć na stronie Extending Your Installation (Altium Designer Develop, Altium Designer Agile, Altium Designer).

Po kliknięciu w celu pobrania i zainstalowania rozszerzenia otworzy się End-User License Agreement (). Kliknięcie Accept oznacza akceptację warunków umowy licencyjnej użytkownika końcowego (EULA); po ich zaakceptowaniu instalacja będzie kontynuowana. Kliknięcie Close oznacza brak akceptacji warunków umowy EULA i spowoduje przerwanie instalacji.

Po zainstalowaniu rozszerzenia Power Analyzer by Keysight dostępne są następujące możliwości:

 
 
 
 
 
  • dodawanie nowego lub otwieranie istniejącego dokumentu analizy zasilania; 

  • Button, Manage Power Nets konfigurowanie Power Analyzer i sieci zasilających; 

  • Button, Show Power Net in Tree przeglądanie struktury drzewa sieci;

  • Button, Show the Power Net Analysis on the PCB przeglądanie istniejących wyników analizy zasilania;

  • Button, View the Power Net Analysis results as a Report wyświetlanie istniejących raportów i generowanie nowych na podstawie istniejących wyników analizy zasilania.

Aby jednak przeprowadzić nową analizę zasilania, trzeba mieć aktywną subskrypcję Power Analyzer by Keysight. W przeciwnym razie próba uruchomienia analizy zasilania spowoduje otwarcie okna dialogowego Analyze Your Power Nets, w którym można poprosić o bezpłatną wersję próbną ().

Uruchamianie Power Analyzer

Aby rozpocząć pracę z Power Analyzer, otwórz dokument PCB projektu lub jeden z jego schematów i wybierz Tools » Power Analyzer by Keysight z menu głównego.

Dokument Power Analyzer Keysight (<ProjectName>.pdnaK) zostanie otwarty i dodany do obszaru Source Documents projektu (w panelu Projects), jak pokazano poniżej.

Polecenie Power Analyzer by Keysight nie jest dostępne w menu? Sprawdź, czy rozszerzenie jest zainstalowane i czy masz jego subskrypcję (dowiedz się więcej).

Power Analyzer można uruchomić z menu edytora schematów lub edytora PCB. Ponieważ jednak Power Analyzer symuluje struktury PCB, wszelkie zmiany projektowe wprowadzone w schemacie muszą zostać zsynchronizowane z PCB, zanim będzie można je wykryć z poziomu dokumentu analizatora (*.pdnaK). Jeśli zmiana projektowa nie została wykryta, zapisz, zamknij i ponownie otwórz dokument analizatora.

Przygotowanie do analizy

Wszystko gotowe do przeprowadzenia analizy, ale po kliknięciu przycisku Analyze otwiera się okno dialogowe z propozycją skorzystania z wersji próbnej? Sprawdź, czy rozszerzenie jest zainstalowane i czy masz na nie subskrypcję (dowiedz się więcej).

Power Analyzer musi znać właściwości fizyczne płytki. Obejmują one maksymalne gęstości prądu dla warstw zewnętrznych i wewnętrznych, minimalne i maksymalne średnice przelotek, rodzaj miedzi, temperaturę pracy itd. Właściwości te definiuje się w obszarze Configuration dokumentu analizatora.

Opcje konfiguracji

  • Maksymalna gęstość prądu i maksymalny prąd przelotki są takie same dla wszystkich sieci, ponieważ zależą od geometrii miedzi.

  • Ustawienia Max Current Density for Surface / Internal Layers określają dopuszczalną wartość dla odpowiednich warstw PCB.

  • Maksymalny prąd w przelotkach określa się dla minimalnej i maksymalnej średnicy otworów użytych w projekcie. Wartości średnic otworów definiuje się w polach Min Via Diameter i Max Via Diameter, wraz z wartością Max Current dopuszczalną dla danej średnicy otworu.

  • Podczas symulacji oprogramowanie dzieli układ PCB na siatkę obliczeniową. Domyślnie używany jest dynamiczny rozmiar siatki. Zaznaczając pole wyboru Simulation Mesh Size, można określić wymagany rozmiar siatki.

  • Domyślnie sieć masy jest wykluczona z wyników mapy cieplnej. Aby uwzględnić sieć masy, usuń zaznaczenie pola wyboru Skip Ground, a następnie wybierz sieć GND z listy rozwijanej Network / Net u góry panelu Power Analysis by Keysight, aby przejrzeć wyniki mapy cieplnej. Pamiętaj, że mapa cieplna obsługuje struktury poligonowe na warstwach sygnałowych, ale nie umożliwia symulowania zachowania warstwy płaszczyzny zasilania.

  • Pole Copper Type określa rodzaj użytej miedzi wraz z powiązanymi parametrami oraz parametrami temperaturowymi. 

  • Parametr Work Temperature służy do określania rezystywności przewodników, a Temperature Compensation jest właściwością samego materiału związaną z jego przewodnością cieplną. Różne materiały mają różne współczynniki przewodności cieplnej, co wpływa na nagrzewanie się materiału w zależności od obciążenia. Nagrzewanie to wpływa na rezystancję wewnętrzną materiału, co z kolei wpływa na spadek napięcia.

  • Wartość Via Plating Thickness wyświetlana w obszarze Global PCB Parameters jest definiowana w panelu Properties narzędzia Layer Stack Manager – dowiedz się więcej.

W razie potrzeby zmień wartości domyślne, aby dostosować je do swojego projektu.

Oprócz maksymalnej gęstości prądu i maksymalnego prądu przelotki należy określić dopuszczalny spadek napięcia dla każdej zdefiniowanej sieci zasilania. Skonfiguruj DC Drop Limit dla każdej sieci, wybierając zdefiniowaną wartość procentową lub wprowadzając wartość Custom.

Ustawienia Auto-Define Settings są używane przez Power Analyzer podczas próby automatycznego zdefiniowania sieci zasilania w projekcie. W tym celu narzędzie musi wiedzieć, jak rozpoznawać elementy obwodu, takie jak stabilizatory napięcia, złącza i komponenty połączone szeregowo. Oprócz wykorzystania wskazówek, takich jak prefiksy oznaczeń komponentów, można również dodać parametry do określonych komponentów, aby usprawnić proces automatycznego wykrywania. Więcej informacji można znaleźć w sekcji Wymagania dotyczące automatycznego rozpoznawania.

Dodawanie sieci zasilania do symulacji

Aby dodać sieć zasilania do symulacji, kliknij przycisk  w lewym górnym rogu, aby otworzyć okno dialogowe Manage Nets. Zaznacz pole wyboru przy wymaganej pozycji Power Net Name i skonfiguruj odpowiednią pozycję Reference Net. Jeśli sieć nie ma obiektu portu zasilania na schemacie, nie pojawi się na liście Power Net Name. Kliknij Show Custom Nets, aby uwzględnić wszystkie sieci w projekcie. W razie potrzeby można włączyć wiele sieci zasilania. Zależności hierarchiczne między sieciami zasilania są rozstrzygane automatycznie po pełnym skonfigurowaniu sieci zasilania.

Każda sieć zasilania wymaga źródła zasilania. Źródła te zostaną skonfigurowane w następnym kroku.

Możesz również kliknąć przycisk , aby oprogramowanie utworzyło sieci zasilania automatycznie. Podejmie ono próbę rozpoznania topologii projektu na podstawie bieżących ustawień w obszarze Auto-Define Settings sekcji Configuration dokumentu analizatora (*.pdnaK).

Dodawanie źródła zasilania

Aby dodać źródło zasilania, kliknij + (lub powiązany element sterujący Zarządzaj) w sekcji Sources wybranego obwodu zasilania. Jeśli obwód zawiera więcej niż jedno źródło zasilania, kliknij Zarządzaj i wybierz pozostałe komponenty.

Aby komponent był dostępny jako źródło, musi być połączony z wybraną siecią Power Net, ale z wybraną siecią Reference Net może być połączony za pośrednictwem dowolnego komponentu podłączonego do tej sieci Reference Net.

Karta komponentu

Każdy komponent uwzględniony jako źródło lub obciążenie jest reprezentowany w dokumencie Power Analyzer przez Component Card.

  • Najedź kursorem na kartę komponentu, aby wyświetlić przyciski Edit i Delete.
  • Kliknij dwukrotnie kartę komponentu, aby otworzyć okno dialogowe Properties dla tego komponentu.
  • Kliknij wartość Identyfikator elementu projektu, aby przejść do tego komponentu na schemacie za pomocą funkcji cross-probe. Poziom powiększenia funkcji cross-probe jest definiowany w sekcji Highlight Methods na stronie System - Navigation okna dialogowego Preferences.
  • Edytuj główną wartość analizy tego komponentu bezpośrednio na karcie (lub przejdź do edycji komponentu, aby uzyskać dostęp do wszystkich właściwości).

Rozszerzanie sieci

Sieci zasilania na płytce mogą przebiegać przez elementy pasywne, takie jak bezpieczniki lub rezystory, po których drugiej stronie znajduje się inna sieć. W takiej sytuacji zaleca się extend the net przez włączenie komponentu pośredniczącego i jego drugiej sieci do sieci głównej. Służy do tego funkcja Extend Nets.

Aby rozszerzyć sieć, kliknij ikonę +Rozszerz sieci obok jej nazwy, aby otworzyć okno dialogowe <PowerNet> Extensions Manager. Kliknij +, aby rozszerzyć wybraną sieć. Power Analyzer wyświetla tylko sieci, które można połączyć za pośrednictwem pojedynczego elementu rozszerzającego. Po Add sieci powiązany element zostanie automatycznie dodany w oknie dialogowym <PowerNet> Extensions Manager; w razie potrzeby można go zmienić.

Sieci zasilające można rozszerzać za pośrednictwem elementu szeregowego.Sieci zasilające można rozszerzać za pośrednictwem elementu szeregowego.

Następnie możesz dalej rozszerzać sieć, klikając symbol +, jak pokazano na poniższej ilustracji. Po zakończeniu kliknij Zapisz w oknie dialogowym <PowerNet> Extensions Manager.

Kontynuuj dodawanie elementów szeregowych i sieci.Kontynuuj dodawanie elementów szeregowych i sieci.

Uwagi dotyczące rozszerzania sieci

  • Dla każdego elementu szeregowego można określić spadek napięcia, rezystancję i maksymalny dopuszczalny prąd, które zostaną uwzględnione podczas analizy (pokaż ilustrację).

  • Jeśli zdefiniujesz niewłaściwą sieć, możesz ją usunąć, najeżdżając kursorem na jej nazwę i klikając wyświetloną ikonę usuwania.

  • Po zapisaniu rozszerzonej sieci elementy podłączone do sieci rozszerzających pojawią się na liście obciążeń i będzie można je dodać.

  • Obok nazwy sieci zasilającej widoczna jest liczba dodanych rozszerzeń. Najedź kursorem na tę liczbę, aby wyświetlić nazwy sieci rozszerzających (jak pokazano na powyższej ilustracji).

  • Obsługę symulacji elementów równoległych w rozszerzonej sieci dodano w wersji 1.0.6 rozszerzenia PABK, a obsługę w interfejsie użytkownika — w wersji 1.0.9. Aby zdefiniować elementy równoległe, wybierz sieć w wyskakującym oknie dialogowym Extensions Manager, a następnie włącz wszystkie elementy równoległe, jak pokazano na poniższej ilustracji. Najedź kursorem na ilustrację, aby wyświetlić okno dialogowe po zakończeniu rozszerzania sieci.

    Wybierz wszystkie elementy równoległe w sieci.Wybierz wszystkie elementy równoległe w sieci.

Określanie obciążenia

Aby dodać element stanowiący obciążenie, kliknij + (lub powiązany element sterujący Zarządzaj) w sekcji Loads, a następnie wybierz żądany element. Element jest widoczny na liście w oknie dialogowym, gdy jest podłączony do sieci głównej lub rozszerzającej.

Po dodaniu elementu możesz określić jego pobór prądu bezpośrednio na jego karcie lub kliknąć przycisk , aby otworzyć okno dialogowe <NetName>/<LoadName> Load Properties.

Uwagi dotyczące konfiguracji obciążenia

  • Określ właściwości obciążenia, w tym Load Type, Total Load Current oraz Min i Max Voltage.
  • Sprawdź, czy sieć zasilająca IN oraz opcje Reference i Connected to reference through są poprawnie skonfigurowane.
  • Prąd obciążenia jest automatycznie rozdzielany równomiernie między wszystkie zidentyfikowane wyprowadzenia zasilające; w razie potrzeby zmień te wartości.
  • Podczas konfigurowania obciążenia typu IC (Current) widoczne są wszystkie wyprowadzenia elementu obciążenia, które łączą go ze źródłem przez różne elementy szeregowe, z możliwością wyboru wymaganych wyprowadzeń.

Otwarte okno dialogowe Manage Loads (lub Add Sources) zawiera kolumnę Design Item Id. Kliknij wpis w tej kolumnie, aby wskazać powiązany element na schemacie, co ułatwia sprawdzenie, czy wybrano właściwy element.

Poziom powiększenia przy wskazywaniu powiązanego elementu jest określony w sekcji Highlight Methods na stronie System - Navigation okna dialogowego Preferences.

Określanie modułu VRM

Aby zdefiniować element jako moduł regulatora napięcia (VRM), najpierw dodaj go jako obciążenie. Następnie otwórz okno dialogowe Load Properties elementu (kliknij przycisk ), aby go skonfigurować.

Po skonfigurowaniu obciążenia jako modułu VRM pojawi się ono również jako źródło sieci zasilającej określonej jako jego sieć OUT.Po skonfigurowaniu obciążenia jako modułu VRM pojawi się ono również jako źródło sieci zasilającej określonej jako jego sieć OUT.

Uwagi dotyczące konfiguracji modułu VRM

  • Ustaw Load Type jako moduł VRM żądanego typu.
  • Określ napięcie wyjściowe w polu Vout oraz pozostałe właściwości regulatora.
  • Skonfiguruj sieci IN i OUT w obszarze Nets Management okna dialogowego.
  • Jeśli moduł VRM nie łączy się bezpośrednio z siecią odniesienia lub korzysta z innego odniesienia, odpowiednio skonfiguruj opcje Reference i Connected to reference through.
  • W hierarchii automatycznie tworzona jest podrzędna sieć zasilająca, której źródłem jest ten moduł VRM (jak pokazano powyżej).
  • Jeśli moduł VRM ma więcej niż jedną sieć wyjściową, dodaj wszystkie wymagane sieci za pomocą łącza +Dodaj sieć wyjściową w oknie dialogowym Load Properties i określ ich prąd wyjściowy w odpowiednich polach, które się pojawią.

Skonfigurowana sieć zasilająca

Każda skonfigurowana sieć zasilająca jest prezentowana jako osobna, zwijana definicja w dokumencie *.pdnaK. Poniżej pokazano skonfigurowaną sieć PWR_IN wraz z dwiema podrzędnymi sieciami zasilającymi, 3V3 i 1V8, nieznacznie wciętymi w celu wskazania ich podrzędnego statusu.

Omówienie definicji sieci zasilającej

  • Każda sieć zasilająca jest prezentowana jako osobna, zwijana Power Net Definition.
  • Nagłówek definicji sieci zasilającej zawiera:
    • Nazwę sieci zasilającej 
    • Sieć odniesienia 
    • Wskaźnik liczby dodatkowych sieci (), jeśli sieć została rozszerzona. Najedź na niego kursorem, aby wyświetlić nazwy sieci podrzędnych.
    • Przycisk  , który po kliknięciu wyświetla strukturę połączeń elementów w tej sieci w kontekście całej hierarchii sieci zasilających.
    • Przycisk  , który po kliknięciu usuwa tę sieć z procesu analizy wraz ze wszystkimi sieciami podrzędnymi.
    • Przycisk  , który po kliknięciu uruchamia analizę tej sieci wraz ze wszystkimi sieciami podrzędnymi.
  • Każdy element w sieci jest reprezentowany przez kartę elementu.
  • Po przeanalizowaniu sieci wyniki Voltage Drop, Current Density i Max Via Current dla tej sieci są wyświetlane w definicji sieci zasilającej, jak pokazano na powyższej ilustracji.
    • Każdy wskaźnik pokazuje wartość z symulacji względem określonego dla niej limitu. Jeśli wartość mieści się w dopuszczalnym zakresie, linia skali jest zielona. Jeśli zbliża się do limitu, linia jest żółta, a po jego przekroczeniu — czerwona. 
    • Kliknij przycisk  , aby przełączyć widok do edytora PCB i wyświetlić miedź należącą do tej sieci na płytce. W edytorze PCB użyj panelu Power Analyzer by Keysight do sterowania procesem analizy.
    • Kliknij przycisk  , aby wygenerować i otworzyć szczegółowy raport dotyczący tej sieci zasilającej. W raporcie użyj  przycisk, aby zapisać kopię w formacie HTML.

Widok drzewa sieci zasilania

Aby wyświetlić skonfigurowaną sieć zasilania (oraz wszystkie sieci podrzędne zdefiniowane za pomocą modułów VRM) w postaci drzewa, kliknij odpowiedni przycisk . Zostanie wyświetlona cała struktura, a wybrana sieć zasilania i powiązane z nią komponenty zostaną odpowiednio wyróżnione.

Widok drzewa pozwala szybko ocenić, czy cały układ zasilania został zdefiniowany zgodnie z wymaganiami i jest gotowy do analizy. Aby wrócić do głównego okna, kliknij łącze Power Analyzer by Keysight w lewym górnym rogu dokumentu .pdnaK.

Uruchamianie analizy

Po zakończeniu konfiguracji możesz uruchomić analizę konkretnej sieci, klikając przypisany do niej przycisk . Podsumowanie wyników analizy jest prezentowane w definicji sieci zasilania, jak pokazano poniżej. Aby zobaczyć wyniki na płytce PCB, kliknij odpowiedni przycisk .

Aby przeanalizować wszystkie skonfigurowane sieci jednocześnie, kliknij przycisk  (w prawym górnym rogu dokumentu analizatora). Jeśli wybierzesz analizę sieci zasilania najwyższego poziomu w strukturze drzewa, przeanalizowane zostaną również wszystkie sieci podrzędne (utworzone za pomocą komponentów VRM). Jeśli przeanalizowano wszystkie sieci, możesz wybrać aktualnie wyróżnianą sieć z listy rozwijanej Network/Net u góry panelu Power Analyzer by Keysight. 

Zarządzanie warstwami

Warstwy symulacji można przełączać tak samo jak podczas pracy z PCB — za pomocą kart warstw u dołu okna edytora PCB. Możesz także skupić widok na bieżącej warstwie za pomocą skrótu Shift+S; używaj tego skrótu, aby przełączać kolejno opcje widoczności w trybie pojedynczej warstwy.

Użyj kart warstw PCB, aby szybko przełączać wyświetlane wyniki analizy. Tutaj pokazano wyniki dla warstwy górnej. Najedź kursorem na obraz, aby zobaczyć wyniki dla warstwy dolnej.Użyj kart warstw PCB, aby szybko przełączać wyświetlane wyniki analizy. Tutaj pokazano wyniki dla warstwy górnej. Najedź kursorem na obraz, aby zobaczyć wyniki dla warstwy dolnej.

Panel Power Analyzer by Keysight

W edytorze PCB procesem analizy i jej wynikami steruje się za pomocą panelu Power Analyzer by Keysight. Pamiętaj, że panel jest dodawany do listy dostępnych paneli (otwieranej przyciskiem Panels) po przeprowadzeniu analizy zasilania i kliknięciu przycisku  .  

Układ / Sieć

  • Network / Net — służy do wyboru układu () lub sieci (), które mają być wyświetlane jako mapa cieplna w graficznym obszarze roboczym.
  • Only nets with violations — gdy ta opcja jest włączona (domyślnie), na liście rozwijanej dostępne są tylko sieci, w których aktualnie występuje naruszenie. Wyłącz tę opcję, aby wyświetlić wszystkie sieci zasilania. 
  • Korzystaj ze standardowych metod przesuwania i powiększania widoku w edytorze PCB, aby przeglądać wyniki symulacji w obszarze roboczym.

Poniżej selektora Network / Net panel zawiera dwie karty: General i Heatmap. Opcje na tych kartach dotyczą sieci aktualnie wybranej z listy rozwijanej Network / Net.

Wybierz sieć do wyświetlenia, a następnie skonfiguruj dla niej opcje ogólne lub opcje mapy cieplnej.Wybierz sieć do wyświetlenia, a następnie skonfiguruj dla niej opcje ogólne lub opcje mapy cieplnej.

Mapa cieplna

Karta Heatmap w panelu Power Analyzer by Keysight służy do określania, jakie dane są prezentowane w postaci mapy cieplnej — gęstość prądu czy spadek napięcia — oraz w jaki sposób kolory odwzorowują te wielkości.

Użyj karty Heatmap  panelu Power Analyzer by Keysight, aby zmienić wyniki symulacji prezentowane na PCB. Tutaj wyświetlane są wyniki gęstości prądu. Najedź kursorem na obraz, aby zobaczyć wyniki spadku napięcia.Użyj karty Heatmap panelu Power Analyzer by Keysight, aby zmienić wyniki symulacji prezentowane na PCB. Tutaj wyświetlane są wyniki gęstości prądu. Najedź kursorem na obraz, aby zobaczyć wyniki spadku napięcia.

Opcje każdego z tych trybów opisano poniżej.

Mapa cieplna gęstości prądu
  • Cała sieć jest kolorowana tak, aby odzwierciedlać gęstość prądu w każdym jej punkcie — im większa gęstość prądu, tym cieplejszy (bardziej czerwony) kolor. 
  • Show Heatmap — użyj tego elementu sterującego, aby szybko usunąć mapę cieplną i przywrócić standardowy widok PCB. 
  • Show Arrows of Current Direction — włącz tę opcję, aby wyświetlić małe strzałki wskazujące kierunek przepływu prądu w całej sieci.
  • Use Noise Suppression — gdy obliczona wartość prądu zbliża się do zera, strzałki kierunku przepływu sprawiają wrażenie, że w danym obszarze płynie prąd, mimo że w rzeczywistości jest on praktycznie zerowy. Włącz tę opcję, aby wykluczyć te niewielkie, potencjalnie mylące wartości prądu.
  • Scope Controller — sposób przypisywania kolorów do sieci w celu przedstawienia natężenia, czyli poziomu „ciepła”, jest kontrolowany przez Scope Controller. Wartość Max domyślnie odpowiada maksymalnej obliczonej gęstości prądu w danej sieci (pokaż obraz), a wartość Min domyślnie wynosi 0 A/mm2. Skala ta jest wyświetlana jako kolorowy pasek poniżej PCB, odzwierciedlający bieżące ustawienia minimum i maksimum, skalę określoną przez wybrany typ skali oraz jednostki. Wartości Min i Max można zmieniać, klikając i przeciągając suwak lub wpisując nową wartość w polach Min lub Max. Obliczone wartości poniżej Min są wyświetlane na niebiesko, a wartości powyżej Max — na czerwono. 
  • Use Logarithmic Scale — włącz tę opcję, aby zmienić skalę z liniowej na logarytmiczną. Skala logarytmiczna powoduje skupienie wyższych wartości bliżej końca hot skali kolorów. Możesz na przykład włączyć skalę logarytmiczną, aby szybko zlokalizować odcinki ścieżek przewodzące większe prądy, a następnie przełączyć się na skalę liniową, aby zbadać rozkład gęstości prądu w danym odcinku ścieżki.

Logarytmiczna mapa cieplna gęstości prądu wskazuje obszar wymagający uwagi. Najedź kursorem na obraz, aby zobaczyć ten obszar w skali liniowej.Logarytmiczna mapa cieplna gęstości prądu wskazuje obszar wymagający uwagi. Najedź kursorem na obraz, aby zobaczyć ten obszar w skali liniowej.

Mapa cieplna spadku napięcia
  • Cała sieć jest pokolorowana tak, aby odzwierciedlać spadek napięcia w każdym jej punkcie — im wyższe napięcie, tym cieplejszy (bardziej czerwony) kolor. Przy takim sposobie prezentacji im chłodniejszy kolor, tym niższe napięcie (i większy spadek napięcia). 
  • Show Heatmap - użyj tego elementu sterującego, aby szybko usunąć mapę cieplną i przywrócić standardowy widok PCB. 
  • Show Arrows of Current Direction - włącz, aby wyświetlić małe strzałki wskazujące kierunek przepływu prądu w całej sieci.
  • Use Noise Suppression - Gdy obliczony prąd zbliża się do zera, strzałki kierunku prądu sprawiają wrażenie, że w danym obszarze płynie prąd, choć w rzeczywistości praktycznie go tam nie ma. Włącz tę opcję, aby wykluczyć te niewielkie, potencjalnie mylące wartości prądu.
  • Scope Controller - sposób przypisywania kolorów do sieci w celu przedstawienia intensywności, czyli poziomu „ciepła”, jest określany przez Scope Controller. Wartość Max jest domyślnie ustawiona nieco poniżej określonego maksymalnego napięcia dla danej sieci, a wartość Min wynosi Max - calculated voltage drop (pokaż obraz). Skala ta jest wyświetlana jako kolorowy pasek poniżej PCB i przedstawia spadek napięcia jako wartość bezwzględną lub procentową, bieżące ustawienia Min i Max oraz jednostki. Wartości Min i Max można dostosować, klikając i przeciągając uchwyty suwaka lub wpisując nową wartość w polach Min lub Max. Obliczone wartości poniżej Min są wyświetlane na niebiesko, a wartości powyżej Max — na czerwono. 
  • Scale Type - skala spadku napięcia może być wyrażona w woltach (kliknij przycisk  ) lub w procentach (kliknij przycisk  ).
  • Enable Visual Slider for Voltage Contour - po włączeniu wyświetla na mapie cieplnej miejsca, w których napięcie jest równe określonym wartościom punktów konturu napięcia, co pozwala łatwo je zidentyfikować. Wartości punktów konturu można dostosować, przeciągając suwaki lub wpisując wartości w polach Voltage Contour Points poniżej. Można dodawać kolejne punkty i usuwać istniejące, klikając odpowiednią ikonę.

Punkty konturu można skonfigurować tak, aby szybko identyfikować miejsca na płytce, w których napięcie ma określoną wartość.Punkty konturu można skonfigurować tak, aby szybko identyfikować miejsca na płytce, w których napięcie ma określoną wartość.

Wykrywanie naruszeń

Jeśli symulacja wykryje naruszenie typu Voltage Drop, Current Density lub Max Via Current, zostanie ono wymienione w sekcji Violations panelu Power Analyzer by Keysight. Kliknij naruszenie w panelu, aby przejść do konkretnego miejsca na PCB, w którym wystąpił dany błąd. Jeśli nie możesz odczytać całego opisu naruszenia, najedź kursorem na jego sekcję opisu, aby wyświetlić podpowiedź ze wszystkimi szczegółami.

Szczegóły naruszeń są automatycznie wyświetlane w sekcji Violations panelu Power Analyzer by Keysight. Najedź kursorem na obraz, aby wyświetlić naruszenie dotyczące prądu przelotki.Szczegóły naruszeń są automatycznie wyświetlane w sekcji Violations panelu Power Analyzer by Keysight. Najedź kursorem na obraz, aby wyświetlić naruszenie dotyczące prądu przelotki.

Pamiętaj, że tryb mapy cieplnej (gęstość prądu lub spadek napięcia) jest wybierany automatycznie na podstawie typu klikniętego naruszenia. 

Sondy

Sekcja sond w panelu Power Analyzer by Keysight służy do umieszczania sond pomiarowych bezpośrednio na PCB. Sondy mogą mierzyć gęstość prądu lub spadek napięcia, a typ pomiaru zależy od bieżącego trybu mapy cieplnej płytki.

Dostępne są następujące typy sond:

  1. Sonda pojedyncza, mierząca wartość bezwzględną w miejscu umieszczenia sondy, lub
  2. Sonda różnicowa, mierząca różnicę między dwoma miejscami pomiaru. 

Oba typy sond umieszcza się, klikając przycisk  w obszarze Probes panelu. Aby umieścić sondę pojedynczą, kliknij w żądanym miejscu, a następnie kliknij prawym przyciskiem myszy (lub naciśnij Esc). Aby umieścić sondę różnicową, kliknij raz, aby określić pierwsze miejsce pomiaru, a następnie drugi raz, aby określić drugie miejsce pomiaru. Po zdefiniowaniu sondy wyniki pomiaru zostaną wyświetlone w panelu.

Podczas umieszczania sondy obowiązują te same funkcje przyciągania co podczas umieszczania innych obiektów projektowych w edytorze PCB. Więcej informacji o ujednoliconym systemie przyciągania kursora znajdziesz na stronie Praca z systemem przyciągania kursora.

Kliknij przycisk  , aby utworzyć obraz PCB w ostatnio klikniętym miejscu pomiaru sondy. Obraz zostanie wyświetlony w obszarze Image Captures panelu i oznaczony etykietą Probe. Najedź kursorem na zrzut ekranu, aby wyświetlić szczegóły sondy (pokaż obraz). 

Sondy mogą mierzyć napięcie lub prąd — jako wartość bezwzględną albo różnicę między dwoma miejscami. Najedź kursorem na obraz, aby wyświetlić sondę prądową.Sondy mogą mierzyć napięcie lub prąd — jako wartość bezwzględną albo różnicę między dwoma miejscami. Najedź kursorem na obraz, aby wyświetlić sondę prądową.

Jeśli w projekcie zostaną wprowadzone jakiekolwiek zmiany, należy usunąć istniejące sondy () i umieścić nowe.

Zrzuty ekranu

Funkcja wykonywania zrzutów ekranu w panelu Power Analyzer by Keysight umożliwia przechwycenie widoku wybranej sieci w danym projekcie, który można następnie dołączyć do raportu.

Aby wykonać zrzut określonego obszaru płytki, najpierw ustaw widok płytki w głównym obszarze projektowym tak, aby widoczne były elementy, które chcesz uwzględnić na zrzucie. Następnie kliknij przycisk   w obszarze Image Captures panelu, aby wykonać zrzut ekranu. Możesz dalej zmieniać widok płytki i używać funkcji Add, aby wykonywać kolejne zrzuty. Aby usunąć obraz, najedź na niego kursorem, aby wyświetlić przycisk  , a następnie kliknij go raz.

Zrzuty ekranu nie są zapisywane wraz z projektem. Aby zapisać obrazy, wygeneruj raport z analizy.

Raport z analizy

Aby wygenerować pełny raport z analizy, kliknij przycisk  u góry dokumentu analizatora. Pełny raport zawiera sekcję dla każdej sieci zasilającej w układzie zasilania, jak pokazano na poniższym obrazie. 

W raporcie kliknij sieć zasilającą, aby wyświetlić jej szczegółowy raport, obejmujący:

  • Globalne ustawienia konfiguracji
  • Układ warstw płytki
  • Mapy cieplne gęstości prądu dla każdej warstwy sygnałowej
  • Mapy cieplne spadku napięcia dla każdej warstwy sygnałowej
  • Widok drzewa układu zasilania z wyróżnioną wybraną siecią.
  • Szczegóły analizy wybranej sieci, w tym: pobór mocy; szczegóły marginesów i wyniki oceny spełnienia wymagań; szczegółowe podsumowanie parametrów pracy wszystkich przelotek w danej sieci; wszystkie zrzuty ekranu wykonane przez użytkownika.

  • Kliknij przycisk  , aby zapisać raport w formacie HTML. W wyświetlonym następnie oknie dialogowym Save Report Settings określ, które układy zasilania i jakie dane mają zostać uwzględnione w raporcie.
  • Raport jest zapisywany w podfolderze folderu projektu o nazwie \PowerAnalyzerByKeysight_Output\HTMLReport\<ProjectName> [PDNA]_<CurrentDate>_<CurrentTime>.
  • Wszystkie obrazy z raportu są zapisywane w podfolderze \Images.
  • Podczas analizy generowane są również pliki dziennika, które także są zapisywane w podfolderze folderu projektu o nazwie \PowerAnalyzerByKeysight_Output\<BoardName>\.

Wymagania dotyczące automatycznego rozpoznawania

Oprócz ręcznego dodawania sieci zasilających narzędzie Power Analyzer by Keysight umożliwia ich automatyczne rozpoznawanie i dodawanie, wraz ze źródłami i obciążeniami, skracając czas potrzebny na zdefiniowanie struktury zasilania.

Ustawienia automatycznego definiowania

Przed rozpoczęciem automatycznego rozpoznawania należy skonfigurować parametry algorytmu odpowiednio do projektu. Parametry te konfiguruje się w obszarze Auto-Define Settings sekcji Configuration w oknie dokumentu Power Analyzer by Keysight.

Komponenty, które nie spełniają tych kryteriów automatycznego definiowania, są traktowane jako zwykłe obciążenia. Można również dodawać nazwane parametry do poszczególnych komponentów schematu, określając typ i właściwości danego komponentu w układzie zasilania. Parametry te można określić podczas tworzenia komponentu lub dodać później na schemacie.

Parametry komponentów

Aby zapewnić prawidłowe rozpoznawanie, wszystkie komponenty związane z zasilaniem powinny spełniać następujące kryteria:

  • Aby komponent został automatycznie wykryty jako źródło, powinien mieć parametr o nazwie Component Type i wartości Source.

  • Jeśli parametr nie zostanie znaleziony, wyszukiwanie będzie oparte na Default Connectors Designators, zdefiniowanych w obszarze Auto-Define Settings sekcji Configuration w dokumencie analizatora (*.pdnaK). Należy pamiętać, że zdefiniowane zostaną tylko złącza z połączeniami zasilającymi, chyba że są one wskazane jako część sieci rozszerzonej.
  • Moduły regulatorów napięcia (VRM):
    • Regulatory liniowe powinny mieć parametr o nazwie Component Type i wartości VRM.
    • W przypadku regulatora VRM typu SMPS parametr Component Type musi mieć wartość SMPS.
    • Jeśli moduł VRM ma funkcję pomiaru napięcia Sense, parametr Component Type musi mieć wartość Sense.

  • Jeśli parametr nie jest zdefiniowany, wyszukiwanie będzie oparte na VRM Keywords zdefiniowanych w obszarze Auto-Define Settings sekcji Configuration w dokumencie analizatora. Domyślnie są to następujące słowa kluczowe: PWR, REG, Regulator, Voltage, Switch.

  • Wartość poboru prądu komponentu (obciążenia) należy określić za pomocą parametru o nazwie Current Consumption. Należy zwrócić uwagę na separator dziesiętny użyty w wartości — w zależności od ustawień systemowych może to być kropka lub przecinek.

Jeśli komponent ma parametr Current Consumption, podana wartość jest dzielona między wszystkie wyprowadzenia podłączone do tego samego obwodu.

Synchronizacja parametrów

Wszystkie parametry muszą być zsynchronizowane między PCB a schematem. Można to sprawdzić, zaznaczając komponent na PCB i upewniając się, że parametry analizy zasilania są widoczne na karcie Parameters panelu Properties.

Wymagania dotyczące projektu

  • Wszystkie sieci zasilające powinny być zdefiniowane:
    • za pomocą obiektu Power Port,
    • przez skonfigurowanie właściwości Power Net tak, aby sieć zawierała Supply Net Parameter (zgodnie z opisem poniżej),
    • lub przez nadanie im nazw wykrywanych przez Name Mask (zdefiniowane w obszarze Auto-Define Settings sekcji Configuration w dokumencie analizatora).
  • Aby uzyskać wartość napięcia za pomocą Name Mask, nazwa sieci zasilającej powinna mieć format *V* lub *.*V, gdzie * jest wartością liczbową, jak pokazano na poniższej ilustracji.

  • Alternatywnym sposobem określenia wartości napięcia sieci zasilającej jest skonfigurowanie właściwości Power Net, dostępnej w panelu Properties dla dowolnego przewodu w tej sieci. Aby włączyć tę właściwość, należy najpierw umieścić w sieci dyrektywę zestawu parametrów (Parameter Set Directive, Place » Directives » Parameter Set) (najedź kursorem na poniższą ilustrację, aby wyświetlić obraz przedstawiający ten proces). Rozmiar, kolor i etykietę określa użytkownik — to sama obecność dyrektywy udostępnia właściwość Power Net danej sieci. Po dodaniu dyrektywy zaznacz przewód w tej sieci, włącz właściwość Power Net i skonfiguruj Voltage sieci, jak pokazano poniżej. 

  • Komponenty szeregowe powinny mieć oznaczenia zgodne ze zdefiniowanymi oznaczeniami rezystorów, cewek indukcyjnych i niestandardowych komponentów szeregowych (określonymi w obszarze Auto-Define Settings sekcji Configuration w dokumencie analizatora).

  • Moduły VRM powinny być podłączone do co najmniej dwóch sieci zasilających.

Polecenia Power Analyzer

Poniższe polecenia są dostępne w menu głównym edytora Power Analyzer.

Polecenie

Opis i zastosowanie

Tools » Define Automatically

Podejmuje próbę automatycznego rozpoznania topologii projektu na podstawie bieżących ustawień w obszarze Auto-Define Settings sekcji Configuration w dokumencie analizatora (*.pdnaK). Polecenie to można również wywołać, klikając przycisk Define Automatically w lewym górnym rogu edytora.

File » Load from File

Wczytuje zapisany dokument Power Analyzer by Keysight (*.pdnaK) do edytora Power Analyzer.

Edit » Manage Nets

Otwiera okno dialogowe Manage Nets, w którym można wybrać sieci zasilające do analizy. Zaznaczenie sieci powoduje dodanie jej do dokumentu analizatora (*.pdnaK). Usunięcie zaznaczenia sieci powoduje usunięcie jej (wraz ze wszystkimi podrzędnymi sieciami zasilającymi) z dokumentu. Polecenie to można również wywołać, klikając przycisk Manage Nets w lewym górnym rogu edytora. Dowiedz się więcej o zarządzaniu sieciami.

File » Save

Zapisuje bieżącą konfigurację Power Analyzer w dokumencie Power Analyzer by Keysight (*.pdnaK)

File » Save As

Zapisuje bieżącą konfigurację Power Analyzer w dokumencie Power Analyzer by Keysight (*.pdnaK) pod nową nazwą określoną przez użytkownika.

Tools » Measurement Units » mil

Konfiguruje Power Analyzer tak, aby używał imperialnych jednostek miary (mils).

Tools » Measurement Units » mm

Konfiguruje Power Analyzer tak, aby używał metrycznych jednostek miary (mm).

Ograniczenia Power Analyzer

Na obecnym etapie Power Analyzer by Keysight nie obsługuje:

  1. Napięć ujemnych.
  2. Komponentów wbudowanych (komponentów umieszczonych na warstwie wewnętrznej). Dowiedz się więcej o projektowaniu PCB z komponentami wbudowanymi.

 

AI-LocalizedTłumaczenie SI
Jeśli znajdziesz błąd, zaznacz tekst/obraz i naciśnij Ctrl + Enter aby wysłać nam wiadomość.
Contents
Dostępność funkcji

Dostępne funkcje zależą od tego, z którego rozwiązania Altium korzystasz – Altium Develop, Altium Agile Teams, Altium Agile Enterprise lub Altium Designer (w ramach aktywnej subskrypcji terminowej).

Jeśli opisana funkcja nie jest widoczna w Twoim oprogramowaniu, skontaktuj się z działem sprzedaży Altium, aby dowiedzieć się więcej.

Starsza dokumentacja

Dokumentacja Altium Designer nie jest już wersjonowana. Jeśli potrzebujesz dostępu do dokumentacji dla starszych wersji Altium Designer, odwiedź sekcję Starsza dokumentacja na stronie Inne instalatory.

Contents