Keeping the Schematics & PCB Synchronized
Altium Essentials: Transfer to PCB
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
W skrócie
- Poznaj różnicę między porównywaniem dwukierunkowym a bezpośrednią aktualizacją oraz dowiedz się, kiedy stosuje się każde z tych podejść.
- Dowiedz się, jakie dane Altium Designer może synchronizować między schematem a PCB, w tym komponenty, połączenia, klasy i wybrane reguły projektowe.
- Zobacz, jak opcje projektu, takie jak ustawienia komparatora (Comparator) i generowania ECO (ECO Generation), wpływają na proces synchronizacji oraz zakres zmian, które można zastosować.
Najczęstszym zadaniem przy przenoszeniu projektu ze schematu na PCB jest utrzymywanie zgodności lub synchronizacji schematu i PCB. Niezależnie od tego, czy po raz pierwszy przenosisz projekt ze schematu na nową PCB, czy wprowadzasz zmiany w istniejącym projekcie po stronie schematu lub PCB, potrzebujesz sposobu na utrzymanie synchronizacji obu części. Altium Designer oferuje zaawansowane funkcje synchronizacji projektu, które upraszczają to zadanie i pozwalają projektantowi skupić się na twórczych aspektach procesu projektowania.
Proces synchronizacji wykrywa i usuwa różnice między schematem a PCB.
Synchronizacja projektu odbywa się bezpośrednio między edytorami schematów i PCB; nie jest używany żaden dokument pośredni, taki jak lista połączeń. Oprogramowanie wykorzystuje mechanizm porównywania do porównania wszystkich aspektów projektu i przedstawia wyniki w postaci listy różnic. Projektant decyduje, po której stronie należy wprowadzić zmiany, aby usunąć różnice, a następnie tworzony jest zestaw zleceń zmian inżynierskich (ECO). Po ich zastosowaniu obie części projektu są ponownie zsynchronizowane.
Co można synchronizować?
Proces synchronizacji zapewnia zgodność danych komponentów i połączeń na schemacie z danymi komponentów i połączeń na PCB. Oprócz tych danych proces synchronizacji zapewnia również zgodność innych ograniczeń projektowych, takich jak klasy sieci, klasy komponentów i reguły projektowe.
Konfigurowanie opcji porównywania
Dialog page: Opcje projektu PCB, karta porównywania
To, jakie dokładnie dane what schematu i PCB są porównywane, konfiguruje się na karcie porównywania w oknie dialogowym Options for PCB Project. Wybierz Project » Project Options, aby otworzyć to okno.

Mechanizm porównywania działa zgodnie z ustawieniami zdefiniowanymi na karcie Comparator w oknie dialogowym Options for Project.
Główny obszar okna dialogowego zawiera obszerną listę typów porównań, takich jak Different Designators i Changed Net Name, podzielonych na 5 kategorii. Kolumna Mode po prawej stronie zawiera dla każdego z nich listę rozwijaną, na której wybiera się tryb porównywania, na przykład Find Differences lub Ignore Differences. Porównania tekstowe mają trzecią opcję, która pozwala ignorować wielkość liter.
Domyślnie w nowym projekcie dla każdego typu porównania włączone jest wyszukiwanie różnic. Dostosuj te opcje do wymagań projektu.
W dolnej części okna dialogowego znajdują się opcje ustawiania Object Matching Criteria. Dopasowywanie jest zaawansowanym, wieloetapowym procesem, który nie opiera się na prostym wyszukiwaniu identycznych ciągów znaków. Więcej informacji znajdziesz w sekcji Dopasowywanie sieci i klas.
Zwróć uwagę na opcję Ignore Rules Defined in the PCB Only u dołu okna dialogowego. Włącz ją, aby wykluczyć z procesu porównywania reguły zdefiniowane na PCB.
Synchronizacja klas sieci i komponentów
Dialog page: Opcje projektu PCB, karta generowania klas
Oprócz danych komponentów i połączeń można również generować i synchronizować klasy oraz reguły projektowe podczas wykonywania operacji Design » Update PCB.
Synchronizacja reguł projektowych
Reguły projektowe można definiować na schemacie za pomocą obiektu zestawu parametrów (Parameter Set). Po wybraniu obiektu zestawu parametrów panel Properties lub modalne okno dialogowe zawiera obszar Rules. Kliknij listę rozwijaną Add, aby dodać regułę projektową. Reguła zostanie zastosowana do sieci / magistrali / wiązki / obiektów objętych obszarem Blanket, z którym styka się obiekt zestawu parametrów.
Na poniższej ilustracji reguła projektowa ograniczająca szerokość jest stosowana do klasy sieci USB_data (klasa sieci jest również zdefiniowana w tym zestawie parametrów, w obszarze Classes listy rozwijanej Parameters ).

Zestaw parametrów służy do definiowania klasy sieci i reguły projektowej dla sieci objętych obiektem Blanket na schemacie. Wymagane jednostki miary konfiguruje się u dołu okna dialogowego edycji reguły PCB.
Dodawanie reguły projektowej na schemacie
- Dołącz zestaw parametrów do sieci / magistrali / wiązki / obszaru Blanket (w razie potrzeby dodaj w zestawie parametrów definicję klasy sieci).
- Add definicję reguły w zestawie parametrów. Spowoduje to otwarcie okna dialogowego Choose Design Rule Type, jak pokazano powyżej.
- Wybierz wymagany Rule Type.
- Kliknij przycisk OK, aby otworzyć okno dialogowe Edit PCB Rule.
- Skonfiguruj wymagania reguły PCB zgodnie z potrzebami. Jednostki miary wymagane dla tej reguły PCB wybiera się u dołu okna dialogowego.
Zarówno na powyższej, jak i na poniższej ilustracji reguła projektowa jest zdefiniowana w obiekcie zestawu parametrów dołączonym do obszaru Blanket. Umieszczenie definicji klasy w obiekcie zestawu parametrów spowoduje również utworzenie klasy sieci PCB, a ponieważ definicja klasy jest obecna, zakres stosowania reguły PCB zostanie ustawiony na InNetClass('<PCB_NetClassName >').
Na poniższej ilustracji obiekt zestawu parametrów jest wyświetlany jako dyrektywa pary różnicowej. Jest to specjalny typ obiektu zestawu parametrów, umieszczany za pomocą polecenia Place » Directives » Differential Pair.

Dyrektywa pary różnicowej służy do definiowania klasy sieci i reguły projektowej, która jest następnie stosowana do wskazanych par różnicowych.
Konfigurowanie opcji generowania ECO
Okno dialogowe Options for Project zawiera również kartę Generowanie ECO. Na tej karcie określa się, dla których modyfikacji projektu można tworzyć ECO. Zazwyczaj wszystkie te opcje są włączone, a opcje na karcie Komparator tego okna dialogowego służą do określania, które zmiany projektu mają być synchronizowane między schematem a PCB.

Karta Generowanie ECO określa typy modyfikacji, dla których można tworzyć ECO.
Wykrywanie różnic
Funkcja synchronizacji projektu umożliwia wykrywanie i rozwiązywanie różnic w obu kierunkach: ze schematu do PCB lub z PCB do schematu.
Oprogramowanie umożliwia rozwiązywanie tych różnic przez jednoczesne wprowadzanie zmian po obu stronach. Wyobraź sobie na przykład sytuację, w której projektant elektroniki zmienił wartość kondensatora, a projektant PCB zmienił footprint tego samego kondensatora. Te dwie różnice można rozwiązać w ramach jednego procesu aktualizacji, stosując zmianę komentarza jako aktualizację ze schematu do PCB, a zmianę footprintu jako aktualizację z PCB do schematu.
Gdy mechanizm porównujący porównuje projekt schematu z PCB, tworzona jest pełna lista różnic — na tym etapie nie zakłada się, po której stronie należy wprowadzić zmiany, aby przywrócić synchronizację.
Listę różnic można wyświetlić w oknie dialogowym Differences between.
Opcje i elementy sterujące okna dialogowego Differences between
Okno dialogowe jest podzielone na trzy główne obszary — Differences, Update i Change Order.
Różnice
Ten obszar okna dialogowego zawiera wszystkie różnice wykryte przez komparator między wybranymi dokumentami. Każda różnica jest wyświetlana w kolumnie odpowiadającej dokumentowi, w którym występuje. Różnice są grupowane według typu porównania zgodnie z listą i ustawieniami włączenia na karcie Komparator okna dialogowego Project Options . Wpis na poziomie grupy wskazuje liczbę różnic danego typu.
Kliknij dwukrotnie wpis, aby przejść do odpowiadającego mu obiektu w odpowiednim dokumencie źródłowym.
Aktualizacja
W tym obszarze okna dialogowego określa się, który dokument należy zaktualizować, aby wyeliminować różnicę. Domyślnie wszystkim wpisom Decision jest początkowo przypisana decyzja No Change .
Decyzję o aktualizacji dla każdej różnicy można określić indywidualnie, klikając odpowiedni wpis w kolumnie Decision , a następnie wybierając wymagane działanie aktualizacyjne w wyświetlonym oknie dialogowym ECO Decision. Wystarczy wybrać kierunek aktualizacji (który z porównywanych dokumentów ma zostać zaktualizowany) lub No Updates.
Zlecenie zmian
Ten obszar okna dialogowego zawiera (dla każdej różnicy, w odniesieniu do której zdecydujesz się podjąć działanie) działanie do wykonania, obiekt, którego ono dotyczy, oraz dokument, w którym zostanie wykonane. Te informacje służą do przygotowania ECO, które następnie zostanie użyte do wprowadzenia aktualizacji. Typowe działania wyświetlane w tym obszarze to:
- Remove — gdy aktualizacja jest skierowana do dokumentu zawierającego obiekt powodujący różnicę; obiekt zostanie usunięty.
- Add — gdy aktualizacja jest skierowana do dokumentu, który nie zawiera obiektu powodującego różnicę; obiekt zostanie dodany.
- Update — gdy oba dokumenty zawierają ten sam obiekt, który różni się w pewien sposób; to, który obiekt zostanie zmieniony, zależy od wybranego kierunku.
Menu kontekstowe
- Create Change Order — służy do tworzenia zlecenia zmian inżynierskich (ECO).
- Generate Report — służy do generowania raportu dotyczącego różnic wykrytych przez komparator. Wybrane decyzje dotyczące aktualizacji oraz działania zostaną uwzględnione w wygenerowanym ECO. Raport zostanie załadowany do okna dialogowego Report Preview. Użyj tego okna do przejrzenia raportu przed wyeksportowaniem go do jednego z obsługiwanych formatów lub bezpośrednim wydrukowaniem.
- << Update All in — służy do ustawiania kierunku aktualizacji wszystkich różnic na dokument po lewej stronie (tam, gdzie jest to możliwe).
- Update All in >> — służy do ustawiania kierunku aktualizacji wszystkich różnic na dokument po prawej stronie (tam, gdzie jest to możliwe).
- Reverse Direction For All — służy do szybkiego odwracania kierunku aktualizacji wszystkich różnic (tam, gdzie jest to możliwe). Jeśli zmiana kierunku dla danej różnicy nie jest możliwa, wpis zostanie ustawiony na No Change.
- Set No Action For All — służy do szybkiego ustawiania decyzji dotyczącej aktualizacji wszystkich różnic na No Change.
- << Update Same Kind in — służy do ustawiania kierunku aktualizacji wszystkich różnic o tym samym typie porównania co aktualnie zaznaczona różnica na dokument po lewej stronie (tam, gdzie jest to możliwe).
- Update Same Kind in >> - służy do ustawienia kierunku aktualizacji dla wszystkich różnic tego samego typu porównania co aktualnie wskazana różnica na dokument po prawej stronie (jeśli dotyczy).
- Reverse Direction For Same Kind - służy do szybkiego odwrócenia kierunku aktualizacji dla wszystkich różnic tego samego typu porównania co aktualnie wskazana różnica, jeśli dotyczy. Jeśli zmiana kierunku dla danej różnicy nie jest dozwolona, wpis zostanie ustawiony na No Change.
- Set No Action For Same Kind - służy do szybkiego ustawienia kierunku aktualizacji dla wszystkich różnic tego samego typu porównania co aktualnie wskazana różnica na No Change.
- << Update Selected in - służy do ustawienia kierunku aktualizacji dla wszystkich zaznaczonych różnic na dokument po lewej stronie (jeśli dotyczy).
- Update Selected in >> - służy do ustawienia kierunku aktualizacji dla wszystkich zaznaczonych różnic na dokument po prawej stronie (jeśli dotyczy).
- Reverse Direction For Selected - służy do szybkiego odwrócenia kierunku aktualizacji dla wszystkich zaznaczonych różnic (jeśli dotyczy). Jeśli zmiana kierunku dla danej różnicy nie jest dozwolona, wpis zostanie ustawiony na No Change.
- Set No Action For Selected - służy do szybkiego ustawienia decyzji o aktualizacji dla wszystkich zaznaczonych różnic na No Change.
- Invert Selection - służy do zaznaczenia wszystkich niezaznaczonych obecnie różnic na liście lub usunięcia zaznaczenia z tych, które są zaznaczone.
Dodatkowe elementy sterujące
U dołu okna dialogowego dostępne są następujące przyciski:
- Create Engineering Change Order - kliknij ten przycisk, aby wygenerować ECO. Pojawi się okno dialogowe Engineering Change Order, w którym możesz zweryfikować i wykonać aktualizacje w celu synchronizacji dokumentów.
- Report Differences - kliknij ten przycisk, aby wygenerować raport dotyczący różnic wykrytych przez komparator. Podjęte decyzje o aktualizacji oraz działania zostaną uwzględnione w wygenerowanym ECO. Raport zostanie wczytany do okna dialogowego Report Preview. W tym oknie możesz przejrzeć raport przed wyeksportowaniem go do jednego z obsługiwanych formatów lub bezpośrednim wydrukowaniem.
- Explore Differences - kliknij ten przycisk, aby dokładniej przeanalizować różnice wykryte przez komparator przed wygenerowaniem ECO. Okno dialogowe Differences between zostanie zamknięte i powrócisz do głównego obszaru roboczego z otwartym panelem Differences. Panel będzie zawierał wszystkie różnice wykazane przez komparator, podzielone na te same kategorie. Użyj panelu, aby przejść za pomocą funkcji cross-probing do obiektu powodującego różnicę w jego dokumencie źródłowym.
Aby otworzyć okno dialogowe Difference between i wyświetlić listę różnic:
-
Aby otworzyć okno dialogowe Choose Documents to Compare, pokazane na poniższej ilustracji, uruchom polecenie Project » Show Differences lub kliknij prawym przyciskiem myszy wpis odpowiedniego projektu (lub jednego z jego dokumentów źródłowych) w panelu Projects i wybierz polecenie Show Differences z menu kontekstowego. Okno dialogowe Choose Documents to Compare służy do wyboru dwóch dokumentów lub zestawów dokumentów, które chcesz porównać. Zazwyczaj porównuje się projekt schematu z PCB. Możesz również użyć tego okna do porównania dowolnych dwóch dokumentów, zaznaczając opcję Advanced Mode. Możesz na przykład porównać listę połączeń z PCB lub jedno PCB z drugim.
Domyślna konfiguracja okna dialogowego — zarówno w trybie podstawowym, jak i zaawansowanym — zwykle wystarcza do większości porównań projektów, w których dokumenty źródłowe i docelowy projekt PCB należy porównać w celu ich synchronizacji. Okno umożliwia jednak również porównywanie innych dokumentów, co może być przydatne, gdy trzeba wczytać różne wersje projektu i porównać różnice między odpowiadającymi sobie dokumentami źródłowymi.

Wybierz PCB, z którym chcesz porównać projekt schematu. - Wybierz PCB w głównej części okna dialogowego i kliknij OK, aby otworzyć okno dialogowe Difference between, pokazane poniżej. Jeśli dokument PCB jest obecnie zsynchronizowany z dokumentami źródłowymi, pojawi się okno z informacją, że nie wykryto żadnych różnic.
Otworzy się okno dialogowe Differences between. Synchronizator działa dwukierunkowo. Oznacza to, że w ramach jednego ECO możesz określić aktualizacje obu dokumentów. Aby zsynchronizować porównywane dokumenty, dla każdej różnicy należy ustalić, czy podjąć działanie i w którym kierunku wprowadzić zmianę — czyli wskazać dokument, który ma zostać zaktualizowany w celu usunięcia różnicy. Następnym krokiem jest zatem przypisanie każdej różnicy kierunku aktualizacji:
- W przypadku pojedynczej różnicy kliknij w kolumnie Update, aby wyświetlić selektor kierunku, jak pokazano na poniższej ilustracji.
- W przypadku wielu różnic tego samego rodzaju kliknij prawym przyciskiem myszy nagłówek, np. Różne footprinty, i wybierz odpowiednie polecenie Update Same Kind.
- W przypadku wszystkich różnic kliknij prawym przyciskiem myszy w dowolnym miejscu okna dialogowego i wybierz odpowiednie polecenie Update All.

Dla każdej różnicy należy ustawić kierunek aktualizacji, aby można było utworzyć ECO służące do jej usunięcia.
Kliknij przycisk Explore Differences, aby otworzyć panel Differences i przeanalizować różnice zgodnie z opisem w sekcji Analiza zmian w projekcie za pomocą panelu Differences poniżej.
Kliknij Report Differences, aby skonfigurować i wydrukować lub wyeksportować raport dotyczący różnic wykrytych przez komparator, określonych decyzji o aktualizacji oraz działań, które zostaną uwzględnione w wygenerowanym ECO.
Po przypisaniu kierunku aktualizacji kliknij przycisk Create Engineering Change Order, aby otworzyć okno dialogowe Engineering Change Order, opisane w sekcji Usuwanie różnic — stosowanie ECO poniżej.
Analiza zmian w projekcie za pomocą panelu Differences

Panel Differences wyświetla hierarchiczny widok różnic między dokumentami.
Podsumowanie
Panel Differences służy do wyświetlania różnic logicznych lub fizycznych wykrytych przez wbudowany w oprogramowanie komparator różnic podczas porównywania dokumentów projektowych (na przykład podczas porównywania hierarchii dokumentów źródłowych (schematów) projektu z dokumentem projektu PCB). Panel umożliwia interaktywne przeglądanie różnic przed podjęciem decyzji o utworzeniu zlecenia zmiany inżynierskiej (ECO), które posłuży do synchronizacji dokumentów projektu.
Dostęp do panelu
Aby otworzyć panel Differences :
- Wybierz View » Panels » Differences z menu głównego.
- Kliknij przycisk Panels w prawym dolnym rogu obszaru roboczego projektu, a następnie kliknij Differences.
Wyświetlanie różnic
Sposób wykorzystania panelu Differences zależy od tego, czy celem jest:
- Analiza spójności całego projektu pod względem zawartości i struktury poprzez wykrywanie różnic logicznych w hierarchii projektu.
- Porównanie dwóch wersji tego samego dokumentu schematu lub PCB poprzez wykrywanie różnic graficznych (fizycznych).
Wyświetlanie różnic logicznych
Porównywanie dokumentów projektu pod kątem różnic logicznych odbywa się w oknie dialogowym Choose Documents To Compare, otwieranym przez kliknięcie prawym przyciskiem myszy projektu (lub dokumentu projektu) w panelu Projekty i wybranie Show Differences z odpowiedniego menu kontekstowego.

Kliknij prawym przyciskiem myszy nazwę projektu, a następnie wybierz Show Differences, aby otworzyć okno dialogowe Choose Documents To Compare.
Zazwyczaj dokument PCB porównuje się z hierarchią dokumentów źródłowych projektu nadrzędnego, aby wykryć różnice logiczne między zawartością projektu schematu a zawartością projektu PCB.
Po kliknięciu OK, jeśli między wskazanymi dokumentami występują różnice, otworzy się okno dialogowe Różnice między. Informacje w panelu Differences pojawią się dopiero po kliknięciu przycisku Explore Differences w oknie dialogowym Differences between.
Panel Differences wyświetla tylko różnice wymienione w oknie dialogowym Differences between. Te z kolei zależą od ustawień na karcie Komparator okna dialogowego Project Options (Project » Options). Na tej karcie wymieniono wszystkie typy porównań, takie jak różnice dotyczące komponentów, sieci i parametrów. Wybranie ustawienia Mode dla każdej kategorii porównania — Find Differences lub Ignore Differences — określa, czy komparator różnic przekaże wyniki do okna dialogowego Differences between .

Skonfiguruj sposób wykrywania i zgłaszania różnic w oknie dialogowym Project Options.
Panel Differences wyświetla różnice wykryte między dokumentami źródłowymi w strukturze drzewa, w której folder najwyższego poziomu wskazuje łączną liczbę wykrytych różnic. Następnie tworzone są podfoldery dla poszczególnych typów porównań występujących w oknie dialogowym Różnice między. Każdy podfolder zawiera listę konkretnych wykrytych różnic, które są dalej rozbite na obiekty w dokumentach odpowiedzialne za te różnice.
Jeśli powiązany dokument jest otwarty (lub otwarty i ukryty), kliknięcie wpisu obiektu w panelu spowoduje przejście do tego obiektu w dokumencie.
Obiekt jest wyświetlany z zastosowaniem powiększenia i przyciemnienia — zostaje wyróżniony przez przyciemnienie wszystkich pozostałych obiektów. Kontrast przyciemnienia można regulować suwakiem Dimming znajdującym się w sekcji Highlight Methods na stronie System — Nawigacja okna dialogowego Preferences .
Wyświetlanie różnic fizycznych
Porównywanie graficzne (fizyczne) dwóch wersji tego samego dokumentu schematu lub PCB odbywa się zasadniczo w taki sam sposób jak opisane powyżej porównywanie logiczne, ale dodatkowo wykorzystuje Advanced Mode w oknie dialogowym Choose Documents To Compare.
Aby przeprowadzić porównanie fizyczne dokumentów, użyj polecenia Show Differences (w menu kontekstowym panelu Projects), aby otworzyć okno dialogowe Choose Documents To Compare, a następnie zaznacz pole Advanced Mode. Gdy w oknie dialogowym zostaną wyświetlone wszystkie pliki projektu, wybierz dwie wersje dokumentu do porównania.

Wybieranie dokumentów do porównania fizycznego w oknie dialogowym Choose Documents To Compare w Advanced Mode.
Kliknięcie OK uruchomi porównanie graficzne i otworzy okno dialogowe Różnice między, zgodnie z wcześniejszym opisem. Kliknij Explore Differences, aby otworzyć interaktywną listę różnic w panelu Differences.
Panel wyświetla różnice wykryte między dokumentami w strukturze drzewa. Folder najwyższego poziomu wskazuje łączną liczbę wykrytych różnic. Dla każdego typu różnicy tworzone są wpisy zawierające odpowiednie odwołania oraz obiekt (port, element itp.), którego dotyczy dana różnica.
Wybranie wpisu obiektu dla wykrytej różnicy spowoduje wyróżnienie tego obiektu i powiększenie jego widoku w obszarze projektowym edytora.
Uwagi
- Jeśli obiekt w panelu znajduje się w dokumencie, który jest obecnie ukryty, kliknięcie odpowiedniego wpisu spowoduje automatyczne otwarcie dokumentu i ustawienie go jako aktywnego dokumentu w oknie edytora projektu.
- Filtrowanie stosowane podczas przechodzenia z panelu Differences do obiektów w dokumentach jest tymczasowe. Nie uniemożliwia więc zaznaczania ani edytowania obiektów projektu znajdujących się poza zakresem filtra.
- Informacje w panelu Differences zostaną usunięte po wykonaniu nowego porównania dokumentów lub skompilowaniu projektu nadrzędnego.
- Użyj polecenia Project » Show Physical Differences z menu głównego, aby wykryć różnice fizyczne między dwiema wersjami dokumentu schematu lub PCB i przedstawić je graficznie podczas wyświetlania obu dokumentów obok siebie w obszarze projektowym. Funkcja Pokaż różnice fizyczne umożliwia wyłącznie porównanie wizualne — żadnego z porównywanych dokumentów nie można zaktualizować przez wygenerowanie ECO. Jest przeznaczona do porównywania dwóch wersji tego samego dokumentu, ale jeśli zostanie uruchomiona w celu porównania różnych dokumentów, na przykład hierarchii dokumentów źródłowych projektu z PCB, pojawi się panel Differences z listą wykrytych różnic logicznych.
Wykonywanie bezpośredniej aktualizacji
Ponieważ projektant zazwyczaj wie, w którym kierunku chce zastosować aktualizacje, a wszystkie aktualizacje przebiegają w tym samym kierunku, można pominąć opisany powyżej proces wykrywania różnic i przypisywania kierunku zmian.
Zamiast wybierać polecenie Show Differences z menu Project, wybierz polecenie Update z menu Design w edytorze schematów lub edytorze PCB. Wybór edytora, z którego uruchamiasz polecenie, określa kierunek wprowadzania zmian — z edytora this do edytora that. Na przykład wybierz Design » Update w edytorze schematów, aby przenieść wszystkie zmiany ze schematu do PCB.
Okno dialogowe Differences between zostanie pominięte i nastąpi bezpośrednie przejście do okna dialogowego Engineering Change Order.
Jeśli wszystkie aktualizacje mają być zastosowane w tym samym kierunku, użyj polecenia Design » Update.
Rozwiązywanie różnic — stosowanie ECO
Każdą różnicę rozwiązuje się przez zastosowanie zlecenia zmiany inżynierskiej (Engineering Change Order, ECO). Zlecenia ECO są wyświetlane w oknie dialogowym Engineering Change Order, po jednym w każdym wierszu, a każde z nich ma własne pole wyboru Enable.
Podczas korzystania z okna dialogowego Engineering Change Order:
- Okno otwiera się ze wszystkimi zmianami włączonymi. Wyłącz te zmiany, które chcesz na razie odłożyć. Okno obsługuje zaznaczanie wielu pozycji — użyj menu kontekstowego dostępnego pod prawym przyciskiem myszy, aby przełączać stan włączenia zaznaczonych ECO.
- Użyj polecenia Cross Probe dostępnego pod prawym przyciskiem myszy, aby sprawdzić obiekty, których dotyczy dane ECO.
- Użyj przycisku Validate Changes, aby sprawdzić, czy zmiany można wykonać. ECO najczęściej nie udaje się wykonać z powodu niedostępności obiektu — na przykład wskazany footprint PCB nie istnieje w dostępnych bibliotekach plikowych albo wskazany pad nie istnieje w footprincie.
- Wykonanie ECO może się również nie powieść, gdy obiekt wymagany przez dane ECO początkowo nie istniał, lecz został dodany podczas przetwarzania bieżących ECO. W takiej sytuacji uruchom ponownie polecenie Update, aby wykonać to ECO.

Każda zmiana w projekcie jest przedstawiana jako ECO. Włącz te, które są wymagane.
Opcje i elementy sterujące okna dialogowego Engineering Change Order
Okno dialogowe jest podzielone na dwa główne obszary: Modifications i Status.
Modyfikacje
Ten obszar okna dialogowego zawiera wszystkie modyfikacje niezbędne do wprowadzenia zmian wymaganych do synchronizacji. Modyfikacje są pogrupowane według typu, zgodnie z listą i ustawieniami włączenia w oknie dialogowym Project Options - ECO Generation. Wpis na poziomie grupy wskazuje liczbę modyfikacji danego typu. Każda modyfikacja w tym obszarze jest opisana następująco:
- Enable - ta opcja określa, czy modyfikacja zostanie uwzględniona podczas wykonywania ECO. Kliknij bezpośrednio pole wyboru, aby przełączyć jego stan między włączonym/uwzględnionym (zaznaczone) a wyłączonym/pominiętym (niezaznaczone). Pole wyboru Enable można zaznaczać i odznaczać za pomocą spacji.
- Action - konkretna czynność do wykonania. Dostępne typy czynności zależą od rodzaju ECO, które należy wykonać.
- Affected Object - obiekt, którego dotyczy czynność.
- Affected Document - dokument, w którym zostanie wykonana czynność.
Menu kontekstowe
Domyślnie wszystkie modyfikacje są włączone i zostaną uwzględnione podczas wykonywania ECO. Włączaj lub wyłączaj poszczególne modyfikacje zgodnie z potrzebami albo użyj poniższych poleceń z menu kontekstowego, aby zmienić stan włączenia wielu modyfikacji:
- Validate Changes - kliknij, aby zweryfikować modyfikacje włączone do uwzględnienia w ECO. Wyniki weryfikacji pojawią się w kolumnie Check w obszarze Status okna dialogowego.
- Execute Changes - kliknij, aby wykonać ECO. Wyniki wykonania pojawią się w kolumnie Done w obszarze Status okna dialogowego. Pamiętaj, że wykonane zostaną tylko zmiany, które pomyślnie przejdą weryfikację.
- Create Report - kliknij, aby wygenerować raport dotyczący modyfikacji zawartych w ECO. Raport zostanie załadowany do okna dialogowego Report Preview.
- Cross Probe - kliknij, aby za pomocą funkcji cross-probe wskazać obiekty docelowe i referencyjne objęte modyfikacją w powiązanych dokumentach schematów i PCB.
- Expand All - kliknij, aby rozwinąć widok wszystkich modyfikacji na liście.
- Contract All - kliknij, aby zwinąć widok wszystkich modyfikacji na liście.
- Enable All - służy do włączania wszystkich modyfikacji.
- Disable All - służy do wyłączania wszystkich modyfikacji.
- Enable Selected - służy do włączania wszystkich zaznaczonych modyfikacji.
- Disable Selected - służy do wyłączania wszystkich zaznaczonych modyfikacji.
- Enable all of same Kind - służy do włączania wszystkich modyfikacji tego samego typu co bieżąca modyfikacja.
- Disable all of same Kind - służy do wyłączania wszystkich modyfikacji tego samego typu co bieżąca modyfikacja.
- Invert Selection - służy do szybkiego zaznaczania wszystkich niezaznaczonych modyfikacji na liście i odznaczania tych, które są zaznaczone.
Status
Ten obszar okna dialogowego przedstawia następujące informacje o statusie każdej włączonej modyfikacji:
- Check - to pole pokazuje wynik weryfikacji modyfikacji. Zielony znacznik wyboru oznacza, że proponowana zmiana jest obsługiwana i zostanie wprowadzona podczas wykonywania ECO. Czerwony krzyżyk oznacza, że proponowana zmiana jest nieprawidłowa i nie zostanie wprowadzona podczas wykonywania ECO.
- Done - to pole pokazuje wynik wykonania modyfikacji. Zielony znacznik wyboru oznacza, że prawidłowa modyfikacja została pomyślnie wykonana.
- Message - jeśli modyfikacja nie przejdzie etapu walidacji, w tym polu (a także w panelu Messages) pojawi się wpis wskazujący przyczynę niepowodzenia.
Dodatkowe elementy sterujące
U dołu okna dialogowego oraz w menu kontekstowym dostępne są następujące elementy sterujące:
- Validate Changes - kliknij, aby przeprowadzić walidację modyfikacji zaznaczonych do uwzględnienia w ECO. Wyniki walidacji pojawią się w kolumnie Check w obszarze Status okna dialogowego.
- Execute Changes - kliknij, aby wykonać ECO i zastosować zawarte w nim prawidłowe zmiany. Wyniki wykonania pojawią się w kolumnie Done w obszarze Status okna dialogowego. Pamiętaj, że wykonane zostaną tylko zmiany, które przejdą etap walidacji.
- Report Changes - kliknij, aby wygenerować raport dotyczący modyfikacji zawartych w ECO. Raport zostanie wczytany do okna dialogowego Report Preview.
- Only Show Errors - zaznacz tę opcję, aby wyświetlać tylko błędy zlecenia zmian inżynierskich (ECO). Zmiany, które przeszły walidację, nie będą wyświetlane. Wyświetlenie samej listy błędów umożliwi szybkie przejrzenie i wprowadzenie niezbędnych zmian w projekcie, tak aby wynikowe ECO w całości przeszło walidację.
Zasady powiązania schematu z PCB
Dopasowywanie komponentów za pomocą unikalnych identyfikatorów
Każdy komponent schematu jest powiązany ze swoim odpowiednikiem na PCB za pomocą unikalnego identyfikatora (UID). UID jest przypisywany podczas umieszczania komponentu na arkuszu schematu, a jego wartość jest przenoszona do komponentu PCB podczas przenoszenia projektu do edytora PCB. Gdy informacje o komponentach są po raz pierwszy przenoszone ze źródłowych dokumentów schematu do pustego dokumentu projektu PCB za pomocą Synchronizer, wszystkie komponenty zostają automatycznie powiązane za pomocą unikalnych identyfikatorów — identyfikator każdego komponentu schematu jest przypisywany do odpowiadającej mu obudowy na PCB.
Ten mechanizm wystarczyłby w przypadku prostego projektu, ale nie pozwala obsługiwać projektu wielokanałowego. W projekcie wielokanałowym ten sam komponent schematu jest powielany w każdym fizycznym kanale, co oznaczałoby, że powielone komponenty PCB miałyby ten sam UID. Aby temu zaradzić, UID komponentu PCB jest tworzony przez połączenie UID nadrzędnego symbolu arkusza z UID komponentu schematu. Składnia UID na PCB różni się nieznacznie w zależności od sposobu utworzenia projektu wielokanałowego.
W przypadku projektu wielokanałowego utworzonego przez umieszczenie wielu symboli arkuszy odwołujących się do tego samego arkusza schematu każdy symbol arkusza może dostarczyć unikalny identyfikator, więc UID na PCB ma następujący format:
\SheetSymbolUID\SchComponentUID
W przypadku projektu wielokanałowego utworzonego za pomocą słowa kluczowego Repeat dostępny jest tylko jeden UID symbolu arkusza, dlatego UID na PCB zawiera również wartość ChannelIndex i ma następujący format:
\ChannelIndex+SheetSymbolUID\SchComponentUID
Gdy komponenty nie są powiązane
Zaletą używania UID do dopasowywania komponentów schematu i PCB jest możliwość utraty synchronizacji oznaczeń (na przykład po kilkukrotnym ponownym numerowaniu komponentów na PCB) bez ryzyka, że ponowna synchronizacja schematu i PCB stanie się niemożliwa.
Jeśli na schemacie lub PCB występuje komponent, który nie ma odpowiednika (o tym samym UID) w drugim edytorze, nastąpi jedna z poniższych sytuacji:
- Jeśli dodatkowy komponent występuje tylko w edytorze źródłowym, zostanie wygenerowane ECO dodające ten komponent w edytorze docelowym.
- Jeśli dodatkowy komponent występuje tylko w edytorze docelowym, zostanie wygenerowane ECO usuwające ten komponent.
- Gdy niedopasowane komponenty występują w obu edytorach, program potrzebuje wskazówek, jak je obsłużyć, dlatego otworzy się okno dialogowe Failed to Match Unique Identifiers.
Okno dialogowe e Failed to Match Unique Identifiers
Przyciski w oknie dialogowym udostępniają następujące opcje:
- Automatically Create Component Links - kliknij ten przycisk, jeśli wiesz, że niedopasowane komponenty mają już zgodne oznaczenia. Na podstawie oznaczeń komponentów program przypisze tym dodatkowym komponentom zgodne identyfikatory UID. W przypadku komponentów, które można dopasować według oznaczenia, wszelkie inne różnice we właściwościach (takie jak niezgodne parametry) spowodują wygenerowanie ECO. Jeśli niektórych komponentów nie da się dopasować według oznaczenia, zostaną wygenerowane ECO dodające lub usuwające te komponenty (dodatkowe komponenty w edytorze źródłowym zostaną dodane, a dodatkowe komponenty w edytorze docelowym — usunięte).
-
Manual Component Links - kliknij ten przycisk, jeśli wiesz, że istnieją odpowiadające sobie komponenty, ale nie znasz stanu ich oznaczeń. Otworzy się okno dialogowe Edit Component Links (opisane poniżej), w którym można ręcznie wybrać każdy komponent źródłowy i docelowy, a następnie przenieść je na listę dopasowanych komponentów, przypisując im zgodne identyfikatory UID. Następnie zostaną wygenerowane ECO synchronizujące oznaczenia (oraz wszelkie inne niezgodne właściwości komponentów).
- Cancel - kliknij ten przycisk, aby wygenerować ECO dodające dodatkowe komponenty obecne w edytorze źródłowym i usuwające dodatkowe komponenty z edytora docelowego.
Ręczne powiązywanie komponentów
Stan powiązań między komponentami schematu a odpowiadającymi im obudowami komponentów na PCB można w dowolnym momencie sprawdzić i zmienić w oknie dialogowym Edit Component Links (edytor PCB, polecenie Projects » Component Links).

Okno dialogowe Edytuj powiązania komponentów służy do wykrywania i usuwania niezgodności identyfikatorów UID i jest otwierane z poziomu edytora PCB.
Podsumowanie funkcji okna dialogowego:
- Niedopasowane komponenty są wyświetlane w dwóch kolumnach Un-Matched Components po lewej stronie, a komponenty o zgodnych identyfikatorach UID — w obszarze Matched Components po prawej stronie okna dialogowego.
- Przyciski ze strzałkami pośrodku okna dialogowego służą do ręcznego dopasowywania (lub usuwania dopasowania) wybranych komponentów albo do usuwania dopasowania wszystkich aktualnie dopasowanych komponentów.
- Przycisk Add Pairs Matched By i opcje u dołu okna dialogowego służą do przeszukiwania listy aktualnie niedopasowanych komponentów i podejmowania próby dopasowania ich na podstawie zaznaczonych właściwości (oznaczenie, komentarz, obudowa).
- Po kliknięciu przycisku Perform Update każdemu nowo dopasowanemu komponentowi PCB przypisywany jest UID jego odpowiednika na schemacie. Jeśli przeniesiono jakiekolwiek wpisy w Matched sekcji okna dialogowego z powrotem do sekcji Unmatched , pojawi się okno potwierdzenia z informacją, że kontynuowanie spowoduje zerwanie istniejących powiązań komponentów. Kliknięcie Yes spowoduje kontynuowanie aktualizacji i wyświetlenie okna informacyjnego z podsumowaniem powiązań komponentów zmodyfikowanych w dokumencie PCB. Nowy wpis w sekcji Matched jest podsumowany jako Link Modified, natomiast wcześniej powiązany wpis, którego dopasowanie zostało teraz usunięte, jest podsumowany jako Link Removed.
- Po użyciu tego okna dialogowego do ręcznego powiązania komponentów warto sprawdzić stan synchronizacji (uruchomić polecenie Design » Update).
Dopasowywanie sieci i klas
Zarówno sieci, jak i klasy mają element nadrzędny (sieć lub klasę) oraz elementy podrzędne (członków danej sieci lub klasy). Ich dopasowywanie wymaga innego podejścia niż mechanizm UID stosowany do powiązywania komponentów, aby obsługiwać zmiany elementu nadrzędnego, elementów podrzędnych lub obu tych grup. Na przykład tak prosta operacja jak zmiana nazwy sieci na schemacie nie powinna wymagać usunięcia z PCB tej sieci i wszystkich należących do niej pinów, następnie dodania sieci pod nową nazwą, a na końcu dodania wszystkich pinów do tej nowej sieci.
Aby to umożliwić, oprogramowanie zawiera odrębne algorytmy dopasowywania sieci i klas według ich członków oraz według nazwy. Proces dopasowywania konfiguruje się w sekcji Object Matching Criteria na karcie Comparator okna dialogowego Options for Project.

Domyślne ustawienia przewidują dopasowywanie najpierw według członków, a następnie według nazwy typu obiektu.
Dopasowywanie tych typów obiektów przebiega w następujący sposób:
- Podczas synchronizacji projektu domyślnie najpierw podejmowana jest próba dopasowania według członków, zgodnie z ustawieniami Min Match % i Min Match Member.
- Jeśli dopasowanie według członków się nie powiedzie, oprogramowanie spróbuje dopasować obiekty według nazwy (jeśli opcja Use Name Matching jest włączona).
- Jeśli którykolwiek z tych procesów dopasowywania zakończy się powodzeniem, nastąpi przejście do okna dialogowego Engineering Change Order.
-
Jeśli obie metody dopasowywania zawiodą (lub opcja Use Name Matching jest ustawiona na
Never), otworzy się okno dialogowe Match Manually.
- Kliknięcie No w oknie dialogowym Match Manually spowoduje pominięcie ręcznego dopasowywania i przejście bezpośrednio do okna dialogowego Engineering Change Order. Ponieważ nie podjęto próby dopasowania żadnych niedopasowanych obiektów, oprogramowanie zakłada, że obiekty referencyjne i docelowe nie są ze sobą powiązane. Zostaną więc wygenerowane ECO usuwające Unmatched Reference Objects z płytki i dodające Unmatched Target Objects jako nowe obiekty.
- Jeśli klikniesz Yes w oknie dialogowym, aby przeprowadzić ręczne dopasowanie, otworzy się okno dialogowe Match, pokazane poniżej (tytuł okna zmieni się odpowiednio do typu niedopasowanych obiektów).
Okno dialogowe Match służy do ręcznego dopasowywania obiektów, o których wiesz, że sobie odpowiadają. Jeśli nie masz pewności, pozostaw prawą stronę pustą i kliknij Continue.
Opcje i elementy sterujące okna dialogowego dopasowywania
-
Unmatched <Object>
- Unmatched Reference Objects - wyświetla listę niedopasowanych obiektów. Użyj elementów rozwijania/zwijania, aby otworzyć lub zamknąć listę.
- Unmatched Target Objects - wyświetla listę obiektów docelowych. Użyj elementów rozwijania/zwijania, aby otworzyć lub zamknąć listę.
-
- kliknij, aby dopasować wybrane obiekty referencyjne i docelowe oraz przenieść wybrane obiekty z obszaru Unmatched do obszaru Matched Pairs.
-
- kliknij, aby przenieść wybrane obiekty z obszaru Matched Pairs do obszaru Unmatched. Ta czynność spowoduje usunięcie dopasowania przeniesionych obiektów.
-
- kliknij, aby przenieść wszystkie obiekty z obszaru Matched Pairs do obszaru Unmatched. Ta czynność spowoduje usunięcie dopasowania przeniesionych obiektów.
- Matched Pairs - wyświetla listę Reference Object i Target Object , które są teraz dopasowane.
- Continue - kliknij, aby zaakceptować zmiany dopasowania i otworzyć okno dialogowe Engineering Change Order.
- W tym oknie dialogowym zaznacz obiekty, które chcesz dopasować, w Unmatched Reference Objects i Unmatched Target Objects, a następnie przenieś je do sekcji Matched Pairs okna dialogowego. Dla tych obiektów oprogramowanie wygeneruje ECO aktualizujące nazwy, aby były zgodne, oraz ECO usuwające i dodające członków, aby oni również byli zgodni.
- Jeśli nie masz pewności, nie musisz ręcznie dopasowywać obiektów. W przypadku wszystkich niedopasowanych obiektów oprogramowanie zakłada, że obiekty referencyjne i docelowe nie są ze sobą powiązane, więc wygeneruje ECO usuwające Unmatched Reference Objects z płytki i dodające Unmatched Target Objects jako nowe obiekty.
- Po dopasowaniu obiektów, o których wiesz, że sobie odpowiadają, kliknij Continue, aby otworzyć okno dialogowe Engineering Change Order.
- Kliknięcie Cancel spowoduje zakończenie procesu aktualizacji.
Dopasowywanie reguł projektowych
Reguły projektowe zdefiniowane na schemacie muszą również zostać powiązane z odpowiadającymi im regułami na PCB. Bez mechanizmu powiązań nie można byłoby zaktualizować reguły na schemacie i przenieść tych zmian na PCB. Do powiązania reguły projektowej na schemacie z regułą projektową na PCB używane są identyfikatory UID.
UID jest automatycznie przypisywany w zestawie parametrów zawierającym definicję reguły na schemacie i przenoszony na PCB podczas synchronizacji projektu.
Reguły projektowe wykorzystują UID do dopasowania definicji reguły projektowej na schemacie do reguły projektowej na PCB.
Zazwyczaj nie trzeba ręcznie zarządzać dopasowywaniem reguł, chyba że identyfikator UID został ręcznie zmieniony w oknie dialogowym PCB Rules and Constraints w edytorze PCB. Jeśli identyfikatory UID nie są zgodne, oprogramowanie doda do PCB nową regułę dla każdej reguły schematu, która nie ma odpowiadającej jej reguły PCB, oraz usunie każdą regułę projektową PCB, która nie ma odpowiadającej jej reguły projektowej schematu.
