Panel nawigacyjny
Altium Essentials: Navigating Schematics
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
W skrócie
- Dowiedz się, jak panel Navigator umożliwia przeglądanie poszczególnych arkuszy schematu, całego projektu i jego hierarchii, aby szybko znajdować połączone obiekty.
- Zobacz, jak poruszać się w obu kierunkach — od panelu do schematu i od schematu do panelu — oraz kiedy kliknięcie z wciśniętym klawiszem Alt może pomóc w lokalizowaniu powiązanych obiektów na PCB.
- Poznaj wpływ podświetlania, powiększania, przyciemniania i walidacji na widok podczas nawigacji, aby łatwiej śledzić połączenia w złożonych projektach.
Jeśli projekt jest duży i obejmuje wiele arkuszy, śledzenie sieci i weryfikowanie połączeń w projekcie wyłącznie na podstawie schematów może być trudne. Znalezienie tych samych obiektów na PCB stanowi jeszcze większe wyzwanie. Pomaga w tym panel Navigator.

Panel Navigator zapewnia wgląd w cały projekt. Przytrzymaj Alt podczas klikania w panelu, aby zlokalizować dany element również na PCB.
Panel Navigator umożliwia przeglądanie aktywnego źródłowego dokumentu schematu lub wszystkich źródłowych dokumentów schematów w aktywnym projekcie. Podstawą nawigacji w panelu jest model połączeń projektu, tworzony automatycznie w tle. Panel umożliwia również nawigację do komponentów, pól lutowniczych, magistral i sieci na PCB.
Nawigacja po projekcie
Nawigację można prowadzić na dwa sposoby — klikając w panelu Navigator, aby zlokalizować obiekt na schemacie, lub klikając obiekt na schemacie, aby zlokalizować go w panelu Navigator.
Z panelu Navigator
Aby wyświetlić panel Navigator, użyj przycisku Panels w prawym dolnym rogu okna programu lub wybierz View » Panels » Navigator z menu.
Informacje o komponentach i połączeniach są ładowane do panelu po otwarciu schematu. Aby je wyświetlić, kliknij ikonę w sekcji Documents. Program automatycznie tworzy dynamiczny model danych dla całego projektu i aktualizuje go podczas edycji. Należy pamiętać, że karty dokumentów (u góry graficznego obszaru edycji) nie są wyświetlane dla wszystkich arkuszy schematu — arkusze te są otwierane w tle. Karta pojawia się dopiero po wykonaniu przez użytkownika operacji na danym arkuszu.
Dynamiczny model danych jest dostępny w każdym edytorze, a także w panelu Navigator. Jeśli nie masz pewności, czy zawartość panelu odpowiada bieżącemu stanowi projektu, wybierz polecenie Validate Project, aby wymusić odświeżenie modelu (w menu Project lub w menu kontekstowym otwieranym prawym przyciskiem myszy w panelu Navigator).

Kliknij obiekt w panelu Navigator, aby zlokalizować wszystkie jego wystąpienia w całym projekcie.
Nawigacja interaktywna
Oprócz nawigowania za pomocą list obiektów w panelu i klikania w celu zlokalizowania obiektu w obszarze graficznym można również nawigować z obszaru graficznego do listy. Ten tryb, nazywany nawigacją interaktywną, uruchamia się przez kliknięcie przycisku Interactive Navigation u góry panelu Navigator. Kursor zmienia się w krzyżyk, wskazując tryb nawigacji, który pozostaje aktywny do kliknięcia prawym przyciskiem myszy lub naciśnięcia klawisza Esc .
Podczas nawigacji po projekcie widok arkusza jest aktualizowany zgodnie z bieżącymi opcjami wyróżniania, a panel Navigator jest aktualizowany tak, aby wyświetlać informacje związane z bieżącym zaznaczeniem w graficznym oknie edycji.

Uruchom nawigację interaktywną (przycisk u góry panelu Navigator), a następnie kliknij obiekt na arkuszu, aby zlokalizować go w panelu i w pozostałej części projektu.
Skrót do nawigacji interaktywnej
Oprócz uruchamiania nawigacji interaktywnej z panelu Navigator można ją wywołać w dowolnym momencie w edytorze schematów — przytrzymaj Alt podczas klikania obiektu projektu. Możesz kliknąć dowolny obiekt, w tym przewód, etykietę sieci, port, wejście arkusza, symbol arkusza lub komponent.
Użyj skrótu Alt+kliknięcie, aby nawigować po projekcie.
Sposób wyróżniania obiektów podczas nawigacji
Po kliknięciu obiektu w panelu Navigator jest on wyświetlany w graficznym obszarze edycji. Sposób jego prezentacji zależy od ustawień System - Navigation w oknie dialogowym Preferences. Aby uzyskać dostęp do tych ustawień bezpośrednio z panelu Navigator, kliknij przycisk Navigation Options u góry panelu, aby otworzyć okno dialogowe.
Obszar Highlight Methods okna dialogowego Preferences zawiera opcje sterujące efektem wizualnym tymczasowego filtrowania stosowanego w dokumencie podczas nawigacji — zarówno z poziomu panelu, jak i bezpośrednio w dokumencie. Można włączyć dowolną kombinację tych opcji. Na przykład można przybliżyć i zaznaczyć wszystkie odfiltrowane obiekty w oknie edytora projektu, a jednocześnie przyciemnić pozostałe obiekty projektu, aby ograniczyć wizualny chaos.
Panel Navigator
Panel Navigator umożliwia przeglądanie modelu połączeń projektu. Struktura projektu jest przedstawiona w czterech sekcjach panelu, z których każdą opisano poniżej.
Panel Navigator przedstawia cały projekt z perspektywy połączeń.
Sekcja Documents
Znajdująca się u góry panelu sekcja Documents oferuje trzy różne sposoby przeglądania projektu — individual sheets, flattened hierarchy (cały projekt) lub możliwość przeglądania full design hierarchy. Kliknij raz ikonę w tej pierwszej sekcji, aby załadować dane do panelu, lub kliknij dwukrotnie, aby dodatkowo wyświetlić wyniki w graficznym obszarze edycji.
Funkcje sekcji Documents
Sekcja Documents |
|
| Individual Sheets | Wyświetla ikonę dla każdego arkusza schematu w projekcie, identyfikowanego przez Kliknij raz, aby wyświetlić wyniki w panelu Navigator, lub kliknij dwukrotnie, aby dodatkowo wyświetlić je w graficznym obszarze edycji. |
| Flattened Hierarchy (cały projekt |
Wyświetla wszystkie obiekty i połączenia w całym projekcie. Jeśli w projekcie występują powtarzane arkusze (kanały), dla każdej klasy kanałów zostanie wyświetlona ikona podrzędna, identyfikowana nazwą kanału (pochodzącą z Kliknij raz, aby wyświetlić wyniki w panelu Navigator, lub kliknij dwukrotnie, aby dodatkowo wyświetlić je w graficznym obszarze edycji. |
| Full Design Hierarchy | Wyświetla ikonę dla każdego logicznego arkusza w projekcie. Jeśli w projekcie występują powtarzane arkusze (kanały), dla każdego kanału dostępna jest ikona arkusza, identyfikowanego przez Kliknij raz, aby wyświetlić wyniki w panelu Navigator, lub kliknij dwukrotnie, aby dodatkowo wyświetlić je w graficznym obszarze edycji. Dwukrotne kliknięcie ikony powtarzanego kanału spowoduje nie tylko wyświetlenie arkusza tego kanału, ale również wybranie karty danego kanału u dołu obszaru edycji schematu. |
Sekcja Components
Drugi obszar panelu zawiera wszystkie komponenty występujące w dokumencie aktualnie wybranym w pierwszej sekcji. Po wybraniu na liście wpisu instancji komponentu najwyższego poziomu zostanie zastosowany filtr oparty na tym wpisie, a jego efekt wizualny będzie zależał od wybranych metod wyróżniania. Jeśli włączone opcje wyróżniania obejmują opcję Connective Graph, widoczne będą wszystkie pozostałe komponenty połączone z wybranym komponentem (filtr zostanie rozszerzony tak, aby je uwzględnić). Połączone komponenty są wizualnie wyróżniane zielonymi liniami grafu połączeń.
Ponieważ opcja Connective Graph jest włączona, do każdego komponentu połączonego z komponentem wybranym w panelu rysowana jest zielona linia.
Funkcje sekcji Components
Sekcja Components |
|
| Information available | Dla każdego wpisu komponentu dostępne są podfoldery Parameters i Implementations (modele). Jeśli opcja Pins jest włączona w opcjach wyróżniania, dostępny będzie również podfolder Pins |
| When you click | Po kliknięciu wpisu pinu na liście Instance odpowiadający mu wpis zostanie zaznaczony w sekcji Net / Bus panelu, a wszystkie piny należące do jego sieci zostaną wyświetlone w dolnej sekcji panelu. Zostanie również zastosowany filtr oparty na wybranym wpisie pinu; efekt wizualny będzie zależał od włączonych metod wyróżniania. |
| Connective Graph | Jeśli włączono opcję Connective Graph, widoczne będą wszystkie pozostałe piny połączone z siecią, do której należy wybrany pin (filtr zostanie rozszerzony tak, aby je uwzględnić). Sieć, do której należą połączone piny, jest wizualnie wyróżniana czerwonymi liniami grafu połączeń |
Sekcja sieci / magistral
Trzecia sekcja panelu zawiera listę wszystkich sieci i magistral w przeglądanym dokumencie (lub spłaszczonej hierarchii). Po kliknięciu pozycji wszystkie obiekty powiązane z daną siecią lub magistralą — wyprowadzenia, etykiety sieci, porty, wejścia arkusza i łączniki międzyarkuszowe — zostaną wyświetlone w oknie edytora projektu zgodnie z włączonymi metodami wyróżniania.
Funkcje sekcji sieci / magistral
Sekcja sieci / magistral |
|
| Information available | Poszczególne typy obiektów powiązanych z wybraną siecią lub magistralą są wyświetlane w podfolderach, zależnie od aktualnie włączonych opcji wyróżniania oraz obecności danego typu obiektu w wybranej sieci lub magistrali. Dla każdej sieci lub magistrali może być dostępny dodatkowy podfolder zawierający listę linii graficznych użytych do połączenia powiązanych wyprowadzeń, portów, etykiet sieci, wejść arkusza i łączników międzyarkuszowych. Kliknij pozycję linii, aby odfiltrować tylko ten obiekt liniowy i zastosować ustawienia wyświetlania. |
| When you click | Wszystkie obiekty sieci, których wyświetlanie w panelu zostało włączone (z wyjątkiem linii graficznych), będą widoczne w dolnej sekcji panelu Także tutaj kliknięcie dowolnego z nich spowoduje zastosowanie filtrowania zgodnie z włączonymi metodami wyróżniania. |
Sekcja sieci magistrali — wyprowadzeń sieci
Zawartość czwartej sekcji panelu zależy od dwóch czynników: przeglądanego obiektu oraz obiektów wybranych do wyświetlania. Jeśli klikniesz bus w sekcji sieci / magistral, w tej sekcji panelu zostaną wyświetlone sieci należące do tej magistrali. Jeśli klikniesz net w sekcji sieci / magistral, zostaną wyświetlone wyprowadzenia należące do tej sieci. Wyświetlane są również identyfikatory sieci dołączone do tej sieci, o ile włączono ich wyświetlanie.
Sekcja sygnałów
Panel Navigator umożliwia przeglądanie projektu z perspektywy sygnałów zamiast standardowego widoku opartego na obiektach. Jeśli w sekcji Documents panelu wybrano dokument schematu, włączenie opcji Show Signals u góry panelu przełącza trzecią sekcję panelu w tryb Signal.
Kliknij pozycję sygnału, aby zastosować filtr. Węzły tego sygnału (wyprowadzenia, porty, etykiety sieci, wejścia arkusza i łączniki międzyarkuszowe) zostaną wyświetlone w oknie edytora projektu zgodnie z włączonymi metodami wyróżniania. Dla każdego sygnału na liście zostaną wyświetlone powiązane z nim wyprowadzenia węzłów, wejścia arkusza lub łączniki międzyarkuszowe. Pozycje te będą wyświetlane niezależnie od tego, czy włączono odpowiednią opcję wyświetlania danego typu obiektu.
Funkcje sekcji sygnałów
Sekcja sygnałów |
|
| Signal | Nazwa sygnału (nazwa magistrali lub sieci). |
| Width | Liczba odrębnych sieci w obrębie tego sygnału. |
| Click on a top-level signal entry | Kliknij pozycję sygnału na najwyższym poziomie, aby wypełnić dolną sekcję panelu wszystkimi węzłami powiązanymi z tym sygnałem. Mogą to być wyprowadzenia, etykiety sieci, porty, wejścia arkusza i łączniki międzyarkuszowe. Pozycje będą wyświetlane tylko wtedy, gdy włączono odpowiednią opcję wyświetlania danego typu obiektu. |
| Click on a sub-entry | Kliknij pozycję podrzędną na głównej liście sygnałów, aby wypełnić dolną sekcję panelu wszystkimi obiektami sieci powiązanymi z siecią nadrzędną tego sygnału. |
| SignalName Driven By Pin X | Wyświetlane, gdy wyprowadzenie węzła powiązane z sygnałem jest wyprowadzeniem wyjściowym lub wejściowo-wyjściowym. X oznacza oznaczenie komponentu i wyprowadzenia, które steruje sygnałem. |
| Driving Node Pin X | Wyświetlane, gdy wyprowadzenie węzła powiązane z sygnałem jest wyprowadzeniem wejściowym. X oznacza oznaczenie komponentu i wyprowadzenia, które jest sterowane przez sygnał. |
| Driven By Node Sheet Entry SignalName | Wyświetlane, gdy typ elektryczny węzła wejścia arkusza to wyjście lub wejście/wyjście — wejście arkusza steruje sygnałem. |
| Driving Node Sheet Entry X | Wyświetlane, gdy typ elektryczny wejścia arkusza to wejście — wejście arkusza jest wówczas sterowane przez sygnał. |
Nawigacja po PCB
Klikając w panelu Navigator, możesz przechodzić do obiektów na schemacie, a jednocześnie także do odpowiadających im obiektów na PCB. Jeśli podczas klikania obiektu w panelu Navigator przytrzymasz klawisz Alt, obiekty docelowe zostaną wyróżnione zarówno na schemacie, jak i na PCB.
Ponieważ nawigacja zawsze odbywa się na schemacie, aby przechodzić do obiektów na PCB, musisz wyświetlić jednocześnie schemat i PCB. Możesz to zrobić, wyświetlając PCB w osobnym oknie lub dzieląc obszar graficzny za pomocą funkcji Split Vertical albo Split Horizonal (poniżej pokazano podział pionowy). Polecenia obu tych funkcji są dostępne w menu kontekstowym otwieranym po kliknięciu prawym przyciskiem myszy karty dokumentu.
Przytrzymaj klawisz Alt podczas nawigacji po projekcie, aby lokalizować te obiekty również na PCB.
Altium Designer oferuje szereg funkcji ułatwiających pracę ze schematem i PCB, w tym:
| Cross probe | Lokalizowanie wzajemne — uruchom funkcję prawym przyciskiem myszy, a następnie kliknij obiekt (komponent, wyprowadzenie, sieć) w jednym edytorze, aby przejść do tego obiektu w drugim edytorze. Dostępne są dwa tryby: continuous (pozostanie w edytorze źródłowym) lub jump-to (uaktywnienie edytora/dokumentu docelowego). Przytrzymaj Ctrl podczas lokalizowania wzajemnego, aby uruchomić tryb jump-to. Lokalizowanie wzajemne jest obsługiwane w edytorach schematów, PCB i BOM, w menedżerze Constraint Manager oraz w panelach Project, Navigator i Messages. |
| Cross select | Kliknij komponent w jednym edytorze, aby zaznaczyć go również w drugim. Funkcja jest obsługiwana między edytorami schematów i PCB, a włącza się ją w menu View. |
Dowiedz się więcej o lokalizowaniu wzajemnym i zaznaczaniu wzajemnym
Menu kontekstowe panelu Navigator
Menu kontekstowe panelu Navigator, otwierane prawym przyciskiem myszy, zawiera następujące polecenia:
)
)
).


).
).
).

).
