Краткое руководство по началу работы с Power Analyzer от Keysight

Краткий обзор

В этом кратком руководстве описано, как Power Analyzer by Keysight помогает оценить сеть распределения питания постоянного тока на печатной плате непосредственно в Altium Designer. Вместо предположений вы сможете проверить, способны ли медные проводящие структуры, полигоны, дорожки и переходные отверстия обеспечить потребности вашего устройства в питании. Вы узнаете, как расширение интегрируется с текущим проектом, как его установить и запустить, какие исходные данные требуются для анализа и с чего начать настройку и моделирование цепей питания. Если вы хотите понять, как начать использовать Power Analyzer by Keysight в привычном рабочем процессе, читайте дальше: в статье приведены основные шаги, которые помогут приступить к работе и увереннее пользоваться инструментом.

- Узнайте, какие задачи решает Power Analyzer by Keysight в Altium Designer и как он помогает анализировать целостность питания постоянного тока на основе уже имеющихся данных проекта.
- Ознакомьтесь с основным рабочим процессом: установкой расширения, открытием документа анализатора и подготовкой настроек платы и цепей к моделированию.
- Изучите ключевые требования к подготовке, включая синхронизацию схемы и печатной платы, параметры конфигурации, требования к подписке и выбор цепей питания.
Узнайте больше с ИИ:

В современных цифровых устройствах с высокоскоростными цепями, высокой плотностью размещения компонентов на плате и несколькими низковольтными шинами питания требования к сети распределения питания постоянного тока обусловливают необходимость аналитического подхода к ее проектированию. Анализ сети распределения питания по постоянному току, или анализ целостности питания по постоянному току (PI-DC), позволяет убедиться, что на пути от источников напряжения к нагрузкам предусмотрено достаточно меди — иными словами, что полигоны, дорожки и переходные отверстия на плате имеют достаточные размеры (и характеристики) для обеспечения потребностей установленных на плате устройств в питании.

К счастью, при оценке сети распределения питания печатной платы можно обойтись без догадок, используя инструмент моделирования целостности питания по постоянному току (PI-DC), который анализирует характеристики платы по постоянному току на основе ее электрических и физических свойств. Такой инструмент доступен для Altium Designer — Power Analyzer by Keysight.

Power Analyzer поставляется в виде загружаемого расширения Altium и интегрируется непосредственно в Altium Designer, позволяя выполнять моделирование и анализ PI-DC для текущего проекта печатной платы. Поскольку Power Analyzer работает внутри Altium Designer, вам не потребуется вручную импортировать и экспортировать данные, преобразовывать их или запускать отдельные приложения — просто запустите Power Analyzer из редактора схем или печатных плат, задайте нужные параметры проверки и выполните моделирование. Результаты в основном представлены в виде 2D/3D-моделей медных структур печатной платы, что позволяет быстро оценить их и исследовать различные варианты топологии платы по принципу «что, если».

Доступ к функциям Power Analyzer by Keysight

Для доступа к функциям Power Analyzer by Keysight в Altium Designer необходимо установить программное расширение Power Analyzer by Keysight . Это расширение можно установить или удалить вручную.

Подробнее об управлении расширениями см. на странице Extending Your Installation (Altium Designer Develop, Altium Designer Agile, Altium Designer).

При нажатии кнопки загрузки и установки расширения открывается End-User License Agreement (). Нажимая Accept, вы подтверждаете свое согласие с условиями лицензионного соглашения (EULA), после чего установка продолжится. Нажатие Close означает, что вы не принимаете условия EULA, и процесс установки будет прекращен.

Установка программного расширения Power Analyzer by Keysight позволяет:

 
 
 
 
 
  • добавлять новый или открывать существующий документ анализа питания; 

  • Button, Manage Power Nets настраивать Power Analyzer и цепи питания; 

  • Button, Show Power Net in Tree изучать древовидную структуру цепей;

  • Button, Show the Power Net Analysis on the PCB просматривать существующие результаты анализа питания;

  • Button, View the Power Net Analysis results as a Report просматривать существующие отчеты и создавать новые на основе имеющихся результатов анализа питания.

Однако для выполнения нового анализа питания необходима действующая подписка на Power Analyzer by Keysight. В противном случае при попытке запустить анализ питания откроется диалоговое окно Analyze Your Power Nets, в котором можно запросить бесплатную пробную версию ().

Запуск Power Analyzer

Чтобы начать работу с Power Analyzer, откройте документ печатной платы проекта или одну из его схем и выберите Tools » Power Analyzer by Keysight в главном меню.

Откроется документ Power Analyzer Keysight (<ProjectName>.pdnaK), который будет добавлен в область Source Documents проекта (на панели Projects), как показано ниже.

Команда Power Analyzer by Keysight отсутствует в меню? Убедитесь, что расширение установлено и у вас есть подписка на него (подробнее).

Power Analyzer можно запустить из меню редактора схем или редактора печатных плат. Однако, поскольку Power Analyzer моделирует структуры печатной платы, любые изменения, внесенные в схему, необходимо перенести на плату путем синхронизации, прежде чем они смогут быть обнаружены в документе анализатора (*.pdnaK). Если изменение проекта не было обнаружено, сохраните, закройте и снова откройте документ анализатора.

Подготовка к анализу

Все готово к анализу, но при нажатии кнопки Analyze открывается диалоговое окно с предложением получить пробный доступ? Убедитесь, что расширение установлено и у вас есть подписка на него (подробнее).

Для работы Power Analyzer необходимы сведения о физических свойствах платы. К ним относятся максимальная плотность тока для наружных и внутренних слоев, минимальный и максимальный диаметры переходных отверстий, тип меди, рабочая температура и т. д. Эти свойства задаются в области Configuration документа анализатора.

Параметры конфигурации

  • Максимальная плотность тока и максимальный ток через переходное отверстие одинаковы для всех цепей, поскольку зависят от геометрии медных проводников.

  • Настройки Max Current Density for Surface / Internal Layers задают допустимое значение для соответствующих слоев печатной платы.

  • Максимальный ток через переходные отверстия задается для минимального и максимального диаметров отверстий, используемых в проекте. Значения диаметров отверстий задаются в полях Min Via Diameter и Max Via Diameter вместе с допустимым для соответствующего диаметра значением Max Current.

  • В процессе моделирования программа разбивает топологию печатной платы на сетку. По умолчанию используется динамический размер ячеек сетки. Установив флажок Simulation Mesh Size, можно задать требуемый размер ячеек.

  • По умолчанию цепь земли исключена из результатов тепловой карты. Чтобы включить цепь земли, снимите флажок Skip Ground, затем выберите цепь GND в раскрывающемся списке Network / Net в верхней части панели Power Analysis by Keysight для просмотра результатов тепловой карты. Обратите внимание: тепловая карта поддерживает полигональные структуры на сигнальных слоях, но моделирование поведения слоя питания невозможно.

  • Поле Copper Type задает тип используемой меди, связанные с ним параметры и температурные параметры. 

  • Параметр Work Temperature используется для определения удельного сопротивления проводников, а Temperature Compensation — это характеристика самого материала, связанная с его теплопроводностью. Разные материалы имеют разные коэффициенты теплопроводности и, соответственно, по-разному нагреваются в зависимости от нагрузки. Этот нагрев влияет на внутреннее сопротивление материала, что, в свою очередь, влияет на падение напряжения.

  • Значение Via Plating Thickness, отображаемое в области Global PCB Parameters, задается на панели Properties в редакторе Layer Stack Manager — подробнее.

При необходимости измените значения по умолчанию в соответствии с требованиями вашего проекта.

Помимо максимальной плотности тока и максимального тока через переходное отверстие, для каждой заданной цепи питания необходимо указать допустимое падение напряжения. Настройте DC Drop Limit для каждой цепи, выбрав предустановленное процентное значение или введя значение Custom.

Параметры Auto-Define Settings используются Power Analyzer при попытке автоматически определить цепи питания в проекте. Для этого анализатор должен уметь распознавать такие элементы схемы, как стабилизаторы напряжения, разъемы и последовательно включенные компоненты. Помимо использования таких признаков, как префиксы позиционных обозначений компонентов, можно добавлять параметры определенным компонентам, чтобы улучшить автоматическое распознавание. Дополнительные сведения см. в разделе Требования к автоматическому распознаванию.

Добавление цепи питания для моделирования

Чтобы добавить цепь питания для моделирования, нажмите кнопку  в левом верхнем углу, чтобы открыть диалоговое окно Manage Nets. Установите флажок для нужной Power Net Name и настройте соответствующий параметр Reference Net. Если на принципиальной схеме у цепи нет объекта порта питания, она не будет отображаться в списке Power Net Name. Нажмите Show Custom Nets, чтобы включить все цепи проекта. При необходимости можно выбрать несколько цепей питания. Иерархические связи между цепями питания определяются автоматически после завершения настройки цепи питания.

Для каждой цепи питания требуется источник питания. Их настройка описана далее.

Также можно нажать кнопку , чтобы программа создала цепи питания автоматически. Для этого она попытается распознать топологию проекта на основе текущих настроек в области Auto-Define Settings раздела Configuration документа анализатора (*.pdnaK).

Добавление источника питания

Чтобы добавить источник питания, нажмите + (или соответствующий элемент управления Управление) в разделе Sources нужной цепи питания. Если цепь содержит несколько источников питания, нажмите Управление и выберите остальные компоненты.

Чтобы компонент был доступен в качестве источника, он должен быть подключен к выбранной Power Net, при этом к выбранной Reference Net он может подключаться через любой компонент, соединенный с этой Reference Net.

Карточка компонента

Каждый компонент, включенный в качестве источника или нагрузки, представлен в документе Power Analyzer в виде Component Card.

Расширение цепи

Цепи питания на плате могут проходить через пассивные элементы, такие как предохранители или резисторы, причем по другую сторону компонента будет уже другая цепь. В этой ситуации рекомендуется extend the net, включив промежуточный компонент и его вторую цепь в состав основной цепи. Для этого используется функция Extend Nets.

Чтобы расширить цепь, нажмите значок +Extend Nets рядом с ее именем, чтобы открыть диалоговое окно <PowerNet> Extensions Manager. Нажмите +, чтобы расширить выбранную цепь. Power Analyzer отображает только те цепи, которые можно подключить через один компонент расширения. После того как вы выполните Add для цепи, соответствующий компонент будет автоматически добавлен в диалоговое окно <PowerNet> Extensions Manager; при необходимости его можно изменить.

Цепи питания можно расширять через последовательно включенный компонент.Цепи питания можно расширять через последовательно включенный компонент.

Затем можно продолжить расширение цепи, нажимая символ +, как показано на изображении ниже. По завершении нажмите Save в диалоговом окне <PowerNet> Extensions Manager.

Продолжайте добавлять последовательно включенные компоненты и цепи.Продолжайте добавлять последовательно включенные компоненты и цепи.

Примечания по расширению цепи

  • Для каждого последовательно включенного компонента можно задать падение напряжения, сопротивление и максимально допустимый ток — эти параметры будут учитываться при анализе (показать изображение).

  • Если вы указали неверную цепь, ее можно удалить, наведя указатель на ее имя и нажав появившийся значок удаления.

  • После сохранения расширенной цепи подключенные к ней компоненты появятся в списке нагрузок, и вы сможете их добавить.

  • Рядом с именем цепи питания отображается количество добавленных расширений. Наведите указатель на это число, чтобы отобразить имена цепей расширения (как показано на изображении выше).

  • Поддержка моделирования параллельно включенных компонентов в расширенной цепи была добавлена в версии V1.0.6 расширения PABK, а поддержка в пользовательском интерфейсе — в версии V1.0.9. Чтобы задать параллельно включенные компоненты, выберите цепь во всплывающем диалоговом окне Extensions Manager, затем включите все параллельно включенные компоненты, как показано на изображении ниже. Наведите указатель на изображение, чтобы увидеть диалоговое окно после завершения расширения цепи.

    Выберите все параллельно включенные компоненты в цепи.Выберите все параллельно включенные компоненты в цепи.

Задание нагрузки

Чтобы добавить компонент нагрузки, нажмите + (или соответствующий элемент управления Manage) в разделе Loads, а затем выберите нужный компонент. Компонент отображается в списке диалогового окна, если он подключен к основной или расширенной цепи.

После добавления компонента можно задать его потребление непосредственно в карточке компонента или нажать кнопку , чтобы открыть диалоговое окно <NetName>/<LoadName> Load Properties.

Примечания по настройке нагрузки

  • Задайте параметры нагрузки, включая Load Type, Total Load Current, а также Min и Max Voltage.
  • Убедитесь, что цепь питания IN и параметры Reference и Connected to reference through настроены правильно.
  • Ток нагрузки автоматически распределяется поровну между всеми выявленными выводами питания; при необходимости измените эти значения.
  • При настройке нагрузки типа IC (Current) отображаются все выводы компонента нагрузки, соединяющие его с источником через различные последовательно включенные компоненты, с возможностью выбора нужных выводов.

В открытом диалоговом окне Manage Loads (или Add Sources) имеется столбец Design Item Id. Нажмите запись в этом столбце, чтобы перейти к соответствующему компоненту на схеме с помощью перекрестного выделения. Это упрощает проверку правильности выбора компонента.

Масштаб при перекрестном выделении задается в разделе Highlight Methods на странице System - Navigation диалогового окна Preferences.

Задание VRM

Чтобы задать компонент модуля стабилизации напряжения (VRM), сначала добавьте его как нагрузку. Затем откройте диалоговое окно компонента Load Properties (нажмите кнопку ), чтобы настроить его.

После настройки нагрузки в качестве VRM она также будет отображаться как источник для цепи питания, указанной в качестве ее цепи OUT.После настройки нагрузки в качестве VRM она также будет отображаться как источник для цепи питания, указанной в качестве ее цепи OUT.

Примечания по настройке VRM

  • Укажите для Load Type VRM нужного типа.
  • Задайте выходное напряжение в поле Vout, а также остальные параметры стабилизатора.
  • Настройте цепи IN и OUT в области Nets Management диалогового окна.
  • Если VRM не подключен непосредственно к опорной цепи или использует другую опорную цепь, настройте параметры Reference и Connected to reference through соответствующим образом.
  • В иерархии автоматически создается дочерняя сеть питания, источником которой служит этот VRM (как показано выше).
  • Если у VRM несколько выходных цепей, добавьте все необходимые цепи с помощью ссылки +Add Out Net в диалоговом окне Load Properties и задайте их выходной ток в появившихся соответствующих полях.

Настроенная цепь питания

Каждая настроенная цепь питания представлена отдельным сворачиваемым блоком описания в документе *.pdnaK. Ниже показана настроенная цепь PWR_IN с двумя дочерними цепями питания, 3V3 и 1V8, которые отображаются с небольшим отступом, указывающим на их дочерний статус.

Структура описания цепи питания

  • Каждая цепь питания представлена отдельным сворачиваемым блоком Power Net Definition.
  • Заголовок блока описания цепи питания содержит:
    • Имя цепи питания 
    • Опорную цепь 
    • Индикатор количества дополнительных цепей (), если цепь была расширена. Наведите указатель, чтобы увидеть имена дочерних цепей.
    • Кнопку  : нажмите ее, чтобы отобразить структуру соединений компонентов этой цепи в контексте всей иерархии цепей питания.
    • Кнопку  : нажмите ее, чтобы исключить эту цепь и все дочерние цепи из анализа.
    • Кнопку  : нажмите ее, чтобы выполнить анализ этой цепи и всех дочерних цепей.
  • Каждый компонент цепи представлен карточкой компонента.
  • После анализа цепи результаты Voltage Drop, Current Density и Max Via Current для этой цепи отображаются в блоке описания цепи питания, как показано на изображении выше.
    • Каждый индикатор показывает смоделированное значение относительно заданного предела. Если значение находится в допустимых пределах, линия шкалы отображается зеленым цветом. Если оно близко к пределу, линия становится желтой, а при превышении предела — красной. 
    • Нажмите кнопку  , чтобы переключиться в редактор печатных плат и отобразить медные участки этой цепи на плате. В редакторе печатных плат используйте панель Power Analyzer by Keysight для управления процессом анализа.
    • Нажмите кнопку  , чтобы сформировать и открыть подробный отчет об этой цепи питания. В отчете используйте  кнопку, чтобы сохранить копию в формате HTML.

Древовидное представление цепей питания

Чтобы просмотреть настроенную цепь питания (и все дочерние цепи, определённые через VRM) в виде дерева, нажмите соответствующую  кнопку. Будет показана вся структура с выделением выбранной цепи питания и связанных с ней компонентов.

Древовидное представление позволяет быстро оценить, полностью ли определена сеть питания в соответствии с требованиями и готова ли она к анализу. Чтобы вернуться в главное окно, нажмите ссылку Power Analyzer by Keysight в левом верхнем углу документа .pdnaK.

Запуск анализа

Завершив настройку, можно запустить анализ отдельной цепи, нажав соответствующую  кнопку. Сводные результаты анализа отображаются в разделе определения цепи питания, как показано ниже. Чтобы просмотреть результаты на печатной плате, нажмите соответствующую  кнопку.

Чтобы проанализировать все настроенные цепи за один раз, нажмите  кнопку (в правом верхнем углу документа анализатора). Если выбрать для анализа цепь питания верхнего уровня в древовидной структуре, будут также проанализированы все дочерние цепи (созданные через компоненты VRM). Если все цепи уже проанализированы, выбрать выделяемую цепь можно в раскрывающемся списке Network/Net в верхней части панели Power Analyzer by Keysight. 

Управление слоями

Переключать слои при моделировании можно так же, как при работе с печатной платой, — с помощью вкладок слоёв в нижней части окна редактора печатных плат. Также можно сосредоточиться на текущем слое с помощью Shift+S — это сочетание клавиш позволяет последовательно переключать варианты видимости в режиме одного слоя.

Используйте вкладки слоёв печатной платы для быстрого переключения отображаемых результатов анализа. Здесь показаны результаты для верхнего слоя. Наведите курсор на изображение, чтобы увидеть результаты для нижнего слоя.Используйте вкладки слоёв печатной платы для быстрого переключения отображаемых результатов анализа. Здесь показаны результаты для верхнего слоя. Наведите курсор на изображение, чтобы увидеть результаты для нижнего слоя.

Панель Power Analyzer by Keysight

В редакторе печатных плат управление процессом и результатами анализа осуществляется через панель Power Analyzer by Keysight. Обратите внимание: панель добавляется в список доступных панелей (открываемый кнопкой Panels) после выполнения анализа питания и нажатия  кнопки.  

Сеть / цепь

  • Network / Net — позволяет выбрать сеть () или цепь (), которую нужно отобразить в виде тепловой карты в графической рабочей области.
  • Only nets with violations — если этот параметр включён (по умолчанию), в раскрывающемся списке доступны только цепи, в которых на данный момент есть нарушения. Отключите этот параметр, чтобы отобразить все цепи питания. 
  • Для изучения результатов моделирования используйте стандартные средства панорамирования и масштабирования рабочей области редактора печатных плат.

Под списком выбора Network / Net на панели находятся две вкладки: General и Heatmap. Параметры на этих вкладках применяются к цепи, выбранной в раскрывающемся списке Network / Net.

Выберите цепь для отображения, затем настройте для неё общие параметры или параметры тепловой карты.Выберите цепь для отображения, затем настройте для неё общие параметры или параметры тепловой карты.

Тепловая карта

Вкладка Heatmap панели Power Analyzer by Keysight позволяет выбрать данные для отображения в виде тепловой карты — плотность тока или падение напряжения, — а также настроить цветовое отображение этих величин.

Используйте вкладку Heatmap  панели Power Analyzer by Keysight, чтобы изменить результаты моделирования, отображаемые на печатной плате. Здесь показаны результаты расчёта плотности тока. Наведите курсор на изображение, чтобы увидеть результаты расчёта падения напряжения.Используйте вкладку Heatmap панели Power Analyzer by Keysight, чтобы изменить результаты моделирования, отображаемые на печатной плате. Здесь показаны результаты расчёта плотности тока. Наведите курсор на изображение, чтобы увидеть результаты расчёта падения напряжения.

Параметры каждого из этих режимов описаны ниже.

Тепловая карта плотности тока
  • Вся цепь окрашивается в соответствии с плотностью тока в каждой её точке: чем выше плотность тока, тем горячее (краснее) цвет. 
  • Show Heatmap — используйте этот элемент управления, чтобы быстро скрыть тепловую карту и восстановить стандартное отображение печатной платы. 
  • Show Arrows of Current Direction — включите этот параметр, чтобы отобразить небольшие стрелки, указывающие направление тока по всей цепи.
  • Use Noise Suppression — когда рассчитанный ток приближается к нулю, стрелки направления тока создают впечатление, что в этой области течёт ток, хотя фактически его практически нет. Включите этот параметр, чтобы исключить отображение таких малых значений тока, способных ввести в заблуждение.
  • Scope Controller — цветовое отображение интенсивности, или нагрева, цепи задаётся с помощью Scope Controller. Значение Max по умолчанию равно максимальной рассчитанной плотности тока в этой цепи (показать изображение), а значение Min по умолчанию равно 0 А/мм2. Эта шкала отображается в виде цветной полосы под печатной платой и отражает текущие минимальное и максимальное значения, градацию, определяемую выбранным типом шкалы, и единицы измерения. Значения Min и Max можно изменять, перетаскивая ползунок или вводя новое значение в поля Min и Max. Рассчитанные значения ниже Min отображаются синим цветом, а значения выше Max — красным. 
  • Use Logarithmic Scale — включите этот параметр, чтобы переключить шкалу с линейной на логарифмическую. На логарифмической шкале высокие значения сосредоточены ближе к концу цветовой шкалы hot. Например, можно включить логарифмическую шкалу, чтобы быстро найти участки трассировки с более высокими токами, а затем переключиться на линейную шкалу, чтобы изучить распределение плотности тока на этом участке трассировки.

Логарифмическая тепловая карта плотности тока показывает проблемную область. Наведите курсор на изображение, чтобы увидеть эту область с линейной шкалой.Логарифмическая тепловая карта плотности тока показывает проблемную область. Наведите курсор на изображение, чтобы увидеть эту область с линейной шкалой.

Тепловая карта падения напряжения
  • Вся цепь окрашивается в соответствии с падением напряжения в каждой её точке: чем выше напряжение, тем теплее (краснее) цвет. При таком подходе чем холоднее цвет, тем ниже напряжение (и тем больше падение напряжения). 
  • Show Heatmap - используйте этот элемент управления, чтобы быстро убрать тепловую карту и восстановить стандартное отображение печатной платы. 
  • Show Arrows of Current Direction - включите, чтобы отобразить небольшие стрелки, указывающие направление тока во всей цепи.
  • Use Noise Suppression - Когда расчётный ток приближается к нулю, стрелки направления тока создают впечатление, что в этой области протекает ток, хотя его практически нет. Включите этот параметр, чтобы исключить отображение таких малых значений тока, которые могут вводить в заблуждение.
  • Scope Controller - окраска цепи для отображения интенсивности, или «нагрева», задаётся с помощью Scope Controller. По умолчанию значение Max немного ниже заданного максимального напряжения для этой цепи, а значение Min равно Max - calculated voltage drop (показать изображение). Эта шкала отображается в виде цветной полосы под печатной платой и показывает падение напряжения в абсолютных значениях или процентах, текущие настройки минимума и максимума, а также единицы измерения. Значения Min и Max можно изменить, перетаскивая ползунки или вводя новое значение в поля Min или Max. Расчётные значения ниже Min отображаются синим цветом, а значения выше Max — красным. 
  • Scale Type - шкалу падения напряжения можно отображать в вольтах (нажмите кнопку  ) или в процентах (нажмите кнопку  ).
  • Enable Visual Slider for Voltage Contour - при включении отображает на тепловой карте места, где напряжение равно заданным значениям точек контура напряжения, что позволяет легко находить эти участки. Значения точек контура можно изменять, перетаскивая ползунки или вводя значения в поля Voltage Contour Points ниже. Дополнительные точки можно добавлять, а существующие — удалять, нажимая соответствующий значок.

Точки контура можно настроить так, чтобы быстро находить участки платы, где напряжение равно заданному значению.Точки контура можно настроить так, чтобы быстро находить участки платы, где напряжение равно заданному значению.

Обнаружение нарушений

Если при моделировании обнаружены нарушения Voltage Drop, Current Density или Max Via Current, они перечисляются в разделе Violations панели Power Analyzer by Keysight. Нажмите на нарушение в панели, чтобы перейти к соответствующему месту на печатной плате, где возникла ошибка. Если описание нарушения отображается не полностью, наведите указатель на область описания нарушения, чтобы открыть всплывающую подсказку со всеми подробностями.

Подробные сведения о нарушениях автоматически отображаются в разделе Violations панели Power Analyzer by Keysight. Наведите указатель на изображение, чтобы увидеть нарушение допустимого тока переходного отверстия.Подробные сведения о нарушениях автоматически отображаются в разделе Violations панели Power Analyzer by Keysight. Наведите указатель на изображение, чтобы увидеть нарушение допустимого тока переходного отверстия.

Обратите внимание: режим тепловой карты (плотность тока или падение напряжения) выбирается автоматически в зависимости от типа нарушения, на которое вы нажали. 

Зонды

Раздел зондов панели Power Analyzer by Keysight используется для размещения измерительных зондов непосредственно на печатной плате. Зонды могут измерять плотность тока или падение напряжения; тип измерения определяется текущим режимом тепловой карты платы.

Зонды бывают двух типов:

  1. Одиночный зонд — для измерения абсолютного значения в точке установки зонда, или
  2. Дифференциальный зонд — для измерения разности значений в двух точках установки зондов. 

Оба типа зондов размещаются нажатием кнопки  в области Probes панели. Чтобы разместить одиночный зонд, щёлкните в нужном месте, затем щёлкните правой кнопкой мыши (или нажмите Esc). Чтобы разместить дифференциальный зонд, щёлкните один раз для задания первой точки, затем второй раз для задания второй точки. После размещения зонда результаты измерения отобразятся в панели.

При размещении зонда действуют те же функции привязки, что и при размещении других объектов проекта в редакторе печатных плат. Подробнее о единой системе привязки курсора см. на странице Работа с системой привязки курсора.

Нажмите кнопку  , чтобы создать изображение печатной платы в месте расположения зонда, на который вы нажали последним. Изображение появится в области Image Captures панели с меткой Probe. Наведите указатель на снимок экрана, чтобы отобразить сведения о зонде (показать изображение). 

Зонды могут измерять напряжение или ток как в абсолютных значениях, так и в виде разности значений в двух точках. Наведите указатель на изображение, чтобы увидеть токовый зонд.Зонды могут измерять напряжение или ток как в абсолютных значениях, так и в виде разности значений в двух точках. Наведите указатель на изображение, чтобы увидеть токовый зонд.

При любом изменении проекта необходимо удалить существующие зонды () и разместить новые.

Снимки экрана

Функция создания снимков экрана в панели Power Analyzer by Keysight позволяет получить снимок выбранной цепи в проекте, который затем можно включить в отчёт.

Чтобы сделать снимок определённого участка платы, сначала настройте вид платы в основной рабочей области так, чтобы были видны все элементы, которые нужно включить в снимок. Затем нажмите кнопку   в области Image Captures панели, чтобы создать снимок экрана. Вы можете продолжать изменять вид платы и Add дополнительные изображения. Чтобы удалить изображение, наведите на него указатель — появится кнопка  ; нажмите её один раз для удаления.

Снимки экрана не сохраняются вместе с проектом. Чтобы сохранить изображения, сформируйте отчёт об анализе.

Отчёт об анализе

Чтобы сформировать полный отчёт об анализе, нажмите кнопку  в верхней части документа анализатора. Полный отчёт содержит раздел для каждой цепи питания в сети, как показано на изображении ниже. 

В отчёте нажмите на цепь питания, чтобы просмотреть подробный отчёт по ней, включающий:

  • Общие настройки конфигурации
  • Стек слоёв платы
  • Тепловые карты плотности тока для каждого сигнального слоя
  • Тепловые карты падения напряжения для каждого сигнального слоя
  • Дерево сети питания с выделенной выбранной цепью.
  • Подробные результаты анализа выбранной цепи, включая: потребляемую мощность; сведения о запасах и результатах проверки «пройдено/не пройдено»; подробную сводку характеристик всех переходных отверстий в этой цепи; все созданные пользователем снимки экрана.

  • Нажмите кнопку  , чтобы сохранить отчёт в формате HTML. В открывшемся диалоговом окне Save Report Settings укажите, какие сети и какие именно данные следует включить в отчёт.
  • Отчёт сохраняется в подпапке папки проекта с именем \PowerAnalyzerByKeysight_Output\HTMLReport\<ProjectName> [PDNA]_<CurrentDate>_<CurrentTime>.
  • Все изображения отчёта сохраняются в подпапке \Images.
  • В процессе анализа также создаётся несколько файлов журналов; они сохраняются в подпапке папки проекта с именем \PowerAnalyzerByKeysight_Output\<BoardName>\.

Требования для автоматического распознавания

Помимо добавления цепей питания вручную, Power Analyzer by Keysight позволяет автоматически распознавать и добавлять цепи питания, включая источники и нагрузки, сокращая время на определение структуры системы питания.

Настройки автоматического определения

Перед запуском автоматического распознавания необходимо настроить параметры алгоритма в соответствии с вашим проектом. Эти параметры задаются в области Auto-Define Settings раздела Configuration окна документа Power Analyzer by Keysight.

Компоненты, которые не соответствуют этим критериям автоматического определения, рассматриваются как обычные нагрузки. Также можно добавлять именованные параметры отдельным компонентам схемы, определяя тип и свойства компонента в системе питания. Эти параметры можно задать при создании компонента или добавить позже на схеме.

Параметры компонентов

Для корректного распознавания все компоненты, относящиеся к системе питания, должны соответствовать следующим критериям:

  • Для автоматического обнаружения компонента-источника у него должен быть параметр с именем Component Type и значением Source.

  • Если параметр не найден, поиск будет выполняться на основе Default Connectors Designators, заданных в области Auto-Define Settings раздела Configuration документа анализатора (*.pdnaK). Обратите внимание: будут определены только разъёмы с подключениями питания, если только они не указаны как часть расширенной цепи.
  • Модули регулирования напряжения (VRM):
    • Линейные стабилизаторы должны иметь параметр с именем Component Type и значением VRM.
    • Для импульсного стабилизатора VRM типа SMPS параметр Component Type должен иметь значение SMPS.
    • Если VRM поддерживает функцию Sense, параметр Component Type должен иметь значение Sense.

  • Если параметр не задан, поиск будет выполняться на основе VRM Keywords, заданных в области Auto-Define Settings раздела Configuration документа анализатора. По умолчанию используются следующие ключевые слова: PWR, REG, Regulator, Voltage, Switch.

  • Потребляемый компонентом (нагрузкой) ток должен быть задан параметром с именем Current Consumption. Обратите внимание на десятичный разделитель в значении: в зависимости от системных настроек это может быть точка или запятая.

Если у компонента есть параметр Current Consumption, указанное значение распределяется между всеми выводами, подключёнными к одной цепи.

Синхронизация параметров

Все параметры должны быть синхронизированы между платой и схемой. Чтобы проверить это, выберите компонент на плате и убедитесь, что параметры анализа питания присутствуют на вкладке Parameters панели Properties.

Требования к проекту

  • Все цепи питания должны быть определены одним из следующих способов:
    • с помощью объекта Power Port,
    • путём настройки свойства Power Net так, чтобы цепь включала Supply Net Parameter (как описано ниже),
    • либо с помощью имени, распознаваемого по Name Mask (заданным в области Auto-Define Settings раздела Configuration документа анализатора).
  • Чтобы получить значение напряжения с помощью Name Mask, имя цепи питания должно соответствовать формату *V* или *.*V, где * — числовое значение, как показано на изображении ниже.

  • Другой способ задать значение напряжения для цепи питания — настроить свойство Power Net на панели Properties для любого проводника этой цепи. Чтобы сделать свойство доступным, сначала разместите на цепи директиву Parameter Set (Place » Directives » Parameter Set) (наведите курсор на изображение ниже, чтобы увидеть, как это делается). Размер, цвет и метку задаёт пользователь; именно наличие директивы делает доступным свойство Power Net этой цепи. После добавления директивы выберите проводник в этой цепи, включите свойство Power Net и настройте Voltage цепи, как показано ниже. 

  • Последовательно включённые компоненты должны соответствовать заданным позиционным обозначениям резисторов, дросселей и пользовательских последовательных компонентов (заданным в области Auto-Define Settings раздела Configuration документа анализатора).

  • VRM должны быть подключены как минимум к двум цепям питания.

Команды Power Analyzer

В главном меню редактора Power Analyzer доступны следующие команды.

Команда

Описание и использование

Tools » Define Automatically

Выполняет попытку автоматически распознать топологию проекта на основе текущих настроек в области Auto-Define Settings раздела Configuration документа анализатора (*.pdnaK). Эту команду также можно вызвать, нажав кнопку Define Automatically в левом верхнем углу редактора.

File » Load from File

Загрузить сохранённый документ Power Analyzer by Keysight (*.pdnaK) в редактор Power Analyzer.

Edit » Manage Nets

Открыть диалоговое окно Manage Nets для выбора цепей питания, которые требуется проанализировать. Установка флажка для цепи добавляет её в документ анализатора (*.pdnaK). Снятие флажка удаляет цепь (вместе со всеми дочерними цепями питания) из документа. Эту команду также можно вызвать, нажав кнопку Manage Nets в левом верхнем углу редактора. Подробнее см. Управление цепями.

File » Save

Сохранить текущую конфигурацию Power Analyzer в документ Power Analyzer by Keysight (*.pdnaK)

File » Save As

Сохранить текущую конфигурацию Power Analyzer в документ Power Analyzer by Keysight (*.pdnaK) с новым именем, заданным пользователем.

Tools » Measurement Units » mil

Настроить Power Analyzer на использование имперских единиц измерения (мил).

Tools » Measurement Units » mm

Настроить Power Analyzer на использование метрических единиц измерения (мм).

Ограничения Power Analyzer

В настоящее время Power Analyzer by Keysight не поддерживает:

  1. Отрицательные напряжения.
  2. Встроенные компоненты (компоненты, размещённые на внутреннем слое). Подробнее см. Проектирование печатных плат со встроенными компонентами.

 

AI-LocalizedЛокализовано с помощью ИИ
Если вы обнаружили проблему, выделите текст/изображение и нажмитеCtrl + Enter, чтобы отправить нам свой отзыв.
Меню
Contents
Доступность функций

Доступные вам функции зависят от того, какое решение Altium вы используете: Altium Develop, Altium Agile Teams, Altium Agile Enterprise или Altium Designer (при активной подписке).

Если вы не видите описанную функцию в используемом вами программном обеспечении, свяжитесь с отделом продаж Altium, чтобы узнать больше.

Устаревшая документация

Документация Altium Designer больше не разделена по версиям ПО. Если вам необходим доступ к документации по старым версиям Altium Designer, посетите раздел Устаревшая документация на странице Прочие установщики.

Contents