Настройка документа Draftsman
Altium Essentials: Draftsman
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
Краткий обзор
- Узнайте, как создать новый документ Draftsman, выбрать шаблон и указать нужный проект и исходную печатную плату.
- Разберитесь, как Draftsman сохраняет связь с данными печатной платы и как обновлять документ при изменении проекта платы.
- Ознакомьтесь с основными настройками и параметрами документа, которые определяют его внешний вид и поведение.
Draftsman создает и сохраняет файлы чертежей печатных плат в специальном формате (*.PCBDwf).
Создание нового документа Draftsman
Чтобы создать новый документ Draftsman, используйте команду File » New » Draftsman Document в главном меню или щелкните правой кнопкой мыши запись нужного проекта на панели Projects, а затем выберите команду Add New to Project » Draftsman Document в контекстном меню. В открывшемся диалоговом окне New Document можно выбрать готовый шаблон документа или вариант [Default], который создает пустой документ формата A4.

Создание пустого документа Draftsman или документа на основе шаблона для указанного проекта и печатной платы.
Для шаблонов из рабочего пространства (перечисленных под записью подключенного рабочего пространства в формате <TemplateName> (v.<Revision>)) используется последняя ревизия каждого доступного шаблона. Нажмите кнопку
, чтобы перейти на страницу Управление данными — Шаблоны диалогового окна Preferences.
Помимо нужного шаблона документа, можно выбрать конкретный Project (если в Altium Designer открыто несколько проектов) и исходный Document печатной платы, входящий в выбранный проект. Новый документ будет добавлен в указанный проект и будет получать из него данные; этот проект станет активным.
Флажки Layers в диалоговом окне определяют, какие слои платы (Signal/Plane, Mask, Paste и/или Silk, заданные в стеке слоев) используются для формирования производственных чертежей в документе при использовании шаблона производственной документации. Производственные чертежи создаются по одному на лист, если для параметра Layer соответствующего вида изготовления платы в выбранном шаблоне установлено значение All (for document template).
Синхронизация Draftsman с печатной платой
Draftsman извлекает данные проекта непосредственно из медных слоев, слоев компонентов и механических слоев печатной платы. Если данные платы изменились, их можно обновить в Draftsman, щелкнув правой кнопкой мыши в любом месте документа и выбрав Import Changes From <PCBDocumentName>.PcbDoc в контекстном меню либо выбрав команду Tools » Import Changes From <PCBDocumentName>.PcbDoc в главном меню.
Общие параметры документа
Настройки всего документа Draftsman (который может состоять из нескольких листов/страниц — подробнее) задаются на вкладке General панели Properties, когда в рабочей области не выбран ни один объект. Эти настройки определяют исходные данные проекта для документа, графическое оформление, поведение чертежных объектов и используемые единицы измерения. Изменения этих настроек переопределяют значения свойств по умолчанию, заданные примененным шаблоном документа.
| Grid Size, Show Grid |
Используйте эти параметры для настройки сетки документа. Подробнее см. в разделе Настройка сетки и параметров привязки. |
| Snapping, Snapping Distance |
Используйте эти параметры для настройки функции привязки. Подробнее см. в разделе Настройка сетки и параметров привязки. |
| Document Font | Задайте базовый стиль шрифта и дополнительные атрибуты, используемые на листах документа. Это определяет шрифт уровня документа, применяемый к чертежным объектам, например к заголовку сборочного вида платы. Для отдельных объектов шрифт уровня документа можно переопределить на панели Properties этих объектов. |
| Sheet Border | Задайте цвет линий и символов зонной рамки для листов документа. |
| Sheet Color | Задайте цвет фона листов документа. |
| Variants Display, Pattern, Not Fitted Text, Not Fitted Font, Font Size (Min/Max) |
Используйте эти параметры, чтобы настроить отображение на сборочных видах платы компонентов, помеченных как неустанавливаемые для выбранного варианта проекта. Подробнее см. на странице Сборочный вид платы. |
| PCB Document | Задайте проект платы, используемый в качестве источника данных для документа Draftsman. В раскрывающемся меню выберите один из доступных документов печатной платы текущего проекта. |
| Variants | В раскрывающемся меню выберите вариант исполнения платы, который будет использоваться в качестве источника данных для документа Draftsman. Подробнее см. в разделе Поддержка вариантов проекта. |
| Scale | Задайте размер вновь размещаемых в текущем документе видов всей платы (таких как сборочный вид платы, вид изготовления платы или вид сверловки). Подробнее об управлении масштабом размещенного вида см. на странице Работа с видами. |
| Dash Pattern | Определения длин штрихов и промежутков для вариантов штриховых линий в единицах по 0,02 мм (в метрическом режиме). Например, значение шаблона 20,10,20 задает повторяющуюся последовательность штрихов длиной 0,4 мм, 0,2 мм и 0,4 мм с длиной цикла 1 мм (50 единиц). Пользовательский вариант штриховой линии можно создать с помощью кнопки |
| Line Thicknesses | Толщина доступных вариантов стилей линий. Используйте кнопку |
| Units | Задайте тип основных единиц измерения документа. |
| Dual Units | Задайте тип дополнительных (дублирующих) единиц измерения документа. Отображение дополнительных единиц измерения можно включить для чертежного объекта на его панели Properties. |
| Decimal Separator | В раскрывающемся меню выберите символ, используемый в качестве десятичного разделителя. |
| Remove Leading Zero | Включите этот параметр, чтобы автоматически удалять начальный ноль в значениях меньше «1». Например, при включенном параметре «0.5» будет отображаться как «.5». Dimensioning and Tolerancing, ASME Y14.5, указывает, что при использовании дюймов для значений меньше 1 начальные нули следует опускать. |
| Primary Units |
|
| Dual Units |
|
Параметры документа Draftsman
На вкладке Parameters панели Properties, когда в рабочей области не выбран ни один объект, отображается таблица параметров, доступных в текущем документе. В список входят параметры проекта (включая вариант), системные параметры, параметры печатной платы и все добавленные пользовательские параметры.
Используйте кнопки
и
для создания и удаления собственных пользовательских параметров.
Используйте флажки в нижней части списка, чтобы выбрать, какие группы параметров отображать:
(проект),
(система),
(печатная плата). Параметры проекта, системы и печатной платы доступны только для чтения, а добавленные пользовательские параметры можно редактировать, и они всегда отображаются в списке.
Ниже приведены предопределенные системные параметры и параметры печатной платы.
Системные параметры
Application_BuildNumber |
Версия и номер сборки установленного экземпляра Altium Designer. |
BOMPageNumber |
Используется в поле Title свойств таблицы спецификации для отображения номера текущей страницы таблицы спецификации. |
BOMTotalPages |
Используется в поле Title свойств таблицы спецификации для отображения общего количества страниц таблицы спецификации. |
ComponentName |
Используется в поле Title свойств вида компонента для отображения комментария компонента, для которого создан вид. |
CurrentDate |
Текущая дата, автоматически определяемая на основе настроек системы. |
CurrentTime |
Текущее время, автоматически определяемое на основе настроек системы. |
DocumentFullPathAndName |
Полный путь и имя файла документа Draftsman. Пример: C:\MyTestDesign\Kame_FMU_asm_rm.PCBDwf. |
DocumentName |
Только имя файла документа Draftsman (без пути к файлу). Пример: Kame_FMU_asm_rm.PCBDwf. |
DocumentScale |
Масштаб, выбранный для документа Draftsman. |
DocumentUnits |
Единицы измерения, выбранные для документа Draftsman. |
FootprintName |
Используется в поле Title свойств вида компонента для отображения имени посадочного места компонента, для которого создан вид. |
HoleName |
Используется в поле Title свойств вида отверстия с зенковкой или цековкой для отображения имени контактной площадки (с учетом ее обозначения, положения на печатной плате и слоя), для которой создан вид. |
ModifiedDate |
Дата изменения файла документа Draftsman; заполняется автоматически. |
ProjectName |
Фактическое имя родительского проекта документа Draftsman (включая расширение). Пример: Sample - Kame_FMU.PrjPcb. |
Revision |
Отображает значение, заданное для параметра уровня документа по умолчанию Revision. |
SheetNumber |
При размещении в виде специальной строки отображает номер текущего листа документа Draftsman. |
SheetNumber_OneSheet |
При размещении в виде специальной строки отображает номер текущего листа документа Draftsman. Если документ Draftsman содержит только один лист, значение не отображается. |
SheetTotal |
Общее количество листов документа Draftsman. |
VersionControl_PCBDocumentRevNumber |
Номер текущей ревизии исходной печатной платы документа Draftsman. Чтобы эта строка содержала какие-либо сведения, необходимо использовать систему контроля версий. |
VersionControl_PCBDocumentRevNumberShort |
Сокращенный хеш Git (первые восемь символов) и статус в системе контроля версий для текущей ревизии исходной печатной платы документа Draftsman. Чтобы эта строка содержала какие-либо сведения, необходимо использовать систему контроля версий. |
VersionControl_PrjFolderRevNumber |
Номер текущей ревизии проекта, который увеличивается при каждой полной фиксации проекта (т. е. включая файл проекта). Чтобы эта строка содержала какие-либо сведения, необходимо использовать систему контроля версий. |
VersionControl_PrjFolderRevNumberShort |
Сокращенный хеш Git (первые восемь символов) и статус проекта в системе контроля версий. Чтобы эта строка содержала какие-либо сведения, необходимо использовать систему контроля версий. |
VersionControl_RevNumber |
Номер текущей ревизии документа Draftsman. Чтобы эта строка содержала какие-либо сведения, необходимо использовать систему контроля версий. |
VersionControl_RevNumberShort |
Сокращенный хеш Git (первые восемь символов) и статус в системе контроля версий для текущей ревизии документа Draftsman. Чтобы эта строка содержала какие-либо сведения, необходимо использовать систему контроля версий. |
ViewLabel |
Используется в поле Title свойств вида сечения платы или выносного вида платы для отображения Label, примененного к виду. |
ViewLayerName |
Используется в поле Title свойств технологического вида платы для отображения Layer, для которого создан вид. |
ViewScale |
Используется в поле Title свойств вида для отображения выбранного для этого вида Scale. |
ViewSide |
Используется в поле Title свойств сборочного вида платы, технологического вида платы, вида компонента или изометрического вида платы для отображения View Side / Face side, для которого создан вид. |
ViewVariantName |
Используется в поле Title свойств сборочного вида платы или изометрического вида платы для отображения Variation, для которого создан вид. |
Параметры печатной платы
Arc_Count |
Количество объектов-дуг на исходной печатной плате документа Draftsman. |
BoardArea |
Площадь исходной печатной платы документа Draftsman, выраженная в основных единицах измерения, выбранных для документа Draftsman. |
BoardDensity |
Плотность исходной печатной платы документа Draftsman. |
BoardHeight |
Высота исходной печатной платы документа Draftsman, выраженная в основных единицах измерения, выбранных для документа Draftsman. |
BoardWidth |
Ширина исходной печатной платы документа Draftsman, выраженная в основных единицах измерения, выбранных для документа Draftsman. |
BlindVia_Count |
Количество глухих переходных отверстий на исходной печатной плате документа Draftsman. |
BuriedVia_Count |
Количество скрытых переходных отверстий на исходной печатной плате документа Draftsman. |
Component_Count |
Количество объектов-компонентов на исходной печатной плате документа Draftsman. |
ComponentMixed_Count |
Количество компонентов со смешанными контактными площадками (как для поверхностного монтажа, так и для монтажа в отверстия) на исходной печатной плате документа Draftsman. |
ComponentsArea |
Площадь компонентов исходной печатной платы документа Draftsman, выраженная в основных единицах измерения, выбранных для документа Draftsman. |
ComponentSMD_Count |
Количество компонентов с контактными площадками для поверхностного монтажа на исходной печатной плате документа Draftsman. |
ComponentThru_Count |
Количество компонентов с контактными площадками для монтажа в отверстия на исходной печатной плате документа Draftsman. |
ComputerName |
Системное имя компьютера, на котором был создан документ Draftsman. |
CopperInner_Weight_Max |
Максимальная масса меди на внутренних слоях. |
CopperOuter_Weight_Max |
Максимальная масса меди на внешних слоях. |
Fill_Count |
Количество объектов-заливок на исходной печатной плате документа Draftsman. |
Hole_Count |
Количество отверстий контактных площадок и переходных отверстий на исходной печатной плате документа Draftsman. |
Hole_Size_Min |
Минимальный диаметр отверстия на исходной печатной плате документа Draftsman, выраженный в основных единицах измерения, выбранных для документа Draftsman. |
Hole_Size_Num |
Количество уникальных диаметров отверстий на исходной печатной плате документа Draftsman. |
Item |
Имя последнего элемента проекта печатной платы, в который были выпущены исходные данные проекта с помощью Project Releaser. Пример: SRC-Sample - Kame_FMU. |
ItemRevision |
Ревизия последнего элемента проекта печатной платы, в который были выпущены исходные данные проекта с помощью Project Releaser. Пример: 01.A.1. |
ItemRevisionBase |
Базовый уровень ревизии последнего элемента проекта печатной платы, в который были выпущены исходные данные проекта с помощью Project Releaser. Пример: 1. |
ItemRevisionLevel1 |
Уровень 1 ревизии последнего элемента проекта печатной платы, в который были выпущены исходные данные проекта с помощью Project Releaser. Пример: A. |
ItemRevisionLevel2 |
Уровень 2 ревизии последнего элемента проекта печатной платы, в который были выпущены исходные данные проекта с помощью Project Releaser. Пример: 01. |
Layer_Count |
Количество медных слоев на исходной печатной плате документа Draftsman. |
MicroVia_Count |
Количество микропереходных отверстий на исходной печатной плате документа Draftsman. |
Net_Count |
Количество цепей на исходной печатной плате документа Draftsman. |
Pad_Count |
Количество объектов-контактных площадок на исходной печатной плате документа Draftsman. |
Pcb_File_Name |
Полный путь и имя файла исходной печатной платы документа Draftsman. Пример: C:\MyTestDesign\Kame_FMU.PcbDoc. |
Pcb_File_Name_No_Path |
Только имя файла исходной печатной платы документа Draftsman (без пути к файлу). Пример: Kame_FMU.PcbDoc. |
PCBConfigurationName |
Имя набора данных, из которого были сформированы выходные данные, как указано в представлении Release (Project Releaser). |
PadSMD_Count |
Количество контактных площадок для поверхностного монтажа на исходной печатной плате документа Draftsman. |
PadThru_Count |
Количество контактных площадок для монтажа в отверстия на исходной печатной плате документа Draftsman. |
Poly_Count |
Количество объектов полигональной заливки на исходной печатной плате документа Draftsman. |
SlotHole_Count |
Количество объектов-контактных площадок с пазовыми отверстиями на исходной печатной плате документа Draftsman. |
SolderMask_Bottom |
Наличие нижней паяльной маски. Если слой нижней паяльной маски отсутствует, параметр будет иметь значение No mask. Если слой нижней паяльной маски есть, но его цвет не задан, параметр будет иметь значение No color. Если слой нижней паяльной маски есть и его цвет задан, параметр будет отображать цвет: его название (Green, Black, Blue, Red и т. д.) или код RGBA (например, #FF0065FF). |
SolderMask_Top |
Наличие верхней паяльной маски. Если слой верхней паяльной маски отсутствует, параметр будет иметь значение No mask. Если слой верхней паяльной маски есть, но его цвет не задан, параметр будет иметь значение No color. Если слой верхней паяльной маски есть и его цвет задан, параметр будет отображать цвет: его название (Green, Black, Blue, Red и т. д.) или код RGBA (например, #FF0065FF). |
SquareHole_Count |
Количество объектов-контактных площадок с прямоугольными отверстиями на исходной печатной плате документа Draftsman. |
StackedVia_Count |
Количество переходных отверстий, расположенных друг над другом, на исходной печатной плате документа Draftsman. |
String_Count |
Количество текстовых объектов на исходной печатной плате документа Draftsman. |
Thru_Via_Count |
Количество сквозных переходных отверстий на исходной печатной плате документа Draftsman. |
Total_Thickness |
Общая толщина исходной печатной платы документа Draftsman. |
Track_Count |
Количество объектов-дорожек на исходной печатной плате документа Draftsman. |
VariantName |
Имя варианта проекта, выбранного для документа Draftsman. |
Via_Count |
Количество объектов-переходных отверстий на исходной печатной плате документа Draftsman. |
Настройка сетки и параметров привязки
Перед размещением объектов в документе Draftsman задайте сетки и настройте параметры привязки, чтобы упростить размещение. Параметры сетки и привязки настраиваются в области General на вкладке General панели Properties, когда в рабочей области не выбран ни один объект.
В рабочей области линии сетки отображаются пунктиром, а каждая десятая линия — сплошной линией. Задайте расстояние между линиями сетки в поле Grid Size панели Properties, когда в документе не выбран ни один объект. Также значение шага сетки можно задать в диалоговом окне Snap Grid (1..1000) , которое открывается при выборе команды View » Set Grid Size в главном меню (сочетание клавиш: G).
Используйте параметр Show Grid для управления отображением линий сетки на листах документа. Используйте соответствующую кнопку выбора цвета, чтобы задать цвет сетки в рабочей области.
Привязка помогает размещать и перемещать объекты на листах документа Draftsman. Эта функция притягивает примитив к точкам или направляющим, сформированным существующими объектами или заданной для документа сеткой. Это позволяет быстро и легко выравнивать различные элементы на страницах документа. Привязку можно включить или отключить с помощью параметра Snapping на панели Properties или команды View » Toggle Snapping в главном меню (сочетание клавиш: Shift+E).
Если привязка включена, ее можно дополнительно настроить, по отдельности включая или отключая приведенные ниже параметры.
| Snap to Grid | Если этот параметр включен, в режиме размещения объектов курсор предварительного просмотра будет привязываться (скачкообразно перемещаться) к пересечениям линий сетки. Обратите внимание: привязка к сетке не работает, если сетка не отображается (то есть если параметр Show_Grid отключен). |
| Snap to Vertices | Если этот параметр включен, в режиме размещения объектов курсор предварительного просмотра будет привязываться к углу (вершине) объекта. Когда курсор привязывается к вершине, она выделяется оранжевой точкой. |
| Snap to Boundaries | Если этот параметр включен, в режиме размещения объектов курсор предварительного просмотра будет привязываться к линии контура объекта (или к продолжению этой грани). Продолжения линий контура объекта отображаются тонкой штриховой линией. |
| Snap to Line centers | Если этот параметр включен, в режиме размещения объектов курсор предварительного просмотра будет привязываться к середине линии контура объекта. Когда курсор привязывается к середине линии, она выделяется оранжевой точкой. |
| Snap to Circle centers | Если этот параметр включен, в режиме размещения объектов курсор предварительного просмотра будет привязываться к центру окружности. Когда курсор привязывается к центру окружности, он выделяется оранжевой точкой. |
| Snap to component references | Если этот параметр включен, курсор предварительного просмотра будет привязываться к опорным точкам компонентов. |
| Snap to Visible primitives | Если этот параметр включен, курсор предварительного просмотра будет привязываться (в соответствии с другими параметрами привязки) к примитивам объектов, видимым в текущем представлении листа. Если параметр отключен, курсор будет привязываться ко всем объектам на листе. ![]() |
Используйте параметр Snapping Distance, чтобы задать расстояние, на котором курсор предварительного просмотра будет привязываться к элементам, указанным в качестве целей привязки. Также можно выбрать в раскрывающемся списке значение относительно текущей сетки (например, 0.5x Snap Grid).
Настройка листов (страниц) документа
Документы Draftsman имеют многостраничный формат, позволяющий включать отдельные страницы (листы), предназначенные для определенных видов производственной информации проекта платы.
Добавлять листы в текущий документ и удалять их из него можно с помощью команд Add New Sheet и Remove Sheet главного меню Tools или контекстного меню рабочей области. Новый лист вставляется после листа, на котором находится курсор в момент выполнения команды, и оформляется в соответствии с шаблоном листа Draftsman, примененным к непосредственно предшествующему листу.
Параметры отдельных страниц (листов) документа Draftsman можно задать на вкладке Page Options панели Properties, когда в рабочей области не выбран ни один объект. Эти параметры определяют базовую структуру страницы (размер, поля и т. д.).
Изменения параметров страницы можно применить к текущей странице или ко всем страницам документа. Нажмите кнопку
в верхней части панели Properties, чтобы применить измененные параметры к текущему листу, или кнопку
, чтобы применить изменения ко всем листам документа. Номер текущей страницы отображается в раскрывающемся списке Current Page, в котором также можно выбрать страницу.
В разделе Formatting and Size панели можно выбрать способ задания формата страницы.
| Template | Задайте размер и формат страницы, выбрав один из доступных шаблонов листов Draftsman. Для шаблонов Workspace (перечисленных под именем подключенного Workspace в формате |
| Standard | Задайте размер листа, выбрав стандартный формат страницы. Используйте раскрывающийся список Sheet Size для выбора стандартных размеров страницы. |
| Custom | Задайте произвольные размеры листа в полях Width и Height. Обратите внимание: максимальное значение ширины или высоты, которое можно ввести, составляет 20000 мм. |
Параметры в разделе Margin and Zones панели определяют размеры рамки листа и ее деление на зоны.
| Show Zones | Включите этот параметр, чтобы отображать деление рамки на зоны. |
| Vertical | Задайте количество делений (строк) на вертикальном поле листа. Тип буквенно-цифровых обозначений зон определяется параметрами Origin и Letter Position в этом разделе панели. |
| Horizontal | Задайте количество делений (столбцов) на горизонтальном поле листа. Тип буквенно-цифровых обозначений зон определяется параметрами Origin и Letter Position в этом разделе панели. |
| Margin | Задайте расстояние от края страницы до каждой из четырех линий рамки. |
| Origin | Укажите, с какого угла листов документа будут начинаться буквенно-цифровые обозначения зон по периметру (позиция зоны A-1 или 1-A). |
| Letter Position | Задайте расположение буквенных обозначений зон на листах документа: в горизонтальных зонах по периметру (столбцах) или в вертикальных зонах (строках). Установите флажок Iterate Columns Across Sheets, чтобы буквенно-цифровые обозначения столбцов последовательно увеличивались на всех листах документа, а не начинались с A или 1 на каждом листе. |
Навигация по документу Draftsman с помощью панели Bookmarks
Панель Bookmarks обеспечивает удобную навигацию по многостраничным документам Draftsman и управление ими. На панели отображается раскрываемое дерево всей структуры документа, аналогичное дереву на панели Projects, которое включает все листы документа и основные объекты видов на этих листах.

Используйте панель Bookmarks для перехода между видами в многостраничном документе Draftsman.
На панели Bookmarks отображается структурированное дерево листов и объектов документа Draftsman, в котором запись каждого листа можно развернуть или свернуть. Draftsman автоматически присваивает имена записям листов в дереве в порядке убывания. Вложенное содержимое каждой записи листа на панели включает объекты видов Draftsman, размещённые на этом листе, но не вспомогательные объекты чертежа, такие как размеры, выноски, графические фигуры и т. д.
Панель Bookmarks поддерживает активную навигацию: лист или объект чертежа, выбранный в дереве, отображается в рабочей области. Объект, выбранный в дереве, также выделяется на чертеже, а масштаб отображения изменяется так, чтобы объект помещался в окне. Навигация по дереву является двунаправленной, поэтому выделение в дереве также изменяется при выборе листов или объектов в рабочей области.
Панель Bookmarks также предоставляет дополнительные функции управления листами документа, например добавление и удаление листов и изменение порядка их расположения в структуре документа Draftsman. Для управления отображением и структурой листов документа используются функциональные кнопки в верхней части панели:
-
Задайте режим отображения страниц документа с помощью кнопок Single/Continuous: кнопка
включает отображение одного листа в рабочей области, а кнопка
включает непрерывный режим, в котором все листы отображаются последовательно с возможностью прокрутки.
-
Нажмите кнопку
, чтобы добавить новый лист документа после текущего выбранного листа. Кнопка
удаляет текущий выбранный лист из дерева или, если выбран объект чертежа, удаляет этот объект с листа.
-
Используйте кнопки
и
, чтобы переместить текущий выбранный лист на одну позицию вверх или вниз в дереве. Лист и содержащиеся на нём объекты изменят своё положение соответствующим образом, а лист будет переименован в соответствии с его новой позицией в дереве.
Дополнительные команды доступны в контекстном меню листа или объекта в дереве, открываемом правой кнопкой мыши.
-
Используйте команды контекстного меню листа, чтобы удалить выбранный лист, добавить новый лист в документ или открыть его свойства на панели Properties, которая откроется, если она ещё не открыта.
-
Используйте команды контекстного меню объекта, чтобы удалить выбранный объект или открыть его свойства на панели Properties, которая откроется, если она ещё не открыта.
Поддержка вариантов проекта
В Altium Designer можно создавать различные исполнения проекта платы (варианты проекта) и передавать информацию о вариантах в Draftsman, что позволяет применять вариант проекта к размещённому виду чертежа или таблице спецификации. Для каждого варианта можно добавить параметры. Эти параметры обычно используются в документах Altium Designer в виде специальных (интерпретируемых) строк, указывающих, какой вариант выбран в данный момент.
В Draftsman текущий вариант проекта на уровне документа выбирается в раскрывающемся списке Variants в области Properties на вкладке General панели Properties, когда в рабочей области не выбран ни один объект.
Размещённые сборочный вид платы, изометрический вид платы и реалистичный вид платы будут отображаться с учётом выбранного варианта. На сборочном виде платы отображение неустанавливаемых компонентов определяется настройками документа (подробнее). На изометрическом виде платы или реалистичном виде платы неустанавливаемые компоненты не отображаются Текущий вариант для вида можно выбрать на панели Properties, когда этот вид выбран в рабочей области.
Специальные строки, такие как =VariantName, и параметры вариантов можно размещать на чертеже в виде произвольных текстовых строк.
Дополнительные сведения о текстовых объектах см. на странице Работа с аннотациями.
)
)
)
)
).
)
).
).
)
).