Thiết kế phân cấp & nhiều trang sơ đồ

Altium Training

Altium Essentials: Navigating Schematics

This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.

Sơ lược

Bài viết này giải thích vì sao việc tổ chức sơ đồ nguyên lý trên nhiều trang có thể giúp thiết kế dễ xây dựng, đọc hiểu, chia sẻ và in ấn hơn, ngay cả khi mạch không quá phức tạp. Bài viết giới thiệu hai quyết định quan trọng khi thiết kế trên nhiều trang: mối quan hệ về cấu trúc giữa các trang và cách xử lý kết nối điện. Sau đó, bài viết tập trung vào khía cạnh cấu trúc bằng cách so sánh mô hình phẳng và mô hình phân cấp trong Altium Designer. Bạn cũng sẽ tìm hiểu trường hợp phù hợp nhất để áp dụng từng mô hình, những ưu nhược điểm cần cân nhắc và vai trò của các ký hiệu trang trong việc tổ chức sơ đồ nhiều trang. Đây là hướng dẫn thực tiễn giúp bạn chọn cấu trúc phù hợp trước khi bắt đầu thiết kế. Hãy đọc tiếp để xây dựng nền tảng vững chắc hơn cho sơ đồ nguyên lý tiếp theo của bạn.

- Hiểu sự khác biệt giữa thiết kế nhiều trang theo mô hình phẳng và mô hình phân cấp, cũng như khi nào nên chọn từng mô hình.
- Tìm hiểu vì sao việc tổ chức sơ đồ trên nhiều trang có thể giúp sơ đồ dễ đọc hơn, hỗ trợ làm việc nhóm, tăng tính mô-đun và thuận tiện hơn khi in ấn.
- Tìm hiểu cách sử dụng ký hiệu trang để biểu diễn các trang con và hỗ trợ tổ chức cấu trúc sơ đồ nguyên lý trong Altium Designer.
Tìm hiểu sâu hơn với AI:

Ban đầu, sơ đồ nguyên lý thường được vẽ trên một tờ giấy đủ lớn để phủ kín bàn vẽ kỹ thuật cỡ lớn, sau đó được sao chụp bằng máy photocopy khổ lớn chuyên dụng. Thời thế đã thay đổi: ngày nay, sơ đồ nguyên lý được vẽ trên máy tính để bàn, lưu trữ trên máy chủ và in bằng máy in laser khổ nhỏ.

Sự thay đổi này có nghĩa là ngay cả một thiết kế đơn giản cũng có thể được trình bày và hiểu dễ dàng hơn khi được chia thành nhiều trang sơ đồ nguyên lý. Ngay cả khi thiết kế không quá phức tạp, việc tổ chức thiết kế trên nhiều trang vẫn có thể mang lại lợi ích.

Ví dụ, thiết kế có thể bao gồm nhiều phần tử dạng mô-đun. Việc lưu các mô-đun này dưới dạng tài liệu riêng biệt cho phép nhiều người thiết kế cùng làm việc trên một dự án. Chia thiết kế thành các mô-đun theo chức năng cũng giúp thiết kế dễ đọc hơn rất nhiều. Đây là yếu tố quan trọng đối với những người cần đọc và diễn giải sơ đồ nguyên lý ở các giai đoạn sau trong vòng đời sản phẩm. Một lợi ích khác là khi thiết kế được tổ chức trên nhiều trang với ít linh kiện hơn trên mỗi trang, có thể sử dụng thiết bị in khổ nhỏ, chẳng hạn như máy in laser.

Có hai điều cần quyết định nếu bạn dự định chia thiết kế trên nhiều trang:

  • mối quan hệ cấu trúc giữa các trang, và

  • phương pháp thiết lập kết nối điện giữa các mạch trên những trang đó.

Lựa chọn của bạn sẽ thay đổi tùy theo quy mô, loại dự án và sở thích cá nhân.

Bài viết này tập trung vào mối quan hệ cấu trúc giữa các trang, cách cấu trúc đó hoạt động, cùng các công cụ và kỹ thuật có sẵn để tạo thiết kế nhiều trang. Để tìm hiểu thêm về cách thiết lập kết nối, hãy tham khảo bài viết Tạo kết nối.

Thiết kế phẳng hay phân cấp

Như đã đề cập, với vai trò là người thiết kế, bạn cần quyết định cách tổ chức các trang sơ đồ nguyên lý và cách thiết lập kết nối giữa chúng. Tuy nhiên, đây không phải là hai quyết định độc lập: khi chọn cấu trúc, bạn cũng cần chọn cách tạo kết nối giữa các trang.

Có hai cách tổ chức một thiết kế nhiều trang: flat hoặc hierarchical.

Cả hai cách đều phù hợp; mỗi cách có những ưu điểm và hạn chế riêng. Thiết kế phẳng có thể được tạo nhanh hơn nhưng khiến người khác khó theo dõi tín hiệu và hiểu chức năng hơn, đặc biệt là trên bản in. Thiết kế phân cấp cần nhiều thời gian để vẽ hơn do phải thực hiện nhiều bước hơn để tạo kết nối, đổi lại, người khác sẽ dễ hiểu chức năng của thiết kế và theo dõi tín hiệu xuyên suốt các trang hơn. Thiết kế phân cấp cũng đóng vai trò quan trọng trong việc tái sử dụng thiết kế và là một phần thiết yếu của thiết kế đa kênh.

Kỹ thuật dùng để liên kết trang con với trang cha giống nhau ở cả thiết kế phẳng và thiết kế phân cấp — chính cách thiết lập kết nối quyết định đó là thiết kế phẳng hay phân cấp.

Thiết kế phẳng

Bạn có thể hình dung thiết kế phẳng như một trang sơ đồ nguyên lý lớn được cắt thành nhiều trang nhỏ hơn — trong thiết kế phẳng, tất cả các trang đều nằm cùng một cấp. Kết nối trong thiết kế phẳng được thiết lập trực tiếp từ bất kỳ trang nào đến bất kỳ trang nào khác — kiểu kết nối này được gọi là kết nối ngang.

Trong thiết kế phẳng, trang trên cùng là tùy chọn. Nếu có, trang này sẽ chứa một ký hiệu trang cho mỗi trang trong thiết kế, nhưng không được chứa bất kỳ đường dây nối nào. Thiết kế phẳng có thể có số lượng trang bất kỳ.

Hình thứ nhất — thiết kế phẳng không có trang trên cùng; hình thứ hai — cùng thiết kế đó nhưng có trang trên cùng. Lưu ý rằng trang trên cùng không có đường dây nối. Trang này chỉ thể hiện các trang có trong thiết kế. 
Hình thứ nhất — thiết kế phẳng không có trang trên cùng; hình thứ hai — cùng thiết kế đó nhưng có trang trên cùng. Lưu ý rằng trang trên cùng không có đường dây nối. Trang này chỉ thể hiện các trang có trong thiết kế.

Cả hai hình trên đều thể hiện thiết kế phẳng; phiên bản bên trái không có trang trên cùng, còn phiên bản bên phải thì có. Với một thiết kế nhỏ chỉ gồm hai hoặc ba trang sơ đồ nguyên lý, bạn có thể thấy trang trên cùng không mang lại thêm giá trị. Khi số lượng trang tăng lên, trang trên cùng có thể giúp người đọc hiểu chức năng của thiết kế mạch thông qua cách bố trí các khối logic (ký hiệu trang) trên trang. Tất cả các trang trong thiết kế đều xuất hiện ở cùng một cấp trong bảng Projects vì không có cấu trúc phân cấp.

Thiết kế phân cấp

Cần nhớ rằng đối với thiết kế phân cấp, một dự án chỉ có thể chứa một trang cấp cao nhất. Tất cả các tài liệu nguồn khác phải được tham chiếu bằng các ký hiệu trang. Khi thực hiện kiểm tra tính hợp lệ của thiết kế, có thể sử dụng phép kiểm tra vi phạm Nhiều tài liệu cấp cao nhất để cảnh báo nếu điều kiện này không được đáp ứng. Ngoài ra, không ký hiệu trang nào được tham chiếu đến chính trang chứa nó hoặc bất kỳ trang nào ở cấp cao hơn, vì điều này sẽ tạo ra một vòng lặp không thể giải quyết trong cấu trúc.

Thiết kế phân cấp là thiết kế thể hiện cấu trúc dạng cây — hay các mối quan hệ giữa các trang — trong thiết kế. Điều này được thực hiện bằng các ký hiệu trang, đại diện cho các trang cấp dưới trong hệ thống phân cấp thiết kế. Ký hiệu đại diện cho trang bên dưới, còn các đầu nối trang trong ký hiệu đại diện cho (hoặc kết nối với) các cổng trên trang bên dưới. Kết nối được thực hiện thông qua các Đầu nối trang trong các Ký hiệu trang đó — không phải trực tiếp từ các Cổng trên trang này đến các Cổng trên trang khác.

Giống như trong thiết kế phẳng, trang con được xác định bằng cách khai báo tên tệp của nó trong ký hiệu trang. Trong thiết kế phân cấp, trang con đó cũng có thể chứa các ký hiệu trang tham chiếu đến những trang cấp thấp hơn, từ đó tạo thêm một cấp trong hệ thống phân cấp. Hình bên dưới minh họa một thiết kế phân cấp với 3 cấp.

Trong thiết kế phân cấp, cấu trúc hiển thị trong cây được xác định bởi các mối quan hệ cha–con do các ký hiệu trang tạo ra.
Trong thiết kế phân cấp, cấu trúc hiển thị trong cây được xác định bởi các mối quan hệ cha–con do các ký hiệu trang tạo ra.

Trong thiết kế phân cấp, tín hiệu trên một trang sơ đồ con đi ra khỏi trang qua một cổng (Port), kết nối lên mục vào trang (Sheet Entry) tương ứng trên trang sơ đồ cha. Trang sơ đồ cha có các đường dây dẫn tín hiệu từ trang con đến một mục vào trang trong ký hiệu trang (Sheet Symbol) khác, sau đó tín hiệu đi xuống cổng tương ứng trên trang sơ đồ con thứ hai, như minh họa trong hình bên dưới.

The connectivity is from a Port on the child sheet up to a matching Sheet Entry in the Sheet Symbol on the parent sheet

Cấu trúc trang sơ đồ cha-con này có thể được định nghĩa với độ sâu bất kỳ, và một thiết kế phân cấp có thể chứa số lượng trang sơ đồ tùy ý.

Kết nối giữa các trang sơ đồ được xác định bởi Net Identifier Scope. Thiết lập này nằm trong thẻ Options của hộp thoại Options for Project. Để tìm hiểu thêm về cách tạo kết nối, hãy đọc trang Tạo kết nối. Lưu ý rằng Phạm vi định danh mạng (Net Identifier Scope) có tùy chọn Tự động (Automatic); nếu không có yêu cầu kết nối đặc biệt, đây là một lựa chọn phù hợp.

Ưu điểm của thiết kế phân cấp là cho người đọc thấy cấu trúc của thiết kế và các kết nối hoàn toàn có thể dự đoán, dễ dàng truy vết vì chúng luôn đi từ trang sơ đồ con lên ký hiệu trang trên trang sơ đồ cha.

Một ưu điểm khác của thiết kế phân cấp là cung cấp nền tảng để triển khai một hệ thống tái sử dụng thiết kế tinh vi. Hệ thống này được triển khai theo hai cách, tùy thuộc vào cách lưu trữ dữ liệu: dựa trên tệp hoặc dựa trên máy chủ.

  • Hệ thống dựa trên tệp được gọi là Device Sheets, cho phép bạn đặt trực tiếp một sơ đồ nguyên lý có sẵn từ thư viện Device Sheets vào thiết kế đang tạo. Để tìm hiểu thêm về Device Sheets, hãy tham khảo trang Làm việc với Device Sheets.

  • Hệ thống dựa trên Workspace được gọi là Managed Schematic Sheets, cho phép bạn đặt trực tiếp một sơ đồ nguyên lý có sẵn từ Workspace được kết nối vào thiết kế đang tạo. Để tìm hiểu thêm về Managed Sheets, hãy tham khảo trang Làm việc với Managed Schematic Sheets.

Thêm tham chiếu chéo

Việc thêm tham chiếu chéo vào dự án giúp bạn dễ dàng theo dõi luồng kết nối của các net giữa các trang sơ đồ nguyên lý trong dự án. Trình chỉnh sửa sơ đồ nguyên lý hỗ trợ tự động tạo và cập nhật tham chiếu chéo.

Bật tùy chọn Automatic Cross References trong vùng General và cấu hình các tùy chọn trong vùng Cross References của thẻ Options trong hộp thoại Project Options. Bạn có thể đặt một kiểu tham chiếu chéo cụ thể cho dự án đang hoạt động hoặc bật tùy chọn Follow Cross References settings in Preferences để kế thừa các tùy chọn trong vùng Port Cross References trên trang Schematic – General của hộp thoại Preferences. Tại đây, bạn cũng có thể chọn các đối tượng (cổng, đầu nối ngoài trang, cổng vào trang) sẽ được hiển thị tham chiếu chéo.

Bạn có thể truy cập nhanh thẻ Options của hộp thoại Project Options bằng cách chọn lệnh Reports » Automatic Cross References Settings từ các menu chính hoặc nhấp chuột phải trong không gian thiết kế rồi chọn lệnh Sheet Actions » Automatic Cross References Settings từ menu ngữ cảnh.

Cấu hình tham chiếu chéo tự động cho dự án đang hoạt động trong thẻ Options của hộp thoại Project Options.
Cấu hình tham chiếu chéo tự động cho dự án đang hoạt động trong thẻ Options của hộp thoại Project Options.

Tham chiếu chéo sẽ được hiển thị trên sơ đồ nguyên lý bên cạnh các đối tượng đã chọn theo kiểu đã cấu hình. Các giá trị tham chiếu chéo cũng được hiển thị trong bảng Properties, nơi bạn có thể bật/tắt hiển thị tham chiếu chéo cho các đối tượng đã chọn.

Bạn có thể xem tham chiếu chéo trên sơ đồ nguyên lý và, đối với đối tượng đã chọn, trong bảng Properties. Ví dụ về tham chiếu chéo cho một cổng được minh họa tại đây.
Bạn có thể xem tham chiếu chéo trên sơ đồ nguyên lý và, đối với đối tượng đã chọn, trong bảng Properties. Ví dụ về tham chiếu chéo cho một cổng được minh họa tại đây.

Tham chiếu chéo cũng được hỗ trợ trong các tệp PDF xuất từ sơ đồ nguyên lý. Nếu một đối tượng liên kết với nhiều đối tượng được kết nối (ví dụ: một cổng được kết nối với một cổng vào trang trên các trang sơ đồ nguyên lý cấp cha và các cổng trên những trang khác), việc nhấp vào đối tượng trong tệp PDF xuất ra sẽ hiển thị danh sách các trang chứa những đối tượng được kết nối. Chọn một mục trong danh sách để mở trang tương ứng. Nếu một đối tượng chỉ liên kết với một đối tượng được kết nối, việc nhấp vào đối tượng sẽ mở ngay trang tương ứng.

Trong tệp PDF xuất từ sơ đồ nguyên lý, bạn có thể dễ dàng điều hướng giữa nhiều đối tượng được kết nối bằng menu bật lên.
Trong tệp PDF xuất từ sơ đồ nguyên lý, bạn có thể dễ dàng điều hướng giữa nhiều đối tượng được kết nối bằng menu bật lên.

Tạo thiết kế nhiều trang

Ngay khi thêm trang sơ đồ nguyên lý thứ hai vào dự án, bạn đã tạo một thiết kế nhiều trang. Nếu định tạo một thiết kế phẳng không có trang cấp cao nhất, bạn chỉ cần tiếp tục thêm các trang sơ đồ nguyên lý vào dự án (nhấp chuột phải vào mục dự án trong bảng Projects và chọn lệnh Add New to Project » Schematic từ menu ngữ cảnh), sau đó xác nhận rằng Net Identifier Scope được đặt chính xác.

Nếu muốn dùng các ký hiệu trang để tham chiếu đến các trang cấp thấp hơn, bạn có thể đặt ký hiệu trang rồi chỉnh sửa thủ công để tham chiếu chính xác đến trang cấp thấp hơn, hoặc sử dụng các lệnh tích hợp sẵn để hỗ trợ, như mô tả bên dưới.

Tham chiếu đến trang con

Chính thuộc tính Filename của ký hiệu trang tham chiếu đến trang cấp dưới. Lưu ý rằng trường này chỉ được chứa tên tệp sơ đồ nguyên lý, không bao gồm đường dẫn đến vị trí của tệp (thông tin vị trí này thực tế được lưu trong tệp dự án).

Thuộc tính Filename liên kết ký hiệu trang này với trang sơ đồ nguyên lý con.
Thuộc tính Filename liên kết ký hiệu trang này với trang sơ đồ nguyên lý con.

Lưu ý rằng sơ đồ nguyên lý con không nhất thiết phải được lưu trong cùng thư mục với sơ đồ nguyên lý cha. Nếu tệp được lưu trong một thư mục con của thư mục lưu trang cha, tham chiếu tệp tương đối sẽ được sử dụng. Nếu tệp được lưu ở vị trí khác, tham chiếu tệp tuyệt đối sẽ được sử dụng. Hãy cẩn thận khi di chuyển các tệp trong dự án như vậy, hoặc sử dụng Project Packager để nén các tệp thành ZIP, vì công cụ này sẽ xử lý các đường dẫn tệp khi nén dự án.

Điều hướng trong thiết kế nhiều trang

Trình biên tập sơ đồ nguyên lý cung cấp các công cụ cho phép bạn nhanh chóng điều hướng giữa các tài liệu trong thiết kế nhiều trang và các đối tượng liên quan trong đó.

Lệnh Tools » Up/Down Hierarchy được dùng để chuyển từ tài liệu hiện tại lên hoặc xuống một cấp trong cấu trúc phân cấp thiết kế. Sau khi khởi chạy lệnh, con trỏ sẽ chuyển thành hình chữ thập và bạn sẽ được nhắc chọn một điểm điều hướng. Nếu nhấp vào một đầu nối trang, bạn sẽ được đưa đến cổng tương ứng trên trang con; nếu nhấp vào một ký hiệu trang, toàn bộ trang con sẽ được hiển thị. Để điều hướng lên trên trong cấu trúc phân cấp, hãy nhấp vào một cổng để được đưa đến đầu nối trang tương ứng trên trang cha.

Nếu một đầu nối trang hoặc cổng được kết nối với bus, lần nhấp đầu tiên sẽ mở một menu, từ đó bạn có thể chọn toàn bộ bus hoặc một tín hiệu riêng lẻ trong bus. Dây nối tương ứng từ đầu nối trang hoặc cổng sẽ được tô sáng. Nhấp lần thứ hai vào đầu nối trang hoặc cổng ban đầu sẽ đưa bạn đến cổng tương ứng trên trang sơ đồ nguyên lý bên dưới hoặc đầu nối trang trên trang bên trên.

Để mở trang con được tham chiếu bởi ký hiệu trang hiện nằm dưới con trỏ, hãy nhấp chuột phải lên một ký hiệu trang đã đặt và chọn lệnh Sheet Symbol Actions » Open SubSheet <SchematicDocumentName> từ menu ngữ cảnh. Sau khi khởi chạy lệnh, tài liệu sơ đồ nguyên lý được ký hiệu tham chiếu đến sẽ được mở (nếu chưa mở) và trở thành tài liệu đang hoạt động trong cửa sổ thiết kế chính.

Khi tham chiếu chéo tự động được bật cho các đối tượng liên quan, bạn cũng có thể sử dụng các lệnh Jump To từ các menu con Port Actions, Sheet Entry Actions và Off Sheet Actions (đối với thiết kế phẳng) trong menu chuột phải của đối tượng để điều hướng giữa các cổng, đầu nối trang và đầu nối ngoài trang. Ví dụ, khi tùy chọn Automatic Cross References được bật và tùy chọn thiết lập Sheet Entry & Ports được chọn cho tùy chọn Ports trên tab Options của hộp thoại Options for Project, bạn có thể nhấp chuột phải lên một cổng và chọn lệnh Port Actions » Jump to Port <PortName> on <SchematicDocumentName> hoặc Port Actions » Jump to Sheet Entry <PortName> on <SchematicDocumentName> cần dùng từ menu ngữ cảnh - tài liệu nguồn của cổng hoặc đầu nối trang được chỉ định sẽ trở thành tài liệu đang hoạt động, và con trỏ sẽ được đặt trên cổng hoặc đầu nối trang đó. Tất cả các cổng cùng tên (và mọi dây nối được kết nối) trên tài liệu đích sẽ được tô sáng.

Sử dụng lệnh Jump to để chuyển đến một đối tượng tương ứng ở bất kỳ đâu trong thiết kế.
Sử dụng lệnh Jump to để chuyển đến một đối tượng tương ứng ở bất kỳ đâu trong thiết kế.

  • Khi bạn điều hướng giữa các đối tượng, đối tượng tương ứng sẽ được tô sáng trong không gian thiết kế. Cách hiển thị tuân theo Highlight Methods (Làm mờ, Thu phóng, Chọn) được xác định trên trang System - Navigation của hộp thoại Preferences.
  • Bạn cũng có thể điều hướng trực tiếp trong cấu trúc phân cấp bằng cách nhấn Ctrl và nhấp đúp lên một cổng, đầu nối trang hoặc ký hiệu trang.
  • Bạn cũng có thể điều hướng trong cấu trúc phân cấp bằng tính năng Interactive Navigation của bảng Navigator.

Tạo cấu trúc phân cấp

Phần mềm bao gồm một số lệnh cho phép bạn xây dựng cấu trúc phân cấp gồm nhiều tài liệu một cách nhanh chóng và hiệu quả. Các lệnh bạn sử dụng sẽ phụ thuộc vào phương pháp thiết kế cá nhân - nhìn chung có thể chia thành từ trên xuống hoặc từ dưới lên. Những lệnh này hiệu quả hơn việc tạo cấu trúc phân cấp theo cách thủ công, vì chúng xử lý tất cả các thành phần cần thiết trong quá trình này, chẳng hạn như thêm đầu nối trang, tạo trang sơ đồ nguyên lý mới, đặt cổng, v.v.

Sử dụng lệnh này để xây dựng cấu trúc phân cấp theo hướng từ trên xuống:

  • Create Sheet From Sheet Symbol (menu chính Design hoặc menu con Sheet Symbol Actions trong menu chuột phải của ký hiệu trang) – sử dụng lệnh này để tạo một trang sơ đồ nguyên lý mới bên dưới ký hiệu trang được chỉ định. Các cổng tương ứng với các đầu nối trang trên ký hiệu sẽ được đặt ở góc dưới bên trái của tài liệu mới. Đừng lo nếu bạn chưa thêm đủ tất cả các đầu nối trang vào ký hiệu trang; nếu sau này thêm các đầu nối khác, bạn có thể đồng bộ lại các đầu nối trang và cổng, như trình bày bên dưới.

    • Tài liệu sơ đồ nguyên lý được tạo sẽ lấy tên tệp trong ký hiệu trang làm tên tệp của mình. Bạn có thể nhập tên dự kiến cho tài liệu vào trường File Name của ký hiệu trang, bao gồm cả phần mở rộng (ví dụ: <DocumentName>.SchDoc), hoặc để trống tên và nhập tên khi lưu tài liệu sau này.
    • Cần thận trọng khi tạo trang từ ký hiệu trang nếu đã tồn tại một trang có tên tệp đó. Một trang mới có cùng tên tệp sẽ được tạo. Có thể xử lý tình trạng trùng tên khi lưu bằng cách lưu trang mới với tên khác hoặc ghi đè trang hiện có nếu cần.
    • Kiểu I/O điện của các cổng được tạo trên trang con mới sẽ giống với kiểu I/O của các đầu nối trang trên ký hiệu trang cha ban đầu.

Sử dụng lệnh này để xây dựng cấu trúc phân cấp theo hướng từ dưới lên:

  • Create Sheet Symbol From Sheet (menu chính Design hoặc menu con Sheet Actions trong menu chuột phải của không gian thiết kế) – sử dụng lệnh này để tạo ký hiệu từ trang sơ đồ nguyên lý được chỉ định. Để sử dụng lệnh này, trước tiên hãy chuyển sang trang sẽ chứa ký hiệu trang mới, sau đó khởi chạy lệnh. Hộp thoại Choose Document to Place sẽ mở ra - sử dụng hộp thoại này để chọn tài liệu sơ đồ nguyên lý đích mà ký hiệu trang mới tạo sẽ tham chiếu đến. Ký hiệu trang sẽ bao gồm một đầu nối trang tương ứng với mỗi cổng tìm thấy. Nếu sau này thêm hoặc xóa cổng hay đầu nối trang, bạn có thể đồng bộ lại chúng, như trình bày bên dưới.

    • Khi ký hiệu trang được tạo và đặt trên trang hiện hành, trang này sẽ không được liệt kê trong hộp thoại Choose Document to Place . Đó là vì ký hiệu trang không thể tham chiếu đến chính trang mà nó được đặt trên đó.
    • Kiểu I/O điện của các đầu nối trang được tạo trong ký hiệu trang cha mới sẽ giống với kiểu I/O của các cổng trên trang con ban đầu.

Sử dụng lệnh này để sắp xếp lại cách bố trí mạch trong thiết kế:

  • Edit » Refactor » Move Selected Sub-circuit to Different Sheet - sử dụng lệnh này để chuyển các linh kiện và dây nối đã chọn sang một trang khác trong dự án. Hộp thoại Choose Destination Document sẽ mở ra, cho phép bạn chọn bất kỳ trang sơ đồ nguyên lý hiện có nào trong dự án. Lệnh này được mô tả chi tiết hơn ở bên dưới.

Nếu bạn thắc mắc tại sao lại có các lệnh chuyên dụng để chuyển linh kiện từ trang này sang trang khác, thì lý do là các lệnh Cắt & Sao chép tiêu chuẩn sẽ tự động đặt lại mã định danh duy nhất của từng linh kiện. UID liên kết linh kiện trên sơ đồ nguyên lý với linh kiện trên PCB. Nếu UID của một linh kiện trên sơ đồ nguyên lý đã bị đặt lại, bạn sẽ được nhắc thử đối sánh theo ký hiệu định danh mỗi khi đồng bộ hóa thiết kế (khi sử dụng lệnh Design » Update). Nếu cần, có thể đồng bộ hóa lại các UID bằng lệnh Project » Component Links trong trình biên tập PCB.

► Tìm hiểu thêm về Đồng bộ hóa thiết kế

Tái cấu trúc thiết kế

Main article: Tái tổ chức thiết kế

Quá trình thiết kế thường không theo một cấu trúc cố định mà phát triển tự nhiên; người thiết kế có thể đồng thời hình thành ý tưởng cho nhiều phần của thiết kế và thể hiện từng phần khi các ý tưởng dần hoàn thiện. Điều đó có nghĩa là một bộ sơ đồ nguyên lý ban đầu được tổ chức tốt, bố trí gọn gàng có thể trở nên chật chội và thiếu ngăn nắp. Mặc dù bạn có thể dùng các lệnh Cắt, Sao chép và Dán để sắp xếp lại thiết kế sơ đồ nguyên lý, đây không phải lúc nào cũng là cách tốt nhất.

Tại sao không nên cắt và sao chép? Vì mỗi linh kiện khi được đặt đều được gán một mã định danh duy nhất, và mã này sẽ tự động được đặt lại mỗi khi linh kiện được Cắt/Sao chép rồi Dán. Cách quản lý UID này nhằm đảm bảo mỗi UID chỉ xuất hiện một lần trong thiết kế, vì đây là trường khóa liên kết linh kiện trên sơ đồ nguyên lý với linh kiện trên PCB. Cách Cắt/Sao chép/Dán phù hợp nếu thiết kế chưa được chuyển sang trình biên tập PCB; nhưng nếu đã chuyển, bạn nên sử dụng các công cụ tái tổ chức thiết kế.

Chuyển một mạch con sang trang khác

Cách dễ nhất để chuyển một phần mạch từ trang này sang trang khác là chọn phần mạch đó, sau đó chạy lệnh Edit » Refactor » Move Selected Sub-circuit to Different Sheet. Hộp thoại Choose Destination Document sẽ mở ra. Sau khi bạn chọn trang đích và nhấp vào OK, trang đó sẽ xuất hiện cùng mạch con bám theo con trỏ, sẵn sàng để đặt vào vị trí.

Có thể dễ dàng chuyển một phần mạch đã chọn sang trang khác trong dự án bằng lệnh Move Selected Subcircuit to Different Sheet.
Có thể dễ dàng chuyển một phần mạch đã chọn sang trang khác trong dự án bằng lệnh Move Selected Subcircuit to Different Sheet.

► Tìm hiểu thêm về Tái tổ chức thiết kế.

Đồng bộ hóa cổng và đầu nối trang

Nếu bạn đã di chuyển linh kiện và dây nối khi tái cấu trúc thiết kế, bạn cũng có thể cần đồng bộ hóa lại trang con với ký hiệu trang tương ứng để mỗi cổng đều có một đầu nối trang khớp với nó. Việc này được thực hiện bằng lệnh Synchronize Sheet Entries and Ports, với các cách sử dụng sau:

  • A specific Sheet Symbol - nhấp chuột phải vào ký hiệu trang để hiển thị menu ngữ cảnh, rồi chọn lệnh Sheet Symbol Actions » Synchronize Sheet Entries and Ports để chỉ phân tích ký hiệu trang dưới con trỏ.
  • All Sheet Symbols in the design - chọn lệnh Design » Synchronize Sheet Entries and Ports để phân tích tất cả ký hiệu trang trong toàn bộ thiết kế. Hộp thoại sẽ có một tab cho mỗi ký hiệu trang trong thiết kế, theo tùy chọn Only Show unmatched sheet symbols ở cuối hộp thoại.

Với cả hai lệnh này, hộp thoại Synchronize Ports to Sheet Entries sẽ mở ra. Các cổng/đầu nối trang đã khớp sẽ được liệt kê ở phía bên phải hộp thoại, còn các cổng và đầu nối trang chưa khớp sẽ được liệt kê trong hai cột ở phía bên trái. Một ký hiệu trang được coi là “đã đồng bộ hóa” với trang con mà nó tham chiếu nếu tất cả đầu nối trang của nó đều khớp với các cổng tương ứng trên trang con đó — cả về tên lẫn kiểu I/O.

Hộp thoại Synchronize Ports to Sheet Entries được dùng để đảm bảo các đầu nối trang khớp với các cổng trên trang con. Lưu ý rằng hộp thoại có hai tab, nghĩa là trong thiết kế này có hai ký hiệu trang có các đầu nối trang/cổng không khớp nhau.
Hộp thoại Synchronize Ports to Sheet Entries được dùng để đảm bảo các đầu nối trang khớp với các cổng trên trang con. Lưu ý rằng hộp thoại có hai tab, nghĩa là trong thiết kế này có hai ký hiệu trang có các đầu nối trang/cổng không khớp nhau.

Đối với các mục không khớp hiển thị ở bên trái hộp thoại, hãy chọn Đầu vào trang trong cột đầu tiên, sau đó chọn Cổng phù hợp trong cột thứ hai, rồi nhấp vào nút cần thiết ở giữa hộp thoại để cập nhật một trong hai đối tượng nhằm đồng bộ chúng (và chuyển chúng sang danh sách ở bên phải hộp thoại).

Các nút có chức năng như sau:

  • Button, update the Port to Match the Sheet Entry - sử dụng các thuộc tính của Đầu vào trang và áp dụng chúng cho Cổng được chọn.
  • Button, update the Sheet Entry to Match the Port - sử dụng các thuộc tính của Cổng và áp dụng chúng cho Đầu vào trang được chọn.

Nếu chọn nhiều Đầu vào trang trong cột bên trái, phần mềm sẽ đồng bộ từng Đầu vào trang với Cổng nằm cạnh nó trong cột thứ hai. Nếu không có Cổng (hoặc Đầu vào trang) nằm cạnh, một đối tượng mới sẽ được tạo.

  • Nếu lệnh thêm các Đầu vào trang hoặc Cổng mới, bạn sẽ cần bố trí chúng vào đúng vị trí trên trang sơ đồ nguyên lý sau khi lệnh hoàn tất.
  • Lưu ý rằng mọi thay đổi được thực hiện trong hộp thoại đều có hiệu lực ngay lập tức. Bạn không thể hoàn tác thay đổi thông qua hộp thoại. Bạn cần sử dụng tính năng Undo của tài liệu để hoàn tác thay đổi.
AI-LocalizedBản địa hóa bằng AI
Nếu bạn phát hiện vấn đề, hãy chọn văn bản/hình ảnh và nhấnCtrl + Enterđể gửi phản hồi cho chúng tôi.
Nav
Contents
Tính khả dụng của tính năng

Các tính năng bạn có thể sử dụng phụ thuộc vào giải pháp Altium mà bạn đang có – Altium Develop, Altium Agile Teams, Altium Agile Enterprise, hoặc Altium Designer (đang trong thời hạn hiệu lực).

Nếu bạn không thấy một tính năng được nêu trong tài liệu có trong phần mềm thực tế của mình, liên hệ Bộ phận Kinh doanh của Altium để tìm hiểu thêm.

Tài liệu cũ

Tài liệu Altium Designer không còn được phân phiên bản. Nếu bạn cần truy cập tài liệu cho các phiên bản cũ hơn của Altium Designer, hãy truy cập mục Tài liệu cũ trên trang Trình cài đặt khác.

Contents