发布到工作区
概览
- 确定要包含哪些源数据、制造数据、装配数据、变体数据和自定义数据集,以及如何分配所需的输出作业。
- 了解发布目标选项、工作区条目命名方案,以及目标修订版的控制选项。
- 按照各个发布阶段逐步操作,并了解自动发布命令如何影响审查、报告和 PLM 发布。
在 Online Mode 的 Release 视图中,发布过程采用分阶段流程,视图左侧的条目可让您一目了然地了解当前所处的阶段:
-
Configure Server Release – 在发布过程的此阶段,您可以指定要生成的数据类型:源数据(始终生成)、制造数据、装配数据(针对基础设计及检测到的每个变体)。
-
Validate Project – 当在已分配的 OutJob 文件中检测到一个或多个验证类型的报告时,发布过程的下一阶段将自动运行。系统将运行分配给待发布数据项的 Output Job 文件中定义的所有验证输出生成器。
-
Generate Data – 发布过程的下一阶段会自动运行。在此阶段,系统将运行分配给所包含数据项的 OutJob 文件中定义的所有其他输出,以生成要发布到工作区中相应目标项的数据。
-
Review Data – 所有验证检查通过且输出数据生成后,您可以在发布过程的此阶段查看生成的数据。
-
Upload Data – 在上一阶段确认发布后,系统会自动进入下一阶段。此阶段仅显示将数据上传到目标工作区中相关数据项修订版的进度。
-
Execution Report – 这是该流程的最后阶段,提供发布摘要。您可以通过提供的导航链接,在 Explorer 面板中快速浏览生成的项修订版。如果您是在执行发布并推送到 PLM 的流程时访问 Project Releaser,则会显示
按钮。单击此按钮可继续执行该流程的底层工作流,将数据推送到 PLM。
-
Publish to PLM – 仅在通过相应的已激活流程执行发布时(先发布,再推送到 PLM),才会出现此阶段。在上一阶段单击
按钮后,系统会自动进入此阶段(如果使用了 Prepare & Release & Publish to PLM 命令,则会直接进入此阶段,该命令位于
按钮关联的菜单中)。随后会显示 Login Credentials 对话框。输入您的 PLM 实例的 Username 和 Password,然后选择要使用的 PLM 模板(以 <PLMInstance>:<PublishingTemplate>的形式显示)。
在线阶段 1 – 配置服务器发布
在发布过程的此阶段,您可以指定要生成的数据类型。可发布的数据项包括:
- Source Data – 源设计的快照。
- Fabrication Data – PCB 制造商生产裸板所需的数据。
- Assembly Data for the Base Design (no variations) – 装配厂按照物料清单为未应用变体的基础设计完成裸板全部元器件装配所需的数据。
-
Assembly Data for Design
Variant n– 装配厂按照物料清单为基础设计的Variant n完成裸板元器件装配所需的数据。
装配数据集的数量与基础设计(未应用变体)以及该设计中检测到的所有已定义变体相对应。

项目发布过程的阶段 1 – 配置发布所包含的内容(要生成的数据)。
发布始终包含 Source Data 项。其他数据项可按需包含。
分配输出作业
要在发布中包含 Fabrication Data 和 Assembly Data 项,必须为其分配至少一个 Output Job 文件。如果您的 Output Job 文件名称以子字符串“fab”和“ass”开头,则在首次访问 Release 视图时,这些 OutJob 会分别自动分配到 Fabrication Data 和 Assembly Data 部分。否则,您需要分别手动分配适用的 OutJob。这可以在 Project Release Options 对话框的 Release Options 选项卡中完成(单击视图左下角的
按钮即可访问)。

根据需要将 OutJob 分配给相应的数据集。
切换发布目标
Project Release Options 对话框的 Release Options 选项卡还可用于更改发布目标,即在受管(Online)和非受管(Offline)操作模式之间切换。有以下三个选项:
-
Unmanaged - Folder(Offline):选择此选项可将生成的数据发布到本地文件夹。根文件夹路径在对话框的 Output Path 选项卡中指定。默认设置为[OutputPath](使用“项目选项”对话框的“选项”选项卡中 Output Path 字段定义的路径)。 -
Unmanaged - Zip(Offline):选择此选项可将生成的数据发布到本地文件夹。数据将打包到单个 Zip 文件中。Zip 文件的路径/名称在对话框的 Output Path 选项卡中指定。默认设置为[OutputPath][ProjectName].zip(使用 Project Options 对话框的 Options 选项卡中 Output Path 字段 定义的路径)。 -
Managed - <WorkspaceName>(Online):选择此选项可发布到您当前连接的工作区(使用WorkspaceName)。

切换发布目标(即生成数据的发送位置),作为工程发布选项的一部分。
设置工作区条目命名方案
首次将工程发布到目标工作区时,您可以定义该工作区中目标数据条目的命名方式(这些条目的修订版用于接收生成的数据)。此操作在 Project Release Options 对话框的 Item Naming 选项卡中完成。单击视图左下角的
按钮即可打开该对话框(也可以单击待发布数据集的 Target Revision 链接,然后从上下文菜单中选择 Edit)。使用此选项卡可以:
- 定义工程名称。默认情况下,此处会填入工程的实际名称。
-
为发布过程中可生成的各类数据条目定义默认命名方案。单击 Item ID 列中的某个字段,然后单击该字段右侧的
按钮,打开 Choose Item 对话框(Explorer 面板的一种形式),从而选择当前连接的工作区中的现有条目作为目标。
要更改任一命名方案,请单击 Settings 按钮,打开 Naming Template Settings 对话框。

设置工程名称,并定义目标工作区中生成的数据条目的命名方式。此处的字段可以编辑,因为该工程尚未发布。
命名模板支持使用以下宏格式:
-
Parameter-based – 支持使用方括号括起来的参数(例如
[ProjectName]、[VariantName]、[ProjectParameter])。 -
Numeric-based – 支持使用花括号括起来的数字量词(例如
{0000}、{9000})。
控制目标修订版
返回主视图,单击 Target Revision 条目旁边的链接,即可打开命令菜单,如下图所示:

访问相关控件,为发布过程中要生成的数据集指定目标修订版——将鼠标悬停在图像上即可查看。
可用命令取决于条目是否已完成首次发布。以下列出了所有可能的命令:
-
Auto <RevisionID> – 此选项让系统处理修订版,因此您无需在尚无计划修订版时手动创建。
RevisionID显示条目在所分配的修订版命名方案中同一级别的下一个修订版(例如,如果当前修订版为A.1,此命令会将目标显示为A.2)。 -
Next <RevisionID> – 此选项仅在条目首次发布后可用。使用它可按照所分配的修订版命名方案,快速递增下一级别的目标修订版。
RevisionID显示下一个修订版(例如,如果当前修订版为A.1,此命令会将目标切换为B.1)。 -
Custom – 使用此选项可通过 自定义修订版 ID 对话框定义自定义修订版 ID,从而指定目标条目的特定修订版。 根据所采用的修订版命名方案,对话框中最多可能有三个级别 ID 字段。请注意,从条目创建后到数据发布到其初始修订版之前(即该修订版仍处于
Planned状态时),均可更改该条目第一个计划修订版的 ID。 - Browse – 使用此选项可指定一个现有的目标条目修订版,以向其中发布数据。系统将打开 Choose Target Item 对话框(Explorer 面板的一种形式),供您进行选择。
- Edit – 使用此选项可打开 Project Release Options 对话框的 Item Naming 选项卡,您可以在其中更改将要创建的目标条目(及其初始修订版)的名称。
- Navigate – 使用此选项可在 Explorer 面板中快速定位到该条目(该条目已发布,且下一个修订版已处于计划状态)。
菜单顶部的条目会反映当前选择或定义的目标修订版。
查看数据生成详情
单击数据集标题最右侧的 Details 控件,可查看该数据集具体将生成哪些数据。单击 Hide Details 控件可折叠此展开视图。除 Source Data 数据集外,生成的数据均来自一个或多个已分配的输出作业文件。单击 Configure 控件可快速访问源 OutJob 文件。

打开数据集的详细视图,查看将生成哪些数据——将鼠标悬停在图像上即可查看。
其他设置
在 Preferences 对话框的 数据管理 – 服务器页面上,还可以定义与工程发布相关的其他设置:
-
用于在上传到当前连接的工作区之前临时存储生成文件的文件夹,可以设置为自动指定的位置(默认安装时为
\Users\<ProfileName>\AppData\Local\Temp\Releases),也可以手动指定为您选择的文件夹。 - 启用 Delete contents after exiting release mode 选项,可在发布过程完成后清空临时存储文件夹。
- 每个生成的输出名称前均可选择添加条目 ID 和修订版 ID 作为前缀(例如
[FAB-Kame_FMU-A.1] Validation.PDF)。为此,请启用 Prepend revision HRID to file names 选项。
按需配置好要在发布过程中创建的数据条目后,单击视图右下角的
按钮以继续。
准备过程中会执行多项发布前检查,包括:
- 确保项目和所有文件均已保存。
- 确保项目和所有相关文件均已提交到 VCS(如适用)。
- 确保每个已启用的数据条目均已命名。
- 确保用户具有创建目标条目(及其修订版)的权限。
- 如果所需的目标条目(及计划修订版)在工作区中尚不存在,则创建它们;对于已存在的条目,确保使用其下一个修订版。
如果发现任何问题,系统会提供相应的解决方法(例如保存本地修改的文件并提交到 VCS)。
此时会生成 Source Data 条目,并将源设计项目文件的快照发布到目标条目修订版。
在线阶段 2 – 验证项目
阶段 1 顺利完成后,如果在分配的 OutJob 文件中检测到一个或多个验证类报告,系统将自动运行发布流程的下一阶段。系统会运行分配给待发布数据条目的输出作业文件中定义的所有验证输出生成器。其中包括运行以下任意检查:
- Differences Report – 使用比较器确定源设计文档与 PCB 设计文档是否正确同步。
- Electrical Rules Check – 检查已绘制的源设计在电气和制图方面的有效性。
- Design Rules Check – 根据指定的板级设计约束,检查 PCB 文档的有效性。
-
BOM Checks – 检查源 BOM 文档(
*.BomDoc,如有)中的设计条目或元件选型是否存在潜在违规情况。 - Footprint Comparison Report – 将板上的封装与其源库进行比较,确保它们为最新版本且相互匹配。
- Component State Checking – 检查是否存在处于受限状态的元件。在配置过程中,您可以针对目标工作区中当前定义的每个生命周期定义的各个状态,指定要采取的操作:不执行任何操作、发出警告或生成错误。生成错误会阻止设计发布。此外,运行此检查还会生成一份实用的 HTML 报告,让您一目了然地查看哪些设计元件未处于有效状态。
- Environment Configuration Compliance Check – 检查是否仅使用了您的指定角色所适用的环境配置允许使用的数据条目(如适用)。此检查还可以确保所有设计条目均来自工作区。
如果验证成功,将显示
图标和文本 Passed。否则,将显示
图标和文本 Failed。
在线阶段 3 – 生成数据
阶段 2 顺利完成后,系统将自动运行发布流程的下一阶段。在此阶段,将运行分配给所含数据条目的 OutJob 文件中定义的所有其他输出,以生成要发布到工作区中相应目标条目的数据。
与其他阶段一样,系统使用图标来显示生成进度;由于此阶段运行时间较长,这些图标的作用也更加明显:
– 尚未运行/生成。
– 正在运行/生成。
– 已成功生成。
– 生成失败。
在线阶段 4 – 审查数据
所有验证检查均通过且输出数据已生成后,您可以在发布流程的此阶段审查生成的数据。

在提交发布并将数据上传到工作区之前,请审查生成的数据,检查一切是否符合预期。
此页面默认以简洁(紧凑)视图显示生成的数据。单击所关注部分对应的 Details 控件,可切换到更详细的视图。

单击 Details 控件,可将相应部分生成数据的视图从简洁视图切换为详细视图。单击 Hide Details 控件可切换回简洁视图。
详细视图中的输出生成状态
下表列出了在详细视图中观察数据生成过程时可能出现的输出状态:
状态 |
说明 |
|---|---|
|
输出尚未生成/不存在。 |
|
输出已生成,但此后设计发生了更改,因此该数据已不再有效。 |
|
正在生成输出。 |
|
该输出为验证类输出,且已生成不含任何错误的报告。对于 ERC 报告,表示不存在错误,或错误级别未超过该报告指定的最大容许错误级别。 |
|
输出(验证类输出除外)已成功生成。 |
|
输出未能成功生成。对于验证类输出,这意味着源设计文档中存在导致某些检查失败的错误。对于标准输出,则表示无法成功生成输出。可能是在执行生成前验证时出现了致命错误,或输出作业文件中相关输出生成器的配置存在问题。 |
在所生成数据的紧凑视图中,单击 View 链接,即可在 Altium Designer 的相应编辑器(例如,用于 Gerber 文件或压缩/未压缩 ODB++ 文件的 CAM 编辑器)或相应的外部应用程序(例如,用于物料清单的 Microsoft Excel)中打开关联的数据文件或文件集。在详细视图中,双击某个条目可仅查看该文件。
许多设计人员常用的一种发布就绪测试,是将当前发布生成的 Gerber 文件与上一次发布的 Gerber 文件进行比较。单击 Gerber 输出旁的 Compare Gerber 链接,然后从下拉菜单中选择先前的发布,即可将准备好的 Gerber 数据与所选 发布中的数据进行比较。默认浏览器将打开您的公司工作区并显示比较结果。

在将数据发布到工作区之前,从 Project Releaser 访问 Gerber 比较功能。
► 了解有关 Gerber Comparison 功能的更多信息(Altium 365 工作区、Enterprise Server 工作区)。
如果在检查数据后发现需要修改,请单击视图右下角的
按钮。此时会出现一个确认对话框,提醒您所有已生成的数据都将丢失。单击 OK 将取消发布,并返回流程的第 1 阶段。
如果生成的所有数据都没有问题,请单击
按钮(同样位于视图右下角)继续发布。此时将出现 Confirm Release 对话框,汇总将要发布到工作区的项目配置。您还可以在此添加 Name(此处的默认条目为 [ProjectName])、Description,并添加任何相关的发布说明。

确认将要发布的内容(即生成的条目修订版),并可更改名称/描述以及添加发布说明。
在线阶段 5 – 上传数据
在上一阶段确认发布后,系统会自动进入此阶段。此阶段仅显示数据上传到工作区中相应数据条目修订版的进度。

此阶段仅显示将生成的数据上传到工作区中所关联条目修订版的进度。
在线阶段 6 – 执行报告
这是流程的最后一个阶段,提供本次发布的汇总信息。
使用导航链接,可在 Explorer 面板(访问工作区的入口)中快速访问包含已发布数据(制造数据、装配数据以及任何自定义数据集)的关联条目修订版。

通过 Explorer 面板,直接在工作区中查看项目已发布的数据。
查看已发布的项目
对于工作区项目,发布完成后还可以使用一项额外功能。单击 Execution Report 页面顶部导航链接中的最后一个链接 Project Page,将打开 Explorer 面板,并在 Project View 中显示项目;此功能仅适用于工作区项目。

借助 Project View,您可以在 Explorer 面板中更详细地浏览工作区 项目。
Releases 区域(位于视图左下角)将集中显示与项目关联的各次项目发布,其中包括每次发布及其组成数据包的摘要。单击此区域中的
按钮,可打开 批量状态更改对话框,通过一次批处理操作,同时更改与同一次发布相关的多个条目的生命周期状态。
还可以通过目标工作区的 Web 查看器访问更多项目发布信息,该查看器可通过 Explorer 面板的
按钮打开。在工作区的 Web 查看器中,可在 Releases 视图中访问与项目关联的所有发布;对于由本地服务器提供的工作区,则可在 Manufacture 视图中访问。该页面列出了所有项目发布,最新的条目位于顶部。通过某次发布的打开按钮(
),可在工作区的 Manufacturing Portal 中打开该发布。Manufacturing Portal 视图提供有关所选发布的更详细信息,包括其组成发布包文件、完整的设计文档集,以及元件制造商和供应商详细信息。请注意,Send to Manufacturer 功能仅在 Altium 365 工作区中可用。► 有关更多信息,请参阅 Altium 365 工作区发布视图页面。
至此,项目已发布,您只需关闭 Release 视图即可(使用视图右下角的
按钮)。将来需要重新发布同一项目时,Project Releaser 可帮助您快速轻松地完成操作,并自动递增目标条目修订版。
发布到 PLM 实例
Related pages: PLM 集成(Altium 365 工作区、Enterprise Server 工作区),发布到 PLM
您可以在 Altium Designer 中运行 Project Releaser 时,将设计发布到 PLM 实例。发布操作使用发布模板来控制数据如何传递到 PLM,该模板在相应 PLM 实例的集成配置中定义。此功能通过经过适当配置的流程提供。安装时提供了一个示例流程定义——Project Releaser with Publish——其底层工作流可将发布到已集成的 PLM 实例作为项目发布器的附加阶段。工作流图如下所示。

默认 Project Releaser with Publish 示例流程定义的工作流图
激活后,即可在 Altium Designer 中,通过当前活动项目的 Project » Project Releaser 子菜单,或通过 Project Releaser 右键子菜单,访问作为 Project Releaser 一部分的发布到 PLM 实例的流程。要打开该右键子菜单,请在 Projects 面板中右键单击设计项目条目。
一部分的发布到 PLM 实例的流程Project Releaser 将会显示,并新增一个阶段——7. Publish to PLM。此外,
按钮关联的菜单中还提供了 Prepare & Release & Publish to PLM 命令,供您运行 Project Releaser,而不暂停以检查生成的数据和执行报告。

用于运行 Project Releaser 而不暂停以检查生成的数据和执行报告的附加命令
如果使用标准的 Prepare 命令运行 Project Releaser,则在检查并发布数据后,Execution Report 阶段会显示
按钮。单击此按钮可继续执行该流程的底层工作流,以发布到 PLM。随后会显示 Login Credentials 对话框。输入 PLM 实例的 Username 和 Password,并选择要使用的 PLM 模板(以 <PLMInstance>:<PublishingTemplate> 的形式显示)。

首次发布到 PLM 实例时显示的 Login Credentials 对话框。
单击 Diagram 选项卡可查看该流程的底层工作流。

Login Credentials 对话框的 Diagram 选项卡
单击
按钮,按照该工作流继续执行发布流程。

)。为避免潜在问题,建议将与项目关联的所有文档都存储在项目文件夹或其子文件夹中。



