Altium Designer Documentation

ConvertToManagedObject

Modified by Jason Howie on Jun 26, 2017

Parent page: UnifiedComponent Commands

The following pre-packaged resource, derived from this base command, is available:


Applied Parameters: None

Summary

This command is used to create a Managed Project from an existing non-managed one. Managed Projects target the development stage of the project lifecycle, simplifying the creation and ongoing workflow for version controlled projects. Centralized storage under the control of the Altium Vault also enables this feature to be a foundation for other collaborative services. Some key benefits to using Managed Projects are:

  • Simplified storage. No need to make decisions about storage locations. Backup and other basic services are taken care of.
  • Foundation for collaborative features.
  • Enforced version control.
  • Beneficiary of a dedicated commenting system.
  • Notifications and status. Document status including local modifications is visible to entire design teams.
  • Concurrent PCB design works without any complex setup.
The beauty of Managed Projects is that they are version controlled by default, and can be collaboratively worked upon without having to worry about shared drives, servers, agreements etc.

Access

This command is accessed by right-clicking over the entry for a non-managed project in the Projects panel, and choosing the Convert to Managed Project command from the context menu.

If the Convert to Managed Project option is not available from the menu, it means that the project is currently under Version Control (in a local or network VCS Design Repository), or has been so in the past.

This can be resolved by creating a 'clean' copy of the project (one not associated with VCS) in another local folder and converting that version to a Managed Project.

  1. Open the project in Altium Designer:
    • For a project currently under Version Control, use File » Checkout to open (check out) the project from its VCS repository to a local working folder.
    • For a project that is no longer under Version Control, use File » Open Project to locate and open the project from its local folder.
  2. Use the Project Packager (Project » Project Packager) to create a single zip file of the project, which by default, will be stored in the project's local source directory - typically, a path such as C:\Users\Public\Documents\Altium\Projects\MyProject.
  3. In the operating system, create a local working folder specifically for Managed Projects, for example: C:\Users\Public\Documents\Altium\ManagedProjects.
  4. Move the project's packaged zip file to the new folder (...\ManagedProjects) and extract its contents: right-click - Extract All and rename to suit. The resulting path to the duplicated project folder would therefore be C:\Users\Public\Documents\Altium\ManagedProjects\MyProject.
  5. If the project was previously a Managed Project, open its Project file (*.PrjPcb) in a text editor such as Windows Notepad and delete the ManagedProjectGUID= entry, which can be found under the first [Design] section. Save the edited Project file.
  6. Back in Altium Designer, navigate to and open (File » Open Project) the newly duplicated project from its folder – that is, from where the project was unzipped.
  7. Right click on the project file and select the Convert to Managed Project command, which should now be available.

Use

Prior to converting an existing non-managed project, ensure that a Design Repository exists in which to store that project, and all future projects. Design Repositories are centrally managed as part of the Altium Vault. Such repositories can be created through the local SVN Service - part of your Altium Vault installation. Alternatively, you can connect to an external repository.

After launching the command, the Convert to Managed Project dialog will appear. This dialog operates in the following two modes:

  • Simple Mode - determine the project's name, and a description. By default, the name will be that of the original project.
  • Advanced Mode - provides access to the managed Design Repository. Choose from all managed repositories shared with the current user signed in to the Altium Vault, as defined on the VCS page of the Vault's browser interface. The repository path and directory therein are shown, the latter of which can be modified as required (by default a folder of the same name as the project will be created within the repository). The path to the local working copy of the project is also reflected.

Once you have defined the properties for the Managed Project as required, click OK. The Add to Version Control dialog will open, with all pertinent files selected for addition. Check all is as required and click OK. Once added, the Projects panel will reflect the fully synchronized state that exists between the files in the repository and the local working copy.

The newly-converted Managed Project will subsequently be available from the PROJECTS page of the Vault's browser interface.

Tips

  1. The project will initially be shared with the designer who converted it, all Administrators for the Altium Vault, and publically - all users of the Vault can view (but not edit unless the owner/admin). To make it accessible to others simply share it, by configuring its permissions. Sharing can be performed directly from within Altium Designer, or by navigating to the project and setting Share permissions from the Projects page of the Altium Vault's browser interface.

 

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

联系我们

联系原厂或当地办公室

You are reporting an issue with the following selected text
and/or image within the active document:
Altium Designer 免费试用
Altium Designer Free Trial
我们开始吧!首先,您或者您的公司已经在使用Altium Designer了吗?

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

既然您在使用Altium Designer,为何仍需要试用?

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

好的,实际上您无需下载一个试用版本。

点击下方按钮下载最新版本的Altium Designer安装包

下载Altium Designer 安装包

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

填写下方表格,获取Altium Designer最新报价。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

如果您是Altium维保期内客户,您不需要下载试用版本。

如果您不是Altium维保客户,请填写下方表格免费试用。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

您为何想要试用Altium Designer?

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

那您来对地方了!请填写下方表格申请试用吧。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

Great News!

Valid students can get their very own 6-month Altium Designer Student License for FREE! Just fill out the form below to request your Student License today.

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

好的,您可以下载免费的Altium Designer Viewer查看文档,有效期6个月。

请填写下方表格申请。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

好棒!创作是一件超酷的事情,我们可以为您提供完美的设计软件。

Upverter是一个社区导向的交流平台,专为您这样的创客量身定做。

点击这里看看吧!

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

好的,您可以下载免费的Altium Designer Viewer查看文档,有效期6个月。

请填写下方表格申请。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。