Erstellen und Pflegen Ihrer Komponenten und Bibliotheken
Ein Elektronikdesign besteht aus einer Vielzahl miteinander verbundener Bauteile. Das Spannende an der Produktentwicklung ist, kreative Lösungen für technische Herausforderungen zu finden und diese Bauteile zu einem einzigartigen Design zu verbinden.
Ein großer Teil der Arbeit – und für viele Entwickler der mühsamere Teil – besteht jedoch darin, die Bauteile zu erstellen. Auch wenn dies nicht besonders aufregend ist, werden die Bauteile zu einer wertvollen Ressource für Ihr Unternehmen. Deshalb ist es unerlässlich, dass sie die realen Bauteile exakt abbilden.
Das Bauteil, das Sie kaufen und auf die Leiterplatte löten oder in einem Kabelbaum verwenden, ist das reale Bauteil. Dieses muss jedoch für jeden Bereich des Elektronikdesigns modelliert werden, in dem Sie es einsetzen möchten.
Je nachdem, welche Art von Design Sie umsetzen möchten, kann Ihr Bauteil ein Schaltplansymbol, ein Simulationsmodell für den Schaltungssimulator, ein IBIS-Modell für die Signalintegritätsanalyse, ein Anschlussmuster oder einen Footprint für das Leiterplattenlayout und ein 3D-Modell für die Visualisierung, die 3D-Abstandsprüfung sowie den Export in die mechanische CAD-Umgebung enthalten.
Bauteilverwaltung
Die effektive Verwaltung von Bauteildaten ist für das Elektronikdesign unverzichtbar. Die Verwaltung der in einem Design verwendeten Bauteile war schon immer ein grundlegender Bestandteil der Designsoftware von Altium. Mit der Weiterentwicklung der Software über die Jahre haben sich auch die Methoden zur Bauteilverwaltung erheblich weiterentwickelt: von einfachen, separaten Bibliotheken für Schaltplan- und Leiterplattenmodelle über Datenbankbibliotheken bis hin zu Workspace-Bauteilen, die Designbauteile im gesamten Produktentwicklungsprozess verfügbar machen. Hinzu kommen modernste, benutzerfreundliche Funktionen für eine herausragende Zusammenarbeit während des gesamten Designprozesses.
| Workspace-Bibliothek | Bauteile werden in einem verbundenen Workspace gespeichert, der Ihrem gesamten Designteam eine zentrale Quelle für aktuelle und standardisierte Bauteildaten bietet. Dank parametrischer Suche und Facettensuche können Sie die benötigten Bauteile schnell und effizient finden und platzieren. Diese Bauteile sind eng mit den tatsächlich gefertigten Bauteilen und den bereits während des Designs verfügbaren Lieferkettendaten verknüpft. Das ermöglicht erhebliche Einsparungen bei Beschaffungskosten und -zeit für die Fertigung des bestückten Produkts. |
|
| Datenbankbibliothek | Möchten Sie Ihre Designbauteile eng mit Ihrer Unternehmensdatenbank verknüpfen? Dann sollten Sie sich Datenbankbibliotheken ansehen. Jeder Datensatz steht für ein Bauteil und verweist auf die erforderlichen Modelle und parametrischen Bauteildaten. Beim Platzieren werden die Modellverknüpfungen und Parameter zum Symbol hinzugefügt, wodurch es zu einem Altium Designer-Bauteil wird. | |
| SVN-Datenbankbibliothek | Eine SVN-Datenbankbibliothek ist eine Erweiterung des Datenbankbibliotheksmodells. Der Unterschied besteht darin, dass die Quellsymbole und -modelle unter Versionskontrolle gespeichert werden. Die Quellbibliotheken werden in einem Subversion-basierten Repository erstellt, ergänzt und gepflegt. Die Verknüpfung zum Repository und zur externen Datenbank wird in einer SVN-Datenbankbibliotheksdatei (*.SVNDbLib) definiert. |
|
| Datenbankverknüpfung | Bei dieser Methode definiert die Datenbankverknüpfungsdatei (*.DbLink) die Verknüpfung zwischen dem Schaltplanbauteil und einem entsprechenden Datensatz in einer Datenbank. Die Zuordnung des Datensatzes erfolgt über Schlüsselfelder. Dabei kann ein einzelnes Schlüsselfeld verwendet werden, beispielsweise eine Teilenummer, oder mehrere Schlüsselfelder, indem eine WHERE-Klausel definiert wird. |
|
| Integrierte Bibliothek | Möchten Sie Ihre Bauteile vorab gebündelt und geprüft in einer einzigen Datei bereitstellen? Dann kompilieren Sie die Schaltplan-, Leiterplatten- und Simulationsquellmodelle, um eine integrierte Bibliothek (*.IntLib) zu erzeugen. |
|
| Schaltplanbibliothek | Eine Schaltplanbibliothek (*.SchLib) kann als Modellbibliothek dienen, die Bauteilsymbole enthält. Werden jedem Symbol Modellverknüpfungen und parametrische Daten hinzugefügt, wird daraus eine Bauteilbibliothek. |
|
| Leiterplattenbibliothek | Eine Bibliothek zum Speichern von Leiterplatten-Footprint-Modellen (*.PcbLib). Bei Bedarf kann jedem Footprint ein 3D-Modell hinzugefügt werden. 3D-Modelle werden aus 3D-Körperobjekten erstellt oder als STEP-Modell in ein 3D-Körperobjekt importiert. |
Workspace-Bibliothek
Bauteile werden in Ihrem Workspace gespeichert – einem zentralen, sicheren Speicherort für all Ihre Designdaten, auf den Ihr gesamtes Designteam zugreifen kann. Die Nutzung von Bauteilen, die in einem Workspace bereitgestellt werden, bietet zahlreiche Vorteile. Dazu gehören:
-
Single source of component data – Da der Workspace dem gesamten Team zugänglich ist, können Entwickler aktuelle und standardisierte Bauteile aus einer zentralen, sicheren Quelle beziehen, Lieferkettendaten in Echtzeit abrufen und mithilfe der parametrischen Suche und Facettensuche genau die benötigten Bauteile finden.
-
Design-time choice of physical components – Für jedes Bauteil können Sie festlegen, welche Herstellerteile bei der Bestückung der Leiterplatte zur Umsetzung dieses Bauteils verwendet werden dürfen.
-
Real-time supply-chain information – Die Informationen werden aus der zusammengeführten Bauteildatenbank des Altium Parts Provider zurückgemeldet, die ihrerseits mit aktivierten Lieferanten verbunden ist und deren Bauteildaten erfasst. So erfährt der Entwickler die aktuellen Preise und die Verfügbarkeit der ausgewählten Bauteile bei allen Anbietern, die diese Bauteile verkaufen, wie im lokalen Teilekatalog des Workspace definiert. Diese Informationen können einem Bauteil jederzeit hinzugefügt werden, auch nachdem es im Workspace gespeichert wurde – ohne es direkt zu bearbeiten und somit ohne Auswirkungen auf Designs, in denen es bereits verwendet wird. Anschließend können sie als Bestandteil einer Stückliste genutzt werden.
-
Concurrent editing of the library – Da die Workspace-Bibliothek im Wesentlichen aus einer Sammlung von Bauteil-Items besteht, die in diesem Workspace gespeichert sind, können mehrere Benutzer unabhängig voneinander Bauteile für die Workspace-Bibliothek bearbeiten oder neu erstellen, ohne darauf warten zu müssen, dass andere Benutzer ihre Arbeit abschließen.
-
Component Models Reuse – Ein Bauteil lässt sich als „Container“ verstehen, in dem alle parametrischen Informationen und bereichsspezifischen Modelle zusammengeführt werden, darunter Schaltplansymbole, Leiterplatten-Footprints, Kabelbaumverdrahtung und Simulationsmodelle. Das Bauteil enthält nicht die bereichsspezifischen Modelle selbst, sondern Verknüpfungen zu den entsprechenden Modell-Items, die ebenfalls in einem Workspace gespeichert sind. Dadurch kann ein Modell von mehreren Bauteilen verwendet werden. Wenn sich ein Modell ändert, wird Ihnen vorgeschlagen, alle Bauteile zu aktualisieren, die dieses Modell verwenden. So wird sichergestellt, dass kein Bauteil ein veraltetes Modell verwendet.
-
Direct Component Editing – Wenn ein Bauteil bearbeitet werden muss, können Sie es direkt aus Ihrem Workspace zur Bearbeitung öffnen. Eine temporäre Instanz des Bauteileditors ermöglicht es Ihnen, alle Aspekte des Bauteils zu bearbeiten, einschließlich der referenzierten bereichsspezifischen Modelle – ganz ohne dateibasierte Dokumente.
-
Use of Component Templates – Wenden Sie Vorlagen auf Basis von Parametern und Bauteiltaxonomien an, damit jeder neue Bauteiltyp automatisch den richtigen, stücklistenkonformen Parametersatz erhält. Gleichzeitig werden die korrekten Benennungs-, Revisions- und Lebenszyklusschemata automatisch angewendet.
-
Component Lifecycle Validation – Wenn sich ein Bauteil im Status „Ende der Lebensdauer“, „Abgekündigt“ oder „Aufgegeben“ befindet, erhalten Sie eine Warnung, bevor Sie Leiterplatten fertigen lassen, die dieses Bauteil verwenden.
-
Where-used Component Traceability – Die Verwendung von Bauteilen lässt sich lückenlos nachverfolgen: Wird ein Bauteil abgekündigt, können Sie ermitteln, in welchen Designs es verwendet wurde, und erkennen, welche Designs aktualisiert werden müssen. Enthält ein Symbol oder Footprint einen Fehler, können Sie alle Bauteile anzeigen, die dieses Symbol oder diesen Footprint verwenden, um sie zu korrigieren.
-
Requests of new components – Entwickler können Anfragen für neue oder fehlende Bauteile an die zuständigen Bibliotheksverantwortlichen senden. Sie werden benachrichtigt, sobald das Bauteil für ihre Designs und die anderer Entwickler im Unternehmen verfügbar ist.
Erstellen eines neuen Bauteils in der Workspace-Bibliothek
Das physische Bauteil, das auf der Leiterplatte montiert oder bei der Fertigung des Kabelbaums verwendet wird, wird bei der Schaltplaneingabe als Schaltplansymbol und beim Leiterplattenentwurf als PCB-Footprint dargestellt (optional mit einem 3D-Modell zur Visualisierung, 3D-Abstandsprüfung und zum Export in die mechanische CAD-Umgebung). Ein Designbauteil kann außerdem ein Simulationsmodell für den Schaltungssimulator und ein IBIS-Modell für die Signalintegritätsanalyse enthalten. Um Designbauteile auch im erweiterten Produktentwicklungsumfeld abzubilden, können ihnen eine oder mehrere Bauteiloptionen hinzugefügt werden.
Bauteile für Ihr Designprojekt können in der Workspace-Bibliothek Ihres Unternehmens erstellt und abgelegt werden. Sie werden über das Bedienfeld Components platziert, das die erweiterte Bauteilsuchmaschine von Altium Designer verwendet.
Ein neues Bauteil in der Workspace-Bibliothek wird mit dem Bauteileditor erstellt. Dort können Sie alle Bauteildaten (Domänenmodelle, Parameter, Bauteiloptionen usw.) manuell definieren oder Daten verwenden, die aus dem Bedienfeld Manufacturer Part Search abgerufen wurden.
So erstellen Sie ein neues Bauteil in der Workspace-Bibliothek:
-
Wählen Sie einen Befehl zur Bauteilerstellung. Dieser ist wie folgt zugänglich:
-
Wählen Sie den Befehl File » New » Component aus den Hauptmenüs.
-
Wählen Sie File » New » Library aus den Hauptmenüs und anschließend im sich öffnenden Dialog New Library die Option Create Library Content » Component im Bereich Workspace des Dialogs.
-
Klicken Sie im Bedienfeld „Components“ mit der rechten Maustaste in den Bereich der Bauteilliste und wählen Sie den Befehl Create aus dem Kontextmenü.
-
-
Wählen Sie im sich öffnenden Dialog Create new component einen Bauteiltyp aus. Wenn eine Bauteilvorlage mit dem ausgewählten Bauteiltyp verknüpft ist, wird das Bauteil anhand der Daten aus dieser Vorlage vordefiniert.

Öffnen Sie den Dialog Create new component, um den Typ des zu erstellenden Bauteils auszuwählen. -
Nach einem Klick auf OK öffnet sich der Bauteileditor im Modus zur Einzelbauteilbearbeitung. Er bietet eine übersichtliche Oberfläche zum Definieren und Bearbeiten eines einzelnen Bauteils.
-
Definieren Sie das Bauteil, indem Sie seine Angaben im Bauteileditor hinzufügen:
- Definieren Sie im Bereich Component des Bauteileditors die Angaben Name und Description des Bauteils. Diese Angaben sind für die spätere Bauteilsuche wichtig, wenn Sie ein benötigtes Bauteil in Ihrem Designprojekt verwenden möchten.
-
Klicken Sie auf das Steuerelement Advanced Settings, um weitere Bauteilangaben zu definieren oder zu ändern, beispielsweise die Angabe Id, die für das im Workspace gespeicherte Bauteil verwendet wird, sowie Folder im Ziel-Workspace, in dem das Bauteil gespeichert wird.
-
Definieren Sie im Bereich Parameters des Bauteileditors weitere Bauteilangaben: Standardparameter, URL-Links zu Webseiten (beispielsweise zur Website eines Herstellers) und Links zu Datenblättern (in beliebigen Formaten).
-
Geben Sie im Bereich Part Choices des Bauteileditors eine oder mehrere Bauteiloptionen für das Bauteil an – die „zulässigen“ Herstellerbauteile, mit denen das Bauteil auf der bestückten Leiterplatte realisiert werden kann.
-
Fügen Sie im Bereich Models des Bauteileditors Verknüpfungen zu gespeicherten (oder direkt erstellten) Domänenmodellen hinzu, die vom Bauteil verwendet werden sollen. Ein Bauteil kann ein Schaltplansymbol und mehrere PCB-Footprint- und Simulationsmodelle oder ein Kabelbaumverdrahtungsmodell besitzen. Ein Bauteil muss mindestens ein Modell besitzen.
-
Prüfen Sie das definierte Bauteil, um sicherzustellen, dass es die Anforderungen gemäß den Einstellungen auf der Seite „Data Management – Component Rule Checks“ des Dialogs Preferences erfüllt. Speichern Sie Ihr Bauteil lokal (File » Save) und wählen Sie anschließend den Befehl Tools » Component Rule Check aus den Hauptmenüs. Alle gefundenen Verstöße werden im Bedienfeld Messages aufgelistet.
-
Nachdem das Bauteil definiert wurde, wählen Sie den Befehl File » Save to Server aus den Hauptmenüs, um das Bauteil im Workspace zu speichern. Der Dialog Edit Revision wird angezeigt. Darin können Sie den Namen und die Beschreibung ändern sowie bei Bedarf Freigabehinweise hinzufügen. Der Editor wird nach dem Speichern geschlossen.
Ihr neues Bauteil steht anschließend im Bedienfeld „Components“ zum Suchen und Verwenden bereit.
Hinweise
-
Um ein neues Bauteil zu erstellen, das einem vorhandenen Bauteil in Ihrem Workspace ähnelt, können Sie dieses Bauteil kopieren. Suchen Sie im Bedienfeld Components nach dem gewünschten Bauteil, klicken Sie mit der rechten Maustaste darauf und wählen Sie den Befehl Operations » Make a copy aus. Der Bauteileditor öffnet sich mit einem Bauteil, das anhand der Daten des ausgewählten Bauteils vordefiniert ist.
-
Eine Komponente kann anhand von Daten definiert werden, die von der Funktion „Manufacturer Part Search“ bereitgestellt werden. Beginnen Sie mit der Eingabe im Feld Name und wählen Sie ein passendes Herstellerbauteil aus oder fügen Sie der zu definierenden Komponente eine Bauteiloption hinzu. Daraufhin wird der Dialog „Use Component Data“ geöffnet. Er bietet Steuerelemente zur Auswahl der Daten, die Sie auf die gerade erstellte oder bearbeitete Komponente anwenden möchten: Name, Beschreibung, Parameter, Modelle und Datenblätter.

Komponentendaten können aus der Herstellerbauteilsuche übernommen werden. Hier wird beispielhaft gezeigt, wie Sie auf diese Funktion zugreifen, indem Sie einen Komponentennamen in das Feld Name eingeben und einen passenden Eintrag aus der eingeblendeten Liste auswählen. -
Der Komponenteneditor kann auch im Modus zur Stapelbearbeitung von Komponenten arbeiten, der eine Benutzeroberfläche zum Definieren und Bearbeiten mehrerer Komponenten bietet. Wenn sich der Komponenteneditor im Single Component Editing Modus befindet, können Sie über den Befehl Tools » Switch to Batch Editor in den Hauptmenüs des Editors auf den Stapelbearbeitungsmodus zugreifen.
-
Um Ihre vorhandenen dateibasierten Bibliotheken und Datenbankbibliotheken (SchLib, PcbLib, IntLib, DbLib, SVNDbLib) schnell in den Workspace zu importieren, können Sie den Library Importer verwenden. Der Library Importer bietet eine Ein-Klick-Lösung, die die ausgewählten Bibliotheken automatisch analysiert und in den Workspace importiert, mit dem Sie aktuell verbunden sind.
-
Eine neue Komponente kann auch erstellt werden, indem Sie im Projects Panel mit der rechten Maustaste auf den Eintrag des verbundenen Workspace klicken und im Menü den Befehl Create Component auswählen.
-
Um eine Workspace-Komponente zu bearbeiten, klicken Sie im Components-Panel mit der rechten Maustaste auf den Eintrag einer Komponente und wählen Sie im Kontextmenü den Befehl Edit. Der Komponenteneditor wird im Single Component Editing Modus geöffnet, wobei die Komponentendefinition zur Bearbeitung bereitsteht. Nehmen Sie die erforderlichen Änderungen vor und speichern Sie die Komponentendefinition anschließend als nächste Revision der Workspace-Komponente.
-
Auf die gleiche Weise können Sie im Components-Panel mehrere Komponenten auswählen und im Kontextmenü den Befehl Edit wählen. Wenn die ausgewählten Komponenten auf dieselbe Komponentenvorlage verweisen, wird eine einzelne Instanz des Komponenteneditors im Modus zur Stapelbearbeitung von Komponenten geöffnet. Andernfalls wird für jede Gruppe von Komponenten, die dieselbe Komponentenvorlage verwenden, eine separate Instanz des Komponenteneditors geöffnet.
-
Zur Bearbeitung geöffnete Workspace-Komponenten werden unter dem Eintrag Workspace Components im Projects Panel angezeigt.
Über das Kontextmenü des Eintrags Workspace Component können Sie die Komponenten der Gruppe öffnen, schließen, lokal speichern, im verbundenen Workspace speichern oder Änderungen verwerfen (ohne Änderungen schließen)
. Wenn Sie den Befehl Close All verwenden und mehrere Komponenten der Gruppe geändert wurden, wird ein Dialog zur Bestätigung des Speicherns angezeigt. Dieser bietet Entscheidungsoptionen für die Arbeit mit einem zur Bearbeitung geöffneten Workspace-Objekt
-
Wenn Sie als Benutzer mit reinen Leseberechtigungen versuchen, eine Workspace-Komponente zur Bearbeitung zu öffnen, wird der Komponenteneditor geöffnet und ermöglicht Ihnen den Zugriff auf die Komponentendetails. Änderungen können jedoch nicht im Workspace gespeichert werden. In diesem Fall wird der Eintrag dieser Workspace-Komponente im Projects Panel mit der Kennzeichnung Local Edits Only angezeigt
-
Beim Speichern einer bearbeiteten Komponente in Ihrer Workspace-Bibliothek können Sie den aktuellen Lebenszyklusstatus der Komponente beibehalten. Dies wird über die Option Preserve lifecycle state (not recommended) gesteuert, die beim erneuten Speichern im Dialog Edit Revision verfügbar ist (Bild anzeigen). Wenn sie aktiviert ist, wird die neue Komponentenrevision automatisch auf den Lebenszyklusstatus der vorherigen Revision gesetzt. Diese Funktion steht Benutzern zur Verfügung, denen die Berechtigung für den Vorgang Allow to skip lifecycle state change for new revisions zugewiesen wurde (weitere Informationen finden Sie unter Festlegen globaler Berechtigungen für Vorgänge in einem Workspace).
Datenbankbibliotheken
Altium Designer bietet die Möglichkeit, Komponenten direkt aus einer Unternehmensdatenbank zu platzieren, indem Sie eine Database Library erstellen und verwenden. Die Platzierung erfolgt über das Components Panel, das nach der Installation einer Datenbankbibliothek als Browser für Ihre Datenbank dient.
Nach der Platzierung können die Informationen zu Designparametern zwischen den platzierten Komponenten und den entsprechenden verknüpften Datensätzen in der Datenbank synchronisiert werden. Vollständige Komponentenaktualisierungen – einschließlich des grafischen Symbols, der Modellreferenzen und der Parameter – sind möglich. Parameterinformationen aus der Datenbank können auch in die endgültige Stückliste (BOM) für die Komponentenbeschaffung aufgenommen werden.
Lesen Sie mehr über Datenbankbibliotheken.
Dateibasierte Bibliotheken
Wenn Sie Ihre Komponenten lokal in Ihrem Dateisystem speichern müssen, können Sie sie in dateibasierten Bibliotheken organisieren.
Eine dateibasierte Bibliothek in Altium Designer ist eine beliebige Sammlung von Modellen oder Komponenten. Wie die Modelle oder Komponenten in Bibliotheken organisiert werden, entscheiden Sie selbst. Sie können Ihre Bibliotheken nach Bauteillieferanten strukturieren oder Komponenten nach ihrer Funktion gruppieren, beispielsweise in einer Bibliothek für alle Mikrocontroller, die Ihr Unternehmen verwendet.
Schaltplansymbole für Komponenten werden in Schaltplanbibliotheken (*.SchLib) erstellt. Die Komponenten in diesen Bibliotheken verweisen dann auf Footprints und andere Modelle, die in separaten Footprint-Bibliotheken (*.PcbLib) und Modelldateien definiert sind. Als Entwickler können Sie Komponenten aus diesen einzelnen Komponentenbibliotheken platzieren oder die Symbolbibliotheken, Footprint-Bibliotheken und Modelldateien zu integrierten Bibliotheken (*.IntLib) kompilieren.
Lesen Sie mehr über Dateibasierte Komponentenbibliotheken.
Modelle
Aus Sicht eines Entwicklers fasst eine Komponente alle Informationen, die zur Darstellung dieser Komponente in sämtlichen Designbereichen erforderlich sind, in einem einzigen Objekt zusammen. In dieser Hinsicht kann sie daher als Container betrachtet werden.
Jede Komponente ist eine Sammlung verknüpfter Modelle und parametrischer Komponentendaten. Die Modelle enthalten die detaillierten Informationen, die der jeweilige Designbereich benötigt.
Die folgenden Modelltypen können verwendet werden:
| Schaltplansymbol | Das Symbol stellt die Komponente auf dem Schaltplanblatt dar. Es wird mithilfe von Standard-Zeichenobjekten erstellt; die Pins ergänzen die elektrischen Eigenschaften. |
| SPICE-Modell | Simulieren Sie das Verhalten der verbundenen Komponenten mit dem SPICE-Simulator. SPICE-Modelle werden in der Regel von Bauteillieferanten bereitgestellt. |
| Signalintegritätsmodell | Mit zunehmenden Schaltgeschwindigkeiten von Bauteilen und Schaltungen werden die Verbindungen auf der Leiterplatte selbst zu einem Teil der Schaltung. IBIS-Modelle beschreiben das Verhalten der Pins und ermöglichen es dem Signalintegritätssimulator von Altium Designer, die Leiterbahnen zu analysieren. |
| PCB-Footprint | Für jede Komponente muss ein Bereich auf der Leiterplatte definiert sein, an dem sie montiert und angeschlossen wird – der Footprint ist das Modell, das diesen Bereich auf der Leiterplatte definiert. Ein PCB-Footprint wird aus einer Reihe von Standardobjekten erstellt, wobei die Pads die elektrische Verbindung herstellen. |
| 3D-Modell | Heutige elektronische Produkte sind kompakt und dicht bestückt, haben ungewöhnliche Formen und enthalten mitunter eine Leiterplatte, die gefaltet ist, damit sie in das Gehäuse passt. Um ein solches Produkt zu entwickeln, müssen Sie die Leiterplatte in 3D modellieren können – so können Sie die fertige Leiterplatte visualisieren, eine 3D-Abstandsprüfung durchführen und die bestückte Leiterplatte in die mechanische CAD-Umgebung übertragen. Dafür benötigen Sie ein 3D-Modell jedes Bauteils. |
Lesen Sie mehr über das Erstellen und Verwalten von Symbolen, Footprint-Modellen, Simulationsmodellen und 3D-Modellen in Ihrem Workspace.
Das Bedienfeld „Components“
Das Bedienfeld Components bietet in Altium Designer direkten Zugriff auf alle verfügbaren Bauteile, einschließlich Bauteilen aus dem Workspace sowie aus datenbank- und dateibasierten Bibliotheken.
Das Bedienfeld bezieht Bauteile aus einem Workspace und allen geöffneten oder installierten Bibliotheksdateien. Es bietet umfassende Details zum ausgewählten Bauteil (Parameter, Modelle, Bauteiloptionen, Lieferantendaten usw.), einen Bauteilvergleich und für Workspace-Bauteile eine filterbasierte parametrische Suche, mit der Sie die gewünschten Bauteilparameter festlegen können. Mithilfe kontextbezogener dynamischer Filter können Sie über die Suchfunktion des Bedienfelds schnell genau das benötigte Bauteil im verbundenen Workspace Ihres Unternehmens finden.
Lesen Sie mehr über das Bedienfeld „Components“.
Das Bedienfeld „Manufacturer Part Search“
Über das Bedienfeld Manufacturer Part Search können Sie auch nach tatsächlich erhältlichen Herstellerbauteilen suchen. Es verwendet die grundlegende Suchfunktion und Ansicht des Bedienfelds Components. Ein ausgewähltes Herstellerbauteil kann als Grundlage für ein neues Bauteil in Ihrem verbundenen Workspace dienen. Alternativ können seine Parameter und Datenblätter einem platzierten Bauteil hinzugefügt werden.
Das
Symbol in einem Bauteileintrag zeigt an, dass diesem Bauteil Modelle (Schaltplansymbole, PCB-Footprints, Simulationsmodelle) zugeordnet sind. Wenn Sie auf Basis dieses Herstellerbauteils ein neues Bauteil erstellen, werden auch dessen Modelle übernommen. Alternativ können Sie dieses Bauteil lokal herunterladen oder direkt in Ihrem Schaltplan platzieren.
Lesen Sie mehr über das Bedienfeld „Manufacturer Part Search“.
Wie geht es weiter?
Ein Schaltplansymbol erstellen
Ein Kabelbaum-Verdrahtungsbauteil erstellen



).
).



