Erstellen von Pad- und Via-Vorlagen und -Bibliotheken
Auf einen Blick
- Erfahren Sie, wie Sie eine Bibliothek von Grund auf oder aus Pads und Vias einer vorhandenen Leiterplatte erstellen.
- Lernen Sie, wie Sie Pad- und Via-Vorlagen hinzufügen, löschen und bearbeiten.
- Entdecken Sie die Konfigurationsmöglichkeiten für Bohrungsabmessungen, Masken, Pad- und Via-Stacks sowie Einstellungen für Wärmefallen.
Neben Leiterbahnobjekten sind Pads und Vias grundlegende Elemente aller Leiterplattenentwürfe. Um die Wiederverwendung und Verwaltung von Pads und Vias in PCB-Designs zu verbessern, unterstützt Altium Designer Bibliotheken mit Pad- und Via-Vorlagen.
Das Konzept von Pad- und Via-Vorlagen, die in einer Bibliothek zusammengefasst werden können, ähnelt dem von PCB-Footprint-Bibliotheken, ist jedoch etwas einfacher. Die Pad-/Via-Vorlagenbibliothek speichert keine tatsächlichen Pads und Vias, sondern vorkonfigurierte Definitionen, die beim Platzieren auf eine Pad- oder Via-Instanz angewendet werden. Gespeicherte Pad-/Via-Vorlagenbibliotheken können geladen und verwendet werden, um Instanzen vordefinierter Pads und Vias in beliebigen PCB-Designs oder PCB-Footprints zu platzieren.
Pad-/Via-Vorlagenbibliotheken sind ein weiterer Typ von Designdokumenten, die in Altium Designer erstellt werden können. Sie haben die Dateierweiterung *.PvLib. Pad-/Via-Vorlagenbibliotheken können als Projektdokument eingebunden werden. In diesem Fall stehen ihre Vorlagen dem Projekt stets über das Panel PCB Pad Via Templates zur Verfügung. Vorlagenbibliotheken können auch im Panel installiert werden und stehen damit allen geöffneten Projekten zur Verfügung. Weitere Informationen dazu, wie Sie Vorlagen verfügbar machen, finden Sie auf der Seite Arbeiten mit Pad-/Via-Vorlagen.
Pad- und Via-Vorlagen werden durch Öffnen einer PvLib-Datei erstellt und bearbeitet. Die Pad- und Via-Vorlagen in der PvLib werden im Panel Pad Via Library aufgelistet. Die ausgewählte Pad- oder Via-Vorlage wird im Pad-/Via-Vorlageneditor angezeigt, wie unten dargestellt.
|
Sowohl Pad- als auch Via-Vorlagen werden durch Öffnen der PvLib-Datei bearbeitet. Die Editoroptionen passen sich dem Typ des bearbeiteten Objekts an. Hier ist der Pad-Vorlageneditor dargestellt. Sowohl Pad- als auch Via-Vorlagen werden durch Öffnen der PvLib-Datei bearbeitet. Die Editoroptionen passen sich dem Typ des bearbeiteten Objekts an. Hier ist der Via-Vorlageneditor dargestellt. |
Erstellen einer Pad-/Via-Vorlagenbibliothek
Eine neue Pad-/Via-Vorlagenbibliothek kann auf folgende Weise erstellt werden:
-
Wählen Sie den Befehl File » New » Library in den Hauptmenüs und anschließend die Option Pad Via Library im Bereich File des sich öffnenden Dialogfelds New Library. Klicken Sie dann auf Create. Die neue Pad-/Via-Vorlagenbibliothek erhält den Standardnamen
PvLib1.PvLib. Zu diesem Zeitpunkt wurde die Datei noch nicht auf der Festplatte gespeichert; sie befindet sich nur im Arbeitsspeicher des Computers. Da sie noch nicht gespeichert ist, wird beim ersten Speichern das Dialogfeld Save As geöffnet. Darin wird vorgeschlagen, sie unter Default Location zu speichern, wie auf der Seite System – Standardspeicherorte des Dialogfelds Preferences festgelegt. -
Eine neue Pad-/Via-Vorlagenbibliothek kann auch zum aktuellen Projekt hinzugefügt werden, indem Sie im Panel Projects mit der rechten Maustaste auf das Projekt klicken und im Kontextmenü Add New to Project » Pad Via Library auswählen. Die Datei wird im Ordner
Libraries/Pad Via Library Documentsder Projektstruktur angezeigt. Beim Speichern der Datei wird standardmäßig der Projektordner als Speicherort verwendet. -
Eine Pad-/Via-Vorlagenbibliothek kann aus den Pads und Vias einer geöffneten Leiterplatte im Modus „Pad & Via Templates“ des PCB-Panels erstellt werden. Wählen Sie mit den üblichen Windows-Auswahlmethoden die Pad-/Via-Vorlagen aus, die in der Bibliothek gespeichert werden sollen, und klicken Sie dann auf die Schaltfläche Save as Library. Die neue PvLib wird zur Bearbeitung geöffnet, ist jedoch noch nicht auf der Festplatte gespeichert. Speichern Sie die Datei unter einem passenden Namen an einem geeigneten Speicherort. Wenn die Pad-/Via-Vorlagenbibliothek zum ersten Mal im Vorlageneditor geöffnet wird, wird im Panel Pad Via Library möglicherweise nur eine Pad-Vorlage angezeigt (die Standardvorlage). Speichern und schließen Sie in diesem Fall die Datei und öffnen Sie sie erneut, um die Vorlagenliste im Panel Pad Via Library zu aktualisieren.

Eine Pad-/Via-Vorlagenbibliothek kann aus den ausgewählten Pads/Vias der aktuellen Leiterplatte erstellt werden.
Panel „Pad Via Library“
Das Panel Pad Via Library bietet Zugriff auf die Vorlagen in der aktiven Pad-/Via-Bibliothek. Das im Pad-/Via-Vorlageneditor verfügbare Panel Pad Via Library listet die Pad- und Via-Vorlagen auf, die in der aktuellen Pad-/Via-Vorlagenbibliothek enthalten sind. Die bevorzugten Einheiten für diese Bearbeitungssitzung werden über das Dropdown-Menü Display Units oben im Panel ausgewählt.
Zugriff auf das Panel
Das Panel kann im Pad-/Via-Vorlageneditor (wenn ein *.PvLib-Dokument als aktives Dokument im Designbereich geöffnet ist) auf folgende Weise aufgerufen werden:
- Klicken Sie auf die Schaltfläche Panels unten rechts im Designbereich und wählen Sie anschließend Pad Via Library.
- Wählen Sie View » Panels » Pad Via Library in den Hauptmenüs.
Erstellen einer Pad- oder Via-Vorlage
Um eine neue Pad- oder Via-Vorlage zu erstellen, klicken Sie mit der rechten Maustaste in das Panel und wählen Sie im Kontextmenü Add Pad template oder Add Via template aus. Verwenden Sie Delete, um eine Vorlage aus der Bibliothek zu entfernen.

Das Panel bietet Zugriff auf die Vorlagen in der aktuellen Pad-/Via-Bibliothek. Klicken Sie mit der rechten Maustaste, um eine neue Vorlage hinzuzufügen.
Pad-/Via-Vorlageneditor
Mit dem Pad Template Editor werden die grundlegenden Konfigurationsoptionen einer Pad- oder Via-Vorlage festgelegt, die anschließend auf ein Pad oder Via in einem PCB- oder PCB-Footprint-Dokument angewendet werden kann. Dazu gehören die Haupteigenschaften einer Pad-/Via-Konfiguration. Dokumentspezifische Eigenschaften (wie Position, Ausrichtung, Lage usw.) werden hingegen beim Platzieren des Pads oder Vias in einem Designdokument festgelegt.

Mit dem Vorlageneditor wird die aktuell im Panel Pad Via Library ausgewählte Pad- oder Via-Vorlage konfiguriert.
Die meisten Pad-/Via-Konfigurationsoptionen sind die üblichen und vertrauten Altium Designer-Einstellungen für Pads und Vias (Größe, Bohrung, Maske usw.). Der Pad-Vorlageneditor und der Via-Vorlageneditor haben eine einheitliche Benutzeroberfläche und viele gemeinsame Optionen. Im Folgenden werden die einzelnen Bereiche des Vorlageneditors beschrieben. Optionen, die nur für Pads oder Vias gelten, sind entsprechend gekennzeichnet.
Allgemein
-
Name – standardmäßig wird ein automatischer Name auf Grundlage der Pad-/Via-Attribute gemäß IPC-7251/7351 Padstack naming conventions vergeben (hier beschrieben). Bei Bedarf kann ein manueller Name festgelegt und durch Klicken auf die Schaltfläche
wieder entfernt werden. Wenn eine manuell benannte Vorlage in einem Leiterplattendesign verwendet wurde und anschließend ihre Verknüpfung mit der Vorlagenbibliothek aufgehoben wird (sodass ihre Eigenschaften bearbeitbar werden), wird der manuelle Name durch den automatischen Namen ersetzt.
- Description – optionale Beschreibung.
- Pad Type (nur Pads) – Oberflächenmontage oder Durchsteckmontage.
Bohrungsinformationen
- Hole Size – im Namen durch h<Value> gekennzeichnet; Durchmesser der Bohrung.
- Tolerance – im Namen durch Tol gekennzeichnet; geben Sie bei Bedarf die Plus- und Minustoleranzen der Bohrung ein. Geben Sie N/A ein, falls nicht zutreffend.
- Hole Type (nur Pads) – Rund, quadratisch oder Langloch.
- Length (nur Pads) – durch _<Value> gekennzeichnet, das im Namen an die Bohrungsgröße angehängt wird; Länge der quadratischen Bohrung oder des Langlochs.
- Rotation (nur Pads) – Drehwinkel der quadratischen Bohrung oder des Langlochs.
- Plated (nur Pads) – durchkontaktiert oder nicht durchkontaktiert (nicht durchkontaktiert wird im Namen durch n gekennzeichnet).
Pastenmaske (nur Pads)
- Manual Expansion – aktivieren Sie das Kontrollkästchen, um einen manuellen Erweiterungswert festzulegen, der den Wert einer Designregel überschreibt, wenn das Pad in einem PCB-Design platziert wird. Dieser Wert wird im Namen der Pad-Vorlage durch p<Value> gekennzeichnet.
- Expansion – Betrag, um den die Öffnung in der Pastenmaske erweitert (positiver Wert) oder verkleinert (negativer Wert) wird. Er kann entweder als absoluter Wert (mil/mm) oder als Prozentsatz der Pad-Fläche definiert werden. Wenn ein absoluter Wert definiert ist, wird rechts neben dem Feld der Prozentsatz angezeigt und umgekehrt. Deaktivieren Sie das Kontrollkästchen Use Paste links neben dem Feld, um die Verwendung der Pastenmaske für die Pad-Vorlage zu deaktivieren.
Lötstoppmaske
- Manual Expansion – im Namen durch m<Value> gekennzeichnet, wobei m<Value> die Gesamtgröße der Öffnung in der Lötstoppmaske angibt. Das Namenselement wird zu m<Value>mx<Value>, wenn die Erweiterungswerte für Ober- und Unterseite nicht verknüpft sind.
- Top/Bottom – Erweiterungsbetrag, gemessen vom Rand des Pads/Vias, sofern die Option Solder mask from the hole edge nicht aktiviert ist.
-
– die Werte für Ober- und Unterseite sind verknüpft (identisch). Klicken Sie hier, um unterschiedliche Werte für Ober- und Unterseite festzulegen.
- Tented – aktivieren Sie diese Option, um die Öffnung in der Lötstoppmaske zu schließen (die Öffnungsgröße wird auf null gesetzt).
- Solder mask from the hole edge – aktivieren Sie diese Option, um den Erweiterungswert auf den Rand der Bohrung statt auf den Rand des Pads/Vias zu beziehen.
Via-Typen & Merkmale (nur Vias)
- IPC 4761 Via Type – wählen Sie über die Dropdown-Liste einen Via-Typ gemäß der Norm IPC 4761 aus, Design Guide for Protection of Printed Board Via Structures.
-
Grid – wird angezeigt, wenn in der Dropdown-Liste IPC 4761 Via Type ein anderer Via-Typ als
Noneausgewählt ist. Wählen Sie die Leiterplatten-Side aus und geben Sie einen Wert für Material für die Merkmale ein, die entsprechend dem ausgewählten Via-Typ verfügbar sind.
Größe und Form
- Offset From Hole Center (X/Y) (nur Pads) – im Namen durch o<Xvalue>_<Yvalue> gekennzeichnet; Betrag, um den die Pad-Bohrung gegenüber der Pad-Mitte versetzt ist.
-
Mode – Typ des Pad-/Via-Stacks. Verfügbare Optionen sind
Simple,Top-Middle-BottomoderFull Stack(bei Pads ist diese Option nur verfügbar, wenn Pad Type auf Durchgangsbohrung eingestellt ist). Ermöglicht unterschiedliche Größen- und Formeigenschaften von Pads/Vias auf den für diesen Modus verfügbaren Lagen. Das Namenselement x<Xvalue_Yvalue> wird hinzugefügt, wenn für die untere Lage eine andere Größe/Form definiert ist. Das Namenselement z<Xvalue_Yvalue> wird hinzugefügt, wenn für die Innenlagen eine andere Größe/Form definiert ist. -
Attributes on Layer – Standardattribute für Pads/Vias.
-
Shape (nur Pads) – gekennzeichnet durch c<SizeValue> (kreisförmig); s<SizeValue> (quadratisch) oder r<xSizeValue_ySizeValue> (rechteckig), je nachdem, ob die X-/Y-Abmessungen gleich oder unterschiedlich sind; s<SizeValue>c<Value> (achteckig); s<Sizevalue>r<Radius%Value> oder r<xSizeValue_ySizeValue>r<Radius%Value> (abgerundetes Rechteck).
-
X & Y Size (nur Pads) – Abmessungen des Pads in der X- & Y-Ebene.
-
Corner Radius (nur Pads) – absoluter Wert des Eckenradius des Pads. Der Wert muss kleiner oder gleich der Hälfte der kürzesten Pad-Seite sein. Geben Sie einen Wert gefolgt vom Symbol
%ein, um den Radius als Prozentsatz der Hälfte der kürzesten Pad-Seite zu definieren, wobei100%die kürzeste Pad-Seite vollständig abrundet. Diese Option ist nur verfügbar, wenn Rounded Rectangle für die Pad-Shape ausgewählt ist. -
Diameter (nur Vias) – Durchmesser des Vias (Vias können nur kreisförmig sein).
-
-
Thermal Relief – Einstellungen für die Wärmefallenanbindung dieses Pads an ein umgebendes Polygon desselben Netzes. Deaktivieren Sie das Kontrollkästchen From Rule, um diese lokalen Einstellungen zu bearbeiten und zu verwenden.
- From Rule – lokale Einstellungen werden nicht angewendet, wenn diese Option aktiviert ist. Deaktivieren Sie sie, um lokale Einstellungen festzulegen und zu verwenden.
- Connect Style – Art der Wärmefallenanbindung.
- Air Gap – Abstand vom Pad-Rand zum umgebenden Polygon.
- Conductors – Anzahl der Verbindungsstege zwischen Pad und umgebendem Polygon.
- Width – Breite der Verbindungsstege zwischen Pad und umgebendem Polygon.
- Angle – Winkelanordnung der Wärmefallenstege.
- Layer – Lagen in diesem Pad-/Via-Stack. Die verfügbaren Lagen hängen von der aktuellen Einstellung für Mode ab. Klicken Sie mit der rechten Maustaste, um Lagen hinzuzufügen, zu entfernen oder zurückzusetzen, wenn Mode auf „Full Stack“ eingestellt ist.


