Verwalten von Designänderungen zwischen Schaltplan und PCB

Auf einen Blick

Dieser Artikel zeigt Ihnen, wie Altium Designer Designvorgaben und die Synchronisierung zwischen Schaltplan und Leiterplatte verwaltet – von der Verwendung des Constraint Managers über das Festlegen von Projektoptionen und das Generieren von ECOs bis hin zu Cross-Probing und Cross-Selecting, mit denen Sie Änderungen überprüfen und gezielt nachvollziehen können. Er erläutert, wo Vorgaben definiert werden, wie diese Einstellungen gespeichert und übertragen werden und wie Sie steuern, welche Daten beim Übertragen vom Schaltplan auf die Leiterplatte verglichen und aktualisiert werden. Wenn Sie sich einen klareren, zuverlässigeren Arbeitsablauf wünschen, um Ihre Designdaten bei Änderungen konsistent zu halten, führt Sie dieser Leitfaden Schritt für Schritt durch den Prozess. Lesen Sie weiter.

- Erfahren Sie, wie Sie feststellen, ob Ihr Projekt den Constraint Manager oder den PCB Rule and Constraints Editor verwendet, und wo Sie die jeweiligen Einstellungen finden.
- Verstehen Sie, wie Projektoptionen, Vergleichseinstellungen und die ECO-Generierung beeinflussen, welche Änderungen vom Schaltplan auf die Leiterplatte übertragen werden.
- Lernen Sie, wie Cross-Probing und Cross-Selecting Ihnen helfen, einander entsprechende Objekte in verschiedenen Editoren zu prüfen und bei Designänderungen effizienter zu arbeiten.
Mit KI tiefer einsteigen:

Designanforderungen mit dem Constraint Manager definieren

Designvorgaben bilden gemeinsam einen Anweisungssatz für das Leiterplattendesign. Sie decken jeden Aspekt des Designs ab: Abstände, Leiterbahnbreiten, Topologie usw. Zum Anzeigen, Erstellen und Verwalten der Designvorgaben für Ihre Leiterplattendesigns wird der Constraint Manager verwendet. Der Constraint Manager bietet eine einheitliche, tabellenbasierte Bearbeitungsoberfläche zum Definieren von Designvorgaben, die sowohl vom Schaltplan als auch von der Leiterplatte aus zugänglich ist. Dieser leistungsstarke und zugleich übersichtliche Ansatz erleichtert die Zusammenarbeit zwischen Ingenieuren mit unterschiedlichen Aufgaben innerhalb eines Unternehmens und ermöglicht es einem erweiterten Kreis von Beteiligten, die erforderlichen Vorgaben für ein Design gemeinsam festzulegen.

Do I have the Constraint Manager?

Altium Designer bietet zwei unterschiedliche Ansätze zum Definieren von Designvorgaben: den Constraint Manager und den Dialog PCB Rule and Constraints Editor.

Der Constraint Manager ist in einem Leiterplattendesignprojekt nur verfügbar, wenn die Option Constraint Management beim Erstellen dieses Projekts im Dialog Projekt erstellen aktiviert wurde. Beachten Sie Folgendes:

  • Wenn der Constraint Manager für das Leiterplattenprojekt aktiviert wurde, ist der Dialog PCB Rule and Constraints Editor im Leiterplatteneditor not verfügbar.

  • Wenn der Constraint Manager für das Leiterplattenprojekt not aktiviert wurde, können nur die bisherigen Ansätze zum Definieren von Designvorgaben (die Verwendung von Designanweisungen und des Dialogs PCB Rule and Constraints Editor) genutzt werden.

Um schnell zu prüfen, welcher Ansatz zum Definieren von Designvorgaben im aktuellen Leiterplattenprojekt verwendet wird, prüfen Sie, ob der Befehl Design » Constraint Manager in den Hauptmenüs des Schaltplan- oder Leiterplatteneditors verfügbar ist, wenn ein Schaltplan-/Leiterplattendokument des Projekts geöffnet ist. Ist der Befehl vorhanden, wird der Constraint Manager für dieses Projekt verwendet. Andernfalls wird der Dialog PCB Rule and Constraints Editor (Design » Rules im Leiterplatteneditor) für dieses Projekt verwendet.

Der Constraint Manager kann durch Auswahl des Befehls Design » Constraint Manager in den Hauptmenüs des Schaltplan- oder Leiterplatteneditors geöffnet werden. Der Constraint Manager verfügt über mehrere Ansichten zum Definieren verschiedener Vorgabentypen. Verwenden Sie die Schaltflächen oben im Constraint Manager, um zwischen den Ansichten zu wechseln:

  • Clearances – eine Abstandsmatrix, mit der sich elektrische Abstände zwischen Netzklassen definieren lassen.

  • Physical – eine Liste von Netzen, Differenzialpaaren, xNets und deren Klassen, in der Sie physikalische Vorgaben für das Design definieren können: Leiterbahnbreiten, den Abstand innerhalb von Differenzialpaaren usw.

  • Electrical – eine Liste von Netzen, xNets, xSignals und deren Klassen, in der Sie elektrische Vorgaben für das Design definieren können: Topologie, Impedanz usw.

Wenn der Constraint Manager vom Leiterplatteneditor aus geöffnet wird, ist eine zusätzliche Ansicht All Rules verfügbar. Dies ist eine regelorientierte Ansicht der Designvorgaben, die alle Regeln im Leiterplattendesign auflistet und in der Sie benutzerdefinierte Regeln auf Basis von Abfragen erstellen können.

Im Constraint Manager muss gespeichert werden, bevor Änderungen im Design wirksam werden. Verwenden Sie dazu den Befehl File » Save (wenn der Constraint Manager vom Schaltplan aus geöffnet wurde) oder File » Save to PCB (wenn der Constraint Manager von der Leiterplatte aus geöffnet wurde) in den Hauptmenüs des Constraint Manager oder die Tastenkombination Ctrl+S.

Vorgaben, die im Constraint Manager auf der Schaltplanseite definiert wurden, werden während des regulären ECO-Prozesses (Engineering Change Order) in das Leiterplattendesign übertragen, wie unten beschrieben.

Weitere Informationen finden Sie auf der Seite Designanforderungen mit dem Constraint Manager definieren.

Das Projekt für die Übertragung auf die Leiterplatte einrichten

Der Dialog Project Options enthält eine Reihe von Einstellungen, die steuern, welche Daten zwischen dem Schaltplandesign und dem Leiterplattenlayout übertragen werden. Klicken Sie im Panel Projects mit der rechten Maustaste auf den Projekteintrag und wählen Sie den Befehl Project Options im Kontextmenü, um den Dialog zu öffnen.

Verwenden Sie die folgenden Registerkarten des Dialogs, um festzulegen, was bei der Übertragung des Designs synchronisiert werden soll:

Javascript ID: Dlg_ProjectOptions

Class Generation – ermöglicht Ihnen, die Erstellung von Bauteil- und Netzklassen zu konfigurieren und zu steuern. Beispielsweise können Bauteile, die auf bestimmten Schaltplanblättern platziert sind, zu Bauteilklassen zusammengefasst werden, oder Netze, die in Bussen gebündelt sind, können zu Netzklassen zusammengefasst werden. Auf dieser Registerkarte lässt sich außerdem die Erstellung benutzerdefinierter Klassen konfigurieren, die aus platzierten Designanweisungen abgeleitet werden. Weitere Informationen finden Sie unter Mit Klassen im Schaltplan und auf der Leiterplatte arbeiten.

Comparator – ermöglicht Ihnen festzulegen, welche Arten von Unterschieden beim Vergleich von Dokumenten erkannt und welche ignoriert werden sollen, also welche Schaltplan- und Leiterplattendaten genau verglichen werden. Verwenden Sie die Spalte Mode für einen Vergleichstyp, um den Vergleichsmodus auszuwählen, beispielsweise Find Differences oder Ignore Differences.

ECO Generation – ermöglicht Ihnen festzulegen, für welche Designänderungen (basierend auf den vom Vergleich erkannten Unterschieden) bei der Datenübertragung Engineering Change Orders (ECOs) erstellt werden können. Verwenden Sie die Spalte Mode für einen Änderungstyp, um den Erstellungsmodus auszuwählen, beispielsweise Generate Change Orders oder Ignore Differences.

Weitere Informationen finden Sie auf der Seite Projektoptionen aufrufen, definieren und verwalten.

Designinformationen auf die Leiterplatte übertragen

Die Designsynchronisierung erfolgt direkt zwischen dem Schaltplan- und dem Leiterplatteneditor. Wenn Sie Ihrem Projekt ein Leiterplattendokument hinzugefügt und auf der Festplatte gespeichert haben, wählen Sie den Befehl Design » Update PCB Document <PCBDocumentName> in den Hauptmenüs des Schaltplaneditors, um den Dialog Engineering Change Order zu öffnen. Der Dialog enthält die Liste der Änderungen (Engineering Change Order – ECO), die an der Leiterplatte vorgenommen werden müssen, damit sie gemäß den aktuellen Projektoptionen mit dem Schaltplan übereinstimmt.

  • Sie können Änderungseinträge im Dialog nach Bedarf aktivieren oder deaktivieren.

  • Klicken Sie auf die Schaltfläche Validate Changes, um die Änderungen zu validieren, die für die Aufnahme in den ECO aktiviert sind. Die Validierungsergebnisse werden in der Spalte Check  im Bereich Status  des Dialogs angezeigt.

    Wenn Änderungseinträge die Validierung nicht bestehen, erscheint in der entsprechenden Spalte Message des Dialogs ein Eintrag mit einem Hinweis auf die Ursache (z. B. Footprint Not Found). Sie können den Dialog jederzeit schließen, um zu untersuchen, warum bestimmte Änderungen fehlschlagen, und bei Bedarf entsprechende Designänderungen vornehmen.
  • Wenn Sie mit den vorgesehenen Änderungen zufrieden sind, klicken Sie auf die Schaltfläche Execute Changes, um den ECO auszuführen und die darin enthaltenen gültigen Änderungen anzuwenden. Die Ausführungsergebnisse werden in der Spalte Done  im Bereich Status des Dialogs angezeigt.

Nachdem Sie auf die Schaltfläche Execute Changes geklickt haben, werden die Änderungen auf das PCB-Dokument angewendet, und der Dialog Engineering Change Order kann geschlossen werden. Bei einer neu erstellten Leiterplatte sehen Sie die außerhalb der Leiterplatte platzierten Bauteil-Footprints sowie Verbindungslinien zwischen den Pads der Footprints entsprechend dem Schaltplanentwurf.

Nach der ersten Übertragung des Entwurfs auf die Leiterplatte werden weitere Änderungen am Schaltplan mit demselben Verfahren auf die Leiterplatte übertragen.

Weitere Informationen finden Sie auf der Seite Schaltpläne & Leiterplatte synchron halten.

Cross-Probing

Mit Cross-Probing können Sie ein Objekt in anderen Editoren lokalisieren, indem Sie im aktuellen Editor auf das Objekt klicken. Wenn Sie beispielsweise den Befehl Tools » Cross Probe im Schaltplaneditor aufgerufen haben, können Sie auf ein Bauteil im Schaltplan klicken, um dasselbe Bauteil auf der Leiterplatte anzuzeigen. Dieser Befehl unterstützt Cross-Probing zwischen Bauteilen, Bussen, Netzen und Pins/Pads.

Standardmäßig bleiben Sie im Quelleditor. Verwenden Sie dieses Verhalten, wenn sowohl das Quell- als auch das Zieldokument sichtbar sind, z. B. wenn der Arbeitsbereich geteilt ist, um zwei Dokumente anzuzeigen, wie im Video oben demonstriert. Weitere Informationen finden Sie unter Verwaltung von Dokumentfenstern.

Wenn nur ein Dokument sichtbar ist, halten Sie Ctrl gedrückt, während Sie auf ein Objekt klicken, um es per Cross-Probing im Zieldokument zu lokalisieren und dieses Dokument zu aktivieren.

Dokumentübergreifende Auswahl

Mit der dokumentübergreifenden Auswahl können Sie einander entsprechende Objekte in PCB- und Schaltplandokumenten auswählen. Wenn Sie also ein Objekt im PCB-Dokument auswählen, wird dasselbe Objekt auch im Quellschaltplandokument ausgewählt und umgekehrt.

Um die dokumentübergreifende Auswahl zu aktivieren, wählen Sie den Befehl Tools » Cross Select Mode im Hauptmenü des Schaltplan- oder PCB-Editors. Dieser Befehl schaltet die Funktion ein und aus. Das Befehlssymbol im Menü zeigt den Status des Befehls an.

Diese Funktion kann besonders nützlich sein, um im PCB-Dokument schnell eine neue Bauteilklasse zu erstellen, indem Sie eine Gruppe von Bauteilen in den Schaltplänen auswählen, oder um mehrere PCB-Bauteile nacheinander in der Reihenfolge neu zu positionieren, in der Sie sie in den Schaltplänen ausgewählt haben.
Weitere Informationen finden Sie auf der Seite Cross-Probing & dokumentübergreifende Auswahl.
AI-LocalizedKI-lokalisiert
Wenn Sie ein Problem feststellen, wählen Sie den Text/das Bild aus und drücken SieCtrl + Enter, um uns Ihr Feedback zu senden.
Contents
Funktionsverfügbarkeit

Die Ihnen zur Verfügung stehenden Funktionen hängen davon ab, über welche Altium-Lösung Sie verfügen – Altium Develop, Altium Agile Teams, Altium Agile Enterprise oder Altium Designer (mit aktivem Laufzeitvertrag).

Wenn Sie eine dokumentierte Funktion in Ihrer tatsächlich verwendeten Software nicht sehen, wenden Sie sich an den Altium-Vertrieb, um mehr zu erfahren.

Legacy-Dokumentation

Die Dokumentation von Altium Designer wird nicht mehr versioniert. Wenn Sie auf Dokumentation für ältere Versionen von Altium Designer zugreifen müssen, besuchen Sie den Abschnitt Legacy-Dokumentation auf der Seite Andere Installer.

Contents